Tạo PCB Footprint

Diện tích mà linh kiện chiếm trên bo mạch sau khi chế tạo được xác định bởi footprint của linh kiện. Một footprint điển hình bao gồm các pad và lớp in ký hiệu linh kiện, đồng thời có thể bao gồm các chi tiết cơ khí cần thiết khác. Trong ví dụ footprint bên dưới, phần lớn đường bao của linh kiện được xác định trên một lớp cơ khí (các đường màu xanh lá) thay vì lớp in ký hiệu (màu vàng), vì linh kiện này sẽ được lắp sao cho nhô ra trên một phần khoét của bo mạch.

Footprint xác định không gian mà linh kiện chiếm và cung cấp các điểm kết nối từ chân/pad của linh kiện đến các đường mạch trên bo mạch. 
Footprint xác định không gian mà linh kiện chiếm và cung cấp các điểm kết nối từ chân/pad của linh kiện đến các đường mạch trên bo mạch.

Linh kiện được lắp trên footprint đó có thể được mô hình hóa bằng các đối tượng 3D Body. Đối tượng 3D Body được dùng làm vùng chứa để nhập mô hình ở định dạng MCAD thông dụng, như minh họa trong hình bên dưới.

Có thể nhập một mô hình MCAD phù hợp vào đối tượng 3D Body.
Có thể nhập một mô hình MCAD phù hợp vào đối tượng 3D Body.

Ngay cả khi có nhiều nguồn tài nguyên cung cấp các linh kiện PCB dựng sẵn (chẳng hạn như bảng Manufacturer Part Search), rất có thể đến một thời điểm nào đó trong công việc, bạn sẽ cần tạo một linh kiện PCB tùy chỉnh. Footprint của linh kiện PCB được tạo trong trình biên tập PCB Footprint bằng cùng tập hợp các đối tượng cơ bản có trong trình biên tập PCB. Ngoài footprint, logo công ty, các định nghĩa phục vụ chế tạo và những đối tượng khác cần thiết trong quá trình thiết kế bo mạch cũng có thể được lưu dưới dạng linh kiện PCB.

Tạo footprint PCB mới

Có thể tạo footprint trực tiếp trong Workspace mà bạn đang kết nối. Để thực hiện:

  1. Chọn File » New » Library từ các menu chính, sau đó trong hộp thoại New Library vừa mở, chọn Create Library Content » Footprint từ vùng Workspace của hộp thoại.

    Tạo footprint Workspace mới bằng hộp thoại New Library
    Tạo footprint Workspace mới bằng hộp thoại New Library

  2. Trong hộp thoại Create New Item vừa mở, nhập thông tin cần thiết, bảo đảm tùy chọn Open for editing after creation được bật rồi nhấp vào OK. Footprint Workspace sẽ được tạo và trình biên tập PCB Footprint tạm thời sẽ mở, với tài liệu .PcbLib được hiển thị làm tài liệu hiện hành. Tài liệu này sẽ được đặt tên theo Item-Revision, theo định dạng: <Item><Revision>.PcbLib (ví dụ: PCC-001-0001-1.PcbLib). Dùng tài liệu này để định nghĩa footprint như mô tả bên dưới.

    Ví dụ về chỉnh sửa phiên bản đầu tiên của footprint Workspace – trình biên tập footprint PCB tạm thời cung cấp tài liệu để bạn định nghĩa footprint của mình.
    Ví dụ về chỉnh sửa phiên bản đầu tiên của footprint Workspace – trình biên tập footprint PCB tạm thời cung cấp tài liệu để bạn định nghĩa footprint của mình.

  3. Khi footprint đã được định nghĩa theo yêu cầu, hãy lưu vào Workspace bằng nút điều khiển Save to Server ở bên phải mục footprint trong bảng Projects. Hộp thoại Edit Revision sẽ xuất hiện, cho phép bạn thay đổi Tên, Mô tả và thêm ghi chú phát hành theo nhu cầu. Tài liệu và trình biên tập sẽ đóng sau khi lưu.

Có thể sử dụng footprint Workspace đã lưu khi định nghĩa linh kiện bằng Component Editor ở chế độ chỉnh sửa một linh kiện hoặc chế độ chỉnh sửa linh kiện hàng loạt.

Có thể duyệt các footprint Workspace bằng bảng Components. Bật hiển thị mô hình bằng cách nhấp vào nút  ở đầu bảng và chọn Models, sau đó chọn danh mục Footprints.

Để chỉnh sửa footprint Workspace, nhấp chuột phải vào mục tương ứng trong bảng Components và chọn lệnh Edit. Trình biên tập tạm thời sẽ lại mở, với footprint sẵn sàng để chỉnh sửa. Thực hiện các thay đổi cần thiết, sau đó lưu tài liệu thành phiên bản tiếp theo của footprint Workspace.

 
 
 
 
 

Khi lưu một footprint đã chỉnh sửa vào Workspace, bạn có thể giữ nguyên trạng thái vòng đời hiện tại của footprint. Bạn có thể kiểm soát việc này bằng tùy chọn Preserve lifecycle state (not recommended) có trong hộp thoại Create Revision khi lưu lại (). Khi tùy chọn này được bật, phiên bản footprint mới sẽ tự động được đặt về trạng thái vòng đời của phiên bản trước. Khả năng này dành cho những người được cấp quyền thao tác Allow to skip lifecycle state change for new revisions (tìm hiểu thêm về Thiết lập quyền thao tác toàn cục cho Workspace).

  • Khi bạn thay đổi một footprint Workspace, ngay khi bạn lưu thay đổi đó thành một phiên bản footprint mới, mọi linh kiện Workspace sử dụng footprint đó sẽ trở nên lỗi thời vì vẫn dùng phiên bản trước. Trong hầu hết các trường hợp, bạn sẽ muốn lưu lại các linh kiện Workspace đó, đồng thời cập nhật các liên kết mô hình tương ứng để sử dụng phiên bản mới nhất hiện có. Để đơn giản hóa quy trình này, Workspace kết hợp với Altium Designer hỗ trợ cập nhật các linh kiện cha ngay tại thời điểm lưu lại footprint Workspace, sau khi bạn đã thực hiện các thay đổi đối với footprint đó thông qua tính năng chỉnh sửa trực tiếp.

    Để biết thêm thông tin về cách cập nhật các linh kiện cha khi lưu mô hình miền thiết kế, hãy tham khảo trang Tạo & chỉnh sửa nội dung.

  • Bạn cũng có thể cập nhật ngay footprint Workspace mà một linh kiện Workspace đang sử dụng trong quá trình chỉnh sửa linh kiện Workspace đó bằng Component Editor ở chế độ chỉnh sửa một linh kiện hoặc chế độ chỉnh sửa linh kiện hàng loạt.

  • Từ góc nhìn của người thiết kế, một linh kiện Workspace tập hợp trong một thực thể duy nhất tất cả thông tin cần thiết để biểu diễn linh kiện đó trên mọi miền thiết kế. Vì vậy, có thể xem nó như một vùng chứa – một “kho” lưu trữ tất cả mô hình miền thiết kế và thông tin tham số. Về cách biểu diễn trong các miền khác nhau, linh kiện Workspace không chứa chính các mô hình miền thiết kế của Workspace mà chứa các liên kết đến những mô hình này. Các liên kết này được chỉ định khi định nghĩa linh kiện.

  • Footprint PCB cũng có thể được tạo trong Workspace khi nhập các thư viện linh kiện hiện có thuộc thế hệ cũ (SchLib, PcbLib, IntLib, DbLib, SVNDbLib). Giao diện thực hiện quy trình này – Library Importer – cung cấp một quy trình trực quan, bắt đầu từ các thư viện được chọn và nhập chúng vào Workspace của bạn. Tìm hiểu thêm về Library Importer.

  • Cũng có thể tạo footprint Workspace mới khi định nghĩa một linh kiện Workspace trong Component Editor ở chế độ chỉnh sửa một linh kiện.

  • Footprint cũng có thể được tạo trong một thư viện footprint PCB dạng tệp.

Định nghĩa footprint PCB

Footprint luôn được tạo ở mặt trên, bất kể cuối cùng được đặt ở mặt nào của bo mạch, bằng cùng bộ công cụ và đối tượng thiết kế có sẵn trong trình biên tập PCB. Các thuộc tính riêng của từng lớp, chẳng hạn như pad gắn bề mặt và định nghĩa lớp phủ chống hàn, sẽ tự động được chuyển sang các lớp tương ứng ở mặt dưới khi bạn lật footprint sang mặt còn lại của bo mạch trong quá trình đặt linh kiện.

Các đối tượng thiết kế có thể được đặt trên bất kỳ lớp nào; tuy nhiên, đường bao thường được tạo trên lớp Top Overlay (in lụa), còn các pad được đặt trên lớp multi-layer (đối với chân linh kiện xuyên lỗ) hoặc lớp tín hiệu trên cùng (đối với chân linh kiện gắn bề mặt). Khi bạn đặt footprint lên PCB, tất cả đối tượng cấu thành footprint sẽ được gán vào các lớp đã định nghĩa cho chúng.

Hình chiếu 2D và 3D của footprint cho một linh kiện cần điều khiển. Hình ảnh 3D cho thấy mô hình STEP đã nhập của linh kiện. Lưu ý rằng có thể nhìn thấy các pad và hình in lụa của linh kiện bên dưới mô hình STEP.
Hình chiếu 2D và 3D của footprint cho một linh kiện cần điều khiển. Hình ảnh 3D cho thấy mô hình STEP đã nhập của linh kiện. Lưu ý rằng có thể nhìn thấy các pad và hình in lụa của linh kiện bên dưới mô hình STEP.

Các footprint được trình bày trên trang này chỉ nhằm minh họa các quy trình cần thực hiện; kích thước của chúng không chính xác. Luôn đối chiếu thông số của footprint mới với bảng dữ liệu của nhà sản xuất.

Trình tự thông thường để tạo thủ công một footprint linh kiện như sau:

  1. Chuẩn bị không gian thiết kế: xác định các tùy chọn bắt dính, cấu hình lưới và đường dẫn hướng - tìm hiểu thêm.

  2. Nên tạo footprint quanh điểm tham chiếu của không gian thiết kế ở tâm trình biên tập footprint PCB. Điểm tham chiếu này thực chất là gốc tọa độ tương đối của không gian thiết kế và là điểm mà con trỏ dùng để giữ footprint linh kiện trong các thao tác Đặt và Di chuyển (tùy thuộc vào Object Snap Options hiện tại trên trang PCB Editor – General của hộp thoại Preferences). Sử dụng các phím tắt J, R để chuyển trực tiếp đến điểm tham chiếu. Nếu quên chuyển đến điểm tham chiếu trước khi bắt đầu tạo footprint, bạn có thể đưa pad tham chiếu đến footprint bằng các lệnh trong menu con Edit » Set Reference:
    • Pin 1 - đặt điểm tham chiếu của linh kiện tại chân 1 của footprint linh kiện.

    • Center - đặt điểm tham chiếu của linh kiện tại tâm footprint linh kiện.

    • Location - đặt điểm tham chiếu của linh kiện tại vị trí do người dùng xác định.

    Điểm đã chọn sẽ được đặt thành 0,0 - điểm này trở thành gốc tọa độ tương đối mới và vị trí của tất cả đối tượng cơ bản sẽ được cập nhật theo điểm này.

  3. Đặt các pad (Place » Pad) theo yêu cầu của linh kiện. Sau khi chạy lệnh Place Pad nhưng trước khi đặt pad đầu tiên, nhấn phím Tab để mở bảng Properties nhằm xác định tất cả thuộc tính của pad, bao gồm Designator, Size and Shape, Layer và Hole Size của pad (đối với pad xuyên lỗ). Designator tự động tăng khi đặt các pad tiếp theo. Đối với pad gắn bề mặt, đặt Layer thành Top Layer. Đối với pad xuyên lỗ, đặt Layer thành Multi-Layer.

    Một số footprint yêu cầu pad có hình dạng không đều. Bạn có thể thực hiện điều này bằng các đối tượng pad có Hình dạng tùy chỉnh. Để tìm hiểu thêm, hãy tham khảo trang Tùy chỉnh cấu trúc pad.
    • Một trong những bước quan trọng nhất khi tạo footprint linh kiện mới là đặt các pad dùng để hàn linh kiện vào PCB. Các pad này phải được đặt ở vị trí chính xác để khớp với các chân trên linh kiện thực tế.
    • Cũng cần cẩn thận khi gán định danh cho pad, vì đây là thuộc tính mà Altium Designer sử dụng khi ánh xạ từ số chân trên ký hiệu sơ đồ nguyên lý.
  4. Để bảo đảm đặt pad chính xác, hãy cân nhắc thiết lập một lưới riêng cho công việc này. Sử dụng các phím tắt Ctrl+G để mở hộp thoại Cartesian Grid Editor và phím Q để chuyển lưới từ hệ Anh sang hệ mét.

  5. Để đặt pad chính xác khi di chuyển bằng chuột, hãy dùng các phím mũi tên trên bàn phím để di chuyển con trỏ theo từng bước lưới hiện tại. Ngoài ra, giữ Shift sẽ di chuyển theo bước bằng 10 lần bước lưới. Vị trí X, Y hiện tại được hiển thị trên thanh Trạng thái và cả trong phần hiển thị Heads Up. Phần hiển thị Heads Up chứa cả vị trí và độ lệch từ vị trí nhấp chuột gần nhất đến vị trí con trỏ hiện tại. Sử dụng phím tắt Shift+H để bật hoặc tắt phần hiển thị Heads Up. Ngoài ra, bạn có thể nhấp đúp để chỉnh sửa pad đã đặt và nhập tọa độ X và Y cần thiết trong bảng Properties .

  6. Để kiểm tra khoảng cách giữa hai điểm trong không gian thiết kế, sử dụng Reports » Measure Distance (phím tắt Ctrl+M). Làm theo hướng dẫn trên thanh Trạng thái.

  7. Các thuộc tính riêng của pad, chẳng hạn như lớp phủ chống hàn và lớp mặt nạ kem hàn, được tính toán tự động dựa trên kích thước pad và các quy tắc thiết kế mặt nạ áp dụng. Mặc dù có thể xác định thủ công các thiết lập mặt nạ cho từng pad, việc này sẽ gây khó khăn khi cần sửa đổi các thiết lập đó sau này trong quá trình thiết kế bo mạch. Thông thường, chỉ thực hiện việc này khi không thể áp dụng quy tắc thiết kế cho các pad đó. Lưu ý rằng các quy tắc được xác định trong trình biên tập PCB trong quá trình thiết kế bo mạch.

  8. Sử dụng các đoạn mạch, cung tròn và đối tượng cơ bản khác để xác định đường bao linh kiện xuất hiện trên phần in lụa của PCB ở lớp Top Overlay. Nếu linh kiện được lật xuống mặt dưới bo mạch trong quá trình đặt, hình in lụa sẽ tự động được chuyển sang lớp Bottom Overlay.

  9. Đặt các đoạn mạch và đối tượng cơ bản khác trên một lớp cơ khí để xác định các chi tiết cơ khí bổ sung, chẳng hạn như vùng bao dành cho việc đặt linh kiện. Các lớp cơ khí là các lớp dùng cho mục đích chung. Bạn nên quy định chức năng của các lớp này và sử dụng nhất quán trên các footprint.

  10. Đặt các đối tượng 3D Body để xác định hình dạng ba chiều của linh kiện thực tế sẽ được gắn lên PCB.

    Đối tượng 3D Body được thêm vào footprint có thể tham chiếu đến một mô hình 3D được tải lên Workspace đã kết nối.
  11. Các chuỗi Designator và Comment được tự động thêm vào lớp Overlay của footprint khi đặt vào không gian thiết kế PCB. Có thể bổ sung các chuỗi Designator và Comment bằng cách đặt các chuỗi đặc biệt .Designator và .Comment trên một lớp cơ khí.

    Khi đặt các chuỗi Designator và Comment, cần xác định một Cặp lớp trong trình biên tập PCB. Điều này bảo đảm các chuỗi được gắn với mặt bo mạch mà linh kiện được lắp lên và phải chuyển sang mặt còn lại của bo mạch khi linh kiện được lật. Để biết thêm thông tin, hãy xem phần Xử lý các yêu cầu đặc biệt theo lớp bên dưới.
  12. Xác định các thuộc tính của footprint (ví dụ: tên và mô tả) trên thẻ Footprint của bảng Properties ở chế độ Library Options (hoạt động khi không có đối tượng nào được chọn trong không gian thiết kế, có thể truy cập bằng Tools » Footprint Properties từ các menu chính). Tham khảo phần bên dưới để tìm hiểu thêm về các tùy chọn và điều khiển có trong tab Footprint của bảng.

  • Để chuẩn hóa định nghĩa pad/via trên tất cả các footprint, có thể sử dụng thư viện Pad/Via (*.PvLib) để đặt Pad/Via – tìm hiểu thêm.
  • Trình chỉnh sửa PCB Footprint cũng cung cấp một số trình hướng dẫn để đẩy nhanh quá trình tạo footprint:
    • IPC Compliant Footprint Wizard – tạo footprint PCB tuân thủ hoàn toàn phiên bản B của tiêu chuẩn IPC 7351 – Generic Requirements for Surface Mount Design and Land Pattern Standard – tìm hiểu thêm.
    • IPC Compliant Footprints Batch Generator – khi làm việc với thư viện footprint PCB dạng tệp, hãy sử dụng IPC Compliant Footprints Batch Generator để nhanh chóng tạo nhiều footprint ở nhiều mức mật độ khác nhau – tìm hiểu thêm.
    • Footprint Wizard – cho phép bạn chọn từ nhiều kiểu vỏ linh kiện và điền thông tin phù hợp, sau đó sẽ tạo footprint linh kiện cho bạn – tìm hiểu thêm.

Chuẩn bị không gian thiết kế

Theo mặc định, lưới được hiển thị bằng các dấu chấm. Nếu muốn, bạn có thể hiển thị lưới bằng các đường kẻ. Thiết lập này được cấu hình trong hộp thoại Grid Editor, truy cập bằng cách nhấp vào nút Properties trong bảng Properties như minh họa bên dưới. Ngoài ra, nhấn phím tắt Ctrl+G để mở hộp thoại.

Trong hình, lưới mịn được hiển thị bằng các dấu chấm, còn lưới thô được hiển thị bằng các đường kẻ.
Trong hình, lưới mịn được hiển thị bằng các dấu chấm, còn lưới thô được hiển thị bằng các đường kẻ.

Bảng thuộc tính

Khi chỉnh sửa footprint trong trình chỉnh sửa footprint PCB và không có đối tượng thiết kế nào đang được chọn trong không gian thiết kế, bảng Properties sẽ hiển thị Library Options.

Các phần có thể thu gọn sau đây chứa thông tin về các tùy chọn và điều khiển có trong tab General của bảng:

Các phần có thể thu gọn sau đây chứa thông tin về các tùy chọn và điều khiển có trên tab Footprint của bảng:

Khả năng xác định thuộc tính footprint bằng tab Footprint của bảng Properties khả dụng khi tùy chọn PCB.FootprintParameters được bật trong hộp thoại Cài đặt nâng cao. Khi tùy chọn này bị tắt, các thuộc tính footprint được xác định bằng hộp thoại PCB Library Footprint (), được truy cập bằng cách chọn lệnh Tools » Footprint Properties từ các menu chính, hoặc chọn một mục footprint trong vùng Footprints của bảng PCB Library rồi nhấp vào nút Edit, hoặc nhấp đúp vào một mục footprint trong vùng Footprints của bảng PCB Library.

Khi một đối tượng thiết kế được chọn, bảng sẽ hiển thị các tùy chọn dành riêng cho loại đối tượng đó. Bảng sau liệt kê các loại đối tượng có thể đặt trong không gian thiết kế footprint PCB – nhấp vào liên kết để truy cập trang thuộc tính của đối tượng tương ứng.

Khối 3D Cung tròn
Vùng cấm dạng cung tròn Vùng tô
Vùng cấm dạng vùng tô Pad
Vùng Vùng cấm dạng vùng
Văn bản (Chuỗi, Khung văn bản) Đường mạch
Vùng cấm dạng đường mạch Via

Độ mở rộng mặt nạ hàn và mặt nạ kem hàn

Để kiểm tra xem mặt nạ hàn và/hoặc mặt nạ kem hàn đã được định nghĩa chính xác trong trình chỉnh sửa footprint PCB hay chưa, hãy mở bảng View Configuration và bật tùy chọn hiển thị () cho từng lớp mặt nạ.

Vòng xuất hiện quanh mép mỗi pad với màu của lớp Top Solder Mask biểu thị mép của hình dạng mặt nạ hàn nhô ra từ bên dưới pad đa lớp theo giá trị mở rộng, vì multi-layer nằm trên cùng trong thứ tự vẽ các lớp; lớp này được vẽ đè lên trên. Layer Drawing Order được thiết lập trên trang PCB Editor - Display của hộp thoại Preferences).

Hình bên dưới minh họa một footprint PCB có đường viền màu tím (màu của lớp Top Solder Mask) xuất hiện quanh mép mỗi pad.

Để nhanh chóng duyệt qua các lớp, hãy sử dụng Chế độ một lớp (Shift+S) kết hợp với Ctrl+Shift+Wheel roll.

Theo mặc định, hình dạng được tạo trên các lớp mặt nạ là hình dạng của pad, được mở rộng hoặc thu hẹp theo giá trị quy định trong các quy tắc thiết kế Độ mở rộng mặt nạ hàn và Độ mở rộng mặt nạ kem hàn được thiết lập trong PCB chứa footprint. Trong một số trường hợp, bạn có thể cần ghi đè các quy tắc thiết kế về độ mở rộng và chỉ định độ mở rộng mặt nạ dưới dạng thuộc tính của pad, chọn từ một tập hợp tiêu chuẩn các hình dạng mặt nạ được định nghĩa sẵn hoặc tạo hình dạng tùy chỉnh của riêng mình. Trong những trường hợp này, bạn có thể cấu hình mặt nạ kem hàn/mặt nạ hàn cho pad đã chọn trong bảng Properties của pad - tìm hiểu thêm. Ngoài ra, bạn có thể đặt các đối tượng cơ bản phù hợp (Vùng, Đường mạch, v.v.) trên lớp mặt nạ cần dùng.

Trong thư viện PCB, tất cả các đối tượng có độ mở rộng mặt nạ hàn được điều khiển bằng quy tắc sẽ có giá trị mở rộng bằng 0 mil. Tính năng này khả dụng khi tùy chọn PCB.SolderMaskZeroExpansion được bật trong hộp thoại Advanced Settings. Khi tùy chọn này bị tắt, giá trị mở rộng mặt nạ hàn cho các đối tượng như vậy trong thư viện PCB là 4 mil.

Hỗ trợ tham số

Các tham số được áp dụng cho đối tượng trong Altium Designer cung cấp một phương thức mạnh mẽ và linh hoạt để bổ sung thông tin cho thiết kế PCB. Là thuộc tính của đối tượng cha, tham số có thể được áp dụng ở nhiều cấp độ, bao gồm dự án, tài liệu, mẫu và từng đối tượng riêng lẻ trong tài liệu thiết kế.

Xem Đối tượng tham số để biết thêm thông tin.

Các tham số có sẵn trong không gian PCB có thể được dùng để lọc Truy vấn, Quy tắc thiết kế, Tập lệnh và Biến thể, đồng thời có thể được áp dụng trong footprint linh kiện PCB để gọi các chuỗi tùy chỉnh trong các footprint đã đặt.

Tham số thông qua Lệnh thay đổi kỹ thuật

Khả năng hỗ trợ tham số PCB dựa trên chức năng được tích hợp trong cơ chế ECO và tài liệu PCB, cho phép chuyển các tham số linh kiện do người dùng định nghĩa sang không gian PCB và lưu giữ chúng tại đó. Đây là quá trình chuyển một chiều và các tham số được chuyển sang chỉ có thể đọc trong môi trường PCB.

Việc chuyển tham số được thực hiện bằng cách tạo một ECO từ sơ đồ nguyên lý sang PCB bằng lệnh menu Design » Update PCB Document.

Khi ECO được thực thi (bằng nút Execute Changes ), mọi tham số mới do người dùng định nghĩa cho linh kiện trên sơ đồ nguyên lý sẽ được chuyển sang tham chiếu footprint tương ứng trong thiết kế PCB. 

Việc phát hiện và chuyển tham số sang PCB được quyết định bởi các thiết lập tùy chọn của dự án (Project » Project Options). Trong hộp thoại Project Options, hãy thiết lập cách phát hiện khác biệt và hành vi sửa đổi trong phần Differences Associated with Parameters của tab Comparator và phần Modifications Associated with Parameters của tab ECO Generation.

Để xem các tham số đã chuyển trong trình chỉnh sửa PCB, hãy nhấp đúp vào một linh kiện để mở bảng Properties , rồi chọn tab Parameters . Tab này sẽ liệt kê các tham số người dùng hiện có đã được gán cho footprint linh kiện được chọn. Các tham số của footprint linh kiện được chọn cũng có sẵn trong bảng Components .

Liên kết thông tin tham khảo

Môi trường PCB tự động tiếp nhận các tham số ComponentLink được định nghĩa sẵn từ sơ đồ nguyên lý. Các tham số này được định nghĩa theo cặp (Mô tả và URL liên kết), thường dùng để thiết lập liên kết tham khảo dữ liệu đến các tệp hoặc địa chỉ internet cụ thể – thường là trang web của nhà sản xuất hoặc URL của bảng dữ liệu.

Xem Định nghĩa liên kết có thể nhấp đến thông tin tham khảo trong thư viện sơ đồ nguyên lý và Truy cập liên kết có thể nhấp đến thông tin tham khảo trong tài liệu PCB để biết thông tin về các tham số Liên kết tham khảo.

Trong cả không gian thiết kế sơ đồ nguyên lý và PCB, có thể truy cập các liên kết từ menu ngữ cảnh nhấp chuột phải khi di chuột lên một linh kiện (trong các tùy chọn menu con References). Các tham số chuyên dụng được thêm trong bảng Properties và khi được chuyển sang không gian PCB, chúng xuất hiện dưới dạng tham số của footprint linh kiện. 

Tham số trong footprint nguồn

Các tham số được chuyển sang PCB có thể được dùng để cung cấp thêm thông tin về sản xuất hoặc chức năng của bo mạch thông qua footprint linh kiện. Bằng cách thêm các chuỗi tham số đặc biệt vào footprint ở cấp thư viện nguồn, các chuỗi tùy chỉnh sẽ được diễn giải trên lớp cơ khí hoặc lớp in ký hiệu đích.

Có thể thêm một chuỗi đặc biệt biểu thị tham số do người dùng định nghĩa vào footprint linh kiện nguồn bằng nút chuỗi đặc biệt và danh sách thả xuống () trong bảng Properties .

Trong footprint thư viện bên dưới, chuỗi đặc biệt .Designator đã được đặt trên lớp Mechanical 2.

Có thể thêm một chuỗi đặc biệt biểu thị tham số người dùng vào footprint linh kiện.

Khi tham số tùy chỉnh đó cũng đã được áp dụng cho các linh kiện trên sơ đồ nguyên lý và dữ liệu tham số đã được chuyển sang PCB, các chuỗi footprint sau khi được diễn giải sẽ xuất hiện cả trong chế độ xem bo mạch lẫn các tệp đầu ra được tạo. Trong trường hợp này, chuỗi tham số đặc biệt chứa mã định danh linh kiện tùy chỉnh để hỗ trợ lắp ráp.

Việc áp dụng các tham số người dùng cho footprint linh kiện dưới dạng chuỗi đặc biệt có thể đáp ứng nhiều yêu cầu PCB tùy chỉnh khác, bao gồm nhãn chức năng cho công tắc và đầu nối, trong đó chuỗi tham số 'chức năng' có thể được đặt trên lớp Top Overlay trong footprint của các loại linh kiện này.

Để xem giá trị đã được diễn giải của các chuỗi đặc biệt trên bố trí bo mạch, hãy bật tùy chọn Special Strings trong phần Additional Options của tab View Options trong View Configuration bảng. Các chuỗi đặc biệt luôn được chuyển đổi trong các tệp đầu ra được tạo.
Trong trình biên tập sơ đồ nguyên lý, nếu muốn, hãy bật tùy chọn Display Names of Special Strings that have No Value Defined trên trang Schematic – Graphical Editing của hộp thoại Preferences.

Truy vấn tham số

Các chuỗi tham số trong môi trường PCB cũng có thể được truy cập thông qua ngôn ngữ truy vấn của Altium Designer, do đó có thể dùng cho các chức năng lọc đối tượng, bao gồm tính năng Tìm đối tượng tương tự.

Để chọn các đối tượng tương tự, hãy nhấp chuột phải vào một linh kiện rồi chọn Find Similar Objects từ menu ngữ cảnh để mở hộp thoại Find Similar Objects.

Hộp thoại Tìm đối tượng tương tự có phần Parameters để chọn các tùy chọn lọc theo nhu cầu.

Bảng PCB Filter có thể áp dụng các từ khóa truy vấn dành riêng cho tham số làm tiêu chí lọc và có thể được dùng để tạo Quy tắc thiết kế dựa trên các tham số PCB.

Có nhiều từ khóa truy vấn để làm việc với các tham số footprint PCB, bao gồm các hàm chuyên dụng để chuyển đổi giá trị chuỗi thành số (chẳng hạn như StrToNumber). Việc chuyển đổi giá trị chuỗi có nhận biết đơn vị (V, mA, mV, kOhm, v.v.) và cho phép xác định kết quả truy vấn bằng cách xử lý số học đối với chuỗi giá trị tham số.

Các loại đơn vị được hỗ trợ có thể chỉ định trong truy vấn gồm:

  • % – Phần trăm
  • A – Dòng điện
  • C – Nhiệt độ
  • dB – Decibel
  • F – Điện dung
  • G – Điện dẫn
  • H – Điện cảm
  • Hz – Tần số
  • Kg – Khối lượng
  • m – Chiều dài
  • Ohm – Điện trở
  • Q – Điện tích
  • s – Thời gian
  • V – Điện áp
  • W – Công suất
  • Z – Trở kháng

Có nhiều từ khóa truy vấn tham số để làm việc với các tham số footprint của linh kiện PCB.

Ví dụ trong hộp thoại Query Helper ở trên xử lý tham số điện áp định mức của từng linh kiện (sử dụng phép chuyển đổi chuỗi thành số – StrToNumber(Unit Value, Unit Type))  để xác định xem giá trị của tham số đó có lớn hơn 50V hay không. Khi áp dụng trong bảng PCB Filter, bố trí bo mạch ví dụ cho thấy một linh kiện điện áp cao duy nhất, C1 (có giá trị điện áp định mức là 3kV).

Ký hiệu khoa học E cũng được hỗ trợ; ví dụ, truy vấn để lọc các giá trị tụ điện trên 1nF sẽ có dạng như sau:
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
Ngoài ra, có thể dùng hàm chuyển đổi số cho cả ParameterValue được trả về and giá trị so sánh:
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Quy tắc và tập lệnh

Các truy vấn tham số PCB cũng có thể được áp dụng cho Tập lệnh và Quy tắc thiết kế trong Altium Designer. Quy tắc thiết kế có thể thực hiện các bước kiểm tra tính hợp lệ của bố trí, chẳng hạn như phát hiện tham số footprint để đánh giá vị trí đặt linh kiện hoặc việc gán lớp. Lưu ý rằng các hàm được liệt kê trong hộp thoại Query Helper ở trên cũng có thể dùng trong ngôn ngữ viết tập lệnh.

Ví dụ dưới đây minh họa truy vấn điện áp định mức của tụ điện (xem truy vấn lọc ở trên) được áp dụng cho quy tắc đặt linh kiện. Khi chạy, quy tắc này kiểm tra các giá trị khoảng cách cách ly cụ thể cho những linh kiện được xác định là thiết bị điện áp cao (>50V).

Các quy tắc thiết kế được xác định bằng những tham số footprint cụ thể, được chuyển từ môi trường sơ đồ nguyên lý, có thể dùng để phát hiện các điều kiện bố trí tùy chỉnh.

Tương tự, các tham số PCB tùy chỉnh có thể dùng để kiểm tra tính tương thích của linh kiện với lớp, ví dụ khi một linh kiện không hỗ trợ hàn sóng và do đó không thể đặt trên lớp dưới cùng. Trong trường hợp này, có thể áp dụng truy vấn đối sánh đối tượng xử lý tham số tùy chỉnh ‘WaveSoldering’ (Yes/No) cho Quy tắc lớp được phép.

Sau đó, Quy tắc (chạy theo lô) sẽ kiểm tra giá trị của tham số linh kiện đó và tạo ra một vi phạm nếu linh kiện không tương thích với việc đặt trên lớp dưới cùng.

Biến thể

Các tham số được chuyển sang PCB và nằm trong các biến thể của thiết kế (Biến thể thiết kế) được xử lý theo lựa chọn Biến thể.

Trong thực tế, một tham số linh kiện thay đổi theo biến thể trong môi trường PCB sẽ được chuỗi truy vấn tự động nhận biết, hoặc được hiển thị trên một lớp bo mạch thông qua chuỗi đặc biệt. 

Tham số footprint do người dùng định nghĩa

Tính năng này khả dụng khi tùy chọn PCB.FootprintParameters được bật trong hộp thoại Cài đặt nâng cao.

Altium Designer hỗ trợ các tham số footprint do người dùng định nghĩa. Có thể dùng vùng Parameters trên tab Footprint của bảng Properties  ở chế độ Library Options  để xem và chỉnh sửa các tham số footprint khi không có đối tượng nào được chọn trong không gian thiết kế của trình biên tập footprint PCB.

Khi linh kiện được đặt trên PCB, bạn có thể xem các tham số này trong bảng Properties  ở chế độ Component  trên tab Parameters .

  • Các tham số footprint của linh kiện được đặt trên PCB sẽ được truyền sang các footprint trong thư viện được tạo bằng lệnh Make PCB Library hoặc Make Integrated Library trong menu chính của trình biên tập PCB.
  • Các tham số footprint được hỗ trợ bởi bộ máy So sánh của Altium Designer và trong đầu ra Pick and Place và ODB++ được tạo.
Altium MCAD CoDesigner hỗ trợ đặt các linh kiện MCAD gốc trong MCAD theo liên kết đã cấu hình. Trong một số trường hợp, nhiều footprint với các mô hình khác nhau được liên kết với một linh kiện (ví dụ: một đèn LED có thể được gắn lên PCB theo hai cách: theo chiều dọc với chân thẳng, hoặc theo chiều ngang với chân uốn cong). Nhờ các tham số footprint, giờ đây bạn có thể tham chiếu đến các mô hình MCAD khác nhau từ những footprint khác nhau đó. Tìm hiểu thêm về Liên kết các linh kiện thiết kế ECAD và MCAD gốc.

Chuỗi ký hiệu định danh và chú thích

Chuỗi ký hiệu định danh và chú thích mặc định

Khi một footprint được đặt trên bo mạch, footprint đó được gán ký hiệu định danh và chú thích dựa trên thông tin trích xuất từ sơ đồ nguyên lý của thiết kế. Không cần xác định thủ công các phần giữ chỗ cho chuỗi ký hiệu định danh và chú thích vì chúng được thêm tự động khi footprint được đặt trên bo mạch. Vị trí của các chuỗi này được xác định bằng tùy chọn Autoposition của chuỗi ký hiệu định danh và chú thích trong bảng Properties ở chế độ Parameter khi chuỗi ký hiệu định danh hoặc chú thích được chọn trong không gian thiết kế. Vị trí và kích thước mặc định của các chuỗi ký hiệu định danh và chú thích được cấu hình trong đối tượng cơ bản tương ứng trên trang Trình biên tập PCB - Mặc định của hộp thoại Preferences .

Chuỗi ký hiệu định danh và chú thích bổ sung

Có những trường hợp bạn muốn có thêm bản sao của các chuỗi ký hiệu định danh hoặc chú thích. Ví dụ, đơn vị lắp ráp của bạn muốn có bản vẽ lắp ráp chi tiết với ký hiệu định danh nằm bên trong đường bao của từng linh kiện, trong khi công ty bạn yêu cầu ký hiệu định danh phải nằm ngay phía trên linh kiện trên lớp in ký hiệu linh kiện của PCB hoàn thiện. Yêu cầu bổ sung ký hiệu định danh này có thể được đáp ứng bằng cách đưa chuỗi đặc biệt .Designator vào footprint. Chuỗi đặc biệt .Comment cũng có sẵn để chỉ định vị trí của chuỗi chú thích trên các lớp hoặc tại các vị trí khác.

Để đáp ứng yêu cầu của đơn vị lắp ráp, chuỗi .Designator sẽ được đặt trên một lớp cơ khí trong trình biên tập footprint PCB. Sau đó, có thể tạo các bản in bao gồm lớp này để đưa vào hướng dẫn lắp ráp của thiết kế.

Xử lý các yêu cầu đặc biệt theo từng lớp

Một linh kiện PCB có thể có nhiều yêu cầu đặc biệt, chẳng hạn như cần một điểm keo hoặc vùng mặt nạ hàn có thể bóc. Nhiều yêu cầu đặc biệt này gắn với mặt bo mạch mà linh kiện được lắp và phải chuyển sang mặt kia của bo mạch khi linh kiện được lật.

Thay vì đưa vào một số lượng lớn các lớp chuyên dụng có thể hiếm khi được sử dụng, trình biên tập PCB của Altium Designer hỗ trợ yêu cầu này thông qua tính năng ghép cặp lớp. Một cặp lớp là hai lớp cơ khí được xác định thành một cặp. Mỗi khi một linh kiện được lật từ mặt này sang mặt kia của bo mạch, mọi đối tượng trên một lớp cơ khí đã ghép cặp sẽ được chuyển sang lớp cơ khí còn lại trong cặp đó. Với cách tiếp cận này, bạn chọn một lớp cơ khí phù hợp để chứa điểm keo (hoặc các yêu cầu đặc biệt khác) và xác định hình dạng của nó bằng các đối tượng có sẵn. Khi đặt footprint đó lên bo mạch, bạn phải thiết lập việc ghép cặp lớp. Thiết lập này cho phần mềm biết phải chuyển các đối tượng sang lớp nào khi linh kiện được lật sang mặt kia của bo mạch. Bạn không thể xác định các cặp lớp trong trình biên tập footprint PCB; việc này được thực hiện trong trình biên tập PCB.

Việc ghép cặp lớp cần được xác định before linh kiện được lật. Nếu việc ghép cặp được xác định sau khi linh kiện đã chuyển sang mặt dưới, nội dung trên lớp cơ khí sẽ được lật nhưng vẫn nằm trên lớp ban đầu. Nếu quên tạo cặp lớp trước khi lật, bạn có thể cập nhật từ thư viện để làm mới phiên bản linh kiện đã đặt trên bo mạch.

Tên các lớp cơ khí có thể được chỉnh sửa trực tiếp từ bảng View Configurations bằng cách nhấp chuột phải rồi chọn Edit Layer.

Một cách phổ biến để quản lý việc sử dụng các lớp cơ khí là gán một số lớp riêng cho từng chức năng lớp cơ khí cần thiết. Cách này yêu cầu tất cả người thiết kế tuân thủ cùng một quy ước gán và đánh số lớp. Nó cũng có thể gây khó khăn khi lấy linh kiện từ các nguồn khác không tuân theo cùng quy ước gán và đánh số. Nếu một quy ước khác đã được sử dụng, các đối tượng thiết kế phải được chuyển từ lớp cơ khí hiện tại sang lớp cơ khí được gán cho chức năng đó.

Vấn đề này được giải quyết nhờ thuộc tính Layer Type. Khi một linh kiện được đặt từ thư viện vào trình biên tập PCB, được sao chép từ thư viện này sang thư viện khác hoặc được tạo bởi IPC Footprint Wizard, các thiết lập Loại lớp hiện có sẽ tự động được đối chiếu, bất kể số lớp cơ khí được gán cho các Loại lớp đó. Các đối tượng được chuyển sang đúng lớp theo Loại lớp của chúng. Nếu phần mềm không thể đối chiếu theo Loại lớp, nó sẽ chuyển sang đối chiếu theo Số lớp.

Đối với cả lớp cơ khí riêng lẻ và Cặp lớp linh kiện, bạn có thể chọn một Loại lớp từ danh sách các loại được định nghĩa sẵn. Bạn có thể mở các hộp thoại minh họa bên dưới bằng cách nhấp chuột phải vào một lớp riêng lẻ, rồi chọn lệnh Edit Layer hoặc Add Component Layer từ menu.

Để biết thông tin chi tiết về các loại lớp cơ khí liên quan đến linh kiện, hãy tham khảo trang Làm việc với các lớp cơ khí.

Thêm chiều cao cho footprint PCB

Ở mức biểu diễn 3D đơn giản nhất, có thể thêm thông tin chiều cao vào footprint PCB. Để thực hiện, hãy mở bảng Properties ở chế độ Library Options (hoạt động khi không có đối tượng nào được chọn trong không gian thiết kế) và nhập chiều cao khuyến nghị cho linh kiện vào trường Height trên thẻ Footprint của bảng.

Có thể xác định các quy tắc thiết kế về chiều cao trong quá trình thiết kế bo mạch (nhấp vào Design » Rules trong trình biên tập PCB), thường để kiểm tra chiều cao tối đa của linh kiện trong một nhóm linh kiện hoặc trong một vùng bố trí đã xác định.

Một lựa chọn tốt hơn để xác định thông tin chiều cao là gắn Khối 3D vào footprint PCB.

Quản lý linh kiện có các đối tượng đi dây cơ bản

Khi thiết kế được chuyển sang PCB, footprint được chỉ định trong mỗi linh kiện sẽ được lấy từ các thư viện có sẵn và đặt lên bo mạch. Sau đó, thuộc tính net của từng pad trong footprint được đặt thành tên của net nối với chân linh kiện đó trong sơ đồ nguyên lý. Tất cả các đối tượng tiếp xúc với một pad đều kết nối với cùng net của pad đó.

Trình biên tập PCB có một công cụ quản lý net toàn diện. Để khởi chạy công cụ này, hãy chọn Design » Netlist » Configure Physical Nets từ các menu chính để mở hộp thoại Configure Physical Nets. Nhấp vào nút Menu để mở menu tùy chọn. Nhấp vào danh sách thả xuống ở tiêu đề New Net Name để chọn net cần gán cho các đối tượng cơ bản chưa được gán net.

Footprint có nhiều pad nối với cùng một chân

Footprint minh họa bên dưới, của một transistor SOT223, có nhiều pad nối với cùng một chân logic của linh kiện trên sơ đồ nguyên lý — Chân 2. Để tạo kết nối này, hai pad đã được thêm với cùng ký hiệu định danh — '2'. Khi sử dụng lệnh Design » Update PCB trong trình biên tập sơ đồ nguyên lý để chuyển thông tin thiết kế sang PCB, kết quả đồng bộ sẽ hiển thị các đường kết nối đến cả hai pad trong trình biên tập PCB, nghĩa là chúng nằm trên cùng một net. Cả hai pad này đều có thể được đi dây.

Footprint SOT223 hiển thị hai pad có ký hiệu định danh là 2.
Footprint SOT223 hiển thị hai pad có ký hiệu định danh là 2.

Chuẩn bị lớp in lụa

Để hỗ trợ giải quyết các vấn đề thường gặp về thiết kế phục vụ sản xuất (DFM) do lớp in lụa chồng lên phần đồng lộ ra và các lỗ, trình biên tập footprint PCB có một tính năng chuyên dụng để chuẩn bị lớp in lụa cho footprint. Các vấn đề này có thể được xử lý hiệu quả bằng cách:

  • tự động cắt gọn các đường thẳng và cung tròn trên lớp in lụa;
  • tự động cắt gọn hoặc di chuyển các vùng tô và vùng;
  • tự động di chuyển các chuỗi văn bản trên lớp in lụa.
Bạn cũng có thể truy cập công cụ chuẩn bị lớp in lụa khi thiết kế PCB – tìm hiểu thêm.

Để truy cập công cụ chuẩn bị lớp in lụa trong trình biên tập footprint PCB, hãy sử dụng lệnh Tools » Silkscreen Preparation từ các menu chính. Hộp thoại Silkscreen Preparation sẽ mở ra.

Sử dụng hộp thoại để cấu hình các thiết lập cắt gọn/di chuyển đối tượng trên lớp in lụa. Các tùy chọn có sẵn gồm:

  • Clip to Exposed Copper – bật để tự động cắt gọn các đối tượng theo phần đồng lộ ra.
  • Clip to Solder Mask Openings – bật để tự động cắt gọn các đối tượng theo các vùng mở mặt nạ hàn.
  • Silkscreen Clearance – xác định khoảng cách tối thiểu chấp nhận được giữa các đối tượng trên lớp in lụa và phần đồng lộ ra / vùng mở mặt nạ hàn và các lỗ.
  • Min Remaining Length – nếu chiều dài đoạn thẳng/cung nhỏ hơn giá trị đã xác định sau khi cắt xén, các đối tượng sẽ bị xóa khỏi footprint. Lưu ý rằng đây là chiều dài từ đỉnh đến đỉnh, không phải từ mép đến mép – xem hình.
  • Move Text – bật để di chuyển các chuỗi văn bản trên lớp in lụa ra xa phần đồng hở / cửa sổ mặt nạ hàn và các lỗ nếu khoảng cách giữa chúng nhỏ hơn Silkscreen Clearance. Mức dịch chuyển bị giới hạn bởi giá trị Max Distance.
  • Fill & Region – chọn thao tác cần thực hiện đối với các vùng tô và vùng đa giác khi khoảng cách giữa chúng và phần đồng hở / cửa sổ mặt nạ hàn và các lỗ nhỏ hơn Silkscreen Clearance:
    • None – giữ nguyên các vùng tô và vùng đa giác.
    • Clip – các vùng tô và vùng đa giác sẽ được cắt xén để duy trì Silkscreen Clearance. Các vùng tô được chuyển thành vùng đa giác khi thích hợp.
    • Move – các vùng tô và vùng đa giác sẽ được di chuyển ra xa phần đồng hở / cửa sổ mặt nạ hàn và các lỗ. Mức dịch chuyển bị giới hạn bởi giá trị Max Distance.
  • Max Distance – xác định khoảng cách tối đa mà các chuỗi văn bản, ký hiệu định danh linh kiện, vùng tô và vùng đa giác có thể được di chuyển để duy trì Silkscreen Clearance.

Nhấp vào OK để cắt xén và/hoặc di chuyển các đối tượng trên lớp in lụa theo các thiết lập trong hộp thoại.

Nếu không thể thực hiện một thao tác đối với một đối tượng (ví dụ: không thể di chuyển chuỗi văn bản do giới hạn của Max Distance), thông báo cho đối tượng đó sẽ xuất hiện trong bảng Messages.

Ví dụ về kết quả hoạt động của công cụ chuẩn bị lớp in lụa được minh họa bên dưới.

Javascript

Tạo footprint bằng trình hướng dẫn tạo footprint tuân thủ IPC

IPC Compliant Footprint Wizard tạo footprint PCB tuân thủ đầy đủ bản sửa đổi B của tiêu chuẩn IPC 7351 - Generic Requirements for Surface Mount Design and Land Pattern Standard. Thay vì làm việc trực tiếp với các kích thước footprint (như Trình hướng dẫn tạo footprint ), IPC Compliant Footprint Wizard sử dụng thông tin kích thước của chính linh kiện, sau đó tính toán các thuộc tính phù hợp cho pad và các thuộc tính footprint khác theo các thuật toán do IPC công bố.

Thay vì yêu cầu bạn nhập các thuộc tính của pad và đường mạch dùng để xác định footprint, Wizard sử dụng kích thước thực tế của linh kiện làm dữ liệu đầu vào. Dựa trên các công thức được xây dựng cho tiêu chuẩn IPC-7351, Wizard sau đó tạo footprint bằng các đối tượng tiêu chuẩn của Altium Designer, chẳng hạn như pad và đường mạch.

  • Hộp thoại này tuân thủ bản sửa đổi B của tiêu chuẩn IPC 7351 - Yêu cầu chung về thiết kế gắn bề mặt và tiêu chuẩn mẫu bố trí pad. IPC-7351B được ban hành năm 2010 và thay thế IPC-7351A (ban hành năm 2007).

  • Để truy cập IPC Compliant Footprint Wizard trong Altium Designer, phải cài đặt tiện ích mở rộng phần mềm IPC Footprint Generator. Tiện ích mở rộng này được cài đặt mặc định cùng với Altium Designer. Bạn có thể cài đặt hoặc gỡ bỏ tiện ích này theo cách thủ công.

    Để biết thêm thông tin về việc quản lý tiện ích mở rộng, hãy tham khảo trang Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Để chạy IPC Compliant Footprint Wizard, chọn Tools » IPC Compliant Footprint Wizard từ các menu chính trong tài liệu thư viện PCB.

Trên trang Select Component Type, chọn họ linh kiện mà bạn muốn tạo footprint trên trang Select Component Type. Vùng xem trước ở phía bên phải của trình hướng dẫn thay đổi linh hoạt để hiển thị linh kiện đang được chọn, đồng thời cho biết các kiểu vỏ linh kiện có thể được tạo. Bảng sau liệt kê các loại linh kiện và kiểu vỏ được trình hướng dẫn hỗ trợ.

Tên Mô tả Các kiểu vỏ được hỗ trợ
BGA Mảng chân bi BGA, CGA
BQFP Vỏ phẳng bốn phía có gờ bảo vệ BQFP
CAPAE Tụ điện nhôm điện phân CAPAE
CFP Vỏ gốm phẳng hai phía - Chân dạng cánh hải âu được cắt và tạo hình CFP
Mảng chip Mảng chip Mảng chip
DFN Vỏ phẳng hai phía không chân DFN
CHIP Linh kiện chip, 2 chân Tụ điện, cuộn cảm, điện trở
CQFP Vỏ gốm phẳng bốn phía - Chân dạng cánh hải âu được cắt và tạo hình CQFP
DPAK Vỏ transistor DPAK
LCC Đế chip không chân LCC
LGA Mảng pad tiếp xúc LGA
MELF Linh kiện MELF, 2 chân Điốt, điện trở
MOLDED Linh kiện đúc, 2 chân Tụ điện, cuộn cảm, điốt
PLCC Đế chip bằng nhựa có chân, hình vuông - Chân dạng J PLCC
PQFN Vỏ phẳng bốn phía không chân, pad lùi vào trong PQFN
PQFP Vỏ nhựa phẳng bốn phía PQFP, PQFP có pad lộ ra ngoài
PSON Vỏ nhỏ không chân, pad lùi vào trong PSON
QFN Vỏ phẳng bốn phía không chân QFN, LLP
QFN-2ROW Vỏ phẳng bốn phía không chân, 2 hàng, hình vuông QFN hai hàng
SODFL Điốt vỏ nhỏ, chân phẳng SODFL
SOIC Vỏ mạch tích hợp nhỏ, bước chân 1,27 mm - Chân dạng cánh hải âu SOIC, SOIC có pad lộ ra ngoài
SOJ Vỏ nhỏ - Chân dạng J SOJ
SON Vỏ nhỏ không chân SON, SON có pad lộ ra ngoài
SOP, TSOP Vỏ nhỏ - Chân dạng cánh hải âu SOP, TSOP, TSSOP
SOT143/343 Transistor vỏ nhỏ SOT143, SOT343
SOT223 Transistor vỏ nhỏ SOT223
SOT23 Transistor vỏ nhỏ 3 chân, 5 chân, 6 chân
SOT89 Transistor vỏ nhỏ SOT89
SOTFL Transistor vỏ nhỏ, chân phẳng 3 chân, 5 chân, 6 chân
DÂY QUẤN Cuộn cảm dây quấn chính xác, 2 chân Cuộn cảm

Các trang tiếp theo của trình hướng dẫn thay đổi tùy theo loại linh kiện đã chọn. Làm theo các trang hướng dẫn trực quan để thiết lập footprint của linh kiện cụ thể theo yêu cầu. Một số lưu ý khi làm việc với IPC Compliant Footprint Wizard:

  • Tất cả kích thước được nhập vào trình hướng dẫn theo đơn vị hệ mét (mm).

  • Bạn có thể nhập và xem ngay kích thước tổng thể của vỏ linh kiện, thông tin chân, khoảng cách giữa các gót chân, phần mối hàn và dung sai.

    Việc thay đổi dung sai IPC có thể tạo ra các footprint PCB không tuân thủ IPC.

  • Có thể nhập các kích thước cơ khí, chẳng hạn như thông tin về vùng Courtyard, bản vẽ lắp ráp và thân linh kiện (3D).

  • Wizard cho phép quay lại các bước trước, giúp bạn dễ dàng xem lại và điều chỉnh.

  • Bản xem trước của footprint được hiển thị ở mọi bước. Với mỗi loại linh kiện, vùng Preview được cập nhật động để hiển thị vị trí, kích thước mới, v.v., cho một số thiết lập. Trong vùng Preview , bạn có thể nhấp vào  hoặc  để chuyển đổi giữa hình ảnh xem trước 2D và 3D.

  • Nếu muốn, bạn có thể xem trước mô hình 3D STEP trước khi tạo mô hình. Nhấp vào Generate STEP Model Preview trên bất kỳ trang nào trong Wizard sau khi chọn loại linh kiện để xem bản xem trước của mô hình 3D STEP trong vùng Preview.

  • Các vùng mở trên lớp mặt nạ kem hàn được chia thành các vùng tô nhỏ đối với các kiểu vỏ có pad tản nhiệt lớn (kích thước từ 2,1 mm x 1,6 mm trở lên).

  • Đối với các kiểu vỏ có chân dạng cánh hải âu, pad được cắt ngắn để tránh kéo dài vào bên dưới thân vỏ.

  • Đối với các kiểu vỏ nhỏ có pad tản nhiệt lớn ở giữa, các pad ngoại vi được cắt ngắn để bảo đảm khoảng hở cần thiết giữa các pad theo tiêu chuẩn IPC.

  • Khi áp dụng việc cắt ngắn pad, một cảnh báo sẽ xuất hiện trong hộp thoại.

  • Tên và mô tả của footprint được tự động đề xuất dựa trên thông tin bạn nhập trong Wizard nhưng có thể thay đổi cho phù hợp với yêu cầu của tổ chức.

  • Theo tiêu chuẩn IPC, trình hướng dẫn hỗ trợ ba biến thể footprint (_L, _N, _M), mỗi biến thể được thiết kế phù hợp với một mật độ bố trí bo mạch khác nhau.

  • Bạn có thể nhấn nút Finish ở bất kỳ bước nào để tạo footprint đang được xem trước. Nếu bạn nhấp vào Finish trước khi hoàn tất toàn bộ Wizard, footprint sẽ được tạo bằng các giá trị mặc định của hệ thống dành cho loại linh kiện bạn đã chọn.

  • Khi làm việc với thư viện footprint PCB dạng tệp, hãy sử dụng Trình tạo hàng loạt footprint tuân thủ IPC để nhanh chóng tạo nhiều footprint ở nhiều mức mật độ khác nhau.

Khi truy cập trình hướng dẫn từ thư viện footprint PCB dạng tệp, trang Footprint Destination sẽ xuất hiện, cho phép bạn chọn vị trí lưu footprint vừa tạo – xem hình ảnh:

  • Chọn Existing PcbLib File nếu bạn muốn lưu footprint vào một tệp thư viện PCB hiện có. Bạn có thể nhập trực tiếp tệp vào hộp văn bản hoặc sử dụng  để mở hộp thoại tìm kiếm tệp mong muốn.
  • Chọn New PcbLib File nếu bạn muốn lưu footprint vào một tệp thư viện PCB mới. Nhập tên tệp thư viện PCB mới vào hộp văn bản. Hệ thống sẽ thêm phần mở rộng .PcbLib vào tên tệp thư viện mới.
  • Chọn Current PcbLib File để lưu footprint vào tệp thư viện PCB đang hiển thị.
  • Bật Produce 3D/STEP model để tạo mô hình 3D STEP.
  • Nếu có giấy phép 'MCAD Co-Designer - SOLIDWORKS(R)' hợp lệ, bạn có thể chọn lưu mô hình ở định dạng tệp Parasolid. Nhấp vào danh sách thả xuống ở bên phải Format rồi chọn Parasolid. Tệp hiển thị trong hộp văn bản External File lúc này là tệp *.x_t. Đây là tên và vị trí của tệp sẽ được lưu.
  • Chọn Embedded (mặc định) hoặc External File. Chọn External File để lưu mô hình 3D STEP dưới dạng tệp bên ngoài. Định dạng tệp mặc định là STEP và tên tệp xuất hiện trong hộp văn bản External File với *.step là phần mở rộng tệp. Nếu muốn, hãy nhấp vào  để duyệt và chọn thư mục lưu mô hình 3D STEP được tạo.

Tạo footprint bằng trình hướng dẫn Footprint Wizard

Trình biên tập footprint PCB có tích hợp Footprint Wizard. Wizard này cho phép bạn chọn từ nhiều loại vỏ linh kiện và điền thông tin phù hợp, sau đó sẽ tạo footprint linh kiện cho bạn. Lưu ý rằng trong Footprint Wizard, bạn nhập các kích thước cần thiết cho pad và lớp overlay của linh kiện.

Để khởi chạy Footprint Wizard, chọn Tools » Footprint Wizard từ các menu chính hoặc nhấp chuột phải trong không gian thiết kế và chọn lệnh Tools » Footprint Wizard từ menu ngữ cảnh.

Sử dụng trang Component patterns để chỉ định dạng bố trí của linh kiện bạn muốn tạo. Chọn dạng bố trí mong muốn từ danh sách, sau đó sử dụng danh sách thả xuống để chọn đơn vị cho linh kiện (Imperial (mil) hoặc Metric (mm)). Các dạng bố trí có sẵn gồm:

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

Các trang tiếp theo của trình hướng dẫn sẽ thay đổi tùy theo dạng bố trí linh kiện đã chọn. Làm theo các trang hướng dẫn trực quan để thiết lập footprint linh kiện cụ thể theo yêu cầu.

Khi thiết lập kiểu đặt tên pad cho footprint có dạng bố trí Edge Connectors, Leadless Chip Carriers (LCC) hoặc Quad Packs (QUAD), hãy nhấp vào mũi tên màu xanh lá để thay đổi thứ tự/hướng đặt tên – xem hình ảnh.

Tạo báo cáo linh kiện

Để tạo báo cáo cho footprint PCB đang hoạt động, chọn lệnh Reports » Component từ các menu chính. Sau khi chạy lệnh, báo cáo sẽ được tạo (<PCBLibraryDocumentName>.CMP) trong cùng thư mục với tài liệu thư viện PCB nguồn và tự động mở dưới dạng tài liệu đang hoạt động trong cửa sổ thiết kế chính. Báo cáo liệt kê các thông tin bao gồm kích thước footprint, chi tiết các đối tượng cơ bản cấu thành footprint và các lớp chứa chúng.

Báo cáo sẽ được thêm vào bảng Projects dưới dạng tài liệu độc lập trong thư mục con Documentation\Text Documents.

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nav
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents