Tạo Bản Vẽ Bố Trí
Sau khi thiết kế harness đã được ghi nhận dưới dạng sơ đồ đi dây, có thể tạo biểu diễn vật lý của thiết kế dưới dạng bản vẽ bố trí harness (*.LdrDoc). Hãy thêm tài liệu này vào dự án harness từ panel Projects bằng cách nhấp chuột phải vào mục dự án rồi chọn Add New to Project » Harness Wiring Diagram từ menu ngữ cảnh (hoặc dùng lệnh File » New » Harness Layout Drawing từ các menu chính).
Thiết lập tài liệu bản vẽ bố trí harness
Các tùy chọn của tài liệu bản vẽ bố trí có thể được cấu hình trong panel Properties khi không có đối tượng nào được chọn trong không gian thiết kế của tài liệu. Các thiết lập chính gồm:
-
Trong vùng General của tab General trên panel – chọn đơn vị đo áp dụng cho tài liệu và các phần tử đồ họa của tài liệu, đồng thời thiết lập lưới để hỗ trợ việc đặt dễ dàng hơn. Altium Designer cung cấp ba loại lưới: visible grid để điều hướng, snap grid để đặt đối tượng, và snap distance để hỗ trợ tạo kết nối.
-
Trong vùng Page Options của tab General trên panel – cấu hình kích thước trang tài liệu và khung tiêu đề hoặc chọn từ các mẫu bản vẽ bố trí harness có sẵn.

Các tab General và Parameters của panel Properties khi không có đối tượng nào được chọn trong tài liệu bản vẽ bố trí harness
Nhập dữ liệu từ sơ đồ đi dây
Chọn lệnh Design » Import Wiring Diagram từ các menu chính để nhập dữ liệu thiết kế từ sơ đồ đi dây. Linh kiện sẽ được đặt trên trang bản vẽ bố trí theo các vị trí tương đối được xác định trong sơ đồ đi dây. Các điểm kết nối liên kết với linh kiện cũng sẽ được đặt cạnh mỗi linh kiện trên bản vẽ bố trí.

Tài liệu bản vẽ bố trí harness với dữ liệu được nhập từ sơ đồ đi dây
Làm việc với linh kiện
Ban đầu, mỗi linh kiện được biểu diễn trên bản vẽ bố trí bằng ký hiệu của nó. Các thuộc tính của một linh kiện đã đặt có thể được cấu hình trong panel Properties khi linh kiện được chọn trong không gian thiết kế. Panel Properties cho một linh kiện bao gồm các tab sau:
-
General – các thuộc tính chung của linh kiện, chẳng hạn như designator và comment, vị trí, biểu diễn model, tham số, v.v.
-
Pins – danh sách chân linh kiện.
-
Cavities – chế độ xem chỉ đọc của các khoang socket được gán cho linh kiện. Việc gán khoang chỉ có thể được sửa trong sơ đồ đi dây – tìm hiểu thêm.
-
Associated Parts – cho phép gán thêm các phần như ống co nhiệt cho linh kiện.
Cấu hình cách biểu diễn của linh kiện
Sử dụng tùy chọn Graphical Symbol / Physical Model trong vùng Model của panel Properties (trong tab General) khi một linh kiện được chọn, bạn có thể chuyển đổi giữa biểu diễn ký hiệu ( symbol của linh kiện) và hình chiếu model 3D ( footprint của linh kiện). Sử dụng các thiết lập khác trong vùng của panel để cấu hình cách biểu diễn.
|
Một linh kiện được biểu diễn bằng ký hiệu sơ đồ nguyên lý của nó Cùng linh kiện đó được biểu diễn bằng hình chiếu của model 3D của nó |
Khi sử dụng biểu diễn Physical Model, hãy dùng các tùy chọn Style để hiển thị model dưới dạng Solid (không có đường nét) hoặc dưới dạng Wireframe. Sử dụng các tùy chọn của danh sách thả xuống Side để chọn mặt nhìn mong muốn của model (có các tùy chọn trực giao và đẳng phối). Các hình ảnh bên dưới minh họa một số thiết lập cùng với kết quả tương ứng trong không gian thiết kế.
Chế độ xem model vật lý có thể được xoay trực quan trong không gian thiết kế bằng cách nắm tay cầm xoay nằm ở góc dưới bên phải của chế độ xem model và dùng chuột; trường Rotation sẽ tự động cập nhật (góc xoay theo bước 1 độ). Bạn cũng có thể giữ phím Alt để giới hạn góc xoay theo bước 45 độ. Để hỗ trợ thêm, khi chế độ xem đang được xoay bằng chuột, góc hiện tại sẽ được hiển thị trong Status Bar.
Xác định bố trí vật lý trên bản vẽ bố trí harness
Tất cả các kết nối vật lý trong harness được định nghĩa là các harness bundle (ngay cả khi một bundle chỉ chứa một dây đơn). Mỗi bundle phải bắt đầu và kết thúc tại một điểm kết nối. Ở lần nhập dữ liệu thiết kế harness ban đầu (như đã mô tả ở trên), mỗi linh kiện có một điểm kết nối được tự động đặt cạnh nó, và điểm kết nối này được liên kết với linh kiện cùng tất cả các chân của nó. Nếu cấu trúc vật lý của thiết kế yêu cầu, có thể đặt các điểm kết nối mới và cấu hình các đối tượng được gán cho điểm kết nối.
Làm việc với điểm kết nối
Để đặt một điểm kết nối mới, hãy dùng lệnh Place » Connection Point từ các menu chính. Các điểm kết nối được hiển thị trong không gian thiết kế như bên dưới.
Các thuộc tính của một điểm kết nối đã đặt (vị trí, biểu diễn trực quan, v.v.) có thể được cấu hình trong panel Properties khi điểm kết nối được chọn trong không gian thiết kế.

Panel Properties khi một điểm kết nối được chọn
Gán đối tượng cho điểm kết nối
Các đối tượng được gán cho một điểm kết nối có thể được cấu hình khi cần theo đúng ý định thiết kế của bạn. Một hoặc nhiều đối tượng (linh kiện, splice/tap, đối tượng 'no connect', và shield có kết nối) có thể được gán cho một điểm kết nối bằng hộp thoại Add Assigned Objects được truy cập bằng cách nhấp vào nút
trong vùng Assigned Objects của panel Properties .
Khi một linh kiện được gán cho một điểm kết nối, một đường gạch chấm sẽ được hiển thị trong không gian thiết kế giữa linh kiện và điểm kết nối, như minh họa bên dưới. Trong Properties, bạn có thể chọn những chân linh kiện nào được gán. Nhấp vào ô trong cột Pins của lưới trong vùng Assigned Objects để truy cập danh sách thả xuống và chọn các chân linh kiện cần thiết.
Làm việc với harness bundle
Để đặt một harness bundle mới, dùng lệnh Place » Harness Bundle từ các menu chính (phím tắt: Shift+B).
Sau khi chọn lệnh, hãy nhấp vào một điểm kết nối (một dấu cộng đỏ sẽ xuất hiện tại con trỏ khi nó nằm trên hotspot của điểm kết nối) để đặt điểm bắt đầu của harness bundle. Di chuyển con trỏ và nhấp để neo một chuỗi các điểm đỉnh xác định hình dạng của harness bundle. Sau khi đặt điểm đỉnh cuối cùng tại hotspot của một điểm kết nối khác, nhấp chuột phải để hoàn tất việc đặt.
Theo mặc định, harness bundle được đặt bằng chế độ đặt Any Angle. Khi đặt harness bundle, nhấn Shift+Spacebar để chuyển qua các chế độ đặt. Chế độ này xác định cách tạo các góc khi đặt bundle và các góc mà bundle có thể được đặt. Khi ở chế độ 90 Degree hoặc 45 Degree (các chế độ trực giao thực sự), nhấn Spacebar để chuyển giữa các chế độ con bắt đầu và kết thúc. Chế độ hiện tại và chế độ con hiện tại được hiển thị trên Status Bar.

Ví dụ về một harness bundle được đặt giữa các điểm kết nối CP1 và CP_P2.
Khi đã được đặt và chọn, các đỉnh của một harness bundle có thể được kéo để thay đổi góc giữa hai đoạn liền kề.
Các thuộc tính của một harness bundle đã đặt (vị trí, biểu diễn trực quan, v.v.) có thể được cấu hình trong panel Properties khi harness bundle được chọn trong không gian thiết kế.

Panel Properties khi một harness bundle được chọn
Mỗi bó dây (bundle) sẽ tự động chứa các đối tượng (dây và/hoặc cáp) theo kết nối được định nghĩa trong sơ đồ đi dây. Các đối tượng này được liệt kê trong vùng Bundle Objects của bảng Properties khi chọn bó dây. Nhấp vào một đối tượng trong danh sách này để tô sáng tất cả các bó dây mà đối tượng đã chọn đi qua.
Sử dụng trường Length trong vùng Properties của bảng, bạn có thể xác định chiều dài của bó dây đã chọn. Chiều dài của các dây và cáp đi qua các bó dây được tính dựa trên các giá trị Length của các bó dây này. Các giá trị chiều dài dây/cáp được tính toán sẽ hiển thị trong cột Length Value của lưới trong vùng Bundle Objects của bảng.
Thêm Chế độ xem Đoạn dây
Chế độ xem đoạn dây hiển thị các dây nằm bên trong đoạn đó, tức là các dây riêng lẻ, các cặp dây xoắn và các dây là một phần của cáp. Điều này cho phép bạn thấy chính xác cách các dây được sắp xếp vật lý với nhau bên trong đoạn bó dây harness. Mỗi dây được gắn nhãn và tô màu theo màu đã định nghĩa của dây, cũng như độ dày của nó dựa trên giá trị tham số Thickness (được định nghĩa trên sơ đồ đi dây (*.WirDoc)). Bạn có thể đặt chế độ xem đoạn của một đoạn bó dây đã đặt vào bản vẽ bố trí (*.LdrDoc) bằng lệnh Add Segment View trong vùng Model của bảng Properties . Vùng Segment View sau đó sẽ hiển thị một danh sách thả xuống để bạn chọn mức Zoom cho chế độ xem được thêm vào. Không gian thiết kế sẽ phóng to vào chế độ xem như minh họa trong trình chiếu ví dụ bên dưới. Để xóa chế độ xem đoạn, sử dụng lệnh Delete trong vùng Segment View. Nhấp để chọn chế độ xem và di chuyển nó đến vị trí mong muốn trong không gian thiết kế.
Thêm Điểm ngắt
Một điểm ngắt, được dùng để cho biết bó dây Không theo tỷ lệ (NTS), có thể được đặt trên một bó dây harness. Bó dây sẽ hiển thị ký hiệu ngắt ở giữa đoạn dài nhất của nó như trong hình đầu tiên bên dưới, và các thuộc tính sẽ hiển thị Drawn Length. Để đặt điểm ngắt, bật tùy chọn Add Break Symbol trong vùng Properties của thuộc tính bó dây. Các lớp bọc harness bao phủ một bó dây harness có điểm ngắt cũng sẽ hiển thị điểm ngắt tại cùng vị trí đó. Nếu lớp bọc harness kết thúc tại điểm ngắt của bó dây harness, lớp bọc sẽ được vẽ dài hơn một chút, như minh họa trong hình thứ hai.
Bundles with Wires from Split Cables
Tất cả các bó dây harness bao gồm các dây từ một cáp harness được tách sẽ được tô sáng trên bản vẽ bố trí khi cáp đó được chọn trong vùng Bundle Objects của bảng Properties. Chiều dài của cáp được tách được xác định bởi chiều dài của dây dài nhất.
|
Cáp C1 được tách giữa các đầu nối khác nhau. Khi nhấp vào mục cáp trong vùng Bundle Objects của bảng Properties cho bó dây đã chọn, tất cả các bó dây có chứa dây từ C1 sẽ được tô sáng. Chiều dài của cáp được xác định bởi chiều dài của dây dài nhất (trong trường hợp này, các dây đi qua các bó B1 và B3 là dài nhất). |
No Connect Objects Within a Cable
Nếu sơ đồ đi dây bao gồm các đối tượng 'no connect' bên trong một cáp, thì không cần thêm các đối tượng này vào các điểm kết nối trong bản vẽ bố trí. Bó dây harness sẽ nhận diện chính xác các đối tượng của cáp. Xem ví dụ trong các hình bên dưới.
|
Một cáp trong tài liệu sơ đồ đi dây chứa các dây chưa được kết nối (W4 và W5). Các đối tượng 'no connect' không được gán cho các điểm kết nối trong bản vẽ bố trí. Tuy nhiên, bó dây vẫn nhận diện chính xác tất cả các đối tượng của cáp (bao gồm cả dây W4 và W5). |
Jumper Wires
Dây jumper có thể được hiển thị trong bản vẽ bố trí. Khi sơ đồ đi dây của một dự án harness bao gồm một dây kết nối các cavity của cùng một đầu nối harness, dây này sẽ được hiển thị trong bảng Properties như một đối tượng của bó dây harness tương ứng với đầu nối harness trên bản vẽ bố trí của dự án khi bó dây harness được chọn trong không gian thiết kế.
Gán lại các đối tượng bó dây
Bạn có thể gán lại các đối tượng bó dây trong bản vẽ bố trí, tại đó một dây có thể đi qua nhiều hơn một đường giữa các đầu nối nguồn và đích của nó. Mặc định, dây đó sẽ tự động được gán vào đường bó dây ngắn nhất, nhưng bạn có thể ghi đè hành vi này. Điều khiển Assign Objects to Bundle xuất hiện ở cuối phần Bundle Objects của bảng Properties (khi Bundle được chọn trong không gian thiết kế), và chỉ xuất hiện khi tồn tại một đường đi thay thế. Hộp thoại Assign Objects to Bundle sẽ mở ra, tại đó bạn có thể chọn các đối tượng (dây/cáp) để di chuyển giữa các bó dây hợp lệ và áp dụng được.
Phủ bọc các bó dây Harness
Một đối tượng lớp bọc harness (Place » Harness Covering) có thể được đặt phủ lên một bó dây harness. Chiều dài của lớp bọc có thể được chỉnh sửa bằng đồ họa trong không gian thiết kế trong hoặc sau khi đặt.
Sau khi chọn lệnh đặt lớp bọc harness, một chấm màu cam sẽ xuất hiện trong không gian thiết kế khi con trỏ ở trên một bó dây harness, cho biết rằng lớp bọc harness có thể được đặt tại đó (chấm màu xám cho biết không thể đặt lớp bọc harness tại vị trí cụ thể đó). Nhấp vào nơi bạn muốn lớp bọc bắt đầu, sau đó di chuyển con trỏ dọc theo bó dây đến điểm bạn muốn lớp bọc kết thúc, rồi nhấp lại. Các lớp bọc harness có thể chồng lấp lên nhau, như minh họa trong video bên dưới. Ngoài ra, bạn có thể áp dụng/mở rộng một lớp bọc harness qua một điểm nút (một điểm kết nối trong bản vẽ bố trí nơi hai hoặc nhiều bó dây gặp nhau). Điều này giúp không cần các lớp bọc harness riêng biệt giữa các điểm nút trong một phần chứa nhiều đầu nối.
Điểm bắt đầu của một lớp bọc được lấy là điểm ngoài cùng bên trái, phía trên cùng của đường đi của nó, và đường đi chỉ bao gồm các bó dây mà lớp bọc nằm trên đó.
Các thuộc tính của một lớp bọc harness đã đặt có thể được cấu hình trong bảng Properties khi lớp bọc harness được chọn trong không gian thiết kế.

Bảng Properties khi một lớp bọc harness được chọn
Bạn có thể xác định kích thước của một đối tượng lớp bọc harness so với kích thước của bó dây mà nó đang phủ (giá trị Line Width của bó dây) bằng danh sách thả xuống Size trong bảng Properties. Cuộn qua các hình bên dưới để xem ví dụ về các lớp bọc harness có kích thước khác nhau với nhiều kích thước bó dây khác nhau.
Thêm Nhãn bố trí
Nhãn vật lý có thể được đặt vào bản vẽ bố trí (Place » Layout Label).
Các thuộc tính của một nhãn bố trí đã đặt (ký hiệu, văn bản, biểu diễn trực quan, v.v.) có thể được cấu hình trong bảng Properties khi nhãn bố trí được chọn trong không gian thiết kế.

Bảng Properties khi một nhãn bố trí được chọn
Khi xác định văn bản của nhãn trong trường Text, sử dụng Ctrl+Enter hoặc Shift+Enter để thêm một dòng văn bản mới. Bật Show only first line để chỉ hiển thị dòng đầu tiên của trường Text trong không gian thiết kế. Văn bản nhãn bố trí cũng có thể được căn chỉnh theo nhu cầu của bạn bằng các điều khiển Alignment.
Cập nhật các đối tượng bản vẽ bố trí từ thư viện
Các đối tượng sau có thể được cập nhật từ thư viện Workspace nguồn của chúng:
-
Các thành phần harness
-
Các part liên kết với các thành phần harness
-
Các part liên kết với các điểm kết nối
-
Các lớp bọc harness
-
Các nhãn bố trí
Khi một đối tượng được chọn, thông tin về thành phần Workspace được liên kết có thể được tìm thấy trong bảng Properties (ví dụ: tab Associated Parts cho các part liên kết của một thành phần harness hoặc vùng General cho một nhãn bố trí).
Nếu có sẵn một revision mới hơn của thành phần Workspace, mục trạng thái revision sẽ phản ánh điều này bằng văn bản Out of date. Ở cấp độ từng đối tượng riêng lẻ, liên kết có thể được cập nhật lên revision mới nhất của thành phần Workspace bằng cách nhấp nút
.
Một ví dụ về việc chỉ ra revision của thành phần harness đã lỗi thời
Tính năng Update from Libraries (Tools » Update from Libraries) cũng có thể được sử dụng để cập nhật các thành phần đã lỗi thời được liên kết với các đối tượng được liệt kê ở trên. Lưu ý rằng để một đối tượng được bao gồm trong quá trình cập nhật bằng tính năng Update from Libraries, thành phần được gán cho đối tượng đó phải bao gồm một liên kết đến schematic symbol.
Đánh số các đối tượng trong bản vẽ bố trí Harness
Sử dụng các lệnh trong menu Tools » Annotation để đánh số các đối tượng sau trong tài liệu bản vẽ bố trí harness:
-
Các thành phần harness
-
Các điểm kết nối
-
Các bó dây harness
-
Các lớp bọc harness
-
Các nhãn bố trí
Việc đánh số các đối tượng trong tài liệu bản vẽ bố trí harness tương tự như đánh số các thành phần trong tài liệu schematic (*.SchDoc) của một dự án thiết kế PCB. Sử dụng các liên kết sau để tìm hiểu thêm về các lệnh đánh số có sẵn cho tài liệu bản vẽ bố trí harness:
Cross Probing giữa Sơ đồ đi dây và Bản vẽ bố trí
Cross-probing giữa sơ đồ đi dây và bản vẽ bố trí của một dự án harness được hỗ trợ. Lệnh Cross Probe có thể được truy cập từ menu chính Tools và menu nhấp chuột phải trong không gian thiết kế.
Cross-probing có thể được thực hiện:
-
Giữa các thành phần trong sơ đồ đi dây và bản vẽ bố trí.
-
Từ một dây trong sơ đồ đi dây đến (các) bó dây mà dây này đi qua trong bản vẽ bố trí.
-
Từ một bó dây trong bản vẽ bố trí đến (các) dây đi qua bó dây này trong sơ đồ đi dây.
|
Cross-probing từ một thành phần trong sơ đồ đi dây đến thành phần tương ứng trong bản vẽ bố trí. Cross-probing từ một thành phần trong bản vẽ bố trí đến thành phần tương ứng trong sơ đồ đi dây. Cross-probing từ một dây trong sơ đồ đi dây đến các bó dây tương ứng trong bản vẽ bố trí. Cross-probing từ một bó dây trong bản vẽ bố trí đến các dây tương ứng trong sơ đồ đi dây. |
).






).
).
).
).
).
).




).










)
).
).



