Phát hành lên Workspace
Sơ lược
- Xác định các bộ dữ liệu nguồn, chế tạo, lắp ráp, biến thể và tùy chỉnh cần đưa vào, cùng cách gán các Output Job cần thiết.
- Hiểu các tùy chọn đích phát hành, quy tắc đặt tên mục trong Workspace và các thiết lập kiểm soát bản sửa đổi đích.
- Thực hiện theo các giai đoạn phát hành và tìm hiểu cách các lệnh phát hành tự động ảnh hưởng đến việc xem xét, lập báo cáo và xuất bản lên PLM.
Với chế độ xem Release trong Online Mode, quy trình phát hành diễn ra theo từng giai đoạn; các mục ở bên trái chế độ xem giúp bạn nhanh chóng nhận biết mình đang ở giai đoạn nào:
-
Configure Server Release – ở giai đoạn này của quy trình phát hành, bạn chỉ định (các) loại dữ liệu muốn tạo: Dữ liệu nguồn (luôn được tạo), Dữ liệu chế tạo, Dữ liệu lắp ráp (cho thiết kế cơ sở và từng biến thể được phát hiện).
-
Validate Project – giai đoạn tiếp theo này của quy trình phát hành được chạy tự động khi phát hiện một hoặc nhiều báo cáo loại Xác thực trong (các) tệp OutJob đã được gán. Tất cả các trình tạo đầu ra xác thực được định nghĩa trong tệp Output Job đã gán cho mục dữ liệu đang phát hành đều được chạy.
-
Generate Data – giai đoạn tiếp theo này của quy trình phát hành được chạy tự động. Tại đây, tất cả các đầu ra khác – được định nghĩa trong (các) tệp OutJob đã gán cho các Mục dữ liệu được đưa vào – đều được chạy để tạo dữ liệu sẽ phát hành vào các mục đích tương ứng trong Workspace.
-
Review Data – sau khi tất cả các bước kiểm tra xác thực đều đạt và dữ liệu đầu ra đã được tạo, giai đoạn này của quy trình phát hành cho phép bạn xem lại dữ liệu đã tạo.
-
Upload Data – sau khi bạn xác nhận phát hành ở giai đoạn trước, quy trình sẽ tự động chuyển sang giai đoạn này. Giai đoạn này chỉ hiển thị tiến trình tải dữ liệu lên các bản sửa đổi của các Mục dữ liệu tương ứng trong Workspace đích.
-
Execution Report – đây là giai đoạn cuối cùng của quy trình, cung cấp thông tin tóm tắt về đợt phát hành. Các liên kết điều hướng được cung cấp để nhanh chóng truy cập các Bản sửa đổi mục đã tạo trong bảng Explorer. Nếu bạn đã truy cập Project Releaser trong một quy trình phát hành và xuất bản lên PLM, nút
sẽ xuất hiện. Nhấp vào nút này để tiếp tục luồng công việc nền của quy trình và xuất bản lên PLM.
-
Publish to PLM – giai đoạn này chỉ xuất hiện khi thực hiện phát hành theo quy trình tương ứng đã được kích hoạt (để phát hành rồi xuất bản lên PLM). Quy trình tự động chuyển sang giai đoạn này khi nhấp vào nút
ở giai đoạn trước (hoặc chuyển thẳng đến đây nếu sử dụng lệnh Prepare & Release & Publish to PLM từ menu của nút Hộp thoại Login Credentials sẽ xuất hiện. Nhập Username và Password cho phiên bản triển khai PLM của bạn, rồi chọn Mẫu PLM muốn sử dụng (hiển thị dưới dạng <PLMInstance>:<PublishingTemplate>).
Giai đoạn trực tuyến 1 – Cấu hình phát hành lên máy chủ
Ở giai đoạn này của quy trình phát hành, bạn chỉ định (các) loại dữ liệu muốn tạo. Các Mục dữ liệu có thể phát hành gồm:
- Source Data – ảnh chụp trạng thái của thiết kế nguồn.
- Fabrication Data – dữ liệu mà đơn vị chế tạo cần để sản xuất bo mạch trần.
- Assembly Data for the Base Design (no variations) – dữ liệu mà đơn vị lắp ráp cần để gắn đầy đủ linh kiện lên bo mạch trần theo Danh mục vật tư, dành cho thiết kế cơ sở không có biến thể.
-
Assembly Data for Design
Variant n– dữ liệu mà đơn vị lắp ráp cần để gắn linh kiện lên bo mạch trần theo Danh mục vật tư, dành choVariant ncủa thiết kế cơ sở.
Số lượng bộ dữ liệu lắp ráp sẽ tương ứng với thiết kế cơ sở (không có biến thể) và tất cả các biến thể được phát hiện đã định nghĩa cho thiết kế đó.

Giai đoạn 1 của quy trình phát hành dự án – cấu hình nội dung sẽ đưa vào đợt phát hành (dữ liệu cần tạo).
Mục Source Data luôn được đưa vào đợt phát hành. Các mục dữ liệu khác có thể được đưa vào tùy chọn.
Gán các Output Job
Để đưa các mục Fabrication Data và Assembly Data vào đợt phát hành, phải gán ít nhất một tệp OutputJob cho chúng. Nếu bạn có các tệp Output Job với tên bắt đầu bằng các chuỗi con 'fab' và 'ass', các OutJob đó sẽ tự động được gán lần lượt cho các phần Fabrication Data và Assembly Data khi truy cập chế độ xem Release lần đầu. Nếu không, bạn cần gán thủ công các OutJob phù hợp cho từng trường hợp. Bạn có thể thực hiện việc này từ tab Release Options của hộp thoại Project Release Options (nhấp vào nút
ở góc dưới bên trái chế độ xem để truy cập).

Gán các OutJob cho các bộ dữ liệu tương ứng theo yêu cầu.
Chuyển đổi đích phát hành
Tab Release Options của hộp thoại Project Release Options cũng có thể được dùng để thay đổi đích phát hành – chuyển đổi giữa chế độ hoạt động được quản lý (Online) và không được quản lý (Offline). Có ba tùy chọn:
-
Unmanaged - Folder(Offline): chọn tùy chọn này để phát hành dữ liệu đã tạo vào một thư mục cục bộ. Đường dẫn thư mục gốc được chỉ định trên tab Output Path của hộp thoại. Theo mặc định, đường dẫn này được đặt thành[OutputPath](sử dụng đường dẫn được định nghĩa trong trường Output Path, trên tab Options của hộp thoại Project Options). -
Unmanaged - Zip(Offline): chọn tùy chọn này để phát hành dữ liệu đã tạo vào một thư mục cục bộ. Dữ liệu sẽ được đóng gói thành một tệp Zip duy nhất. Đường dẫn/tên tệp Zip được chỉ định trên tab Output Path của hộp thoại. Theo mặc định, giá trị này được đặt thành[OutputPath][ProjectName].zip(sử dụng đường dẫn được định nghĩa trong trường Output Path trên tab Options của hộp thoại Project Options). -
Managed - <WorkspaceName>(Online): chọn tùy chọn này để phát hành lên Workspace (cóWorkspaceName) mà bạn hiện đang kết nối.

Thay đổi đích phát hành – nơi dữ liệu được tạo sẽ được gửi đến – trong các tùy chọn phát hành của dự án.
Thiết lập quy tắc đặt tên Item trong Workspace
Khi phát hành dự án đến Workspace đích lần đầu tiên, bạn có thể xác định cách đặt tên cho các Item dữ liệu đích trong Workspace đó (các bản sửa đổi của chúng sẽ nhận dữ liệu được tạo). Thao tác này được thực hiện trên tab Item Naming của hộp thoại Project Release Options, được truy cập bằng cách nhấn nút
ở góc dưới bên trái của chế độ xem (hoặc nhấp vào liên kết Target Revision của một bộ dữ liệu cần phát hành và chọn Edit từ menu ngữ cảnh). Sử dụng tab này để:
- Xác định tên dự án. Theo mặc định, trường này sẽ được điền bằng tên thực tế của dự án.
-
Xác định các quy tắc đặt tên mặc định cho những Item dữ liệu khác nhau có thể được tạo trong quá trình phát hành. Nhấp vào một trường trong cột Item ID, sau đó nhấp vào nút
ở bên phải trường để truy cập hộp thoại Choose Item (một dạng của bảng Explorer), cho phép bạn chọn một Item hiện có trong Workspace đang kết nối làm đích.
Để thay đổi bất kỳ quy tắc đặt tên nào, hãy nhấp vào nút Settings để truy cập hộp thoại Naming Template Settings.

Đặt tên dự án và xác định cách đặt tên cho các Item dữ liệu được tạo trong Workspace đích. Ở đây, các trường có thể chỉnh sửa vì dự án chưa được phát hành.
Các định dạng macro sau được hỗ trợ trong mẫu đặt tên:
-
Parameter-based – hỗ trợ sử dụng các tham số đặt trong dấu ngoặc vuông (ví dụ:
[ProjectName],[VariantName],[ProjectParameter]). -
Numeric-based – hỗ trợ sử dụng các định lượng số đặt trong dấu ngoặc nhọn (ví dụ:
{0000},{9000}).
Kiểm soát bản sửa đổi đích
Quay lại chế độ xem chính, nhấp vào liên kết bên cạnh một mục Target Revision để truy cập menu lệnh, như minh họa trong hình sau:

Truy cập các tùy chọn điều khiển để chỉ định bản sửa đổi đích cho một bộ dữ liệu sẽ được tạo trong quá trình phát hành – di chuột lên hình ảnh để xem.
Các lệnh khả dụng sẽ phụ thuộc vào việc Item đã được phát hành lần đầu hay chưa. Dưới đây là danh sách tất cả các lệnh có thể có:
-
Auto <RevisionID> – mục này cho phép hệ thống xử lý các bản sửa đổi, nhờ đó bạn không cần tạo các bản sửa đổi dự kiến nếu chúng chưa tồn tại.
RevisionIDhiển thị bản sửa đổi tiếp theo của Item ở cùng cấp trong quy tắc đặt tên bản sửa đổi đã được gán (ví dụ: nếu bản sửa đổi hiện tại làA.1, lệnh này sẽ hiển thị đích làA.2). -
Next <RevisionID> – mục này chỉ khả dụng sau lần phát hành đầu tiên của Item. Sử dụng mục này để nhanh chóng tăng bản sửa đổi đích ở cấp tiếp theo trong quy tắc đặt tên bản sửa đổi đã được gán.
RevisionIDhiển thị bản sửa đổi tiếp theo (ví dụ: nếu bản sửa đổi hiện tại làA.1, lệnh này sẽ chuyển đích thànhB.1). -
Custom – sử dụng mục này để chọn một bản sửa đổi cụ thể của Item đích bằng cách xác định ID bản sửa đổi tùy chỉnh thông qua hộp thoại Custom Revision ID. Tùy thuộc vào quy tắc đặt tên bản sửa đổi được sử dụng, hộp thoại có thể có tối đa ba trường ID cấp. Lưu ý rằng ID của bản sửa đổi dự kiến đầu tiên của Item có thể được thay đổi bất cứ lúc nào sau khi Item được tạo và trước khi dữ liệu được phát hành vào bản sửa đổi đầu tiên đó (tức là bản sửa đổi vẫn ở trạng thái
Planned). - Browse – sử dụng mục này để trỏ đến một bản sửa đổi Item đích hiện có để phát hành dữ liệu vào đó. Hộp thoại Choose Target Item (một dạng của bảng Explorer) sẽ xuất hiện để thực hiện thao tác này.
- Edit – sử dụng mục này để truy cập tab Item Naming của hộp thoại Project Release Options, từ đó bạn có thể thay đổi tên của Item đích (và bản sửa đổi đầu tiên) sẽ được tạo.
- Navigate – sử dụng mục này để nhanh chóng điều hướng đến Item trong bảng Explorer (nơi Item đã được phát hành và bản sửa đổi tiếp theo tồn tại ở trạng thái dự kiến).
Mục ở đầu menu sẽ phản ánh bản sửa đổi đích hiện được chọn/xác định.
Truy cập chi tiết tạo dữ liệu
Nhấp vào nút điều khiển Details – ở ngoài cùng bên phải tiêu đề của bộ dữ liệu – để truy cập thông tin chi tiết về chính xác những gì bộ dữ liệu đó sẽ tạo ra. Thu gọn chế độ xem mở rộng này bằng cách nhấp vào nút điều khiển Hide Details. Ngoại trừ bộ Source Data, dữ liệu được tạo sẽ lấy từ một hoặc nhiều tệp Output Job đã được gán. Bạn có thể truy cập nhanh OutJob nguồn bằng cách nhấp vào nút điều khiển Configure.

Truy cập chế độ xem chi tiết của một bộ dữ liệu để xem dữ liệu nào sẽ được tạo – di chuột lên hình ảnh để xem.
Cài đặt bổ sung
Bạn có thể xác định các cài đặt bổ sung liên quan đến việc phát hành dự án trên trang Data Management – Servers của hộp thoại Preferences:
-
Thư mục dùng để lưu tạm các tệp được tạo trước khi tải lên Workspace đang kết nối có thể được đặt thành vị trí tự động (
\Users\<ProfileName>\AppData\Local\Temp\Releasesđối với cài đặt mặc định), hoặc được chỉ định thủ công bằng một thư mục do bạn chọn. - Bật tùy chọn Delete contents after exiting release mode để dọn sạch thư mục lưu trữ tạm thời sau khi hoàn tất quá trình phát hành.
- Tên của mỗi đầu ra được tạo có thể được thêm tiền tố là ID mục và ID phiên bản (ví dụ:
[FAB-Kame_FMU-A.1] Validation.PDF). Để thực hiện, hãy bật tùy chọn Prepend revision HRID to file names.

Các tùy chọn bổ sung liên quan đến quy trình phát hành dự án.
Sau khi cấu hình các mục dữ liệu sẽ được tạo trong quá trình phát hành theo yêu cầu, hãy nhấp vào nút
ở góc dưới bên phải của chế độ xem để tiếp tục.
Một số bước kiểm tra trước khi phát hành được thực hiện trong quá trình chuẩn bị, bao gồm:
- Bảo đảm dự án và tất cả các tệp đã được lưu.
- Bảo đảm dự án và tất cả các tệp liên quan đã được commit vào VCS, nếu có áp dụng.
- Bảo đảm mỗi mục dữ liệu được bật đều đã được đặt tên.
- Bảo đảm người dùng có quyền tạo mục đích (và phiên bản).
- Tạo các mục đích cần thiết (và các phiên bản dự kiến) trong Workspace nếu chúng chưa tồn tại, đồng thời bảo đảm sử dụng phiên bản tiếp theo cho những mục đã tồn tại.
Nếu phát hiện bất kỳ vấn đề nào, bạn sẽ được cung cấp các giải pháp để khắc phục (chẳng hạn như lưu các tệp đã sửa đổi cục bộ và commit vào VCS).
Mục Source Data được tạo tại thời điểm này – với bản chụp các tệp dự án thiết kế nguồn được phát hành vào phiên bản của mục đích.
Giai đoạn trực tuyến 2 – Xác thực dự án
Sau khi Giai đoạn 1 hoàn tất mà không gặp vấn đề, giai đoạn tiếp theo này của quy trình phát hành sẽ tự động chạy khi phát hiện một hoặc nhiều báo cáo loại Xác thực trong các tệp OutJob được chỉ định. Tất cả các bộ tạo đầu ra xác thực được định nghĩa trong tệp Output Job được chỉ định cho mục dữ liệu đang phát hành đều sẽ chạy. Các tác vụ này bao gồm:
- Differences Report – sử dụng bộ so sánh để xác định xem các tài liệu thiết kế nguồn và PCB có được đồng bộ chính xác hay không.
- Electrical Rules Check – kiểm tra tính hợp lệ về điện và quy cách vẽ của thiết kế nguồn đã được ghi nhận.
- Design Rules Check – kiểm tra tính hợp lệ của tài liệu PCB theo các ràng buộc thiết kế cấp bo mạch đã chỉ định.
-
BOM Checks – kiểm tra các vi phạm có thể xảy ra liên quan đến các mục thiết kế hoặc lựa chọn linh kiện trong tài liệu BOM nguồn (
*.BomDoc), nếu có. - Footprint Comparison Report – so sánh các footprint trên bo mạch với thư viện nguồn để bảo đảm chúng được cập nhật và khớp nhau.
- Component State Checking – kiểm tra các linh kiện đang ở trạng thái bị hạn chế. Trong quá trình cấu hình, bạn xác định hành động cần thực hiện đối với từng trạng thái hiện được định nghĩa, thuộc từng định nghĩa vòng đời hiện có trong Workspace đích: không thực hiện hành động nào, đưa ra cảnh báo hoặc tạo lỗi. Tùy chọn cuối cùng sẽ ngăn việc phát hành thiết kế. Ngoài ra, quá trình kiểm tra sẽ tạo một báo cáo HTML hữu ích, cho phép bạn nhanh chóng nhận biết những linh kiện thiết kế nào không ở trạng thái hợp lệ.
- Environment Configuration Compliance Check – kiểm tra để bảo đảm chỉ sử dụng các mục dữ liệu được cho phép thông qua cấu hình môi trường dành cho vai trò được gán cho bạn (nếu có áp dụng). Bước kiểm tra này cũng có thể bảo đảm rằng tất cả các mục thiết kế đều có nguồn từ một Workspace.
Nếu xác thực thành công, biểu tượng
sẽ xuất hiện cùng với văn bản Passed. Nếu không, biểu tượng
sẽ được hiển thị cùng với văn bản Failed.
Giai đoạn trực tuyến 3 – Tạo dữ liệu
Sau khi Giai đoạn 2 hoàn tất mà không gặp vấn đề, giai đoạn tiếp theo này của quy trình phát hành sẽ tự động chạy. Đây là lúc tất cả các đầu ra khác – được định nghĩa trong các tệp OutJob được chỉ định cho các mục dữ liệu đi kèm – được thực thi để tạo dữ liệu cần phát hành vào các mục đích tương ứng trong Workspace.
Tương tự các giai đoạn khác, nhưng dễ nhận thấy hơn ở giai đoạn này do thời gian thực hiện lâu hơn, các biểu tượng được dùng để hiển thị tiến trình tạo dữ liệu:
– chưa chạy/tạo.
– đang chạy/tạo.
– đã tạo thành công.
– tạo thất bại.
Giai đoạn trực tuyến 4 – Xem xét dữ liệu
Sau khi tất cả các bước kiểm tra xác thực đều đạt và dữ liệu đầu ra đã được tạo, giai đoạn này của quy trình phát hành cho phép bạn xem xét dữ liệu đã tạo.

Xem xét dữ liệu đã tạo, kiểm tra để bảo đảm mọi thứ đều đúng như yêu cầu trước khi xác nhận phát hành và tải dữ liệu lên Workspace.
Theo mặc định, trang hiển thị dữ liệu đã tạo ở chế độ xem đơn giản (thu gọn). Chuyển sang chế độ xem chi tiết hơn bằng cách nhấp vào điều khiển Details của phần bạn quan tâm.

Nhấp vào điều khiển Details để chuyển từ chế độ xem đơn giản sang chế độ xem chi tiết của dữ liệu đã tạo trong phần tương ứng. Chuyển lại bằng cách nhấp vào điều khiển Hide Details.
Các trạng thái tạo đầu ra trong chế độ xem chi tiết
Bảng sau liệt kê các trạng thái đầu ra có thể xuất hiện khi dữ liệu đang được tạo và được theo dõi trong chế độ xem chi tiết:
Trạng thái |
Mô tả |
|---|---|
|
Đầu ra chưa được tạo/không tồn tại. |
|
Đầu ra đã được tạo, nhưng sau đó thiết kế đã có thay đổi, khiến dữ liệu này không còn hợp lệ với thiết kế hiện tại. |
|
Đầu ra hiện đang trong quá trình được tạo. |
|
Đầu ra dựa trên xác thực và đã tạo báo cáo không có lỗi. Đối với báo cáo ERC, hoặc không có lỗi, hoặc mức độ lỗi nằm trong mức lỗi tối đa cho phép đã chỉ định cho báo cáo đó. |
|
Đầu ra (không bao gồm các đầu ra dựa trên xác thực) đã được tạo thành công. |
|
Đầu ra chưa được tạo thành công. Đối với đầu ra dựa trên xác thực, điều này có nghĩa là các tài liệu thiết kế nguồn có lỗi khiến một số bước kiểm tra không đạt. Đối với đầu ra tiêu chuẩn, đầu ra không thể được tạo thành công. Có thể đã xảy ra lỗi nghiêm trọng khi thực hiện xác thực trước khi tạo, hoặc có vấn đề trong cấu hình của bộ tạo đầu ra tương ứng trong tệp Output Job. |
Trong chế độ xem thu gọn của dữ liệu đã tạo, nhấp vào liên kết View để mở tệp dữ liệu hoặc bộ tệp tương ứng trong trình biên tập thích hợp của Altium Designer (ví dụ: trình biên tập CAM dành cho tệp Gerber hoặc tệp ODB++ đã nén/chưa nén), hoặc trong ứng dụng bên ngoài thích hợp (ví dụ: Microsoft Excel dành cho bảng kê vật liệu). Trong chế độ xem chi tiết, nhấp đúp vào một mục để chỉ xem tệp đó.
Một cách kiểm tra mức độ sẵn sàng phát hành thường được nhiều nhà thiết kế sử dụng là so sánh các tệp Gerber được tạo từ bản phát hành hiện tại với các tệp Gerber của bản phát hành trước. Nhấp vào liên kết Compare Gerber bên cạnh một đầu ra Gerber và chọn bản phát hành trước từ menu thả xuống để so sánh dữ liệu Gerber đã chuẩn bị với dữ liệu của bản phát hành đã chọn. Trình duyệt mặc định sẽ mở Workspace của công ty bạn và hiển thị kết quả.

Truy cập tính năng so sánh Gerber từ Project Releaser, trước khi phát hành dữ liệu lên Workspace.
► Tìm hiểu thêm về tính năng Gerber Comparison (Altium 365 Workspace, Enterprise Server Workspace).
Nếu sau khi xem xét dữ liệu, bạn thấy cần chỉnh sửa, hãy nhấp vào nút
ở góc dưới bên phải của chế độ xem. Một hộp thoại xác nhận sẽ xuất hiện, cảnh báo rằng toàn bộ dữ liệu đã tạo sẽ bị mất – nhấp vào OK sẽ hủy quá trình phát hành và đưa bạn trở lại Giai đoạn 1 của quy trình.
Nếu toàn bộ dữ liệu đã tạo đều ổn, hãy tiếp tục phát hành bằng cách nhấp vào nút
(cũng ở góc dưới bên phải của chế độ xem). Hộp thoại Confirm Release sẽ xuất hiện, tóm tắt các cấu hình của dự án sẽ được phát hành lên Workspace. Tại đây, bạn cũng có thể thêm Name (mặc định, nội dung ở đây là [ProjectName]), Description và các ghi chú phát hành liên quan.

Xác nhận nội dung sẽ được phát hành, bao gồm các phiên bản Item được tạo, cùng khả năng thay đổi Tên/Mô tả và thêm ghi chú phát hành.
Giai đoạn trực tuyến 5 – Tải dữ liệu lên
Sau khi xác nhận phát hành ở giai đoạn trước, hệ thống sẽ tự động chuyển sang giai đoạn này. Giai đoạn này chỉ hiển thị tiến trình tải dữ liệu lên các phiên bản của những Item dữ liệu tương ứng trong Workspace.

Giai đoạn này chỉ phản ánh tiến trình tải dữ liệu đã tạo lên các phiên bản Item được liên kết trong Workspace.
Giai đoạn trực tuyến 6 – Báo cáo thực thi
Đây là giai đoạn cuối cùng của quy trình, cung cấp bản tóm tắt về lần phát hành.

Báo cáo cuối cùng về lần phát hành.
Sử dụng các Liên kết điều hướng để truy cập nhanh phiên bản Item tương ứng chứa dữ liệu đã phát hành (Dữ liệu chế tạo, Dữ liệu lắp ráp và mọi bộ Dữ liệu tùy chỉnh) trong bảng Explorer – cổng truy cập Workspace của bạn.

Xem dữ liệu đã phát hành của dự án ngay trong Workspace thông qua bảng Explorer.
Xem dự án đã phát hành
Đối với dự án Workspace, bạn có thêm một chức năng sau khi hoàn tất phát hành. Nhấp vào liên kết Project Page, liên kết cuối cùng trong các Liên kết điều hướng ở đầu trang Execution Report, sẽ mở bảng Explorer, hiển thị dự án trong Project View – chỉ khả dụng cho các dự án Workspace.

Bạn có thể khám phá chi tiết hơn một dự án Workspace trong bảng Explorer thông qua Project View.
Vùng Releases (ở phía dưới bên trái của chế độ xem) sẽ hiển thị thông tin tổng hợp về các bản phát hành gắn với dự án, bao gồm bản tóm tắt của từng bản phát hành và các gói thành phần của bản phát hành đó. Nhấp vào nút
trong vùng này để mở hộp thoại Thay đổi trạng thái hàng loạt, cho phép bạn thay đổi trạng thái vòng đời của nhiều mục liên quan đến cùng một bản phát hành đồng thời trong một quy trình xử lý hàng loạt.
Bạn cũng có thể truy cập thông tin phát hành của dự án trong Trình xem web của Workspace đích, được mở bằng nút
trên bảng Explorer. Trong Trình xem web của Workspace, bạn có thể truy cập tất cả các bản phát hành gắn với dự án trong chế độ xem Releases – hoặc chế độ xem Manufacture đối với Workspace do máy chủ tại chỗ cung cấp. Trang này liệt kê tất cả các bản phát hành dự án, với mục mới nhất ở trên cùng; bạn có thể mở từng bản phát hành trong Manufacturing Portal của Workspace bằng nút mở tương ứng Chế độ xem Manufacturing Portal cung cấp thông tin chi tiết hơn về Bản phát hành đã chọn, bao gồm các tệp thuộc gói phát hành, toàn bộ tài liệu thiết kế, cùng thông tin Nhà sản xuất và Nhà cung cấp linh kiện. Lưu ý rằng tính năng Send to Manufacturer chỉ khả dụng trong Altium 365 Workspace. ► Xem trang Chế độ xem bản phát hành của Altium 365 Workspace để biết thêm thông tin.
Vậy là xong – sau khi dự án đã được phát hành, bạn chỉ cần đóng chế độ xem Release (bằng nút
ở góc dưới bên phải của chế độ xem). Khi cần phát hành lại cùng dự án trong tương lai, Project Releaser giúp bạn thực hiện nhanh chóng, dễ dàng và tự động tăng số phiên bản Item đích.
Xuất bản lên một hệ thống PLM
Related pages: Tích hợp PLM (Altium 365 Workspace, Enterprise Server Workspace), Xuất bản lên PLM
Bạn có thể xuất bản thiết kế lên một hệ thống PLM trong quá trình chạy Project Releaser trong Altium Designer. Thao tác xuất bản sử dụng một mẫu xuất bản – được xác định trong cấu hình tích hợp của hệ thống PLM đó – để kiểm soát cách dữ liệu được chuyển sang PLM. Tính năng này khả dụng thông qua một quy trình được cấu hình phù hợp. Một định nghĩa quy trình mẫu được cung cấp kèm theo bản cài đặt – Project Releaser with Publish – với luồng công việc bên dưới cho phép xuất bản lên hệ thống PLM đã tích hợp như một giai đoạn bổ sung của Project Releaser. Sơ đồ luồng công việc được trình bày bên dưới.

Sơ đồ luồng công việc của định nghĩa quy trình mẫu Project Releaser with Publish mặc định
Sau khi được kích hoạt, quy trình xuất bản lên hệ thống PLM trong khuôn khổ Project Releaser có thể được truy cập từ Altium Designer qua menu con Project » Project Releaser của dự án đang hoạt động hoặc qua menu con ngữ cảnh Project Releaser, mở bằng cách nhấp chuột phải vào mục dự án thiết kế trong bảng Projects.

Truy cập quy trình xuất bản lên hệ thống PLM trong khuôn khổ Project Releaser
Project Releaser sẽ xuất hiện, với một giai đoạn bổ sung – 7. Publish to PLM. Ngoài ra, menu gắn với nút
còn có lệnh Prepare & Release & Publish to PLM nếu bạn muốn chạy Project Releaser mà không dừng lại để xem xét dữ liệu đã tạo và báo cáo thực thi.

Lệnh bổ sung để chạy Project Releaser mà không dừng lại để xem xét dữ liệu đã tạo và báo cáo thực thi
Nếu bạn chạy Project Releaser bằng lệnh Prepare tiêu chuẩn, sau khi xem xét và phát hành dữ liệu, nút
sẽ xuất hiện ở giai đoạn Execution Report. Nhấp vào nút này để tiếp tục luồng công việc bên dưới của quy trình nhằm xuất bản lên PLM. Hộp thoại Login Credentials sẽ xuất hiện. Nhập Username và Password cho hệ thống PLM của bạn, rồi chọn mẫu PLM mà bạn muốn sử dụng (hiển thị theo dạng <PLMInstance>:<PublishingTemplate>).

Hộp thoại Login Credentials được truy cập trong lần đầu xuất bản lên hệ thống PLM.
Nhấp vào thẻ Diagram để xem luồng công việc bên dưới của quy trình.

Thẻ Diagram của hộp thoại Login Credentials
Nhấp vào nút
để tiếp tục quá trình xuất bản theo luồng công việc đó.
).
