Tạo & Quản lý Quy trình

Altium Designer cung cấp một môi trường thiết kế cộng tác mạnh mẽ. Một phần trong đó là hỗ trợ cho Workflows, giúp hướng dẫn các nhà thiết kế trong công ty thực hiện những quy trình thiết kế điển hình hằng ngày như:

  • Yêu cầu thêm linh kiện thư viện Workspace mới
  • Thực hiện review thiết kế
  • Tạo dự án Workspace mới.

Mỗi Workflow được dùng để triển khai một quy trình thiết kế cụ thể sẽ được tạo như một phần của Process Definition. Vì vậy, nó có thể được gọi là Workflow nền tảng của quy trình đó, hoặc đơn giản là một Process Workflow.

Các quy trình và Workflow của chúng được tạo và quản lý thông qua giao diện trình duyệt của Enterprise Server Workspace – bởi Quản trị viên của Workspace đó.

Đối với ba lĩnh vực thiết kế đã đề cập ở trên, các workflow quy trình được định nghĩa sẵn đã được bao gồm trong bản cài đặt máy chủ của bạn. Một số trong đó được kích hoạt để sử dụng ngay từ đầu. Hãy dùng chúng, chỉnh sửa chúng hoặc tạo mới theo nhu cầu để phù hợp với yêu cầu của công ty bạn. Một số khác là mẫu – không thể kích hoạt và sử dụng nguyên trạng. Vì vậy, mỗi mẫu này giống như một “template” hơn – hãy chỉnh sửa cho phù hợp với yêu cầu của công ty bạn, đặt tên và lưu thành một định nghĩa quy trình mới, sau đó bạn can kích hoạt và sử dụng cùng với tất cả các định nghĩa khác.

Một Process Workflow Editor mạnh mẽ mang lại sự linh hoạt để bạn xây dựng các quy trình với workflow có thể đơn giản hoặc phức tạp tùy nhu cầu, và phù hợp với yêu cầu của công ty bạn.

Truy cập Processes

Mọi thao tác quản lý quy trình đều được thực hiện trong khu vực Processes (Admin – Processes) của giao diện trình duyệt Enterprise Server Workspace.

Bạn phải đăng nhập với tư cách Quản trị viên của Enterprise Server Workspace thì mới có thể thấy khu vực Processes của giao diện.

Truy cập khu vực Processes trong giao diện trình duyệt của Enterprise Server Workspace – trung tâm điều khiển để làm việc với các quy trình và workflow liên quan của chúng.Truy cập khu vực Processes trong giao diện trình duyệt của Enterprise Server Workspace – trung tâm điều khiển để làm việc với các quy trình và workflow liên quan của chúng.

Giao diện Processes được trình bày trên bốn tab sau:

  • Browser – cung cấp danh sách tóm tắt của tất cả quy trình (đang hoạt động hoặc đã đóng). Có thể xem đây là một “bảng điều khiển quy trình” tập trung.
  • Part Requests – cung cấp một khu vực chuyên dụng để quản lý các quy trình liên quan đến chủ đề yêu cầu linh kiện.
  • Project Activities – cung cấp một khu vực chuyên dụng để quản lý các quy trình liên quan đến chủ đề làm việc với dự án Workspace, chẳng hạn như review thiết kế và publish lên hệ thống PLM.
  • Project Creations – cung cấp một khu vực chuyên dụng để quản lý các quy trình liên quan đến chủ đề tạo dự án thiết kế Workspace mới.
Ba tab cuối có thể được gọi là Process Themes. Process Themes cho phép nhóm các quy trình một cách trực quan theo từng mảng thiết kế. Chúng cũng cho phép phần mềm hỗ trợ việc tạo quy trình mới bằng cách chỉ hỗ trợ những phần tử workflow cần thiết cho một mảng cụ thể, từ đó đơn giản hóa việc xây dựng workflow cần thiết. Về lâu dài, cách tiếp cận này tạo nền tảng để Altium mở rộng giao diện thông qua việc bổ sung thêm các theme khác khi cần.

Các phần sau sẽ xem xét chi tiết hơn các tab này.

Tab Browser

Dùng tab này để duyệt tập trung tất cả các quy trình đang hoạt động hoặc đã đóng, trên mọi process theme. Mặc định, tab này hiển thị tất cả các quy trình Active (đang chạy). Chuyển sang xem tất cả các quy trình Closed (ví dụ: đã hoàn tất, bị từ chối hoặc bị chấm dứt) bằng trường thả xuống phía trên danh sách.

Duyệt tất cả các quy trình đang hoạt động từ một vị trí thuận tiện. Di chuột lên hình ảnh để xem ví dụ về việc duyệt tất cả các quy trình đã đóng.
Duyệt tất cả các quy trình đang hoạt động từ một vị trí thuận tiện. Di chuột lên hình ảnh để xem ví dụ về việc duyệt tất cả các quy trình đã đóng.

Đối với mỗi mục, thông tin sau sẽ được hiển thị (nếu áp dụng):

  • Status – trạng thái của quy trình. Có thể là một trong các trạng thái sau:
    • Active – quy trình hiện đang hoạt động và workflow liên quan của nó đang được thực hiện.
    • On hold – quy trình hiện đang hoạt động, nhưng đang chờ dữ liệu đầu vào ban đầu, chẳng hạn như phân công người phụ trách, trước khi workflow có thể tiếp tục.
    • Closed – quy trình hiện đã đóng, ví dụ như đã hoàn tất thành công hoặc bị từ chối.
    • Terminated – quy trình hiện đã đóng và đã bị chấm dứt trực tiếp bởi Quản trị viên Workspace.
  • Process Name – tên của định nghĩa quy trình.
  • Title – trường này được dùng để phân biệt giữa nhiều instance của cùng một quy trình. Tiêu đề là tên quy trình, kèm hậu tố instance (#1, #2, v.v.).
  • State – đây là trạng thái hiện tại đã đạt tới trong workflow liên quan của quy trình.
  • Assignee (chỉ quy trình đang hoạt động) – đây là người dùng hiện đang có một tác vụ cần thực hiện để chuyển quy trình sang trạng thái workflow tiếp theo.
  • Started By – người dùng đã khởi tạo quy trình.
  • Started At – ngày giờ mà quy trình được bắt đầu.
  • Ended At (chỉ quy trình đã đóng) – ngày giờ mà quy trình được đóng.

Đối với một quy trình đang hoạt động, còn có điều khiển Terminate (). Nhấp vào đây để buộc kết thúc quy trình. Quy trình sẽ được chuyển sang danh sách quy trình Closed.

Có thể sắp xếp các quy trình theo bất kỳ cột nào có điều khiển – nhấp vào điều khiển đó hoặc tên cột. Cũng có thể tìm kiếm bằng trường Search ở đầu danh sách. Dữ liệu trong tất cả các trường ngoại trừ Status, Started At, Ended AtTerminate đều có thể dùng để tìm kiếm.
  • Bạn cũng có thể import một định nghĩa quy trình đã được export trước đó từ tệp, trực tiếp trong tab Browser . Để thực hiện, nhấp nút . Trong hộp thoại Open xuất hiện, duyệt đến và mở tệp Workflow cần thiết (*.aaw). Process theme phù hợp sẽ được nhận diện, và nội dung của tệp sẽ được nạp vào Process Workflow Editor. Để biết thêm thông tin, xem Importing/Exporting a Process Definition.
  • Dùng nút để export báo cáo về các hoạt động hiện đang được liệt kê (Process Workflows) dưới dạng tệp *.csv phân tách bằng dấu phẩy chi tiết – view example. Có thể export các hoạt động Active hoặc Closed, và các mục được bao gồm có thể được lọc bằng trường Search tên quy trình. Ở phía thiết kế, bảng Explorer panel trong Altium Designer cũng có nút tương đương – dưới tab Activites khi duyệt một dự án (dùng chế độ xem mặc định Project ) – để tải xuống dữ liệu các hoạt động hiện đang được liệt kê liên quan đến dự án đó.

Nhấp vào một mục của quy trình để xem sơ đồ workflow nền tảng của nó (trên tab Diagram bên dưới danh sách), thể hiện những gì cần diễn ra để quy trình được hoàn tất, và quy trình đó hiện đang ở đâu trong luồng của nó, xét theo việc ai hiện có tác vụ tiếp theo để đẩy quy trình đi tiếp.

Nhấp vào điều khiển ở góc dưới bên phải để làm nổi bật điểm hiện tại đã đạt được trong workflow – mục người dùng sẽ nhấp nháy trong chốc lát.

Xem workflow nền tảng của quy trình được chọn trên tab Diagram của nó. Mỗi workflow được xây dựng dưới dạng sơ đồ, cho phép bạn nhìn thoáng qua là biết quy trình hiện đang nằm ở đâu trong workflow và ai là người có tác vụ tiếp theo để tiếp tục tiến trình của quy trình đó.Xem workflow nền tảng của quy trình được chọn trên tab Diagram của nó. Mỗi workflow được xây dựng dưới dạng sơ đồ, cho phép bạn nhìn thoáng qua là biết quy trình hiện đang nằm ở đâu trong workflow và ai là người có tác vụ tiếp theo để tiếp tục tiến trình của quy trình đó.

Các tab bổ sung sau cũng có sẵn:

  • Data – hiển thị toàn bộ dữ liệu liên quan cho quy trình. Ví dụ, với một quy trình review thiết kế, dữ liệu này có thể bao gồm dự án và bộ dữ liệu của nó, loại review, những người tham gia review, và mọi tệp đính kèm bổ sung. Với một quy trình yêu cầu linh kiện, dữ liệu này có thể bao gồm datasheet đính kèm, dữ liệu tham số, và mọi linh kiện sơ bộ.

    Các thực thể áp dụng, chẳng hạn như tệp đính kèm, datasheet, dự án và bộ dữ liệu dự án (Item-Revision), sẽ xuất hiện dưới dạng hyperlink để nhanh chóng điều hướng tới hoặc mở chúng. Bạn cũng có khả năng cấu hình dữ liệu tham số nào sẽ hiển thị cho người dùng tiêu chuẩn trên tab này. Khi chỉnh sửa workflow cho một quy trình, và không chọn phần tử nào, dữ liệu có thể hiển thị trên tab Data sẽ được liệt kê trong khung bên phải. Nhấp điều khiển Edit để truy cập biểu mẫu liên quan của nó (<ProcessName> Data).
  • History – hiển thị lịch sử các hành động đã diễn ra trong workflow của quy trình.

    Dùng các tab Data và History để duyệt chi tiết hơn về quy trình, và dấu vết hoạt động workflow của nó, tương ứng.Dùng các tab DataHistory để duyệt chi tiết hơn về quy trình, và dấu vết hoạt động workflow của nó, tương ứng.

Các tab Part Requests/Project Activities/Project Creations

Dùng các tab này – nơi gom các quy trình theo từng chủ đề cụ thể – để xem, tạo và quản lý các process workflow sẽ được sử dụng tương ứng khi yêu cầu một linh kiện thư viện Workspace mới, thực hiện review thiết kế hoặc publish lên hệ thống PLM, hoặc tạo các dự án thiết kế mới.

Mặc định, vùng phía trên của một tab hiển thị tất cả các phiên bản Latest của những quy trình đã được định nghĩa trong chủ đề đó. Chuyển sang xem các quy trình đã định nghĩa All (tức là mọi phiên bản) bằng trường thả xuống phía trên danh sách.

Ví dụ về việc duyệt các phiên bản mới nhất của những quy trình đã được định nghĩa cho một chủ đề cụ thể (trong trường hợp này là theme Project Activities).Ví dụ về việc duyệt các phiên bản mới nhất của những quy trình đã được định nghĩa cho một chủ đề cụ thể (trong trường hợp này là theme Project Activities).

Đối với mỗi mục, thông tin sau được hiển thị:

  • Process Name : version – tên của định nghĩa quy trình và phiên bản của nó. Để đảm bảo bạn luôn xem/làm việc với phiên bản mới nhất, hãy đảm bảo trường thả xuống phiên bản phía trên danh sách được đặt thành Latest.
  • Instances (active / all) – số lượng instance của phiên bản định nghĩa quy trình này hiện đang hoạt động, cùng với tổng số instance đã được khởi chạy.
  • Created By – người dùng đã tạo phiên bản định nghĩa quy trình này.
  • Created At – ngày giờ mà phiên bản định nghĩa quy trình này được tạo (lưu và triển khai).
  • Active – cho biết phiên bản định nghĩa quy trình này có đang hoạt động () và do đó có thể được sử dụng, hay đã bị tạm ngưng (), hoặc là định nghĩa mẫu (template) () và do đó không thể sử dụng. Chỉ những định nghĩa quy trình đang hoạt động mới xuất hiện trong khu vực liên quan của GUI Altium Designer để các nhà thiết kế sử dụng. Nhấp vào biểu tượng để chuyển đổi trạng thái hoạt động, nếu áp dụng.

    Chỉ phiên bản mới nhất của một định nghĩa quy trình mới có thể được sử dụng (được kích hoạt và khởi chạy). Các phiên bản trước đó không thể được sử dụng, nhưng có thể được chỉnh sửa để tạo ra phiên bản mới hơn. Ngoài ra, các định nghĩa quy trình mẫu (có trạng thái Active được phân biệt bởi ) không thể dùng ngay từ đầu. Mỗi định nghĩa như vậy giống như một “template” hơn – hãy chỉnh sửa cho phù hợp với yêu cầu công ty bạn, đặt tên và lưu thành định nghĩa quy trình mới, sau đó bạn can kích hoạt và sử dụng cùng với tất cả các định nghĩa khác.
  • Actions – nhấp điều khiển  để truy cập menu các hành động cho định nghĩa quy trình:
    • Startvới vai trò quản trị viên, bạn có thể khởi chạy một instance mới của phiên bản định nghĩa quy trình này bằng cách chọn lệnh này. Lệnh chỉ khả dụng nếu định nghĩa quy trình đã được kích hoạt. Nếu quy trình đã bị tạm ngưng, hoặc là định nghĩa mẫu (template), lệnh sẽ bị làm mờ và không thể khởi chạy instance.
    • Edit – chọn để chỉnh sửa workflow nền tảng cho định nghĩa quy trình. Sơ đồ workflow của phiên bản định nghĩa quy trình này sẽ được hiển thị trong Process Workflow Editor, làm điểm khởi đầu để thao tác. Bất kỳ Quản trị viên nào cũng có thể chỉnh sửa bất kỳ định nghĩa quy trình do người dùng tạo nào, bất kể ai là người tạo ban đầu, rồi lưu và triển khai thành phiên bản kế tiếp. Đối với các định nghĩa quy trình mặc định do Altium cung cấp, bạn có thể tạo một định nghĩa quy trình mới dựa trên việc chỉnh sửa một định nghĩa như vậy (về bản chất là tách nhánh), nhưng không thể chỉnh sửa trực tiếp định nghĩa mặc định. Để biết thêm thông tin về việc chỉnh sửa định nghĩa quy trình, xem Editing an Existing Process Definition.
    • Assign – chọn để mở cửa sổ Assign Access to This Workflow, tại đó bạn có thể xác định những người dùng và/hoặc nhóm nào có thể truy cập workflow nền tảng. Để biết thêm thông tin về quản lý quyền truy cập vào workflow, xem Managing Process Workflow Access.
    • Remove – chọn để gỡ bỏ (xóa) phiên bản định nghĩa quy trình này. Lưu ý rằng một số định nghĩa quy trình mặc định do Altium cung cấp không thể gỡ bỏ (và do đó sẽ không có điều khiển này). Nếu ít nhất một instance của định nghĩa quy trình đã được khởi chạy, bất kể hiện còn hoạt động hay không, thì định nghĩa đó không thể bị gỡ bỏ (lệnh sẽ không được liệt kê trong menu).
Các định nghĩa quy trình có thể được sắp xếp theo bất kỳ cột nào có điều khiển – nhấp vào điều khiển đó hoặc tên cột. Cũng có thể tìm kiếm bằng trường Search ở đầu danh sách. Dữ liệu trong các cột Process Name : version Created By có thể dùng để tìm kiếm.

Nhấp vào một mục của định nghĩa quy trình để xem workflow dạng sơ đồ của nó trên tab Diagram bên dưới danh sách. Nếu hiện có một instance đang hoạt động của quy trình, chế độ xem sẽ cho biết quy trình đó đang ở đâu trong luồng của nó, xét theo việc ai hiện đang có tác vụ để chuyển quy trình đi tiếp.

Nếu có nhiều instance của một quy trình đang hoạt động, chế độ xem Diagram sẽ hiển thị trạng thái tổng hợp. Nhấp vào điều khiển ở góc dưới bên phải để làm nổi bật điểm hiện tại đạt được trong workflow – mục người dùng sẽ nhấp nháy trong chốc lát.

Xem workflow nền tảng của quy trình được chọn trên tab Diagram của nó.Xem workflow nền tảng của quy trình được chọn trên tab Diagram của nó.

Các định nghĩa quy trình mặc định

Một số định nghĩa quy trình được Altium cung cấp – trải rộng trên ba process theme – như một phần của bản cài đặt Enterprise Server. Một số trong đó được kích hoạt để sử dụng ngay từ đầu và có thể dùng nguyên trạng, trong khi một số khác là mẫu – không thể kích hoạt và sử dụng trực tiếp. Tất cả đều có thể được dùng làm điểm khởi đầu để tạo các định nghĩa quy trình riêng của bạn khi cần. Hãy dùng các phần thu gọn sau để truy cập thông tin về các định nghĩa quy trình được cung cấp.

Bản cài đặt Enterprise Server cũng bao gồm quy trình LibSync đồng bộ dữ liệu component giữa Enterprise Server và một instance PLM đích. Đây là một workflow quy trình “tích hợp sẵn” chỉ đọc và do đó không thể chỉnh sửa, cũng như không được đưa vào danh sách quy trình trên trang Processes của Workspace (Admin » Processes). Xem PLM Component Synchronization để biết thêm thông tin.

Thêm định nghĩa quy trình mới

Related page: Định nghĩa Process Workflow

Có thể tạo quy trình mới bằng Process Workflow Editor chuyên dụng. Để truy cập trình chỉnh sửa, hãy kích hoạt tab cho theme mà bạn muốn tạo quy trình mới, sau đó nhấp nút ở góc trên bên phải của trang.

Điều quan trọng là phải kích hoạt theme trước, để quy trình được tạo với Type chính xác.

Truy cập Process Workflow Editor. Việc đảm bảo process theme mong muốn được kích hoạt trước khi truy cập sẽ giúp định nghĩa quy trình mới được đặt đúng loại theme.Truy cập Process Workflow Editor. Việc đảm bảo process theme mong muốn được kích hoạt trước khi truy cập sẽ giúp định nghĩa quy trình mới được đặt đúng loại theme.

Hãy đặt cho định nghĩa quy trình mới của bạn một cái tên có ý nghĩa, sau đó xây dựng workflow bằng đồ họa và xác định các khía cạnh cần thiết của từng phần tử trong luồng đó. Với các user task, một User Form Editor được dùng để tạo biểu mẫu cần thiết sẽ được trình bày cho người dùng nhập dữ liệu khi họ được giao tác vụ ở điểm tương ứng trong workflow.

Process Workflow Editor mạnh mẽ mang lại sự linh hoạt để bạn xây dựng các quy trình với workflow có thể đơn giản hoặc phức tạp tùy nhu cầu, và phù hợp với yêu cầu của công ty bạn.Process Workflow Editor mạnh mẽ mang lại sự linh hoạt để bạn xây dựng các quy trình với workflow có thể đơn giản hoặc phức tạp tùy nhu cầu, và phù hợp với yêu cầu của công ty bạn.

Sau khi một quy trình đã được định nghĩa theo yêu cầu, nhấp nút để thêm nó vào danh sách các quy trình sẵn có cho process theme đó. Định nghĩa quy trình mới sẽ được kích hoạt sẵn để sử dụng.

Trình chỉnh sửa sẽ đánh dấu mọi vấn đề trong sơ đồ workflow khiến nó không thể được lưu và triển khai – ví dụ, một sơ đồ phải có sự kiện Start, và ít nhất một sự kiện End được định nghĩa. Và một User Task phải có ít nhất một trường Form và một Assignee.

Chỉnh sửa định nghĩa quy trình hiện có

Bất kỳ Quản trị viên nào cũng có thể chỉnh sửa bất kỳ định nghĩa quy trình do người dùng tạo nào, bất kể ai là người tạo ban đầu, rồi lưu và triển khai nó như phiên bản kế tiếp. Để làm điều đó, nhấp vào  điều khiển trong cột Actions cho định nghĩa quy trình mà bạn muốn chỉnh sửa và chọn Edit từ menu xuất hiện. Sơ đồ workflow cho phiên bản này của định nghĩa quy trình sẽ được hiển thị trong Process Workflow Editor, làm điểm khởi đầu để bạn thực hiện các chỉnh sửa.

Đối với các định nghĩa quy trình do Altium cung cấp, bạn có thể tạo một định nghĩa quy trình mới dựa trên việc chỉnh sửa một định nghĩa như vậy (về bản chất là fork), nhưng không thể chỉnh sửa trực tiếp định nghĩa mặc định.

Ví dụ về chỉnh sửa một định nghĩa quy trình hiện có – truy cập Process Workflow Editor để thực hiện các thay đổi cần thiết.Ví dụ về chỉnh sửa một định nghĩa quy trình hiện có – truy cập Process Workflow Editor để thực hiện các thay đổi cần thiết.

Thực hiện các thay đổi cần thiết đối với workflow dạng sơ đồ của quy trình, bao gồm mọi thay đổi đối với các biểu mẫu liên kết với các tác vụ người dùng, sau đó nhấp nút để lưu định nghĩa thành phiên bản tiếp theo. Trong ví dụ này, định nghĩa quy trình gốc Company Pre-release Review : 1 (phiên bản 1) được chỉnh sửa và lưu thành Company Pre-release Review : 2 (phiên bản 2).

Sau khi hoàn tất các chỉnh sửa, hãy lưu và triển khai dưới dạng phiên bản tiếp theo của định nghĩa quy trình đó.Sau khi hoàn tất các chỉnh sửa, hãy lưu và triển khai dưới dạng phiên bản tiếp theo của định nghĩa quy trình đó.

Bằng cách sử dụng trường danh sách thả xuống ở góc trên bên trái và đặt mục nhập thành All, bạn có thể xem tất cả các phiên bản của các định nghĩa quy trình hiện có. Trong hình bên dưới, bạn có thể thấy cả hai phiên bản của định nghĩa quy trình Company Pre-release Review.

Hiển thị tất cả các phiên bản của định nghĩa quy trình ví dụ Company Pre-release Review. Lưu ý rằng chỉ phiên bản mới nhất (phiên bản 2) mới có thể được kích hoạt và sử dụng.Hiển thị tất cả các phiên bản của định nghĩa quy trình ví dụ Company Pre-release Review. Lưu ý rằng chỉ phiên bản mới nhất (phiên bản 2) mới có thể được kích hoạt và sử dụng.

Chỉ có thể sử dụng phiên bản mới nhất của một định nghĩa quy trình (được kích hoạt và khởi chạy). Tuy nhiên, các phiên bản trước đó vẫn có thể được dùng làm điểm khởi đầu để xây dựng phiên bản mới hơn. Nếu bạn xóa phiên bản mới nhất của một định nghĩa quy trình, thì phiên bản liền trước đó sẽ trở thành phiên bản mới nhất, và lại có thể được kích hoạt và sử dụng (khởi tạo các instance).

Nhập/Xuất Định nghĩa Quy trình

Các định nghĩa quy trình có thể được xuất và nhập, cho phép bạn nhanh chóng tái sử dụng chúng trên các instance Enterprise Server – một cách tiết kiệm thời gian thực sự trong trường hợp workflow nền tảng của một quy trình đặc biệt phức tạp, và nếu phải “phát minh lại bánh xe” thì đó sẽ là một việc khá nặng nề.

Để nhập:

  1. Truy cập tab chủ đề (Part Requests, Project Activities, Project Creations) tương ứng với định nghĩa quy trình mà bạn muốn nhập.

    Nếu bạn cố nhập một định nghĩa quy trình vào sai chủ đề, phần mềm sẽ cảnh báo và việc nhập sẽ bị ngăn lại.
  2. Nhấp nút để tạo một định nghĩa quy trình mới, rồi truy cập Process Workflow Editor.
  3. Nhấp nút . Trong hộp thoại Open xuất hiện, điều hướng đến và mở tệp Workflow cần dùng (*.aaw). Nội dung của tệp sẽ ghi đè hoàn toàn mọi thứ hiện được định nghĩa cho định nghĩa quy trình (Tên, sơ đồ, v.v.).
Bạn cũng có thể nhập một định nghĩa quy trình đã xuất trước đó từ tệp, trực tiếp trong tab Browser của giao diện. Để thực hiện, nhấp nút . Trong hộp thoại Open xuất hiện, điều hướng đến và mở tệp Workflow cần dùng (*.aaw). Chủ đề quy trình phù hợp sẽ được nhận diện và nội dung của tệp sẽ được nạp vào Process Workflow Editor.

Để xuất:

  1. Nhấp vào điều khiển  trong cột Actions cho phiên bản cần thiết của định nghĩa quy trình mà bạn muốn xuất và chọn Edit từ menu xuất hiện để vào chế độ chỉnh sửa.
  2. Trong Process Workflow Editor, nhấp nút . Định nghĩa quy trình sẽ được xuất thành một tệp Workflow (<ProcessDefinitionName>.aaw) vào thư mục tải xuống mặc định được xác định cho trình duyệt của bạn.
  3. Nhấp vào mục Processes trong cây điều hướng bên trái của giao diện trình duyệt của Workspace để thoát khỏi Process Workflow Editor mà không thực hiện thay đổi nào đối với định nghĩa quy trình.

Quản lý Quyền truy cập Workflow của Quy trình

Là quản trị viên, bạn có thể xác định người dùng và/hoặc nhóm nào có thể truy cập workflow của một quy trình. Để thực hiện, nhấp vào điều khiển  trong cột Actions cho định nghĩa quy trình mà bạn muốn cấu hình quyền truy cập vào workflow nền tảng, rồi chọn Assign từ menu xuất hiện. Cửa sổ Assign Access to This Workflow sẽ mở ra.

Bắt đầu nhập họ tên đầy đủ hoặc tên người dùng của một người dùng, hoặc tên của một nhóm trong trường văn bản để bật lên danh sách các người dùng/nhóm phù hợp. Có thể thêm nhiều người dùng/nhóm. Để loại bỏ quyền truy cập workflow của một người dùng/nhóm đã thêm, nhấp vào dấu xóa ở ngoài cùng bên phải tên của họ.

Sau khi đã xác định người dùng/nhóm theo yêu cầu, nhấp để áp dụng việc gán workflow. Từ lúc này, workflow sẽ chỉ khả dụng với những người dùng/nhóm đã được thêm vào (và các thành viên của nhóm Administrators) khi được truy cập như mô tả trong phần Quyền truy cập Workflow Quy trình trong Designer bên dưới.

Như đã nêu trong cửa sổ Assign Access to This Workflow, nếu không thêm người dùng/nhóm nào, workflow sẽ khả dụng với tất cả người dùng.

Quyền truy cập Workflow Quy trình trong Designer

Related pages: Thực hiện Design Review, Xuất bản lên PLM, Yêu cầu Linh kiện dựa trên Quy trình

Sau khi bộ định nghĩa quy trình cần thiết cho từng chủ đề quy trình sẵn có đã được tạo theo nhu cầu của công ty bạn, các định nghĩa đã được kích hoạt sẽ sẵn sàng để người dùng được chỉ định sử dụng khi họ kết nối tới Workspace của Enterprise Server. Các phần sau đây sẽ xem xét nơi mà một designer có thể truy cập và khởi chạy các quy trình đang hoạt động này – cả thông qua Altium Designer lẫn giao diện trình duyệt của Workspace.

Như đã đề cập trước đó, quản trị viên của Workspace có thể khởi tạo một instance mới của bất kỳ định nghĩa quy trình đã kích hoạt nào – trực tiếp từ tab chủ đề quy trình tương ứng trong khu vực Processes của giao diện trình duyệt Workspace – bằng cách nhấp vào điều khiển  trong cột Actions và chọn Start từ menu xuất hiện.

Yêu cầu Linh kiện

Related page: Yêu cầu Linh kiện dựa trên Quy trình

Từ bên trong Altium Designer, các định nghĩa quy trình đã kích hoạt thuộc chủ đề Part Requests có thể được truy cập tại các vị trí sau:

  • Từ panel Components. Nhấp chuột phải trong vùng chính của panel – các định nghĩa quy trình yêu cầu linh kiện đang hoạt động sẽ có sẵn trong menu con Operations » Submit Request. Ngoài ra, nhấp vào liên kết Submit request bên dưới phần Need more components?.

Nếu không có định nghĩa quy trình đang hoạt động nào cho chủ đề quy trình Part Requests, menu con Submit Request sẽ không xuất hiện. Bạn có thể cần đăng xuất khỏi Workspace rồi đăng nhập lại, hoặc khởi động lại Altium Designer, để làm mới.
  • Từ trong panel Manufacturer Part Search. Nếu mục tìm kiếm hiện đang được chọn có biểu tượng , ngăn Information (truy cập bằng cách nhấp ) sẽ hiển thị nút . Nhấp vào phần thả xuống của nút để truy cập menu các định nghĩa quy trình yêu cầu linh kiện đang hoạt động. Nhấp trực tiếp vào phần chính của nút sẽ khởi chạy định nghĩa quy trình đầu tiên trong danh sách.
Việc yêu cầu một linh kiện thông qua panel Manufacturer Part Search có thêm lợi ích là tự động điền cho bạn các thông tin quan trọng, bao gồm tất cả các datasheet và thông tin tham số.

Nếu không có định nghĩa quy trình đang hoạt động nào cho chủ đề quy trình Part Requests, nút sẽ không xuất hiện. Bạn có thể cần đăng xuất khỏi Workspace rồi đăng nhập lại, hoặc khởi động lại Altium Designer, để làm mới.

Nếu mục tìm kiếm hiện đang được chọn có biểu tượng , các định nghĩa quy trình yêu cầu linh kiện đang hoạt động sẽ có sẵn từ menu gắn với nút (nhấp vào phần thả xuống của nút).

Các định nghĩa quy trình yêu cầu linh kiện đang hoạt động cũng có thể được truy cập từ menu nhấp chuột phải cho vùng chính của panel, từ menu con Submit Request.

Nếu không có định nghĩa quy trình đang hoạt động nào cho chủ đề quy trình Part Requests, menu con Submit Request sẽ không xuất hiện. Bạn có thể cần đăng xuất khỏi Workspace rồi đăng nhập lại, hoặc khởi động lại Altium Designer, để làm mới.
  • Từ panel Explorer, trong thư mục Part requests hoặc sau khi đã thực hiện tìm kiếm. Nút sẽ khả dụng, và khi nhấn vào sẽ hiển thị các định nghĩa quy trình yêu cầu linh kiện đang hoạt động để lựa chọn.

Lưu ý rằng nếu tính năng Legacy Part Requests đã được bật, thì nút sẽ xuất hiện là . Một mục bổ sung liên quan đến các yêu cầu linh kiện mới sử dụng chức năng kế thừa đó cũng sẽ xuất hiện trên menu. Mục này sẽ có hậu tố (Legacy). Nếu không có định nghĩa quy trình đang hoạt động nào cho chủ đề quy trình Part Requests, và tính năng Legacy Part Requests không được bật, nút Submit Request sẽ không hiển thị. Bạn có thể cần đăng xuất khỏi Workspace rồi đăng nhập lại, hoặc khởi động lại Altium Designer, để làm mới.

Từ giao diện trình duyệt của Workspace, các định nghĩa quy trình đã kích hoạt thuộc chủ đề Part Requests có thể được truy cập từ trang Part Requests, bằng cách nhấp nút ở góc trên bên phải của trang.

Truy cập các định nghĩa Part Requests đã kích hoạt từ trang Part Requests của giao diện trình duyệt Workspace.Truy cập các định nghĩa Part Requests đã kích hoạt từ trang Part Requests của giao diện trình duyệt Workspace.

Nếu không có định nghĩa quy trình đang hoạt động nào cho chủ đề quy trình Part Requests, nút sẽ không khả dụng. Nếu chỉ có một định nghĩa quy trình tồn tại, nút sẽ không xuất hiện với chức năng thả xuống và sẽ khởi chạy quy trình đó ngay khi được nhấp.

Hoạt động Dự án

Related pages: Thực hiện Design Review, Xuất bản lên PLM, Tích hợp PLM.

Các định nghĩa quy trình đã kích hoạt thuộc chủ đề Project Activities có thể được truy cập ở nhiều nơi khác nhau.

Design Review và Xuất bản PLM Chuẩn

Từ bên trong Altium Designer, các định nghĩa quy trình review thiết kế và xuất bản – thuộc chủ đề Project Activities – có thể được truy cập từ menu con ngữ cảnh Project Activities, được truy cập bằng cách nhấp chuột phải vào mục của dự án thiết kế trong panel Projects, hoặc từ menu chính Project » Project Activities.

Nếu không có định nghĩa quy trình review thiết kế đang hoạt động và xuất bản PLM chuẩn nào cho chủ đề quy trình Project Activities, các menu sẽ không hiển thị.

Từ giao diện trình duyệt của Workspace, các định nghĩa quy trình review thiết kế và xuất bản đã kích hoạt – thuộc chủ đề Project Activities – có thể được truy cập từ trang Projects của giao diện. Chọn dự án cần thiết, rồi nhấp nút .

Truy cập các định nghĩa Project Activities đã kích hoạt (review thiết kế và xuất bản PLM chuẩn) cho một dự án Workspace, trong khu vực Projects của giao diện trình duyệt Workspace.Truy cập các định nghĩa Project Activities đã kích hoạt (review thiết kế và xuất bản PLM chuẩn) cho một dự án Workspace, trong khu vực Projects của giao diện trình duyệt Workspace.

Nếu không có định nghĩa quy trình review thiết kế đang hoạt động và xuất bản PLM chuẩn nào cho chủ đề quy trình Project Activities, nút sẽ không hiển thị.

Xuất bản PLM thông qua Project Releaser

Từ bên trong Altium Designer, quy trình xuất bản lên một instance PLM như một phần của Project Releaser có thể được truy cập từ menu con Project » Project Releaser cho dự án đang hoạt động, hoặc bằng cách nhấp chuột phải vào mục của dự án thiết kế trong panel Projects và chọn quy trình từ mục menu ngữ cảnh Project Releaser.

Tạo Dự án

Từ bên trong Altium Designer, các định nghĩa quy trình đã kích hoạt thuộc chủ đề Project Creations có thể được truy cập ở ba nơi:

  • Từ menu con chính File » New » Project in <WorkspaceName>.

  • Từ menu con ngữ cảnh Convert to Managed Project, được truy cập bằng cách nhấp chuột phải vào mục của một dự án cục bộ trong panel Projects.

  • Từ menu con ngữ cảnh Clone, được truy cập bằng cách nhấp chuột phải vào mục của một dự án trong hộp thoại Open Project dialog khi vị trí Workspace được chọn.

Lưu ý rằng khi có ít nhất một định nghĩa quy trình cho chủ đề quy trình Project Creations đang hoạt động, khả năng tạo một dự án Workspace mới thông qua hộp thoại Create Project dialog (File » New » Project) sẽ bị vô hiệu hóa – Workspace đã kết nối sẽ không khả dụng như một vị trí đích. Regular (Cục bộ) và các dự án loại VCS vẫn có thể được tạo bình thường thông qua hộp thoại này.

Nếu không có định nghĩa quy trình đang hoạt động nào cho chủ đề quy trình Project Creations – đây là trường hợp mặc định đối với một cài đặt Enterprise Server mới – các menu quy trình sẽ không hiển thị, và bạn sẽ có thể tạo một dự án Workspace thông qua hộp thoại Create Project như bình thường.

Cũng lưu ý rằng trong cấu hình mặc định này, lệnh Convert to Managed Project sẽ đổi thành Make Project Available on Server.

Từ giao diện trình duyệt của Workspace, các định nghĩa quy trình đã kích hoạt thuộc chủ đề Project Creations có thể được truy cập tại các vị trí sau:

  • Từ trang chính Projects của giao diện, bằng cách nhấp nút .

Truy cập các định nghĩa Project Creations đã kích hoạt từ khu vực chính Projects của giao diện trình duyệt Workspace.Truy cập các định nghĩa Project Creations đã kích hoạt từ khu vực chính Projects của giao diện trình duyệt Workspace.

  • Từ trang Projects của giao diện, khi muốn clone một dự án cụ thể. Chọn dự án cần thiết, rồi nhấp nút để truy cập các quy trình trên menu.

Truy cập các định nghĩa Project Creations đã kích hoạt khi muốn clone một dự án Workspace, trong khu vực Projects của giao diện trình duyệt Workspace.Truy cập các định nghĩa Project Creations đã kích hoạt khi muốn clone một dự án Workspace, trong khu vực Projects của giao diện trình duyệt Workspace.

  • Nếu không có định nghĩa quy trình đang hoạt động nào cho chủ đề quy trình Project Creations – đây là trường hợp mặc định đối với một cài đặt Enterprise Server mới – menu sẽ cung cấp chức năng clone dự án cơ bản (Clone). Chức năng này không liên quan đến chức năng workflow quy trình.
  • Để sử dụng Constraint Manager để quản lý các ràng buộc thiết kế cho dự án PCB Workspace dựa trên quy trình của bạn, hãy đảm bảo gán một template dự án phù hợp khi tạo dự án đó. Đây nên là một template được lưu từ một dự án PCB đã được tạo với tùy chọn Constraint Management của nó được bật trong hộp thoại Create Project dialog.
AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nội dung