Altium NEXUS Documentation

Zoom

Modified by Susan Riege on Jul 21, 2018

Parent page: PCB Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: Action = All

Summary

This command is used to display all design objects on the current document.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Fit Document command (from the PCB Editor or PCB Library Editor) or the View » Fit All Objects command (from the PCB Library Editor) from the main menus.
  • Clicking the  button on the PCB Standard toolbar (PCB Editor), or PCB Lib Standard toolbar (PCB Library Editor).
  • Using the Ctrl+PgDn keyboard shortcut.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Fit Document command (from the PCB Editor and PCB Library Editor), or Fit All Objects command (from the PCB Library Editor).
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the All command.
In the PCB Library Editor, the command can also be accessed by right-clicking in the workspace then choosing either the View » Fit Document command or the View » Fit All Objects command from the context menu.

Use

After launching the command, the view in the main design window will change to present all design objects in the workspace.


Applied Parameters: Action = Document

Summary

This command is used to display all electrical design objects on the current document.

Access

This command is accessed from the PCB Editor by:

  • Choosing the View » Fit Board command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu, then choosing the Fit Board command.

Use

After launching the command, the view of the main design window will change to display all electrical design objects.


Applied Parameters: Action = Board

Summary

This command is used to display all objects that are part of the 2D footprint aspect of the active library component (PCB Library document), or all electrical objects on the current board (PCB document).

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Fit Document command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu, then choosing the Fit Document command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Board command.

Use

After launching the command, the view of the main design window will change to display:

  • PCB Editor - all electrical design objects.
  • PCB Library Editor - all design objects that consitute the 2D footprint aspect of the component.

Tips

  1. In the PCB Library Editor, the view will not extend to include any defined 3D Body objects, that are placed beyond the extents of the objects used to define the 2D footprint.


Applied Parameters: Action = Area

Summary

This command is used to zoom into a user-defined area of the current document.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Area command from the main menus.
  • Clicking the  button on the PCB Standard toolbar (PCB Editor) or PCB Lib Standard toolbar (PCB Library Editor).
  • Pressing the V key in the workspace to access the View pop-up menu, then choosing the Area command.
In the PCB Library Editor, the command can also be accessed by right-clicking in the workspace then choosing the View » Area command from the context menu.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to select the first corner of the zoom window. Position the cursor then click or press Enter to anchor this corner. You will then be prompted to select the second corner. Move the cursor to size the zoom area then click or press Enter to anchor this second corner. The display will change with the specified area centered in the main design window.


Applied Parameters: Action = Window

Summary

This command is used to zoom into a user-defined area of the current document.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Window command.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to select the first corner of the zoom window. Position the cursor then click or press Enter to anchor this corner. You will then be prompted to select the second corner. Move the cursor to size the zoom area then click or press Enter to anchor this second corner. The display will change with the specified area centered in the main design window.


Applied Parameters: Action = Point

Summary

This command is used to redefine the display area about a specified point in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Around Point command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Around Point command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Point command.
In the PCB Library Editor, the command can also be accessed by right-clicking in the workspace then choosing the View » Around Point command from the context menu.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to select the center point of a zoom window. Position the cursor then click or press Enter to anchor this center point. You will then be prompted to select the corner of the zoom window. Move the cursor to size the zoom area then click or press Enter to anchor the corner. The display will change with the specified area centered in the main design window around the specified center point.


Applied Parameters: Action= Selected

Summary

This command is used to change the view in the main design window so that all selected objects are visible.

Access

This command is accessed from the PCB Editor, and PCB Library Editor by:

  • Choosing the View » Selected Objects command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Selected Objects command.
  • Pressing the Z key in the PCB Editor workspace to access the Zoom pop-up menu then choosing the Selected command.
  • Clicking the  button on the PCB Standard toolbar (PCB Editor).
  • Right-clicking in the PCB Library Editor workspace then choosing the View » Selected Objects command from the context menu.

Use

First, ensure that all objects that you want to zoom in upon are selected.

After launching the command, the view in the main design window will change to fit all selected objects. Depending on the number of objects selected and their respective locations, the selection will be zoomed and centered in the window.


Applied Parameters: Action= Filtered

Summary

This command is used to change the view of the main design window to fit all objects that come under the scope of the currently applied filter.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Filtered Objects command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Filtered Objects command.
  • Pressing the Z key in the PCB Editor workspace to access the Zoom pop-up menu then choosing the Filtered command.
  • Clicking the  button on the PCB Standard toolbar or Filter toolbar (PCB Editor).
  • Right-clicking in the PCB Library Editor workspace then choosing the View » Filtered Objects command from the context menu.

Use

After launching the command, the view of the main design window will change to fit all design objects that come under the scope of the applied filter query.

Tips

  1. Adjust the level of masking applied to all objects not falling under the scope of the filter by using the Masked Objects slider bar located in the Mask and Dim Settings section on the View Options tab of the View Configuration panel.
  2. Filtering can be quickly cleared by using the Shift+C keyboard shortcut.


Applied Parameters: Action = In

Summary

This command is used to bring the design closer to you, relative to the cursor position, in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Zoom In command from the main menus.
  • Using the PgUp keyboard shortcut.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Zoom In command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the In command.
  • Right-clicking in the PCB Library Editor workspace and choosing the View » Zoom In command from the context menu.
The command can also be accessed in the PCB Library Editor by clicking the  button on the PCB Lib Standard toolbar.

Use

Launch the command to zoom in on a particular section of the design. Use the command repeatedly to zoom in to a greater extent.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command. To use the command effectively, use the shortcut or use the accelerator keyboard sequence: V, I (or Z, I).
  2. This command can be used through its respective keyboard shortcut even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom in to a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel upward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button, then move the mouse forward.
    3. Hold the right (first) and left (second) mouse buttons, then move the mouse forward.
    4. Click and hold the mouse wheel, then move the mouse forward.


Applied Parameters: Action = MicroIn

Summary

This command is used to bring the design closer to you, relative to the cursor position, in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the Shift+PgUp keyboard shortcut.

Use

Launch the command to zoom in on a particular section of the design. Use the command repeatedly to zoom in to a greater extent, and in progressively smaller steps.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command.
  2. This command can be used even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom in to a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel upward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button, then move the mouse forward.
    3. Hold the right (first) and left (second) mouse buttons, then move the mouse forward.
    4. Click and hold the mouse wheel, then move the mouse forward.


Applied Parameters: ZoomLevel = 4.0

Summary

This command is used to set the magnification of the current document to 400%.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the Ctrl+PgUp keyboard shortcut.

Use

After launching the command, the view of the current document will be set to a magnification of 400%, centered around the current cursor location.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command.
  2. This command can be used even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom in to a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel upward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button, then move the mouse forward.
    3. Hold the right (first) and left (second) mouse buttons, then move the mouse forward.
    4. Click and hold the mouse wheel, then move the mouse forward.


Applied Parameters: Action = Out

Summary

This command is used to move the design away from you, relative to the cursor position, in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Zoom Out command from the main menus.
  • Using the PgDn keyboard shortcut.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Zoom Out command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Out command.
  • Right-clicking in the PCB Library Editor workspace then choosing the View » Zoom Out command from the context menu.
The command can also be accessed in the PCB Library Editor by clicking the  button on the PCB Lib Standard toolbar.

Use

Launch the command to zoom out from a particular section of the design. Use the command repeatedly to zoom out to a greater extent.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command. To use the command effectively, use the shortcut or use the accelerator keyboard sequence: V, O (or Z, O).
  2. This command can be used, through its respective keyboard shortcut, even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom out from a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel downward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button then move the mouse backward.
    3. Hold the right (first) and left (second) mouse buttons then move the mouse backward.
    4. Click and hold the mouse wheel then move the mouse backward.


Applied Parameters: Action = MicroOut

Summary

This command is used to move the design away from you, relative to the cursor position, in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the Shift+PgDn keyboard shortcut.

Use

Launch the command to zoom out from a particular section of the design. Use the command repeatedly to zoom out to a greater extent, and in progressively larger steps.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command.
  2. This command can be used even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom out from a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel downward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button then move the mouse backward.
    3. Hold the right (first) and left (second) mouse buttons then move the mouse backward.
    4. Click and hold the mouse wheel then move the mouse backward.


Applied Parameters: None

Summary

This command is used to change the magnification of the display of the current document by a specified value.

Access

This command is accessed from the PCB Editor and PCB Library Editor by pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Select command.

Use

After launching the command, the Zoom Value (0.001x..4x) dialog will appear. Enter the required zoom level (magnification) required then click OK. The view of the main design window will update in accordance with the chosen magnification.

Tips

  1. Values greater than 1 are entered in order to zoom in to a greater extent (increase magnification). Values less than 1 are used to zoom out to a greater extent (decrease magnification).
  2. You can use the mouse to zoom in to or zoom out from a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel upward or downward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button then move the mouse forward or backward.
    3. Hold the right (first) and left (second) mouse buttons then move the mouse forward or backward.
    4. Click and hold the mouse wheel then move the mouse forward or backward.


Applied Parameters: Action = RedrawCurrent

Summary

This command is used to redraw the current layer of the current document to remove any undesirable drawing update effects.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Using the Alt+End keyboard shortcut.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Current command.

Use

After launching the command, the main design window is refreshed and the content of the current layer is redrawn.

Tips

  1. This command does not affect the current view setting of the main design window.


Applied Parameters: Action = Last

Summary

This command is used to return the display to the previous view of the screen in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Zoom Last command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Zoom Last command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Last command.
In the PCB Library Editor, the command can also be accessed by right-clicking in the workspace then choosing the View » Zoom Last command from the context menu.

Use

After launching the command, the main design window will show the previous view of the current document. Use the command repeatedly to toggle back and forth between current and previous views.


Applied Parameters: Action = Pan

Summary

This command is used to redraw the view in the main design window, placing the location marked by the cursor - prior to launching the command - at the center of the window.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the Home keyboard shortcut.

Use

After launching the command, the location in the workspace directly underneath the cursor prior to the launch will be centered in the main design window.

Tips

  1. The zoom-level remains unchanged when using this command. If the present zoom-level does not allow for the centering of the location, the document will be horizontally scrolled so that the location is horizontally centered in the main design window.
  2. Hold the right mouse button down to display the slider (panning) hand cursor then drag to move your view of the workspace.


Applied Parameters: Action = Redraw

Summary

This command is used to refresh the screen, in effect performing a redraw of the current document, to remove any undesirable drawing update effects.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the End keyboard shortcut.

Use

After launching the command, the main design window is refreshed and the content of the window is redrawn.

Tips

  1. This command does not affect the current view setting for the workspace.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。