PDN Analyzer (by CST) – Beispielanleitung

Auf einen Blick

Dieser Leitfaden zeigt Ihnen, wie Sie PDN Analyzer (von CST) in Altium Designer verwenden: von der Einrichtung der Netzparameter für die PI-DC-Simulation über die Durchführung einer Analyse bis hin zur Interpretation der Ergebnisse, damit Sie die Power-Integrität Ihres Leiterplattendesigns schrittweise verbessern können. Außerdem werden der Aufbau der Benutzeroberfläche, verfügbare Beispielprojekte, der Workflow zur Netzidentifizierung, die Simulationssteuerung und die wichtigsten Panel-Optionen erläutert, mit denen Sie Stromversorgungsnetzwerke direkt aus Ihren geladenen Projektdaten erstellen und verwalten können. Wenn Sie einen praxisnahen Überblick darüber suchen, wie sich PDN Analyzer in Ihren Designprozess einfügt und wo Sie die benötigten Werkzeuge finden, hilft Ihnen dieser Artikel beim Einstieg und bereitet Sie auf die weitere Erkundung vor.

- Sie lernen den grundlegenden Workflow von PDN Analyzer kennen und erfahren, wie Sie Simulationen konfigurieren, ausführen und bei Änderungen an Ihrem Leiterplattendesign wiederverwenden.
- Sie erfahren, wie die Benutzeroberfläche von PDN Analyzer aufgebaut ist – einschließlich Layoutmodi, Andockoptionen, Netzwerkansichten und Zugriffsmöglichkeiten auf Konfiguration und Ergebnisse.
- Sie lernen die verfügbaren Beispielprojekte und integrierten Optionen kennen, die Ihnen helfen, Gleichstromnetze zu identifizieren, Simulationsdateien zu verwalten und mit Stromversorgungsnetzwerkstrukturen zu arbeiten.
Mit KI tiefer einsteigen:

Die neuesten Funktionen zur Analyse der DC-Versorgungsintegrität bietet Altiums Power Analyzer by Keysight.

Die Anwendung PDN Analyzer (PDNA) ist relativ einfach zu bedienen. Im Wesentlichen werden die Netzparameter für die PI-DC-Simulation eingerichtet, die Simulation ausgeführt und anschließend die Ergebnisse interpretiert. Die Daten für eine Versorgungsnetzsimulation mit PDN Analyzer werden direkt aus dem aktuell geladenen PCB-Designprojekt übernommen. Dieses kann schrittweise bearbeitet werden, um die Versorgungsintegrität der Versorgungspfade zu verbessern. Anschließend lässt sich die PDN-Simulation erneut ausführen, um die Ergebnisse zu überprüfen.

Diese Anleitung zur Arbeit mit PDN Analyzer verwendet zwei Referenzdesigns, die von Altium bereitgestellt werden:

Zusätzlich enthält die PDN Analyzer-Installation das PCB-Projekt SpiritLevel mit mehreren Beispielen für Analysekonfigurationsdateien. Über die PDNA-Menüoption File » Explore Samples können Sie auf das Projekt und die Beispiele zugreifen und diese anschließend entpacken.

Diese Anleitung setzt voraus, dass PDN Analyzer in Ihrer Altium Designer-Installation verfügbar ist und Sie über grundlegende Kenntnisse der verwendeten PI-DC-Prinzipien (DC-Versorgungsintegrität) verfügen.

Informationen zum Zugriff auf die Funktionen von PDN Analyzer sowie zu den Grundlagen der PI-DC-Simulation finden Sie auf der Seite zu PDN Analyzer.

PDN Analyzer-Benutzeroberfläche

Die Benutzeroberfläche der PDN Analyzer-Erweiterung wird als nicht modales Fenster in Altium Designer geöffnet. Dieses kann an einer beliebigen geeigneten Stelle im Arbeitsbereich oder auf einem weiteren Bildschirm, sofern vorhanden, positioniert werden. Um das Hauptfenster PDN Analyzer zu öffnen, öffnen Sie ein Schaltplan- oder PCB-Dokument eines Projekts und wählen Sie die Anwendung im Menü „Tools“ aus (Tools » PDN Analyzer).

Die PDN Analyzer-Benutzeroberfläche mit einem ausgewählten Versorgungsnetzwerk. Die Anzeige- und Ergebniskonfigurationen sind im unteren Bereich des Panels verfügbar.Die PDN Analyzer-Benutzeroberfläche mit einem ausgewählten Versorgungsnetzwerk. Die Anzeige- und Ergebniskonfigurationen sind im unteren Bereich des Panels verfügbar.

Die PDNA-Benutzeroberfläche ist in zwei Bereiche unterteilt: Der obere Bereich dient der Datei- und Netzverwaltung und zeigt eine interaktive Darstellung der aktuell ausgewählten Versorgungsnetzwerke. Der untere Bereich bietet Zugriff auf Analyseoptionen, Anzeigeeinstellungen und Ergebnisdaten. PDNA Version 2 unterstützt mehrere miteinander verbundene Netze. Dadurch lässt sich die DC-Versorgungsintegrität eines gesamten PCB-Designs als hierarchische Struktur oder in Form einzelner Versorgungsnetze analysieren.

Die PDN Analyzer-Benutzeroberfläche mit ausgewählter vollständiger Versorgungsnetzhierarchie. Die Anzeige der enthaltenen Netzwerke und Lagen wird im unteren Bereich des Panels gesteuert.Die PDN Analyzer-Benutzeroberfläche mit ausgewählter vollständiger Versorgungsnetzhierarchie. Die Anzeige der enthaltenen Netzwerke und Lagen wird im unteren Bereich des Panels gesteuert.

Die PDN-Benutzeroberfläche bietet außerdem einen kompakten Anzeigemodus (File » Compact Layout) ohne den unteren Panelbereich. Dieser eignet sich ideal zum horizontalen oder vertikalen Andocken im Hauptfenster von Altium Designer. Um das Andocken im kompakten oder im Standardmodus zu aktivieren, klicken Sie mit der rechten Maustaste auf die Titelleiste der PDNA-Benutzeroberfläche, wählen Sie im Kontextmenü Allow Dock und anschließend die Option Horizontally oder Vertically.

Details zur Benutzeroberfläche des Panels PDN Analyzer finden Sie im folgenden ausklappbaren Abschnitt. 

Identifizierung von Gleichspannungsnetzen

Wenn der PDN Analyzer zum ersten Mal für ein PCB-Design geöffnet wird, versucht er, anhand gängiger Bezeichnungen für Versorgungsnetzwerke alle Gleichspannungs-Versorgungsnetzwerke in den Netzdaten des Designs zu identifizieren.  Wenn nicht alle potenziellen Versorgungsnetze identifiziert wurden, deaktivieren Sie die entsprechenden Filteroptionen Qualifiers. Um alle Netze anzuzeigen, wählen Sie die Option Enable all nets for filtering.

Wählen Sie mithilfe der Kontrollkästchen Select aus, welche Versorgungsnetze dem PDNA-Analysator zur Verfügung stehen sollen, und geben Sie geeignete Spannungspegel in die zugehörigen Felder Nominal Voltage ein. Klicken Sie auf die Schaltfläche Add Selected, um die Liste Currently Identified DC Nets zu füllen und diese Netze als identifizierte Versorgungsnetzwerke zu bestätigen.

Beachten Sie, dass Sie durch Doppelklicken auf einen Netzeintrag im Dialog über Cross-Probing zum entsprechenden Netz im PCB-Layout navigieren.

Weitere Netze können während der Einrichtung der PDN-Analyse identifiziert und übernommen werden, indem Sie in der grafischen Benutzeroberfläche des Analyzers die Schaltfläche DC Nets auswählen.

Die folgenden Analysebeispiele veranschaulichen die wichtigsten Funktionen und Möglichkeiten des PDN Analyzer. Jedes Beispiel zeigt nur eine von vielen möglichen Parameterkonfigurationen, mit denen sich die Versorgungsintegrität des Netzwerks je nach Untersuchungsschwerpunkt auf unterschiedliche Weise bewerten lässt. Beachten Sie, dass eine erfolgreich abgeschlossene Analyse als PDNA-Konfigurationsdatei (*.pdna) gespeichert und jederzeit erneut geladen werden kann – File » Save As und File » Open (standardmäßig im Ordner PDNAnalyzer_Config des Projekts).

Beispiel 1

Dieses Beispiel zeigt die Grundlagen der Einrichtung einer Simulation der Versorgungsintegrität mit einem einfachen Versorgungsnetz und dessen Stromlasten. Die Konfiguration dient dazu, die Verteilung der 5-V-Versorgung und den zugehörigen Masse-Rückstrompfad im Referenzprojekt SpiritLevel-SL1 unter Belastung durch das LCD-Display des Designs zu bewerten. In diesem Fall wird die Versorgungsschiene 5V als einfache Spannungsquelle betrachtet; die daran angeschlossenen Netzwerke (etwa über den Schalter S1) werden nicht einbezogen.

Für dieses PDN-Simulationsbeispiel gelten folgende Voraussetzungen:

  • Das Leiterplattenprojekt Spirit Level ist in Altium Designer geöffnet.
  • Die Anwendung PDN Analyzer ist aktiv (Tools » PDN Analyzer).
  • Die Gleichstromnetze des Leiterplattendesigns wurden im Dialog PDN Analyzer DC Net Identification identifiziert, wie oben beschrieben.

Beginnen Sie die Analyse, indem Sie die Versorgungs- und Massenetze festlegen. Doppelklicken Sie in der Netzwerkgrafik der Benutzeroberfläche auf die Elemente <Power Net> und <Ground Net>, um den Dialog Choose Net zu öffnen. Dort stehen die identifizierten Versorgungsnetze zur Auswahl.

Verwenden Sie bei Bedarf die Qualifizierungs-/Filteroptionen des Dialogs, um die Liste der Netze einzuschränken oder zu erweitern, oder kehren Sie zum Hauptbildschirm zurück und wählen Sie die Schaltfläche , um die Gleichstrom-Versorgungsnetze erneut zu identifizieren.

Zwischen dem festgelegten Versorgungs- und Massenetz kann nun ein Quellen- oder Lastelement hinzugefügt werden. Beachten Sie, dass die Statusanzeigen für Masse und Versorgung nun ein Häkchen anzeigen (✔). Klicken Sie mit der rechten Maustaste in den Arbeitsbereich der Netzwerkgrafik und wählen Sie im Kontextmenü Add Source (oder Add Load), um den Dialog Device Properties zu öffnen. Die im Dialog angegebenen Schritte lauten wie folgt:

  1. Um dem Netzwerk eine Versorgungsquelle hinzuzufügen – in diesem Fall eine einfache Spannungsquelle –, wählen Sie im Dropdown-Menü Device Type des Dialogs die Option Voltage Source.
  2. In der Liste der Quellenverbindungen versucht PDNA, anhand der Parameter des Versorgungsnetzwerks die richtigen Netzanschlüsse auszuwählen – hier zwischen den Netzen 5V und GND. Verwenden Sie die Optionen des Dropdown-Menüs Refdes, um die Bauteilanschlusspunkte der Spannungsquelle festzulegen. In diesem Beispiel wird TP1 als Anschlusspunkt der Quellenspannung festgelegt und die Gleichstrom-Eingangsbuchse J1 des Designs als Masse-Rückleitung (Pins 2 und 3).
  3. Im unteren Bereich des Dialogs legen die Quellenparameter die Eigenschaften des Simulationsmodells der Spannungsquelle fest. Hier wird die Quellenspannung (Vout) auf 5V eingestellt, während der Innenwiderstand des Modells (Rout) auf der Standardeinstellung 0Ω belassen wird.
  4. Schließlich werden der maximale Quellenstrom und der Pin-Strom (bei Quellen mit mehreren Ausgangspins) auf den Standardeinstellungen (0A: Don't Care) belassen. Wenn für Limits bestimmte Stromwerte festgelegt werden, meldet die PDN-Analyse eine Grenzwertverletzung, sobald die Simulationsergebnisse diese Werte überschreiten.

Fügen Sie auf die gleiche Weise wie beim Hinzufügen einer Quelle zum Netzwerk eine Last hinzu und legen Sie deren Parameter im Dialog Device Properties fest.

In diesem Fall wird eine Stromsenkenlast (Device Type: IC (Current)) hinzugefügt, um den Strom darzustellen, den die LCD-Komponente des Designs aus der 5-V-Versorgung aufnimmt. Beachten Sie, dass auch eine rein ohmsche Last verfügbar ist, indem Sie  Resistor als Device Type auswählen.

Legen Sie den Lastanschluss als LCD1 fest und geben Sie den Load Current an, den die Last aus der 5-V-Versorgung aufnehmen soll. Beachten Sie, dass Einheitenpräfixe unterstützt werden (beispielsweise 500m für 0.5A). Die Spannungseinstellungen Limits sind optional, wurden hier jedoch über die zugehörige Schaltfläche auf  +/-10% gesetzt. Dadurch wird eine Grenzwertverletzung in der Simulation ausgelöst, wenn die Spannung direkt an der Last unter 4,5 V fällt oder über 5,5 V steigt.

Wenn das Versorgungsnetzwerk definiert ist und alle Parameter festgelegt sind (alle Netzwerkelemente weisen den Status ✔ auf), kann die PDN-Analyse durch Auswahl der Schaltfläche  gestartet werden. Der Fortschritt der Simulation wird auf der Registerkarte Messages als Folge von Ereignissen angezeigt. Falls der Vorgang nicht abgeschlossen werden kann, wird dort auch die Ursache des Simulationsfehlers angegeben.

Bei der Ausführung einer Analyse wird die aktuelle Simulationskonfiguration – die festgelegten Netze, Quellen/Lasten usw. und deren zugehörige Parameter – zusammen mit den Analyseergebnissen gespeichert (File » Explore; siehe Ordner PDNAnalyzer_Ouput). Diese Konfiguration kann jederzeit für die aktuelle Simulation wiederhergestellt werden, indem Sie mit der rechten Maustaste auf den Simulationsnamen klicken und im Kontextmenü Revert auswählen.

Die unmittelbaren Ergebnisse der PDN-Analyse sind in der Netzwerkgrafik zu sehen. Diese enthält die berechneten Spannungs- und Stromwerte der Lasten/Quellen (sofern zutreffend) und hebt alle Bereiche des Netzwerks hervor, in denen eine Parametergrenze verletzt wurde. Beachten Sie, dass die Registerkarte Visual nun im Fokus und aktiv ist.

Bewegen Sie den Mauszeiger über ein beliebiges Element im Netzwerk (Last, Quelle oder Serienelement), um zusätzliche Informationen wie die festgelegten Parameter und Analyseergebnisse anzuzeigen.

Grafische Darstellung im PCB-Editor

Die Simulationsergebnisse können nun im PCB-Editor von Altium Designer grafisch angezeigt werden. Die Darstellung wird über die Einstellungen auf der Registerkarte Visual von PDNA gesteuert.  Stellen Sie die Anzeigeoptionen so ein, dass Voltage für beide Layers (Top und Bottom) von 5V Net angezeigt wird – dies entspricht den anfänglichen Standardeinstellungen. Die Analyseergebnisse werden im PCB-Editor dargestellt und ersetzen die vorhandene grafische Überlagerung der Leiterplatte.

Der Spannungsabfall entlang des ausgewählten Netzpfads – in diesem Fall von der 5-V-Quelle bei TP1 bis zur Komponente LCD1 – wird mit einem Farbverlauf dargestellt, der der Spannungsskala am unteren Rand der Ansicht entspricht. Die Darstellung erfolgt als prozentualer Spannungswert (Option Per Rail unter Color Scale) oder als absoluter Spannungsbereich (Option Displayed).

In der folgenden Abbildung stellt der Farbverlauf entlang des Netzpfads auf der Leiterplatte dessen gesamten Spannungsabfall dar. Der durch ohmsche Verluste verursachte Minimalwert (0%:, blau) liegt an der Komponente LCD1, der Maximalwert (100 %: rot) am festgelegten Anschlusspunkt der Spannungsquelle (TP1).

Um die entsprechende Stromanalyse für das Netzwerk anzuzeigen, wählen Sie auf der Registerkarte Visual die Option Current Density. Hier beziehen sich die Farbabstufungen entlang des Netzpfads auf der Leiterplatte auf die prozentuale Änderung der Stromdichte. Dabei kennzeichnet 100 % (rot) die maximal berechnete Stromdichte im Layout des Netzpfads und 0 % (blau) den Minimalwert – höchstwahrscheinlich 0A/mm2.

Beachten Sie, dass die alternative Spannungs-/Stromskalierung (Displayed) zwar eine intuitivere Darstellung einzelner Netze ermöglicht, bei der gleichzeitigen Anzeige mehrerer Spannungsnetze jedoch nur begrenzt aussagekräftig ist – etwa bei 5V and GND in diesem Beispiel oder wenn mehrere Versorgungsnetze eines Designs analysiert wurden.

Um die Ergebnisse der Power-Integrity-Analyse im GND-Rückstrompfad des Beispiels anzuzeigen und zu analysieren, deaktivieren Sie die Option für das 5V-Netz in der Liste Net auf der Registerkarte Visual des PDNA und wählen Sie anschließend das GND-Netz aus. Der Masse-Rückstrompfad verläuft sowohl über die obere als auch über die untere Lage des Designs. Diese lassen sich im PCB-Editor einzeln anzeigen, indem Sie den jeweiligen Eintrag in der Liste Layer des PDNA auswählen.

Die folgende Abbildung zeigt die Spannungsdarstellung für die untere Lage des GND-Netzes, wobei die Skalierung Color Scale auf Displayed eingestellt ist. Der größte Spannungsabfall (rot: etwa 0,5 mV) tritt am Pin GND des LCD auf, während der geringste Spannungsabfall (blau: etwa 0 V) am Rückleitungspunkt der Spannungsquelle (J1) liegt.

Wenn Sie zur Option Current Density des PDNA wechseln, werden die Bereiche mit der höchsten Stromdichte als rote „Hotspots“ dargestellt. Die maximale Stromdichte selbst (1.74 A/mm2) ist sehr niedrig und liegt deutlich innerhalb akzeptabler Grenzen.

Anzeigesteuerung und Optionen

Der PDN Analyzer bietet verschiedene interaktive Anzeigeoptionen, die festlegen, wie die Analyseergebnisse im PCB-Editor von Altium Designer grafisch dargestellt werden. Neben den Optionen für die Anzeige Color Scale lässt sich die Grafik zwischen den Darstellungsarten 2D und 3D umschalten. Letztere bietet wertvolle Einblicke in die Analyseergebnisse innerhalb von Durchkontaktierungen und zwischen den Lagen.

Darüber hinaus steht die Option Clear zur Verfügung, um die Analyseergebnisse aus der Editoranzeige auszublenden. Dabei wird automatisch wieder das standardmäßige Leiterplattenlayout dargestellt. Die Option Overlay der Ansicht aktiviert dagegen die Leiterplattenlayoutansicht, die zusammen mit den aktuell angezeigten Analyseergebnissen dargestellt wird. Diese Option ist besonders hilfreich, um festzustellen, wo sich eine interessante Stelle aus den Analyseergebnissen im eigentlichen Leiterplattenlayout befindet.

Arbeiten mit Lasten

Bei Bedarf können dem Netz weitere Lasten hinzugefügt und die Versorgungsanalyse erneut ausgeführt werden, um die Ergebnisse zu beurteilen. Um beispielsweise den kleinen Laststrom (etwa 15mA) der Betriebsanzeige-LED des Designs hinzuzufügen, wählen Sie deren Vorwiderstand (R15) als Anschluss an die 5V-Versorgung und den LED-Pin als GND-Anschluss aus.

Mit dem PDN Analyzer lassen sich außerdem die Bauteil-Pinanschlüsse einer Last festlegen. Dadurch können mehrere Lastmodelle für ein einzelnes Bauteil erstellt werden, das über unterschiedliche Pins unterschiedliche Ströme aufnimmt.

Das LCD im Beispielprojekt veranschaulicht diesen Fall: Sein 5V-Anschluss an Pin 15 (LED+) versorgt die Hintergrundbeleuchtung des Displays, während der 5V-Anschluss an Pin 2 (VDD) die interne Logik versorgt. In der Praxis nimmt Pin 15 deutlich mehr Strom auf als Pin 2.

Als LCD1 zuvor als einzelnes PDNA-Lastmodell hinzugefügt wurde, wurden standardmäßig beide Pins als 5V-Lastanschluss festgelegt. Die PDN-Analyse verteilte den Laststrom von LCD1 daher gleichmäßig auf diese Pins. Um die Genauigkeit der Versorgungsanalyse zu verbessern, kann das Bauteil LCD1 durch two Lastmodelle dargestellt werden: eines für jeden 5V-Pin und den zugehörigen Laststrom. Dazu bearbeiten Sie die Pin-Parameter des vorhandenen LCD1-Lastmodells und fügen anschließend eine weitere Last für den separat zu betrachtenden Pin hinzu.

Öffnen Sie das vorhandene LCD1-Lastmodell, indem Sie in der Netzgrafik auf dessen Symbol doppelklicken, um den Dialog Device Properties zu öffnen. Doppelklicken Sie anschließend auf das Feld Pins(s) des Eintrags für das 5V-Versorgungsnetz. Im daraufhin aktivierten Pin-Bearbeitungsmodus können Sie einzelne Bauteil-Pins für diese Last auswählen. Deaktivieren Sie Pin 2, um die Last nur für Pin 15 (LED+) zu konfigurieren, und stellen Sie den Parameter Load Current beispielsweise auf 75mA ein, um den Strom der LCD-Hintergrundbeleuchtung abzubilden.

Erstellen Sie als Nächstes eine weitere Last für LCD1 im 5V-Netz und aktivieren Sie Pin 2 bei deaktiviertem Pin 15, um die Last VDD abzubilden. Für diese kann ein entsprechend niedrigerer Wert für Load Current eingestellt werden – beispielsweise 20mA.

Das 5V-Versorgungsnetz kann anschließend erneut analysiert werden, um die Lastverteilung von LCD1 über die Netzpfade genauer abzubilden.

Der Unterschied in der Laststromverteilung wird beim Vergleich der Stromdichte in den Leiterbahnen des LCD1-Versorgungsnetzes zwischen der ursprünglichen und der aktualisierten Lastkonfiguration sichtbar. Die folgenden Abbildungen der Stromdichteanalyse zeigen links das Ergebnis des ursprünglichen LCD1-Modells mit einer einzelnen Last und rechts das aktualisierte Ergebnis mit mehreren Lasten.

Beachten Sie die Stromdichte in den Leiterbahnen, die Pin 2 (das weiter links liegende LCD-Pad) und Pin 15 versorgen. Die aktualisierte Version zeigt korrekt, dass der Großteil des LCD-Stroms zu Pin 15 (dem weiter rechts liegenden LCD-Pad) fließt, anstatt wie zuvor gleichmäßig auf beide Pins verteilt zu werden (linke Abbildung).

 

Simulationseinstellungen

Die Ergebnisse einer Analyse und insbesondere das Ausmaß der ohmschen Spannungsabfälle in den Kupferflächen der Leiterplatte hängen auch von den Angaben zur Leitfähigkeit des Leiterplattenkupfers und zur Wandstärke der Durchkontaktierungen ab. Um diese Einstellungen anzuzeigen und zu bearbeiten, wählen Sie die Registerkarte Simulation im Dialog Settings aus. Zum Öffnen des Dialogs klicken Sie mit der rechten Maustaste auf den Namen der aktuellen Analyse und wählen im Kontextmenü Settings.

Metallleitfähigkeit

Der Abschnitt Metal Conductivity des Dialogs enthält Angaben und Einstellungen zum Leitfähigkeitswert (Kehrwert des spezifischen Widerstands; 1/R) des im Design verwendeten Metalls. Die Grundleitfähigkeit (bzw. der spezifische Widerstand), der Temperaturkoeffizient und/oder die Temperatur lassen sich im Dialog auswählen oder ändern, um die Eigenschaften des Leiterplattenaufbaus im Design abzubilden:

  • Pure Copper – Für Kupfer wird üblicherweise eine Leitfähigkeit von 5.88e7S/m bei 25°C und ein Temperaturkoeffizient der Leitfähigkeit von 0.4%/°C angenommen. Dieser positive Temperaturkoeffizient bedeutet beispielsweise, dass eine Erhöhung der Einstellung Temp. Compensation im Dialog von 25°C auf 125°C (Differenz: 100°C) die Leitfähigkeit in der Simulation um 40% auf 3.53e7S/m verringert.
  • PCB Copper – Dies ist die Standardeinstellung für Simulationen. Sie entspricht den in der Fachliteratur angegebenen Leitfähigkeitswerten für galvanisch abgeschiedenes Kupfer (ED-Kupfer) auf Leiterplatten. Dafür wurde eine Leitfähigkeit von 4.7e7S/m bei 25°C mit einem Temperaturkoeffizienten von 0.4%/°C gemessen.
  • Custom – Wählen Sie diese Option, um bestimmte Werte für die Leitfähigkeit oder den spezifischen Widerstand für die Simulation einzugeben.

Beachten Sie, dass der angezeigte Wert Sim Conductivity die endgültige Leitfähigkeit unter Berücksichtigung aller Parameter darstellt. Der Wert „Sim Resistivity“ ist dessen Kehrwert.

Durchkontaktierung

Legen Sie mit dem Wert Via Wall Thickness im Dialog die Metallstärke der Durchkontaktierungswände für alle Durchkontaktierungen in der Simulationsanalyse des Designs fest.

Diese Einstellung kann die Gleichstromverluste im Versorgungsnetz merklich beeinflussen, da eine dünnwandige bzw. dünn metallisierte Durchkontaktierung einen entsprechenden Eigenwiderstand aufweist. Bei ausreichender Größe bzw. Metallstärke beeinträchtigt eine Durchkontaktierung das Gleichstromverhalten eines Designs jedoch nicht. Sie weist dann dieselbe Stromdichte wie die angeschlossenen Versorgungsleiterbahnen und keinen nennenswerten Spannungsabfall zwischen ihren Anschlusspunkten auf. Ein Beispiel für eine Gleichstromanalyse der Verluste in Durchkontaktierungen finden Sie in einem weiter unten folgenden Abschnitt.

Für die Simulation bestimmen die Größe und die Wandstärke der Durchkontaktierung die Menge des leitfähigen Materials, das durch die Durchkontaktierung repräsentiert wird, und damit ihren Widerstand bzw. ihre Leitfähigkeit. Bei der Simulation wird davon ausgegangen, dass der Durchmesser der Durchkontaktierung dem fertigen Bohrungsdurchmesser entspricht und die Wandstärke der Durchkontaktierung diesen Durchmesser vergrößert. Daher gilt: Finished Hole Diameter + (2 x Wall_Thickness) = Drill Diameter.

Beispiel 2

Dieses Beispiel zeigt, wie eine Reihe miteinander verbundener Netzwerke implementiert werden kann, die sich als Ganzes analysieren lassen, wobei die Parameter der verbindenden Serienelemente berücksichtigt werden. Außerdem wird erläutert, wie Quellen in Form von Spannungsreglermodellen (VRMs) hinzugefügt werden, die ebenfalls als Verbindungen zwischen Netzwerken dienen, und wie eine vollständige Hierarchie des Stromversorgungsnetzwerks eines Designs aufgebaut wird.

Das Beispiel modelliert das Netzwerk von PWR_IN bis 5V des Referenzprojekts SpiritLevel-SL1 und umfasst sowohl den 3,3-V-VRM (VCCO) als auch den 1,8-V-VRM (VCCINT), um eine vollständige Stromversorgungsnetzwerkstruktur zu erstellen.

Die Voraussetzungen für dieses PDN-Simulationsbeispiel sind:

  • Das Leiterplattenprojekt Spirit Level ist in Altium Designer geöffnet.
  • Die Anwendung PDN Analyzer ist aktiv (Tools » PDN Analyzer).
  • Die Gleichspannungsnetze des Leiterplattendesigns wurden im Dialogfeld PDN Analyzer DC Net Identification identifiziert, wie oben beschrieben.

Beginnen Sie mit dem Aufbau des Beispiel-Stromversorgungsnetzwerks, indem Sie das Eingangsversorgungsnetz (PWR_IN) in einer neuen Simulation angeben (wählen Sie bei Bedarf File » New Simulation). Wie im Projektschaltplan angegeben, beträgt der PDN-Parameter <Power Net> PWR_IN, <Ground Net> beträgt GND und Source beträgt J1.

Netzwerke über Serienelemente erweitern

Um den vollständigen Versorgungspfad vom Netzwerk PWR_IN zum Netzwerk 5V zu modellieren, müssen die in Reihe geschalteten Bauteile Sicherung (F1) und Schalter (S1) sowie das dazwischenliegende Netz hinzugefügt werden. In der PDNA-Oberfläche werden diese durch schrittweises Erweitern des Stromversorgungsnetzwerks hinzugefügt. Jede Netzerweiterung wird über ein universelles Serienelementmodell angebunden.

Um ein Netz zu erweitern, klicken Sie zunächst mit der rechten Maustaste in das Netzwerk, das Sie erweitern möchten, und wählen Sie im Kontextmenü die Option Extend Network. Wählen Sie im Dialogfeld Choose Net das Netzwerk aus, das über ein Serienelement mit PWR_IN verbunden ist. In diesem Fall ist dies NetD1_2 – das Netzwerk, das F1 und Pin 3 von S1 verbindet und als Pin 2 der Diode D1 gekennzeichnet ist.

Da dieses Netzwerk vermutlich nicht bei der anfänglichen Identifizierung der Gleichspannungsnetze erfasst wurde, deaktivieren Sie im Dialogfeld Choose Net die Option List DC nets only, damit dieses Netz zur Auswahl angezeigt wird.

Bei der Netzerweiterung wird automatisch ein Serienelement zwischen den beiden Netzen hinzugefügt. Doppelklicken Sie auf dieses Element, um seine Verbindungen und Parameter im Dialogfeld Device Properties festzulegen. Das Serienelementmodell besteht aus einer Spannungsquelle in Reihe mit einem Widerstand und ermöglicht so die grundlegende Modellierung von Bauteilen wie Widerständen, Induktivitäten, Dioden und Schaltern.

In diesem Fall ist das Serienelement die Sicherung F1, die über die Verbindungsoptionen RefDes ausgewählt wird und einen nominalen internen Resistance von 0.1Ω erhält. Wäre das Serienelement ein Halbleiterbauteil, beispielsweise eine Diode, würde zusätzlich zum internen Resistance-Wert des Bauteils der Parameter Voltage Drop angegeben.

Dem Schaltplan folgend besteht der nächste Schritt darin, das Netz D1_2 über den Schalter S1 zum Versorgungsnetz 5V zu erweitern. Wählen Sie wie zuvor Extend Net im Kontextmenü der rechten Maustaste und wählen Sie im Dialogfeld Choose Net das Netz aus, zu dem die Erweiterung erfolgen soll.

Das hinzugefügte Serienelement ist in diesem Fall S1, das das Netz D1_2 über die Pins 3 und 2 mit dem Ausgangsnetzwerk 5V verbindet (siehe Schaltplan). Da der ungenutzte Schaltereingang von S1 (Pin 1) mit dessen Ausgangsanschluss (Pin 2) verbunden ist und keinen Laststrom führt, kann Pin 1 hier beispielhaft über die Optionen zur Pin-Auswahl im Dialogfeld Device Properties aus der Netzwerkanalyse entfernt werden. Doppelklicken Sie dazu auf das Feld Pin(s) des Anschluss-Eintrags OUT.

Dem 5-V-Abschnitt der verbundenen Stromversorgungsnetzwerke kann nun eine Last hinzugefügt werden – in diesem Fall die des Anzeigemoduls LCD1.

Wenn die Analyse erneut ausgeführt wird, umfassen sowohl die Daten als auch die grafische Darstellung im PCB-Editor alle drei verbundenen Stromversorgungsnetzwerke und zeigen den berechneten Strom sowie den Spannungsabfall über den verbindenden Serienelementen.

Spannungsreglermodelle einbeziehen

PDN Analyzer bietet aktive Spannungsreglermodelle (VRMs), die zwischen Spannungseingangs- und Spannungsausgangsnetzwerken eingefügt werden können. Werden sie PDNA-Stromversorgungsnetzwerken hinzugefügt, erscheinen sie sowohl als Last im Spannungseingangsnetzwerk als auch als Quelle im Spannungsausgangsnetzwerk. Die VRM-Modelloptionen umfassen Linearregler, Schaltregler und Schaltregler mit Fernmessung.

Das Referenzprojekt SpiritLevel-SL1 verwendet lineare Spannungsregler, um die Versorgungsschienen für 3,3 V (VCCO) und 1,8 V (VCCINT) bereitzustellen. Wenn der VCCO-Regler (U3) dem PDNA-Simulationsnetzwerk hinzugefügt wird, erscheint er als Last im 5-V-Eingangsnetzwerk und als Quelle für das 3,3-V-Netzwerk. 

Um den Linearregler U3 als Last im 5-V-Netzwerk zu platzieren (wie im obigen Verfahren umgesetzt), fügen Sie dem 5-V-Netzwerk eine Last hinzu und wählen Sie im Dialogfeld Device Properties die Option VRM (Linear) als Device Type. Legen Sie die Verbindungen des Modells gemäß dem Schaltplan fest und geben Sie den Pin Ref als GND-Anschluss von R14 an. Dieser Bezugspunkt könnte sich je nach Layout des GND-Netzwerks auch an einer anderen, möglicherweise besser geeigneten Stelle in der unmittelbaren Umgebung auf der Leiterplatte befinden.

Um den VRM fertigzustellen, legen Sie seinen Ausgangsspannungsparameter (Vout: 3.3V) und optional seinen internen Ausgangswiderstand, den Ruhestrom sowie alle Limits fest, die während der Analyse erkannt werden sollen.

PDNA bietet eine Funktion, mit der das ausgangsseitige Modell des VRM automatisch als Quelle zum Zielnetz für die Ausgangsspannung hinzugefügt und dieses Netzwerk bei Bedarf erstellt werden kann.

Klicken Sie für dieses Beispiel mit der rechten Maustaste auf das soeben erstellte VRM-Lastmodell (Load2: U3) und wählen Sie die Option Add VRM To New Network. Dadurch wird automatisch das VCCO-Netzwerk mit dem ausgangsseitigen Modell des VRM (Source 1: U3) als Spannungsquelle (3,3 V) erstellt.

Beachten Sie, dass die beiden Darstellungen des 3,3-V-VRM – sein Eingangsmodell als Last im 5-V-Netz und sein Ausgangsmodell als Quelle für das 3,3-V-Netz – miteinander verknüpft sind und tatsächlich dasselbe Modell darstellen. Daher kann der VRM in der PDNA-Oberfläche von beiden Netzwerken aus aufgerufen und bearbeitet werden.

Das neue VCCO-Netzwerk kann nun ausgewählt und eine geeignete Last hinzugefügt werden. In diesem Beispiel handelt es sich um einen Laststrom von 0,2 A, der über mehrere Pins des Bauteils U1 fließt.

Die fertige Stromversorgungsnetzwerkanordnung umfasst nun zwei Netzwerke (PWR_IN und VCCO), die über den 3,3-V-VRM vom Typ Linearregler miteinander verbunden sind. Wenn in der aktuellen PDNA-Dateistruktur die oberste Ebene der Netzwerkhierarchie ausgewählt wird, bietet die Netzwerkgrafik eine blockartige Übersicht über die Verbindungen zwischen den Versorgungsnetzen.

In diesem Beispiel wurde der VRM dem 5-V-Netzwerk (Eingangsspannung) als Last hinzugefügt und anschließend verwendet, um automatisch das 3,3-V-Ausgangsspannungsnetzwerk (VCCO) mit dem VRM als Quelle zu erstellen. Dieser Vorgang ist auch in umgekehrter Reihenfolge möglich, was in manchen Fällen praktischer sein kann. Dabei wird der VRM dem Ausgangsspannungsnetzwerk als Quelle hinzugefügt und dieses Modell anschließend einem Eingangsspannungsnetzwerk als Last zugewiesen (Add VRM To New Network oder Add VRM To Existing Network).

Eine PDN-Analyse liefert Ergebnisse für das gesamte verbundene Netzwerk einschließlich des VRM. Im PCB-Editor werden alle Netzwerke grafisch dargestellt, wenn in der PDNA-Oberfläche die oberste Ebene der Netzwerkhierarchie ausgewählt ist. Wählen Sie in der Liste ein einzelnes Netzwerk aus, um die grafische Darstellung auf dieses Netzwerk zu beschränken, und schalten Sie die Optionen Net und Layer im unteren Bereich um, um die Ansicht weiter anzupassen.

Beachten Sie, dass der GND-Netzwerkpfad des Beispiels nun die Rückstromanteile sowohl des Netzwerks PWR_IN als auch des Netzwerks VCCO umfasst.

Das Stromversorgungsnetzwerk des Beispielprojekts lässt sich vervollständigen, indem der verbleibende VRM (U4) und sein 1,8-V-Ausgangsversorgungsnetzwerk (VCCINT) hinzugefügt werden.

Fügen Sie dem 5-V-Netzwerk wie zuvor beschrieben einen linearen VRM hinzu und setzen Sie dessen Parameter Vout auf 1.8V.

Fügen Sie den VRM (hier Load 3) einem neuen Netzwerk hinzu, um das 1,8-V-Versorgungsnetzwerk (VCCINT) zu erstellen.

Fügen Sie dem VCCINT-Netzwerk eine geeignete Last hinzu – hier die 1,8-V-Versorgungspins des Bauteils U1.

Die Netzwerkhierarchie in der PDNA-Oberfläche zeigt nun alle drei miteinander verbundenen Netzwerke.

Eine PDN-Analyse liefert Ergebnisse für das gesamte verbundene Netzwerk einschließlich der VRMs.

Beachten Sie erneut, dass das GND-Netzwerk nun den Rückstrom aller drei Netzwerke umfasst, die die gemeinsamen Kupferflächen der GND-Lage nutzen. Seine maximale Stromdichte (65.8 A/mm2) ist jetzt hoch und überschreitet wahrscheinlich die zulässigen Grenzwerte.

Probleme mit der Versorgungsintegrität lokalisieren

Der PDN Analyzer bietet umfangreiche grafische Informationen und Daten, mit denen sich die Versorgungsintegrität eines analysierten Leiterplattendesigns bewerten und Probleme untersuchen lassen.

Im oben gezeigten Beispiel weist die Analyse des GND-Netzwerkpfads Top Layer auf eine unzulässig hohe Stromdichte hin, wie der maximale Skalenwert von 65.8A/mm2 zeigt. Die Lage des Problembereichs ist nicht unmittelbar ersichtlich, lässt sich jedoch mithilfe der PDNA-Funktion Highlight Peak Values sichtbar machen.

Wenn diese Funktion ausgewählt und die Option Filter auf Maxima eingestellt ist, wird der Bereich mit der höchsten Stromdichte in der Analysegrafik im PCB-Editor hervorgehoben und markiert.

Klicken Sie auf die Schaltfläche , um die grafische Hervorhebung zu wiederholen, oder verwenden Sie die zugehörigen Schaltflächen (), um die höchsten Spitzenwerte bzw. deren Positionen der Reihe nach durchzugehen. Legen Sie mit den Optionen Scope fest, ob die Spitzenwerte im aktuell sichtbaren Leiterplattenbereich (In View)) oder im gesamten Layout (Design) hervorgehoben werden sollen – bei letzterer Option wird beim Durchgehen der Positionen die Ansicht jeweils entsprechend verschoben und gezoomt.

Weitere Informationen zu einem kritischen Bereich erhalten Sie, indem Sie die PDNA-Funktion Show Arrows aktivieren. Diese blendet mehrere Pfeile ein, die an der jeweiligen Position die Stromrichtung (durch den Winkel des Pfeils) und die relative Stromstärke (durch die Größe des Pfeils) angeben. In diesem Beispiel bestätigt dies, dass der Bereich mit hoher Stromdichte im Rückstrompfad von U1 (oben) zum GND-Bereich am unteren Rand der Leiterplatte liegt.

Eine Möglichkeit zur Behebung dieses Problems besteht darin, die Leiterbahn im kritischen Bereich zu verbreitern.

Die Leiterplatte kann bei aktivem PDN Analyzer bearbeitet werden. Dadurch lässt sich das Layout schrittweise verbessern und anschließend erneut analysieren. Klicken Sie im Bereich Views auf die Schaltfläche Clear, um die Anzeige der PDNA-Ergebnisse im PCB-Editor zu deaktivieren, und nehmen Sie die erforderliche Änderung an der Leiterplatte vor.

Anschließend kann die PDN-Analyse wiederholt werden (klicken Sie auf ), um die Ergebnisse zur Versorgungsintegrität zu prüfen. Die beiden folgenden Abbildungen veranschaulichen die Veränderung der Stromdichte im GND-Netzwerk (auf Top Layer) durch die Verbreiterung der Leiterbahn an dieser kritischen Stelle. Die obere Abbildung zeigt das ursprüngliche Stromdichteergebnis, die untere die Stromdichtegrafik nach der Änderung der Leiterplatte.

Bei diesem Vorher-Nachher-Vergleich (obere bzw. untere Abbildung) sind folgende Punkte zu beachten:

  • Die maximale Stromdichte in der GND-Lage ist auf einen akzeptablen Wert von etwa einem Zehntel des ursprünglichen Werts gesunken – von 65.8A/mm2  auf 7.1A/mm2.
  • Die Bereiche mit den höchsten Stromdichten, deren Werte nun deutlich niedriger sind, sind gleichmäßiger über die GND-Rückstrompfade verteilt, statt sich an einer problematischen Stelle zu konzentrieren.
  • Für einen direkten grafischen Vergleich stellen Sie die Stromdichteskala manuell auf den vorherigen Wert ein: Wählen Sie die Skalenoption Manual, geben Sie 65.8 in das Feld Max ein und klicken Sie auf die Schaltfläche , um die Anzeige zu aktualisieren.

Verletzungen der Stromdichtegrenzwerte

Eine objektivere Methode zur Lokalisierung und Behebung von Problemen mit der Versorgungsintegrität in den Strompfaden eines Leiterplattendesigns besteht darin, konkrete Stromdichtegrenzwerte festzulegen, deren Überschreitung eine Verletzung auslöst. Weitere Informationen zu anderen Arten von Verletzungen finden Sie weiter unten.

Stromdichtegrenzwerte für Außen- und Innenlagen sowie Durchkontaktierungen werden auf der Registerkarte Limits im Dialogfeld Settings festgelegt. Dieses öffnen Sie, indem Sie mit der rechten Maustaste auf den Namen der aktuellen PDN-Simulation klicken und im Kontextmenü Settings auswählen. Die festgelegten Grenzwerte gelten für alle Außen- und Innenlagen sowie Durchkontaktierungen im Leiterplattendesign.

Die festgelegten Stromdichtegrenzwerte werden auf die Ergebnisse der aktuellen Analyse angewendet und können geändert und erneut geprüft werden, ohne die Simulation erneut ausführen zu müssen – die Grenzwertprüfung erfolgt nach der Analyse. Netzwerke, die Verletzungen enthalten, werden mit einer gestrichelten roten Umrandung angezeigt.

Im hier gezeigten Beispiel enthält das VCCO-Versorgungsnetzwerk Stromdichteverletzungen. Wenn das VCCO-Netzwerk selbst ausgewählt wird, zeigt die hervorgehobene Umrandung des VCCO-Versorgungspfads an, dass eine Verletzung vorliegt.

Bewegen Sie den Mauszeiger über das Netzwerk mit den Verletzungen, um eine Pop-up-Liste der aktuellen Verletzungen und der zugehörigen Details anzuzeigen. Der einzelne Eintrag in diesem Fall gibt an, dass die Stromdichte in einer Durchkontaktierung (ca. 34.5A/mm2) den festgelegten Grenzwert (30A/mm2) überschreitet.

Doppelklicken Sie auf den Verletzungseintrag, um die zugehörige Position auf der Leiterplatte per Cross-Probing anzusteuern, also die Ansicht dorthin zu verschieben und zu zoomen. In der folgenden Abbildung ist die PDNA-Grafikansicht auf den Modus 3D eingestellt, der die betreffende Durchkontaktierung und ihre Verbindungen zur Ober- und Unterseite deutlicher darstellt.

Beachten Sie, dass die Durchkontaktierung im Leiterplattendesign des Projekts Spirit Level verkleinert wurde, um eine einzelne Verletzung zu demonstrieren.

Die zugehörigen Daten für diese Durchkontaktierung, einschließlich eines Hinweises auf die Stromdichteverletzung, sind auf der Registerkarte Via der PDNA-Oberfläche verfügbar.

Die Liste der Durchkontaktierungsdaten gilt für alle Netzwerke im aktuellen Design. Klicken Sie auf die Spaltenüberschriften Net und Current Density, um die Liste so zu sortieren, dass die Durchkontaktierungen des VCCO-Netzwerks nach Stromdichte geordnet angezeigt werden. Alle Stromdichtewerte, die den festgelegten Grenzwert überschreiten, werden rot hervorgehoben.

Doppelklicken Sie auf einen beliebigen Eintrag in der Liste der Durchkontaktierungen, um die zugehörige Position in der PDNA-Leiterplattengrafik per Cross-Probing anzusteuern.

Weitere Verstöße

Neben der Erkennung von Überschreitungen der festgelegten Stromdichtegrenzwerte erkennt der PDN Analyzer auch gezielt Verstöße gegen die Leistungsanforderungen des Netzwerks, beispielsweise gegen Grenzwertparameter, die beim Hinzufügen einer Last, einer Quelle oder eines Serienelements in der Simulationskonfiguration festgelegt wurden.

Zu diesen Grenzwertparametern der Simulation gehören:

  • Der zulässige Spannungsbereich an einer Last
  • Der maximale Ausgangsstrom einer Quelle
  • Die zulässige Verlustleistung einer Linearreglerquelle und deren maximaler Ausgangsstrom.
  • Der maximale Ausgangsstrom einer Schaltreglerquelle.
  • Der maximale Strom durch ein Serienelement.
Im Gegensatz zu den Simulationsparametern der Netzwerkelemente (wie Quellenspannung oder Laststrom), die während der Analyse verarbeitet werden, erfolgt die Erkennung von Grenzwertverletzungen (etwa der festgelegten Mindestspannung an einer Last) erst nach der Analyse. Das bedeutet, dass sich Änderungen an einem Grenzwertparameter sofort auswirken, ohne dass die Simulationsanalyse erneut ausgeführt werden muss.

Wenn ein Grenzwertparameter festgelegt wurde (also einen Wert ungleich null hat), wird das betreffende Netzwerkelement bei einer Grenzwertverletzung in der Netzwerkgrafik der PDNA-Oberfläche hervorgehoben. Bewegen Sie den Mauszeiger über das Element, um dessen Parameter und Analyseergebnisse anzuzeigen.

Im unten gezeigten Beispiel hat die berechnete Verlustleistung in Source 1 (Spannungsregler U1) den festgelegten maximalen Verlustleistungswert von 2W überschritten.

Detailliertere Informationen zur Leistungsfähigkeit eines Versorgungsnetzwerks finden Sie auf der zugehörigen Netzwerkregisterkarte. Diese zeigt die Analyseergebnisse in Tabellenform an und enthält die berechneten Werte für die Leistungsaufnahme des Netzwerks.

Beispiel 3

Dieses Beispiel veranschaulicht den Einsatz der Schaltnetzteil-Simulationsmodelle (SMPS-Modelle bzw. VRMs) des PDN Analyzer in einem Versorgungsnetzwerk und zeigt, wie ein aktualisiertes Netzwerkmodell genauere Ergebnisse bei der Leistungsanalyse liefern kann. Außerdem gibt das Beispiel einen Überblick über die Verwendung der Spannungssonden- und Konturfunktionen des PDNA, mit denen Spannungsdaten an bestimmten Punkten oder in bestimmten Bereichen des Leiterplattenlayouts dargestellt werden können.

Das Beispiel basiert auf dem Altium-Referenzprojekt DB46 Xilinx Daughter Board und konzentriert sich auf den SMPS-Abschnitt (U5), der für das 1,2-V-Versorgungsnetzwerk (1V2) des Designs verwendet wird.

Auch für dieses PDN-Simulationsbeispiel gelten die folgenden Voraussetzungen:

  • Das Projekt DB46 Xilinx Daughter Board ist in Altium Designer geöffnet.
  • Die Anwendung PDN Analyzer ist aktiv (Tools » PDN Analyzer).
  • Die Gleichspannungsnetze des Leiterplattendesigns wurden im Dialogfeld PDN Analyzer DC Net Identification identifiziert, wie oben beschrieben. Beachten Sie, dass für dieses Beispiel auch die Netzwerke LX und AGND benötigt werden.

Beginnen Sie mit dem Aufbau des beispielhaften Versorgungsnetzwerks, indem Sie das Eingangsversorgungsnetz in einer neuen Simulation festlegen (wählen Sie bei Bedarf File » New Simulation). Wie im obigen Schaltplan dargestellt, ist <Power Net> des PDN 5V und <Ground Net> ist GND. Als Source für das 5-V-Netzwerk dient die Stiftleiste HDR_T1 oder HDR_B1.

Schaltregler-VRM

Das Modell für die SMPS-Schaltung des Designs wird dem 5-V-Versorgungsnetzwerk hinzugefügt, indem im Dialogfeld Device Properties die Option VRM(SMPS) als Device Type der Last ausgewählt wird. Wie im Modellschaltplan im Dialogfeld dargestellt, werden die IN- und OUT-Pingruppen separat definiert.

Um dieses Modell für die Schaltung korrekt zu definieren, geben Sie LX als Ausgang, U5 für die Optionen RefDes und 1.2V als Parameter Vout an – wie im obigen Schaltplan gezeigt. Optional können Sie Rout sowie die Wirkungsgrad-/Stromparameter passend zum verwendeten SMPS-Baustein einstellen.

Schließen Sie die Implementierung des SMPS-Modells ab, indem Sie den VRM zu seinem Ausgangsnetzwerk (Add VRM To New Network) hinzufügen, das automatisch als Netzwerk LX ausgewählt wird. Anschließend kann das Netzwerk LX gemäß dem Schaltplan um das 1,2-V-Versorgungsnetzwerk erweitert werden.

Die Netzwerke LX und 1V2 sind durch das Serienelement L1 (die Abwärtswandler-Induktivität des SMPS) miteinander verbunden. Für dieses sollte ein geeigneter Serienwiderstand eingestellt werden. Für dieses Beispiel wird ein etwas hoher Wert von 0.2Ω verwendet.

Fügen Sie abschließend U4 als 0.3A-Last zum Netzwerk 1V2 hinzu und legen Sie eine zulässige Abweichung der Lastspannung von +/-5% fest. Beachten Sie, dass die Optionen für die Stromdichtegrenzwerte auf der Registerkarte Limits des Dialogfelds Settings für dieses Beispiel auf 0 eingestellt sein sollten (die Standardeinstellung ohne Grenzwert).

Führen Sie die Analyse aus. Beachten Sie, dass die Last im zusammengesetzten Netzwerk LX einen Verstoß anzeigt, da die Spannung des Netzwerks 1V2 an der Last (U4) unzulässig niedrig ist (etwa 1.14V).

Datensonde

Neben der visuellen Auswertung der PDNA-Grafik und der Skala im PCB-Editor bietet der PDN Analyzer verschiedene Werkzeuge zur Auswertung der Analyseergebnisse in bestimmten Bereichen oder an bestimmten Punkten des Designlayouts, beispielsweise Probe, das gerade aktiv ist.

Mit dem Sondenwerkzeug lassen sich Spannungs- oder Stromdichtedaten an ausgewählten Punkten im Designlayout erfassen und vergleichen. Dank seiner Vielseitigkeit ermöglicht das Werkzeug eine präzise Bewertung der Analyseergebnisse in jedem Netzwerk und auf jeder Lage. In diesem Beispiel kann es jedoch dazu verwendet werden, die Ursache des unzulässigen Spannungsabfalls an der Last des Netzwerks 1V2 zu bestätigen – dieser ist eindeutig auf den Widerstand des Serienelements L1 zurückzuführen.

Um eine Differenzmessung der Spannung im Netzwerk 1V2 durchzuführen, stellen Sie den PNDA zunächst so ein, dass nur Layer MidLayer 1 (der Hauptpfad der 1,2-V-Versorgung zu U4) und Net 1V2 angezeigt werden. Klicken Sie auf die Schaltfläche , um das Dialogfeld Probe zu öffnen, und aktivieren Sie die erste Sondenposition (). Wählen Sie mit dem Fadenkreuz den Punkt mit der höchsten Spannung aus (die Quelle des Netzwerks 1V2 auf dieser Lage). Aktivieren Sie anschließend die Option  Difference der Sonde und wählen Sie die zweite Position () aus – den Punkt mit der niedrigsten Spannung an der Last U4.

Beachten Sie, dass der Messwert Difference der Sonde einen Spannungsabfall von nur etwa 3mV entlang des Netzwerkpfads anzeigt. Prüfen Sie auf die gleiche Weise den Pfad des Netzwerks LX (mit aktivierten Top und Bottom Layer). Hier zeigt sich ein Spannungsabfall von lediglich etwa 0.5mV.

Eine Spannungsdifferenzmessung mit der Sonde between den beiden Netzwerken (Net LX und 1V2 aktiviert, Top und Bottom Layer) zeigt einen Spannungsabfall von 60mV über der Induktivität L1. Dies ist der wesentliche Spannungsverlust, der diesen konkreten Verstoß in der Analyse auslöst.

Die hier gezeigte Untersuchung mit der Spannungssonde hat zwar die Hauptursache der ohmschen Spannungsverluste im Versorgungsnetzwerk ermittelt, doch hätte sich diese auch direkter durch eine Prüfung der Spannungsdaten an den Bauteilpins auf der Registerkarte Pins des PDNA feststellen lassen. Die Sondenfunktion eignet sich besonders für detailliertere Untersuchungen, bei denen ihre präzise Positionierung voll genutzt werden kann.

SMPS-VRM mit Spannungserfassung

Die in diesem Beispiel verwendete Schaltnetzteilschaltung würde normalerweise eine Induktivität (L1) mit einem wesentlich geringeren Widerstandswert verwenden. Die Analyseergebnisse verdeutlichen jedoch, dass das grundlegende SMPS-Modell Verluste durch L1 nicht berücksichtigen kann – in einer praktischen Schaltung wäre dies allerdings im Allgemeinen kein Problem.

In der SMPS-Schaltung des Beispielprojekts wird die von U5 (an Pin 8) erfasste Rückkopplungsspannung aus der Widerstandskette R25–R26 abgeleitet, die zwischen dem Ausgangsnetz 1V2 und dem analogen Massenetz AGND liegt. Letzteres ist über einen 0Ω-Kopplungswiderstand R118 mit dem Netz GND verbunden.

Beachten Sie, dass das zugrunde liegende Referenzprojekt DB46 Xilinx Daughter Board für dieses Beispiel geändert wurde: Anstelle der direkten Kupferverbindung wurde eine widerstandsbasierte Netzkopplung (R118) zwischen den Netzen GND und AGND eingefügt.

Um das Schaltungsverhalten im Bereich von U5 genauer zu modellieren, kann anstelle des standardmäßigen SMPS-Bauelements das Schaltreglermodell mit Fernmessung von PDNA verwendet werden. Dieses Modell bietet separate Anschlüsse zur Spannungsmessung (S+ und S-), die an beliebige Pins der angegebenen Ausgangsnetze „angeschlossen“ werden können – beispielsweise an die Pins der Widerstandskette zur Spannungsmessung in dieser Schaltung.

Der erste Schritt zur Erstellung eines vollständigeren Netzmodells für die SMPS-Schaltung U5 besteht darin, das Netz AGND zum vorhandenen Netz GND hinzuzufügen. Verwenden Sie die Option Extend Network und wählen Sie das Netz AGND aus.

Das Netz AGND ist über den Widerstand R118 mit dem Netz GND verbunden, wie im obigen Schaltplan dargestellt. Für den Widerstand sollte ein Resistance-Wert von 0Ω festgelegt werden.

Um das SMPS-Modell im Netz LX zu aktualisieren, löschen Sie das vorhandene Quellenbauelement U5 (Source 1) und fügen Sie stattdessen das alternative SMPS-Sense-Modell hinzu. Legen Sie die Verbindungen der IN- und OUT-Anschlüsse wie zuvor fest. Die Messanschlüsse (S+/S-) werden mit den beiden Enden der Rückkopplungs-Widerstandskette der Schaltung verbunden, wie im Schaltplan dargestellt.

Übernehmen Sie das neue SMPS-Modell aus dem Netz LX in das Quellennetz 5V, damit die Netze übereinstimmen. Löschen Sie dazu dessen Last U5 und wenden Sie anschließend die Quellenoption Add VRM To Existing Network » 5V im Netz LX an.

Die aktualisierte Schaltung kann anschließend erneut analysiert werden, um die Ergebnisse zu bewerten.  Wie in der folgenden Abbildung gezeigt, liegt die Lastspannung nun deutlich innerhalb der Anforderung +/-5%, sodass keine Verletzung angezeigt wird. Durch die Erfassung der Ausgangsspannung am Netz 1V2 hat das SMPS den Spannungsverlust im Serienelement L1 ausgeglichen – entsprechend ist die Spannung am Netz LX um 60mV höher.

Während die Verwendung des erweiterten SMPS-Sense-Modells für diese spezielle Schaltung genauere Analyseergebnisse liefert, können bei der praktischen Verwendung von SMPS-Bauelementen mit Fernmessfunktion direkte Leiterplattenverbindungen von den Messanschlüssen zur Last selbst vorgesehen sein, anstatt zu einem nahe gelegenen Rückkopplungsnetzwerk. In diesem Fall würden beide Messleitungen (S+ und S-)) über eigene Leiterbahnen zu den jeweiligen Enden der Last oder in deren Nähe geführt.

Spannungskonturen

Die Entscheidung, wo die Fernmessleitungen eines SMPS am besten angeschlossen werden sollten (wie oben beschrieben), ist eine der vielen möglichen Anwendungen der Funktion Voltage Contour von PDN Analyzer, die wichtige Spannungsübergangspunkte im Leiterplattenlayout grafisch darstellt.

Mit dieser Funktion lassen sich gestrichelte Spannungskonturlinien über die angezeigten Lagen in der grafischen Ansicht des PCB-Editors legen. Es können mehrere Konturlinien festgelegt und entweder als Prozentsatz des Spannungsabfalls im Netz oder als absolute Spannungswerte angezeigt werden – siehe die Optionen Indicate.

Zusätzlich zu den Konturlinien an festgelegten Prozentwerten kann mit der Option Slider eine weitere Linie eingeblendet werden, deren Übergangspunkt sich stufenlos einstellen lässt.

Um beispielsweise einen geeigneten positiven Spannungsmesspunkt an der Last für ein SMPS zu bestimmen, sollte die Messleitung an einem Punkt angeschlossen werden, dessen Spannung um weniger als beispielsweise 20% des Spannungsabfalls von der Spannung an der Last abweicht. Für das oben gezeigte SMPS-Sense-Beispiel würde eine Messleiterbahn von U5 (S+) an einem beliebigen geeigneten Punkt zwischen den Lastpins U4 (links) und der Spannungskonturlinie 20% mit der Versorgungsfläche des Netzes 1V2 verbunden.

Ebenso könnte zur Bestimmung geeigneter Abgriffpunkte für die negative Messleitung (S-) des SMPS (U5) eine Spannungskonturlinie von beispielsweise 80% für den Rückstrompfad der Last (U4) auf der Lage GND festgelegt werden. Da es sich hierbei um einen negativen Lastrückstrom handelt, sollte der Anschlusspunkt der negativen Messleitung auf der Massefläche innerhalb der Konturlinie 80% liegen.

Analysebericht

Um die Ergebnisse einer Power-Integrity-Analyse zur weiteren Untersuchung oder zur Weitergabe an Beteiligte zu speichern, bietet PDN Analyzer die Funktion Report für Daten und Dokumentation. Die Berichtsfunktion erstellt ein sehr umfassendes HTML-basiertes Dokument, das Grafiken und Daten sowohl zu den aktuellen Analyseergebnissen als auch zum Leiterplattendesign selbst enthält.

Klicken Sie auf die Schaltfläche , um die Berichtsoptionen im Dialogfeld HTML Report zu konfigurieren. Aktivieren Sie die Kontrollkästchen Results, um den Detailgrad des Berichts festzulegen, und prüfen Sie die aufgenommenen Bilder, die in den Berichtsordner () aufgenommen werden sollen. Verwenden Sie die Schaltfläche in der Hauptoberfläche, um Bilder der Analyseergebnisse aufzunehmen.

Klicken Sie auf die Schaltfläche , um den interaktiven HTML-Bericht zu erstellen und den zugehörigen Ordner zu öffnen. Dieser enthält alle Bilder (einschließlich der aufgenommenen) sowie die zugehörige Analysekonfigurationsdatei (*.pdna).

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents