Vorbereitung Ihres Designs für die Fertigung
Auf einen Blick
- Erfahren Sie, wie Sie Ausgaben in einem OutJob hinzufügen und konfigurieren und dabei Datenquellen auswählen, die eine Wiederverwendung über mehrere Projekte hinweg ermöglichen.
- Lernen Sie, wie Sie Ausgaben Containern oder Druckaufträgen zuordnen und festlegen, wo die erzeugten Dateien gespeichert werden.
- Durchlaufen Sie den Workflow zur Projektfreigabe – von den Freigabeoptionen über die Validierung, sofern konfiguriert, bis hin zur Datenerzeugung und Prüfung.
Die letzte Phase des Designzyklus besteht darin, die für die Herstellung des Produkts erforderlichen Ausgabedateien zu erzeugen. Dazu müssen verschiedene Ausgabedateien in unterschiedlichen Formaten erstellt werden. Als Entwickler können Sie die Ausgaben entweder einzeln über den Schaltplan- und PCB-Editor konfigurieren und erzeugen oder alle erforderlichen Ausgaben in einem OutputJob zusammenfassen und anschließend im Rahmen des Projektfreigabeprozesses erzeugen.

Das übergeordnete Ziel ist die Herstellung des Produkts – beispielsweise die Fertigung und Bestückung einer Leiterplatte.
Fertigungsdaten mit Output Jobs vorbereiten
Sie können die Ausgaben einzeln direkt über die Menüs File und Reports der jeweiligen Editoren konfigurieren und erzeugen. In diesem Fall werden die Ausgaben direkt erzeugt, sobald Sie im zugehörigen Einstellungsdialog auf OK klicken. Sie werden am Speicherort abgelegt, der im Feld Output Path auf der Registerkarte Options des Dialogs Project Options angegeben ist.
Output-Job-Dateien vereinfachen jedoch die Vorbereitung der Ausgaben für Ihre Designs und deren anschließende Erzeugung über den Projektfreigabeprozess mit hoher Datenintegrität. Ein Output Job, kurz „OutJob“, ist im Wesentlichen ein vorkonfigurierter Satz von Ausgaben, der die Einstellungen für diese Ausgaben speichert und festlegt, wo die erzeugten Ausgaben abgelegt werden.
Um Ihrem Designprojekt einen neuen OutJob hinzuzufügen, klicken Sie im Panel Projects mit der rechten Maustaste auf den Projekteintrag und wählen Sie im Kontextmenü den Befehl Add New to Project » Output Job File aus. Im Designbereich wird ein Standard-OutJob geöffnet.

Ein neu erstellter OutJob ist das aktive Dokument im Designbereich.
Auf der linken Seite des OutJobs können Sie zahlreiche Ausgabetypen für unterschiedliche Zwecke hinzufügen und konfigurieren. Die Ausgaben sind in funktionale Kategorien gegliedert, beispielsweise Bestückungsausgaben, Fertigungsausgaben und Berichtsausgaben.
Fügen Sie eine neue Ausgabe des gewünschten Typs hinzu, indem Sie unten in einer Kategorie auf den entsprechenden Text Add New <Type> Output klicken und im Popup-Menü den gewünschten Ausgabetyp auswählen. Für jeden Ausgabetyp steht ein Untermenü zur Verfügung, in dem Sie die Datenquelle festlegen können, also die Quelldokumente, die beim Erzeugen der Ausgabe verwendet werden sollen. Sie können beliebig viele Ausgaben hinzufügen.
Bei bestimmten Ausgabetypen können Sie eine hinzugefügte Ausgabe konfigurieren, indem Sie in der Liste mit der rechten Maustaste auf die Ausgabe klicken und im Kontextmenü den Befehl Configure auswählen. Daraufhin öffnet sich der zugehörige Konfigurationsdialog, in dem Sie die Optionen für die Ausgabe festlegen können. Für eine Ausgabe vom Typ Gerber X2 Setup wird beispielsweise der Dialog Gerber X2 Setup geöffnet.

Konfigurieren Sie eine Ausgabe nach Bedarf im zugehörigen Einstellungsdialog.
Um festzulegen, wo und in welchem Format eine Ausgabe erzeugt werden soll, werden Ausgabecontainer und Druckaufträge verwendet. Ausgaben können, sofern zutreffend, in drei Arten von Ausgabecontainern geschrieben werden: PDF, Video oder Ordnerstruktur (für ein bestimmtes Ausgabedateiformat, beispielsweise eine Gerber-Datei). Bestimmte Ausgaben können auch direkt als Ausdruck an einen Drucker gesendet werden, indem Sie einen Druckauftrag hinzufügen und konfigurieren.
Ein neuer OutJob enthält je einen Ausgabecontainer jedes Typs sowie einen Druckauftrag für den Standarddrucker. Die entsprechenden Einträge werden auf der rechten Seite des OutJobs angezeigt. Bei Bedarf können Sie einen neuen Ausgabecontainer hinzufügen, indem Sie auf das Steuerelement Add New Output Container klicken und den gewünschten Containertyp auswählen. Einen neuen Druckauftrag fügen Sie hinzu, indem Sie auf das Steuerelement Add New Print Job klicken und den gewünschten Drucker auswählen.

Fügen Sie nach Bedarf neue Ausgabecontainer und/oder Druckaufträge hinzu.
Um festzulegen, welche Ausgaben über welchen Ausgabecontainer bzw. Druckauftrag erzeugt werden sollen, wählen Sie einen Container oder Druckauftrag aus und aktivieren Sie anschließend für jede gewünschte Ausgabe in der Ausgabeliste das Kontrollkästchen Enabled. Nach der Aktivierung verbindet eine grüne Linie die Ausgabe mit dem ausgewählten Ausgabecontainer bzw. Druckauftrag. Ausgaben können einzelnen oder gemeinsam genutzten Ausgabecontainern bzw. Druckaufträgen zugeordnet werden.

Ordnen Sie hinzugefügte Ausgaben über die Kontrollkästchen Enabled den entsprechenden Ausgabecontainern und Druckaufträgen zu.
Um einen Ausgabecontainer bzw. Druckauftrag zu konfigurieren, wählen Sie den entsprechenden Eintrag aus und klicken Sie auf das Steuerelement Change. Der zugehörige Dialog wird geöffnet. Wenn beispielsweise ein Ausgabecontainer vom Typ Ordnerstruktur ausgewählt ist, öffnet sich der Dialog Folder Structure settings, in dem Sie den Ausgabespeicherort der zu erzeugenden Dateien sowie weitere Optionen zur Dateierzeugung konfigurieren können.

Konfigurieren Sie die Einstellungen eines Ausgabecontainers bzw. Druckauftrags im zugehörigen Dialog.
Die in einem OutJob konfigurierten Ausgaben können entweder direkt aus dem OutJob heraus oder bei einem PCB-Designprojekt im Rahmen des Projektfreigabeprozesses mit hoher Datenintegrität erzeugt werden. Um die einem Ausgabecontainer bzw. Druckauftrag zugeordneten Ausgaben direkt aus dem OutJob heraus zu erzeugen, wählen Sie den Container bzw. Druckauftrag aus und klicken Sie auf das Steuerelement Generate content bzw. Print.

Sie können Ausgaben direkt aus dem OutJob heraus erzeugen oder drucken.
Freigabe des Leiterplattendesigns
Mit dem Freigabeprozess für Leiterplattendesigns können Sie alle Fertigungsdaten, die in den OutJob-Dateien Ihres PCB-Projekts konfiguriert sind, gleichzeitig erzeugen. Dieser Prozess bietet gegenüber dem einzelnen Erzeugen von Ausgaben oder dem direkten Erzeugen aus OutJobs mehrere Vorteile. Dazu gehören die Validierung des Designs als integraler Bestandteil des Freigabeprozesses und die Vermeidung manueller Eingriffe während der Freigabe. Bei der Freigabe im verbundenen Workspace steht außerdem eine enge Integration mit dessen Versionsverwaltung zur Verfügung.
Um die Freigabe eines Projekts zu starten, klicken Sie im Panel Projects mit der rechten Maustaste auf den Projekteintrag und wählen Sie im Kontextmenü den Befehl Project Releaser aus. Die Ansicht Release wird als separate Registerkarte geöffnet.

Öffnen Sie die Ansicht Release – die Benutzeroberfläche für Project Releaser.
Der Freigabeprozess ist in mehrere Phasen unterteilt. Die Einträge auf der linken Seite der Ansicht Release zeigen Ihnen, in welcher Phase Sie sich gerade befinden.
In der ersten Phase des Freigabeprozesses können Sie unten links in der Ansicht auf die Schaltfläche Options klicken, um den Dialog Project Release Options zu öffnen und die Optionen für den Freigabeprozess nach Bedarf zu konfigurieren. Zu den Optionen gehören die Auswahl des Freigabeziels (Workspace, Ordner oder ZIP-Datei) und die Zuweisung von OutJobs.

Konfigurieren Sie die Freigabeoptionen im Dialog Project Release Options.
Je nach ausgewähltem Freigabeziel unterscheiden sich die Phasen des Freigabeprozesses geringfügig. Nachfolgend wird als Beispiel eine Freigabe an einen verbundenen Workspace gezeigt.
|
In der Phase Configure Server Release können Sie festlegen, welche Datentypen Sie generieren möchten: Quelldaten (eine Momentaufnahme des Quelldesigns, die immer in der Freigabe enthalten ist), Fertigungsdaten und Bestückungsdaten. Die Anzahl der Bestückungsdatensätze entspricht dem Basisdesign (ohne Varianten) und allen erkannten Designvarianten. Wenn Sie bereit sind, klicken Sie unten rechts in der Ansicht auf die Schaltfläche Prepare, um fortzufahren. Falls Probleme festgestellt werden, werden Ihnen Lösungen zu deren Behebung angeboten. Die Phase Validate Project wird automatisch ausgeführt, wenn in den zugewiesenen OutJob-Dateien ein oder mehrere Validierungsberichte, beispielsweise ein Bericht zur Prüfung der Designregeln (DRC), erkannt werden. Dabei werden die zugehörigen Validierungsausgaben ausgeführt. Die Freigabe schlägt fehl, wenn nicht alle Validierungsprüfungen erfolgreich bestanden werden. Die Phase Generate Data wird automatisch ausgeführt, wenn die vorherige Phase ohne Probleme abgeschlossen wurde. In dieser Phase werden alle anderen Ausgaben, die in den zugewiesenen OutJob-Dateien definiert sind, ausgeführt, um die freizugebenden Daten zu generieren. Nachdem alle Validierungsprüfungen bestanden und die Ausgabedaten generiert wurden, können Sie in der Phase Review Data die generierten Daten überprüfen. Setzen Sie die Freigabe fort, indem Sie unten rechts in der Ansicht auf die Schaltfläche Release klicken und die Freigabe im angezeigten Dialog bestätigen. Nachdem Sie die Freigabe in der vorherigen Phase bestätigt haben, wird automatisch die Phase Upload Data aufgerufen. Sie zeigt den Fortschritt des Datenuploads an. Die abschließende Phase Execution Report des Prozesses bietet eine Zusammenfassung der Freigabe. Nachdem Ihr Projekt freigegeben wurde, können Sie die Ansicht Release schließen, indem Sie unten rechts in der Ansicht auf die Schaltfläche Close klicken. |






