Zugriff auf, Definition und Verwaltung von Projektoptionen
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Die Registerkarten General, Error Reporting und Options des Dialogs Project Options
Zusammenfassung
Einem vorhandenen oder neu erstellten Projekt sind verschiedene projektspezifische Optionseinstellungen zugeordnet. Diese werden in der Projektdatei (z. B. *.PrjPcb) gespeichert und unterscheiden sich je nach Projekttyp. Die Optionseinstellungen werden im Dialog Project Options konfiguriert.
Zugriff
Der Dialog Project Options kann auf eine der folgenden Arten geöffnet werden:
- Klicken Sie im Projects-Panel mit der rechten Maustaste auf den Projekteintrag und anschließend im Kontextmenü auf Project Options.
-
Klicken Sie im Panel Projects auf das Symbol
, wenn das gewünschte Projekt im Panel ausgewählt ist.
- Wählen Sie in einem beliebigen Editor in den Hauptmenüs Project » Project Options aus.
Registerkarten des Dialogs
Allgemein

Die Registerkarte General des Dialogs Project Options
Auf der Registerkarte General des Dialogs Project Options können Sie die Online-Verfügbarkeit und Synchronisierung eines Workspace-Projekts steuern.
Optionen/Steuerelemente
Wenn Sie den Dialog für ein Projekt öffnen, dessen Workspace-Verbindung getrennt ist, steht nur die Schaltfläche Turn Off Synchronization zur Verfügung.
Wenn Sie den Dialog für ein Projekt öffnen, das kein Workspace-Projekt ist, wird auf der Registerkarte General des Dialogs Project Options nur die Schaltfläche Make Project Available Online angezeigt. Klicken Sie auf die Schaltfläche, um den Dialog Online verfügbar machen zu öffnen. Nach Durchführung der erforderlichen Schritte wird Ihr Projekt dem Workspace hinzugefügt. Anschließend stehen alle Optionen auf dieser Registerkarte des Dialogs zur Verfügung.
Allgemein
- Description – In diesem Feld können Sie eine optionale Beschreibung des Projekts eingeben. Diese wird im Beschreibungsfeld angezeigt, wenn Sie Ihr Projekt in der Browseroberfläche des Workspace aufrufen.
Online-Verfügbarkeit und Synchronisierung
-
Version Control – Dieses Kontrollkästchen zeigt die aktuelle Art der Online-Verfügbarkeit an. Aktivieren Sie diese Option, um das Projekt unter Versionskontrolle im Git-Design-Repository Versioned Storage des Workspace zu speichern, oder deaktivieren Sie sie, um die einfache Synchronisierung zu verwenden. Die Aktivierung der vollständigen Versionskontrolle ermöglicht es mehreren Benutzern, am Projekt zu arbeiten. Das Projekt wird dabei für alle anderen Mitwirkenden freigegeben, die mit Ihrem Workspace verbunden sind.
-
Migrate to Altium 365 Versioned Storage – Aktivieren Sie diese Option, um ein Projekt, das ein externes Versionskontrollsystem (VCS) verwendet, zum nativen VCS des Altium 365 Workspace zu migrieren. Das konvertierte Designprojekt behält den bisherigen Verlauf der VCS-Commits bei und kann anschließend die nativen VCS-gestützten Funktionen des Workspace nutzen, beispielsweise die ereignisbasierte Verlaufszeitleiste. Diese Option ist nur für ein gespiegeltes Projekt verfügbar.
-
Server Folder – Der Workspace-Ordner, in dem sich das Projekt befindet.
-
Enable Conflict Prevention Notifications – Aktivieren Sie diese Option, um den Bearbeitungszugriff auf Dateien zu verwalten: Sie erhalten eine Warnung, wenn ein Teammitglied dasselbe Dokument eines Workspace-Projekts bearbeitet. So lassen sich mögliche Datenkonflikte vermeiden.
-
Turn Off Synchronization – Klicken Sie auf diese Schaltfläche, um die Synchronisierung zu deaktivieren. Dadurch wird die Verknüpfung zwischen der lokalen Projektkopie und dem Projekt im Workspace aufgehoben. Das Projekt im Workspace bleibt unverändert.
Anforderungen
-
Link Requirements – Wenn der Block des Requirements Portal nicht mit dem Designprojekt verknüpft ist, klicken Sie auf diese Schaltfläche, um den Dialog Link Requirements zu öffnen. Dort können Sie den Block auswählen, der mit dem Projekt verknüpft werden soll.
-
Linked Requirements – Wenn der Block des Requirements Portal mit dem Designprojekt verknüpft ist, zeigt dieser Eintrag den verknüpften Block an Klicken Sie auf den Link, um die aktuelle Projekt-Block-Zuordnung zu ändern. Klicken Sie auf die Schaltfläche Unlink, um die Verknüpfung zu entfernen.
Weitere Informationen finden Sie auf der Seite Anforderungen in einem Design.
Fehlermeldungen

Die Registerkarte Error Reporting des Dialogs Project Options (für ein PCB-Projekt)
Auf der Registerkarte Error Reporting des Dialogs Project Options können Sie die Meldestufen für alle möglichen elektrischen und zeichnerischen Verstöße festlegen, die bei der Projektvalidierung in den Quell-Schaltplandokumenten auftreten können. Bei der Validierung des Projekts werden diese Einstellungen zusammen mit den Einstellungen auf der Registerkarte „Verbindungsmatrix“ verwendet, um die Quelldokumente auf Verbindungsverstöße zu prüfen.
Optionen/Steuerelemente
Liste der Verstöße
Diese Liste enthält alle möglichen elektrischen und zeichnerischen Verstöße, die in den Quelldokumenten des Projekts auftreten können. Die Verstöße sind in folgende Kategorien unterteilt:
PCB Design:
Multi-board Design:
Harness Design:
Für jeden spezifischen Verstoßtyp werden die folgenden Felder angezeigt:
- Violation Type Description – Eine kurze Beschreibung des Verstoßtyps.
-
Report Mode – In diesem Feld legen Sie den Schweregrad fest, der einem Verstoß bei dieser Prüfung zugeordnet wird. Wählen Sie über die Dropdown-Liste eine der folgenden Meldestufen aus:
-
Kontextmenü
Die folgenden Befehle sind im Kontextmenü verfügbar:
- All Off – Setzt Report Mode für alle Verstoßtypen auf No Report.
- All Warning – Setzt Report Mode für alle Verstoßtypen auf Warning.
- All Error – Setzt Report Mode für alle Verstoßtypen auf Error.
- All Fatal – Setzt Report Mode für alle Verstoßtypen auf Fatal Error.
- Selected Off – Setzt Report Mode für alle ausgewählten Verstoßtypen auf No Report.
- Selected To Warning – Setzt Report Mode für alle ausgewählten Verstoßtypen auf Warning.
- Selected To Error - setzt Report Mode für alle ausgewählten Verstoßtypen auf Error.
- Selected To Fatal - setzt Report Mode für alle ausgewählten Verstoßtypen auf Fatal Error.
- Default - setzt Report Mode für alle Verstoßtypen auf die Standardeinstellungen zurück.
- Report Suppressed Violations in Messages Panel - aktivieren Sie diese Option, um Verstöße im Panel Messages anzuzeigen, auch wenn sie über diese Registerkarte unterdrückt wurden.
Zusätzliche Option
- Set To Installation Defaults - klicken Sie hier, um die Optionen der Registerkarte auf die Installationsstandards zurückzusetzen.
Verbindungsmatrix

Die Registerkarte Connection Matrix des Dialogs Project Options
Die Registerkarte Connection Matrix des Dialogs Project Options bietet eine Matrix, mit der sich Verbindungsregeln zwischen Bauteilpins und Netzkennungen wie Ports und Schaltplanblatteinträgen festlegen lassen. Sie definiert die logischen oder elektrischen Bedingungen, die als Warnungen oder Fehler gemeldet werden sollen. Beispielsweise würde ein mit einem anderen Ausgangspin verbundener Ausgangspin normalerweise als Fehler gelten, zwei miteinander verbundene passive Pins hingegen nicht. Bei der Validierung des Projekts werden diese Einstellungen für Verstöße (zusammen mit den Einstellungen auf der Registerkarte „Fehlermeldungen“) verwendet, um die Quelldokumente auf Verstöße zu prüfen.
Optionen/Steuerelemente
Verbindungsmatrix
Die Matrix enthält alle möglichen Prüfungen von Verdrahtungsverbindungen zwischen Kombinationen aus Pins, Ports und Schaltplanblatteinträgen sowie Prüfungen auf nicht verbundene Objekte. Die Matrix wird zeilen- und spaltenweise gelesen. Die Farbe des Matrixelements am Schnittpunkt einer Zeile und einer Spalte legt fest, wie der Compiler bei der Prüfung auf die jeweilige Bedingung reagiert.
Um den Meldemodus für eine Verstoßprüfung in der Matrix zu ändern, klicken Sie auf das farbige Quadrat am Schnittpunkt der Zeile und Spalte zweier Objekte. Mit jedem Klick wechselt der Modus zur nächsten Meldestufe. Folgende Stufen werden unterstützt:
- No Report
- Warning
- Error
- Fatal Error
Rechtsklickmenü
Die folgenden Befehle sind im Rechtsklick-Kontextmenü verfügbar:
- All Off - setzt alle Einträge in der Matrix auf No Report.
- All Warning - setzt alle Einträge in der Matrix auf Warning.
- All Error - setzt alle Einträge in der Matrix auf Error.
- All Fatal - setzt alle Einträge in der Matrix auf Fatal Error.
- Default - setzt alle Einträge auf ihre Standardwerte zurück.
Zusätzliche Option
- Set To Installation Defaults - klicken Sie hier, um die Optionen der Registerkarte auf die Installationsstandards zurückzusetzen.
Klassengenerierung

Die Registerkarte Class Generation des Dialogs Project Options
Auf der Registerkarte Class Generation des Dialogs Project Options können Sie die Klassengenerierung konfigurieren und steuern. Klassen sind logische Zusammenfassungen von Designobjekten eines bestimmten Typs. Beispielsweise könnten zusammengehörige Bauteile in einer eigenen Bauteilklasse zusammengefasst werden, die dann als Grundlage für die Erstellung einer gezielten Regel dienen könnte. Diese Registerkarte bietet Steuerelemente, mit denen festgelegt wird, welche Klassen automatisch generiert werden und welche benutzerdefinierten Klassen generiert werden, wenn die Quellschaltplandokumente mit dem PCB-Designdokument synchronisiert werden.
Optionen/Steuerelemente
Automatisch generierte Klassen
-
Generate Net Classes for Buses - aktivieren Sie diese Option, um für jeden Bus im Design automatisch eine Netzklasse zu generieren. Die Mitglieder einer Klasse sind die einzelnen Netze des Busses, aus dem diese Klasse generiert wurde.
-
Generate Net Classes for Components - aktivieren Sie diese Option, um für jedes Bauteil im Design automatisch eine Netzklasse zu generieren. Die Mitglieder einer Klasse sind die zugehörigen Netze, mit denen die Pins des Bauteils verbunden sind, aus dem diese Klasse generiert wurde.
-
Generate Separate Net Classes for Bus Sections - aktivieren Sie diese Option, um für jeden Busabschnitt automatisch eine separate Netzklasse zu generieren. Ein Busabschnitt wird erstellt, indem ein Bus angegeben wird, der tatsächlich ein Abschnitt eines größeren Busses ist, beispielsweise
D[15..8]aus dem BusD[15..0]. -
Generate Net Classes for Named Signal Harnesses - aktivieren Sie diese Option, um für jedes benannte Signalbündel im Design automatisch eine Netzklasse zu generieren. Die Mitglieder einer Klasse sind die Netze der Signale, die im benannten Signalbündel zusammengefasst sind, aus dem die Klasse generiert wurde.
-
Sheet-Level Class Generation Grid - in diesem Bereich können Sie die automatische Generierung von Bauteil- und/oder Netzklassen auf der Ebene einzelner Schaltplanblätter steuern. Alle Quellschaltplanblätter des Projekts werden aufgelistet, wobei für jedes Blatt die folgenden Informationen angezeigt werden:
- Sheet Name - der Name des Schaltplandokuments.
- Full Path - der absolute Pfad zum Ordner, in dem sich das Dokument befindet.
-
Component Classes - aktivieren Sie diese Option, um eine Bauteilklasse für das Blatt zu erzeugen.
- Generate Rooms - aktivieren Sie diese Option, um einen Raum für die Bauteilklasse zu erzeugen.
-
Net Classes Scope - legen Sie in diesem Feld fest, ob eine Netzklasse für das Blatt erzeugt werden soll und, falls ja, welchen Umfang sie haben soll. Die Dropdown-Liste des Feldes bietet folgende Auswahlmöglichkeiten:
- None - keine Netzklasse für dieses Blatt erzeugen.
- Local Nets Only - eine Netzklasse für dieses Blatt erzeugen, die jedoch nur Netze enthält, die lokal auf dem Blatt liegen.
- All Nets - eine Netzklasse für dieses Blatt erzeugen, die alle dem Blatt zugeordneten Netze enthält (sowohl lokale als auch solche, die zu anderen Blättern führen).
-
Structure Classes Generate Structure - aktivieren Sie diese Option, um eine Strukturklasse für das Blatt zu erzeugen.
Eine Strukturklasse ist ein spezieller Klassentyp, der beliebige Klassen (Netzklassen, Bauteilklassen usw.) als Mitglieder enthalten kann. Indem beim Übertragen des Designs auf die Leiterplatte automatisch für jedes Schaltplanblatt im Projekt, das Bauteile und/oder Netze enthält, eine Strukturklasse erzeugt wird, lässt sich die Projektstruktur auf der Leiterplattenseite originalgetreu abbilden. Strukturklassen ermöglichen nicht nur die Nachbildung der Schaltplandokumentstruktur im PCB-Bereich für eine erweiterte Navigation, sondern können auch in logischen Abfragen verwendet werden, beispielsweise beim Festlegen des Geltungsbereichs von Designregeln oder beim Filtern.
Benutzerdefinierte Klassen
- Generate Component Classes - aktivieren Sie diese Option, um beim Übertragen des Designs auf die Leiterplatte benutzerdefinierte Bauteilklassen zu erzeugen. Bauteilklassen werden im Schaltplan manuell definiert, indem den betreffenden Bauteilen ein ClassName Parameter hinzugefügt und dessen Wert auf den gewünschten Klassennamen gesetzt wird.
- Generate Rooms for Component Class - aktivieren Sie diese Option, um Räume auf Grundlage der benutzerdefinierten Bauteilklassen zu erzeugen. Diese Bauteile müssen über einen Bauteilparameter mit dem Parameternamen „ClassName“ verfügen.
- Generate Net Classes - aktivieren Sie diese Option, um beim Übertragen des Designs auf die Leiterplatte benutzerdefinierte Netzklassen zu erzeugen. Netzklassen werden im Schaltplan mithilfe der Netzklassen-Direktive manuell definiert. Um ein Netz einer Netzklasse zuzuordnen, platzieren Sie eine Netzklassen-Direktive an der entsprechenden Leitung oder am entsprechenden Bus (oder an einem Blanket) und setzen Sie den Wert ihres Parameters ClassName auf den gewünschten Klassennamen.
► Erfahren Sie, wie Sie eine benutzerdefinierte Netzklasse erstellen
► Erfahren Sie, wie Sie eine benutzerdefinierte Bauteilklasse erstellen
Zusätzliche Option
- Set To Installation Defaults - klicken Sie hier, um die Optionen der Registerkarte auf die Installationsstandardwerte zurückzusetzen.
Hinweise
-
Um beim Übertragen des Designs auf die Leiterplatte Klassen (automatisch und/oder benutzerdefiniert) zu erzeugen, müssen Sie sicherstellen, dass die jeweiligen Vergleichseinstellungen auf der Registerkarte „Vergleich“ des Dialogs Project Options wie folgt auf Find Differences gesetzt sind:
- Netzklassen – setzen Sie den Vergleichstyp Extra Net Classes (in der Kategorie Differences Associated with Nets) auf Find Differences.
- Bauteilklassen – setzen Sie den Vergleichstyp Extra Component Classes (in der Kategorie Differences Associated with Components) auf Find Differences.
-
Außerdem müssen Sie sicherstellen, dass auf der Registerkarte „ECO-Erzeugung“ des Dialogs Project Options die jeweiligen ECO-Einstellungen auf Generate Change Orders gesetzt sind.
- Netzklassen – setzen Sie den Änderungstyp Add Net Classes (in der Kategorie Modifications Associated with Nets) auf Generate Change Orders.
- Bauteilklassen – setzen Sie den Änderungstyp Add Component Classes (in der Kategorie Modifications Associated with Components) auf Generate Change Orders.
Vergleich

Die Registerkarte Comparator des Dialogs Project Options
Auf der Registerkarte Comparator des Dialogs Project Options können Sie festlegen, welche Arten von Unterschieden beim Vergleichen von Dokumenten ermittelt und welche ignoriert werden sollen. Für jeden möglichen Vergleich können Sie über die zugehörige Dropdown-Liste in der Spalte Mode auswählen, ob Unterschiede ermittelt oder ignoriert werden sollen. Sie können die Ermittlung von Unterschieden bei Bauteilen, Netzen, Parametern und physischen Objekten nach Bedarf konfigurieren.
Optionen/Bedienelemente
Dieser Dialog ist in zwei Hauptbereiche unterteilt:
- Der obere Bereich mit der Bezeichnung Comparison Type Description/Mode enthält die Beschreibung und den Vergleichsmodus jedes verfügbaren Vergleichstyps.
- Der untere Bereich mit der Bezeichnung Object Matching Criteria dient zum Festlegen der Übereinstimmungskriterien für Net, Net Class, Component Class, Differential Pair und Structure Class.
Beschreibung/Modus des Vergleichstyps
- Comparison Type Description - dieser Bereich enthält die Beschreibungen aller im Projekt verfügbaren Vergleichstypen. Verwenden Sie die Bildlaufleiste ganz rechts, um zu Differences Associated with Components, Differences Associated with Nets, Differences Associated with Parameters, Differences Associated with Physical und Differences Associated with Structure Classes zu blättern und die Vergleichsmodi im jeweiligen Bereich anzuzeigen oder zu ändern.
-
Mode - klicken Sie auf einen Eintrag, um den Vergleichsmodus über die Dropdown-Liste zu ändern:
-
Find Differences- wählen Sie diese Option, um Unterschiede für diesen Vergleichstyp zu ermitteln. -
Ignore Differences- wählen Sie diese Option, um alle Unterschiede für diesen Vergleichstyp zu ignorieren (für diesen Vergleichstyp wird kein Vergleich durchgeführt).
-
Kriterien für die Objektübereinstimmung
- Object Type - Liste der Objekttypen, wie Net, Net Class, Component Class, Differential Pair und Structure Class.
- Min Match % - geben Sie den gewünschten Mindestprozentsatz für die Übereinstimmung ein oder klicken Sie auf die rechte Seite der Spalte und verwenden Sie dann die Pfeiltasten nach oben und unten, um den Wert zu erhöhen oder zu verringern.
- Min Matched Members - geben Sie die gewünschte Mindestanzahl übereinstimmender Mitglieder ein oder klicken Sie auf die rechte Seite der Spalte und verwenden Sie dann die Pfeiltasten nach oben und unten, um den Wert zu erhöhen oder zu verringern.
- Use Name Matching - klicken Sie auf den Eintrag oder verwenden Sie die Dropdown-Liste, um After member matching oder Never auszuwählen.
- Show Manual Matching Dialog - Klicken Sie auf den Eintrag oder wählen Sie über die Dropdown-Liste For unmatched objects oder Never aus.
Zusätzliche Optionen
- Ignore Rules Defined in PCB Only – Aktivieren Sie diese Option, um Regeln zu ignorieren, die innerhalb des Designprojekts nur auf der Leiterplatte definiert sind. Wenn Sie beispielsweise einen Engineering Change Order ausführen, können Änderungen vom Schaltplan auf die Leiterplatte übertragen werden. Ist diese Option aktiviert, werden dabei Regeln ignoriert, die nur auf der Leiterplatte vorhanden sind. Wenn auf den Schaltplanblättern desselben Projekts keine entsprechenden Regeln vorhanden sind, versucht der Komparator nicht, neue Regeln hinzuzufügen.
- Set To Installation Defaults – Klicken Sie hier, um die Optionen der Registerkarte auf die Installationsstandardwerte zurückzusetzen.
ECO-Erstellung

Die Registerkarte ECO Generation des Dialogfelds Project Options
Auf der Registerkarte ECO Generation des Dialogfelds Project Options können Sie festlegen, welche Änderungstypen bei der Erstellung eines Engineering Change Order (ECO) auf Grundlage der vom Komparator ermittelten Unterschiede berücksichtigt werden können.
Optionen/Steuerelemente
Liste der Änderungstypen
Diese Liste enthält alle möglichen Änderungen, die über einen Engineering Change Order bei der Synchronisierung der Quellschaltplandokumente mit dem Leiterplattendesigndokument vorgenommen werden können. Die Listeneinträge umfassen Kategorien für Änderungstypen, die mit Components, Nets, Parameters, Structure Classes usw. zusammenhängen.
Jeder einzelne Änderungstyp umfasst die folgenden Felder:
- Modification Type Description – Eine kurze Beschreibung des Änderungstyps (der vom Synchronisierer auszuführenden Aktion).
-
Mode – In diesem Feld legen Sie fest, ob der Änderungstyp in einen erstellten ECO aufgenommen wird oder nicht. Wählen Sie über die Dropdown-Liste eine der folgenden Optionen:
- Generate Change Orders – Den Änderungstyp in einen erstellten ECO aufnehmen.
- Ignore Differences – Den Änderungstyp aus einem erstellten ECO ausschließen.
Kontextmenü
Der folgende Befehl ist über das per Rechtsklick aufrufbare Kontextmenü verfügbar:
- Report – Mit diesem Befehl erstellen Sie einen Bericht über die aktuell konfigurierten Änderungsmodi. Das Dialogfeld Report Preview wird geöffnet, wobei der Bericht bereits geladen ist. In diesem Dialogfeld können Sie den Bericht mithilfe verschiedener Seiten- und Zoom-Steuerelemente prüfen, bevor Sie ihn in eine Datei exportieren oder drucken.
Zusätzliche Optionen
- Push Component Designator Changes to Annotation File (if any) – Aktivieren Sie diese Option, um Änderungen an Bauteilbezeichnern in die Annotationsdatei aufzunehmen.
- Set To Installation Defaults – Klicken Sie hier, um die Optionen der Registerkarte auf die Installationsstandardwerte zurückzusetzen.
Optionen

Die Registerkarte Options des Dialogfelds Project Options
Auf der Registerkarte Options des Dialogfelds Project Options können Sie den Ausgabepfad und die zugehörigen Optionen für die erzeugten Projektausgaben festlegen. Außerdem können Sie verschiedene Optionen zur Netzlistenerstellung sowie den Gültigkeitsbereich von Netzbezeichnern festlegen.
Optionen/Steuerelemente
-
Output Path – Der Standardausgabepfad für die Erstellung von Ausgabedateien aus dem aktuellen Designprojekt (
*.PrjPcb). - ECO Log Path – Der Standardausgabepfad für ECO-Protokolldateien.
-
Schematic Template Location – Geben Sie in diesem Feld ein Verzeichnis an, aus dem Schaltplanvorlagendateien (
*.SchDot,*.SchDoc) für das Projekt bezogen werden sollen.
Ausgabeoptionen
- Open outputs after compile – Aktivieren Sie diese Option, um Dateien zu öffnen, die nach dem Kompilieren des Designprojekts erzeugt wurden. Aktivieren Sie diese Option bei einem Paketprojekt für eine integrierte Bibliothek, um die integrierte Bibliothek nach dem Kompilieren des Paketprojekts zu installieren.
-
Timestamp folder – Aktivieren Sie diese Option, um einen Ordner mit Zeitstempel für die erzeugte Ausgabe zu erstellen, beispielsweise für einen Stücklistenbericht (Reports » Bill of Materials). Der Ordnername hat das Format
<FolderName> Date Time, wobei<FolderName>im Feld Output Path angegeben wird undDateundTimedasselbe Format wie Ihre Systemeinstellungen verwenden. - Archive project document – Aktivieren Sie diese Option, um das Projektdokument zu archivieren. Wenn beispielsweise Fertigungsdaten aus einem Leiterplattendesign (File » Fabrication Outputs und File » Assembly Outputs) erzeugt werden, enthält der Zielausgabeordner eine Kopie des zugehörigen Leiterplattendokuments.
- Use separate folder for each output type – Aktivieren Sie diese Option, um für jeden für das Designprojekt erzeugten Ausgabetyp einen separaten Ordner zu erstellen. Diese Ordnerstruktur wird auch im Panel Projects dargestellt.
Netzlistenoptionen
- Allow Ports to Name Nets – Aktivieren Sie diese Option, um ein Netz anhand der Eigenschaft „Name“ eines angeschlossenen Ports zu benennen, statt einen standardmäßigen, vom System erzeugten Netznamen zu verwenden.
- Allow Sheet Entries to Name Nets – Aktivieren Sie diese Option, um ein Netz anhand des Namens des Blatteintrags zu benennen, statt einen standardmäßigen, vom System erzeugten Netznamen zu verwenden.
- Allow Single Pin Nets – Aktivieren Sie diese Option, um Netze zuzulassen, die nur einen einzigen Pin enthalten.
-
Append Sheet Numbers to Local Net – Aktivieren Sie diese Option, um den Wert des Parameters „Sheet Number“ eines Schaltplandokuments (ein Parameter auf Dokumentebene) an Netze anzuhängen, die lokal zu diesem Blatt gehören. Ein lokales Netz ist ein Netz, das das Blatt nicht verlässt. Für ein Netz, das das Blatt verlässt (und daher nicht lokal ist), gilt diese Option nicht.
- Higher Level Names Take Priority – Aktivieren Sie diese Option, damit die Netzlabels auf hierarchisch höher liegenden Blättern zur Benennung der Netze auf den darunterliegenden Blättern verwendet werden.
-
Power Port Names Take Priority – Die Software kann ein globales Versorgungsnetz lokalisieren, indem ein Versorgungsanschluss mit einem normalen Port verbunden wird. Dadurch werden alle Pins auf diesem Blatt, die mit diesem Versorgungsanschluss verbunden sind, einem separaten Netz zugeordnet. Wenn Sie diese Option aktivieren, wird für die Netzbenennung der Name des Netzes verwendet, das dem Versorgungsanschluss zugewiesen ist.
Gültigkeitsbereich von Netzbezeichnern
Mehrblättrige Designs werden auf elektrischer Ebene (bzw. Verbindungsebene) durch Netzbezeichner definiert. Netzbezeichner (Netzlabels, Ports, Schaltplanblatteinträge, Versorgungsanschlüsse und ausgeblendete Pins) stellen logische Verbindungen zwischen Punkten desselben Netzes her. Dies kann innerhalb eines Schaltplanblatts oder über mehrere Blätter hinweg erfolgen. Physische Verbindungen bestehen, wenn ein Objekt über eine Leitung direkt mit einem anderen elektrischen Objekt verbunden ist. Logische Verbindungen entstehen, wenn zwei Netzbezeichner desselben Typs (z. B. zwei Netzlabels) dieselbe Net -Eigenschaft aufweisen.
Beim Erstellen des Verbindungsmodells für das Design müssen Sie festlegen, wie Netzbezeichner miteinander verbunden werden sollen – dazu legen Sie den Net Identifier Scope fest. Grundsätzlich gibt es zwei Möglichkeiten, die Blätter eines mehrblättrigen Designs miteinander zu verbinden: entweder horizontal, direkt von einem Blatt zum nächsten usw., oder vertikal, von einem untergeordneten Blatt zum Blattsymbol, das dieses auf dem übergeordneten Blatt repräsentiert. Bei horizontalen Verbindungen werden Ports miteinander verbunden (auch Verbindungen zwischen Netzlabels sind möglich). Bei vertikalen Verbindungen werden Schaltplanblatteinträge mit Ports verbunden.
Wählen Sie in der Dropdown-Liste einen der folgenden Gültigkeitsbereiche aus:
-
Automatic (Based on project contents) – dieser Modus wählt den zu verwendenden Netzbezeichnermodus anhand folgender Kriterien automatisch aus: Wenn auf dem obersten Blatt Schaltplanblatteinträge vorhanden sind, wird Hierarchical verwendet. Wenn keine Schaltplanblatteinträge, aber Ports vorhanden sind, wird Flat verwendet. Wenn weder Schaltplanblatteinträge noch Ports vorhanden sind, wird Global verwendet.
- Flat (Only ports global) – Ports werden global über alle Blätter des Designs hinweg verbunden. Bei dieser Option gelten Netzlabels nur lokal auf dem jeweiligen Blatt, d. h., sie stellen keine blattübergreifenden Verbindungen her. Alle Ports mit demselben Namen werden auf allen Blättern miteinander verbunden. Diese Option kann für flache mehrblättrige Designs verwendet werden. Für große Designs wird sie nicht empfohlen, da es schwierig sein kann, ein Netz über die Blätter hinweg zu verfolgen.
- Hierarchical (Sheet entry <-> port connections, power ports global) – stellt vertikale Verbindungen zwischen einem Port und dem zugehörigen Schaltplanblatteintrag her. Diese Option stellt blattübergreifende Verbindungen ausschließlich über Einträge in Blattsymbolen und die zugehörigen Ports auf untergeordneten Blättern her. Sie verwendet Ports auf den Blättern, um Netze oder Busse zu den Schaltplanblatteinträgen in den entsprechenden Blattsymbolen auf dem übergeordneten Blatt zu führen. Ports ohne passenden Schaltplanblatteintrag werden nicht verbunden, selbst wenn auf einem anderen Blatt ein Port mit demselben Namen vorhanden ist. Netzlabels gelten nur lokal auf dem jeweiligen Blatt, d. h., sie stellen keine blattübergreifenden Verbindungen her. Versorgungsanschlüsse sind jedoch global – alle Versorgungsanschlüsse mit demselben Namen werden im gesamten Design miteinander verbunden. Mit dieser Option lassen sich Designs mit beliebig vielen Hierarchieebenen erstellen. Zudem lässt sich ein Netz im ausgedruckten Schaltplan durch das gesamte Design verfolgen.
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) – dieser Verbindungsmodus verhält sich wie der Modus Hierarchical , mit dem Unterschied, dass Versorgungsanschlüsse nur lokal auf dem jeweiligen Blatt gelten. Sie werden also nicht blattübergreifend mit gleichnamigen Versorgungsanschlüssen verbunden.
- Global (Netlabels and ports global) – Ports und Netzlabels werden über alle Blätter des Designs hinweg verbunden. Bei dieser Option werden alle Netze mit demselben Netzlabel auf allen Blättern miteinander verbunden. Ebenso werden alle Ports mit demselben Namen auf allen Blättern miteinander verbunden. Wenn ein mit einem Port verbundenes Netz auch ein Netzlabel besitzt, wird dessen Name als Netzname verwendet. Diese Option kann ebenfalls für flache mehrblättrige Designs verwendet werden. Allerdings ist die Verfolgung von einem Blatt zum anderen schwierig, da sich Netznamen im Schaltplan visuell nicht immer leicht finden lassen.
Pin-Tausch mit diesen Methoden zulassen
Im PCB-Editor werden Pins, differenzielle Paare und Bauteilsektionen getauscht, indem die Netze an den Bauteilpads und den zugehörigen Kupferstrukturen ausgetauscht werden. Beim Übernehmen der Änderungen in die Schaltpläne kann ein Pin-Tausch auf zwei Arten umgesetzt werden:
-
Adding / Removing Net-Labels – aktivieren Sie diese Option, um das Tauschen von Pins an einem Bauteilsymbol zuzulassen. Ein Tausch im Schaltplan durch Austauschen der Netzlabels ist nur möglich, wenn die Verbindungen über Netzlabels hergestellt werden, d. h., wenn die Pins nicht direkt miteinander verdrahtet sind.
-
Changing Schematic Pins – aktivieren Sie diese Option, um das Tauschen von Netzlabels auf den mit den Pins eines Bauteils verbundenen Leitungen zuzulassen. Wenn Netze direkt mit einem Bauteil verdrahtet sind, ist das Tauschen von Pins die einzige verfügbare Option. Diese Methode kann bei einfachen Bauteilen (z. B. einem Widerstandsarray) verwendet werden oder wenn die Struktur des Schaltplandesigns keine Alternative zulässt.
Allgemein
- Automatic Sheet Numbering – aktivieren Sie diese Option, um die Schaltplanblätter in diesem Projekt automatisch zu nummerieren. Damit können Sie die Blattbezeichnungen steuern und als Parameter in den jeweiligen Schaltplandokumenten speichern.
-
Automatic Cross References – aktivieren Sie diese Option, um allen Quell-Schaltplandokumenten im aktiven Projekt automatisch Querverweisinformationen für Ports, blattübergreifende Verbinder und Schaltplanblatteinträge hinzuzufügen. Diese Funktion erleichtert die Verfolgung von Netzverbindungen in einem nicht hierarchischen Design.
- New Indexing of Sheet Symbols – aktivieren Sie diese Option, um eine beliebige Ziffer oder Zahl als ersten oder letzten Index eines wiederholten Blattsymbols zu verwenden, einschließlich 0. Negative Zahlen sind nicht zulässig. Der letzte Index muss immer größer als der erste sein.
Querverweise
-
Sheet Style – wählen Sie einen der folgenden Blattstile für die Querverweise von Ports auf einem oder mehreren Schaltplanblättern innerhalb eines Projekts.
-
None– der Querverweiszeichenfolge aller Ports wird kein Blattstil hinzugefügt. -
Name– die Namen der Blätter, mit denen die Ports verbunden sind, werden den Querverweiszeichenfolgen hinzugefügt. -
Number– die Blattnummern der Blätter, mit denen die Ports verbunden sind, werden den Querverweiszeichenfolgen hinzugefügt.
-
-
Location Style – wählen Sie einen der folgenden Positionsstile für die Querverweise von Ports auf einem oder mehreren Schaltplanblättern innerhalb eines Projekts.
-
None– der Querverweiszeichenfolge aller Ports wird kein Positionsstil hinzugefügt. -
Zone– die Referenzzonen-Nummerierung (die Zonen befinden sich an den Blatträndern) wird den Querverweiszeichenfolgen aller Ports hinzugefügt, die übergeordneten Objekten zugeordnet sind, beispielsweise der Position von Blattsymbolen. -
Location X,Y– die Positionen der Ports werden in Klammern in den Querverweiszeichenfolgen aller Ports ausgegeben, die übergeordneten Objekten zugeordnet sind, beispielsweise der Position von Blattsymbolen.
-
- Follow Cross References settings in Preferences – wenn diese Option aktiviert ist, werden die Werte der Optionen Sheet Style und Location Style aus den Optionen im Bereich Port Cross References auf der Seite Schematic – General des Dialogs Preferences übernommen.
-
Display Cross References for:
-
Ports – wählen Sie über die Dropdown-Liste den Anzeigemodus für Querverweise von Ports aus.
-
Disabled– Ports wird kein Querverweis hinzugefügt. -
Only Related Sheet Entry– zeigt einen Querverweis auf den zugehörigen Blatteintrag auf dem übergeordneten Schaltplanblatt an. -
Only Related Ports– zeigt Querverweise auf die zugehörigen Ports an. -
Sheet Entry & Ports– zeigt Querverweise sowohl auf den Blatteintrag als auch auf die Ports an.
-
- Off-sheet Connectors – aktivieren Sie diese Option, um Querverweise für blattübergreifende Verbinderobjekte anzuzeigen.
- Sheet Entries – aktivieren Sie diese Option, um Querverweise für Blatteintragsobjekte anzuzeigen.
-
Ports – wählen Sie über die Dropdown-Liste den Anzeigemodus für Querverweise von Ports aus.
Differenzpaare
-
Custom Diff Pair Suffix Grid – listet die standardmäßigen Differenzpaar-Suffixe (
_P/_N) und alle definierten benutzerdefinierten Differenzpaar-Suffixe mit folgenden Angaben auf:- Positive Suffix – das Suffix für das positive Netz eines Differenzpaars.
- Negative Suffix – das Suffix für das negative Netz eines Differenzpaars.
- Add – klicken Sie hier, um der Liste ein neues Suffixpaar hinzuzufügen.
- Remove – klicken Sie hier, um die ausgewählten Suffixpaare aus der Liste zu löschen.
Erstellung von xNets
- Sources/Destinations – definieren Sie eine kommagetrennte Liste von Präfixen für Bezeichner von Bauteilen, die als Quell- oder Zielbauteile in xNets verwendet werden können.
- Discretes – definieren Sie eine kommagetrennte Liste von Präfixen für Bezeichner von Bauteilen, die als in Reihe geschaltete Bauteile in xNets verwendet werden können.
Mehrkanal

Die Registerkarte Multi-Channel des Dialogs Project Options
Auf der Registerkarte Multi-Channel des Dialogs Project Options können Sie das Benennungsschema für Räume und das Format der Bauteilbezeichner für Mehrkanaldesigns festlegen. Mehrkanaldesign ermöglicht es, dasselbe untergeordnete Blatt innerhalb eines Projekts mehrfach zu referenzieren. Dies kann durch das Platzieren mehrerer Blattsymbole geschehen, die auf dasselbe untergeordnete Blatt verweisen, oder durch das Einfügen des Schlüsselworts Repeat in den Bezeichner eines Blattsymbols, um dieses mehrfach zu instanziieren.
Altium Designer bietet echtes Mehrkanaldesign, sodass Sie einzelne Blätter in einem Projekt mehrfach referenzieren können. Erforderliche Änderungen können an einer einzigen Stelle vorgenommen werden. Durch erneutes Kompilieren des Projekts werden diese Änderungen anschließend auf alle Instanzen übertragen. Altium Designer unterstützt nicht nur mehrere Kanäle, sondern ermöglicht auch deren Verschachtelung.
Die Zuordnung eines einzelnen logischen Bauteils im Schaltplan zu mehreren physischen Instanzen auf der Leiterplatte wird durch das auf dieser Registerkarte definierte Mehrkanal-Bezeichnerschema gesteuert.
Optionen/Steuerelemente
Raumbenennung
-
Room Naming Style – legen Sie in diesem Feld den Stil für die Benennung der Räume fest. Wenn Sie einen Stil aus der Liste auswählen, wird die darunterliegende Abbildung aktualisiert und zeigt die Benennungskonvention, die im Design verwendet wird. Beim Kompilieren des Designs wird für jedes Blatt im Design ein Raum erstellt, einschließlich jeder Kanalgruppe und jedes untergeordneten Kanals. Es stehen fünf Stile zur Verfügung – zwei flache und drei hierarchische (mit Pfadangabe):
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths – legen Sie in diesem Feld das gewünschte Zeichen/Symbol zum Trennen der Pfadangaben bei Verwendung der hierarchischen Benennungsstile (Stile mit Pfadangabe) fest. Standardmäßig wird der Unterstrich (_) verwendet.
- Preview – wenn Sie Änderungen an Room Naming Style und/oder Designator Format vornehmen, wird die Abbildung in diesem Bereich dynamisch aktualisiert und zeigt die Benennungskonvention, die im Design verwendet wird. Die Abbildung zeigt ein Beispiel für ein verschachteltes 2-x-2-Kanaldesign. Die größeren kreuzschraffierten Bereiche stellen die beiden übergeordneten Kanäle (oder Kanalgruppen) dar. Die schattierten Bereiche darin stellen die untergeordneten Kanäle dar (mit jeweils zwei Beispielbauteilen).
Bauteilbenennung
-
Designator Format - Verwenden Sie dieses Feld, um das Format für die Vergabe von Bezeichnern an die Bauteile des Designs festzulegen. In der Dropdown-Liste des Feldes stehen die folgenden acht vordefinierten Formate zur Verfügung: fünf flache und drei, die in einem hierarchischen Kontext verwendet werden können (mit Kanalbenennung):
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
Eigenes Bezeichnerformat definieren
Sie können auch ein eigenes Format für Bauteilbezeichner definieren, indem Sie es direkt in das Feld Designator Format eingeben. Die folgenden Schlüsselwörter können zum Erstellen der Formatzeichenfolge verwendet werden:
- $RoomName - Dies ist der Name des zugehörigen Kanals, der sich aus dem im Feld Room Naming Style gewählten Stil ergibt.
- $Component- Dies ist der logische Bezeichner des Bauteils.
- $ComponentPrefix - Dies ist das Präfix des logischen Bauteilbezeichners (z. B. U für U1).
- $ComponentIndex - Dies ist der Index des logischen Bauteilbezeichners (z. B. 1 für U1).
- $ChannelPrefix - Dies ist der logische Bezeichner des Blattsymbols.
- $ChannelIndex - Dies ist der Kanalindex.
- $ChannelAlpha - Dies ist der als Buchstabe dargestellte Kanalindex.
Hinweise
- Die alphabetische Indizierung eines Kanals ist nur dann wirklich sinnvoll, wenn Ihr Design insgesamt weniger als 26 Kanäle enthält oder wenn Sie ein hierarchisches Bezeichnerformat verwenden.
- Bei einem Mehrkanaldesign werden am unteren Rand des Schaltplanblatts im Designfenster Registerkarten angezeigt, jeweils eine für jeden Kanal (oder jede Kanalgruppe). Die Namen der Registerkarten setzen sich aus den Blattsymbolnamen und der Kanalnummer zusammen, z. B. BANKA. Dies sind die kompilierten Ansichten (physischen Ansichten) des Designs, während das logische Design wie zuvor auf der Registerkarte Editor verbleibt.
Standarddruckausgaben

Die Registerkarte Default Prints des Dialogs Project Options
Auf der Registerkarte Default Prints des Dialogs Project Options können Sie die Standarddruckausgaben für verschiedene Editoren von Altium Designer einrichten. Diese festgelegten Standardeinstellungen werden verwendet, wenn die folgenden Druckbefehle über die Hauptmenüs der Editoren ausgeführt werden:
- File » Print
- File » Print Preview » Print
Die Registerkarte Default Prints des Dialogs Project Options kann auch aus dem Schaltplaneditor und dem PCB-Editor aufgerufen werden, indem Sie den Befehl File » Default Prints im jeweiligen Hauptmenü wählen.
Optionen/Steuerelemente
Im Hauptbereich der Registerkarte werden alle unterstützten Druckausgaben aufgelistet, die in den Schaltplan- und PCB-Editoren erzeugt werden können. Die Ausgabetypen sind in die folgenden Kategorien unterteilt:
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
Für jeden Eintrag werden die folgenden Informationen angezeigt:
- Output Description – Was mit diesem Druckausgabetyp ausgegeben wird.
- Supports – Der Editor, für den dieser Druckausgabetyp unterstützt wird.
-
Default Print – Gibt an, ob dieser Druckausgabetyp als Standarddrucktyp verwendet werden soll (aktiviert) oder nicht (deaktiviert).
Weitere Optionen
-
Configure – Klicken Sie auf diese Schaltfläche, um den zugehörigen Dialog zum Konfigurieren der aktuell ausgewählten Druckausgabe zu öffnen. Dazu gehören folgende Dialoge:
- Dialog „Drucken“ – Zum Konfigurieren von Bestückungszeichnungen, Gesamtzeichnungen, PCB-Ausdrucken, PCBLIB-Ausdrucken, Schaltplanausdrucken, Gesamtbohrzeichnungen, Bohrzeichnungen/-führungen, Ausdrucken der fertigen Druckvorlagen, Ausdrucken von Versorgungslagen und Ausdrucken von Lötstopp-/Lotpastenmasken.
- Dialog „PCB-3D-Druckeinstellungen“ – Zum Konfigurieren von PCB-3D-Ausdrucken.
- Dialog „PCB-3D-Video“ – Zum Konfigurieren von PCB-3D-Videoausgaben.
- Dialog „PDF3D“ – Zum Konfigurieren von PDF3D- und PDF3D-MBA-Ausgaben.
- Dialog „Erweiterte Textdruckeigenschaften“ – Zum Konfigurieren von Berichts- und Textausdrucken. Legen Sie Optionen für die Druckausgabe fest (z. B. Kopfzeile und Seiten-/Zeilennummerierung). Sie können auch die Verwendung einer bestimmten Schriftart festlegen.
- Wave Print Properties Form Dialog – Zum Konfigurieren von SimView-Ausdrucken.
- Dialog „Lagenaufbaubericht einrichten“ – Zum Konfigurieren der Ausgabe von Leiterplatten-Lagenaufbauberichten.
- Dialog „Berichtsmanager“ – Zum Konfigurieren von Stücklisten und Stücklistenvergleichsberichten.
- Dialog „Kommentarexport konfigurieren“ – Zum Konfigurieren eines Berichts mit exportierten Kommentaren.
- Dialog „Unterschiede einrichten“ – Zum Konfigurieren eines Unterschiedsberichts.
- Dialog „Elektrische Regelprüfung einrichten“ – Zum Konfigurieren eines Validierungsberichts zur elektrischen Regelprüfung.
- Page Setup – Klicken Sie hier, um einen Dialog zur Seiteneinrichtung für die aktuell ausgewählte Druckausgabe zu öffnen. In diesem Dialog können Sie Papier, Skalierung und Farbeinstellungen für den Ausdruck auf dem ausgewählten Drucker konfigurieren. Sie können außerdem den zugehörigen Konfigurationsdialog sowie den Dialog zur Druckereinrichtung öffnen, eine Druckvorschau anzeigen und die Ausgabe schließlich auf dem ausgewählten Drucker drucken.
Suchpfade

Die Registerkarte Search Paths des Dialogs Project Options
Auf der Registerkarte Search Paths des Dialogs Project Options können Sie die Suchpfade zu Bibliotheks- und Modelldateien für das Projekt festlegen.
Optionen/Steuerelemente
Geordnete Liste der Suchpfade
Diese Tabelle zeigt die geordnete Liste der Suchpfade für Bibliotheks- und Modelldateien (z. B. PCB-Footprint-Bibliotheken, Simulations- und Signalintegritätsmodelle). Für jeden Pfad können Sie den Filter und die Einstellungen für die rekursive Suche festlegen.
- Path - Speicherort des Suchpfads.
- Filter - der Filter für die Suche. Standardmäßig sucht der Filter nach allen Dateien.
- Recursive - aktivieren Sie diese Option, um alle Unterverzeichnisse des Suchpfadverzeichnisses zu durchsuchen. Doppelklicken Sie auf einen Suchpfad, um ihn zu bearbeiten.
Die folgenden Dateitypen werden unterstützt: Footprint-Bibliotheken (*.PcbLib), Simulationsmodelldateien (*.mdl), Simulations-Subcircuit-Dateien (*.ckt), IBIS-Modelldateien (*.ibs).
- Delete - entfernt einen ausgewählten Suchpfad.
- Properties - öffnet das Dialogfeld Edit Search Path, in dem Sie die Eigenschaften des ausgewählten Suchpfads bearbeiten können.
- Move Up - verschiebt den ausgewählten Suchpfad um eine Zeile nach oben.
- Move Down - verschiebt den ausgewählten Suchpfad um eine Zeile nach unten.
In allen Suchpfaden gefundene Dateien
Diese Tabelle zeigt die Bibliotheks- und Modelldateien an, die anhand der Liste Ordered List of Search Paths gefunden werden. Verwenden Sie die Schaltfläche Refresh List, um eine aktualisierte Liste anzuzeigen.
Parameter

Die Registerkarte Parameters des Dialogfelds Project Options
Auf der Registerkarte Parameters des Dialogfelds Project Options können Sie die für das Projekt definierten Parameter verwalten, die häufig als project-level parameters bezeichnet werden. Auf Projektebene definierte Parameter können mithilfe spezieller Zeichenfolgen auf allen Schaltplanblättern und in allen PCB-Dokumenten des Projekts verwendet werden: =<ProjectParameterName> in einem Schaltplan (z. B. =Project) und .<ProjectParameterName> auf einer Leiterplatte (z. B. .Project). Parameter können zusätzliche Designinformationen bereitstellen. Parameter auf Projektebene können beispielsweise global als Quelle für parametrische Daten spezieller Zeichenfolgen dienen, die Schaltplanblättern und/oder dem PCB-Dokument hinzugefügt werden sollen. Letzteres unterstützt keine lokalen Parameter.
Workspace-seitige Projektparameter werden zusammen mit dem Projekt im Workspace gespeichert und können nur über die Browseroberfläche des Workspace bearbeitet werden (weitere Informationen zu Editing a Project im Altium 356 Workspace oder On-Prem Enterprise Workspace). Designseitige Projektparameter werden hingegen in der Projektdatei (*.PrjPcb) gespeichert und können in Altium Designer bearbeitet werden. Workspace-seitige Projektparameter werden auf der Registerkarte Parameter des Dialogfelds Project Options mit einem blauen Symbol angezeigt, designseitige Projektparameter dagegen mit einem orangefarbenen Symbol
Optionen/Steuerelemente
-
Parameters Grid – der Hauptbereich listet alle derzeit für das Projekt definierten Parameter mit folgenden Angaben auf:
- Name – der Name des Parameters.
- Value – der Wert des Parameters.
-
Add – klicken Sie hier, um das Dialogfeld Parameter Properties zu öffnen, in dem Sie einen Parameter hinzufügen können. Verwenden Sie die Felder Name und Value, um dem Parameter einen aussagekräftigen Namen zu geben, der seinen Zweck widerspiegelt, bzw. seinen Wert festzulegen. Beide Felder erlauben maximal 255 Zeichen.
- Remove – klicken Sie hier, um die ausgewählten Parameter aus der Parameterliste zu löschen. Diese Option ist für Workspace-seitige Projektparameter nicht verfügbar, da diese nur im Workspace entfernt oder bearbeitet werden können.
- Edit – klicken Sie hier, um das Dialogfeld Parameter Properties zu öffnen, in dem Sie den Inhalt des aktuell ausgewählten Parameters ändern können. Diese Option ist für Workspace-seitige Projektparameter nicht verfügbar, da diese nur im Workspace entfernt oder bearbeitet werden können.
- Refresh – klicken Sie hier, um die letzten Änderungen am designseitigen Projektparameter rückgängig zu machen. Bei Workspace-seitigen Projektparametern klicken Sie hier, um sicherzustellen, dass Ihnen die neueste Version des Parameters vorliegt. Änderungen an Workspace-seitigen Projektparametern, die im Workspace vorgenommen wurden, werden in diesem Dialogfeld erst angezeigt, nachdem diese Option verwendet wurde.
Kontextmenü
Die folgenden Befehle sind im Kontextmenü verfügbar:
-
Edit – ändert den aktuell ausgewählten Parameter im Dialogfeld Parameter Properties. Dieser Befehl ist für Workspace-seitige Projektparameter nicht verfügbar, da diese nur im Workspace entfernt oder bearbeitet werden können.
-
Add – fügt der Liste über das Dialogfeld Parameter Properties einen neuen designseitigen Parameter hinzu.
-
Remove – verwenden Sie diesen Befehl, um die ausgewählten Parameter aus der Liste zu löschen. Dieser Befehl ist für Workspace-seitige Projektparameter nicht verfügbar, da diese nur im Workspace entfernt oder bearbeitet werden können.
-
Copy – verwenden Sie diesen Befehl, um die ausgewählten Parameter in die Windows-Zwischenablage zu kopieren.
-
Paste – verwenden Sie diesen Befehl, um Parameter aus der Windows-Zwischenablage in die Parameterliste einzufügen. Dieser Befehl ist für Workspace-seitige Projektparameter nicht verfügbar, da diese nur im Workspace entfernt oder bearbeitet werden können.
Geräteblätter

Die Registerkarte Device Sheets des Dialogs Project Options
Auf der Registerkarte Device Sheets des Dialogs Project Options können Sie die Ordner, in denen sich die Geräteblätter befinden, sowie deren Reihenfolge festlegen.
Optionen/Bedienelemente
- Main region – listet die Device Sheet Folders Pfade für das aktuelle Projekt auf. Aktivieren Sie Include Sub-folders , um die Unterordner der aufgeführten übergeordneten Ordner einzubeziehen.
- Move Up – verwenden Sie diese Option, um den ausgewählten Geräteblattordner jeweils um eine Position nach oben zu verschieben.
- Move Down – verwenden Sie diese Option, um den ausgewählten Geräteblattordner jeweils um eine Position nach unten zu verschieben.
- Add – verwenden Sie diese Option, um einen Dialog zu öffnen, in dem Sie nach einem neuen hinzuzufügenden Ordner suchen können.
- Remove – verwenden Sie diese Option, um den ausgewählten Geräteblattordner zu entfernen.
Verwaltete OutputJobs

Die Registerkarte Managed OutputJobs des Dialogs Project Options
Auf der Registerkarte Managed OutputJobs des Dialogs Project Options können Sie eine Liste von Ausgabeauftragsvorlagen konfigurieren, die über Ihren verbundenen Workspace zur Verwendung mit dem Projekt verfügbar sind.
Optionen/Bedienelemente
- Outputjob List – listet alle OutputJobs im Workspace mit den Angaben Item Revision, Revision State, Description und Name auf.
- Add – klicken Sie hier, um den Dialog Select configuration item (Output Jobs) zu öffnen und die gewünschten OutputJobs auszuwählen.
- Remove – klicken Sie hier, um die ausgewählten Ausgabeaufträge zu entfernen.
Bibliotheksoptionen

Die Registerkarte Library Options des Dialogs Project Options
Auf der Registerkarte Library Options des Dialogs Project Options können Sie das Format für ein integriertes Bibliotheksprojekt auswählen.
Optionen/Bedienelemente
-
Integrated Library Format
- Original – wählen Sie diese Option, um das ursprüngliche Format für integrierte Bibliotheken zu verwenden. Dieses dient der Kompatibilität mit der Software Protel DXP (DXP 2002) aus der Zeit vor der Einführung von Altium Designer.
-
Altium Designer– wählen Sie diese Option, um Altium Designer als Format für integrierte Bibliotheken zu verwenden (wird seit dem ursprünglichen Altium Designer 2004 in allen Versionen der Software verwendet).
).
