Altium Designer Documentation

Testpoint Setup

Modified by Susan Riege on Feb 2, 2019

     The two varations of the Testpoint Setup dialog

Summary

The Assembly/Fabrication Testpoint Setup dialog is used to configure testpoint reports. The banner of this dialog will change (either Assembly or Fabrication) depending on whether it was accessed to configure options for an Assembly or a Fabrication Testpoint report.

Testpoints are assigned manually or can be detected automatically by running the Testpoint Manager

Access

Testpoint output can be generated in one of two ways:

  • By using an Assembly or Fabrication Test Point Report output generator in an OutputJob Configuration file (*.OutJob). Output is generated when the configured output generator is run.
  • Directly from within the active PCB document using File » Fabrication Outputs » Test Point Report or File » Assembly Outputs » Test Point Report. Output will be generated immediately upon clicking OK in the dialog.
The settings defined in the Testpoint Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an Output Job Configuration file. In the former, the settings are stored in the project file; for the latter, they are stored in the Output Job Configuration file.

Options/Controls

Report Formats

  • Text - enable for standard text format in the report.
  • CSV - enable for standard comma separated value format, which can be imported into a spreadsheet application, such as Excel, for further processing.
  • IPC-D-356A - enable for an IPC netlist file which carries blind and buried via information as well as differentiating between through-hole vias and free pads. When imported into a CAM document along with image and drill data, it facilitates the recovery of original net names used in the PCB design, making the PCB easier to understand and manage within the CAM Editor.

Test Point Layers 

These selections allow you to specify a scope for the report:

  • Top layer - check to include valid testpoints assigned on the top of the board.
  • Bottom layer - check to include valid testpoints assigned on the bottom of the board.

Units

  • Imperial - check to output coordinates in inches.
  • Metric - check to output coordinates in millimeters.

Coordinate Positions

  • Reference to absolute origin - select to use the absolute origin as the reference point for testpoint coordinates.
  • Reference to relative origin - select to use the relative origin as the reference point for testpoint coordinates.

IPC-D-356A Options 

This region of the dialog becomes available only when the IPC-D-356A Report Format option is enabled.
  • Adjacency Information - check to include a list of nets that could possibly be shorted, then enter the adjacency criteria in the text box.
  • Board Outline - check to permit the description of outlines and other segment type data that are not connected to a specific net.  Use the drop down to select the desired information.
  • Conductor Traces - Refer to the IPC-D-356A spec for more detail.

Generated Files

All generated testpoint files are named first by type (Fabrication or Assembly), then by filename. For example: Fabrication Testpoint Report for BoardFileName. The following file extensions are used, depending on which of the Report Formats is enabled: .txt, .CSV, .IPC (note that this is an ASCII file).

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the Testpoint output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name: Project Outputs for ProjectName. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, then the Testpoint files will be written to a further sub-folder named Testpoint Output.

Automatically Opening the Generated Output

When generating Testpoint output, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the IPC-D-356A Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.