Altium NEXUS Documentation

SetupPreferences

Modified by Jason Howie on Jul 25, 2017

Parent page: Client Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: Server=SCH

Summary

This command is used to access the Schematic area of the Preferences dialog, from where you can set up various schematic-based document preferences. These are global system settings that apply when working in any schematic/schematic library document (as applicable). Changing any of these preferences will affect all relevant schematic-based documents you work on.

Access

This command can be accessed from the Schematic Editor, and Schematic Library Editor, by:

  • Choosing the Tools » Preferences command, from the main menus.
  • Right-clicking in the design workspace and choosing the Options » Preferences command, from the context menu.
  • Press O in the design workspace, to access the Options pop-up, then choose the Preferences entry.

Use

After launching the command, the Preferences dialog will appear, with the Schematic - General page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. If a different page in the Schematic area of the Preferences dialog had previously been accessed, this will be the page that is accessed when using this command.


Applied Parameters: Server=SCH|Pagename = GraphEdit

Summary

This command is used to access the Schematic - Graphical Editing page of the Preferences dialog, which provides numerous controls related to editing of schematic-based documents directly in the workspace.

Access

This command is accessed from the Schematic Editor, and Schematic Library Editor, by pressing O in the design workspace, to access the Options pop-up, then choosing the Graphical Editing entry.

Use

After launching the command, the Preferences dialog will appear, with the Schematic - Graphical Editing page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=SCH|Pagename = DefPrimitives

Summary

This command is used to access the Schematic - Default Primitives page of the Preferences dialog, which provides controls and information related to design primitives placed on schematic-based documents.

Access

This command is accessed from the Schematic Editor, and Schematic Library Editor, by pressing O in the design workspace, to access the Options pop-up, then choosing the Defaults entry.

Use

After launching the command, the Preferences dialog will appear, with the Schematic - Defaults page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=SCH|Pagename = Compiler

Summary

This command is used to access the Schematic - Compiler page of the Preferences dialog, which provides numerous controls related to schematic compilation.

Access

This command is accessed from the Schematic Editor, and Schematic Library Editor, by pressing O in the design workspace, to access the Options pop-up, then choosing the Compiler entry.

Use

After launching the command, the Preferences dialog will appear, with the Schematic - Compiler page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=SCH|Pagename = AutoFocus

Summary

This command is used to access the Schematic - AutoFocus page of the Preferences dialog, which provides numerous controls related to auto focus operations on schematic-based documents.

Access

This command is accessed from the Schematic Editor, and Schematic Library Editor, by pressing O in the design workspace, to access the Options pop-up, then choosing the Autofocus entry.

Use

After launching the command, the Preferences dialog will appear, with the Schematic - Autofocus page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=SCH|Pagename = BreakWire

Summary

This command is used to access the Schematic - Break Wire page of the Preferences dialog, which provides controls related to breaking wires on the schematic.

Access

This command is accessed from the Schematic Editor, and Schematic Library Editor, by pressing O in the design workspace, to access the Options pop-up, then choosing the Breakwire entry.

Use

After launching the command, the Preferences dialog will appear, with the Schematic - Break Wire page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=SCH|Pagename = GridsAndUnits

Summary

This command is used to access the Schematic - Grids page of the Preferences dialog, which provides the settings for grid configuration in the Schematic Editor.

Access

This command is accessed from the Schematic Editor, and Schematic Library Editor, by pressing O in the design workspace, to access the Options pop-up, then choosing the Grids entry.

Use

After launching the command, the Preferences dialog will appear, with the Schematic - Grids page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=WorkspaceManager|Pagename = Navigation

Summary

This command is used to access the System - Navigation page of the Preferences dialog, which provides controls related to highlighting and zooming on source schematic design documents.

Access

This command is accessed from the Schematic Editor by pressing O in the design workspace, to access the Options pop-up, then choosing the Navigation entry.

Use

After launching the command, the Preferences dialog will appear, with the System - Navigation page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=PCB

Summary

This command is used to access the PCB Editor area of the Preferences dialog, from where you can set up various PCB-based document preferences. These are global system settings that apply when working in any PCB/PCB library document (as applicable). Changing any of these preferences will affect all relevant PCB-based documents you work on.

Access

This command is accessed from the PCB Editor, PCB Library Editor, and Pad Via Library Editor, by choosing the Tools » Preferences command, from the main menus.

Use

After launching the command, the Preferences dialog will appear, with the PCB Editor - General page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. If a different page in the PCB Editor area of the Preferences dialog had previously been accessed, this will be the page that is accessed when using this command.


Applied Parameters: Server=PCB|PageName = General

Summary

This command is used to access the PCB Editor - General page of the Preferences dialog, which provides a range of configuration controls relating to the relevant editors within the PCB workspace.

Access

This command can be accessed from the PCB Editor, and PCB Library Editor, by:

  • Right-clicking in the design workspace and choosing the Preferences command, from the context menu.
  • Press O in the design workspace, to access the Options pop-up, then choose the Preferences entry.

Use

After launching the command, the Preferences dialog will appear, with the PCB Editor - General page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=PCB|PageName = Display

Summary

This command is used to access the PCB Editor - Display page of the Preferences dialog, which provides a range of options relating to the visual functionality the PCB workspace.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by pressing O in the design workspace, to access the Options pop-up, then choosing the Display entry.

Use

After launching the command, the Preferences dialog will appear, with the PCB Editor - Display page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=PCB|PageName = DefPrimitives

Summary

This command is used to access the PCB Editor - Defaults page of the Preferences dialog, which provides controls and information related to design primitives placed on PCB-based documents.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by pressing O in the design workspace, to access the Options pop-up, then choosing the Defaults entry.

Use

After launching the command, the Preferences dialog will appear, with the PCB Editor - Defaults page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=PCB|PageName = BoardInsight

Summary

This command is used to access the PCB Editor - Board Insight Modes page of the Preferences dialog, which provides numerous controls relating to the functionality of the Board Insight system within the PCB workspace.

Access

This command is accessed from the PCB Editor by pressing O in the design workspace, to access the Options pop-up, then choosing the Board Insight entry.

Use

After launching the command, the Preferences dialog will appear, with the PCB Editor - Board Insight Modes page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=PCB|PageName = BoardInsightDisplay

Summary

This command is used to access the PCB Editor - Board Insight Display page of the Preferences dialog, which provides numerous controls relating to the display of elements within the Board Insight system, used within the PCB workspace.

Access

This command is accessed from the PCB Editor by pressing O in the design workspace, to access the Options pop-up, then choosing the Board Insight Display entry.

Use

After launching the command, the Preferences dialog will appear, with the PCB Editor - Board Insight Display page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=PCB|PageName = RoutingOptions

Summary

This command is used to access the PCB Editor - Interactive Routing page of the Preferences dialog, which provides options relating to the functionality of the Interactive Routing feature within the PCB workspace.

Access

This command is accessed from the PCB Editor by pressing O in the design workspace, to access the Options pop-up, then choosing the Routing Options entry.

Use

After launching the command, the Preferences dialog will appear, with the PCB Editor - Interactive Routing page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=WorkspaceManager|PageName = MouseWheelConfiguration

Summary

This command is used to access the System - Mouse Wheel Configuration page of the Preferences dialog, which provides options relating to configuration of use of the mouse wheel within the PCB workspace.

Access

This command is accessed from the PCB Editor by pressing O in the design workspace, to access the Options pop-up, then choosing the Mouse Configuration entry.

Use

After launching the command, the Preferences dialog will appear, with the System - Mouse Wheel Configuration page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=PCB|PageName = TrueTypeFonts

Summary

This command is used to access the PCB Editor - True Type Fonts page of the Preferences dialog, which provides options relating to configuration of use of True Type fonts within the PCB workspace.

Access

This command is accessed from the PCB Editor by pressing O in the design workspace, to access the Options pop-up, then choosing the TrueType Fonts Options entry.

Use

After launching the command, the Preferences dialog will appear, with the PCB Editor - True Type Fonts page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: None

Summary

This command is used to access the Preferences dialog, from where you can set up various preferences across different functional areas of the software. These are global system settings that apply across projects and relevant documents.

Access

This command is accessed by clicking the  button, at the top-right of the workspace.

Use

After launching the command, the Preferences dialog will appear. Browse through the various pages, configure options as required, then either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. The page presented within the dialog when it opens, will be the page last accessed.


Applied Parameters: Server=TextEdit

Summary

This command is used to access the Text Editors area of the Preferences dialog, from where you can set up various text-based document preferences. These are global system settings that apply when working in any text-based document (as applicable). Changing any of these preferences will affect all relevant text-based documents you work on.

Access

This command is accessed from a text-based editor by choosing the Tools » Editor Preferences command, from the main menus.

Use

After launching the command, the Preferences dialog will appear, with the Text Editors - General page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. If a different page in the Text Editors area of the Preferences dialog had previously been accessed, this will be the page that is accessed when using this command.


Applied Parameters: Server=Camtastic|Pagename=Dimension

Summary

This command is used to access the CAM Editor - Draw Dimension page of the Preferences dialog, which provides options relating to the use of dimension objects within CAM documents.

Access

This command is accessed from the CAMtastic Editor by choosing the Place » Settings command, from the main menus.

Use

After launching the command, the Preferences dialog will appear, with the CAM Editor - Draw Dimension page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=Camtastic|Pagename=FilmBox

Summary

This command is used to access the CAM Editor - Film Box page of the Preferences dialog, which provides options relating to the use of film boxes within CAM documents.

Access

This command is accessed from the CAMtastic Editor by choosing the View » Film Box command, from the main menus.

Use

After launching the command, the Preferences dialog will appear, with the CAM Editor - Film Box page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=Camtastic|Pagename=DrawingModes

Summary

This command is used to access the CAM Editor - Drawing Modes page of the Preferences dialog, which provides options relating to drawing modes used within CAM documents, including grid and object snapping options.

Access

This command can be accessed from the CAMtastic Editor by:

  • Choosing the Tools » Preferences command, from the main menus.
  • Using the Shift+G keyboard shortcut.

Use

After launching the command, the Preferences dialog will appear, with the CAM Editor - Drawing Modes page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.


Applied Parameters: Server=Camtastic

Summary

This command is used to access the CAM Editor area of the Preferences dialog, from where you can set up various CAM-based document preferences. These are global system settings that apply when working in any CAM document. Changing any of these preferences will affect all relevant CAM-based documents you work on..

Access

This command is accessed from the CAMtastic Editor by choosing the File » Setup » General command, from the main menus.

Use

After launching the command, the Preferences dialog will appear, with the CAM Editor - General page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. If a different page in the CAM Editor area of the Preferences dialog had previously been accessed, this will be the page that is accessed when using this command.


Applied Parameters: Server=Camtastic|Pagename=ImportExport

Summary

This command is used to access the CAM Editor - Import/Export page of the Preferences dialog, which provides options relating to import to, and export from, CAM documents.

Access

This command is accessed from the CAMtastic Editor by choosing the File » Setup » Import/Export command, from the main menus.

Use

After launching the command, the Preferences dialog will appear, with the CAM Editor - Import/Export page open as the active page. Configure options as required and either click Apply (to keep the dialog open for editing of further preferences), or OK.

Tips

  1. Settings defined in the Preferences dialog apply across projects and relevant documents.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.