Panel Navegador
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
De un vistazo
- Aprende cómo el panel Navigator te permite explorar hojas de esquema individuales, el proyecto completo y la jerarquía del diseño para encontrar rápidamente objetos conectados.
- Descubre cómo navegar en ambas direcciones, desde el panel hasta el esquema y desde el esquema de vuelta al panel, y en qué casos Alt + clic puede ayudarte a localizar elementos relacionados en la PCB.
- Comprende cómo el resaltado, el zoom, la atenuación y la validación afectan a lo que ves durante la navegación, para que puedas seguir mejor la conectividad en diseños complejos.
Si el diseño es grande y está distribuido en muchas hojas, puede resultar difícil seguir una red y verificar la conectividad del diseño simplemente observando los esquemas. Intentar localizar esos mismos objetos en la PCB supone un reto aún mayor. Para facilitar este proceso, se utiliza el panel Navigator.

Utilice el panel Navigator para obtener una visión de todo el diseño. Mantenga pulsado Alt mientras hace clic en el panel para localizar también ese elemento en la PCB.
El panel Navigator permite explorar el documento esquemático de origen activo o todos los documentos esquemáticos de origen del proyecto activo. El panel utiliza el modelo de conectividad del diseño, que se crea automáticamente en segundo plano, como base para la navegación. El panel también puede utilizarse para navegar hasta componentes, pads, buses y redes en la PCB.
Navegación por el diseño
La navegación puede realizarse de dos formas: haciendo clic en el panel Navigator para localizar el objeto en el esquema, o haciendo clic en el objeto del esquema para localizarlo en el panel Navigator.
Desde el panel Navigator
Para mostrar el panel Navigator, utilice el botón Panels situado en la esquina inferior derecha del software, o seleccione View » Panels » Navigator en los menús.
La información de los componentes y de conectividad se cargará en el panel en cuanto se abra un esquema; haga clic en un icono de la sección Documents para mostrarla. El software crea automáticamente un modelo de datos dinámico para todo el proyecto y lo mantiene actualizado a medida que se realizan acciones de edición. Tenga en cuenta que no se muestran pestañas de documento (en la parte superior del área de edición gráfica) para todas las hojas de esquema, ya que estas se abren en segundo plano; una pestaña solo aparece cuando el usuario realiza una acción en esa hoja.
El modelo de datos dinámico está disponible para cada uno de los editores y también para el panel Navigator. Si en algún momento no está seguro de que el contenido del panel coincida con el estado actual del diseño, seleccione el comando Validate Project para forzar una actualización del modelo (menú Project, o menú contextual que aparece al hacer clic con el botón derecho en el panel Navigator).

Haga clic en un objeto del panel Navigator para localizar todas sus instancias en todo el diseño.
Navegación interactiva
Además de navegar desde las listas de objetos del panel y hacer clic para localizar un objeto en el área gráfica, también puede navegar desde el área gráfica hasta la lista. Este modo, denominado navegación interactiva, se inicia haciendo clic en el botón Interactive Navigation de la parte superior del panel Navigator. El cursor cambia a una cruz, lo que indica que está en modo de navegación, y permanece en este modo hasta que haga clic con el botón derecho o pulse la tecla Esc .
Mientras navega por un diseño, la visualización de la hoja se actualizará de acuerdo con las opciones de resaltado actuales y el panel Navigator se actualizará para mostrar información relacionada con la selección actual en la ventana de edición gráfica.

Active la navegación interactiva (botón de la parte superior del panel Navigator) y, a continuación, haga clic en un objeto de la hoja para localizarlo en el panel y en el resto del diseño.
Atajo de navegación interactiva
Además de iniciar la navegación interactiva desde el panel Navigator, puede activar la navegación en cualquier momento en el editor de esquemas: mantenga pulsado Alt mientras hace clic en un objeto del diseño. Puede hacer clic en cualquier objeto, incluidos cables, etiquetas de red, puertos, entradas de hoja, símbolos de hoja o componentes.
Utilice el atajo Alt+clic para navegar por el diseño.
Cómo se resaltan los objetos durante la navegación
Al hacer clic en un objeto del panel Navigator, el objeto se muestra en el área de edición gráfica. Su apariencia depende de los ajustes de Sistema - Navegación del cuadro de diálogo Preferences. Para acceder a los ajustes directamente desde el panel Navigator, haga clic en el botón Navigation Options situado en la parte superior del panel para abrir el cuadro de diálogo.
La región Highlight Methods del cuadro de diálogo Preferences ofrece opciones para controlar el resultado visual del filtrado temporal que se aplica al documento al navegar, tanto desde el panel como desde el propio documento. Se puede activar cualquier combinación de estas opciones. Por ejemplo, puede que desee ampliar y seleccionar todos los objetos filtrados en la ventana del editor de diseño y, al mismo tiempo, atenuar los demás objetos del diseño para reducir la saturación visual.
El panel Navigator
El panel Navigator ofrece una vista del modelo de conectividad del diseño. La estructura del diseño se presenta en las cuatro secciones del panel, que se describen a continuación.
El panel Navigator presenta una vista de todo el diseño centrada en la conectividad.
Sección de documentos
Situada en la parte superior del panel, la sección Documents ofrece tres formas diferentes de visualizar el diseño: el individual sheets, el flattened hierarchy (todo el proyecto) o la posibilidad de explorar los full design hierarchy. Haga clic una vez en un icono de esta primera sección para cargar los datos en el panel, o haga doble clic para mostrar también los resultados en el espacio de edición gráfica.
Características de la sección de documentos
Sección de documentos |
|
| Individual Sheets | Muestra un icono para cada una de las hojas de esquemático capturadas, identificadas por el Haga clic una vez para mostrar los resultados en el panel Navigator, o haga doble clic para mostrarlos también en el espacio de edición gráfica. |
| Flattened Hierarchy (todo el proyecto |
Muestra todos los objetos y la conectividad de todo el proyecto. Si hay hojas repetidas (canales) en el diseño, se mostrará un icono secundario para cada clase de canal, identificado por el nombre del canal (derivado del Haga clic una vez para mostrar los resultados en el panel Navigator, o haga doble clic para mostrarlos también en el espacio de edición gráfica. |
| Full Design Hierarchy | Muestra un icono para cada hoja lógica del proyecto. Si hay hojas repetidas (canales) en el diseño, habrá un icono de hoja para cada canal, identificado por el Haga clic una vez para mostrar los resultados en el panel Navigator, o haga doble clic para mostrarlos también en el espacio de edición gráfica. Si hace doble clic en el icono de un canal repetido, además de mostrar la hoja de ese canal, se seleccionará la pestaña del canal específico en la parte inferior del espacio de edición del esquemático. |
Sección de componentes
La segunda región del panel contiene todos los componentes del documento seleccionado actualmente en la primera sección. Al seleccionar una entrada de instancia de componente de nivel superior en la lista, se aplicará un filtro basado en esa entrada, cuyo resultado visual dependerá de los métodos de resaltado elegidos. Si las opciones de resaltado activadas incluyen la opción Connective Graph, todos los demás componentes conectados al componente seleccionado serán visibles (el filtro se habrá ampliado para incluirlos). Los componentes conectados se resaltan visualmente mediante las líneas verdes de conexión del gráfico.
Como el gráfico de conectividad está activado, se dibuja una línea verde hacia cada componente conectado al componente seleccionado en el panel.
Características de la sección de componentes
Sección de componentes |
|
| Information available | Para cada entrada de componente, hay subcarpetas de Parameters y Implementations (modelos). Si la opción Pins está activada en las opciones de resaltado, también estará disponible una subcarpeta Pins |
| When you click | Al hacer clic en una entrada de pin de la lista Instance, la entrada correspondiente a ese pin se seleccionará en la sección Net / Bus del panel y todos los pines de la red a la que pertenece se enumerarán en la sección inferior del panel. También se aplicará un filtro basado en la entrada de pin elegida; el resultado visual dependerá de los métodos de resaltado activados. |
| Connective Graph | Si ha activado la opción Connective Graph, todos los demás pines conectados a la red a la que pertenece el pin seleccionado serán visibles (el filtro se habrá ampliado para incluirlos). La red a la que pertenecen los pines conectados se resalta visualmente mediante líneas rojas de conexión del gráfico |
Sección Red / Bus
La tercera sección del panel enumera cada una de las redes y los buses del documento (o de la jerarquía aplanada) que se está explorando. Al hacer clic en una entrada, todos los objetos asociados a la red o al bus —pines, etiquetas de red, puertos, entradas de hoja y conectores entre hojas— se mostrarán en la ventana del editor de diseño de acuerdo con los métodos de resaltado habilitados.
Características de la sección Red / Bus
Sección Red / Bus |
|
| Information available | Los distintos tipos de objetos asociados a la red o al bus seleccionados se enumeran en subcarpetas, en función de las opciones de resaltado habilitadas y de la presencia de ese tipo de objeto en la red o el bus seleccionados. Para cada red o bus, se puede incluir una subcarpeta adicional que enumere las líneas gráficas utilizadas para conectar los pines, puertos, etiquetas de red, entradas de hoja y conectores entre hojas asociados. Haga clic en una entrada de línea para filtrar únicamente ese objeto de línea y aplicar los ajustes de control visual. |
| When you click | Todos los objetos de red cuya visualización se haya habilitado en el panel (a excepción de las líneas gráficas) se mostrarán en la sección inferior del panel De nuevo, al hacer clic en cualquiera de ellos se aplicará el filtrado de acuerdo con los métodos de resaltado habilitados. |
Sección Redes del bus - Pines de la red
El contenido de la cuarta sección del panel depende de dos factores: el objeto por el que esté navegando y los objetos que haya configurado para su visualización. Si hace clic en un bus en la sección Red / Bus, las redes de ese bus se enumerarán en esta sección del panel. Si hace clic en una net en la sección Red / Bus, se enumerarán los pines de esa red. También se enumerarán los identificadores de red asociados a esa red, si su visualización está habilitada.
Sección Señal
El panel Navigator permite visualizar el diseño centrándose en las señales, en lugar del enfoque centrado en objetos con el que normalmente presenta el diseño. Si se selecciona un documento esquemático en la sección Documents del panel, al habilitar la opción Show Signals en la parte superior del panel, la tercera sección del panel cambia al modo Signal.
Haga clic en una entrada de señal para aplicar un filtro y los nodos de esa señal (pines, puertos, etiquetas de red, entradas de hoja y conectores entre hojas) se mostrarán en la ventana del editor de diseño de acuerdo con los métodos de resaltado habilitados. Para cada señal de la lista, se enumerarán los pines de nodo, las entradas de hoja o los conectores entre hojas asociados a esa señal. Estas entradas se mostrarán independientemente de si se ha habilitado o no la opción de visualización correspondiente a ese tipo de objeto.
Características de la sección Señal
Sección Señal |
|
| Signal | Nombre de la señal (nombre del bus o de la red). |
| Width | Número de redes individuales dentro de esta señal. |
| Click on a top-level signal entry | Haga clic en una entrada de señal de nivel superior para mostrar en la sección inferior del panel todos los nodos de señal asociados a esa señal. Estos pueden incluir pines, etiquetas de red, puertos, entradas de hoja y conectores entre hojas. Las entradas solo se mostrarán si se ha habilitado la opción correspondiente para visualizar ese tipo de objeto. |
| Click on a sub-entry | Haga clic en una subentrada de la lista principal de señales para mostrar en la sección inferior del panel todos los objetos de red asociados a la red principal de esa señal. |
| SignalName Driven By Pin X | Se muestra cuando un pin de nodo asociado a una señal es un pin de salida o de E/S. X representa el designador de componente-pin que controla la señal. |
| Driving Node Pin X | Se muestra cuando un pin de nodo asociado a una señal es un pin de entrada. X representa el designador de componente-pin controlado por la señal. |
| Driven By Node Sheet Entry SignalName | Se muestra cuando el tipo eléctrico de un nodo de entrada de hoja es de salida o de E/S; la entrada controla la señal. |
| Driving Node Sheet Entry X | Se muestra cuando el tipo eléctrico de la entrada de hoja es de entrada; en ese caso, la señal controla la entrada. |
Navegación por la PCB
Además de navegar hasta los objetos del esquemático al hacer clic en el panel Navigator, también puede navegar hasta esos objetos en la PCB al mismo tiempo. Si mantiene pulsada la tecla Alt mientras hace clic en un objeto del panel Navigator, los objetos de destino se resaltarán tanto en el esquemático como en la PCB.
Dado que la navegación siempre se realiza en el esquemático, para navegar hasta los objetos de la PCB debe mostrar el esquemático y la PCB al mismo tiempo. Puede hacerlo mostrando la PCB en una ventana independiente o compartiendo el espacio gráfico mediante la función Split Vertical o Split Horizonal (a continuación se muestra la disposición vertical). Los comandos de cada una de estas opciones están disponibles en el menú contextual que aparece al hacer clic con el botón derecho en una pestaña de documento.
Mantenga pulsada la tecla Alt mientras navega por el diseño para localizar también esos objetos en la PCB.
Altium Designer incluye varias funciones para trabajar entre el esquemático y la PCB, entre ellas:
| Cross probe | Sondeo cruzado: haga clic con el botón derecho para iniciarlo y, a continuación, haga clic en un objeto (componente, pin o red) de un editor para ir a ese objeto en el otro editor. Hay dos modos: continuous (permanecer en el editor de origen) o jump-to (convertir el editor o documento de destino en el documento activo). Mantenga pulsada la tecla Ctrl durante el sondeo cruzado para activar el modo jump-to. El sondeo cruzado está disponible desde los editores de esquemáticos, PCB y BOM; el Constraint Manager; y los paneles Project, Navigator y Messages. |
| Cross select | Haga clic para seleccionar un componente en un editor y que también se seleccione en el otro. Esta función está disponible entre los editores de esquemáticos y PCB y se habilita en el menú View. |
Más información sobre Sondeo cruzado y selección cruzada
Menú contextual del panel Navigator
El menú contextual del panel Navigator, que se abre al hacer clic con el botón derecho, incluye los siguientes comandos:
)
)
).


).
).
).

).
