Mantener sincronizados los esquemáticos y la PCB
Altium Essentials: Transfer to PCB
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
De un vistazo
- Descubre la diferencia entre los flujos de trabajo de comparación bidireccional y de actualización directa, y cuándo se utiliza cada enfoque.
- Comprende qué puede sincronizar Altium Designer entre el esquema y la PCB, incluidos los componentes, la conectividad, las clases y determinadas reglas de diseño.
- Conoce cómo las opciones del proyecto, como la configuración del comparador y de la generación de ECO, influyen en el proceso de sincronización y en los cambios que se pueden aplicar.
La tarea más habitual en el diseño de esquemas y PCB consiste en mantener el esquema y la PCB concordantes o sincronizados. Tanto si transfiere por primera vez un diseño capturado a una nueva PCB como si realiza cambios en un diseño existente, ya sea en el esquema o en la PCB, necesita una forma de mantener ambas partes sincronizadas. Altium Designer incluye potentes funciones de sincronización del diseño que simplifican esta tarea y permiten al diseñador centrarse en los aspectos creativos del proceso de diseño.
El proceso de sincronización detecta y resuelve las diferencias entre el esquema y la PCB.
La sincronización del diseño se realiza directamente entre los editores de esquemas y PCB; no se utiliza ningún documento intermedio de tipo lista de conexiones. El software utiliza un motor de comparación para comparar todos los aspectos del diseño y presenta los resultados como una lista de diferencias. El diseñador decide qué parte debe modificarse para resolver las diferencias y se crea un conjunto de órdenes de cambio de ingeniería (ECO). Al aplicarlas, las dos partes del diseño vuelven a estar sincronizadas.
¿Qué se puede sincronizar?
El proceso de sincronización garantiza que los datos de componentes y conectividad del esquema coincidan con los de la PCB. Además de estos datos, el proceso de sincronización también garantiza que otras restricciones de diseño, como las clases de redes, las clases de componentes y las reglas de diseño, estén sincronizadas.
Configuración de las opciones del comparador
Dialog page: Opciones del proyecto de PCB, pestaña Comparador
Los datos concretos del esquema y de la PCB que se comparan, what, se configuran en la pestaña Comparador del cuadro de diálogo Options for PCB Project. Seleccione Project » Project Options para abrir el cuadro de diálogo.

El motor de comparación respeta los ajustes definidos en la pestaña Comparator del cuadro de diálogo Options for Project.
La zona principal del cuadro de diálogo incluye una amplia lista de tipos de comparación, como Different Designators y Changed Net Name, agrupados en 5 categorías. La columna Mode de la derecha incluye una lista desplegable para cada uno, en la que se selecciona el modo de comparación, como Find Differences o Ignore Differences. Las comparaciones de texto tienen una tercera opción que permite comparar sin distinguir entre mayúsculas y minúsculas.
De forma predeterminada, en un proyecto nuevo se buscan diferencias para todos los tipos de comparación. Configure las opciones según las necesidades de su proyecto.
En la parte inferior del cuadro de diálogo hay opciones para configurar Object Matching Criteria. La correspondencia se establece mediante un proceso sofisticado de varias pasadas que no se basa en una simple coincidencia exacta de cadenas. Para obtener más información, consulte la sección Correspondencia de redes y clases.
Observe la opción Ignore Rules Defined in the PCB Only en la parte inferior del cuadro de diálogo; actívela para excluir del proceso de comparación las reglas que haya definido en la PCB.
Sincronización de clases de redes y componentes
Dialog page: Opciones del proyecto de PCB, pestaña Generación de clases
Además de los datos de componentes y conectividad, también puede generar y sincronizar clases y reglas de diseño al realizar una Design » Update PCB.
Sincronización de reglas de diseño
Las reglas de diseño se pueden definir en el esquema mediante un objeto de conjunto de parámetros. Al seleccionar un objeto de conjunto de parámetros, el panel o cuadro de diálogo modal Properties incluye una sección Rules. Haga clic en la lista desplegable Add para añadir una regla de diseño. La regla se aplicará a la red, el bus, el mazo de cables o los objetos cubiertos por la directiva de cobertura con los que esté en contacto el objeto de conjunto de parámetros.
En la imagen siguiente, se está aplicando una regla de diseño de restricción de anchura a la clase de redes USB_data (la clase de redes también se define como parte de este conjunto de parámetros, en la sección Classes de la lista desplegable Parameters ).

El conjunto de parámetros se utiliza para definir una clase de redes y una regla de diseño para las redes cubiertas por el objeto de cobertura del esquema. Tenga en cuenta que las unidades de medida necesarias se configuran en la parte inferior del cuadro de diálogo Editar regla de PCB.
Añadir una regla de diseño en el esquema
- Asocie un conjunto de parámetros a la red, el bus, el mazo de cables o la directiva de cobertura (añada una definición de clase de redes al conjunto de parámetros si es necesario).
- Add una definición de regla en el conjunto de parámetros. Se abrirá el cuadro de diálogo Choose Design Rule Type, como se muestra arriba.
- Seleccione el Rule Type necesario.
- Haga clic en el botón OK para abrir el cuadro de diálogo Edit PCB Rule.
- Configure los requisitos de la regla de PCB según sea necesario. Tenga en cuenta que las unidades de medida necesarias para esta regla de PCB se seleccionan en la parte inferior del cuadro de diálogo.
Tanto en la imagen anterior como en la siguiente, la regla de diseño se define en un objeto de conjunto de parámetros asociado a una directiva de cobertura. Al incluir una definición de clase en el objeto de conjunto de parámetros, también se creará una clase de redes de PCB y, puesto que la definición de clase está presente, el ámbito de aplicación de la regla de PCB será InNetClass('<PCB_NetClassName >').
En la imagen siguiente observará que el objeto de conjunto de parámetros se muestra como una directiva de par diferencial. Este es un tipo especial de objeto de conjunto de parámetros que se coloca mediante el comando Place » Directives » Differential Pair.

La directiva de par diferencial se utiliza para definir una clase de redes y una regla de diseño que se aplica a los pares diferenciales especificados.
Configuración de las opciones de generación de ECO
El cuadro de diálogo Options for Project también incluye una pestaña Generación de ECO. Esta pestaña define para qué modificaciones de diseño se pueden crear ECO. Normalmente, todas están habilitadas, y las opciones de la pestaña Comparador del cuadro de diálogo se utilizan para configurar qué cambios de diseño se sincronizarán entre el esquema y la PCB.

La pestaña Generación de ECO define para qué tipos de modificaciones se pueden crear ECO.
Detección de diferencias
La función de sincronización del diseño puede detectar y resolver diferencias en ambas direcciones; es decir, del esquema a la PCB o de la PCB al esquema.
El software es capaz de resolver estas diferencias aplicando cambios en ambos lados al mismo tiempo. Por ejemplo, imagine que el diseñador electrónico ha cambiado el valor de un condensador, mientras que el diseñador de la PCB ha cambiado la huella de ese mismo condensador. Estas dos diferencias se pueden resolver en un único proceso de actualización, aplicando el cambio de comentario como una actualización del esquema a la PCB y el cambio de huella como una actualización de la PCB al esquema.
Cuando el motor del comparador compara el proyecto esquemático con la PCB, se crea una lista completa de diferencias; en esta fase no se presupone qué lado debe modificarse para que vuelvan a estar sincronizados.
La lista de diferencias se puede consultar en el cuadro de diálogo Differences between.
Opciones y controles del cuadro de diálogo Diferencias entre
El cuadro de diálogo se divide esencialmente en tres áreas principales: Differences, Update y Change Order.
Diferencias
Esta área del cuadro de diálogo muestra todas las diferencias que el comparador ha encontrado entre los documentos seleccionados. Cada diferencia se muestra en la columna correspondiente al documento en el que se encuentra. Las diferencias se agrupan por tipo de comparación, según los tipos enumerados y habilitados en la pestaña Comparador del cuadro de diálogo Project Options . La entrada de este nivel de agrupación indica el número de diferencias de ese tipo.
Haga doble clic en una entrada para localizar el objeto en el documento de origen correspondiente mediante la navegación cruzada.
Actualización
Utilice esta área del cuadro de diálogo para especificar qué documento debe actualizarse para resolver la diferencia. De forma predeterminada, todas las entradas Decision tienen inicialmente asignada la decisión No Change .
La decisión de actualización para cada diferencia se puede determinar individualmente haciendo clic en la entrada asociada de la columna Decision y seleccionando la acción de actualización requerida en el posterior cuadro de diálogo Decisión de ECO. Simplemente elija la dirección de la actualización (cuál de los documentos comparados se actualizará) o No Updates.
Orden de cambio
Esta área del cuadro de diálogo muestra, para cada diferencia sobre la que decida actuar, la acción que se realizará, el objeto afectado por la acción y el documento en el que se llevará a cabo. Esta información se utiliza para elaborar la ECO posterior que se empleará para realizar las actualizaciones. Las acciones habituales que se mostrarán en esta área son:
- Remove - cuando la actualización se realiza hacia el documento que contiene el objeto que causa la diferencia; el objeto se eliminará.
- Add - cuando la actualización se realiza hacia el documento que no contiene el objeto que causa la diferencia; el objeto se añadirá.
- Update - cuando ambos documentos contienen el mismo objeto, pero este difiere en algún aspecto; el objeto que se modificará depende de la dirección elegida.
Menú contextual
- Create Change Order - se utiliza para crear una orden de cambio de ingeniería (ECO).
- Generate Report - se utiliza para generar un informe de las diferencias encontradas por el comparador. Las decisiones de actualización que haya tomado y las acciones se incluirán en la ECO generada. El informe se cargará en el cuadro de diálogo Report Preview. Utilice este cuadro de diálogo para revisar el informe antes de exportarlo a uno de los diversos formatos compatibles o imprimirlo directamente.
- << Update All in - se utiliza para establecer la dirección de actualización de todas las diferencias hacia el documento de la izquierda (cuando corresponda).
- Update All in >> - se utiliza para establecer la dirección de actualización de todas las diferencias hacia el documento de la derecha (cuando corresponda).
- Reverse Direction For All - se utiliza para invertir rápidamente la dirección de actualización de todas las diferencias (cuando corresponda). Si no es válido cambiar la dirección de una diferencia, la entrada se establecerá en No Change.
- Set No Action For All - se utiliza para establecer rápidamente la decisión de actualización de todas las diferencias en No Change.
- << Update Same Kind in - se utiliza para establecer la dirección de actualización de todas las diferencias del mismo tipo de comparación que la diferencia seleccionada actualmente hacia el documento de la izquierda (cuando corresponda).
- Update Same Kind in >> - utilícelo para establecer la dirección de actualización de todas las diferencias del mismo tipo de comparación que la diferencia actualmente enfocada hacia el documento de la derecha (cuando corresponda).
- Reverse Direction For Same Kind - utilícelo para invertir rápidamente la dirección de actualización de todas las diferencias del mismo tipo de comparación que la diferencia actualmente enfocada, cuando corresponda. Si no es válido cambiar la dirección de una diferencia, la entrada se establecerá en No Change.
- Set No Action For Same Kind - utilícelo para establecer rápidamente la dirección de actualización de todas las diferencias del mismo tipo de comparación que la diferencia actualmente enfocada en No Change.
- << Update Selected in - utilícelo para establecer la dirección de actualización de todas las diferencias seleccionadas hacia el documento de la izquierda (cuando corresponda).
- Update Selected in >> - utilícelo para establecer la dirección de actualización de todas las diferencias seleccionadas hacia el documento de la derecha (cuando corresponda).
- Reverse Direction For Selected - utilícelo para invertir rápidamente la dirección de actualización de todas las diferencias seleccionadas (cuando corresponda). Si no es válido cambiar la dirección de una diferencia, la entrada se establecerá en No Change.
- Set No Action For Selected - utilícelo para establecer rápidamente la decisión de actualización de todas las diferencias seleccionadas en No Change.
- Invert Selection - utilícelo para seleccionar todas las diferencias que no estén seleccionadas actualmente en la lista o deseleccionar las que sí lo estén.
Controles adicionales
Los siguientes botones están disponibles en la parte inferior del cuadro de diálogo:
- Create Engineering Change Order - haga clic en este botón para generar una ECO. Aparecerá el cuadro de diálogo Engineering Change Order, desde el cual podrá validar y ejecutar las actualizaciones para sincronizar los documentos.
- Report Differences - haga clic en este botón para generar un informe de las diferencias encontradas por el comparador. Las decisiones de actualización que haya tomado y las acciones se incluirán en la ECO generada. El informe se cargará en el cuadro de diálogo Report Preview. Utilice este cuadro de diálogo para revisar el informe antes de exportarlo a uno de los diversos formatos admitidos o imprimirlo directamente.
- Explore Differences - haga clic en este botón para investigar con más detalle las diferencias encontradas por el comparador antes de generar una ECO. El cuadro de diálogo Differences between se cerrará y volverá al espacio de trabajo principal con el panel Differences abierto. El panel contendrá todas las diferencias enumeradas por el comparador, agrupadas en las mismas categorías. Utilice el panel para localizar mediante sondeo cruzado el objeto responsable de una diferencia en el documento al que pertenece.
Para abrir el cuadro de diálogo Difference between y ver una lista de diferencias:
-
Para abrir el cuadro de diálogo Choose Documents to Compare, como se muestra en la imagen siguiente, ejecute el comando Project » Show Differences o haga clic con el botón derecho en la entrada del proyecto deseado (o de uno de sus documentos de origen) en el panel Projects y seleccione el comando Show Differences en el menú contextual. El cuadro de diálogo Choose Documents to Compare se utiliza para seleccionar los dos documentos o conjuntos de documentos que se van a comparar; normalmente, se compara el proyecto de esquemáticos con la PCB. También puede utilizar este cuadro de diálogo para comparar cualquier documento con otro marcando la opción Advanced Mode. Por ejemplo, puede comparar una lista de conexiones con una PCB, o una PCB con otra PCB.
Por lo general, la configuración predeterminada del cuadro de diálogo, tanto en el modo básico como en el avanzado, es adecuada para la mayoría de las necesidades de comparación de diseños, en las que se deben comparar los documentos de origen y el diseño de PCB de destino con el fin de sincronizarlos. No obstante, el cuadro de diálogo permite comparar otros documentos, lo que puede resultar útil si necesita cargar versiones de un proyecto y comparar las diferencias entre los documentos de origen correspondientes.

Seleccione la PCB con la que desea comparar el proyecto de esquemáticos. - Seleccione la PCB en la parte principal del cuadro de diálogo y haga clic en OK para abrir el cuadro de diálogo Difference between, como se muestra a continuación. Si el documento de PCB ya está sincronizado con los documentos de origen, aparecerá un cuadro de diálogo que indica que no se han detectado diferencias.
Se abrirá el cuadro de diálogo Differences between. El sincronizador es bidireccional. Esto significa que puede especificar actualizaciones para ambos documentos en la misma ECO. Para sincronizar los documentos comparados, el objetivo es determinar, para cada diferencia, si se debe realizar alguna acción y en qué dirección se aplicará el cambio, especificando qué documento debe actualizarse para resolver la diferencia. Por tanto, el siguiente paso consiste en asignar una dirección de actualización a cada diferencia:
- Para una diferencia individual, haga clic en la columna Update para mostrar un selector de dirección, como se muestra en la imagen siguiente.
- Para varias diferencias del mismo tipo, haga clic con el botón derecho en un encabezado, como Huellas diferentes, y seleccione el comando Update Same Kind deseado.
- Para todas las diferencias, haga clic con el botón derecho en cualquier lugar del cuadro de diálogo y seleccione el comando Update All deseado.

Para cada diferencia, se debe establecer la dirección de actualización a fin de crear una ECO que la resuelva.
Haga clic en el botón Explore Differences para acceder al panel Differences y explorar las diferencias como se describe en la sección Exploración de cambios de diseño con el panel Differences que aparece a continuación.
Haga clic en Report Differences para configurar e imprimir o exportar un informe de las diferencias encontradas por el comparador, las decisiones de actualización especificadas y las acciones que se incluirán en la ECO generada.
Una vez asignada la dirección de actualización, haga clic en el botón Create Engineering Change Order para abrir el cuadro de diálogo Engineering Change Order, que se describe en la sección Resolución de diferencias: aplicación de las ECO que aparece a continuación.
Exploración de cambios de diseño con el panel Differences

El panel Differences muestra una vista jerárquica de las diferencias entre documentos.
Resumen
El panel Differences se utiliza para mostrar las diferencias lógicas o físicas que encuentra el comparador de diferencias integrado del software al comparar documentos de diseño (por ejemplo, al comparar la jerarquía de documentos fuente [esquemáticos] de un proyecto con el documento de diseño de PCB). El panel permite explorar las diferencias de forma interactiva antes de decidir si se crea una orden de cambio de ingeniería (ECO) que se utilizará para sincronizar los documentos del proyecto.
Acceso al panel
Para abrir el panel Differences :
- Seleccione View » Panels » Differences en los menús principales.
- Haga clic en el botón Panels situado en la parte inferior derecha del espacio de trabajo de diseño y, a continuación, haga clic en Differences.
Visualización de diferencias
El uso del panel Differences depende de si el objetivo es:
- Analizar la integridad del proyecto completo en cuanto a su contenido y estructura mediante la detección de diferencias lógicas dentro de la jerarquía del proyecto.
- Comparar dos versiones del mismo documento de esquemático o PCB mediante la detección de sus diferencias gráficas (físicas).
Visualización de diferencias lógicas
La comparación de documentos del proyecto para detectar diferencias lógicas se realiza en el cuadro de diálogo Choose Documents To Compare, que se activa haciendo clic con el botón derecho en un proyecto (o documento del proyecto) en el panel Proyectos y seleccionando Show Differences en el menú contextual correspondiente.

Haga clic con el botón derecho en el nombre de un proyecto y seleccione Show Differences para abrir el cuadro de diálogo Choose Documents To Compare.
Normalmente, el documento de PCB se compara con la jerarquía de documentos fuente del proyecto al que pertenece para detectar diferencias lógicas entre el contenido del diseño esquemático y el contenido del diseño de PCB.
Después de hacer clic en OK, si existen diferencias entre los documentos seleccionados, se abrirá el cuadro de diálogo Diferencias entre. La información del panel Differences solo aparecerá después de hacer clic en el botón Explore Differences del cuadro de diálogo Differences between.
El panel Differences mostrará únicamente las diferencias que se enumeran en el cuadro de diálogo Differences between. Estas, a su vez, se determinan mediante las selecciones realizadas en la pestaña Comparador del cuadro de diálogo Project Options (Project » Options). Esta pestaña enumera todos los tipos de comparación, como las diferencias relacionadas con componentes, redes y parámetros. Al establecer Mode para cada categoría de comparación en Find Differences o Ignore Differences, se determina si el comparador de diferencias transmite sus resultados al cuadro de diálogo Differences between .

Configure cómo se detectan y se notifican las diferencias en el cuadro de diálogo Project Options .
El panel Differences muestra las diferencias encontradas entre los documentos fuente en una estructura de árbol, en la que la carpeta de nivel superior muestra el número total de diferencias detectadas. A continuación, se crean subcarpetas para cada tipo de comparación específico que aparece en el cuadro de diálogo Diferencias entre. Cada subcarpeta enumera las diferencias específicas que se han encontrado, que, a su vez, se desglosan en los objetos de los documentos responsables de generar esas diferencias.
Si el documento asociado está abierto (o abierto y oculto), al hacer clic en una entrada de objeto en el panel se localizará el objeto correspondiente en el documento mediante navegación cruzada.
La visualización del objeto utiliza un efecto de zoom y atenuación: el objeto se resalta atenuando todos los demás objetos. El contraste de la atenuación puede ajustarse con el control deslizante Dimming que se encuentra en la sección Highlight Methods de la página Sistema - Navegación del cuadro de diálogo Preferences .
Visualización de diferencias físicas
La comparación gráfica (física) de dos versiones del mismo documento de esquemático o PCB se realiza básicamente de la misma manera que la comparación lógica descrita anteriormente, pero también utiliza Advanced Mode en el cuadro de diálogo Choose Documents To Compare.
Para realizar una comparación física de documentos, utilice el comando Show Differences (menú contextual del panel Projects) para abrir el cuadro de diálogo Choose Documents To Compare y, a continuación, marque la casilla Advanced Mode. Una vez que se muestren todos los archivos del proyecto en el cuadro de diálogo, seleccione las dos variantes de un documento que desea comparar.

Selección de documentos para la comparación física desde el cuadro de diálogo Choose Documents To Compare en Advanced Mode.
Al hacer clic en OK, se realizará la comparación gráfica y se abrirá el cuadro de diálogo Diferencias entre como se ha descrito anteriormente. Haga clic en Explore Differences para abrir la lista interactiva de diferencias en el panel Differences.
El panel muestra las diferencias encontradas entre los documentos en una estructura de árbol. La carpeta de nivel superior muestra el número total de diferencias detectadas. Se crean entradas para cada tipo de diferencia que, a su vez, contienen las referencias específicas y el objeto (puerto, componente, etc.) implicado en cada una.
Al seleccionar la entrada del objeto correspondiente a una diferencia detectada, se resaltará el objeto y se ampliará su vista en el espacio de diseño del editor.
Notas
- Si un objeto del panel se encuentra en un documento que está oculto, el documento se abrirá automáticamente y se convertirá en el documento activo de la ventana del editor de diseño cuando haga clic en la entrada asociada.
- El filtrado que se aplica al realizar la navegación cruzada desde el panel Differences es temporal. Por tanto, no impide seleccionar ni editar objetos de diseño que queden fuera del alcance del filtro.
- La información del panel Differences se borrará al realizar una nueva comparación de documentos o al compilar el proyecto al que pertenece.
- Utilice el comando Project » Show Physical Differences de los menús principales para detectar las diferencias físicas que existen entre dos versiones de un documento de esquemático o PCB y presentar estas diferencias gráficamente al visualizar los dos documentos uno junto al otro en el espacio de diseño. Esta función Mostrar diferencias físicas ofrece una comparación exclusivamente visual: ninguno de los documentos comparados puede actualizarse mediante la generación de ECO. Está pensada para comparar dos versiones del mismo documento, pero, si se ejecuta para comparar documentos distintos, como la jerarquía de documentos fuente del proyecto con la PCB, aparecerá el panel Differences con una lista de las diferencias lógicas detectadas.
Realización de una actualización directa
Como el diseñador suele saber en qué dirección desea aplicar las actualizaciones y todas ellas se realizan en la misma dirección, puede optar por omitir el proceso de detección de diferencias y asignación de dirección que se acaba de describir.
En lugar de seleccionar el comando Show Differences del menú Project, seleccione el comando Update del menú Design, ya sea desde el editor de esquemas o desde el editor de PCB. El editor desde el que ejecute el comando indica la dirección en la que desea aplicar los cambios: del editor this al editor that. Por ejemplo, seleccionaría Design » Update en el editor de esquemas para transferir todos los cambios del esquema a la PCB.
Se omitirá el cuadro de diálogo Differences between y pasará directamente al cuadro de diálogo Engineering Change Order.
Si todas las actualizaciones se van a aplicar en la misma dirección, utilice el comando Design » Update.
Resolución de diferencias: aplicación de las ECO
Cada diferencia se resuelve aplicando una orden de cambio de ingeniería (ECO). Las ECO se enumeran en el cuadro de diálogo Engineering Change Order, con una ECO por línea, cada una con su propia casilla Enable.
Al utilizar el cuadro de diálogo Engineering Change Order:
- El cuadro de diálogo se abre con todos los cambios habilitados; deshabilite los que desee posponer por ahora. El cuadro de diálogo admite la selección múltiple: utilice el menú contextual del botón derecho para alternar el estado de habilitación de las ECO seleccionadas.
- Utilice el comando de sondeo cruzado del menú contextual del botón derecho para examinar los objetos afectados por esa ECO.
- Utilice el botón Validate Changes para comprobar que los cambios se pueden realizar. Las ECO suelen fallar porque un objeto no está disponible; por ejemplo, la huella de PCB especificada no existe en las Bibliotecas basadas en archivos disponibles, o el pad especificado no existe en la huella.
- Una ECO también puede fallar porque un objeto necesario para una determinada ECO no estaba presente, pero se añadió durante el procesamiento de las ECO actuales. En esta situación, ejecute de nuevo el comando Actualizar para completar esa ECO.

Cada cambio de diseño se presenta como una ECO; habilite las que sean necesarias.
Opciones y controles del cuadro de diálogo Orden de cambio de ingeniería
El cuadro de diálogo se divide en dos áreas principales: Modifications y Status.
Modificaciones
Esta área del cuadro de diálogo enumera todas las modificaciones necesarias para implementar los cambios requeridos para lograr la sincronización. Las modificaciones se agrupan por tipo de modificación, según se enumeran y habilitan en el cuadro de diálogo Opciones del proyecto - Generación de ECO. La entrada de cada grupo refleja el número de modificaciones de ese tipo. Cada modificación específica de esta área se describe mediante lo siguiente:
- Enable - esta opción determina si la modificación se incluirá o no cuando se ejecute la ECO. Haga clic directamente en la casilla para alternar su estado entre habilitada/incluida (marcada) y deshabilitada/excluida (desmarcada). Puede marcar y desmarcar la casilla Enable mediante la barra espaciadora.
- Action - la acción específica que se realizará. Los tipos de acciones dependen del tipo de ECO que se deba realizar.
- Affected Object - el objeto afectado por la acción.
- Affected Document - el documento en el que se realizará la acción.
Menú contextual del botón derecho
De forma predeterminada, todas las modificaciones están habilitadas para incluirse al ejecutar la ECO. Habilite o deshabilite cada entrada de modificación según sea necesario, ya sea de forma individual o mediante los siguientes comandos del menú contextual del botón derecho para cambiar el estado de habilitación de varias modificaciones:
- Validate Changes - haga clic para ejecutar una comprobación de validación de las modificaciones habilitadas para incluirse en la ECO. Los resultados de la validación aparecerán en la columna Check del área Status del cuadro de diálogo.
- Execute Changes - haga clic para ejecutar la ECO. Los resultados de la ejecución aparecerán en la columna Done del área Status del cuadro de diálogo. Recuerde que solo se ejecutarán los cambios que superen la fase de validación.
- Create Report - haga clic para generar un informe de las modificaciones contenidas en la ECO. El informe se cargará en el cuadro de diálogo Report Preview.
- Cross Probe - haga clic para realizar un sondeo cruzado de los objetos de destino y de referencia implicados en una acción de modificación en los documentos de esquema y PCB asociados.
- Expand All - haga clic para expandir la vista de todas las modificaciones de la lista.
- Contract All - haga clic para contraer la vista de todas las modificaciones de la lista.
- Enable All - utilice esta opción para habilitar todas las modificaciones.
- Disable All - utilice esta opción para deshabilitar todas las modificaciones.
- Enable Selected - utilice esta opción para habilitar todas las modificaciones seleccionadas.
- Disable Selected - utilice esta opción para deshabilitar todas las modificaciones seleccionadas.
- Enable all of same Kind - utilice esta opción para habilitar todas las modificaciones del mismo tipo que la modificación que tiene actualmente el foco.
- Disable all of same Kind - utilice esta opción para deshabilitar todas las modificaciones del mismo tipo que la modificación que tiene actualmente el foco.
- Invert Selection - utilice esta opción para seleccionar rápidamente todas las modificaciones que no estén seleccionadas en la lista y deseleccionar las que sí lo estén.
Estado
Esta área del cuadro de diálogo presenta la siguiente información de estado para cada modificación habilitada:
- Check - este campo muestra el resultado de ejecutar una comprobación de validación de la modificación. Una marca de verificación verde indica que el cambio propuesto es válido y se realizará al ejecutar la ECO. Una cruz roja indica que el cambio propuesto no es válido y no se realizará al ejecutar la ECO.
- Done - este campo muestra el resultado de la ejecución de la modificación. Una marca de verificación verde indica que la modificación válida se ejecutó correctamente.
- Message - si la modificación no supera la etapa de validación, aparecerá una entrada en este campo (y también en el panel Messages), indicando por qué ha fallado.
Controles adicionales
Los siguientes controles están disponibles en la parte inferior del cuadro de diálogo y en el menú contextual:
- Validate Changes - haga clic para ejecutar una comprobación de validación de las modificaciones habilitadas para su inclusión en la ECO. Los resultados de la validación aparecerán en la columna Check de la región Status del cuadro de diálogo.
- Execute Changes - haga clic para ejecutar la ECO y aplicar los cambios válidos que contiene. Los resultados de la ejecución aparecerán en la columna Done de la región Status del cuadro de diálogo. Recuerde que solo se ejecutarán los cambios que superen la etapa de validación.
- Report Changes - haga clic para generar un informe de las modificaciones contenidas en la ECO. El informe se cargará en el cuadro de diálogo Report Preview.
- Only Show Errors - marque esta opción para mostrar únicamente los errores de la orden de cambio de ingeniería. Los cambios validados no se mostrarán. Mostrar solo la lista de errores le permitirá revisar rápidamente su diseño y realizar los cambios necesarios para que la ECO resultante se valide por completo.
Comprender la vinculación entre el esquemático y la PCB
Emparejamiento de componentes mediante identificadores únicos
Cada componente del esquemático se vincula con su componente de PCB mediante un identificador único (UID). El UID se asigna cuando el componente del esquemático se coloca en la hoja, y este valor se transfiere al componente de PCB cuando el diseño se transfiere al editor de PCB. Cuando la información de los componentes se transfiere por primera vez entre los documentos de origen del esquemático y el documento de diseño de PCB en blanco mediante Synchronizer, todos los componentes se vinculan automáticamente mediante su ID único: la información de ID de cada componente del esquemático se asigna a la huella del componente correspondiente.
Este sistema sería adecuado para un diseño sencillo, pero no permite trabajar con un diseño multicanal. En un diseño multicanal, el mismo componente del esquemático se repite en cada canal físico, lo que implicaría que los componentes de PCB repetidos tendrían el mismo UID. Para resolverlo, el UID del componente de PCB se crea combinando el UID del símbolo de hoja superior con el UID del componente del esquemático. La sintaxis del UID de PCB varía ligeramente según cómo se haya creado el diseño multicanal.
En un diseño multicanal creado colocando varios símbolos de hoja que hacen referencia a la misma hoja de esquemático, cada símbolo de hoja puede proporcionar un ID único, por lo que el UID de PCB tiene el siguiente formato:
\SheetSymbolUID\SchComponentUID
En un diseño multicanal creado mediante la palabra clave Repeat, solo hay disponible un UID de símbolo de hoja, por lo que el UID de PCB también incluye el valor ChannelIndex, con el siguiente formato:
\ChannelIndex+SheetSymbolUID\SchComponentUID
Cuando los componentes no están vinculados
La ventaja de utilizar un UID para emparejar los componentes del esquemático y de la PCB es que permite que los designadores dejen de estar sincronizados (por ejemplo, al realizar varias reanotaciones de la PCB), sin riesgo de que el esquemático y la PCB ya no puedan sincronizarse.
Si hay un componente en el esquemático o en la PCB que no tiene un componente correspondiente (con el mismo UID) en el otro editor, ocurrirá lo siguiente:
- Si el componente adicional solo está presente en el editor de origen, se generará una ECO para añadirlo al editor de destino.
- Si el componente adicional solo está presente en el editor de destino, se generará una ECO para eliminarlo.
- Cuando hay componentes sin emparejar en ambos editores, el software necesita instrucciones sobre cómo tratarlos, por lo que se abre el cuadro de diálogo Failed to Match Unique Identifiers.
El cuadro de diálogo e Failed to Match Unique Identifiers
Los botones del cuadro de diálogo ofrecen las siguientes opciones:
- Automatically Create Component Links - haga clic en este botón si sabe que los componentes sin emparejar ya tienen designadores coincidentes. Mediante los designadores de los componentes, el software asignará UID coincidentes a estos componentes adicionales. Para los componentes que puedan emparejarse por designador, cualquier otra diferencia en sus propiedades (como parámetros que no coincidan) dará lugar a la generación de ECO. Si hay componentes que no pueden emparejarse por designador, se generarán ECO para añadirlos o eliminarlos (se añadirán los componentes adicionales presentes en el editor de origen y se eliminarán los del editor de destino).
-
Manual Component Links - haga clic en este botón si sabe que hay componentes que se corresponden, pero desconoce el estado de sus designadores. Se abrirá el cuadro de diálogo Edit Component Links (descrito a continuación), donde podrá seleccionar manualmente cada componente de origen y de destino y transferirlos a la lista de componentes emparejados, asignándoles UID coincidentes. A continuación, se generarán ECO para sincronizar los designadores (y cualquier otra propiedad de los componentes que no coincida).
- Cancel - haga clic en este botón para generar ECO que añadan los componentes adicionales presentes en el editor de origen y eliminen los componentes adicionales del editor de destino.
Vinculación manual de componentes
El estado de los vínculos entre los componentes del esquemático y sus correspondientes huellas de componentes de PCB se puede comprobar y gestionar en cualquier momento en el cuadro de diálogo Edit Component Links (editor de PCB, comando Projects » Component Links).

El cuadro de diálogo Editar vínculos de componentes se utiliza para detectar y resolver discrepancias de UID y se abre desde el editor de PCB.
Resumen de las funciones del cuadro de diálogo:
- Los componentes sin emparejar se muestran en las dos columnas Un-Matched Components de la izquierda; los componentes que comparten un UID coincidente se muestran en la región Matched Components de la derecha del cuadro de diálogo.
- Los botones de flecha situados en el centro del cuadro de diálogo se utilizan para emparejar (o desemparejar) manualmente los componentes seleccionados, o para desemparejar todos los componentes actualmente emparejados.
- El botón Add Pairs Matched By y las opciones de la parte inferior del cuadro de diálogo se utilizan para examinar la lista de componentes actualmente sin emparejar e intentar emparejarlos mediante las propiedades habilitadas (Designador, Comentario, Huella).
- Al hacer clic en el botón Perform Update, se asigna a cada componente de PCB recién emparejado el UID de su correspondiente componente del esquemático. Si ha movido alguna entrada en Matched sección del cuadro de diálogo de vuelta a las Unmatched secciones, aparecerá un cuadro de diálogo de confirmación que advertirá de que las asociaciones existentes entre componentes se romperán si continúa. Al hacer clic en Yes se realizará la actualización y aparecerá un cuadro de diálogo informativo con un resumen de los vínculos de componentes modificados en el documento PCB. Una nueva entrada en la sección Matched se resume como Link Modified, mientras que una entrada previamente vinculada cuya correspondencia haya eliminado se resume como Link Removed.
- Después de utilizar este cuadro de diálogo para vincular componentes manualmente, es recomendable comprobar el estado de sincronización (ejecute el comando Design » Update).
Establecer correspondencias entre redes y clases
Tanto las redes como las clases tienen un elemento principal (la red o la clase) y elementos secundarios (los miembros de esa red o clase). Para establecer correspondencias entre ellos se requiere un enfoque distinto del mecanismo de UID utilizado para vincular componentes, que permita gestionar cambios en el elemento principal, en los elementos secundarios o en ambos. Por ejemplo, algo tan sencillo como cambiar el nombre de una red en el esquemático no debería requerir que se eliminen de la PCB esa red y todos sus pines secundarios, que después se añada la red con el nuevo nombre y, finalmente, que se añadan todos los pines secundarios a esa nueva red.
Para permitirlo, el software incluye algoritmos de correspondencia independientes que establecen correspondencias entre redes y clases por sus miembros y también por su nombre. El proceso de correspondencia se configura en la sección Object Matching Criteria de la pestaña Comparator del cuadro de diálogo Options for Project.

La configuración predeterminada establece correspondencias primero por miembros y después por el nombre del tipo de objeto.
La correspondencia de estos tipos de objetos se gestiona de la siguiente manera:
- Durante la sincronización del diseño, el comportamiento predeterminado consiste en intentar primero establecer correspondencias por miembros, de acuerdo con la configuración de Min Match % y Min Match Member.
- Si no se logra establecer correspondencias por miembros, el software intentará hacerlo por nombre (si la opción Use Name Matching está habilitada).
- Si cualquiera de estos procesos de correspondencia tiene éxito, se pasará al cuadro de diálogo Engineering Change Order.
-
Si ambas técnicas de correspondencia fallan (o la opción Use Name Matching está configurada como
Never), se abrirá el cuadro de diálogo Match Manually.
- Al hacer clic en No en el cuadro de diálogo Match Manually, se omitirá el proceso de correspondencia manual y se pasará directamente al cuadro de diálogo Engineering Change Order. Como no ha intentado establecer correspondencias para los objetos sin correspondencia, el software supone que los objetos de referencia y de destino no están relacionados, por lo que se generarán ECO que eliminarán los Unmatched Reference Objects de la placa y añadirán los Unmatched Target Objects como objetos nuevos.
- Si hace clic en Yes en el cuadro de diálogo para establecer correspondencias manualmente, se abrirá el cuadro de diálogo Match, como se muestra a continuación (el título del cuadro de diálogo cambiará para adaptarse al tipo de objeto sin correspondencia).
El cuadro de diálogo Match se utiliza para establecer manualmente correspondencias entre objetos que sabe que se corresponden. Deje el lado derecho vacío y haga clic en Continue si no está seguro.
Opciones y controles del cuadro de diálogo de correspondencias
-
Unmatched <Object>
- Unmatched Reference Objects - muestra los objetos sin correspondencia. Utilice los controles de expansión y contracción para abrir o cerrar la lista.
- Unmatched Target Objects - muestra los objetos de destino. Utilice los controles de expansión y contracción para abrir o cerrar la lista.
-
- haga clic para establecer correspondencias entre los objetos de referencia y de destino seleccionados y mover los objetos seleccionados del área Unmatched al área Matched Pairs.
-
- haga clic para mover los objetos seleccionados del área Matched Pairs al área Unmatched. Esta acción eliminará las correspondencias de los objetos movidos.
-
- haga clic para mover todos los objetos del área Matched Pairs al área Unmatched. Esta acción eliminará las correspondencias de los objetos movidos.
- Matched Pairs - muestra los Reference Object y Target Object que ahora tienen correspondencia.
- Continue - haga clic para aceptar las actualizaciones de correspondencias y abrir el cuadro de diálogo Engineering Change Order.
- En este cuadro de diálogo, seleccione los objetos para los que desea establecer correspondencias en Unmatched Reference Objects y Unmatched Target Objects, y después transfiéralos a la sección Matched Pairs del cuadro de diálogo. Para estos objetos, el software generará una ECO para actualizar los nombres de modo que coincidan, y otras ECO para eliminar o añadir miembros de modo que también coincidan.
- Si no está seguro, no es necesario que establezca correspondencias manualmente. Para los objetos sin correspondencia, el software supone que los objetos de referencia y de destino no están relacionados, por lo que generará ECO que eliminarán los Unmatched Reference Objects de la placa y añadirán los Unmatched Target Objects como objetos nuevos.
- Una vez que haya establecido las correspondencias entre los objetos que sabe que se corresponden, haga clic en Continue para abrir el cuadro de diálogo Engineering Change Order.
- Si hace clic en Cancel, el proceso de actualización finalizará.
Establecer correspondencias entre reglas de diseño
Las reglas de diseño definidas en el esquemático también deben vincularse a la regla correspondiente en la PCB. Si no hubiera un mecanismo de vinculación, no sería posible actualizar la regla en el esquemático y transferir esos cambios a la PCB. Se utilizan UID para vincular la regla de diseño del esquemático con la regla de diseño de la PCB.
El UID se asigna automáticamente en el conjunto de parámetros que contiene la definición de la regla en el esquemático y se transfiere a la PCB durante la sincronización del diseño.
Las reglas de diseño utilizan un UID para establecer la correspondencia entre la definición de la regla de diseño del esquemático y la regla de diseño de la PCB.
Normalmente, no será necesario gestionar manualmente la correspondencia entre las reglas, a menos que haya editado manualmente el UID en el cuadro de diálogo PCB Rules and Constraints del editor de PCB. Si los UID no coinciden, el software añadirá una nueva regla a la PCB por cada regla del esquemático que no tenga una regla correspondiente en la PCB y eliminará cualquier regla de diseño de la PCB que no tenga una regla de diseño correspondiente en el esquemático.
