Búsqueda de componentes en bibliotecas basadas en bases de datos y archivos
Altium Essentials: Schematic Capture
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
De un vistazo
- Comprende las diferencias entre las bibliotecas del proyecto, las instaladas y las de las rutas de búsqueda, y cómo afecta cada una a la disponibilidad de componentes en Altium Designer.
- Aprende dónde gestionar las bibliotecas disponibles, cómo funciona el orden de búsqueda y por qué algunas opciones de configuración de las bibliotecas pueden afectar a la velocidad y la fiabilidad.
- Descubre cómo funciona la búsqueda de componentes en bibliotecas basadas en archivos y bases de datos, incluido qué puedes esperar al utilizar fuentes DbLib y SVNDbLib.
Gestión de bibliotecas disponibles basadas en bases de datos y archivos
En Altium Designer, los componentes de bibliotecas basadas en bases de datos y archivos solo se pueden colocar desde bibliotecas que estén disponibles en ese momento. Estas incluyen:
-
Libraries in the current project – si una biblioteca forma parte del proyecto, sus componentes están disponibles automáticamente para colocarlos en ese proyecto.
-
Installed libraries – estas bibliotecas se han instalado en Altium Designer; sus componentes están disponibles para su uso en cualquier proyecto abierto.
-
Libraries on a defined search path – también es posible definir una ruta de búsqueda a una carpeta con varias bibliotecas. Dado que se busca en todos los archivos de la ruta de búsqueda cada vez que se elige un componente nuevo en un panel, este método solo se recomienda para bibliotecas pequeñas con definiciones de modelos sencillas, como los modelos de simulación. Las rutas de búsqueda no se recomiendan para modelos complejos, como las huellas que incluyen modelos 3D.
Para gestionar las bibliotecas disponibles basadas en bases de datos y archivos, puede utilizar el cuadro de diálogo Libraries Preferences, al que se accede haciendo clic en el botón
situado en la parte superior del panel Components y seleccionando Libraries Preferences en el menú.
El cuadro de diálogo Libraries Preferences tiene tres pestañas. Todas las bibliotecas y ubicaciones de modelos definidas en estas pestañas se reúnen para formar la lista de bibliotecas disponibles. Cuando se realiza una acción que requiere buscar un modelo, como transferir el diseño del esquema al diseño de la PCB, se busca en las bibliotecas siguiendo el orden de las pestañas y, dentro de cada pestaña, el orden en el que aparecen las bibliotecas y los modelos. En cuanto se encuentra el modelo correcto, el proceso de búsqueda se detiene.
Bibliotecas del proyecto
Las bibliotecas que forman parte del proyecto activo se muestran en la pestaña Project del cuadro de diálogo Libraries Preferences cuando ese proyecto es el proyecto activo en el software. La ventaja de las bibliotecas del proyecto es que los modelos y las bibliotecas estarán disponibles automáticamente cada vez que se abra el proyecto. La desventaja es que, si los modelos y las bibliotecas no se almacenan en la misma estructura de carpetas del proyecto que los archivos de diseño, es fácil olvidarlos al mover los archivos del proyecto.

La pestaña Project proporciona una lista de las bibliotecas disponibles en el proyecto actual.
Bibliotecas instaladas
Las bibliotecas y los modelos que se han puesto a disposición en su instalación del software se denominan bibliotecas instaladas. Estas se muestran en la pestaña Installed del cuadro de diálogo Libraries Preferences.
Las bibliotecas instaladas se pueden enumerar mediante una ruta absoluta o una ruta relativa al ajuste Library Path Relative To. La ventaja de utilizar una ruta relativa es que permite crear un subentorno común en varios PC, lo que facilita mover los archivos de diseño entre ellos. Además, las bibliotecas instaladas se pueden desactivar temporalmente desmarcando la casilla Activated, en lugar de eliminarlas.

La pestaña Installed muestra las bibliotecas que se han puesto a disposición en esta instalación de Altium Designer.
Ruta de búsqueda
La pestaña Search Path presenta una lista de las bibliotecas que se han encontrado según los ajustes de ruta definidos en la pestaña Rutas de búsqueda del cuadro de diálogo Opciones del proyecto, al que se accede haciendo clic en el botón Paths. Cada ruta de búsqueda define una carpeta y puede incluir subcarpetas si la opción Recursive está activada (disponible en la pestaña Search Paths del cuadro de diálogo Project Options después de añadir una ruta). Todos los archivos de modelos y bibliotecas encontrados en la ruta de búsqueda estarán disponibles. Las rutas de búsqueda se guardan con el proyecto.

La pestaña Search Path muestra las bibliotecas que se han encontrado en las rutas de búsqueda definidas.
La recuperación de modelos mediante rutas de búsqueda puede ser lenta si hay un gran número de archivos en las carpetas de la ruta de búsqueda. Por este motivo, no se recomienda utilizar este método para las bibliotecas de PCB, ya que pueden ser archivos grandes que contienen muchas huellas. Esta función se desarrolló para proporcionar una forma de referenciar los modelos de simulación e integridad de señal disponibles.
Exploración de los componentes de la base de datos
Una vez que se haya añadido el archivo DbLib/SVNDbLib a la lista de bibliotecas disponibles basadas en archivos, los componentes de la base de datos estarán disponibles para su exploración en el panel Components. Aunque solo se añade un único archivo DbLib/SVNDbLib, cada tabla de la base de datos vinculada se mostrará como si fuera una biblioteca independiente.
La lista desplegable superior del panel se rellenará con entradas con el formato:
- <LibraryName>.DbLib - <TableName> o <LibraryName>.SVNDbLib - <TableName> ----si su base de datos contiene tablas
- <LibraryName>.DbLib - <SheetName>$ o <LibraryName>.SVNDbLib - <SheetName>$ ----donde la base de datos está formada por hojas de un archivo de Excel.
Ejemplo de una DbLib cargada con tres tablas, otra con una tabla y una SVNDbLib con una tabla.
Cada entrada de componente del panel corresponde a un registro de esa tabla concreta de la base de datos. De hecho, al explorar las bibliotecas de bases de datos cargadas, el panel Components se comporta como un explorador directo de bases de datos. La información de símbolos y modelos se obtiene de las bibliotecas de símbolos y modelos subyacentes a las que apuntan los campos correspondientes de la base de datos (junto con las rutas y ubicaciones de búsqueda definidas).
Exploración de componentes en una base de datos externa vinculada mediante una biblioteca de base de datos.
De forma predeterminada, solo se muestran los campos Part Number y Library Ref en la región de listado de componentes del panel. Para mostrar otros campos de la tabla de la base de datos, haga clic con el botón derecho en la región y seleccione Select Columns en el menú contextual. Esto le dará acceso al cuadro de diálogo Seleccionar columnas, en el que podrá habilitar la visualización de cualquiera de los campos adicionales de esa tabla.
Almacenamiento en caché local de símbolos y modelos utilizados por las bibliotecas de bases de datos SVN
Cuando se añade un archivo SVNDbLib a la lista de bibliotecas disponibles, las bibliotecas de símbolos y modelos del repositorio se almacenan en caché en una carpeta temporal local del equipo del diseñador. Cuando una acción del software requiere el uso de un símbolo esquemático o un modelo, dicho símbolo o modelo se recupera de la caché local.
Actualización automática de la caché
Las bibliotecas de la caché se actualizarán automáticamente con las versiones más recientes del repositorio de control de versiones al realizar cualquiera de las siguientes acciones en el software:
-
Colocar un componente desde un archivo SVNDbLib instalado (desde el panel Componentes).
-
Realizar una transferencia del diseño (es decir, actualizar la PCB).
-
Utilizar el comando Tools » Update From Libraries en el editor de esquemas.
-
Utilizar el comando Tools » Update From PCB Libraries en el editor de PCB.
Aunque la actualización es automática, se puede controlar mediante la opción Do not check files more often than xx minutes de la página Gestión de datos - Bibliotecas SVN del Preferences cuadro de diálogo. Esta opción proporciona, en esencia, un «temporizador de actualización» para la caché local. Si ha transcurrido el tiempo especificado desde la última actualización de la caché, esta se actualizará automáticamente cuando se realice una de las acciones enumeradas. Si se realiza una acción dentro de este intervalo, se utilizará el contenido actual de la caché, que puede estar desactualizado con respecto al contenido del repositorio.
Forzar manualmente una actualización de la caché
En ocasiones, puede que desee forzar una actualización de la caché local para asegurarse de disponer de las bibliotecas más recientes almacenadas en el repositorio de control de versiones. Por ejemplo, al prepararse para transferir el diseño del esquema a la PCB.
Puede forzar una actualización manual de la caché mediante uno de los siguientes métodos:
- Utilizar uno de los Refresh comandos disponibles en el menú contextual del panel Componentes.
- Desinstalar y volver a instalar el archivo SVNDbLib en la lista de bibliotecas disponibles.
Búsqueda de componentes en bibliotecas de bases de datos y basadas en archivos
Para facilitar la búsqueda de componentes en bibliotecas basadas en archivos (tanto instaladas como no instaladas actualmente) y de bases de datos, Altium Designer incluye una función de búsqueda en bibliotecas.
Es posible buscar un componente en bibliotecas de bases de datos y basadas en archivos mediante el campo Search del panel Components. Introduzca una cadena de texto y pulse Enter para buscarla en la biblioteca actual, en cualquier parte de los parámetros visibles de los componentes.
Puede realizar una búsqueda directamente en el panel Components.
El cuadro de diálogo File-based Libraries Search permite realizar búsquedas más detalladas. Para acceder a él, haga clic en el botón
del panel Components y seleccione File-based Libraries Search en el menú. La mitad superior del cuadro de diálogo se utiliza para definir what se busca; la mitad inferior se utiliza para definir where buscar.
Busque en las bibliotecas instaladas (Available libraries) o en las bibliotecas del disco duro (Libraries on path).El proceso de búsqueda se puede resumir de la siguiente manera:
-
La búsqueda se realiza definiendo Filters que se aplican a todas las bibliotecas en las que se puede buscar según la configuración actual de Scope de búsqueda.
-
El Scope incluye el tipo de bibliotecas en las que se buscará. Solo se puede buscar en un tipo a la vez.
-
Para habilitar la búsqueda de componentes de bases de datos, establezca el campo Search in en Database Components y seleccione la Table deseada. Tenga en cuenta que los Fields disponibles en la lista desplegable anterior cambiarán para reflejar los encabezados de columna disponibles en la tabla seleccionada. Las demás opciones del cuadro de diálogo se deshabilitan, ya que no son pertinentes para la búsqueda en bibliotecas de bases de datos.
-
El Scope define en qué bibliotecas se buscará: las bibliotecas a las que el software tiene acceso actualmente (Available libraries) o todas las bibliotecas de una carpeta (Libraries on path).
-
Al buscar bibliotecas en una ruta, el destino es una carpeta específica y también se puede Include Subdirectories.
-
También puede buscar dentro de los resultados de búsqueda estableciendo el Scope en Refine last search.
-
Haga clic en Clear para borrar los parámetros de búsqueda introducidos.
Configuración del filtro de búsqueda
La región Filters se utiliza para definir las cadenas de texto que se aplicarán a la búsqueda. Hay tres regiones que configurar:
-
Field – este es el atributo del componente en el que se buscará. Puede ser cualquier atributo del componente o de la huella, incluidos el nombre, la descripción, el comentario, la huella o cualquier parámetro que se haya añadido a un componente. Seleccione un campo disponible en la lista desplegable o introduzca un campo en el cuadro de texto.
-
Operator – define cómo se determina una coincidencia. Puede ser cuando el valor equals, contains, starts with o ends with. Tenga en cuenta que equals requiere una coincidencia exacta de la cadena, por lo que solo debe utilizarse cuando tenga la certeza de que la cadena de búsqueda es correcta y está completa.
-
Value – los caracteres que se buscarán en el Field seleccionado, cuya coincidencia se determinará según el Operator elegido. Seleccione un valor disponible en la lista desplegable o introduzca un valor en el campo de texto.
De forma predeterminada, hay tres condiciones de filtro; puede añadir hasta siete filas adicionales para un total de 10 filas mediante el Add Row control. La última fila de condiciones de filtro añadida se puede eliminar mediante el Remove Row. Puede eliminar las filas que no se utilicen.
Configuración del ámbito
Existen, básicamente, dos formas de buscar:
-
Bibliotecas disponibles actualmente: esta es la lista de bibliotecas que se muestra en el desplegable de la parte superior del panel Components .
-
Bibliotecas almacenadas en una carpeta específica, incluidos los subdirectorios si la opción está habilitada.
La búsqueda devolverá todos los elementos del tipo de búsqueda elegido en la lista desplegable Search in (Components/Footprints/3D Models/Database Components) que se encuentren en todas las bibliotecas comprendidas en el Scope definido:
- Available libraries - habilite esta opción para buscar los tipos de modelos especificados solo en las bibliotecas disponibles.
-
Libraries on path - habilite esta opción para buscar los tipos de modelos especificados en las bibliotecas disponibles en las carpetas especificadas. En la sección Path del cuadro de diálogo, que pasa a estar disponible al seleccionar la opción de ámbito Libraries on path, puede definir la ruta, incluir subdirectorios e incluir la máscara de archivos de biblioteca para especificar y acotar los criterios de búsqueda:
- Path - edite este campo para definir la carpeta en la que se buscarán las bibliotecas o haga clic en el icono de exploración al final del campo para buscar una carpeta.
- Include Subdirectories - habilite esta opción si desea buscar bibliotecas en la ruta especificada y en sus subrutas.
-
File Mask - introduzca la cadena de máscara de archivos o elija una de las máscaras de archivos existentes en la lista desplegable. La búsqueda se filtra para mostrar los archivos que coincidan con la cadena. Puede utilizar el comodín * (cualquier carácter) en la cadena. Por ejemplo, escriba * para buscar todos los archivos y escriba M para buscar todos los archivos que comiencen por la letra M.
Por ejemplo, si desea encontrar un componente que cree que está en una biblioteca dentro de unas carpetas específicas del disco duro y esa biblioteca no aparece actualmente en Available File-based Libraries, defina la búsqueda de la siguiente manera:
- En la sección Scope, establezca Search in en Components y seleccione Libraries on path.
- En la sección Path, configure Path para que apunte a la carpeta que contiene el documento de biblioteca en el que desea buscar.
- Haga clic en Search. Los resultados se muestran en el panel Components a medida que se realiza la búsqueda.
Modo de búsqueda avanzada
La búsqueda en bibliotecas se realiza mediante consultas. En el cuadro de diálogo File-based Libraries Search, cambie al modo Advanced para examinar la consulta.
En el modo Advanced del cuadro de diálogo, también puede crear sus propias consultas utilizando las palabras clave del lenguaje de consultas para realizar una búsqueda basada en consultas. Consulte la sección siguiente para obtener más información sobre las palabras clave disponibles del lenguaje de consultas.
Utilice los siguientes controles adicionales cuando esté seleccionado el modo Advanced:
-
Helper - haga clic para abrir el cuadro de diálogo Asistente de consultas y crear fácilmente una consulta de búsqueda en bibliotecas con funciones de biblioteca y de sistema predefinidas. También puede utilizar los botones History y Favorites para elegir una consulta de biblioteca aplicada recientemente o predefinida.
-
History - haga clic para abrir el cuadro de diálogo Administrador de expresiones y elegir una de las expresiones de consulta aplicadas anteriormente para utilizarla en la búsqueda en bibliotecas. También puede utilizar el botón Favorites para usar una consulta predefinida en una búsqueda específica en bibliotecas.
-
Favorites - haga clic para abrir el cuadro de diálogo Administrador de expresiones y elegir una de sus expresiones de consulta favoritas para utilizarla en una búsqueda en bibliotecas. También puede modificar la lista Favorites eliminando, renombrando o copiando expresiones de la lista History.
Al buscar en Database Components, el modo Advanced le permitirá realizar una búsqueda mediante una consulta SQL. Este nivel de búsqueda ofrece una búsqueda precisa basada en una expresión de consulta especificada, y permite introducir una consulta SQL directamente en la sección del editor de consultas del cuadro de diálogo.
Haga clic en Advanced para acceder a una potente búsqueda basada en consultas SQL. Haga clic de nuevo en Advanced para volver a la búsqueda simple.
Funciones de consulta de componentes y bibliotecas

Funciones de consulta de componentes y bibliotecas en el cuadro de diálogo Query Helper
Los editores de esquemas y PCB de Altium Designer cuentan con un potente motor de consultas. Al introducir consultas en este motor, puede delimitar con precisión y de forma lógica los objetos que necesita.
Una consulta es una cadena que se introduce utilizando palabras clave y una sintaxis específicas, y que devuelve los objetos buscados. Hay muchas palabras clave disponibles que permiten seleccionar objetos por su tipo, sus propiedades o ambos.
Las secciones siguientes detallan las palabras clave del lenguaje de consultas disponibles al buscar componentes basados en bases de datos y archivos en Altium Designer. Para obtener ayuda sobre una palabra clave de consulta específica, utilice las siguientes secciones desplegables o seleccione cualquier palabra clave (o haga clic dentro de ella) en Query Helper.
Componentes
Comentario
Resumen
Devuelve todos los componentes cuyo Comment cumple la consulta.
Sintaxis
Comment : String
Ejemplo de uso
Comment = 'Res1'
Devuelve todos los componentes cuyo Comment es Res1.
Comment = '100nF'
Devuelve todos los componentes cuyo Comment es 100nF.
Comment Like '*33*'
Devuelve todos los componentes cuyo Comment contiene 33.
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib e IntLib disponibles o situadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
Tipo de componente
Resumen
Devuelve todos los componentes cuya propiedad Component Type cumple la consulta.
Sintaxis
ComponentType = ComponentType_String
ComponentType_String debe ser una de las cadenas de la siguiente lista:
- 'Gráfico'
- 'Puente'
- 'Mecánico'
- 'Unión de redes'
- 'Unión de redes (en la BOM)'
- 'Estándar'
- 'Estándar (sin BOM)'
Ejemplo de uso
ComponentType = 'Graphical'
Devuelve todos los componentes cuyo Component Type es Graphical.
ComponentType = 'Standard'
Devuelve todos los componentes cuyo Component Type es Standard.
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib e IntLib disponibles o ubicadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results, en el panel Componentes.
-
Los caracteres de comilla simple (') al principio y al final de
ComponentType_Stringson obligatorios.
Designador
Resumen
Devuelve todos los componentes cuya propiedad Designator cumple la consulta.
Sintaxis
Designator : String
Ejemplos de uso
Designator = 'U2'
Devuelve todos los componentes cuya propiedad Designator es U2.
Designator Like '*Channel*'
Devuelve todos los componentes cuya propiedad Designator incluye Channel.
Designator <> 'C*'
Devuelve todos los componentes except aquellos cuya propiedad Designator comienza por C.
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib e IntLib disponibles o ubicadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
HasModel
Resumen
Devuelve cada componente vinculado a un modelo de dominio (o que hace referencia a él) cuyas propiedades cumplen la consulta.
Sintaxis
HasModel(ModelType : String,ModelName : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
La cadena ModelType especifica la propiedad Type de un modelo vinculado y debe ser una de las cadenas de la siguiente lista:
- 'PCB3DLIB' - utilice esta cadena para buscar un modelo vinculado cuya propiedad Type sea PCB3D.
- 'PCBLIB' - utilice esta cadena para buscar un modelo vinculado cuya propiedad Type sea Footprint.
- 'IBIS' - utilice esta cadena para buscar un modelo vinculado cuya propiedad Type sea Ibis Model.
- 'SI' - utilice esta cadena para buscar un modelo vinculado cuya propiedad Type sea Signal Integrity.
- 'SIM' - utilice esta cadena para buscar un modelo vinculado cuya propiedad Type sea Simulation.
La cadena ModelName especifica la propiedad Name de un modelo vinculado.
El parámetro CurrentModelOnly especifica si el modelo vinculado debe ser o no un modelo actual de cada componente. Cuando es False, no es necesario que el modelo vinculado sea un modelo actual (aunque puede serlo); cuando es True, el modelo vinculado debe ser un modelo actual.
Ejemplos de uso
HasModel('PCBLIB','SOIC14',False)
HasModel('PCBLIB','SOIC14',False) = True
HasModel('PCBLIB','SOIC14',False) = 'True'
Devuelve todos los componentes vinculados a un modelo de huella cuya propiedad Name es SOIC14; no es necesario que ese modelo sea el modelo de huella actual de cada componente (aunque puede serlo).
HasModel('PCBLIB','DIP14',True)
HasModel('PCBLIB','DIP14',True) = True
HasModel('PCBLIB','DIP14',True) = 'True'
Devuelve todos los componentes vinculados a un modelo de huella cuya propiedad Name es DIP14; ese modelo debe ser el modelo de huella actual del componente.
HasModel('SI','RES1',False)
HasModel('SI','RES1',False) = True
HasModel('SI','RES1',False) = 'True'
Devuelve todos los componentes vinculados a un modelo de integridad de señal cuya propiedad Name es RES1; no es necesario que ese modelo sea el modelo de integridad de señal actual de cada componente (aunque puede serlo).
HasModel('SIM','RESISTOR',True)
HasModel('SIM','RESISTOR',True) = True
HasModel('SIM','RESISTOR',True) = 'True'
Devuelve todos los componentes vinculados a un modelo de simulación cuya propiedad Name es RESISTOR; ese modelo debe ser el modelo de simulación actual del componente.
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib e IntLib disponibles o ubicadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
HasModelParameter
Resumen
Devuelve cada componente vinculado a un modelo de dominio (o que hace referencia a él) que contiene un objeto de parámetro cuyas propiedades Parameter Name y Value cumplen la consulta.
Sintaxis
HasModelParameter(Parameter Name : String,Value : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
El parámetro CurrentModelOnly especifica si el modelo vinculado (que contiene un parámetro que cumple la consulta) debe ser o no un modelo actual de cada componente. Cuando es False, no es necesario que el modelo vinculado sea un modelo actual (aunque puede serlo); cuando es True, el modelo vinculado debe ser un modelo actual.
Ejemplos de uso
HasModelParameter('Inductance A','1mH',False)
HasModelParameter('Inductance A','1mH',False) = True
HasModelParameter('Inductance A','1mH',False) = 'True'
Devuelve todos los componentes vinculados a un modelo que contiene un objeto de parámetro cuya propiedad Parameter Name es Inductance A y cuya propiedad Value es 1mH. No es necesario que ese modelo sea un modelo actual de cada componente (aunque puede serlo).
HasModelParameter('Coupling Factor','0.999',True)
HasModelParameter('Coupling Factor','0.999',True) = True
HasModelParameter('Coupling Factor','0.999',True) = 'True'
Devuelve todos los componentes vinculados a un modelo que contiene un objeto de parámetro cuya propiedad Parameter Name es Coupling Factor y cuya propiedad Value es 0.999. Ese modelo debe ser un modelo actual del componente.
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib e IntLib disponibles o ubicadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
LibReference
Resumen
Devuelve todos los componentes cuya propiedad Library Reference cumple la consulta.
Sintaxis
LibReference : String
Ejemplos de uso
LibReference = 'LM833'
Devuelve todos los componentes cuya propiedad Library Reference es LM833.
LibReference Like 'C*'
Devuelve todos los componentes cuya propiedad Library Reference comienza por C.
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib e IntLib disponibles o ubicadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
Número de partes
Resumen
Devuelve todos los componentes cuya propiedad Part Count cumple con la consulta.
Sintaxis
PartCount : Number
Ejemplos de uso
PartCount = 2
Devuelve todos los componentes cuyo Part Count es 2.
PartCount > 4
Devuelve todos los componentes cuyo Part Count es mayor que 4 (es decir, todos los componentes multiparte que contienen más de cuatro subpartes).
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib e IntLib disponibles o ubicadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
Número de pines
Resumen
Devuelve todos los componentes cuya propiedad Pin Count cumple con la consulta.
Sintaxis
PinCount : Number
Ejemplos de uso
PinCount = 2
Devuelve todos los componentes cuyo Pin Count es 2.
PinCount > 14
Devuelve todos los componentes cuyo Pin Count es mayor que 14.
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib e IntLib disponibles o ubicadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
Todos
Descripción
Resumen
Devuelve todos los componentes o huellas cuya propiedad Description cumple con la consulta.
Sintaxis
Description : String
Ejemplos de uso
Description = 'TTL-RS232 DRIVER'
Devuelve todos los componentes o huellas cuya propiedad Description es TTL-RS232 DRIVER.
Description Like '*RS485*'
Devuelve todos los componentes o huellas cuya propiedad Description incluye RS485.
Notas
-
Las entidades devueltas, componentes o huellas, dependen del ámbito seleccionado, definido mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
Tiene parámetro
Resumen
Devuelve todos los componentes que contienen un objeto de parámetro cuyas propiedades Parameter Name y Value cumplen con la consulta.
Sintaxis
HasParameter(Parameter Name : String,Value : String) : Boolean/Boolean_String
Ejemplos de uso
HasParameter('Comment','1K')
HasParameter('Comment','1K') = True
HasParameter('Comment','1K') = 'True'
Devuelve todos los componentes que contienen un objeto de parámetro cuya propiedad Parameter Name es Comment y cuya propiedad Value es 1K.
Notas
-
Las entidades devueltas, componentes o huellas, dependen del ámbito seleccionado, definido mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
Nombre de biblioteca
Resumen
Devuelve todos los componentes o huellas cuyo nombre de biblioteca de origen cumple con la consulta.
Sintaxis
LibraryName : String
Ejemplos de uso
LibraryName = 'Miscellaneous Devices.SchLib'
Devuelve todos los componentes cuya biblioteca de origen es Miscellaneous Devices.SchLib.
LibraryName Like 'Miscellaneous*.IntLib'
Devuelve todos los componentes o huellas cuyo nombre de biblioteca de origen comienza por Miscellaneous y termina en .IntLib.
LibraryName Like '*Vishay*'
Devuelve todos los componentes cuyo nombre de biblioteca de origen contiene Vishay.
Notas
-
Las entidades devueltas, componentes o huellas, dependen del ámbito seleccionado, definido mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib, IntLib y DbLib disponibles o ubicadas en una ruta de búsqueda definida. Al buscar huellas, se consultarán todas las bibliotecas PcbLib e IntLib.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
Ruta de biblioteca
Resumen
Devuelve todos los componentes o huellas que se encuentran en la biblioteca especificada como parte de la consulta.
Sintaxis
LibraryPath : String
Ejemplos de uso
LibraryPath = 'C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Devuelve todos los componentes cuya biblioteca de origen es MyExampleLibrary.SchLib y cuya biblioteca se encuentra en la carpeta C:\Documents\Altium\Library.
LibraryPath Like ' C:\Documents\Altium\Library\Miscellaneous*.IntLib'
Devuelve todos los componentes o huellas cuyo nombre de biblioteca de origen comienza por Miscellaneous y termina en .IntLib, y cuya biblioteca se encuentra en la carpeta C:\Documents\Altium\Library.
LibraryPath = 'C:\Test Projects\Example DBLib\VishayCapacitor.DBLib'
Devuelve todos los componentes cuya biblioteca de origen es VishayCapacitor.DBLib y cuya biblioteca se encuentra en la carpeta C:\Test Projects\Example DBLib.
Notas
-
Las entidades devueltas, componentes o huellas, dependen del ámbito seleccionado, definido mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib, IntLib y DbLib disponibles en la ruta de bibliotecas definida. Al buscar huellas, se consultarán todas las bibliotecas PcbLib e IntLib.
-
Todos los resultados se muestran en la lista Query Results del panel Componentes.
Nombre
Resumen
Devuelve todos los componentes o huellas cuyo nombre cumple con la consulta.
Sintaxis
Name : String
Ejemplos de uso
Name = 'Res1'
Devuelve todos los componentes o huellas cuyo nombre es Res1.
Name Like 'DIP*'
Devuelve todos los componentes o huellas cuyo nombre comienza por DIP.
Name Like '*33*'
Devuelve todos los componentes o huellas cuyo nombre contiene 33.
Notas
-
Las entidades devueltas, componentes o huellas, dependen del ámbito seleccionado, definido mediante el campo Search in del cuadro de diálogo Búsqueda en bibliotecas de archivos.
-
Al buscar componentes, se consultarán todas las bibliotecas SchLib e IntLib disponibles o ubicadas en una ruta de búsqueda definida. Al buscar huellas, se consultarán todas las bibliotecas PcbLib e IntLib.
-
Todos los resultados se muestran en la lista Query Results, de vuelta en el panel Componentes.
-
El nombre de un componente de esquema se comprueba con respecto a su propiedad Design Item ID, y el nombre de una huella de PCB se comprueba con respecto a su propiedad Footprint .
Nombre de biblioteca fuente
Resumen
Devuelve todos los componentes o huellas cuyo nombre de biblioteca fuente de origen cumple con la consulta.
Sintaxis
SourceLibraryName : String
Ejemplos de uso
SourceLibraryName = 'Miscellaneous Devices.SchLib'
Devuelve todos los componentes cuya biblioteca fuente de origen es Miscellaneous Devices.SchLib.
SourceLibraryName = 'Miscellaneous Devices.PcbLib '
Devuelve todas las huellas cuya biblioteca de origen es Miscellaneous Devices.PcbLib.
Notas
-
Las entidades devueltas, componentes o huellas, dependen del ámbito elegido, definido mediante el campo Search in del cuadro de diálogo File Libraries Search.
-
Al buscar componentes, solo se consultarán las bibliotecas de esquemas de origen disponibles o situadas en una ruta de búsqueda definida. Al buscar huellas, solo se consultarán las bibliotecas de PCB.
-
Todos los resultados se muestran en la lista Query Results del panel Components.
Ruta de la biblioteca de origen
Resumen
Devuelve todos los componentes o huellas que se encuentran en la biblioteca de origen especificada como parte de la consulta.
Sintaxis
SourceLibraryPath : String
Ejemplos de uso
SourceLibraryPath = ' C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Devuelve todos los componentes cuya biblioteca de origen es MyExampleLibrary.SchLib y cuya biblioteca se encuentra en la carpeta C:\Documents\Altium\Library.
SourceLibraryPath = ' C:\Documents\Altium\Library\Miscellaneous Devices.PcbLib'
Devuelve todas las huellas cuya biblioteca de origen es Miscellaneous Devices.PcbLib y cuya biblioteca se encuentra en la carpeta C:\Documents\Altium\Library.
SourceLibraryPath Like ' C:\Documents\Altium\Library\*'
Devuelve todos los componentes o huellas cuya biblioteca de origen se encuentra en la carpeta C:\Documents\Altium\Library.
Notas
-
Las entidades devueltas, componentes o huellas, dependen del ámbito elegido, definido mediante el campo Search in del cuadro de diálogo File Libraries Search.
-
Al buscar componentes, solo se consultarán las bibliotecas de esquemas disponibles en la ruta de bibliotecas definida. Al buscar huellas, solo se consultarán las bibliotecas de PCB.
-
Todos los resultados se muestran en la lista Query Results del panel Components.
Huellas
Altura
Resumen
Devuelve todas las huellas cuya propiedad Height cumple la consulta.
Sintaxis
Height : Number
Number utilizará las unidades de medida empleadas actualmente en la biblioteca: imperiales (mil; 1 mil = 0,001 pulgadas) o métricas (mm; 1 mm = 0,001 metros).
Ejemplos de uso
Height = 300
Devuelve todas las huellas cuya propiedad Height es igual a 300 unidades de medida actuales.
Height >= 5.08
Devuelve todas las huellas cuya propiedad Height es mayor o igual que 5.08 unidades de medida actuales.
Height <> 550
Devuelve todas las huellas cuya propiedad Height es not igual a 550 unidades de medida actuales.
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo File Libraries Search.
-
Al buscar huellas, se consultarán todas las bibliotecas PcbLib e IntLib disponibles o situadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results del panel Components.
Número de pads
Resumen
Devuelve todas las huellas cuya propiedad Pad Count cumple la consulta.
Sintaxis
PadCount : Number
Ejemplos de uso
PadCount = 2
Devuelve todas las huellas cuyo Pad Count es 2.
PadCount > 14
Devuelve todas las huellas cuyo Pad Count es mayor que 14.
Notas
-
Asegúrese de que el ámbito de búsqueda esté establecido en Components mediante el campo Search in del cuadro de diálogo File Libraries Search.
-
Al buscar huellas, se consultarán todas las bibliotecas PcbLib e IntLib disponibles o situadas en una ruta de búsqueda definida.
-
Todos los resultados se muestran en la lista Query Results del panel Components.