Tworzenie i zarządzanie procesami

Altium Designer zapewnia zaawansowane środowisko projektowe do współpracy. Częścią tego środowiska jest obsługa Workflows, które prowadzą projektantów w firmie przez typowe, codzienne procesy projektowe, takie jak:

  • Wnioskowanie o nowe komponenty biblioteczne Workspace
  • Przeprowadzanie przeglądów projektu
  • Tworzenie nowych projektów Workspace.

Każdy Workflow używany do realizacji określonego procesu projektowego jest tworzony jako część Process Definition. Dlatego można go określać jako bazowy Workflow danego procesu lub po prostu jako Process Workflow.

Procesy oraz ich Workflow są tworzone i zarządzane za pośrednictwem interfejsu przeglądarkowego Workspace Enterprise Server — przez Administratora tego Workspace.

Dla trzech obszarów projektowych wymienionych wcześniej wraz z instalacją serwera dostarczane są predefiniowane workflow procesów. Niektóre z nich są aktywowane do użycia od razu po instalacji. Możesz z nich korzystać, modyfikować je lub tworzyć własne, zależnie od potrzeb swojej firmy. Inne są przykładami — nie można ich aktywować i używać w niezmienionej postaci. Każdy z nich jest więc bardziej „szablonem” — należy go edytować zgodnie z wymaganiami firmy, nadać nazwę i zapisać jako nową definicję procesu, którą can następnie aktywujesz i wykorzystasz wraz z pozostałymi definicjami.

Zaawansowany Process Workflow Editor zapewnia elastyczność potrzebną do budowania procesów z workflow tak prostymi lub tak złożonymi, jak to konieczne, zgodnie z wymaganiami Twojej firmy.

Dostęp do procesów

Całe zarządzanie procesami odbywa się w obszarze Processes (Admin – Processes) interfejsu przeglądarkowego Workspace Enterprise Server.

Aby zobaczyć obszar Processes interfejsu, musisz być zalogowany jako Administrator swojego Workspace Enterprise Server.

Dostęp do obszaru Processes interfejsu przeglądarkowego Workspace Enterprise Server — centralnego miejsca do pracy z procesami i powiązanymi z nimi workflow.Dostęp do obszaru Processes interfejsu przeglądarkowego Workspace Enterprise Server — centralnego miejsca do pracy z procesami i powiązanymi z nimi workflow.

Interfejs Processes jest przedstawiony na następujących czterech kartach:

  • Browser — zawiera zbiorcze zestawienie wszystkich procesów (aktywnych lub zamkniętych). Jest to centralny „panel procesów”.
  • Part Requests — udostępnia dedykowany obszar do zarządzania procesami związanymi z tematyką wnioskowania o komponenty.
  • Project Activities — udostępnia dedykowany obszar do zarządzania procesami związanymi z tematyką pracy z projektami Workspace, takimi jak przeglądy projektu i publikowanie do systemu PLM.
  • Project Creations — udostępnia dedykowany obszar do zarządzania procesami związanymi z tematyką tworzenia nowych projektów projektowych Workspace.
Ostatnie trzy karty można określać jako Process Themes. Tematy procesów umożliwiają intuicyjne grupowanie różnych procesów według obszaru projektowego. Pozwalają też oprogramowaniu wspierać tworzenie nowych procesów poprzez udostępnianie tylko tych elementów workflow, które są potrzebne dla danego obszaru, a tym samym usprawniają budowę wymaganego workflow. W przyszłości takie podejście stanowi dla Altium podstawę do rozszerzania interfejsu przez dodawanie kolejnych tematów, w miarę potrzeb.

W kolejnych sekcjach omówiono te różne karty bardziej szczegółowo.

Karta Browser

Użyj tej karty, aby centralnie przeglądać wszystkie aktywne lub zamknięte procesy we wszystkich tematach procesów. Domyślnie karta pokazuje wszystkie Active (uruchomione) procesy. Przełącz widok na wszystkie procesy Closed (np. zakończone, odrzucone lub przerwane), korzystając z listy rozwijanej nad listą.

Przeglądaj wszystkie aktywne procesy z jednego wygodnego miejsca. Najedź kursorem na obraz, aby zobaczyć przykład przeglądania wszystkich zamkniętych procesów.
Przeglądaj wszystkie aktywne procesy z jednego wygodnego miejsca. Najedź kursorem na obraz, aby zobaczyć przykład przeglądania wszystkich zamkniętych procesów.

Dla każdego wpisu prezentowane są następujące informacje (tam, gdzie ma to zastosowanie):

  • Status — stan procesu. Może to być jeden z następujących stanów:
    • Active — proces jest obecnie aktywny, a powiązany z nim workflow jest realizowany.
    • On hold — proces jest obecnie aktywny, ale oczekuje na początkowe dane wejściowe, takie jak przypisanie wykonawcy, zanim jego workflow będzie mógł być kontynuowany.
    • Closed — proces jest już zamknięty, na przykład został pomyślnie zakończony albo odrzucony.
    • Terminated — proces jest już zamknięty i został zakończony bezpośrednio przez Administratora Workspace.
  • Process Name — nazwa definicji procesu.
  • Title — to pole służy do rozróżniania wielu instancji tego samego procesu. Tytuł to nazwa procesu z przyrostkiem instancji (#1, #2 itd.).
  • State — jest to stan aktualnie osiągnięty w workflow powiązanym z procesem.
  • Assignee (Tylko aktywny proces) — użytkownik, który ma teraz do wykonania zadanie, aby przesunąć proces dalej z jego bieżącego stanu workflow.
  • Started By — użytkownik, który zainicjował proces.
  • Started At — data i godzina rozpoczęcia procesu.
  • Ended At (Tylko zamknięty proces) — data i godzina zamknięcia procesu.

Dla aktywnego procesu dostępna jest także kontrolka Terminate (). Kliknij ją, aby wymusić zakończenie procesu. Proces zostanie przeniesiony do listy procesów Closed.

Procesy można sortować według dowolnej kolumny zawierającej kontrolkę — kliknij kontrolkę lub nazwę kolumny. Można również przeprowadzać wyszukiwanie za pomocą pola Search u góry listy. Do wyszukiwania można używać danych we wszystkich polach z wyjątkiem Status, Started At, Ended At i Terminate.
  • Możesz również zaimportować wcześniej wyeksportowaną definicję procesu z pliku bezpośrednio z poziomu karty Browser . Aby to zrobić, kliknij przycisk . W wyświetlonym oknie dialogowym Open wskaż i otwórz wymagany plik Workflow (*.aaw). Zostanie wykryty właściwy temat procesu, a zawartość pliku zostanie załadowana do Process Workflow Editor. Więcej informacji znajdziesz w sekcji Importowanie/eksportowanie definicji procesu.
  • Użyj przycisku , aby wyeksportować raport aktualnie wyświetlanych działań (Process Workflows) jako szczegółowy plik *.csv rozdzielany przecinkami — zobacz przykład. Można eksportować działania Active lub Closed, a wpisy, które mają zostać uwzględnione, można filtrować za pomocą pola Search nazwy procesu. Po stronie projektowej panel Explorer panel w Altium Designer zawiera równoważny przycisk — na karcie Activites podczas przeglądania projektu (przy użyciu domyślnego widoku Project ) — do pobierania aktualnie wyświetlanych danych działań związanych z tym projektem.

Kliknij wpis procesu, aby wyświetlić diagram jego bazowego workflow (na karcie Diagram pod listą), pokazujący, co musi się wydarzyć, aby proces został ukończony, oraz na jakim etapie przebiegu proces obecnie się znajduje, w tym kto ma teraz zadanie do wykonania, aby przesunąć proces dalej.

Kliknij kontrolkę w prawym dolnym rogu, aby podświetlić aktualnie osiągnięty punkt w workflow — wpis użytkownika(ów) zacznie na chwilę migać.

Wyświetlanie bazowego workflow dla wybranego procesu na jego karcie Diagram. Każdy workflow jest budowany diagramowo, co pozwala jednym rzutem oka zobaczyć, w którym miejscu workflow aktualnie znajduje się proces oraz kto ma następne zadanie potrzebne do kontynuowania tego procesu.Wyświetlanie bazowego workflow dla wybranego procesu na jego karcie Diagram. Każdy workflow jest budowany diagramowo, co pozwala jednym rzutem oka zobaczyć, w którym miejscu workflow aktualnie znajduje się proces oraz kto ma następne zadanie potrzebne do kontynuowania tego procesu.

Dostępne są również następujące dodatkowe karty:

  • Data — pokazuje wszystkie istotne dane procesu. Na przykład dla procesu przeglądu projektu mogą to być projekt i jego zestaw danych, typ przeglądu, osoby biorące udział w przeglądzie oraz wszelkie dodatkowe załączniki. W przypadku procesu wniosku o komponent mogą to być dołączone noty katalogowe, dane parametryczne oraz wszelkie komponenty wstępne.

    Odpowiednie obiekty, takie jak załączniki, noty katalogowe, projekt oraz zestaw danych projektu (Item-Revision), będą widoczne jako hiperłącza umożliwiające szybkie przejście do nich lub ich otwarcie. Masz także możliwość skonfigurowania danych parametrycznych widocznych dla standardowego użytkownika na tej karcie. Podczas edycji workflow procesu, gdy żaden element nie jest zaznaczony, dane, które mogą być prezentowane na karcie Data , są wymienione w panelu po prawej stronie. Kliknij kontrolkę Edit , aby uzyskać dostęp do powiązanego formularza (<ProcessName> Data).
  • History — pokazuje historię działań wykonanych wzdłuż workflow procesu.

    Użyj kart Data i History, aby przeglądać odpowiednio bardziej szczegółowe informacje o procesie oraz ślad aktywności jego workflow.Użyj kart Data i History, aby przeglądać odpowiednio bardziej szczegółowe informacje o procesie oraz ślad aktywności jego workflow.

Karty Part Requests/Project Activities/Project Creations

Użyj tych kart — które grupują procesy według określonych tematów — aby przeglądać, tworzyć i zarządzać workflow procesów używanych odpowiednio podczas wnioskowania o nowy komponent biblioteczny Workspace, przeprowadzania przeglądów projektu lub publikowania do systemu PLM, albo tworzenia nowych projektów projektowych.

Domyślnie górny obszar karty pokazuje wszystkie wersje Latest zdefiniowanych procesów w danym temacie. Przełącz widok na procesy zdefiniowane jako All (tj. wszystkie wersje), korzystając z listy rozwijanej nad listą.

Przykład przeglądania najnowszych wersji zdefiniowanych procesów dla określonego tematu (w tym przypadku tematu Project Activities).Przykład przeglądania najnowszych wersji zdefiniowanych procesów dla określonego tematu (w tym przypadku tematu Project Activities).

Dla każdego wpisu prezentowane są następujące informacje:

  • Process Name : version — nazwa definicji procesu oraz jej wersja. Aby mieć pewność, że zawsze przeglądasz/pracujesz z najnowszą wersją, upewnij się, że pole listy rozwijanej wersji nad listą jest ustawione na Latest.
  • Instances (active / all) — liczba instancji tej wersji definicji procesu, które są obecnie aktywne, wraz z łączną liczbą instancji, które zostały uruchomione.
  • Created By — użytkownik, który utworzył tę wersję definicji procesu.
  • Created At — data i godzina utworzenia tej wersji definicji procesu (zapisania i wdrożenia).
  • Active — pokazuje, czy ta wersja definicji procesu jest aktywna () i może być używana, czy została zawieszona (), albo czy jest definicją przykładową (szablonem) () i dlatego nie może być używana. Tylko aktywne definicje procesów będą wyświetlane w odpowiednim obszarze GUI Altium Designer do wykorzystania przez projektantów. Kliknij ikonę, aby przełączyć stan aktywności, jeśli ma to zastosowanie.

    Używana (aktywna i uruchamiana) może być tylko najnowsza wersja definicji procesu. Poprzednie wersje nie mogą być używane, ale można je modyfikować w celu utworzenia nowszej wersji. Ponadto przykładowe definicje procesów (których stan Active jest oznaczony przez ) nie mogą być używane od razu po instalacji. Każda z nich jest bardziej „szablonem” — należy ją edytować zgodnie z wymaganiami firmy, nadać nazwę i zapisać jako nową definicję procesu, którą can następnie aktywujesz i wykorzystasz wraz z innymi definicjami.
  • Actions — kliknij kontrolkę  , aby uzyskać dostęp do menu działań dla definicji procesu:
    • Startjako administrator możesz uruchomić nową instancję tej wersji definicji procesu, wybierając to polecenie. Jest ono dostępne tylko wtedy, gdy definicja procesu została aktywowana. Jeśli proces został zawieszony albo jest definicją przykładową (szablonem), polecenie będzie wyszarzone i nie będzie można uruchomić instancji.
    • Edit — wybierz, aby zmodyfikować bazowy workflow definicji procesu. Diagram workflow dla tej wersji definicji procesu zostanie pokazany w Process Workflow Editor jako punkt wyjścia do dalszej pracy. Każdy Administrator może modyfikować dowolną definicję procesu zdefiniowaną przez użytkownika, niezależnie od tego, kto pierwotnie utworzył tę definicję, i zapisać oraz wdrożyć ją jako następną wersję. W przypadku domyślnych definicji procesów dostarczonych przez Altium możesz utworzyć nową definicję procesu na podstawie edycji jednej z nich (w praktyce tworząc odgałęzienie), ale nie możesz modyfikować samej definicji domyślnej. Więcej informacji o edycji definicji procesu znajdziesz w sekcji Edycja istniejącej definicji procesu.
    • Assign — wybierz, aby otworzyć okno Assign Access to This Workflow, w którym możesz zdefiniować, którzy użytkownicy i/lub grupy mogą uzyskać dostęp do bazowego workflow. Więcej informacji o zarządzaniu dostępem do workflow znajdziesz w sekcji Zarządzanie dostępem do workflow procesu.
    • Remove — wybierz, aby usunąć tę wersję definicji procesu. Pamiętaj, że niektórych domyślnych definicji procesów dostarczonych przez Altium nie można usunąć (i dlatego nie mają takiej kontrolki). Jeśli uruchomiono co najmniej jedną instancję definicji procesu, niezależnie od tego, czy jest nadal aktywna, czy nie, definicji nie można usunąć (polecenie nie będzie widoczne w menu).
Definicje procesów można sortować według dowolnej kolumny zawierającej kontrolkę — kliknij kontrolkę lub nazwę kolumny. Można również wyszukiwać za pomocą pola Search u góry listy. Do wyszukiwania można używać danych z kolumn Process Name : version i Created By.

Kliknij wpis definicji procesu, aby wyświetlić jej diagram workflow na karcie Diagram pod listą. Jeśli istnieje aktualnie aktywna instancja procesu, widok pokaże, na jakim etapie przepływu znajduje się ten proces, w tym kto ma teraz zadanie do wykonania, aby przesunąć go dalej.

Jeśli aktywnych jest wiele instancji procesu, widok Diagram pokaże stan zbiorczy. Kliknij kontrolkę w prawym dolnym rogu, aby podświetlić aktualnie osiągnięty punkt w workflow — wpis użytkownika(ów) zacznie na chwilę migać.

Wyświetlanie bazowego workflow dla wybranego procesu na karcie Diagram.Wyświetlanie bazowego workflow dla wybranego procesu na karcie Diagram.

Domyślne definicje procesów

W ramach instalacji Enterprise Server Altium dostarcza szereg definicji procesów — w trzech tematach procesów. Niektóre z nich są aktywowane do użycia od razu po instalacji i mogą być używane bez zmian, podczas gdy inne są przykładami — nie można ich aktywować ani używać bezpośrednio. Wszystkie mogą jednak posłużyć jako punkt wyjścia do tworzenia własnych definicji procesów według potrzeb. Skorzystaj z poniższych zwijanych sekcji, aby uzyskać informacje o dostarczonych definicjach procesów.

Instalacja Enterprise Server obejmuje również proces LibSync, który synchronizuje dane komponentów między Enterprise Server a docelową instancją PLM. Jest to wbudowany workflow procesu tylko do odczytu, dlatego nie można go edytować ani nie jest uwzględniany na liście procesów na stronie Processes Workspace (Admin » Processes). Więcej informacji znajdziesz w sekcji Synchronizacja komponentów PLM.

Dodawanie nowej definicji procesu

Related page: Definiowanie workflow procesu

Nowe procesy można tworzyć za pomocą dedykowanego Process Workflow Editor. Aby uzyskać dostęp do edytora, uaktywnij kartę tematu, w ramach którego chcesz utworzyć nowy proces, a następnie kliknij przycisk w prawym górnym rogu strony.

Ważne jest, aby najpierw uaktywnić temat, tak aby proces został utworzony z poprawnym Type.

Dostęp do Process Workflow Editor. Upewnienie się, że żądany temat procesu jest aktywny przed uzyskaniem dostępu, sprawi, że nowa definicja procesu zostanie ustawiona na właściwy typ tematu.Dostęp do Process Workflow Editor. Upewnienie się, że żądany temat procesu jest aktywny przed uzyskaniem dostępu, sprawi, że nowa definicja procesu zostanie ustawiona na właściwy typ tematu.

Nadaj nowej definicji procesu odpowiednią nazwę, następnie zbuduj workflow graficznie i zdefiniuj wymagane aspekty każdego elementu w tym przepływie. W przypadku zadań użytkownika do utworzenia wymaganego formularza, który zostanie przedstawiony użytkownikowi w celu wprowadzenia danych, gdy otrzyma zadanie w odpowiednim punkcie workflow, używany jest User Form Editor.

Zaawansowany Process Workflow Editor zapewnia elastyczność potrzebną do budowania procesów z workflow tak prostymi lub tak złożonymi, jak to konieczne, zgodnie z wymaganiami Twojej firmy.Zaawansowany Process Workflow Editor zapewnia elastyczność potrzebną do budowania procesów z workflow tak prostymi lub tak złożonymi, jak to konieczne, zgodnie z wymaganiami Twojej firmy.

Po zdefiniowaniu procesu zgodnie z wymaganiami kliknij przycisk , aby dodać go do listy dostępnych procesów dla danego tematu procesu. Nowa definicja procesu zostanie aktywowana i będzie gotowa do użycia.

Edytor oznaczy wszelkie problemy w diagramie workflow, które uniemożliwiają jego zapisanie i wdrożenie — na przykład diagram musi zawierać zdarzenie Start oraz co najmniej jedno zdarzenie End. Zadanie użytkownika musi też mieć co najmniej jedno pole formularza i przypisanego wykonawcę.

Edycja istniejącej definicji procesu

Każdy Administrator może modyfikować dowolną definicję procesu zdefiniowaną przez użytkownika, niezależnie od tego, kto pierwotnie utworzył tę definicję, i zapisać oraz wdrożyć ją jako następną wersję. Aby to zrobić, kliknij  element sterujący w kolumnie Actions dla definicji procesu, którą chcesz zmodyfikować, i wybierz z wyświetlonego menu pozycję Edit. Diagram przepływu pracy dla tej wersji definicji procesu zostanie wyświetlony w obszarze Process Workflow Editor jako punkt wyjścia do dalszej pracy.

W przypadku definicji procesów dostarczonych przez Altium możesz utworzyć nową definicję procesu na podstawie edycji jednej z nich (w praktyce tworząc fork), ale nie możesz modyfikować samej definicji domyślnej.

Przykład edycji istniejącej definicji procesu – uzyskanie dostępu do Process Workflow Editor, w którym można wprowadzić wymagane zmiany.Przykład edycji istniejącej definicji procesu – uzyskanie dostępu do Process Workflow Editor, w którym można wprowadzić wymagane zmiany.

Wprowadź wymagane zmiany do schematycznego przepływu pracy procesu, w tym wszelkie zmiany formularzy powiązanych z zadaniami użytkownika, a następnie kliknij przycisk , aby zapisać definicję jako następną wersję. W pokazanym tutaj przykładzie oryginalna definicja procesu Company Pre-release Review : 1 (wersja 1) zostaje zmodyfikowana i zapisana jako Company Pre-release Review : 2 (wersja 2).

Po wprowadzeniu zmian zapisz i wdroż je jako następną wersję tej definicji procesu.Po wprowadzeniu zmian zapisz i wdroż je jako następną wersję tej definicji procesu.

Korzystając z pola listy rozwijanej w lewym górnym rogu i ustawiając wpis na All, możesz zobaczyć wszystkie wersje istniejących definicji procesów. Na poniższym obrazie widać obie wersje definicji procesu Company Pre-release Review.

Wyświetlenie wszystkich wersji przykładowej definicji procesu Company Pre-release Review. Zwróć uwagę, że tylko najnowsza wersja (wersja 2) może zostać aktywowana i użyta.Wyświetlenie wszystkich wersji przykładowej definicji procesu Company Pre-release Review. Zwróć uwagę, że tylko najnowsza wersja (wersja 2) może zostać aktywowana i użyta.

Można używać tylko najnowszej wersji definicji procesu (można ją uaktywnić i uruchomić). Poprzednie wersje mogą jednak służyć jako punkt wyjścia do utworzenia późniejszej wersji. Jeśli usuniesz najnowszą wersję definicji procesu, poprzednia wersja automatycznie stanie się najnowszą i ponownie będzie można ją uaktywnić oraz używać (uruchamiać instancje).

Importowanie/eksportowanie definicji procesu

Definicje procesów można eksportować i importować, co pozwala szybko ponownie wykorzystywać je między instancjami Enterprise Server — to ogromna oszczędność czasu, zwłaszcza gdy bazowy przepływ pracy danego procesu jest szczególnie złożony, a konieczność „wynajdywania koła na nowo” byłaby w przeciwnym razie zniechęcającym zadaniem.

Aby zaimportować:

  1. Przejdź do karty motywu (Part Requests, Project Activities, Project Creations) odpowiadającej definicji procesu, którą chcesz zaimportować.

    Jeśli spróbujesz zaimportować definicję procesu do niewłaściwego motywu, oprogramowanie poinformuje Cię o tym i uniemożliwi import.
  2. Kliknij przycisk , aby utworzyć nową definicję procesu i uzyskać dostęp do Process Workflow Editor.
  3. Kliknij przycisk . W wyświetlonym oknie dialogowym Open wskaż wymagany plik Workflow (*.aaw) i otwórz go. Zawartość pliku całkowicie nadpisze wszystko, co jest obecnie zdefiniowane dla tej definicji procesu (nazwa, diagram itd.).
Możesz również zaimportować wcześniej wyeksportowaną definicję procesu z pliku bezpośrednio z karty Browser interfejsu. W tym celu kliknij przycisk . W wyświetlonym oknie dialogowym Open wskaż wymagany plik Workflow (*.aaw) i otwórz go. Poprawny motyw procesu zostanie wykryty, a zawartość pliku zostanie załadowana do Process Workflow Editor.

Aby wyeksportować:

  1. Kliknij element sterujący  w kolumnie Actions dla wymaganej wersji definicji procesu, którą chcesz wyeksportować, i wybierz z wyświetlonego menu pozycję Edit, aby przejść do trybu edycji.
  2. W Process Workflow Editor kliknij przycisk . Definicja procesu zostanie wyeksportowana jako plik Workflow (<ProcessDefinitionName>.aaw) do domyślnego folderu pobierania ustawionego w Twojej przeglądarce.
  3. Kliknij pozycję Processes w lewym drzewie nawigacyjnym interfejsu przeglądarkowego Workspace, aby wyjść z Process Workflow Editor bez wprowadzania zmian w definicji procesu.

Zarządzanie dostępem do przepływu pracy procesu

Jako administrator możesz określić, którzy użytkownicy i/lub grupy mogą uzyskiwać dostęp do przepływu pracy procesu. W tym celu kliknij element sterujący  w kolumnie Actions dla definicji procesu, dla której chcesz skonfigurować dostęp do bazowego przepływu pracy, i wybierz z wyświetlonego menu pozycję Assign. Otworzy się okno Assign Access to This Workflow.

Zacznij wpisywać pełną nazwę lub nazwę użytkownika użytkownika albo nazwę grupy w polu tekstowym, aby wyświetlić wyskakującą listę pasujących użytkowników/grup. Można dodać wielu użytkowników/grup. Aby usunąć dodanego użytkownika/grupę z dostępu do przepływu pracy, kliknij krzyżyk usuwania po prawej stronie nazwy.

Po zdefiniowaniu wymaganych użytkowników/grup kliknij , aby zastosować przypisanie przepływu pracy. Przepływ pracy będzie teraz dostępny tylko dla dodanych użytkowników/grup (oraz członków grupy Administrators) przy dostępie opisanym poniżej w sekcji Dostęp projektanta do przepływów pracy procesu.

Jak podano w oknie Assign Access to This Workflow, jeśli nie zostanie dodany żaden użytkownik/grupa, przepływ pracy będzie dostępny dla wszystkich użytkowników.

Dostęp projektanta do przepływów pracy procesu

Related pages: Przeprowadzanie przeglądów projektu, Publikowanie do systemu PLM, Żądania części oparte na procesie

Po przygotowaniu wymaganego zestawu definicji procesów dla każdego dostępnego motywu procesu zgodnie z potrzebami Twojej firmy, aktywowane definicje będą dostępne do użycia przez przypisanych użytkowników, gdy połączą się oni z Workspace serwera Enterprise Server. W poniższych sekcjach omówiono, gdzie projektant może uzyskać dostęp do tych aktywnych procesów i je uruchamiać — zarówno przez Altium Designer, jak i przez interfejs przeglądarkowy Workspace.

Jak wspomniano wcześniej, administratorzy Workspace mogą uruchomić nową instancję dowolnej aktywowanej definicji procesu — bezpośrednio z odpowiedniej karty motywu procesu w obszarze Processes interfejsu przeglądarkowego Workspace — klikając element sterujący  w kolumnie Actions i wybierając z wyświetlonego menu pozycję Start.

Żądania części

Related page: Żądania części oparte na procesie

Z poziomu Altium Designer aktywowane definicje procesów należące do motywu Part Requests są dostępne w następujących miejscach:

  • Z panelu Components panel. Kliknij prawym przyciskiem myszy w głównym obszarze panelu — aktywne definicje procesów żądań części będą dostępne w podmenu Operations » Submit Request. Alternatywnie kliknij łącze Submit request w sekcji Need more components?.

Jeśli dla motywu procesu Part Requests nie są dostępne żadne aktywne definicje procesów, podmenu Submit Request nie będzie wyświetlane. Aby odświeżyć, może być konieczne wylogowanie się z Workspace i ponowne zalogowanie lub ponowne uruchomienie Altium Designer.
  • Z poziomu panelu Manufacturer Part Search panel. Jeśli aktualnie wybrany element wyszukiwania ma ikonę , w panelu Information (otwieranym przez kliknięcie ) będzie dostępny przycisk . Kliknij część rozwijaną przycisku, aby otworzyć menu aktywnych definicji procesów żądań części. Kliknięcie bezpośrednio głównej części przycisku uruchomi pierwszą definicję procesu z listy.
Wysyłanie żądania części przez panel Manufacturer Part Search daje dodatkową korzyść w postaci automatycznego uzupełnienia kluczowych informacji, w tym wszystkich arkuszy danych i informacji parametrycznych.

Jeśli dla motywu procesu Part Requests nie są dostępne żadne aktywne definicje procesów, przycisk nie będzie wyświetlany. Aby odświeżyć, może być konieczne wylogowanie się z Workspace i ponowne zalogowanie lub ponowne uruchomienie Altium Designer.

Jeśli aktualnie wybrany element wyszukiwania ma ikonę , aktywne definicje procesów żądań części będą dostępne z menu powiązanego z przyciskiem (kliknij rozwijaną część przycisku).

Aktywne definicje procesów żądań części są również dostępne z menu kontekstowego po kliknięciu prawym przyciskiem myszy w głównym obszarze panelu, z podmenu Submit Request.

Jeśli dla motywu procesu Part Requests nie są dostępne żadne aktywne definicje procesów, podmenu Submit Request nie będzie wyświetlane. Aby odświeżyć, może być konieczne wylogowanie się z Workspace i ponowne zalogowanie lub ponowne uruchomienie Altium Designer.
  • Z panelu Explorer panel, w folderze Part requests lub po wykonaniu wyszukiwania. Dostępny będzie przycisk , który po naciśnięciu wyświetli aktywne definicje procesów żądań części dostępne do wyboru.

Zwróć uwagę, że jeśli funkcja Legacy Part Requests feature została włączona, przycisk będzie wyświetlany jako . W menu pojawi się również dodatkowa pozycja dotycząca nowych żądań części z użyciem tej starszej funkcjonalności. Będzie ona miała sufiks (Legacy). Jeśli dla motywu procesu Part Requests nie są dostępne żadne aktywne definicje procesów, a funkcja Legacy Part Requests nie jest włączona, przycisk Submit Request nie będzie wyświetlany. Aby odświeżyć, może być konieczne wylogowanie się z Workspace i ponowne zalogowanie lub ponowne uruchomienie Altium Designer.

Z poziomu interfejsu przeglądarkowego Workspace aktywowane definicje procesów należące do motywu Part Requests są dostępne na stronie Part Requests po kliknięciu przycisku w prawym górnym rogu strony.

Dostęp do aktywowanych definicji Part Requests ze strony Part Requests interfejsu przeglądarkowego Workspace.Dostęp do aktywowanych definicji Part Requests ze strony Part Requests interfejsu przeglądarkowego Workspace.

Jeśli dla motywu procesu Part Requests nie są dostępne żadne aktywne definicje procesów, przycisk będzie niedostępny. Jeśli istnieje tylko jedna definicja procesu, przycisk nie będzie miał funkcji listy rozwijanej i po kliknięciu natychmiast uruchomi ten proces.

Działania projektowe

Related pages: Przeprowadzanie przeglądów projektu, Publikowanie do systemu PLM, Integracja z PLM.

Aktywowane definicje procesów należące do motywu Project Activities są dostępne w różnych miejscach.

Przegląd projektu i standardowe publikowanie do PLM

Z poziomu Altium Designer aktywowane definicje procesów przeglądu projektu i publikowania — należące do motywu Project Activities — są dostępne z podmenu kontekstowego Project Activities, otwieranego przez kliknięcie prawym przyciskiem myszy wpisu projektu projektowego w panelu Projects panel, lub z głównego menu Project » Project Activities.

Jeśli dla motywu procesu Project Activities nie są dostępne żadne aktywne definicje procesów przeglądu projektu i standardowego publikowania do PLM, menu nie będą widoczne.

Z poziomu interfejsu przeglądarkowego Workspace aktywowane definicje procesów przeglądu projektu i publikowania — należące do motywu Project Activities — są dostępne na stronie Projects interfejsu. Wybierz wymagany projekt, a następnie kliknij przycisk .

Dostęp do aktywowanych definicji Project Activities (przegląd projektu i standardowe publikowanie do PLM) dla projektu Workspace w obszarze Projects interfejsu przeglądarkowego Workspace.Dostęp do aktywowanych definicji Project Activities (przegląd projektu i standardowe publikowanie do PLM) dla projektu Workspace w obszarze Projects interfejsu przeglądarkowego Workspace.

Jeśli dla motywu procesu Project Activities nie są dostępne żadne aktywne definicje procesów przeglądu projektu i standardowego publikowania do PLM, przycisk nie będzie wyświetlany.

Publikowanie do PLM przez Project Releaser

Z poziomu Altium Designer proces publikowania do instancji PLM jako część Project Releaser jest dostępny z podmenu Project » Project Releaser dla aktywnego projektu lub po kliknięciu prawym przyciskiem myszy wpisu projektu projektowego w panelu Projects panel i wybraniu procesu z pozycji menu kontekstowego Project Releaser.

Tworzenie projektów

Z poziomu Altium Designer aktywowane definicje procesów należące do motywu Project Creations są dostępne w trzech miejscach:

  • Z głównego podmenu File » New » Project in <WorkspaceName>.

  • Z podmenu kontekstowego Convert to Managed Project, otwieranego po kliknięciu prawym przyciskiem myszy wpisu lokalnego projektu w panelu Projects.

  • Z podmenu kontekstowego Clone, otwieranego po kliknięciu prawym przyciskiem myszy wpisu projektu w oknie dialogowym Open Project dialog, gdy wybrana jest lokalizacja Workspace.

Zwróć uwagę, że gdy aktywna jest co najmniej jedna definicja procesu dla motywu procesu Project Creations, możliwość utworzenia nowego projektu Workspace za pomocą okna dialogowego Create Project dialog (File » New » Project) jest wyłączona — podłączony Workspace nie jest dostępny jako lokalizacja docelowa. Projekty typu Regular (lokalne) i VCS można tworzyć normalnie za pomocą tego okna dialogowego.

Jeśli dla motywu procesu Project Creations nie są dostępne żadne aktywne definicje procesów — co jest przypadkiem domyślnym przy świeżej instalacji Enterprise Server — menu procesów nie będą widoczne i będzie można utworzyć projekt Workspace za pomocą okna dialogowego Create Project jak zwykle.

Zwróć również uwagę, że w tej domyślnej konfiguracji polecenie Convert to Managed Project zmienia się na Make Project Available on Server.

Z poziomu interfejsu przeglądarkowego Workspace aktywowane definicje procesów należące do motywu Project Creations są dostępne w następujących miejscach:

  • Z głównej strony Projects interfejsu, po kliknięciu przycisku .

Dostęp do aktywowanych definicji Project Creations z głównego obszaru Projects interfejsu przeglądarkowego Workspace.Dostęp do aktywowanych definicji Project Creations z głównego obszaru Projects interfejsu przeglądarkowego Workspace.

  • Z poziomu strony Projects interfejsu, gdy chcesz sklonować określony projekt. Wybierz wymagany projekt, a następnie kliknij przycisk , aby uzyskać dostęp do procesów z menu.

Dostęp do aktywowanych definicji Project Creations podczas klonowania projektu Workspace w obszarze Projects interfejsu przeglądarkowego Workspace.Dostęp do aktywowanych definicji Project Creations podczas klonowania projektu Workspace w obszarze Projects interfejsu przeglądarkowego Workspace.

  • Jeśli dla motywu procesu Project Creations nie są dostępne żadne aktywne definicje procesów — co jest przypadkiem domyślnym przy świeżej instalacji Enterprise Server — menu będzie oferować podstawową funkcję klonowania projektu (Clone). Nie jest to związane z funkcjonalnością przepływu pracy procesu.
  • Aby używać Constraint Manager do zarządzania ograniczeniami projektowymi dla opartego na procesie projektu PCB w Workspace, pamiętaj o przypisaniu odpowiedniego szablonu projektu podczas tworzenia tego projektu. Powinien to być szablon zapisany z projektu PCB utworzonego z włączoną opcją Constraint Management w oknie dialogowym Create Project dialog.
AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Content