Altium NEXUS Documentation

Определение формы платы_AD

Created: 28.05.2021 | Updated: 28.05.2021

Главная страница: Плата

Возможности конструирования гибко-жестких плат находятся в активном развитии. Для переключения в режим Rigid-Flex 2 включите следующие опции в диалоговом окне Advanced Settings:

  • PCB.RigidFlex2.0 – включает функциональные возможности Rigid-Flex 2 в режиме Board Planning Mode. Обратите внимание, что в предыдущих версиях Altium Designer эта опция называлась Legacy.PCB.RigidFlex. Вместе изменением названия изменилось поведение – при включении старой опции восстанавливался старый режим (Rigid-Flex1.0), в то время как новая опция включает новый режим (Rigid-Flex2.0).
  • PCB.RigidFlex.SubstackPlanning – включает представление Board в Layer Stack Manager.

Узнайте больше о Конструировании гибко-жестких плат

Javascript

Форма платы Board Shape определяет общую форму конечной платы. Пролистайте изображения, чтобы увидеть три региона платы, которые формируют гибко-жесткую конструкцию, и конечную плату в 3D.

Обзор

Форма платы, которая также называется контуром платы – это замкнутая полигональная форма, которая определяет общую область платы. Форма платы может быть составлена из одного региона платы (для обычных жестких плат) или множества регионов (для гибко-жестких плат). Помимо визуального представления области платы, доступной для размещения компонентов и трассировки, форма платы также используется системой для следующего:

  • Расчет отступа для слоев питания; края могут использоваться в качестве привязки при разделении слоя питания на зоны различных напряжений. Узнайте больше об Определении проводящих областей и управлении ими.
  • Расчет края платы при выводе проектных данных в другие системы.

Доступ

Форма платы Board Shape доступна только в редакторе плат. При создании нового файла платы он открывается с прямоугольной формой, созданной из одного региона Board Region.

Общую форму платы можно создать следующими способами:

  • Путем размещения одного или множества регионов платы для определения общей формы платы.
  • Путем разделения существующего региона платы на два более малых региона, с последующим повторением этого процесса до тех пор, пока не будет достигнуто нужно количество регионов требуемой формы.
  • Путем создания формы платы из объектов, выделенных в проектной области и образующих замкнутый контур. Либо, если для платы необходимо множество регионов, они могут быть созданы из объектов, выделенных в проектной области.
Новый документ платы по умолчанию имеет прямоугольную форму (6 x 4 дюйма, 6000 x 4000 милов или 152,4 x 101,6 мм). С определенными шаблонами проектов, которые могут использоваться при создании нового проекта платы, связанные с ними документы плат могут иметь определенную форму платы, в соответствии с форм-фактором платы.
Текущий режим представления документа платы можно изменить с помощью соответствующих команд меню View либо с помощью клавиш 1 (Board Planning Mode), 2 (2D) и 3 (3D).

Интерактивное определение и редактирование формы платы

Форма платы определяет одним или множеством регионов платы. Конструкторы, которые работают с платой из одного региона, могут использовать следующие команды для определения формы платы:

  • Board Planning Mode:

    • Place » Board Region – используйте эту команду для интерактивного определения региона платы (для платы с одним регионом, объект Board Region определяет форму платы). Узнайте больше об объекте Board Region.
  • 2D Layout Mode:

    • Design » Board Shape » Define Board Shape from Selected Objects – выделите набор линий и/или дуг, которые определяют замкнутый контур, затем используйте эту команду для переопределения формы платы в соответствии с этим контуром.
    • Design » Board Shape » Create Primitives from Board Shape – создает набор примитивов вдоль границы формы платы в соответствии с настройками, заданными в диалоговом окне Line/Arc Primitives from Board Shape.
  • 3D Layout Mode:

    • Design » Board Shape » Define Board Shape from 3D body – используйте эту команду для определения формы платы путем выбора нужной поверхности 3D-модели.
Различие между командами Define Board Shape from Selected Objects и Create Board Region from Selected Objects заключает в том, что первая команда заменяет все существующие регионы платы новым регионом, который создается при запуске команды, в то время как вторая команда создает дополнительный регион платы без удаления существующих регионов.

Определение формы платы из выделенных объектов

Форму платы также можно определить из выделенных объектов (в режиме 2D Layout Mode). Как правило, это набор линий и/или дуг, размещенных на слое Keepout или на механическом слое.

Используйте следующую последовательность действий:

  1. Переключитесь режим представления 2D Layout Mode (меню View).
  2. Откройте панель View Configuration и дважды щелкните ЛКМ по механическому слою, который содержит контур платы, чтобы отредактировать его. Будет открыто диалоговое окно Edit Layer, где вы можете задать типу слоя Layer Type значение Board Shape (Форма платы), как показано на видео ниже.
  3. Сделайте активным механический слой, который содержит контур, и выделите объекты. Для этого отлично подходит команда Edit » Select » All on Layer. Набор выделенных объектов должен включать в себя только трассы и дуги, которые образуют форму контура платы.
  4. Когда все объекты выделены, выберите команду Design » Board Shape » Define Board Shape from Selected Objects. Форма платы будет переопределена выделенными объектами, и будет отображен обновленный контур. Если система не сможет отследить среднюю линию выделенных объектов, будет открыто диалоговое окно с предупреждением. Режим представления изменится на Board Planning Mode.

Видео, демонстрируете создание формы платы из выделенных объектов с последующим разделением формы для создания трех регионов.
Далее показан альтернативный подход, при котором три региона платы определяются из выделенных объектов.

Система попытается найти форму на основе средней линии выделенных объектов. Если координаты конца одного сегмента трассы/дуги не совпадают в точности с координатами конца следующего сегмента трассы/дуги, то алгоритм определения границ даст сбой, и будет отображено сообщение, показывающее место сбоя. Вместо средней линии будет предложено использовать алгоритм трассировки. Обратите внимание, что алгоритм трассировки следует внешнему краю трасс/дуг, и форма платы будет слегка отличаться от той, которая была создана из средних линий. Выбирайте этот вариант, только если это допустимо в конструкции вашей платы.

Импорт контура для использования в качестве формы платы

Форма платы может быть определена из замкнутого контура, импортированного как данные DXF/DWG.

С помощью импорта данных DXF/DWG в механический слой и последующего определения формы платы из выделенных объектов, в редактор плат можно перенести форму, созданную в механической САПР.

Для подготовки новой платы к импорту:

  1. Выберите команду File » New » PCB. Будет открыт новый документ платы, где черная область представляет текущую формы платы Board Shape.
  2. Перед импортом новой формы задайте следующие опции в соответствии с требованиями к конструкции и импортируемой форме:

    • Единицы измерения – задайте нужные единицы измерения с помощью опции Units в разделе Other панели Properties в режиме Board (показать изображение).
    • Сетка – дважды щелкните ЛКМ по строке Global Board Snap Grid в разделе Grid Manager панели Properties в режиме Board и настройте ее нужным образом (показать изображение).
    • Точка отсчета – в новом документе платы положением пользовательской (относительной) точки отсчета является абсолютная точка отсчета, расположенная в нижнем левом углу проектной области. Выберите команду Edit » Origin » Set из главного меню, затем щелкните ЛКМ, чтобы определить положение пользовательской точки отсчета, например, в левом нижнем углу текущего контура платы. Это позволит задать подходящую точку отсчета в соответствии с точкой отсчета импортируемого контура.

Следующим шагом является импорт контура платы из файла .DXF или .DWG. Обратите внимание, что импортируемый контур должен быть замкнут и что внутренние вырезы не будут созданы автоматически (но они могут быть определены из импортированных объектов позже).

  1. Выберите команду File » Import » DXF/DWG, чтобы открыть диалоговое окно Import File, убедитесь, что в качестве типа файла File Type в нижней правой части окна выбрано AutoCAD Files (*.DXF, *.DWG), затем найдите нужный файл.
  2. После нажатия кнопки Open будет открыто диалоговое окно Import from AutoCAD (показать изображение).
  3. Задайте масштаб (Scale), ширину линии по умолчанию (Default Line Width) и отображение слоев (Layer Mappings) необходимым образом, затем нажмите OK.
  4. Все объекты в файле DXF/DWG будут преобразованы в объекты редактора плат, которые будут отображены в проектной области.
  5. Сделайте активным механический слой, который содержит контур, и выделите объекты на этом слое (Edit » Select » All on Layer).
  6. Чтобы обновить форму платы в соответствии с выделенным контуром, выберите команду Design » Board Shape » Define Board Shape from Selected Objects.
  7. Если плата включает в себя вырезы, их можно создать, выделив контур выреза и запустив команду Tools » Convert » Create Board Cutout from Selected Primitives.
Система попытается найти форму на основе средней линии выделенных объектов. Если координаты конца одного сегмента трассы/дуги не совпадают в точности с координатами конца следующего сегмента трассы/дуги, то алгоритм определения границ даст сбой, и будет отображено сообщение, показывающее место сбоя. Вместо средней линии будет предложено использовать алгоритм трассировки. Обратите внимание, что алгоритм трассировки следует внешнему краю трасс/дуг, и форма платы будет слегка отличаться от той, которая была создана из средних линий. Выбирайте этот вариант, только если это допустимо в конструкции вашей платы.

Определение формы платы из 3D-модели

Эта возможность позволяет переопределить форму платы на основе поверхности (грани) импортированной 3D-модели. Поддерживаемые форматы моделей включают в себя: STEP (*.Stp или *.STEP), Parasolid (*.x_t или *x_b) и файл детали SOLIDWORKS (*.SldPrt). Модель можно использовать для быстрого создания сложной формы платы, что позволяет объединить области электронного и механического проектирования. Это двухэтапный процесс: сначала импортируется модель, затем на модели выбирается нужна грань.

Для этого необходимо выполнить следующее:

  1. Переключитесь в режим View » 3D Layout Mode.
  2. Для импорта 3D-модели разместите объект 3D Body (Place » 3D Body).
  3. В диалоговом окне Choose Model найдите и выберите файл модели. 3D-модель будет импортирована в редактор плат и сохранена в объекте 3D Body. Обратите внимание, что при необходимости эту модель можно будет удалить из платы, когда форма платы будет переопределена.
  4. Выберите команду Design » Board Shape » Define Board Shape from 3D body.
  5. В строке состояния будет отображено Pick a 3D body (Выберите 3D-модель). Щелкните ЛКМ по 3D-модели, чтобы выбрать ее.
  6. Курсор изменит свой вид на перекрестие, и в строке состояния будет отображено Choose Face (Выберите грань). При наведении курсора мыши на грань она будет подсвечена. Щелкните ЛКМ по нужной грани, чтобы выбрать ее.
  7. Будет открыто диалоговое окно Board Outline Creation Successful, в которой доступны опции для выбора поверхности платы, с которой должна быть выровнена выбранная поверхность (обычно это верхний слой), и указания, должна ли 3D-модель быть скрыта для отображения и отключена для проверки правил проектирования. Скрытие и отключение можно изменить при необходимости позже в режиме 3D Models панели PCB.

    Обратите внимание, что если вы встроили модель в файл платы или добавили в него ссылку на модель, то при изменении файла модели вы получите уведомление. Вам также будет предложено обновить форму платы, что полезно, если форма платы дорабатывается либо если ожидаются ее изменения.

Для создания формы платы можно использовать только поверхности, выровненные с плоскостью X-Y. Если вы выберите поверхность модели, которой требуется выравнивание с плоскостью X-Y, будет открыто диалоговое окно Confirmation, в котором у вас будет запрошено подтверждение на выравнивание поверхности, перед тем как вы сможете продолжить. Это диалоговое окно позволяет вам разместить модель, выровняв выбранную грань с верхней или нижней поверхностью платы. Это значит, что можно задать вертикальное положение модели. После выравнивания вам понадобится снова выбрать команду Design » Board Shape » Define from 3D Body. После того, как форма платы будет переопределена, вы сможете скрыть 3D-модель.

Создание примитивов из формы платы

Помимо определения формы платы из выделенных примитивов, вы также можете создать примитивы из формы платы с помощью команды Design » Board Shape » Create Primitives from Board Shape. Эта команда откроет диалоговое окно Line/Arc Primitives from Board. Используйте эту команду, если существует форма платы, но нет объектов вдоль ее границы. Ситуации, при которых эта команда может быть полезна:

Добавление отверстия в форму платы

В любом месте формы платы можно разместить вырез в плате. Для размещения выреза переключитесь на представление платы в режиме 2D Layout Mode и используйте команду Design » Board Shape » Define Board Cutout главного меню (либо используйте команду Place » Define Board Cutout в режиме Board Planning Mode). Обратите внимание, что фактически вырез является объектом Region, настроенным как отрицательный объект.

В форме платы был размещен вырез в плате.В форме платы был размещен вырез в плате.

Если вырез имеет нестандартную форму, такую как окружность, может быть проще создать контур выреза с помощью трасс и дуг (например, Place » Arc » Full Circle), выделить контур и преобразовать его в вырез в плате (Tools » Convert » Create Board Cutout from Selected Primitives).

Что важно учитывать при использовании вырезов в плате

Отступ полигона от края выреза в плате

Полигон, который перекрывает вырез в плате, будет залит настолько близко к краю выреза, насколько это допустимо применяемым правилом проектирования Clearance. При необходимости можно создать отдельное правило Clearance, областью действия которого будет, например, IsBoardCutoutRegion и InPolygon.

Определение пути инструмента вдоль края платы и вырезов

Распространенным подходом, используемым для отделения конечной платы от панели, является фрезерование. Также фрезерованием могут быть созданы вырезы в плате. Путь инструмента определяется размещением линий и/или дуг на механическом слое. Это можно сделать вручную или автоматически.

Чтобы определить путь инструмента для платы и любых вырезов в плате:

  1. В режиме 2D Layout Mode запустите команду Design » Board Shape » Create Primitives From Board Shape. Будет открыто диалоговое окно Line/Arc Primitives From Board Shape dialog.
  2. Определите подходящую ширину (Width) объектов, которые определят путь инструмента. Свяжитесь с производителем, если вы не знаете, какую величину следует выбрать.
  3. Выберите доступный механический слой. Этот слой должен быть зарезервирован только для определения пути инструмента.
  4. Включите опцию Include Cutouts, если в плате есть вырезы.
  5. Включите опцию Route Tool Outline. Когда эта опция включена, линии/дуги будут размещены таким образом, что их края будут касаться края формы платы и края выреза.
  6. Нажмите OK, чтобы создать объекты пути инструмента на выбранном механическом слое.
  7. Используемый механический слой должен быть задан в качестве слоя пути инструмента. Для этого откройте вкладку Layers & Colors панели View Configuration, щелкните ПКМ в списке слоев и выберите команду Add Mechanical Layer. В открывшемся диалоговом окне Edit Layer задайте для Layer Type значение Route Tool Path. Этот тип слоя используется для обозначения того, что этот слой содержит информацию о механической трассе. Обратите внимание, что если для Layer Type задано Route Tool Path, пользовательское название недопустимо, поскольку более ранние версии системы используют это название слоя пути инструмента для определения того, что этот слой содержит информацию о трассе. Блокирование названия обеспечит корректную работу конструкции в более ранних версиях.

На изображении ниже показан путь инструмента, определенный на механическом слое.

Вырез в плате на первом изображении с путем инструмента, определенным на втором изображении. Вырез в плате на первом изображении с путем инструмента, определенным на втором изображении.Вырез в плате на первом изображении с путем инструмента, определенным на втором изображении.

Зоны Keepout и форма платы

Помимо формы платы, вы также можете определить границу размещения компонентов и трассировки вдоль края платы. Эту границу можно создать автоматически по самой форме платы с помощью команды Design » Board Shape » Create Primitives From Board Shape (в режиме 2D Layout Mode) и определив в качестве слоя (Layer) значение Keep-Out Layer в диалоговом окне Line/Arc Primitives from Board.

Либо это можно сделать вручную путем размещения объектов на слое Keepout. Объекты, размещенные на этом слое, определят границу, которую не могут пересекать компоненты и трассировка. Обычно необходимо размещать объекты, такие как компоненты и трассировка, на определенном расстоянии от края платы. Этим расстоянием можно управлять путем настройки соответствующих правил проектирования для трассировки и размещения компонентов. Вы также можете определить другие зоны ограничений трассировки и размещения для механических объектов, таких как винты и другие крепежные детали.

Граница зоны ограничений, определенная путем размещения стандартных линий на слое Keepout.Граница зоны ограничений, определенная путем размещения стандартных линий на слое Keepout.

Границы Keepout могут быть определены путем размещения стандартных объектов, таких как линии, заполнения и регионы, на слое Keepout. Объекты, размещенные на слое Keepout, создают зону ограничений для всех сигнальных слоев.

Вы также можете определить зоны ограничений для определенного проводящего слоя. Для этого:

  1. Щелкните ЛКМ по вкладке нужного слоя.
  2. Определите границу или область зоны ограничений путем размещения объектов Keepout для определенного слоя (меню Place » Keepout). Это стандартные объекты с включенным атрибутом Keepout. Они отображаются как заштрихованные области в цвете слоя размещения. Обратите внимание, что объекты Keepout для определенных слоев не включаются в выходные файлы Gerber и ODB++.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: