Создание и управление процессами

Altium Designer предоставляет мощную среду для совместной разработки. Одной из ее составляющих является поддержка Workflows, которые помогают разработчикам компании выполнять типовые повседневные задачи проектирования, такие как:

  • Запрос новых компонентов библиотеки Workspace
  • Проведение проверок проекта
  • Создание новых проектов Workspace.

Каждый Workflow, используемый для реализации определенного процесса проектирования, создается как часть Process Definition. Поэтому его можно назвать базовым Workflow данного процесса или просто Process Workflow.

Процессы и их Workflows создаются и управляются через браузерный интерфейс Workspace Enterprise Server — администратором этого Workspace.

Для трех ранее упомянутых областей проектирования в установку сервера включены предопределенные process workflows. Некоторые из них активированы и готовы к использованию сразу после установки. Используйте их, изменяйте или создавайте собственные по мере необходимости в соответствии с потребностями вашей компании. Другие являются примерами — их нельзя активировать и использовать как есть. Поэтому каждый из них больше похож на «шаблон» — отредактируйте его в соответствии с требованиями вашей компании, задайте имя и сохраните как новое определение процесса, которое затем can активируете и используете наряду со всеми остальными определениями.

Мощный Process Workflow Editor обеспечивает гибкость, позволяя создавать процессы с workflows любой необходимой степени простоты или сложности — в соответствии с требованиями вашей компании.

Доступ к процессам

Все управление процессами выполняется из раздела Processes (Admin – Processes) браузерного интерфейса Workspace Enterprise Server.

Чтобы видеть раздел Processes интерфейса, необходимо войти в систему как Administrator вашего Workspace Enterprise Server.

Доступ к разделу Processes браузерного интерфейса Workspace Enterprise Server — центральной точке работы с процессами и связанными с ними workflows.Доступ к разделу Processes браузерного интерфейса Workspace Enterprise Server — центральной точке работы с процессами и связанными с ними workflows.

Интерфейс Processes представлен следующими четырьмя вкладками:

  • Browser — содержит сводный список всех процессов (активных или закрытых). Это своего рода централизованная «панель процессов».
  • Part Requests — выделенная область для управления процессами, связанными с тематикой запроса компонентов.
  • Project Activities — выделенная область для управления процессами, связанными с работой над проектами Workspace, например проверками проекта и публикацией в PLM-систему.
  • Project Creations — выделенная область для управления процессами, связанными с созданием новых проектов разработки Workspace.
Последние три вкладки можно назвать Process Themes. Темы процессов позволяют интуитивно группировать различные процессы по областям проектирования. Они также позволяют программному обеспечению поддерживать создание новых процессов, предоставляя только те элементы workflow, которые необходимы для конкретной области, тем самым упрощая построение нужного workflow. В дальнейшем такой подход дает Altium основу для расширения интерфейса путем добавления новых тем по мере необходимости.

В следующих разделах эти различные вкладки рассматриваются более подробно.

Вкладка Browser

Используйте эту вкладку для централизованного просмотра всех активных или закрытых процессов во всех темах процессов. По умолчанию вкладка показывает все Active (выполняющиеся) процессы. Переключиться на просмотр всех Closed процессов (например, завершенных, отклоненных или принудительно остановленных) можно с помощью раскрывающегося списка над перечнем.

Просматривайте все активные процессы в одном удобном месте. Наведите курсор на изображение, чтобы увидеть пример просмотра всех закрытых процессов.
Просматривайте все активные процессы в одном удобном месте. Наведите курсор на изображение, чтобы увидеть пример просмотра всех закрытых процессов.

Для каждой записи отображается следующая информация (где применимо):

  • Status — состояние процесса. Оно может быть одним из следующих:
    • Active — процесс в данный момент активен, и связанный с ним workflow выполняется.
    • On hold — процесс в данный момент активен, но ожидает начального ввода, например назначения исполнителя, прежде чем workflow сможет продолжиться.
    • Closed — процесс теперь закрыт, например успешно завершен или отклонен.
    • Terminated — процесс теперь закрыт и был принудительно остановлен непосредственно администратором Workspace.
  • Process Name — имя определения процесса.
  • Title — это поле используется для различения нескольких экземпляров одного и того же процесса. Заголовок представляет собой имя процесса с суффиксом экземпляра (#1, #2 и так далее).
  • State — это текущее состояние, достигнутое в связанном с процессом workflow.
  • Assignee (только для активного процесса) — пользователь, у которого сейчас есть задача, необходимая для продвижения процесса из его текущего состояния workflow.
  • Started By — пользователь, который инициировал процесс.
  • Started At — дата и время запуска процесса.
  • Ended At (только для закрытого процесса) — дата и время закрытия процесса.

Для активного процесса также доступен элемент управления Terminate (). Нажмите его, чтобы принудительно завершить процесс. Процесс будет перемещен в список процессов Closed.

Процессы можно сортировать по любому столбцу, содержащему элемент управления — нажмите на этот элемент или на имя столбца. Также можно выполнять поиск с помощью поля Search в верхней части списка. Для поиска можно использовать данные всех полей, кроме Status, Started At, Ended At и Terminate.
  • Вы также можете импортировать ранее экспортированное определение процесса из файла непосредственно на вкладке Browser . Для этого нажмите кнопку . В появившемся диалоговом окне Open найдите и откройте нужный файл Workflow (*.aaw). Правильная тема процесса будет определена автоматически, а содержимое файла будет загружено в Process Workflow Editor. Дополнительную информацию см. в разделе Импорт/экспорт определения процесса.
  • Используйте кнопку , чтобы экспортировать отчет о текущем списке действий (Process Workflows) в виде подробного файла *.csv с разделителями-запятыми — посмотреть пример. Active или Closed действия могут быть экспортированы, а включаемые записи можно отфильтровать с помощью поля имени процесса Search. Со стороны проектирования в панели Altium Designer Explorer panel также есть аналогичная кнопка — на вкладке Activites при просмотре проекта (в режиме по умолчанию Project ) — для загрузки текущих отображаемых данных о действиях, относящихся к этому проекту.

Щелкните запись процесса, чтобы просмотреть диаграмму его базового workflow (на вкладке Diagram под списком), показывающую, что должно произойти для завершения процесса и на каком этапе потока сейчас находится этот процесс, включая то, у кого в данный момент есть задача для его дальнейшего продвижения.

Нажмите элемент управления в правом нижнем углу, чтобы выделить текущую достигнутую точку в workflow — запись пользователя(ей) кратковременно мигнет.

Просмотр базового workflow для выбранного процесса на вкладке Diagram. Каждый workflow построен в виде диаграммы, что позволяет сразу видеть, на каком этапе workflow находится процесс в данный момент и у кого следующая задача для продолжения его выполнения.Просмотр базового workflow для выбранного процесса на вкладке Diagram. Каждый workflow построен в виде диаграммы, что позволяет сразу видеть, на каком этапе workflow находится процесс в данный момент и у кого следующая задача для продолжения его выполнения.

Также доступны следующие дополнительные вкладки:

  • Data — показывает все относящиеся к процессу данные. Например, для процесса проверки проекта сюда могут входить проект и его набор данных, тип проверки, участники проверки и любые дополнительные вложения. Для процесса запроса компонента сюда могут входить прикрепленные datasheet, параметрические данные и любые предварительные компоненты.

    Применимые сущности, такие как вложения, datasheet, проект и набор данных проекта (Item-Revision), будут отображаться как гиперссылки для быстрого перехода или открытия. Также у вас есть возможность настроить, какие параметрические данные будут видны обычному пользователю на этой вкладке. При редактировании workflow процесса и при отсутствии выбранного элемента данные, которые могут отображаться на вкладке Data , перечислены на правой панели. Нажмите элемент управления Edit , чтобы открыть связанную с ним форму (<ProcessName> Data).
  • History — показывает историю действий, выполненных в рамках workflow процесса.

    Используйте вкладки Data и History для просмотра соответственно более подробной информации о процессе и журнала его workflow-активности.Используйте вкладки Data и History для просмотра соответственно более подробной информации о процессе и журнала его workflow-активности.

Вкладки Part Requests/Project Activities/Project Creations

Используйте эти вкладки, которые объединяют процессы по определенным темам, чтобы просматривать, создавать и управлять process workflows, используемыми соответственно при запросе нового библиотечного компонента Workspace, проведении проверок проекта или публикации в PLM-систему, а также при создании новых проектов разработки.

По умолчанию в верхней области вкладки отображаются все Latest версии определенных процессов в рамках темы. Переключиться на просмотр All определенных процессов (то есть всех версий) можно с помощью раскрывающегося списка над перечнем.

Пример просмотра последних версий определенных процессов для конкретной темы (в данном случае темы Project Activities).Пример просмотра последних версий определенных процессов для конкретной темы (в данном случае темы Project Activities).

Для каждой записи отображается следующая информация:

  • Process Name : version — имя определения процесса и его версия. Чтобы гарантированно всегда просматривать/использовать последнюю версию, убедитесь, что раскрывающийся список версий над перечнем установлен в Latest.
  • Instances (active / all) — количество экземпляров этой версии определения процесса, которые в настоящий момент активны, а также общее количество экземпляров, которые были запущены.
  • Created By — пользователь, создавший эту версию определения процесса.
  • Created At — дата и время создания этой версии определения процесса (сохранения и развертывания).
  • Active — показывает, является ли данная версия определения процесса активной () и, следовательно, может использоваться, либо приостановленной (), либо примером (шаблоном) определения () и потому не может использоваться. Только активные определения процессов будут отображаться в соответствующей области GUI Altium Designer для использования разработчиками. Нажмите на значок, чтобы переключить состояние активности, если это применимо.

    Использоваться (быть активированной и запускаться) может только последняя версия определения процесса. Предыдущие версии использовать нельзя, однако их можно изменять для создания более поздней версии. Кроме того, примерные определения процессов (состояние Active которых обозначается как ) нельзя использовать сразу «из коробки». Каждое из них скорее является «шаблоном» — отредактируйте его в соответствии с требованиями вашей компании, задайте имя и сохраните как новое определение процесса, которое затем can активируете и используете наряду со всеми остальными определениями.
  • Actions — нажмите элемент управления  , чтобы открыть меню действий для определения процесса:
    • Startкак администратор, вы можете запустить новый экземпляр этой версии определения процесса, выбрав эту команду. Она доступна только если определение процесса активировано. Если процесс был приостановлен или является примером (шаблоном), команда будет неактивной, и экземпляр нельзя будет запустить.
    • Edit — выберите , чтобы изменить базовый workflow определения процесса. Диаграмма workflow для этой версии определения процесса будет показана в Process Workflow Editor в качестве отправной точки для работы. Любой Administrator может изменить любое определение процесса, созданное пользователем, независимо от того, кто первоначально создал это определение, и сохранить и развернуть его как следующую версию. Для стандартных определений процессов, поставляемых Altium, вы можете создать новое определение процесса на основе редактирования одного из них (по сути, форк), но не можете изменять сам исходный стандартный вариант. Дополнительную информацию о редактировании определения процесса см. в разделе Редактирование существующего определения процесса.
    • Assign — выберите, чтобы открыть окно Assign Access to This Workflow, в котором можно определить, какие пользователи и/или группы могут получать доступ к базовому workflow. Дополнительную информацию об управлении доступом к workflow см. в разделе Управление доступом к workflow процесса.
    • Remove — выберите, чтобы удалить эту версию определения процесса. Обратите внимание, что некоторые стандартные определения процессов, поставляемые Altium, удалить нельзя (и поэтому для них нет такого элемента управления). Если был запущен хотя бы один экземпляр определения процесса, независимо от того, активен он еще или нет, определение удалить нельзя (команда не будет отображаться в меню).
Определения процессов можно сортировать по любому столбцу, содержащему элемент управления — нажмите на этот элемент или на имя столбца. Также можно выполнять поиск с помощью поля Search в верхней части списка. Для поиска можно использовать данные в столбцах Process Name : version и Created By.

Щелкните запись определения процесса, чтобы просмотреть его workflow в виде диаграммы на вкладке Diagram под списком. Если существует текущий активный экземпляр процесса, представление покажет, на каком этапе потока находится этот процесс, включая то, у кого в данный момент есть задача для его дальнейшего продвижения.

Если активно несколько экземпляров процесса, представление Diagram покажет объединенное состояние. Нажмите элемент управления в правом нижнем углу, чтобы выделить текущую достигнутую точку в workflow — запись пользователя(ей) кратковременно мигнет.

Просмотр базового workflow для выбранного процесса на вкладке Diagram.Просмотр базового workflow для выбранного процесса на вкладке Diagram.

Стандартные определения процессов

В составе установки Enterprise Server Altium предоставляет ряд определений процессов — для трех тем процессов. Некоторые из них активированы и готовы к использованию сразу после установки и могут использоваться как есть, тогда как другие являются примерами — их нельзя активировать и использовать напрямую. Все они могут служить отправной точкой для создания собственных определений процессов по мере необходимости. Используйте следующие сворачиваемые разделы для получения информации о предоставляемых определениях процессов.

Установка Enterprise Server также включает процесс LibSync, который синхронизирует данные компонентов между Enterprise Server и целевым экземпляром PLM. Это встроенный workflow процесса только для чтения, поэтому он не редактируется и не включается в список процессов на странице Processes Workspace (Admin » Processes). Дополнительную информацию см. в разделе Синхронизация компонентов PLM.

Добавление нового определения процесса

Related page: Определение workflow процесса

Новые процессы можно создавать с помощью специального Process Workflow Editor. Чтобы открыть редактор, активируйте вкладку темы, в рамках которой вы хотите создать новый процесс, затем нажмите кнопку в правом верхнем углу страницы.

Важно сначала активировать тему, чтобы процесс был создан с правильным Type.

Открытие Process Workflow Editor. Если перед открытием сделать активной нужную тему процесса, новое определение процесса будет отнесено к правильному типу темы.Открытие Process Workflow Editor. Если перед открытием сделать активной нужную тему процесса, новое определение процесса будет отнесено к правильному типу темы.

Дайте новому определению процесса понятное имя, затем постройте workflow графически и задайте необходимые параметры каждого элемента этого потока. Для пользовательских задач используется User Form Editor для создания нужной формы, которая будет показана пользователю для ввода данных, когда ему будет назначена задача в соответствующей точке workflow.

Мощный Process Workflow Editor обеспечивает гибкость, позволяя создавать процессы с workflows любой необходимой степени простоты или сложности — в соответствии с требованиями вашей компании.Мощный Process Workflow Editor обеспечивает гибкость, позволяя создавать процессы с workflows любой необходимой степени простоты или сложности — в соответствии с требованиями вашей компании.

После того как процесс будет определен нужным образом, нажмите кнопку , чтобы добавить его в список доступных процессов для данной темы процесса. Новое определение процесса будет активировано и готово к использованию.

Редактор отметит все проблемы в вашей диаграмме workflow, которые мешают ее сохранить и развернуть — например, диаграмма должна содержать событие Start и как минимум одно событие End. Кроме того, User Task должна иметь хотя бы одно поле формы и Assignee.

Редактирование существующего определения процесса

Любой Administrator может изменить любое пользовательское определение процесса независимо от того, кто изначально создал это определение, и сохранить и развернуть его как следующую версию. Для этого нажмите  элемент управления в столбце Actions для определения процесса, которое требуется изменить, и выберите Edit в появившемся меню. Диаграмма рабочего процесса для этой версии определения процесса будет показана в Process Workflow Editor как отправная точка для дальнейшей работы.

Для определений процессов, поставляемых Altium, можно создать новое определение процесса на основе редактирования одного из них (по сути, выполнив ответвление), но изменить само определение по умолчанию нельзя.

Пример редактирования существующего определения процесса — доступ к Process Workflow Editor, где можно внести необходимые изменения.Пример редактирования существующего определения процесса — доступ к Process Workflow Editor, где можно внести необходимые изменения.

При необходимости внесите изменения в схематический рабочий процесс, включая любые изменения форм, связанных с пользовательскими задачами, затем нажмите кнопку , чтобы фактически сохранить определение как следующую версию. В данном примере исходное определение процесса Company Pre-release Review : 1 (версия 1) изменяется и сохраняется как Company Pre-release Review : 2 (версия 2).

После внесения изменений сохраните и разверните следующую версию этого определения процесса.После внесения изменений сохраните и разверните следующую версию этого определения процесса.

Используя раскрывающееся поле в левом верхнем углу и установив значение All, вы можете увидеть все версии существующих определений процессов. На изображении ниже показаны обе версии определения процесса Company Pre-release Review.

Показаны все версии примерного определения процесса Company Pre-release Review. Обратите внимание, что активировать и использовать можно только последнюю версию (версия 2).Показаны все версии примерного определения процесса Company Pre-release Review. Обратите внимание, что активировать и использовать можно только последнюю версию (версия 2).

Использоваться может только последняя версия определения процесса (ее можно сделать активной и запустить). Однако предыдущие версии можно использовать как отправную точку для создания более поздней версии. Если удалить последнюю версию определения процесса, то предыдущая версия фактически станет последней и ее снова можно будет сделать активной и использовать (запускать экземпляры).

Импорт/экспорт определения процесса

Определения процессов можно экспортировать и импортировать, что позволяет быстро повторно использовать их в разных экземплярах Enterprise Server — это действительно экономит время, если базовый рабочий процесс особенно сложен и необходимость, как говорится, «изобретать велосипед» заново была бы весьма трудоемкой задачей.

Для импорта:

  1. Откройте вкладку темы (Part Requests, Project Activities, Project Creations), соответствующую определению процесса, которое вы хотите импортировать.

    Если попытаться импортировать определение процесса не в ту тему, программа предупредит об этом, и импорт будет предотвращен.
  2. Нажмите кнопку , чтобы создать новое определение процесса и открыть Process Workflow Editor.
  3. Нажмите кнопку . В появившемся диалоговом окне Open перейдите к нужному файлу Workflow (*.aaw) и откройте его. Содержимое файла полностью перезапишет все, что в данный момент определено для этого определения процесса (имя, диаграмму и т. д.).
Также можно импортировать ранее экспортированное определение процесса из файла непосредственно на вкладке Browser интерфейса. Для этого нажмите кнопку . В появившемся диалоговом окне Open перейдите к нужному файлу Workflow (*.aaw) и откройте его. Корректная тема процесса будет определена автоматически, а содержимое файла будет загружено в Process Workflow Editor.

Для экспорта:

  1. Нажмите элемент управления  в столбце Actions для нужной версии определения процесса, которую вы хотите экспортировать, и выберите Edit в появившемся меню, чтобы перейти в режим редактирования.
  2. В Process Workflow Editor нажмите кнопку . Определение процесса будет экспортировано как файл Workflow (<ProcessDefinitionName>.aaw) в папку загрузок по умолчанию, заданную в вашем браузере.
  3. Нажмите запись Processes в левом навигационном дереве браузерного интерфейса Workspace, чтобы выйти из Process Workflow Editor, не внося никаких изменений в определение процесса.

Управление доступом к рабочему процессу

Как администратор, вы можете определить, какие пользователи и/или группы могут получать доступ к рабочему процессу. Для этого нажмите элемент управления  в столбце Actions для определения процесса, для которого требуется настроить доступ к базовому рабочему процессу, и выберите Assign в появившемся меню. Откроется окно Assign Access to This Workflow.

Начните вводить полное имя или имя пользователя пользователя либо имя группы в текстовом поле, чтобы открыть всплывающий список подходящих пользователей/групп. Можно добавить несколько пользователей/групп. Чтобы удалить добавленного пользователя/группу из списка имеющих доступ к рабочему процессу, нажмите крестик удаления справа от их имени.

После задания нужных пользователей/групп нажмите , чтобы применить назначение рабочего процесса. Теперь рабочий процесс будет доступен только добавленным пользователям/группам (и участникам группы Administrators) при доступе, описанном в разделе Designer Access to Process Workflows ниже.

Как указано в окне Assign Access to This Workflow, если не добавлен ни один пользователь/группа, рабочий процесс будет доступен всем пользователям.

Доступ дизайнера к рабочим процессам

Related pages: Выполнение проверок проекта, Публикация в PLM, Запросы компонентов на основе процессов

После того как необходимый набор определений процессов для каждой доступной темы процессов будет создан в соответствии с требованиями вашей компании, те определения, которые были активированы, станут доступны для использования назначенным пользователям после их подключения к Workspace Enterprise Server. В следующих разделах рассматривается, где разработчик может получить доступ к этим активным процессам и запустить их — как через Altium Designer, так и через браузерный интерфейс Workspace.

Администраторы Workspace могут, как упоминалось ранее, запустить новый экземпляр любого активированного определения процесса — непосредственно с соответствующей вкладки темы процесса в области Processes браузерного интерфейса Workspace — нажав элемент управления  в столбце Actions и выбрав Start в появившемся меню.

Запросы компонентов

Related page: Запросы компонентов на основе процессов

В Altium Designer активированные определения процессов, относящиеся к теме Part Requests, доступны в следующих местах:

  • На панели Components panel. Щелкните правой кнопкой мыши в основной области панели — активные определения процессов запроса компонентов доступны в подменю Operations » Submit Request. Либо нажмите ссылку Submit request в разделе Need more components?.

Если для темы процессов Part Requests нет доступных активных определений процессов, подменю Submit Request не будет отображаться. Для обновления может потребоваться выйти из Workspace и войти снова либо перезапустить Altium Designer.
  • На панели Manufacturer Part Search panel. Если у текущего выбранного результата поиска есть значок , на панели Information (доступной по щелчку ) будет показана кнопка . Нажмите раскрывающуюся часть кнопки, чтобы открыть меню активных определений процессов запроса компонентов. При прямом нажатии на основную часть кнопки будет запущено первое определение процесса в списке.
Отправка запроса на компонент через панель Manufacturer Part Search дает дополнительное преимущество: ключевая информация будет заполнена автоматически, включая все таблицы данных и параметрическую информацию.

Если для темы процессов Part Requests нет доступных активных определений процессов, кнопка не будет отображаться. Для обновления может потребоваться выйти из Workspace и войти снова либо перезапустить Altium Designer.

Если у текущего выбранного результата поиска есть значок , активные определения процессов запроса компонентов будут доступны в меню, связанном с кнопкой (нажмите раскрывающуюся часть кнопки).

Активные определения процессов запроса компонентов также доступны из контекстного меню основной области панели, в подменю Submit Request.

Если для темы процессов Part Requests нет доступных активных определений процессов, подменю Submit Request не будет отображаться. Для обновления может потребоваться выйти из Workspace и войти снова либо перезапустить Altium Designer.
  • На панели Explorer panel, в папке Part requests или после выполнения поиска. Будет доступна кнопка , при нажатии на которую будут показаны активные определения процессов запроса компонентов на выбор.

Обратите внимание, что если включена функция Legacy Part Requests feature, кнопка будет отображаться как . В меню также появится дополнительный пункт, относящийся к новым запросам компонентов с использованием этой устаревшей функциональности. Он будет иметь суффикс (Legacy). Если для темы процессов Part Requests нет доступных активных определений процессов и функция Legacy Part Requests не включена, кнопка Submit Request отображаться не будет. Для обновления может потребоваться выйти из Workspace и войти снова либо перезапустить Altium Designer.

В браузерном интерфейсе Workspace активированные определения процессов, относящиеся к теме Part Requests, доступны на странице Part Requests по нажатию кнопки в правом верхнем углу страницы.

Доступ к активированным определениям Part Requests со страницы Part Requests браузерного интерфейса Workspace.Доступ к активированным определениям Part Requests со страницы Part Requests браузерного интерфейса Workspace.

Если для темы процессов Part Requests нет доступных активных определений процессов, кнопка будет недоступна. Если существует только одно определение процесса, кнопка не будет иметь раскрывающейся функциональности и сразу запустит этот процесс при нажатии.

Действия по проекту

Related pages: Выполнение проверок проекта, Публикация в PLM, Интеграция с PLM.

Активированные определения процессов, относящиеся к теме Project Activities, доступны в различных местах.

Проверка проекта и стандартная публикация в PLM

В Altium Designer активированные определения процессов проверки проекта и публикации — относящиеся к теме Project Activities — доступны из контекстного подменю Project Activities, вызываемого щелчком правой кнопкой мыши по записи проекта в панели Projects panel, либо из главного меню Project » Project Activities.

Если для темы процессов Project Activities нет доступных активных определений процессов проверки проекта и стандартной публикации в PLM, меню отображаться не будут.

В браузерном интерфейсе Workspace активированные определения процессов проверки проекта и публикации — относящиеся к теме Project Activities — доступны на странице Projects интерфейса. Выберите нужный проект, затем нажмите кнопку .

Доступ к активированным определениям Project Activities (проверка проекта и стандартная публикация в PLM) для проекта Workspace в области Projects браузерного интерфейса Workspace.Доступ к активированным определениям Project Activities (проверка проекта и стандартная публикация в PLM) для проекта Workspace в области Projects браузерного интерфейса Workspace.

Если для темы процессов Project Activities нет доступных активных определений процессов проверки проекта и стандартной публикации в PLM, кнопка отображаться не будет.

Публикация в PLM через Project Releaser

В Altium Designer процесс публикации в экземпляр PLM как часть Project Releaser доступен из подменю Project » Project Releaser для активного проекта либо по щелчку правой кнопкой мыши по записи проекта в панели Projects panel с последующим выбором процесса в пункте контекстного меню Project Releaser.

Создание проектов

В Altium Designer активированные определения процессов, относящиеся к теме Project Creations, доступны в трех местах:

  • В главном подменю File » New » Project in <WorkspaceName>.

  • В контекстном подменю Convert to Managed Project, вызываемом щелчком правой кнопкой мыши по записи локального проекта на панели Projects.

  • В контекстном подменю Clone, вызываемом щелчком правой кнопкой мыши по записи проекта в диалоговом окне Open Project dialog, когда выбрано расположение Workspace.

Обратите внимание, что когда активно хотя бы одно определение процесса для темы Project Creations, возможность создать новый проект Workspace через диалоговое окно Create Project dialog (File » New » Project) отключается — подключенный Workspace недоступен как целевое расположение. Regular Проекты типа (Local) и VCS можно создавать через это диалоговое окно как обычно.

Если для темы процессов Project Creations нет доступных активных определений процессов — что является состоянием по умолчанию при новой установке Enterprise Server — меню процессов отображаться не будут, и вы сможете создавать проект Workspace через диалоговое окно Create Project как обычно.

Также обратите внимание, что в этой конфигурации по умолчанию команда Convert to Managed Project изменяется на Make Project Available on Server.

В браузерном интерфейсе Workspace активированные определения процессов, относящиеся к теме Project Creations, доступны в следующих местах:

  • На главной странице интерфейса Projects по нажатию кнопки .

Доступ к активированным определениям Project Creations из основной области Projects браузерного интерфейса Workspace.Доступ к активированным определениям Project Creations из основной области Projects браузерного интерфейса Workspace.

  • На странице Projects интерфейса, когда требуется клонировать определенный проект. Выберите нужный проект, затем нажмите кнопку , чтобы открыть процессы в меню.

Доступ к активированным определениям Project Creations при необходимости клонировать проект Workspace в области Projects браузерного интерфейса Workspace.Доступ к активированным определениям Project Creations при необходимости клонировать проект Workspace в области Projects браузерного интерфейса Workspace.

  • Если для темы процессов Project Creations нет доступных активных определений процессов — что является состоянием по умолчанию при новой установке Enterprise Server — меню предложит базовую функциональность клонирования проекта (Clone). Это не связано с функциональностью рабочего процесса.
  • Чтобы использовать Constraint Manager для управления ограничениями проекта в вашем PCB-проекте Workspace, основанном на процессе, обязательно назначьте подходящий шаблон проекта при создании этого проекта. Это должен быть шаблон, сохраненный из PCB-проекта, который был создан с включенной опцией Constraint Management в диалоговом окне Create Project dialog.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Content