Opening Projects and Documents in Altium Designer

To work on a project in Altium Designer, it should be opened first. This is performed directly from within Altium Designer using the Open Project dialog accessed by selecting the File » Open Project command from the main menus. The Open Project dialog provides a single location to open, search for and browse projects.

Opening a Project Using the Open Project Dialog

Opening a Workspace Project

To work on a Workspace project, you effectively check it out as a local working copy. What happens once the File » Open Project command is selected depends on whether you are a member of the Workspace team or have been shared a project outside of the Workspace team.

Workspace Team Member

The Open Project dialog will open in which you can choose which Workspace project to open from your connected Workspace (when connected to a Workspace, that Workspace will appear in the Locations region of the dialog, distinguished by the icon, and appear with the name given to the Workspace). Only those Workspace projects that have been shared with you (you have permission to access them) will be listed.

The Open Project dialog when the Workspace location is selected
The Open Project dialog when the Workspace location is selected

For each project in the list, the following information is presented:

  • Name – the name of the project; the location path of the project appears below the name.
  • Last Modified – the date and time the project was last modified. The date and time display in accordance with your personal computer settings. To configure each project's modification dates and times in a specific format, you can do so in your computer's system Region settings.

    The Name and Last Modified columns can be sorted in ascending or descending order by clicking (and toggling) the header for each column.

To view and navigate through the project folder hierarchy, select the folder view button () to access project folders and the breadcrumb path in the dialog’s Search bar.

The project list view in the dialog. Hover the cursor over the image to see the folder structure view.
The project list view in the dialog. Hover the cursor over the image to see the folder structure view.

When the folder view is enabled in the dialog and if you have projects located in a folder, a folder entry () will appear, which you can double-click to view the existing projects located within.

When is clicked, the right-hand side of the dialog displays additional details about the selected project, including the basic project information (the General tab of the details pane) and all project Parameters (the Parameters tab of the details pane).

Once opened by clicking the Open button, the project will appear under an entry for the Workspace, in the Projects panel.

Choose which Workspace project to open from your connected Workspace within Altium Designer from those currently shared with you.
Choose which Workspace project to open from your connected Workspace within Altium Designer from those currently shared with you.

  • You have the option to open the project to the default checkout path or use the drop-down menu to specify a custom path. The default checkout path is defined as a property of the design repository in which the project resides. For a Git repository (e.g. the Versioned Storage repository that is native to the Workspace), this is the Local Path field found in the Git Repository dialog. For an SVN repository, this is the Default Checkout Path field found in the SVN Design Repository dialog. Access the properties dialog by selecting the entry for the repository on the Data Management – Design Repositories page of the Preferences dialog then clicking the button.
  • Choose the Open Project As Copy option to create a cloned version of the project under a different name. Learn more about Cloning a Project.

When accessing the Altium 365 location of the Open Project dialog before signing in to your Altium account, connecting to a Workspace or activating a Workspace, the right-hand side of the dialog will display the relevant text and controls.

Invited Stakeholder Outside of the Workspace Team

The Open Project dialog will open in which you can access any Workspace project that has been shared with you from the Shared With Me location.

The Open Project dialog when the Shared With Me location is selected
The Open Project dialog when the Shared With Me location is selected

For each project in the list, the following information is presented:

  • Name – the name of the project.
  • Created By – the name of the person who created the project.
  • Last Modified – the date and time the project was last modified. The date and time display in accordance with your personal computer's settings. To configure each project's modification dates and times in a specific format, you can do so in your computer's system Region settings.

    The Name and Last Modified columns can be sorted in ascending or descending order by clicking (and toggling) the header for each column.

Once opened by clicking the Open button, the selected project will appear under the entry Shared with me, in the Projects panel. What you can do with the project depends on the access rights you have been given to it. If editing rights were assigned to you, you will be able to edit the design normally, which would typically be the case for an external contractor. If you have viewing rights only, you will be able to comment on the WIP design.

The projects that are available under Shared With Me are those that have been shared with your sign-in name (your Altium account) from an Altium 365 Workspace. Note that Altium Designer does not need to be connected to a Workspace to access shared projects.

Choose which Workspace project to open, from within Altium Designer, from those currently shared with you as an external stakeholder. Note that access is made to such projects without having access to the Workspace.
Choose which Workspace project to open, from within Altium Designer, from those currently shared with you as an external stakeholder. Note that access is made to such projects without having access to the Workspace.

You have the option to open the project to the default checkout path or use the drop-down menu to specify a custom path. The default checkout path is taken from the Document Path field on the System – Default Locations page of the Preferences dialog.

When an updated project file name has been synchronized to the Workspace, the Workspace automatically changes the Workspace project's Name parameter to match. Conversely, when the name of a Workspace project is updated in the Workspace (via the Edit mode on the Workspace Projects page or the design client's Explorer panel), the change is propagated to the client-side when the project is next opened. When the updated project is opened (File » Open Project), the Name of the project and project file name are different dialog will open, providing the option to align the project file name with the new project Name, force the project Name to match the existing project file name, or allow the two names to be different.

Opening a Local Project

Select the Local Projects location to see the list of projects stored in the current default location as specified in the System – Default Locations page of the Preferences dialog.

The Open Project dialog when the Local Projects location is selected
The Open Project dialog when the Local Projects location is selected

For each project in the list, the following information is presented:

  • Name – the name of the project; the location path of the project appears below the name. You may double-click the folder icon () to view the existing contents located within.
  • Last Modified – the date and time the project was last modified. The date and time display in accordance with your personal computer's settings. To configure each project's modification dates and times in a specific format, you can do so in your computer's system Region settings.

    The Name and Last Modified columns can be sorted in ascending or descending order by clicking (and toggling) the header for each column.

When is clicked, the right-hand side of the dialog displays the name, last modified date/time and location of the project currently selected in the list.

Once opened by clicking the Open button, the selected project will appear in the Projects panel.

Click the Browse button at the bottom left of the Open Project dialog to browse to and open a project through the Windows Open dialog.

Opening a Recent Project

Select the Recent location to see the list of recently opened projects from local or Workspace sources.

The Open Project dialog when the Local Projects location is selected
The Open Project dialog when the Local Projects location is selected

For each project in the list, the following information is presented:

  • Name – the name of the project; the location path of the project appears below the name.
  • Last Modified – the date and time the project was last modified. The date and time display in accordance with your personal computer's settings. To configure each project's modification dates and times in a specific format, you can do so in your computer's system Region settings.

    The Name and Last Modified columns can be sorted in ascending or descending order by clicking (and toggling) the header for each column.

When is clicked, the right-hand side of the dialog displays the name, last modified date/time and location of the project currently selected in the list.

Recent projects, documents and project groups can also be opened through the File main menu: learn more.

Searching for a Project

Use the Search field at the top of the Open Project dialog to filter the project list by entering alpha/numeric characters. When opening Workspace projects, the Search filter will also respond to Parameters/Value pairs available from Workspace projects. These include Project and Workspace parameters, and the Analytics parameters generated by the Workspace.

Click the  icon at the right of the Search bar to remove the currently defined search string.

When viewing the list of Workspace projects (in the folder structure view) or the list of local projects, the path to the currently selected folder will be shown in the Search bar. Click on a folder name to show the content of this folder in the dialog. Click the  button at the right of the bar or use the Alt + Up Arrow shortcut to show the content of the folder one level higher.

Project Groups

In Altium Designer, you can open and edit multiple projects, and if desired, save the collective set of projects as a Project Group (*.DsnWrk). In the Projects panel, the entry of the current Project Group – either the default one (Project Group 1.DsnWrk), or one you have created or opened – is shown with the   icon.

This can be of particular advantage when the set of projects is related or linked, such as a product design that is composed of multiple PCBs. Creating a Project Group that includes all the relevant projects allows you to open, manipulate, and save multiple projects as a single entity.

A default design Project Group (ProjectGroup1.DsnWrk) is assigned to the Projects panel when:

  • No specific design Project Group has been opened.
  • The creation of a new design Project Group is specified.
  • When all open projects and documents - part of a specific design Project Group or not - are closed.

This default design Project Group is initially unsaved. Its name is used as the default entry in the Save As dialog, when you proceed to save the design Project Group.

Opening a Document

To open a document, double-click it in the Projects panel or right-click its entry and select Open command from the context menu. Multiple documents may be opened simultaneously and each open document has its own tab on the Documents Bar at the top of the design window.

If you have enabled the Opens and shows documents/objects option in the Single Click region on the System - Projects Panel page of the Preferences dialog, then a single click on a document's entry in the panel will open it in the main design window.

You can also open documents as follows:

  • By choosing the File » Open command from an editor's main menus (the button on the Quick Access Bar; shortcut: Ctrl+O). Any document that is opened this way will be opened as a free document (appearing in the relevant sub-folder of the Free Documents folder in the Projects panel) and made the active document in the main design window. Any project file that is opened will be added to the Projects panel and made the focused project.
  • All documents within the focused category (sub-folder) in the Projects panel can be opened by right-clicking on the entry for the required category, then choosing the Open All command from the context menu.
  • All schematic documents of the focused project can be opened by right-clicking on a Source Document folder that contains schematic documents, then selecting the Open All Schematic Documents command from the context menus.
  • One or more documents, either in the currently focused project or all open projects in the active design project groups, can be opened by choosing the Project » Project Documents command from the main menus (shortcut: Alt+Ctrl+O).

    After launching the command, the Open Project Documents dialog will open. Use this dialog to select the documents that you want to open. You can restrict the view to only list documents in the project that is currently focused in the Projects panel or all projects open in the active design project groups. Use the standard Windows shortcuts (Ctrl+Click and Shift+Click) to select multiple items from the list. With the required document(s) selected, clicking OK will cause those documents to be opened.

    The Open Project Documents dialog
    The Open Project Documents dialog

    • You can also double-click on the document name in the dialog to open it.
    • All selected documents will be opened as tabbed document views in the main design window. The last document selected will be the last document opened, with its parent project becoming the active project (and also the focused project) in the Projects panel.
    • To display the current status of documents in the Projects panel, click the button at the top of the panel, then enable the Open/modified status option within the Sorting grouping of pop-up controls. Alternatively, enable this option on the System - Projects Panel page of the Preferences dialog.
Alternatively, you can drag and drop a document, project file, or project group file directly into Altium Designer to open it.

Closing Projects and Documents

To close the currently focused project in the Projects panel, right-click on its entry and choose the Close Project command, from the context menu. The active project can be closed by choosing the Project » Close Project command, from the main menus.

Right-click on any document tab to access a drop-down of commands to close the document on which you right-clicked, close all documents of the same editor (e.g., all PcbDoc, all SchLib, or all PcbLib documents) as the one on which you right-clicked, or close all open documents.

Open documents can also be closed from the following locations:

  • an open document can be closed by right-clicking on its entry in the Projects panel and choosing the Close command from the context menu.
  • the active document can be closed by choosing the File » Close command from the main menus (shortcut: Ctrl+F4).
  • all currently open documents associated with the active project can be closed by choosing the Project » Close Project Documents command from the main menus.
  • all currently open documents associated with the focused project in the Projects panel can be closed by right-clicking on the entry for the required project and choosing the Close Project Documents command from the context menu.
  • all open documents within the focused sub-folder in the Projects panel can be closed by right-clicking on the entry for the required category (sub-folder) and choosing the Close All command from the context menu.
  • all currently open documents can be closed by choosing the Window » Close Documents command from the main menus.
  • all currently open documents and projects in the current Design Project Group can be closed by choosing the Window » Close All or File » New » Design Project Group command from the main menus.

The entry of a free document will be removed from the Projects panel upon closure.

Примечание

Доступные функциональные возможности зависят от вашего уровня Подписки на ПО Altium Designer.

Content