Xác thực một linh kiện
Trước khi lưu một linh kiện Workspace Library được định nghĩa/chỉnh sửa trong trình chỉnh sửa linh kiện (ở chế độ Single Component Editing hoặc Batch Component Editing) vào connected Workspace và làm cho linh kiện đó sẵn sàng để sử dụng trong các thiết kế, điều cần thiết là phải bảo đảm rằng linh kiện này đáp ứng các yêu cầu theo đúng các thiết lập đã cấu hình. Khi bạn cố gắng lưu một linh kiện trở lại Workspace, trình chỉnh sửa linh kiện sẽ chạy một bước xác thực – Component Rule Check. Tính năng này cũng có thể được chạy thủ công vào bất kỳ lúc nào bằng cách chọn lệnh Tools » Component Rule Check từ các menu chính. Hãy bảo đảm rằng bạn đã lưu linh kiện cục bộ (File » Save) trước khi thực hiện việc này.
Tương tự như một dự án bo mạch có quy trình xác thực để phát hiện mọi vi phạm, trình chỉnh sửa linh kiện cũng có chức năng xác thực linh kiện. Mọi vi phạm được tìm thấy sẽ được liệt kê trong panel Messages.
Việc xác thực linh kiện kiểm tra một loạt vấn đề tiềm ẩn với linh kiện và các mô hình đã định nghĩa của nó – bao gồm cả các phép kiểm tra được mã hóa sẵn, cũng như nhiều loại vi phạm có thể do người dùng định nghĩa ở cấp toàn cục.
Các kiểm tra xác thực được mã hóa sẵn sau đây đều có chế độ báo cáo là
:
Folder path not specified for component
Tóm tắt
Vi phạm này xảy ra khi chưa chỉ định thư mục trong Workspace đích, nơi linh kiện đang được định nghĩa trong Component Editor sẽ được lưu.
Thông báo
Một thông báo sẽ được hiển thị trong panel Messages theo định dạng sau:
Folder path not specified for component <ItemID>
trong đó:
- ItemID là ID được dùng cho linh kiện trong Workspace.
Khuyến nghị khắc phục
-
Trong Component Editor ở Single Component Editing mode, sử dụng trường Folder trong Component để chỉ định một thư mục trong Workspace đích, nơi linh kiện sẽ được lưu. Để chỉ định thủ công một thư mục đích, nhấp nút
để mở hộp thoại Choose Folder. Duyệt đến và chọn một thư mục hiện có, hoặc tạo thư mục mới ngay tại đó.
-
Trong Component Editor ở Batch Component Editing mode, sử dụng trường FolderPath (trong nhóm cột Component) ở vùng định nghĩa linh kiện của trình chỉnh sửa để chỉ định một thư mục trong Workspace đích, nơi linh kiện sẽ được lưu. Để chỉ định thủ công một thư mục đích, nhấp một lần vào bên trong trường FolderPath của linh kiện để hiện nút
, rồi nhấp để mở hộp thoại Choose Folder. Duyệt đến và chọn một thư mục hiện có, hoặc tạo thư mục mới ngay tại đó.
Component not having a unique Id
Tóm tắt
Vi phạm này xảy ra khi Item ID của một linh kiện đang được định nghĩa trong Component Editor trùng với Item ID của một mục khác trong connected Workspace.
Thông báo
Một thông báo sẽ được hiển thị trong panel Messages theo định dạng sau:
Duplicate Component Id: "<ItemID>"
trong đó:
- ItemID là ID được dùng cho linh kiện trong Workspace.
Khuyến nghị khắc phục
-
Trong Component Editor ở Single Component Editing mode, sử dụng trường Id trong vùng Component để chỉ định một ID khác là duy nhất đối với nội dung trong Workspace được kết nối.
-
Trong Component Editor ở Batch Component Editing mode, sử dụng trường Item ID trong nhóm cột Component của vùng định nghĩa linh kiện để chỉ định một ID khác là duy nhất đối với nội dung trong Workspace được kết nối.
Lưu ý
Vi phạm này thường xảy ra khi giá trị Item ID được gán tự động của một linh kiện bị ghi đè thủ công. Với một linh kiện mới được tạo thông qua lệnh File » New » Component hoặc panel Components , trường này được điền theo đúng mẫu linh kiện được định nghĩa cho loại linh kiện đã chọn trong hộp thoại Create new component dialog. Khi không tồn tại mẫu, hoặc khi mục <Undefined> được chọn trong hộp thoại, một sơ đồ đặt tên mặc định sẽ được sử dụng; CMP-{00000}. Với một linh kiện mới được tạo thông qua panel Explorer , trường này được điền theo sơ đồ đặt tên mặc định đã chỉ định cho thư mục cha của linh kiện đó. Nếu thư mục cha có đính kèm một mẫu linh kiện, thì Component Naming đã định nghĩa sẽ được lấy từ mẫu đó. Phần mềm sẽ tự động gán ID duy nhất khả dụng tiếp theo, dựa trên sơ đồ đó, sau khi quét toàn bộ Workspace và các định danh của nội dung hiện có.
Các kiểm tra do người dùng định nghĩa được cấu hình trên trang Data Management – Component Rule Checks page của hộp thoại Preferences.
Bất kỳ phép kiểm tra mã hóa sẵn nào không đạt hoặc các kiểm tra do người dùng định nghĩa ở mức Fatal Error sẽ ngăn không cho lưu linh kiện vào Workspace.
Các thiết lập mặc định của các kiểm tra do người dùng định nghĩa có thể không phù hợp với các linh kiện của bạn, vì vậy điều quan trọng là phải làm quen với các tùy chọn này và cách cấu hình chúng để phù hợp với thiết kế của bạn. Thông tin về từng kiểm tra lỗi do người dùng định nghĩa có thể được tìm thấy bên dưới.
Các vi phạm liên quan đến linh kiện
Duplicate component by Name
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi tên của một linh kiện đang được định nghĩa trong Component Editor trùng với tên của một linh kiện trong connected Workspace.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Duplicate component by Name
Khuyến nghị khắc phục
Gán (các) tên khác và duy nhất cho (các) linh kiện theo yêu cầu.
-
Trong Component Editor ở Single Component Editing mode, sử dụng trường Name trong vùng Component để chỉ định một tên khác là duy nhất đối với các linh kiện trong Workspace được kết nối.
-
Trong Component Editor ở Batch Component Editing mode, sử dụng trường Item ID trong nhóm cột Component của vùng định nghĩa linh kiện để chỉ định một tên khác là duy nhất đối với các linh kiện trong Workspace được kết nối.
Duplicate component by PCL
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một linh kiện đang được định nghĩa trong Component Editor có một Part Choice đang được một linh kiện khác trong connected Workspace sử dụng.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Duplicate component by Part Choice list
Khuyến nghị khắc phục
Gán (các) Part Choice khác và duy nhất cho (các) linh kiện theo yêu cầu.
-
Trong Component Editor ở Single Component Editing mode, sử dụng vùng Part Choices để thay đổi danh sách Part Choice của linh kiện sao cho danh sách đó là duy nhất đối với các linh kiện trong Workspace được kết nối.
-
Trong Component Editor ở Batch Component Editing mode, sử dụng nhóm cột Part Choice n của vùng định nghĩa linh kiện để thay đổi danh sách Part Choice của linh kiện sao cho danh sách đó là duy nhất đối với các linh kiện trong Workspace được kết nối.
Invalid pin mappings
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một linh kiện đang được định nghĩa trong Component Editor có ánh xạ không rõ ràng giữa ký hiệu linh kiện và (các) footprint. Ví dụ, vi phạm xảy ra nếu ký hiệu có các chân được định nghĩa trong các trường Designator của chúng là 1, 2, 3, trong khi footprint có các pad được định nghĩa trong các trường Designator của chúng là B, C, E, hoặc khi số lượng chân của ký hiệu lớn hơn số lượng pad của footprint.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Pin <PinDesignator> of the symbol <SymbolName> (<SymbolRevisionID>) does not have corresponding pad <PadDesignator> in footprint <FootprintName> (<FootprintRevisionID>)
trong đó:
-
PinDesignatorlà Designator của chân ký hiệu. -
SymbolNamelà tên của ký hiệu. -
SymbolRevisionIDlà Item-Revision ID của ký hiệu. -
PadDesignatorlà Designator của pad footprint. -
FootprintNamelà tên của footprint. -
FootprintRevisionIDlà Item-Revision ID của footprint.
Khuyến nghị khắc phục
Chỉnh sửa mô hình đang được thêm hoặc chọn một mô hình khác để bảo đảm rằng các chân ký hiệu có ghép nối một-một với các pad footprint.
-
Trong Component Editor ở Single Component Editing mode:
-
nhấp vào điều khiển
ở góc trên bên phải của phần xem trước mô hình để sửa đổi mô hình hiện đang được linh kiện sử dụng (tham chiếu) trong trình chỉnh sửa tạm thời tương ứng cho loại mô hình đó;
-
nhấp vào điều khiển
ở góc trên bên phải của phần xem trước mô hình và chọn mục Select Model từ menu để duyệt và chọn một mô hình khác, hoặc một revision khác của chính mô hình đó;
-
nhấp vào điều khiển
ở góc trên bên phải của phần xem trước ký hiệu để mở panel Pins panel và thay đổi trực tiếp các đích pad/chân được ánh xạ bằng cách nhấp vào một ô của mô hình và nhập giá trị cần thiết.
-
-
Trong Component Editor ở Batch Component Editing mode:
-
nhấp chuột phải vào mục nhập mô hình trong vùng Model Links và chọn lệnh Edit từ menu ngữ cảnh để sửa đổi mô hình hiện đang được linh kiện sử dụng (tham chiếu) trong trình chỉnh sửa tạm thời tương ứng cho loại mô hình đó;
-
nhấp vào trường Item ID của mô hình trong vùng Model Links rồi nhấp vào nút
để duyệt và chọn một mô hình khác, hoặc một revision khác của chính mô hình đó.
-
Missing Component Description
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi phần mô tả của một linh kiện đang được định nghĩa trong Component Editor chưa được chỉ định.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Component Description is not specified
Khuyến nghị khắc phục
Chỉ định mô tả cho (các) linh kiện vi phạm theo yêu cầu.
-
Trong Component Editor ở Single Component Editing mode, sử dụng trường Description trong vùng Component để chỉ định mô tả.
-
Trong Component Editor ở Batch Component Editing mode, sử dụng trường Description trong nhóm cột Component của vùng định nghĩa linh kiện để chỉ định mô tả cho (các) linh kiện vi phạm.
Missing Component Name
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi tên của một linh kiện đang được định nghĩa trong Component Editor chưa được chỉ định.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Component Name is not specified
Khuyến nghị khắc phục
Chỉ định tên cho (các) linh kiện vi phạm theo yêu cầu.
-
Trong Component Editor ở Single Component Editing mode, sử dụng trường Name trong vùng Component để chỉ định tên.
-
Trong Component Editor ở Batch Component Editing mode, sử dụng trường Name trong nhóm cột Component của vùng định nghĩa linh kiện để chỉ định tên cho (các) linh kiện vi phạm.
Missing Component Type
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi loại của một linh kiện đang được định nghĩa trong Component Editor chưa được chỉ định.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Component Type is not specified
Khuyến nghị khắc phục
Chỉ định loại cho (các) linh kiện vi phạm theo yêu cầu.
-
Trong Component Editor ở Single Component Editing mode, sử dụng trường Type trong vùng Component để chỉ định loại.
-
Trong Component Editor ở Batch Component Editing mode, sử dụng trường Type trong nhóm cột Component của vùng định nghĩa linh kiện để chỉ định loại cho (các) linh kiện vi phạm.
Model revision is in Inapplicable State
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình được liên kết đang được một định nghĩa linh kiện sử dụng (tham chiếu) được phát hiện đang ở trạng thái không áp dụng. Ví dụ, mô hình hiện tại là Obsolete và do đó không nên được sử dụng. Tính áp dụng được xác định thông qua tùy chọn Allowed to be used in designs trong hộp thoại State Properties dialog. Từ trong hộp thoại Edit Lifecycle Definitions dialog, hãy mở hộp thoại này cho trạng thái cần thiết bằng cách nhấp đúp vào mục nhập của trạng thái trong định nghĩa vòng đời cha hoặc chọn mục nhập đó và nhấp vào biểu tượng chỉnh sửa xuất hiện Khi tùy chọn này được bật, mô hình ở trạng thái này được phép sử dụng trong một linh kiện. Nó được xem là Applicable. Nếu tùy chọn này bị tắt, mô hình ở trạng thái này không thể được sử dụng hợp lệ và được xem là Inapplicable (hoặc không áp dụng).
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
<ModeName> (<ModelRevisionID>) revision is in inapplicable state
trong đó:
-
ModelNamelà tên của mô hình. -
ModelRevisionIDlà Item-Revision ID của mô hình.
Khuyến nghị khắc phục
Chọn một mô hình thay thế hoặc một revision khác của cùng mô hình đó mà hợp lệ để sử dụng trong linh kiện.
-
Trong Component Editor ở Single Component Editing mode, nhấp vào điều khiển
ở góc trên bên phải của phần xem trước mô hình và chọn mục Select Model từ menu để duyệt và chọn một mô hình khác, hoặc một revision khác của chính mô hình đó.
-
Trong Component Editor ở Batch Component Editing mode, nhấp vào trường Item ID của mô hình trong vùng Model Links rồi nhấp vào nút
để duyệt và chọn một mô hình khác, hoặc một revision khác của chính mô hình đó.
Model revision is Out Of Date
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình được liên kết đang được một định nghĩa linh kiện sử dụng (tham chiếu) được phát hiện là đã lỗi thời. Nếu có một revision mới hơn của mô hình khả dụng, trường Revision State sẽ phản ánh điều này bằng văn bản Out of date, ở bên phải trạng thái vòng đời của revision hiện tại dưới phần xem trước mô hình (trong Component Editor ở Single Component Editing mode), hoặc trường Revision Status trong vùng Model Links sẽ được đánh dấu bằng văn bản Out of date, hiển thị bằng phông chữ đậm (trong Component Editor ở Batch Component Editing mode).
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
<ModelName> (<ModelRevisionID>) revision is Out of Date
trong đó:
-
ModelNamelà tên của mô hình. -
ModelRevisionIDlà Item-Revision ID của mô hình.
Khuyến nghị khắc phục
Cập nhật các liên kết mô hình của linh kiện đang lỗi thời để sử dụng revision mới nhất của các mô hình.
-
Trong Component Editor ở Single Component Editing mode, nhấp vào điều khiển
ở góc trên bên phải của phần xem trước mô hình và chọn mục Update to Latest từ menu.
-
Trong Component Editor ở Batch Component Editing mode, nhấp chuột phải vào bất kỳ đâu trên mục nhập của mô hình trong Model Links khu vực và chọn Update to Latest Revision từ menu.
Number of Pads exceeds Number of Pins
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình footprint đang được thành phần sử dụng (tham chiếu) trong định nghĩa thành phần có chứa nhiều pad hơn (pad SMD được đặt trên các lớp đồng và pad lỗ xuyên mạ) so với số chân của ký hiệu schematic được tham chiếu.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Number of pads in the footprint <FootprintName> (<FootprintRevisionID>) (<FootprintNumberOfPads>) exceeds number of pins in the symbol <SymbolName> (<SymbolRevisionID>) (<SymbolNumberOfPins>)
trong đó:
-
FootprintNamelà tên của footprint. -
FootprintRevisionIDlà ID Item-Revision của footprint. -
FootprintNumberOfPadslà số lượng pad trong footprint. -
SymbolNamelà tên của ký hiệu. -
SymbolRevisionIDlà ID Item-Revision của ký hiệu. -
SymbolNumberOfPinslà số lượng chân trong ký hiệu.
Khuyến nghị để khắc phục
Chỉnh sửa mô hình hiện đang được thêm hoặc chọn một mô hình ký hiệu/footprint khác để bảo đảm rằng footprint có số lượng pad không vượt quá số chân của ký hiệu.
-
Trong Component Editor ở chế độ Single Component Editing:
-
nhấp vào điều khiển
ở góc trên bên phải của phần xem trước mô hình để sửa đổi mô hình hiện đang được thành phần sử dụng (tham chiếu) trong trình soạn thảo tạm thời tương ứng cho loại mô hình đó;
-
nhấp vào điều khiển
ở góc trên bên phải của phần xem trước mô hình và chọn mục Select Model từ menu để duyệt và chọn một mô hình khác hoặc một revision khác của chính mô hình đó.
-
-
Trong Component Editor ở chế độ Batch Component Editing:
-
nhấp chuột phải vào mục nhập mô hình trong khu vực Model Links và chọn lệnh Edit từ menu ngữ cảnh để sửa đổi mô hình hiện đang được thành phần sử dụng (tham chiếu) trong trình soạn thảo tạm thời tương ứng cho loại mô hình đó;
-
nhấp vào trường Item ID của mô hình trong khu vực Model Links sau đó nhấp vào nút
để duyệt và chọn một mô hình khác hoặc một revision khác của chính mô hình đó.
-
Revision that is being edited is not latest
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi revision của thành phần đang được chỉnh sửa không phải là revision mới nhất hiện có trong Workspace được kết nối.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ComponentName> (<ComponentRevisionID>) revision is Out of Date
trong đó:
-
ComponentNamelà Name của thành phần. -
ComponentRevisionIDlà ID Item-Revision của thành phần.
Khuyến nghị để khắc phục
Chọn revision thành phần mới nhất để chỉnh sửa. Để thực hiện việc này, hãy duyệt thành phần trong Components panel, nhấp chuột phải vào mục nhập của nó trong bảng và chọn Edit.
Unrecognized combination of Manufacturer+Part Number in Part Choice
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mục nhập không chính xác cho part choice của thành phần được thêm vào và Workspace không thể truy xuất part đó.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Manufacturer+Part Number combination was not found in the available Part Sources ("Part Choice <n>")
trong đó:
-
nlà số thứ tự của part choice bị lỗi.
Khuyến nghị để khắc phục
Chỉ định part choice hợp lệ cho (các) thành phần bị lỗi.
-
Trong Component Editor ở chế độ Single Component Editing, xóa các part choice không hợp lệ khỏi vùng Part Choices và thêm các part choice mới, chính xác.
-
Trong Component Editor ở chế độ Batch Component Editing, nhập các giá trị đúng vào các trường Part Choice n trong vùng định nghĩa thành phần. Lưu ý rằng khi giá trị của trường part choice có mục nhập không chính xác, văn bản sẽ hiển thị màu xám và in nghiêng. Khi cả hai mục nhập đều chính xác, văn bản sẽ hiển thị bình thường với chữ màu trắng.
Các vi phạm liên quan đến Footprint
Duplicate Pad Designator
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình footprint được liên kết với thành phần đang được định nghĩa trong Component Editor có nhiều đối tượng Pad có cùng giá trị của thuộc tính Designator.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Duplicate Pad Designator On Pads Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
trong đó:
-
Identifier1là định danh của thể hiện đầu tiên của pad có designator bị trùng lặp, được biểu diễn bằng cặp net-designator và tọa độ pad. -
Layer1là lớp mà thể hiện đầu tiên của pad có designator bị trùng lặp được đặt trên đó. -
Identifier2là định danh của thể hiện thứ hai của pad có designator bị trùng lặp, được biểu diễn bằng cặp net-designator và tọa độ pad. -
Layer2là lớp mà thể hiện thứ hai của pad có designator bị trùng lặp được đặt trên đó.
Khuyến nghị để khắc phục
Gán các designator khác nhau và duy nhất cho các pad của mô hình footprint được liên kết.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải của phần xem trước footprint.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục nhập footprint trong khu vực Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Mô hình footprint hiện đang được thành phần sử dụng (tham chiếu) sẽ mở trong trình soạn thảo PCB Footprint tạm thời. Chọn các pad bị lỗi và thay đổi giá trị thuộc tính Designator của chúng trong Pad mode of the Properties panel.
Duplicate Primitives
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình footprint được liên kết với thành phần đang được định nghĩa trong Component Editor có các đối tượng giống hệt nhau được đặt cùng vị trí trên cùng một lớp.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Duplicate Primitives: <ObjectType1> <Identifier1> on <Layer1> And <ObjectType2> <Identifier2> on <Layer2>
trong đó:
-
ObjectType1là loại của thể hiện đầu tiên của đối tượng trùng lặp. -
Identifier1là định danh của thể hiện đầu tiên của đối tượng trùng lặp; cách biểu diễn định danh phụ thuộc vào loại đối tượng. -
Layer1là lớp mà thể hiện đầu tiên của đối tượng trùng lặp được đặt trên đó. -
ObjectType2là loại của thể hiện thứ hai của đối tượng trùng lặp. -
Identifier2là định danh của thể hiện thứ hai của đối tượng trùng lặp; cách biểu diễn định danh phụ thuộc vào loại đối tượng. -
Layer2là lớp mà thể hiện thứ hai của đối tượng trùng lặp được đặt trên đó.
Khuyến nghị để khắc phục
Xóa các đối tượng trùng lặp khỏi mô hình footprint.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải của phần xem trước footprint.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục nhập footprint trong khu vực Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Mô hình footprint hiện đang được thành phần sử dụng (tham chiếu) sẽ mở trong trình soạn thảo PCB Footprint tạm thời. Chọn các đối tượng trùng lặp và xóa chúng bằng phím tắt Delete.
Mirrored Footprint (designed on bottom layer)
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình footprint được liên kết với thành phần đang được định nghĩa trong Component Editor có các primitive quan trọng (pad, track, arc, fill, region, rectangle, chuỗi văn bản, đối tượng keepout) được đặt trên Bottom Layer nhưng không có primitive nào như vậy được đặt trên Top Layer.
Trong PCB Footprint editor, footprint được xây dựng cho mặt trên của bo mạch; nó có thể được lật xuống mặt dưới trong quá trình thiết kế PCB nếu cần.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Bottom Layer Component
Khuyến nghị để khắc phục
Lật các primitive của footprint từ Bottom Layer sang Top Layer.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải của phần xem trước footprint.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục nhập footprint trong khu vực Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Mô hình footprint hiện đang được thành phần sử dụng (tham chiếu) sẽ mở trong trình soạn thảo PCB Footprint tạm thời. Chọn các primitive trên Bottom Layer, rồi thay đổi thuộc tính Layer của chúng trong chế độ tương ứng của bảng Properties thành Top Layer.
Missing Pad Designator
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình footprint được liên kết với thành phần đang được định nghĩa trong Component Editor có một đối tượng Pad không có giá trị nào được chỉ định cho thuộc tính Designator.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Missing Pad Designator on Pad: Pad <Identifier> on <Layer>
trong đó:
-
Identifierlà định danh của pad không có designator được chỉ định, được biểu diễn bằng net của pad và tọa độ. -
Layerlà lớp mà pad không có designator được chỉ định được đặt trên đó.
Khuyến nghị để khắc phục
Chỉ định các giá trị designator cho các pad của mô hình footprint được liên kết.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải của phần xem trước footprint để mở footprint hiện đang được thành phần sử dụng (tham chiếu) trong trình soạn thảo PCB Footprint tạm thời.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục nhập footprint trong khu vực Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Mô hình footprint hiện đang được thành phần sử dụng (tham chiếu) sẽ mở trong trình soạn thảo PCB Footprint tạm thời. Chọn một pad bị lỗi và chỉ định giá trị của thuộc tính Designator của pad đó trong Pad mode of the Properties panel.
Offset Footprint Reference
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình footprint được liên kết với thành phần đang được định nghĩa trong Component Editor có điểm tham chiếu (gốc tọa độ) nằm ngoài hình chữ nhật bao được tạo thành bởi các đối tượng footprint.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Offset Component Origin
Khuyến nghị để khắc phục
Thay đổi vị trí của điểm tham chiếu để nó nằm bên trong hình chữ nhật bao được tạo thành bởi các đối tượng footprint.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải của phần xem trước footprint để mở footprint hiện đang được thành phần sử dụng (tham chiếu) trong trình soạn thảo PCB Footprint tạm thời.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục nhập footprint trong khu vực Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Mô hình footprint hiện đang được thành phần sử dụng (tham chiếu) sẽ mở trong trình soạn thảo PCB Footprint tạm thời. Sử dụng các lệnh của menu con Edit » Set Reference trong các menu chính để thay đổi vị trí hiện tại của điểm tham chiếu footprint.
Shorted Copper
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình footprint được liên kết với thành phần đang được định nghĩa trong Component Editor có các đối tượng Pad được nối với nhau bởi các đối tượng trên một lớp đồng.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Shorted Copper Connection Between Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
trong đó:
-
Identifier1là định danh của thể hiện đầu tiên của pad trong cặp pad bị nối ngắn mạch, được biểu diễn bằng cặp net-designator và tọa độ pad. -
Layer1là lớp mà thể hiện đầu tiên của pad trong cặp pad bị nối ngắn mạch được đặt trên đó. -
Identifier2là định danh của thể hiện thứ hai của pad trong cặp pad bị nối ngắn mạch, được biểu diễn bằng cặp net-designator và tọa độ pad. -
Layer2là lớp mà thể hiện thứ hai của pad trong cặp pad bị nối ngắn mạch được đặt trên đó.
Khuyến nghị để khắc phục
Xóa các đối tượng trên lớp đồng đang nối các pad của mô hình footprint được liên kết.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải của phần xem trước footprint.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục nhập footprint trong khu vực Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Mô hình footprint hiện đang được thành phần sử dụng (tham chiếu) sẽ mở trong trình soạn thảo PCB Footprint tạm thời. Chọn các đối tượng trên lớp đồng đang nối các pad rồi thay đổi chúng để chúng không nối các pad nữa, hoặc xóa các đối tượng này.
Unconnected Copper
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một mô hình footprint được liên kết với thành phần đang được định nghĩa trong Component Editor có các đối tượng trên một lớp đồng, và các đối tượng này không được nối với bất kỳ đối tượng Pad nào. Khi footprint như vậy được đặt vào một thiết kế PCB, một net sẽ không được gán cho các đối tượng trên lớp đồng này và chúng sẽ trở thành đồng chết.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Unconnected Copper on primitive : <ObjectType> <Identifier> on <Layer>
trong đó:
-
ObjectTypelà loại của thể hiện đối tượng không được nối với bất kỳ đối tượng Pad nào trong mô hình footprint. -
Identifierlà định danh của đối tượng không được nối với bất kỳ đối tượng Pad nào trong mô hình footprint; cách biểu diễn định danh phụ thuộc vào loại đối tượng. -
Layerlà lớp mà thể hiện của đối tượng không được nối với bất kỳ đối tượng Pad nào trong mô hình footprint được đặt trên đó.
Khuyến nghị để khắc phục
Thay đổi mô hình footprint để các đối tượng hiện không được nối với bất kỳ đối tượng Pad nào trong mô hình footprint được nối với các pad.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải của phần xem trước footprint.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục nhập footprint trong khu vực Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Mô hình footprint hiện đang được thành phần sử dụng (tham chiếu) sẽ mở trong trình soạn thảo PCB Footprint tạm thời. Đặt các đối tượng trên lớp đồng để tạo kết nối giữa các pad của footprint và các đối tượng hiện không được nối với bất kỳ đối tượng Pad nào, hoặc xóa các đối tượng chưa được nối này.
Các vi phạm liên quan đến Symbol
Different pins between modes
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một trong các chế độ hiển thị của symbol có thêm pin.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Extra Pin in display mode <DisplayMode> of the symbol <SymbolRevisionID>. Part <PartDesignator>. Pin Name "<PinName>"
trong đó:
-
DisplayModelà chế độ biểu diễn đồ họa cụ thể của symbol mà trong đó pin thừa đã được phát hiện. Một symbol có chế độ Normal và có thể có tối đa 255 chế độ Alternate được định nghĩa. Tìm hiểu thêm về cách tạo nhiều chế độ hiển thị đồ họa cho cùng một component symbol. -
SymbolRevisionIDlà Item-Revision ID của symbol. -
PartDesignatorlà Designator của phần symbol. -
PinNamelà Name của pin vi phạm.
Khuyến nghị khắc phục
Vi phạm này thường phát sinh khi một chế độ đồ họa thay thế được định nghĩa cho symbol và xảy ra một trong các trường hợp sau:
- Một pin thừa đã được thêm vào một chế độ hiển thị nhưng không được chỉ định trong chế độ hiển thị khác, hoặc
- Một pin đã được chỉ định với Designator và/hoặc Name khác so với một pin được chỉ định trong chế độ hiển thị khác.
Không chỉ số lượng pin giữa các chế độ hiển thị đồ họa phải giống hệt nhau, mà các pin cũng phải giống nhau ở cả Designator và Name. Tìm hiểu thêm về cách tạo nhiều chế độ hiển thị đồ họa cho cùng một component symbol.
Thay đổi Designator và/hoặc Name của pin vi phạm để số lượng pin và các thuộc tính Designator, Name của chúng giống nhau giữa các chế độ hiển thị của symbol, hoặc xóa pin thừa khỏi một chế độ hiển thị.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải phần xem trước của symbol.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục symbol trong vùng Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Symbol model hiện đang được linh kiện sử dụng (tham chiếu) sẽ mở trong trình chỉnh sửa Schematic Library tạm thời. Chọn các pin vi phạm và thay đổi giá trị thuộc tính Designator và/hoặc Name của chúng trong Pin mode of the Properties panel, hoặc xóa các pin này bằng phím tắt Delete.
Duplicate Pin Designators
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi hai hoặc nhiều pin trong symbol model của linh kiện có cùng designator.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Duplicate Pin Designator(s) (mode <DisplayMode>): <PinDesignatorList>
trong đó:
-
DisplayModelà chế độ biểu diễn đồ họa cụ thể của symbol mà trong đó các pin trùng lặp đã được phát hiện. Một symbol có chế độ Normal và có thể có tối đa 255 chế độ Alternate được định nghĩa. -
PinDesignatorListlà danh sách các designator pin bị trùng, được phân tách bằng dấu phẩy, trong symbol vi phạm.
Khuyến nghị khắc phục
Thay đổi designator của các pin vi phạm cho phù hợp để mỗi pin có một gán định danh duy nhất.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải phần xem trước của symbol.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục symbol trong vùng Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Symbol model hiện đang được linh kiện sử dụng (tham chiếu) sẽ mở trong trình chỉnh sửa Schematic Library tạm thời. Chọn các pin vi phạm và thay đổi giá trị thuộc tính Designator của chúng trong Pin mode of the Properties panel, hoặc xóa các pin này bằng phím tắt Delete.
Missing Default Designator
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi symbol model của linh kiện không có default designator được chỉ định.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Missing Default Designator
Khuyến nghị khắc phục
Chỉ định một default designator cho symbol model vi phạm.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải phần xem trước của symbol.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục symbol trong vùng Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Symbol model hiện đang được linh kiện sử dụng (tham chiếu) sẽ mở trong trình chỉnh sửa Schematic Library tạm thời. Mở Symbol mode of the Properties panel (được kích hoạt khi không có đối tượng nào được chọn trong vùng thiết kế) và chỉ định tiền tố designator bắt buộc, theo sau bởi ký tự '?' trong trường Designator (ví dụ: C?). Các dấu chấm hỏi trong designator của các linh kiện được đặt trên schematic sheet sẽ được cập nhật bằng các số thực tế trong quá trình Design Annotation.
Missing Pin Designator
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một pin trong symbol model của linh kiện không có designator được chỉ định.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Missing Pin Designator of the symbol <SymbolRevisionID>
trong đó:
-
SymbolRevisionIDlà Item-Revision ID của symbol vi phạm.
Khuyến nghị khắc phục
Chỉ định designator cho từng pin trong symbol model vi phạm.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải phần xem trước của symbol.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục symbol trong vùng Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Symbol model hiện đang được linh kiện sử dụng (tham chiếu) sẽ mở trong trình chỉnh sửa Schematic Library tạm thời. Chọn các pin vi phạm và chỉ định giá trị cho thuộc tính Designator của chúng trong Pin mode of the Properties panel, hoặc xóa các pin bằng phím tắt Delete.
Missing Pin Name
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một pin trong symbol model của linh kiện không có tên được chỉ định.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Missing Pin Name of the symbol <SymbolRevisionID>. Pin Designator "<PinDesignator>".
trong đó:
-
SymbolRevisionIDlà Item-Revision ID của symbol vi phạm. -
PinDesignatorlà Designator của pin vi phạm.
Khuyến nghị khắc phục
Chỉ định tên cho từng pin trong symbol model vi phạm.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải phần xem trước của symbol.
-
Trong Component Editor ở chế độ Batch Component Editing, nhấp chuột phải vào mục symbol trong vùng Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Symbol model hiện đang được linh kiện sử dụng (tham chiếu) sẽ mở trong trình chỉnh sửa Schematic Library tạm thời. Chọn các pin vi phạm và chỉ định giá trị cho thuộc tính Name của chúng trong Pin mode of the Properties panel, hoặc xóa các pin này bằng phím tắt Delete.
Lưu ý
Chỉ một phiên bản vi phạm sẽ được liệt kê trong panel Messages cho mỗi linh kiện riêng biệt. Một linh kiện hoàn toàn có thể có một symbol với nhiều hơn một pin chưa được định nghĩa tên.
Missing Pins in Sequence
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi phát hiện thiếu pin trong chuỗi số của các giá trị designator pin của symbol vi phạm. Ví dụ: nếu symbol có các pin với designator 1, 2, 5, và không có các pin với designator 3 và 4.
Thông báo
Một thông báo được hiển thị trong panel Messages theo định dạng sau:
Missing Pin Designator In Sequence : <PinDesignatorList> [<LowerPinDesignator>..<UpperPinDesignator>]
trong đó:
-
PinDesignatorListlà danh sách các designator pin bị thiếu trong chuỗi số được phát hiện trong symbol vi phạm, được phân tách bằng dấu phẩy. -
LowerPinDesignatorlà giá trị số nhỏ nhất của các designator pin được phát hiện trong symbol vi phạm. -
UpperPinDesignatorlà giá trị số lớn nhất của các designator pin được phát hiện trong symbol vi phạm.
Khuyến nghị khắc phục
Trong symbol model vi phạm, thêm các pin có designator còn thiếu trong chuỗi hoặc thay đổi designator pin sao cho các designator pin tạo thành một chuỗi liên tục các giá trị số nguyên.
-
Trong Component Editor ở chế độ Single Component Editing, nhấp vào điều khiển
ở góc trên bên phải phần xem trước của symbol.
-
Trong Trình chỉnh sửa Thành phần ở chế độ Batch Component Editing mode, hãy nhấp chuột phải vào mục ký hiệu trong vùng Model Links và chọn lệnh Edit từ menu ngữ cảnh.
Mô hình ký hiệu hiện đang được thành phần sử dụng (tham chiếu) sẽ mở trong Trình chỉnh sửa Thư viện Sơ đồ tạm thời. Sử dụng lệnh Place » Pin từ các menu chính, thêm số lượng chân cần thiết và chỉ định giá trị của thuộc tính Designator của chúng trong Pin mode of the Properties panel để các định danh chân trong ký hiệu tạo thành một chuỗi liên tục các giá trị số nguyên. Bạn cũng có thể chỉnh sửa thuộc tính Designator của các chân đã được đặt trong ký hiệu.
Lưu ý
Có những thành phần không sử dụng đánh số chân tuần tự, ví dụ như BGA có cách đánh số chân không tuần tự; A1, A3, A5 (v.v.). Trong trường hợp này, bạn nên phát hành thành phần với vi phạm này và ghi rõ lý do trong Ghi chú Phát hành. Hoặc, đặt kiểm tra Missing Pins in Sequence trên trang Data Management – Component Rule Checks của hộp thoại Preferences thành No Report.


