Mẫu linh kiện

Để giúp đơn giản hóa việc tạo linh kiện, Altium Designer, kết hợp với Workspace được kết nối của bạn, hỗ trợ tạo và định nghĩa Component Templates (các Mục mẫu linh kiện) trong Workspace đó. Tương tự như mẫu sơ đồ nguyên lý có thể được dùng để định sẵn thông tin trên các trang sơ đồ tham chiếu đến mẫu, mẫu linh kiện được một linh kiện thư viện Workspace tham chiếu đến và cung cấp các thiết lập định sẵn để sử dụng khi định nghĩa linh kiện đó.

Cụ thể, các mẫu linh kiện được phát triển với trọng tâm là thông tin tham số, cho phép bạn định nghĩa tại một nơi duy nhất một tập hợp tham số sẽ được cung cấp cho linh kiện tham chiếu đến mẫu. Thông qua mẫu, bạn có thể kiểm soát những tham số nào được hiển thị, điền các giá trị mặc định và thậm chí đánh dấu các tham số cần thiết là bắt buộc. Các bước kiểm tra xác thực được thực hiện khi lưu linh kiện để đảm bảo tuân thủ.

Các giá trị mặc định được chỉ định cho nhiều thiết lập của mẫu có thể được khóa ở chế độ chỉ đọc hoặc cho phép người thiết kế ghi đè có chọn lọc khi định nghĩa linh kiện.

Mẫu linh kiện cũng là cơ sở để tạo linh kiện tổng quát. Để tìm hiểu thêm, hãy tham khảo trang Tạo linh kiện tổng quát.

Quyền truy cập các mẫu linh kiện sẽ phụ thuộc vào giấy phép phần mềm. Để biết thêm thông tin, hãy tham khảo hộp Note ở phía bên phải trang.

Các mẫu linh kiện này được tạo trực tiếp trong Workspace. Sau khi mẫu linh kiện được tạo (và dữ liệu được lưu vào một bản sửa đổi của mẫu), bạn có thể tái sử dụng mẫu để tạo một hoặc nhiều linh kiện.

Loại thư mục

Khi tạo thư mục để lưu trữ các mẫu linh kiện, bạn có thể chỉ định loại thư mục. Điều này không ảnh hưởng đến nội dung của thư mục – việc phát hành một mẫu linh kiện luôn tạo ra một Mục mẫu linh kiện tương ứng. Loại thư mục chỉ cung cấp một dấu hiệu trực quan về nội dung được lưu trữ và có thể hữu ích khi duyệt Workspace để tìm nội dung cụ thể. Để chỉ định thư mục dùng làm nơi chứa các mẫu linh kiện, hãy đặt Folder Type thành Component Templates khi định nghĩa thuộc tính thư mục trong hộp thoại Edit Folder.

Việc chỉ định loại thư mục – mục đích sử dụng của thư mục – giúp nhận biết trực quan nội dung của thư mục đó khi duyệt Workspace.
Việc chỉ định loại thư mục – mục đích sử dụng của thư mục – giúp nhận biết trực quan nội dung của thư mục đó khi duyệt Workspace.

Loại nội dung

Khi tạo Mục mẫu linh kiện đích để lưu trữ mẫu linh kiện, hãy đảm bảo Content Type của Mục được đặt thành Component Template trong hộp thoại Create New Item. Nếu bạn đang tạo Mục trong thư mục loại Component Templates, loại nội dung này sẽ có sẵn trong menu ngữ cảnh khi nhấp chuột phải để tạo Mục.

Tạo mẫu linh kiện trong thư mục Component Templates – Content Type phù hợp có sẵn trong menu ngữ cảnh.
Tạo mẫu linh kiện trong thư mục Component Templates – Content Type phù hợp có sẵn trong menu ngữ cảnh.

Lưu mẫu linh kiện

Related page: Tạo & chỉnh sửa nội dung

Đến đây, chúng ta đã thảo luận về khả năng hỗ trợ mẫu linh kiện trong Workspace xét theo các loại thư mục và nội dung liên quan. Việc lưu một mẫu linh kiện đã được định nghĩa vào bản sửa đổi của Mục mẫu linh kiện có thể được thực hiện một cách đơn giản và hiệu quả.

Nhờ khả năng hỗ trợ chỉnh sửa trực tiếp của Workspace, bạn có thể chỉnh sửa và lưu mẫu linh kiện vào bản sửa đổi đầu tiên của một Mục mẫu linh kiện mới tạo. Chỉnh sửa trực tiếp giúp bạn không còn bị ràng buộc bởi dữ liệu nguồn được quản lý phiên bản riêng biệt. Bạn chỉ cần chỉnh sửa loại nội dung được hỗ trợ bằng một trình biên tập tạm thời, được nạp dữ liệu nguồn mới nhất trực tiếp từ Workspace. Khi chỉnh sửa xong, đối tượng sẽ được lưu (hoặc lưu lại) vào một bản sửa đổi kế tiếp đã được lên kế hoạch của Mục cha, và trình biên tập tạm thời sẽ đóng lại. Không có tệp nào trên ổ cứng, không cần băn khoăn liệu bạn có đang làm việc với dữ liệu nguồn đúng hoặc mới nhất hay không, và cũng không cần duy trì phần mềm quản lý phiên bản riêng. Workspace xử lý tất cả, đảm bảo tính toàn vẹn cao và giúp việc thay đổi dữ liệu của bạn diễn ra nhanh chóng hơn đáng kể.

Khi tạo một Mục Mẫu Linh kiện, bạn có thể chỉnh sửa và lưu mẫu linh kiện vào phiên bản sửa đổi ban đầu của Mục đó sau khi tạo. Để thực hiện, hãy bật tùy chọn Open for editing after creation ở cuối hộp thoại Create New Item (tùy chọn này được bật theo mặc định). Mục sẽ được tạo và Trình chỉnh sửa Mẫu Linh kiện tạm thời sẽ mở, hiển thị tài liệu .CMPT làm tài liệu đang hoạt động trong cửa sổ thiết kế chính. Tài liệu này sẽ được đặt tên theo Mục-Phiên bản sửa đổi, với định dạng: <Item><Revision>.CMPT (ví dụ: CMPT-0001-1.CMPT).

 
 
 
 
 

Ví dụ về việc chỉnh sửa phiên bản sửa đổi ban đầu của mẫu linh kiện trực tiếp từ Workspace – Trình chỉnh sửa Mẫu Linh kiện tạm thời cung cấp tài liệu để bạn định nghĩa mẫu linh kiện.
Ví dụ về việc chỉnh sửa phiên bản sửa đổi ban đầu của mẫu linh kiện trực tiếp từ Workspace – Trình chỉnh sửa Mẫu Linh kiện tạm thời cung cấp tài liệu để bạn định nghĩa mẫu linh kiện.

Sử dụng tài liệu để định nghĩa mẫu linh kiện theo yêu cầu. Để biết thêm thông tin về cách thực hiện, xem Định nghĩa Mẫu.

Khi chỉnh sửa trực tiếp, có ba nút điều khiển liên quan, có thể truy cập ngay từ Quick Access Bar (ở góc trên bên trái cửa sổ ứng dụng chính) hoặc từ thanh công cụ Component Template Standard:

  • – Save Active Document. Sử dụng nút này để lưu cục bộ mọi thay đổi đã thực hiện đối với tài liệu. Nhờ đó, bạn có thể lưu các thay đổi hiện tại nếu muốn quay lại sau để chỉnh sửa thêm trước khi lưu vào Workspace.
  • / – Save to Server. Sử dụng nút này để lưu mẫu linh kiện đã định nghĩa vào Workspace, trong phiên bản sửa đổi ban đầu (đã lên kế hoạch) của Mục Mẫu Linh kiện đích. Hộp thoại Edit Revision sẽ xuất hiện, cho phép bạn thay đổi Tên, Mô tả và thêm ghi chú phát hành theo yêu cầu. Tài liệu và trình chỉnh sửa sẽ đóng sau khi lưu. Tài liệu chứa mẫu linh kiện nguồn, *.CMPT, sẽ được lưu trong phiên bản sửa đổi của Mục.

    Nút điều khiển Save to Server cũng được bố trí thuận tiện ở bên phải mục tương ứng với mẫu linh kiện, ngay trong bảng Projects .
  • / – Discard Local Changes. Sử dụng nút này nếu bạn muốn hủy chỉnh sửa và loại bỏ mọi thay đổi đã thực hiện. Tài liệu và trình chỉnh sửa sẽ đóng, và không có nội dung nào được phát hành vào Mục Mẫu Linh kiện đích.

Các nút điều khiển này cũng có sẵn dưới dạng lệnh – Save (Phím tắt: Ctrl+S), Save to Server (Phím tắt: Ctrl+Alt+S) và Discard Local Changes – trong menu chính File và menu chuột phải của mục tương ứng với mẫu linh kiện trong bảng Projects.

Dữ liệu được lưu trong Workspace bao gồm mẫu linh kiện nguồn, được định nghĩa trong tệp Mẫu Linh kiện (<Item><Revision>.CMPT).

 
 
 
 
 

Ví dụ về mẫu linh kiện đã được định nghĩa và lưu lại vào Workspace.
Ví dụ về mẫu linh kiện đã được định nghĩa và lưu lại vào Workspace.

Kế thừa Mẫu Linh kiện

Tính năng này khả dụng khi tùy chọn UI.ComponentTemplateInheritance được bật trong hộp thoại Advanced Settings.

Bạn có thể sử dụng mẫu linh kiện của loại linh kiện gốc nếu loại con chưa được liên kết với mẫu linh kiện nào. Khi xây dựng hệ thống phân cấp loại linh kiện, các loại linh kiện con sẽ kế thừa mẫu linh kiện được gán cho loại linh kiện gốc/cha.

Trình chỉnh sửa CMPT (Mẫu Linh kiện)

Để truy cập trình chỉnh sửa Mẫu Linh kiện trong Altium Designer, bạn phải cài đặt phần mở rộng phần mềm Component Template Editor. Phần mở rộng này được cài đặt mặc định cùng Altium Designer. Bạn có thể cài đặt hoặc gỡ bỏ phần mở rộng này theo cách thủ công.

Để biết thêm thông tin về cách quản lý các phần mở rộng, hãy tham khảo trang Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Định nghĩa Mẫu

Trình chỉnh sửa Mẫu Linh kiện về cơ bản được chia thành hai vùng chính, được minh họa trong hình dưới đây và tóm tắt ở phần tiếp theo.

 
 
 
 
 

Trình chỉnh sửa Mẫu Linh kiện có thể được chia khái quát thành hai vùng chính.
Trình chỉnh sửa Mẫu Linh kiện có thể được chia khái quát thành hai vùng chính.

  1. Upper Region – để định nghĩa các tùy chọn cấp linh kiện (vòng đời, cách đặt tên và tùy chọn thư mục) cho linh kiện tham chiếu đến mẫu.
  2. Lower Region – để định nghĩa các tham số được sử dụng cho linh kiện tham chiếu đến mẫu.

Thiết lập Tùy chọn Linh kiện

Nửa trên của trình chỉnh sửa dành để định nghĩa các giá trị mặc định cho những thuộc tính linh kiện sau:

  • Lifecycle Definition – chọn định nghĩa vòng đời áp dụng cho linh kiện được tạo bằng mẫu. Trường thả xuống liệt kê tất cả các định nghĩa đã được thiết lập cho Workspace và được phép sử dụng cho linh kiện.

  • Revision Naming – chọn quy tắc đặt tên phiên bản sửa đổi áp dụng cho linh kiện được tạo bằng mẫu. Trường thả xuống liệt kê tất cả các quy tắc đã được thiết lập cho Workspace và được phép sử dụng cho linh kiện.

    Nếu tùy chọn kiểm soát việc sử dụng các định nghĩa vòng đời và quy tắc đặt tên bản sửa đổi theo từng loại nội dung được bật cho bất kỳ định nghĩa/quy tắc nào, và loại nội dung Component không được thiết lập để sử dụng một định nghĩa/quy tắc cụ thể, thì định nghĩa/quy tắc đó sẽ không có trong danh sách thả xuống tương ứng.

  • Component Naming – dùng trường này để xác định Quy tắc đặt tên Item mặc định cho linh kiện được tạo bằng mẫu, bảo đảm linh kiện được tạo có một ID duy nhất trong Workspace. Nội dung nhập tại đây sẽ được dùng làm mẫu để tự động đặt tên linh kiện (trong trường Id tương ứng (khi dùng Component Editor ở chế độ Single Component Editing), hoặc trường Item ID (khi dùng Component Editor ở chế độ Batch Component Editing)). Phần mềm sẽ tự động gán ID duy nhất khả dụng tiếp theo dựa trên quy tắc đó, sau khi quét toàn bộ Workspace và các mã định danh của nội dung hiện có. Một quy tắc đặt tên Item mặc định – CMP-{00000} – được cung cấp, nhưng tất nhiên bạn có thể tạo quy tắc riêng bằng cách nhập vào trường này, bảo đảm phần biến được đặt trong dấu ngoặc nhọn (ví dụ: CMP-001-{0000}).

  • Default Folder – dùng để chỉ định thư mục mặc định trong Workspace đích để lưu linh kiện. Để thực hiện, nhấp nút Choose để mở hộp thoại Choose Folder (một phiên bản của bảng Explorer), tại đó bạn có thể duyệt đến và chọn một thư mục hiện có trong Workspace, hoặc tạo ngay một thư mục mới.

Không có trường để thiết lập Workspace đích, vì thiết lập này được cố định để sử dụng cùng Workspace chứa bản sửa đổi của mẫu linh kiện.

Tùy chọn Allow override của từng thuộc tính có thể được dùng để kiểm soát độc lập việc người dùng có thể thay đổi thuộc tính đó (bật) hay không (tắt) khi định nghĩa linh kiện trong Component Editor.

Khi mẫu được tham chiếu, các mục được chỉ định trong vùng này sẽ được dùng để điền sẵn vào các trường tương ứng trong Component Editor (nếu có):

  • Single Component Editing mode – các trường Id và Folder, trong khu vực Advanced Settings của vùng Component.
  • Batch Component Editing mode – trên thẻ Document Options của hộp thoại Document Options và do đó là các trường Item ID và FolderPath, trong khu vực Component của vùng định nghĩa linh kiện.

Khi mẫu được tham chiếu, các mục được dùng để điền sẵn vào các trường tương ứng khi chỉnh sửa linh kiện trong Component Editor ở chế độ Single Component Editing (bên trái) và chế độ Batch Component Editing (bên phải).
Khi mẫu được tham chiếu, các mục được dùng để điền sẵn vào các trường tương ứng khi chỉnh sửa linh kiện trong Component Editor ở chế độ Single Component Editing (bên trái) và chế độ Batch Component Editing (bên phải).

Định nghĩa tham số

Nửa dưới của trình chỉnh sửa dành cho việc định nghĩa và quản lý các tham số sẽ được cung cấp cho linh kiện tham chiếu đến mẫu.

 
 
 
 
 

Ví dụ về các tham số được định nghĩa trong mẫu linh kiện.
Ví dụ về các tham số được định nghĩa trong mẫu linh kiện.

Tham số hệ thống mặc định

Nhiều tham số hệ thống được đưa vào theo mặc định khi tạo mẫu linh kiện mới, như minh họa trong hình sau và được trình bày chi tiết bên dưới.

 
 
 
 
 

Các tham số cấp hệ thống mặc định có trong mẫu linh kiện mới tạo.
Các tham số cấp hệ thống mặc định có trong mẫu linh kiện mới tạo.

  • ComponentType – tham số này cho phép bạn chỉ định loại linh kiện. Điều này hỗ trợ tìm kiếm có mục tiêu thông qua chức năng Search mạnh mẽ của Workspace – một chức năng không chỉ cho phép tìm kiếm theo loại linh kiện mà còn cho phép tìm kiếm thông minh hơn, nhờ hỗ trợ các tham số linh kiện có nhận biết đơn vị. Khi duyệt các linh kiện trong Workspace của bạn bằng bảng Components, cách phân nhóm Categories cho linh kiện được xác định từ các tham số ComponentType gắn với từng linh kiện. Nhấp vào trường Default Value tương ứng, sau đó nhấp nút để mở hộp thoại Choose component type. Dùng hộp thoại này để chọn loại linh kiện cần thiết rồi nhấp OK – loại đã chọn sẽ được chèn làm giá trị cho tham số ComponentType trong bảng tham số chính.

    Hộp thoại Choose component type phản ánh tập hợp các loại linh kiện được định nghĩa trên trang Data Management – Component Types của hộp thoại Preferences. Nhấp nút ở cuối hộp thoại Choose component type để truy cập trang tùy chọn này, nơi bạn có thể điều chỉnh danh sách cho phù hợp hơn với nhu cầu – bằng cách thêm các loại và loại phụ mới, hoặc chỉnh sửa và xóa các loại hiện có.

    Ví dụ về mẫu linh kiện, với tham số hệ thống ComponentType được đặt thành Diodes.
    Ví dụ về mẫu linh kiện, với tham số hệ thống ComponentType được đặt thành Diodes.

     
     
     
     
     

    Kiểu dữ liệu của tham số này được đặt là ComponentType và không thể thay đổi. Ngoài ra, không thể sao chép hoặc xóa tham số ComponentType. Chọn ô và sử dụng phím Delete để xóa giá trị.

  • SCHLIB và PCBLIB – hai tham số này cho phép bạn chỉ định lần lượt mô hình ký hiệu và footprint mặc định. Nhấp vào trường Default Value tương ứng của từng tham số, sau đó nhấp vào nút để mở hộp thoại chọn mô hình cần dùng.

    Lưu ý rằng bạn đang chọn mô hình chứ không phải một phiên bản cụ thể của mô hình đó. Nhờ vậy, linh kiện sử dụng mẫu sẽ luôn sử dụng phiên bản mới nhất của mô hình đã chọn.

    Chỉ định các mô hình ký hiệu và footprint trong mẫu của bạn.
    Chỉ định các mô hình ký hiệu và footprint trong mẫu của bạn.

     
     
     
     
     

    Kiểu dữ liệu của các tham số này được đặt lần lượt là SCHLIB và PCBLIB và không thể thay đổi. Ngoài ra, không thể sao chép hoặc xóa các tham số mô hình. Chọn ô và sử dụng phím Delete để xóa giá trị.

  • Name và Description – hai tham số này cho phép bạn xác định lần lượt tên và mô tả của linh kiện. Nhập các chuỗi cần dùng vào trường Default Value tương ứng của từng tham số.

    Chỉ định các tham số Name và Description trong mẫu của bạn.
    Chỉ định các tham số Name và Description trong mẫu của bạn.

     
     
     
     
     

    Kiểu dữ liệu của cả hai tham số này được đặt là Text và không thể thay đổi. Ngoài ra, không thể sao chép hoặc xóa các tham số này.

Thêm tham số người dùng mới

Để thêm tham số người dùng mới vào danh sách, nhấp vào nút (hoặc sử dụng lệnh Add từ menu ngữ cảnh khi nhấp chuột phải) – tham số sẽ được thêm vào cuối danh sách hiện tại.

 
 
 
 
 

Ví dụ về việc thêm tham số người dùng mới vào mẫu.
Ví dụ về việc thêm tham số người dùng mới vào mẫu.

Mỗi tham số được hiển thị trong danh sách dạng lưới với các thông tin sau:

  • Name – sử dụng trường này để đặt tên cho tham số, thường là một tên có ý nghĩa thể hiện mục đích của tham số. Khi mới được thêm vào, các tham số sẽ được đặt tên mặc định (Parameter, Parameter 1, Parameter 2, v.v.).

  • Type – kiểu tham số. Ban đầu, mục này mặc định là Text, nhưng hệ thống hỗ trợ nhiều kiểu dữ liệu có nhận biết đơn vị, cũng như kiểu PCBLIB, hỗ trợ định nghĩa nhiều footprint, và HarnessWiring, hỗ trợ định nghĩa linh kiện đấu dây bó dây. Các kiểu tham số được định nghĩa bởi các từ điển có sẵn cũng được hỗ trợ – tìm hiểu thêm.

  • Visible – bật tùy chọn này (đây là trạng thái mặc định của tham số mới được thêm vào) để bật tùy chọn Show tương ứng cho tham số khi chỉnh sửa một hoặc nhiều linh kiện trong Trình chỉnh sửa linh kiện (được cấu hình ở chế độ Batch Component Editing). Tùy chọn này sẽ điều khiển việc hiển thị cột tương ứng của tham số đó ở vùng phía dưới của Trình chỉnh sửa linh kiện, nơi định nghĩa các linh kiện. Thuộc tính này không có tác dụng khi định nghĩa linh kiện bằng chế độ Single Component Editing của trình chỉnh sửa.

  • Read Only – bật tùy chọn này để đặt tham số ở chế độ chỉ đọc. Khi chỉnh sửa linh kiện tham chiếu đến mẫu, giá trị của tham số sẽ không thể chỉnh sửa.

  • Required – bật tùy chọn này để đặt tham số thành 'tham số bắt buộc'. Khi chỉnh sửa linh kiện tham chiếu đến mẫu, tham số phải được gán giá trị; nếu không, sẽ không thể lưu linh kiện. Trong Trình chỉnh sửa linh kiện, khi chưa nhập giá trị, tham số này được nhận biết bằng ô giá trị có viền đỏ (ở chế độ Batch Component Editing) hoặc chứa biểu tượng (ở chế độ Single Component Editing).

  • Default Value – sử dụng trường này để nhập giá trị mặc định cho tham số.

    • Nếu tham số được đánh dấu là bắt buộc (bật tùy chọn Required) và cũng được đặt ở chế độ chỉ đọc (bật tùy chọn Read Only), thì MUST nhập giá trị mặc định. Nếu không, khi chỉnh sửa linh kiện tham chiếu đến mẫu, tham số sẽ được đánh dấu là chưa có giá trị, nhưng không thể khắc phục vì tham số ở chế độ chỉ đọc nên không thể chỉnh sửa. Không thể lưu phiên bản sửa đổi mới của mẫu linh kiện này vào Workspace cho đến khi vấn đề được khắc phục.

    • Khi chỉnh sửa một phiên bản sửa đổi của linh kiện, tham số hiện có do người dùng định nghĩa có cùng tên với một tham số trong mẫu linh kiện được liên kết sẽ được thay thế bằng phiên bản trong mẫu. Mọi giá trị hiện có của tham số đó sẽ được giữ lại (và không bị ghi đè bằng giá trị mặc định trong mẫu).

  • Description – thêm mô tả cho tham số, ví dụ như một ghi chú ngắn gọn về chức năng của tham số. Nếu một tham số trong mẫu đã có mô tả, thì cột Description sẽ được hiển thị trong vùng Parameters của Trình chỉnh sửa linh kiện ở Single Component Editing tương ứng.

Danh sách tham số cũng hỗ trợ các thao tác sao chép và dán đơn giản, cho phép bạn nhân bản một hoặc nhiều tham số người dùng hiện có. Các tham số được dán sẽ được thêm vào cuối danh sách.

Các phím tắt sao chép (Ctrl+C) và dán (Ctrl+V) tiêu chuẩn đều được hỗ trợ, đồng thời các lệnh này cũng có trong menu chuột phải. Bạn có thể chọn nhiều tham số người dùng để sao chép và dán bằng các thao tác Ctrl+Click và Shift+Click tiêu chuẩn.
Để xóa một hoặc nhiều tham số người dùng khỏi danh sách, hãy chọn từng tham số, sau đó nhấp vào nút hoặc sử dụng lệnh Remove trong menu ngữ cảnh khi nhấp chuột phải.

Các kiểu dữ liệu tham số linh kiện có hỗ trợ đơn vị

Trình chỉnh sửa mẫu linh kiện cho phép định nghĩa các kiểu dữ liệu cụ thể cho những tham số linh kiện được định nghĩa trong mẫu linh kiện (*.CMPT). Ngoài ra, các kiểu dữ liệu này có hỗ trợ đơn vị và nhiều tiền tố đơn vị thông dụng. Nhờ đó, bạn có thể nhập giá trị của tham số theo nhiều định dạng – chẳng hạn như 2.2k, 2k2, 4M, 2.5GHz – và Workspace được trang bị khả năng nhận biết giá trị số tương ứng với những dữ liệu nhập này.

Tính năng này của mẫu linh kiện giúp tìm kiếm có mục tiêu thông qua chức năng Tìm kiếm nâng cao của máy chủ – một chức năng không chỉ cho phép tìm kiếm theo loại linh kiện mà còn cho phép tìm kiếm thông minh hơn theo khoảng giá trị. Nhờ các tham số linh kiện có hỗ trợ đơn vị, bạn có thể nhanh chóng thiết lập một tìm kiếm, chẳng hạn để tìm tất cả các tụ điện có điện dung từ 47uF đến 220uF.

Các tham số có hỗ trợ đơn vị cũng được sử dụng để lọc thông minh khi tìm kiếm trong các linh kiện của bạn bằng bảng Components.

Sử dụng các phần có thể thu gọn bên dưới để tìm hiểu thêm về các tham số có hỗ trợ đơn vị.

Các kiểu dữ liệu tham số được định nghĩa bằng từ điển

Từ điển là các kiểu tham số tùy chỉnh có một số giá trị được định nghĩa sẵn. Từ điển được quản trị viên Workspace quản lý trên trang Settings – Vault – Dictionaries trong giao diện trình duyệt của Workspace. Bạn có thể truy cập trang này từ Trình chỉnh sửa mẫu linh kiện bằng cách chọn tùy chọn Add New Dictionary trong danh sách thả xuống Type hoặc nhấp vào nút điều khiển Manage Dictionaries ở góc trên bên phải của vùng Parameters.

  • Bạn cũng có thể truy cập trang Settings – Vault – Dictionaries từ trang Quản lý dữ liệu – Từ điển của hộp thoại Preferences bằng cách nhấp vào nút điều khiển Manage Dictionaries, và từ trang Quản lý dữ liệu – Máy chủ của hộp thoại Preferences bằng cách nhấp vào nút điều khiển Properties cho Workspace đang hoạt động hoặc một Workspace đã biết, rồi chọn mục Dictionaries trong menu.

  • Khi một kiểu được định nghĩa bằng từ điển được chọn cho tham số, bạn cũng có thể truy cập trang Settings – Vault – Dictionaries bằng cách nhấp vào ô của tham số trong cột Type, rồi nhấp vào nút  ().

Truy cập trang quản lý từ điển trong giao diện trình duyệt của Workspace từ Trình chỉnh sửa mẫu linh kiện.
Truy cập trang quản lý từ điển trong giao diện trình duyệt của Workspace từ Trình chỉnh sửa mẫu linh kiện.

Tìm hiểu thêm về quản lý từ điển từ giao diện trình duyệt của Workspace (Altium 365 Workspace, Enterprise Server Workspace).

Các từ điển đã định nghĩa có sẵn dưới dạng kiểu tham số trong danh sách thả xuống Type.

Chọn một kiểu tham số được định nghĩa bằng từ điển trong danh sách thả xuống Kiểu.
Chọn một kiểu tham số được định nghĩa bằng từ điển trong danh sách thả xuống Kiểu.

Các giá trị được định nghĩa cho kiểu từ điển đã chọn có sẵn trong danh sách thả xuống Default Value. Chọn giá trị cần dùng làm giá trị mặc định của tham số hoặc chọn <None>.

Chọn một giá trị mặc định trong các giá trị được định nghĩa cho kiểu từ điển đã chọn.
Chọn một giá trị mặc định trong các giá trị được định nghĩa cho kiểu từ điển đã chọn.

  • Các giá trị mặc định được xác thực khi lưu mẫu linh kiện vào Workspace. Nếu giá trị mặc định không còn phù hợp với từ điển (ví dụ: giá trị đã bị xóa khỏi từ điển, sau đó mẫu sử dụng giá trị này được mở để chỉnh sửa), giá trị mặc định này sẽ được tô đỏ trong cột Giá trị mặc định và thông báo lỗi sẽ xuất hiện trong bảng Messages khi bạn cố lưu mẫu trở lại Workspace.

  • Nếu giá trị của một tham số linh kiện không còn phù hợp với từ điển (ví dụ: kiểu của tham số đó đã được chuyển từ Văn bản sang kiểu được định nghĩa bằng từ điển trong mẫu linh kiện, và giá trị hiện tại của linh kiện không khớp với bất kỳ giá trị nào thuộc kiểu từ điển đã chọn), tham số này sẽ được đánh dấu khi chỉnh sửa linh kiện trong Trình chỉnh sửa linh kiện: biểu tượng dấu chấm than sẽ xuất hiện bên cạnh giá trị tham số không phù hợp khi chỉnh sửa linh kiện ở chế độ Chỉnh sửa một linh kiện, và giá trị tham số sẽ được tô đỏ khi chỉnh sửa linh kiện ở chế độ Chỉnh sửa linh kiện hàng loạt. Hãy đảm bảo tất cả tham số linh kiện đều phù hợp với các giá trị trong mẫu; nếu không, bạn sẽ không thể lưu linh kiện sang phiên bản sửa đổi tiếp theo.

  • Nếu từ điển đã được thay đổi trong giao diện trình duyệt của Workspace đang kết nối, bạn cần ngắt kết nối rồi kết nối lại với Workspace để những thay đổi này được cập nhật trong Altium Designer. Tham khảo trang Truy cập Workspace của bạn để tìm hiểu thêm.

Định nghĩa nhiều footprint

Trình chỉnh sửa mẫu linh kiện cũng hỗ trợ định nghĩa nhiều footprint PCB trong một mẫu linh kiện. Bạn có thể chỉ định số lượng liên kết mô hình footprint tùy ý. Đây là tính năng hữu ích cho những người muốn tạo linh kiện tham chiếu đến 3 footprint, đáp ứng các yêu cầu IPC cho những mức mật độ khác nhau: L (ít nhất, hay lượng đồng tối thiểu), M (nhiều nhất, hay lượng đồng tối đa), và N (danh định, hay lượng đồng trung bình).

Để thêm một định nghĩa mô hình footprint vào mẫu, hãy nhấp vào để thêm tham số mới, rồi chọn mục PCBLIB trong menu thả xuống gắn với trường Type.

Chuyển một tham số mới thêm thành định nghĩa mô hình footprint bằng cách đặt Type của tham số đó thành PCBLIB.
Chuyển một tham số mới thêm thành định nghĩa mô hình footprint bằng cách đặt Type của tham số đó thành PCBLIB.

Tên tham số sẽ đổi từ Parameter thành PCBLIB n, trong đó n là số nguyên khả dụng tiếp theo để phân biệt các mô hình footprint (ví dụ: PCBLIB 1, PCBLIB 2, v.v.). Mô hình mặc định sẽ là mô hình gắn với mục PCBLIB. Khi các footprint được đưa vào Trình chỉnh sửa linh kiện trong quá trình định nghĩa linh kiện, mô hình footprint mặc định được nhận biết bằng biểu tượng ở góc trên bên trái của cửa sổ xem trước mô hình (khi ở chế độ Single Component Editing), và bằng mục PCBLIB (default) trong vùng Required Models/Parameters (khi ở chế độ Batch Component Editing).

Ví dụ về một linh kiện được định nghĩa trong Component Editor (chế độ Single Component Editing), sử dụng một mẫu linh kiện được tham chiếu. Mẫu này định nghĩa ba mô hình footprint, được đưa vào định nghĩa linh kiện. Lưu ý rằng mục mô hình PCBLIB trong mẫu được dùng làm mô hình footprint mặc định (được phân biệt bằng biểu tượng ở góc trên bên trái) khi định nghĩa linh kiện. Di chuột lên hình ảnh để xem cùng linh kiện đó được định nghĩa bằng Component Editor ở chế độ Batch Component Editing. Trong trường hợp này, footprint mặc định được gọi là PCBLIB (default).
Ví dụ về một linh kiện được định nghĩa trong Component Editor (chế độ Single Component Editing), sử dụng một mẫu linh kiện được tham chiếu. Mẫu này định nghĩa ba mô hình footprint, được đưa vào định nghĩa linh kiện. Lưu ý rằng mục mô hình PCBLIB trong mẫu được dùng làm mô hình footprint mặc định (được phân biệt bằng biểu tượng ở góc trên bên trái) khi định nghĩa linh kiện. Di chuột lên hình ảnh để xem cùng linh kiện đó được định nghĩa bằng Component Editor ở chế độ Batch Component Editing. Trong trường hợp này, footprint mặc định được gọi là PCBLIB (default).

Nhập và xuất mẫu linh kiện

Có thể nhập một tệp mẫu linh kiện hiện có (*.CMPT) hoặc tệp thư viện linh kiện (*.CMPLIB) vào trình biên tập mẫu linh kiện, và có thể xuất mẫu linh kiện đang chỉnh sửa thành tệp mẫu linh kiện (*.CMPT). Sử dụng các lệnh File » Import » Component Template, File » Import » Component Library và File » Export trong menu chính của trình biên tập linh kiện để chọn thao tác mong muốn, rồi dùng hộp thoại Windows tiêu chuẩn vừa mở để duyệt đến vị trí cần thiết và chọn tệp để nhập hoặc đặt tên cho tệp sẽ xuất.

Tái sử dụng mẫu linh kiện

Có thể sử dụng một phiên bản của mẫu linh kiện — hay chính xác hơn là tham chiếu đến phiên bản đó từ phiên bản linh kiện bạn đang chỉnh sửa — theo các cách sau.

Mỗi linh kiện chỉ có thể tham chiếu đến một mẫu linh kiện tại một thời điểm.

Khi tạo linh kiện mới

Khi tạo linh kiện mới bằng lệnh File » New » Component từ các menu chính, bạn có thể chọn mẫu trong hộp thoại Create new component.

Liên kết nhanh một mẫu linh kiện từ danh sách tất cả các mẫu có sẵn khi tạo linh kiện mới.
Liên kết nhanh một mẫu linh kiện từ danh sách tất cả các mẫu có sẵn khi tạo linh kiện mới.

Thực hiện thủ công trong Component Editor

Việc tái sử dụng một phiên bản mẫu linh kiện từ Component Editor phụ thuộc vào chế độ hoạt động của trình biên tập.

Trong chế độ chỉnh sửa một linh kiện

Khi chỉnh sửa một linh kiện trong chế độ này của Component Editor, hãy chọn mẫu linh kiện cần dùng từ menu thả xuống của trường Template — thuộc nhóm Advanced Settings, trong vùng Component của trình biên tập. Tất cả các mẫu linh kiện hiện có trong cùng Workspace nơi lưu linh kiện đều được liệt kê theo tên, kèm phiên bản mới nhất trong dấu ngoặc. Chọn mẫu cần dùng để áp dụng.

Liên kết nhanh một mẫu linh kiện từ menu chứa tất cả các mẫu có sẵn khi chỉnh sửa phiên bản của linh kiện bằng Component Editor ở chế độ Single Component Editing.
Liên kết nhanh một mẫu linh kiện từ menu chứa tất cả các mẫu có sẵn khi chỉnh sửa phiên bản của linh kiện bằng Component Editor ở chế độ Single Component Editing.

Trong chế độ chỉnh sửa linh kiện hàng loạt

Có hai cách để liên kết một phiên bản mẫu linh kiện với phiên bản linh kiện đang được chỉnh sửa:

  • Từ tab Template của hộp thoại Tùy chọn tài liệu (Edit » Document Options). Nhấp vào nút Choose ở bên phải trường Item Revision. Thao tác này mở hộp thoại Choose Item (một dạng của bảng Explorer). Sử dụng hộp thoại này để duyệt đến và chọn phiên bản của mẫu linh kiện cần dùng. Sau khi nhấp vào OK, một liên kết sẽ được tạo giữa phiên bản linh kiện và phiên bản mẫu linh kiện đích. Bạn có thể kiểm tra liên kết này trên tab Template của hộp thoại Document Options.

    Liên kết thủ công một linh kiện với một phiên bản mẫu linh kiện trong Workspace đích.
    Liên kết thủ công một linh kiện với một phiên bản mẫu linh kiện trong Workspace đích.

    Có thể thay đổi mẫu linh kiện đang sử dụng bất kỳ lúc nào — nhấp vào Choose và chọn một phiên bản của mẫu linh kiện khác.
    Trạng thái phiên bản Item mẫu linh kiện được liên kết được hiển thị trên tab Template của hộp thoại Document Options. Nếu có phiên bản mới hơn của Item được liên kết, hãy nhấp vào nút để sử dụng phiên bản mới nhất đó.
  • Từ menu Add gắn với vùng Required Models/Parameters của Component Editor. Menu con Templates liệt kê theo tên tất cả các mẫu linh kiện hiện có trong cùng Workspace nơi lưu linh kiện, kèm phiên bản mới nhất trong dấu ngoặc. Nhấp vào một mục để tạo liên kết đến phiên bản mới nhất của mẫu linh kiện đó. Bạn cũng có thể kiểm tra liên kết trên tab Templates của hộp thoại Document Options.

    Liên kết nhanh một mẫu linh kiện từ menu chứa tất cả các mẫu có sẵn.
    Liên kết nhanh một mẫu linh kiện từ menu chứa tất cả các mẫu có sẵn.

Kế thừa từ thư mục linh kiện trong Workspace

Bạn có thể chỉ định một mẫu linh kiện để tự động sử dụng cho tất cả các linh kiện (và các phiên bản của chúng) được lưu trong một thư mục Components thuộc Workspace.

Chỉ có thể định nghĩa mẫu linh kiện mặc định cho thư mục thuộc loại Components.

Chỉ định mẫu cần dùng bằng trường Component Template khi thiết lập thuộc tính của thư mục trong hộp thoại Chỉnh sửa thư mục. Danh sách thả xuống của trường này liệt kê theo tên tất cả các mẫu linh kiện hiện có trong cùng Workspace nơi chứa thư mục Components, kèm phiên bản mới nhất trong dấu ngoặc. Chọn một mục để tạo liên kết đến phiên bản mới nhất của mẫu linh kiện đó cho mỗi linh kiện được tạo sau này trong thư mục.

Chỉ định mẫu linh kiện mặc định để áp dụng cho tất cả các linh kiện được tạo trong thư mục Components cha.
Chỉ định mẫu linh kiện mặc định để áp dụng cho tất cả các linh kiện được tạo trong thư mục Components cha.

Để không sử dụng tính năng này, hãy để/đặt trường Component Template thành None.

Nếu một mẫu linh kiện được chọn ở cấp thư mục, mẫu đó sẽ được sử dụng mặc định khi tạo linh kiện trong các thư mục con bên dưới. Điều này giúp tất cả các linh kiện trong thư mục con nhanh chóng kế thừa mẫu.

Khi một phiên bản linh kiện được lưu vào Workspace, về cơ bản, phiên bản cụ thể của mẫu linh kiện đang sử dụng sẽ được cố định — tạo một liên kết chặt chẽ đến phiên bản đó, trừ khi được thay đổi thủ công.

Ảnh hưởng đến mô hình và tham số linh kiện khi sử dụng mẫu linh kiện

Khi chỉnh sửa một phiên bản linh kiện và liên kết/tham chiếu đến một phiên bản mẫu linh kiện, những thay đổi sau sẽ diễn ra trong Component Editor đối với mô hình và tham số:

  • Các mô hình được định nghĩa trong mẫu được tham chiếu sẽ được thêm vào vùng Models (chế độ Single Component Editing) và vùng Model Links (chế độ Batch Component Editing).
  • Mô hình được tham chiếu hiện có sẽ được giữ lại và linh kiện sẽ tiếp tục sử dụng mô hình đó, trừ khi bạn chủ động thay đổi thủ công.
  • Các tham số được định nghĩa trong mẫu được tham chiếu sẽ được thêm vào vùng Parameters (chế độ Single Component Editing) và vùng Required Models/Parameters (chế độ Batch Component Editing).

    Ví dụ về các tham số sau khi liên kết đến một phiên bản mẫu linh kiện, khi sử dụng Component Editor ở chế độ Single Component Editing (bên trái) và chế độ Batch Component Editing (bên phải).
    Ví dụ về các tham số sau khi liên kết đến một phiên bản mẫu linh kiện, khi sử dụng Component Editor ở chế độ Single Component Editing (bên trái) và chế độ Batch Component Editing (bên phải).

    Tất cả các tham số có nguồn gốc từ mẫu linh kiện được tham chiếu đều được phân biệt bằng biểu tượng (chế độ Single Component Editing) và biểu tượng (chế độ Batch Component Editing). Ngoài ra, riêng trong chế độ chỉnh sửa linh kiện hàng loạt, tùy chọn Show của mỗi tham số dựa trên mẫu sẽ có trạng thái giống với tùy chọn Visible tương ứng trong mẫu.
    Không thể xóa các tham số dựa trên mẫu.
    Bạn có thể tùy ý thêm các tham số do người dùng định nghĩa theo nhu cầu.
  • Chỉ trong chế độ Batch Component Editing, các tham số dựa trên mẫu được thiết lập để hiển thị sẽ được nhóm lại trong vùng định nghĩa linh kiện của trình biên tập, với Template Parameters làm tiêu đề.

    Cách hiển thị các tham số dựa trên mẫu trong ví dụ tại khu vực định nghĩa linh kiện, khi sử dụng Component Editor ở chế độ Batch Component Editing.
    Cách hiển thị các tham số dựa trên mẫu trong ví dụ tại khu vực định nghĩa linh kiện, khi sử dụng Component Editor ở chế độ Batch Component Editing.

  • Các trường giá trị của tham số dựa trên mẫu được đánh dấu là chỉ đọc sẽ không thể chỉnh sửa. Với tất cả các tham số dựa trên mẫu khác không được đánh dấu là chỉ đọc, bạn có thể tùy ý thay đổi giá trị theo nhu cầu.

    Khi Component Editor ở chế độ Single Component Editing, tham số mẫu chỉ đọc được nhận diện trong khu vực Parameters bằng biểu tượng .
  • Nếu một tham số dựa trên mẫu được đánh dấu là bắt buộc nhưng chưa được gán giá trị trong mẫu, trường giá trị của tham số đó sẽ hiển thị với viền đỏ (ở chế độ Batch Component Editing) hoặc chứa biểu tượng (ở chế độ Single Component Editing), để cảnh báo rằng tham số này cần có giá trị. Bạn sẽ không thể lưu linh kiện vào Workspace cho đến khi đã xác định giá trị cho tất cả các tham số bắt buộc.

    Khi Component Editor ở chế độ Single Component Editing, tham số mẫu bắt buộc được nhận diện trong khu vực Parameters bằng biểu tượng .

Lưu lại mẫu linh kiện

Bất cứ lúc nào, bạn cũng có thể quay lại bất kỳ phiên bản nào của mẫu linh kiện trong Workspace và chỉnh sửa trực tiếp. Nhấp chuột phải vào phiên bản đó và chọn lệnh Edit từ menu ngữ cảnh. Trình chỉnh sửa tạm thời sẽ mở lại, đồng thời mở mẫu chứa trong phiên bản đó để chỉnh sửa. Thực hiện các thay đổi cần thiết, sau đó lưu mẫu linh kiện vào phiên bản tiếp theo của Item.

Nhấp chuột phải vào mục cấp cao nhất của mẫu linh kiện sẽ cho phép chỉnh sửa phiên bản mới nhất của mẫu đó.

Truy cập lệnh để bắt đầu chỉnh sửa trực tiếp một phiên bản hiện có của mẫu linh kiện.
Truy cập lệnh để bắt đầu chỉnh sửa trực tiếp một phiên bản hiện có của mẫu linh kiện.

Tải xuống dữ liệu đã lưu

Tải xuống dữ liệu được lưu trong một phiên bản của mẫu linh kiện bằng cách nhấp chuột phải vào phiên bản đó (trong bảng Explorer) và chọn lệnh Operations » Download từ menu ngữ cảnh. Tệp mẫu linh kiện sẽ được tải xuống một thư mục con trong thư mục đã chọn, được đặt tên theo ID phiên bản Item. Bạn có thể tìm thấy tệp trong thư mục Released bên trong đó.

Truy cập lệnh Download từ mục cấp cao nhất của mẫu linh kiện để tải xuống tệp mẫu linh kiện được lưu trong phiên bản mới nhất của mẫu đó.
Nhấp vào nút Explore trong hộp thoại Download from Server để mở nhanh thư mục tải xuống.

Xóa mềm

Khi kết nối với Workspace, bạn có thể sử dụng chức năng linh hoạt để xóa mẫu linh kiện trực tiếp trong Altium Designer, từ bảng Explorer. Nhấp chuột phải vào mục của mẫu linh kiện trong bảng và chọn lệnh Delete Item từ menu ngữ cảnh. Hộp thoại Delete Items sẽ xuất hiện để bạn xác nhận việc xóa. Thao tác này thực chất là “xóa mềm”, theo đó mẫu linh kiện sẽ được chuyển vào khu vực Trash của Workspace. Trash về cơ bản là một thùng rác, nơi có thể chuyển bất kỳ nội dung nào trong Workspace vào đó (thông qua thao tác xóa mềm). Khu vực này được tách biệt với phần còn lại của Workspace.

Với chức năng xóa mềm, bạn có thể xóa một mẫu linh kiện hiện đang được sử dụng.
Có thể xóa nhiều mẫu linh kiện trong một thao tác. Chọn tất cả các mẫu linh kiện cần xóa bằng các thao tác chọn nhiều mục thông thường (Shift+Click, Ctrl+Click), sau đó nhấp chuột phải và chọn lệnh Delete Items từ menu ngữ cảnh.

Xóa mềm một mẫu linh kiện. Mẫu sẽ được chuyển vào khu vực Trash của Workspace.
Xóa mềm một mẫu linh kiện. Mẫu sẽ được chuyển vào khu vực Trash của Workspace.

Để tiếp tục xóa, nhấp vào nút . Mục sẽ được xóa và hộp thoại Deletion Summary sẽ xác nhận việc xóa thành công. Nếu có vấn đề xảy ra khi xóa, bạn sẽ nhận được thông báo.

Tất cả nội dung được xóa theo cách này đều có thể tìm thấy trên trang Trash trong giao diện trình duyệt của Workspace. Lưu ý rằng bạn chỉ có thể xem nội dung do chính bạn xóa mềm. Quản trị viên có thể xem toàn bộ nội dung của trang Trash – tức là tất cả nội dung đã được xóa mềm.

Những điều cần lưu ý đối với mẫu linh kiện đã được xóa mềm:

  • Mẫu linh kiện sẽ không còn khả dụng trong phần mềm thiết kế của bạn hoặc trong giao diện Web.
  • Mọi nơi đang sử dụng mẫu linh kiện đó sẽ hiển thị thông tin rằng mẫu linh kiện đã bị xóa.
  • Một mẫu linh kiện có thể được khôi phục hoặc xóa vĩnh viễn từ trang Trash, với điều kiện bạn có quyền chỉnh sửa. Chỉ có thể xóa vĩnh viễn khi mẫu không được Item cha sử dụng.
Lưu ý rằng nếu bạn đã xóa mềm một mẫu linh kiện – chuyển mẫu vào Trash – bạn có thể tạo một mẫu linh kiện mới có cùng tên. Nếu sau đó bạn khôi phục mẫu linh kiện ban đầu mà tên gốc đã được sử dụng, một hậu tố số nguyên sẽ được thêm vào để đảm bảo tên của mẫu là duy nhất trong Workspace.
AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nav
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents