Làm việc với Pads & Vias
Sơ lược
- Bạn sẽ tìm hiểu sự khác biệt thực tế giữa pad và via, bao gồm cấu trúc, mục đích sử dụng và các loại via chính được dùng trong thiết kế PCB.
- Bạn sẽ biết cách đặt, di chuyển, chuyển đổi và gán pad và via trong các quy trình làm việc của Altium Designer.
- Bạn sẽ có cái nhìn tổng quan về cách quản lý thuộc tính của pad và via, bao gồm việc sử dụng mẫu và các tùy chọn chỉnh sửa chính trong bảng Properties.
Tổng quan về pad và via
Pad được dùng để cố định cơ học và kết nối điện với các chân linh kiện
Pad là một đối tượng thiết kế cơ bản. Pad được dùng để cố định linh kiện lên bo mạch và tạo các điểm kết nối từ chân linh kiện đến đường mạch trên bo. Pad có thể nằm trên một lớp, chẳng hạn như pad của linh kiện gắn bề mặt, hoặc là pad xuyên lỗ ba chiều, có thân dạng ống theo phương Z (thẳng đứng) với vùng phẳng trên mỗi lớp đồng (nằm ngang). Thân dạng ống của pad được hình thành khi bo mạch được khoan và mạ xuyên lỗ trong quá trình chế tạo. Trong mặt phẳng XY, pad có thể có hình tròn, chữ nhật, bát giác, chữ nhật bo góc, chữ nhật vát góc hoặc hình dạng tùy chỉnh. Pad có thể được dùng riêng lẻ dưới dạng pad tự do trong thiết kế, nhưng phổ biến hơn là được dùng trong trình biên tập thư viện PCB, nơi chúng được kết hợp với các đối tượng cơ bản khác để tạo thành footprint linh kiện.

Một via kéo dài và kết nối từ lớp trên cùng (đỏ) đến lớp dưới cùng (xanh dương), đồng thời kết nối với một mặt phẳng nguồn bên trong (xanh lá).
Via là một đối tượng thiết kế cơ bản. Via được dùng để tạo kết nối điện theo phương thẳng đứng giữa hai hoặc nhiều lớp điện của PCB. Via là đối tượng ba chiều và có thân dạng ống theo phương Z (thẳng đứng), với một vòng phẳng trên mỗi lớp đồng (nằm ngang). Thân dạng ống của via được hình thành khi bo mạch được khoan và mạ xuyên lỗ trong quá trình chế tạo. Trong mặt phẳng XY, via có hình tròn, giống như pad tròn. Điểm khác biệt chính giữa via và pad là ngoài khả năng xuyên qua tất cả các lớp của bo mạch (từ trên xuống dưới), via còn có thể kéo dài từ một lớp bề mặt đến một lớp bên trong hoặc giữa hai lớp bên trong.
Đặt trực tiếp pad và via
Pad và via có thể được đặt trong cả trình biên tập PCB và trình biên tập footprint PCB. Via thường được đặt tự động trong quá trình đi dây tương tác hoặc tự động, nhưng cũng có thể được đặt thủ công nếu cần. Via được đặt thủ công được gọi là via 'tự do'. Sau khi khởi chạy lệnh đặt pad (Place » Pad) hoặc via (Place » Via), con trỏ sẽ chuyển thành dấu chữ thập và bạn sẽ vào chế độ đặt.
- Định vị con trỏ, sau đó nhấp chuột hoặc nhấn Enter để đặt pad/via.
- Tiếp tục đặt thêm pad/via, hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ đặt.
Trong khi đặt, nhấn phím Alt để giới hạn hướng di chuyển theo trục ngang hoặc trục dọc tùy theo hướng di chuyển ban đầu.
Chỉnh sửa bằng thao tác đồ họa
Không thể thay đổi các thuộc tính của pad và via bằng thao tác đồ họa, ngoại trừ vị trí của chúng.
- Để di chuyển một pad tự do đồng thời di chuyển các đường mạch được kết nối, hãy nhấp, giữ và di chuyển pad. Các đường mạch được kết nối sẽ vẫn gắn với pad khi pad được di chuyển. Lưu ý rằng pad sẽ không di chuyển nếu thuộc về một linh kiện.
- Để di chuyển một pad tự do mà không di chuyển các đường mạch kết nối với nó trong PCB Editor hoặc PCB Library Editor, chọn lệnh Edit » Move » Move, sau đó nhấp, giữ và di chuyển pad.
Chỉnh sửa phi đồ họa thông qua bảng Properties
Phương pháp chỉnh sửa này sử dụng chế độ tương ứng của bảng Properties để sửa đổi các thuộc tính của đối tượng Pad/Via.
Thuộc tính pad

Chế độ Pad của bảng Properties
Thông tin net
Vùng này cung cấp thông tin về net mà pad thuộc về, cũng như cặp vi sai và/hoặc xSignal nếu net đó là một thành viên. Thông tin lớp được hiển thị khi thích hợp. Các giá trị Delay và Length cũng được cung cấp.
Tham khảo trang Kỹ thuật bố trí và chỉnh sửa PCB để tìm hiểu thêm về thông tin net.
Thuộc tính
-
Component – trường này chỉ hiển thị trong PCB Editor khi pad được chọn là một phần của linh kiện PCB và hiển thị ký hiệu định danh của linh kiện PCB cha. Nhấp vào liên kết Component để mở chế độ Component của bảng Properties cho linh kiện cha.
-
Designator – trường này hiển thị ký hiệu định danh hiện tại của pad. Nếu pad là một phần của linh kiện, ký hiệu định danh thường được đặt theo số chân tương ứng của linh kiện. Pad tự do có thể có ký hiệu định danh hoặc để trống trường này. Nếu ký hiệu định danh bắt đầu hoặc kết thúc bằng một số, số đó sẽ tự động tăng khi đặt liên tiếp một chuỗi pad. Chỉnh sửa giá trị trong trường này để thay đổi ký hiệu định danh của pad.
-
Layer – chọn lớp mà pad được gán vào. Chọn Multi-Layer để định nghĩa một pad xuyên lỗ.
-
Net – dùng để chọn net cho pad. Tất cả các net của thiết kế bo mạch đang hoạt động sẽ được liệt kê trong danh sách thả xuống. Chọn No Net để chỉ định rằng pad không kết nối với bất kỳ net nào. Thuộc tính Net của một đối tượng cơ bản được công cụ kiểm tra quy tắc thiết kế sử dụng để xác định xem đối tượng PCB có được đặt hợp lệ hay không. Ngoài ra, bạn có thể nhấp vào biểu tượng Assign Net để chọn một đối tượng trong không gian thiết kế – net của đối tượng đó sẽ được gán cho các pad đã chọn.
-
Electrical Type – trường này hiển thị trạng thái điện hiện tại của pad. Trạng thái này chỉ áp dụng cho các pad của linh kiện và thiết lập các đặc tính đường truyền cho các pad đó. Pad có thể được chỉ định là Load, Source hoặc Terminator. Các thiết lập Source và Terminator được sử dụng khi một net yêu cầu một trong các cấu trúc đi dây nối chuỗi Daisy chain. Nhấp vào trường này để thay đổi loại điện từ danh sách thả xuống.
-
Propagation Delay – trường này liệt kê độ trễ lan truyền, là khoảng thời gian để đầu tín hiệu truyền từ bên gửi đến bên nhận.
-
Pin Package Length – chiều dài chân trong vỏ linh kiện (Pin Package Length) được tự động tính vào các phép tính Signal Length hiển thị trong bảng PCB. Đặt bảng PCB ở chế độ Nets để xem (hoặc chỉnh sửa) giá trị Pin/Pkg Length của các chân trong net đã chọn.
-
Jumper – trường này cung cấp số định danh kết nối jumper (trong khoảng 1 – 1000) cho pad khi bạn sử dụng kết nối jumper trên PCB. Kết nối jumper sử dụng dây dẫn để nối vật lý các pad trên PCB và không sử dụng đường mạch hay các đối tượng điện trên bo mạch. Giá trị Jumper cho phần mềm biết những pad nào cần được coi là 'đã kết nối'. Kết nối jumper chỉ có thể được tạo giữa các pad trong cùng một footprint linh kiện. Các pad được sử dụng phải có cùng giá trị Jumper và cũng phải thuộc cùng một net. Kết nối jumper được hiển thị dưới dạng một đường kết nối cong trong PCB Editor. Sử dụng các mũi tên cuộn hoặc nhập trực tiếp số định danh kết nối jumper mong muốn.
-
Template – hiển thị mẫu hiện tại của pad. Sử dụng danh sách thả xuống để chọn một mẫu khác. Nếu có Library được liên kết, thư viện đó sẽ được hiển thị. Nhấp vào nút
để hủy liên kết mẫu với thư viện mẫu Pad/Via được liên kết.
-
(X/Y)
-
X (trường thứ nhất) – trường này hiển thị tọa độ X hiện tại của tâm pad so với gốc tọa độ hiện tại. Chỉnh sửa giá trị trong trường để thay đổi vị trí của pad so với gốc tọa độ hiện tại. Giá trị có thể được nhập theo hệ mét hoặc hệ inch; hãy kèm theo đơn vị khi nhập một giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ inch) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (được truy cập khi không có đối tượng nào được chọn trong không gian thiết kế), và được sử dụng nếu không chỉ định đơn vị.
-
Y (trường thứ hai) – trường này hiển thị tọa độ Y hiện tại của tâm pad so với gốc tọa độ hiện tại. Chỉnh sửa giá trị trong trường để thay đổi vị trí của pad so với gốc tọa độ hiện tại. Giá trị có thể được nhập theo hệ mét hoặc hệ inch; hãy kèm theo đơn vị khi nhập một giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ inch) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (được truy cập khi không có đối tượng nào được chọn trong không gian thiết kế), và được sử dụng nếu không chỉ định đơn vị.
-
-
Rotation – góc xoay của pad (tính bằng độ), được đo ngược chiều kim đồng hồ từ góc 0 (phương ngang 3 o'clock). Chỉnh sửa trường này để thay đổi góc xoay của pad. Độ phân giải góc tối thiểu là 0.001°.
Cấu trúc lớp pad
-
Simple / Top-Middle-Bottom / Full Stack – chọn chế độ cấu trúc lớp pad mong muốn cho pad xuyên lỗ (tức là khi Multi-Layer được chọn làm Layer của pad). Đối với các lớp khác, các tùy chọn của chế độ Simple được áp dụng.
-
Simple – chọn để sử dụng pad có cấu trúc lớp đơn giản. Bạn có thể xác định các thuộc tính hình dạng pad dùng chung cho tất cả các lớp đồng tín hiệu của pad này.
-
Top-Middle-Bottom – chọn để sử dụng pad có cấu trúc lớp Trên-Giữa-Dưới. Bạn có thể xác định kích thước X và Y cùng các thuộc tính hình dạng cho các lớp đồng tín hiệu trên, giữa và dưới của pad này.
-
Full Stack – chọn để sử dụng pad có cấu trúc lớp đầy đủ. Bạn có thể xác định kích thước X và Y cùng các thuộc tính hình dạng cho tất cả các lớp đồng tín hiệu của pad này.
-
-
Copper – mở rộng các vùng có thể thu gọn hoặc sử dụng bảng để xác định các thuộc tính của pad trên các lớp đồng tín hiệu. Các lớp đồng khả dụng phụ thuộc vào lớp đặt pad và chế độ cấu trúc lớp pad đã chọn.
- Shape – chọn hình dạng pad. Có thể điều chỉnh các hình dạng pad tiêu chuẩn (Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle và Donut) bằng cách thay đổi các thiết lập X và Y để tạo ra các hình dạng pad bất đối xứng. Chọn Custom Shape để xác định pad có hình dạng phi tiêu chuẩn (tìm hiểu thêm).
-
Edit Shape – nhấp để chỉnh sửa tương tác vùng của pad có hình dạng tùy chỉnh trong không gian thiết kế. Nút này chỉ khả dụng nếu Custom Shape được chọn làm Shape.
-
(X/Y) – xác định kích thước X (ngang) và Y (dọc) của pad. Có thể đặt kích thước X và Y độc lập để xác định các hình dạng pad bất đối xứng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm theo đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (được truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị. Tùy chọn này chỉ khả dụng nếu Rounded Rectangle hoặc Chamfered Rectangle được chọn làm Shape.
-
Corner Radius – nhập giá trị tuyệt đối cho bán kính bo góc/kích thước vát góc của pad. Giá trị phải nhỏ hơn hoặc bằng một nửa cạnh ngắn nhất của pad. Giá trị phần trăm được tính toán (theo một nửa cạnh ngắn nhất của pad) sẽ hiển thị ở bên phải trường. Nhập một giá trị theo sau bởi ký hiệu
%để xác định bán kính bo góc/kích thước vát góc theo phần trăm của một nửa cạnh ngắn nhất của pad, trong đó100%bo tròn hoàn toàn cạnh ngắn nhất (trong trường hợp này, giá trị tuyệt đối được tính toán sẽ hiển thị ở bên phải trường). Tùy chọn này chỉ có thể truy cập nếu Rounded Rectangle hoặc Chamfered Rectangle được chọn cho Shape của pad trên lớp đồng tương ứng. -
Upper Left, Upper Right, Lower Left, Lower Right – cho phép bo tròn/vát các góc của hình dạng pad. Các tùy chọn này chỉ khả dụng nếu Rounded Rectangle hoặc Chamfered Rectangle được chọn cho Shape của pad trên lớp đồng tương ứng.
-
Outer Diameter – nhập đường kính ngoài của pad. Tùy chọn này chỉ khả dụng nếu Donut được chọn cho Shape của pad trên lớp đồng tương ứng.
-
Width – nhập chiều rộng của pad. Tùy chọn này chỉ khả dụng nếu Donut được chọn cho Shape của pad trên lớp đồng tương ứng.
-
Thermal Relief – bật để tùy chỉnh kết nối giảm nhiệt cho pad, ghi đè quy tắc Polygon Connect Style hiện hành. Sau khi chọn, nhấp vào liên kết để mở hộp thoại Polygon Connect Style, nơi bạn có thể thay đổi các tùy chọn kết nối giảm nhiệt theo yêu cầu. Nhấp vào nút Edit Points để xác định thủ công các điểm kết nối của các nhánh giảm nhiệt. Tìm hiểu thêm về Xác định kết nối giảm nhiệt tùy chỉnh.
-
Center Offset (X/Y) (chỉ dành cho pad SMD, tức là khi một lớp khác với Multi-Layer được chọn làm Layer của pad) – nhập giá trị để dịch chuyển vùng tiếp xúc của pad so với tâm của nó.
-
Hole – mở rộng vùng có thể thu gọn hoặc sử dụng bảng để xác định các thuộc tính lỗ của pad. Các tùy chọn lỗ chỉ khả dụng cho pad xuyên lỗ (tức là khi Multi-Layer được chọn làm Layer của pad).
-
Shape – chọn hình dạng lỗ mong muốn.
- Round – chỉ định hình dạng lỗ tròn cho kích thước lỗ của pad. Các tệp khoan riêng biệt (định dạng NC Drill Excellon 2) được tạo cho từng loại lỗ, cũng như cho lỗ có mạ và không mạ. Có tối đa sáu tệp khoan khác nhau cho các loại này.
- Rectangular – chỉ định lỗ hình chữ nhật (đột) cho pad này. Lỗ hình chữ nhật có thể được mạ hoặc không mạ. Các tệp khoan riêng biệt (định dạng NC Drill Excellon 2) được tạo cho từng loại lỗ, cũng như cho lỗ có mạ và không mạ. Có tối đa sáu tệp khoan khác nhau cho các loại này.
- Slot – chỉ định lỗ dạng rãnh có hai đầu bo tròn cho pad này. Lỗ dạng rãnh có thể được mạ hoặc không mạ. Các tệp khoan riêng biệt (định dạng NC Drill Excellon 2) được tạo cho từng loại lỗ, cũng như cho lỗ có mạ và không mạ. Có tối đa sáu tệp khoan khác nhau cho các loại này.
- Size – trường này hiển thị kích thước lỗ hiện tại của pad. Giá trị này chỉ định đường kính của lỗ tròn (hoặc chiều rộng của lỗ hình chữ nhật hay lỗ dạng rãnh) tính bằng mil hoặc mm sẽ được tạo trên pad trong quá trình chế tạo. Đối với pad SMD hoặc đầu nối cạnh bo mạch, giá trị này nên được đặt bằng 0. Kích thước lỗ có thể được đặt từ 0 đến 1000 mil và có thể lớn hơn pad để xác định các lỗ cơ khí (không có đồng), nhưng không được lớn hơn Length của lỗ Rectangular hoặc Slot. Chỉnh sửa giá trị trong trường này để thay đổi kích thước lỗ của pad. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm theo đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (được truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị.
-
Tolerance – thiết lập các thuộc tính dung sai lỗ có thể giúp xác định độ lắp ghép và các giới hạn của bo mạch. Chỉ định dung sai tối thiểu (-) và tối đa (+) cho lỗ.
-
Length – hiển thị chiều dài của lỗ trên pad khi Shape của lỗ được đặt thành Rectangular hoặc Slot. Giá trị này chỉ định chiều dài tính bằng mm hoặc mil, để phay NC trên pad trong quá trình chế tạo. Kích thước lỗ có thể được đặt từ 0 đến 1000 mil và có thể lớn hơn pad để xác định các lỗ cơ khí (không có đồng), nhưng không được nhỏ hơn Size của lỗ Rectangular hoặc Slot (sử dụng thiết lập góc xoay để đạt được định hướng X-Y cần thiết). Chỉnh sửa giá trị trong trường này để thay đổi chiều dài. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm theo đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (được truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị. Tùy chọn này không khả dụng nếu Shape của lỗ được đặt thành Round.
- Rotation – hiển thị góc xoay ngược chiều kim đồng hồ hiện tại của lỗ so với pad, tính bằng độ. Chỉnh sửa trường này để thay đổi góc xoay. Độ phân giải góc tối thiểu là 0,001°. Tùy chọn này chỉ khả dụng nếu Rectangular hoặc Slot được chọn làm Shape của lỗ.
- Copper Offset (X/Y) – nhập một giá trị để dịch chuyển vùng tiếp xúc của pad so với tâm lỗ của pad.
- Plated – tùy chọn này xác định lỗ của pad có được mạ hay không. Dấu kiểm trong trường này đặt pad thành pad có lỗ mạ. Nếu thiết kế có cả pad có mạ và không mạ, các lỗ không mạ sẽ được thiết lập để sử dụng dụng cụ khác với các lỗ có mạ trong tệp khoan NC.
-
Shape – chọn hình dạng lỗ mong muốn.
-
Paste – mở rộng các vùng có thể thu gọn hoặc sử dụng bảng lưới để xác định các thuộc tính của pad trên các lớp mặt nạ kem hàn. Các lớp mặt nạ kem hàn khả dụng phụ thuộc vào lớp mà pad được đặt.
-
Shape – chọn hình dạng trên lớp mặt nạ kem hàn.
-
Rule Expansion – chọn để độ mở rộng mặt nạ kem hàn của pad tuân theo giá trị được xác định trong quy tắc thiết kế Độ mở rộng mặt nạ kem hàn áp dụng.
-
Manual Expansion – chọn để chỉ định giá trị độ mở rộng mặt nạ kem hàn cho pad.
-
Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle, và Donut – chọn để xác định hình dạng mặt nạ kem hàn tiêu chuẩn. Có thể điều chỉnh các hình dạng này bằng cách thay đổi thiết lập X và Y để tạo ra các hình dạng bất đối xứng.
- Đối với hình dạng Donut , D biểu thị đường kính ngoài của vành khuyên, còn W biểu thị chiều rộng.
-
Custom Shape – chọn để xác định hình dạng mặt nạ kem hàn không tiêu chuẩn.
-
-
Edit – nhấp để chỉnh sửa tương tác hình dạng tùy chỉnh trên lớp mặt nạ kem hàn trong không gian thiết kế. Nút này chỉ khả dụng nếu Custom Shape được chọn làm Shape.
-
Paste Expansion – nhập giá trị mở rộng mặt nạ kem hàn mong muốn. Giá trị có thể được xác định dưới dạng giá trị tuyệt đối (mil/mm) hoặc phần trăm diện tích pad. Khi nhập giá trị tuyệt đối, hãy kèm theo đơn vị nếu đơn vị của giá trị đó không phải là đơn vị mặc định hiện tại. Đơn vị mặc định được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị. Tùy chọn này chỉ khả dụng nếu Manual Expansion được chọn làm Shape và việc sử dụng mặt nạ kem hàn được Enabled.
-
(X/Y) – xác định kích thước X (ngang) và Y (dọc) của hình dạng mặt nạ kem hàn. Kích thước X và Y có thể được thiết lập độc lập để tạo các hình dạng bất đối xứng. Có thể nhập giá trị theo hệ mét hoặc hệ đo lường Anh; hãy kèm theo đơn vị nếu đơn vị của giá trị đó không phải là đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ đo lường Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị. Tùy chọn này chỉ khả dụng nếu Round, Rectangular, Octagonal, Rounded Rectangle hoặc Chamfered Rectangle được chọn làm Shape.
-
Corner Radius – nhập giá trị tuyệt đối của bán kính bo góc/kích thước vát góc của hình dạng mặt nạ kem hàn. Giá trị phải nhỏ hơn hoặc bằng một nửa cạnh ngắn nhất của hình dạng mặt nạ kem hàn. Giá trị phần trăm được tính toán (tỷ lệ phần trăm của một nửa cạnh ngắn nhất của hình dạng mặt nạ kem hàn) sẽ hiển thị bên phải trường nhập. Nhập một giá trị theo sau bởi ký hiệu
%để xác định bán kính bo góc/kích thước vát góc theo phần trăm của một nửa cạnh ngắn nhất của hình dạng mặt nạ kem hàn, trong đó100%sẽ bo tròn hoàn toàn cạnh ngắn nhất (trong trường hợp này, giá trị tuyệt đối được tính toán sẽ hiển thị bên phải trường nhập). Tùy chọn này chỉ có thể truy cập nếu Rounded Rectangle hoặc Chamfered Rectangle được chọn cho Shape của pad trên lớp mặt nạ kem hàn tương ứng. -
Upper Left, Upper Right, Lower Left, Lower Right – cho phép bo tròn/vát các góc của hình dạng mặt nạ kem hàn. Các tùy chọn này chỉ khả dụng nếu Rounded Rectangle hoặc Chamfered Rectangle được chọn cho Shape của pad trên lớp mặt nạ kem hàn tương ứng.
-
Offset (X/Y) – nhập giá trị để dịch chuyển hình dạng mặt nạ kem hàn so với tâm pad.
-
Outer Diameter – nhập đường kính ngoài của pad. Tùy chọn này chỉ khả dụng nếu Donut được chọn cho Shape của pad trên lớp mặt nạ kem hàn tương ứng.
-
Width – nhập chiều rộng của pad. Tùy chọn này chỉ khả dụng nếu Donut được chọn cho Shape của pad trên lớp mặt nạ kem hàn tương ứng.
-
Enabled – sử dụng tùy chọn này để bật/tắt việc sử dụng hình dạng mặt nạ kem hàn cho pad. Tùy chọn này chỉ khả dụng nếu một tùy chọn khác với Rule Expansion được chọn làm Shape.
-
-
Solder – mở rộng (các) vùng có thể thu gọn hoặc sử dụng bảng để xác định các thuộc tính của pad trên các lớp mặt nạ hàn. Các lớp mặt nạ hàn khả dụng phụ thuộc vào lớp đặt pad.
-
Shape – chọn hình dạng trên lớp mặt nạ hàn.
-
Rule Expansion – chọn để độ mở rộng mặt nạ hàn của pad tuân theo giá trị được xác định trong quy tắc thiết kế Solder Mask Expansion áp dụng.
-
Manual Expansion – chọn để chỉ định giá trị mở rộng mặt nạ hàn cho pad.
- Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle và Donut – chọn để xác định hình dạng mặt nạ hàn tiêu chuẩn. Có thể điều chỉnh các hình dạng này bằng cách thay đổi thiết lập X và Y để tạo các hình dạng bất đối xứng.
-
Custom Shape – chọn để xác định hình dạng mặt nạ hàn không tiêu chuẩn.
-
-
Edit – nhấp để chỉnh sửa tương tác hình dạng tùy chỉnh trên lớp mặt nạ hàn trong không gian thiết kế. Nút này chỉ khả dụng nếu Custom Shape được chọn làm Shape.
-
Solder Expansion – nhập giá trị mở rộng mặt nạ kem hàn mong muốn. Giá trị có thể được xác định dưới dạng giá trị tuyệt đối (mil/mm) hoặc phần trăm diện tích pad. Khi nhập giá trị tuyệt đối, hãy kèm theo đơn vị nếu đơn vị của giá trị đó không phải là đơn vị mặc định hiện tại. Đơn vị mặc định được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị. Tùy chọn này chỉ khả dụng nếu Manual Expansion được chọn làm Shape và tùy chọn Tented bị tắt.
-
From Hole Edge – khi được bật, cửa mở mặt nạ hàn sẽ theo hình dạng của lỗ. Do đó, mặt nạ độc lập với hình dạng và kích thước pad, đồng thời được điều chỉnh theo cả kích thước và hình dạng lỗ. Ví dụ, một pad có lỗ vuông sẽ tạo ra cửa mở mặt nạ hình vuông phù hợp với kích thước lỗ và giá trị mở rộng đã gán. Ngoài ra, lưu ý rằng kích thước cửa mở mặt nạ mở rộng của pad sẽ thay đổi theo mọi thay đổi về kích thước lỗ. Tùy chọn này chỉ khả dụng cho các pad xuyên lỗ (tức là khi Multi-Layer được chọn làm Layer của pad) nếu Manual Expansion được chọn làm Shape và tùy chọn Tented bị vô hiệu hóa.
-
(X/Y) – xác định kích thước X (ngang) và Y (dọc) của hình dạng mặt nạ hàn. Có thể đặt kích thước X và Y độc lập để tạo các hình dạng bất đối xứng. Giá trị có thể được nhập theo hệ mét hoặc hệ inch; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ inch) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị. Tùy chọn này chỉ khả dụng nếu Round, Rectangular, Octagonal, Rounded Rectangle hoặc Chamfered Rectangle được chọn làm Shape.
-
Corner Radius – nhập giá trị tuyệt đối cho bán kính bo góc/kích thước vát góc của hình dạng mặt nạ hàn. Giá trị phải nhỏ hơn hoặc bằng một nửa cạnh ngắn nhất của hình dạng mặt nạ hàn. Giá trị phần trăm được tính toán (tỷ lệ phần trăm của một nửa cạnh ngắn nhất của hình dạng mặt nạ hàn) sẽ hiển thị ở bên phải trường này. Nhập một giá trị theo sau là ký hiệu
%để xác định bán kính bo góc/kích thước vát góc theo tỷ lệ phần trăm của một nửa cạnh ngắn nhất của hình dạng mặt nạ hàn, trong đó100%bo tròn hoàn toàn cạnh ngắn nhất (trong trường hợp này, giá trị tuyệt đối được tính toán sẽ hiển thị ở bên phải trường). Tùy chọn này chỉ có thể truy cập nếu Rounded Rectangle hoặc Chamfered Rectangle được chọn cho Shape của pad trên lớp mặt nạ hàn tương ứng. -
Upper Left, Upper Right, Lower Left, Lower Right – cho phép bo tròn/vát các góc của hình dạng mặt nạ hàn. Các tùy chọn này chỉ khả dụng nếu Rounded Rectangle hoặc Chamfered Rectangle được chọn cho Shape của pad trên lớp mặt nạ hàn tương ứng.
-
Offset (X/Y) – nhập giá trị để dịch chuyển hình dạng mặt nạ hàn so với tâm pad.
-
Outer Diameter – nhập đường kính ngoài của pad. Tùy chọn này chỉ khả dụng nếu Donut được chọn cho Shape của pad trên lớp mặt nạ hàn tương ứng.
-
Width – nhập chiều rộng của pad. Tùy chọn này chỉ khả dụng nếu Donut được chọn cho Shape của pad trên lớp mặt nạ hàn tương ứng.
-
Tented – chọn nếu muốn ghi đè mọi thiết lập mặt nạ hàn trong các quy tắc thiết kế về độ mở rộng mặt nạ hàn, khiến mặt nạ hàn trên lớp trên/dưới của pad này không có lỗ mở và do đó pad được phủ kín. Tắt tùy chọn này để pad chịu tác động của quy tắc mở rộng mặt nạ hàn hoặc giá trị mở rộng cụ thể. Tùy chọn này chỉ khả dụng nếu một tùy chọn khác với Rule Expansion được chọn làm Shape.
-
/
– khi Manual Expansion được chọn làm Shape, có thể truy cập vùng Bottom Solder Mask (và do đó cả tùy chọn Solder Expansion của vùng này) nếu nút được đặt thành
. Khi nút ở trạng thái
, giá trị mở rộng mặt nạ hàn của lớp dưới sẽ giống với lớp trên.
-
Đặc điểm của pad
Top Side / Bottom Side – chọn tùy chọn mong muốn cho lỗ khoét bậc của pad ở mặt trên/dưới của bo mạch. Các tùy chọn khả dụng: None, Counterbore, Countersink. Các tùy chọn này chỉ khả dụng cho pad xuyên lỗ tròn (tức là khi Multi-Layer được chọn làm Layer của pad và Round được chọn làm hình dạng lỗ của pad).
Các lỗ khoét bậc trong tấm nền tạo không gian cho đầu vít. Lỗ khoét côn và lỗ khoét trụ là hai loại lỗ khoét bậc phù hợp với các loại vít khác nhau. Phiên bản này bổ sung khả năng chọn lỗ khoét trụ hoặc lỗ khoét côn. Điểm khác biệt chính giữa vít dùng lỗ khoét côn và vít dùng lỗ khoét trụ là kích thước và hình dạng của lỗ; lỗ khoét trụ rộng hơn và có biên dạng vuông hơn để có thể lắp thêm vòng đệm. Lỗ khoét côn tạo ra một lỗ hình nón khớp với bề mặt nghiêng ở mặt dưới của đầu vít chìm. Lỗ khoét côn là một lỗ hình nón được cắt vào tấm nền. Lỗ này thường được dùng để đầu côn của vít nằm ngang bằng với bề mặt trên của tấm nền. Ngược lại, lỗ khoét trụ có đáy phẳng và thành lỗ được khoan thẳng xuống. Loại lỗ này thường được dùng để lắp đầu bu lông hoặc vít lục giác. Mỗi pad chỉ được phép có một lỗ khoét côn hoặc lỗ khoét trụ.
Một đường nét đứt xuất hiện quanh pad trong chế độ 2D để xác định đường bao của lỗ khoét bậc trên lớp đang hoạt động. Lỗ khoét bậc được hỗ trợ trong 2D, 3D và Draftsman.
Điểm kiểm tra
Fabrication/Assembly – các tùy chọn này cho phép bạn chỉ định các pad (xuyên lỗ hoặc SMD) làm vị trí điểm kiểm tra trong quá trình kiểm tra chế tạo và/hoặc lắp ráp. Bật Top để xác định pad này là điểm kiểm tra trên lớp trên. Bật Bottom để xác định pad này là điểm kiểm tra trên lớp dưới.
Thuộc tính via

Chế độ Via của bảng Properties
Thông tin net
Vùng này cung cấp thông tin về net mà via thuộc về, cũng như cặp vi sai và/hoặc xSignal nếu net đó là một thành viên. Thông tin về lớp được hiển thị khi phù hợp. Các giá trị Delay, Length, Max Current và Resistance cũng được cung cấp.
Tham khảo trang Kỹ thuật bố trí & chỉnh sửa PCB để tìm hiểu thêm về thông tin net.
Định nghĩa
-
Component – trường này chỉ hiển thị trong trình biên tập PCB khi via được chọn là một phần cấu thành của linh kiện PCB và hiển thị ký hiệu định danh của linh kiện PCB mẹ. Chọn liên kết Component có thể nhấp để mở chế độ Linh kiện của bảng Properties cho linh kiện mẹ.
-
Net – dùng để chọn net cho via. Tất cả các net của thiết kế bo mạch đang hoạt động sẽ được liệt kê trong danh sách thả xuống. Chọn No Net để chỉ định rằng via không được kết nối với bất kỳ net nào. Net thuộc tính của một đối tượng nguyên thủy được Trình kiểm tra quy tắc thiết kế sử dụng để xác định xem một đối tượng PCB có được đặt hợp lệ hay không. Ngoài ra, bạn có thể nhấp vào biểu tượng Assign Net để chọn một đối tượng trong không gian thiết kế — net của đối tượng đó sẽ được gán cho các via đã chọn.
-
Name – khi một hoặc nhiều via được chọn, tên các via sẽ được hiển thị khi nhấp vào danh sách thả xuống, trong đó liệt kê tất cả các khoảng lớp của via được định nghĩa trong Layer Stack. Tất cả các via được sử dụng trên bo mạch phải thuộc một trong các khoảng lớp của via được định nghĩa trong Layer Stack.
-
Propagational Delay – trường này liệt kê độ trễ lan truyền, tức là khoảng thời gian để đầu tín hiệu truyền từ bên gửi đến bên nhận.
-
Template – hiển thị mẫu hiện tại của via. Sử dụng danh sách thả xuống để chọn một mẫu khác. Nếu có Library liên kết, thư viện đó sẽ được hiển thị.
-
Library – hiển thị mẫu via có trong thư viện hiện tại. Nếu một via được đặt từ Thư viện Pad Via (*.PvLib), trường này sẽ bao gồm tên của thư viện đó. Sau khi via được đặt, biểu tượng
sẽ được kích hoạt, cho biết các thuộc tính của via đã đặt được định nghĩa trong Thư viện và không còn có thể chỉnh sửa. Nếu biểu tượng
chưa được kích hoạt, nội dung vẫn có thể chỉnh sửa.
-
(X/Y)
- X (trường thứ nhất) – trường này hiển thị tọa độ X hiện tại của tâm via so với gốc tọa độ hiện tại. Chỉnh sửa giá trị trong trường để thay đổi vị trí của via so với gốc tọa độ hiện tại. Giá trị có thể được nhập theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập một giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (được truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị.
- Y (trường thứ hai) – trường này hiển thị tọa độ Y hiện tại của tâm via so với gốc tọa độ hiện tại. Chỉnh sửa giá trị trong trường để thay đổi vị trí của via so với gốc tọa độ hiện tại. Giá trị có thể được nhập theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập một giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (được truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị.
Cấu trúc lớp via
-
Simple – chọn để sử dụng một via đơn giản.
- Diameter – nhập đường kính yêu cầu của via. Đường kính via giống nhau trên tất cả các lớp.
- Relief – bật để tùy chỉnh kết nối giảm nhiệt cho via, ghi đè quy tắc Polygon Connect Style đang áp dụng.
-
Thermal Relief – sau khi tùy chọn Relief được bật, nhấp vào liên kết để mở hộp thoại Polygon Connect Style, nơi bạn có thể thay đổi các tùy chọn kết nối giảm nhiệt theo yêu cầu. Nhấp vào nút Edit Points để xác định thủ công các điểm kết nối của những nhánh nối giảm nhiệt.
-
Top-Middle-Bottom – chọn để sử dụng các đường kính khác nhau cho lớp trên cùng, tất cả các lớp tín hiệu bên trong và lớp dưới cùng.
- Displayed Layer(s) – nhấp vào một lớp được hiển thị để cấu hình các via cho lớp đó. Lớp được chọn sẽ được tô sáng.
- Diameter – nhấp vào danh sách thả xuống rồi nhập đường kính yêu cầu của via cho lớp được chọn.
- Relief – bật để tùy chỉnh kết nối giảm nhiệt cho via, ghi đè quy tắc Polygon Connect Style đang áp dụng.
-
Thermal Relief – sau khi tùy chọn Relief được bật, nhấp vào liên kết để mở hộp thoại Polygon Connect Style, nơi bạn có thể thay đổi các tùy chọn kết nối giảm nhiệt theo yêu cầu. Nhấp vào nút Edit Points để xác định thủ công các điểm kết nối của những nhánh nối giảm nhiệt.
-
Full Stack – chọn để sử dụng một đối tượng via có cấu trúc lớp đầy đủ.
- Displayed Layer(s) – nhấp vào một lớp được hiển thị để cấu hình các via cho lớp đó. Lớp được chọn sẽ được tô sáng.
- Diameter – nhấp vào danh sách thả xuống rồi nhập đường kính yêu cầu của via cho lớp được chọn.
- Relief – bật để tùy chỉnh kết nối giảm nhiệt cho via, ghi đè quy tắc Polygon Connect Style đang áp dụng.
-
Thermal Relief – sau khi tùy chọn Relief được bật, nhấp vào liên kết để mở hộp thoại Polygon Connect Style, nơi bạn có thể thay đổi các tùy chọn kết nối giảm nhiệt theo yêu cầu. Nhấp vào nút Edit Points để xác định thủ công các điểm kết nối của những nhánh nối giảm nhiệt.
-
Hole Size – trường này hiển thị kích thước lỗ hiện tại của via. Giá trị này chỉ định đường kính của lỗ (có dạng tròn, vuông hoặc rãnh) theo đơn vị mil hoặc mm sẽ được khoan trong via khi chế tạo. Kích thước lỗ có thể được đặt từ 0 đến 1000 mil và có thể lớn hơn kích thước via để tạo các lỗ cơ khí (không có đồng). Chỉnh sửa giá trị trong trường này để thay đổi kích thước lỗ via. Giá trị có thể được nhập theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập một giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (được truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị.
-
Tolerance – thiết lập các thuộc tính dung sai lỗ có thể giúp xác định độ lắp ghép và các giới hạn của bo mạch. Chỉ định dung sai tối thiểu (-) và tối đa (+) cho lỗ. Không có giá trị dung sai lỗ mặc định trong Altium Designer.
Độ mở rộng mặt nạ hàn
-
Rule – chọn để độ mở rộng mặt nạ hàn của via tuân theo giá trị được xác định trong quy tắc thiết kế Độ mở rộng mặt nạ hàn áp dụng.
-
Top
- Tented – chọn nếu muốn ghi đè mọi thiết lập mặt nạ hàn trong các quy tắc thiết kế độ mở rộng mặt nạ hàn, khiến mặt nạ hàn không có cửa mở trên lớp trên của via này và do đó via được phủ kín. Tắt tùy chọn này để via tuân theo quy tắc độ mở rộng mặt nạ hàn hoặc giá trị mở rộng cụ thể.
-
Bottom
- Tented – chọn nếu muốn ghi đè mọi thiết lập mặt nạ hàn trong các quy tắc thiết kế độ mở rộng mặt nạ hàn, khiến mặt nạ hàn không có cửa mở trên lớp dưới của via này và do đó via được phủ kín. Tắt tùy chọn này để via tuân theo quy tắc độ mở rộng mặt nạ hàn hoặc giá trị mở rộng cụ thể.
-
Top
-
Manual – chọn để ghi đè quy tắc thiết kế áp dụng và chỉ định giá trị độ mở rộng mặt nạ hàn cho via.
-
Top – nhập giá trị độ mở rộng mặt nạ hàn của lớp trên. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị. Trường này chỉ khả dụng khi Tented không được bật.
- Tented – chọn nếu muốn ghi đè mọi thiết lập mặt nạ hàn trong các quy tắc thiết kế độ mở rộng mặt nạ hàn, khiến mặt nạ hàn không có cửa mở trên lớp trên của via này và do đó via được phủ kín. Tắt tùy chọn này để via tuân theo quy tắc độ mở rộng mặt nạ hàn hoặc giá trị mở rộng cụ thể.
-
Bottom – nhập giá trị độ mở rộng mặt nạ hàn của lớp dưới. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị. Trường này chỉ khả dụng khi biểu tượng
ở bên phải vùng này được đặt thành
và tùy chọn Tented không được bật. Khi biểu tượng ở trạng thái
và tùy chọn Tented không được bật, giá trị độ mở rộng mặt nạ hàn của lớp dưới sẽ giống với lớp trên.
- Tented – chọn nếu muốn ghi đè mọi thiết lập mặt nạ hàn trong các quy tắc thiết kế độ mở rộng mặt nạ hàn, khiến mặt nạ hàn không có cửa mở trên lớp dưới của via này và do đó via được phủ kín. Tắt tùy chọn này để via tuân theo quy tắc độ mở rộng mặt nạ hàn hoặc giá trị mở rộng cụ thể.
- From Hole Edge – khi bật, cửa mở mặt nạ hàn sẽ tuân theo kích thước lỗ. Vì vậy, mặt nạ độc lập với kích thước via và được định kích thước dựa trên kích thước lỗ. Cũng cần lưu ý rằng kích thước cửa mở mặt nạ mở rộng của via sẽ thay đổi theo mọi thay đổi của kích thước lỗ.
-
Top – nhập giá trị độ mở rộng mặt nạ hàn của lớp trên. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong vùng Other của bảng Properties ở chế độ Board (truy cập khi không có đối tượng nào được chọn trong không gian thiết kế) và được sử dụng nếu không chỉ định đơn vị. Trường này chỉ khả dụng khi Tented không được bật.
Loại via & đặc tính
- IPC 4761 Via Type – sử dụng danh sách thả xuống để chọn loại via theo tiêu chuẩn IPC 4761, Design Guide for Protection of Printed Board Via Structures.
-
Grid – xuất hiện khi chọn loại via khác với
Nonetrong danh sách thả xuống IPC 4761 Via Type. Chọn Side của bo mạch và nhập Material cho các đặc tính khả dụng tương ứng với loại via đã chọn.
Điểm kiểm tra
Fabrication/Assembly – các tùy chọn này cho phép bạn chỉ định các via làm vị trí điểm kiểm tra trong quá trình kiểm tra chế tạo và/hoặc lắp ráp. Bật Top để xác định via này là điểm kiểm tra trên lớp trên. Bật Bottom để xác định via này là điểm kiểm tra trên lớp dưới.
Kết nối giảm nhiệt cho pad và via
Trường Thermal Relief trong vùng Pad Stack / Via Stack của bảng Properties tóm tắt cấu hình kết nối giảm nhiệt hiện đang được áp dụng. Ví dụ, Relief, 15mil, 10mil, 4, 90 có nghĩa là:
- kết nối giảm nhiệt được áp dụng;
- khe hở có độ rộng 15mil;
- các nhánh dẫn của kết nối giảm nhiệt có độ rộng 10mil;
- các nhánh dẫn của kết nối giảm nhiệt có góc xoay 90 độ.
Khi bỏ chọn hộp kiểm trong trường Thermal Relief, các kết nối giảm nhiệt giữa polygon với pad và via là rules-driven, tức là các kết nối này được xác định bởi những quy tắc thiết kế Kiểu kết nối polygon áp dụng. Đối với từng pad riêng lẻ, có thể tùy chỉnh cấu hình kết nối giảm nhiệt bằng cách bật tùy chọn Thermal Relief tương ứng cho lớp cần thiết. Trong trường hợp này, các kết nối giảm nhiệt được xem là custom. Tìm hiểu thêm về Xác định kết nối giảm nhiệt tùy chỉnh.
Độ mở rộng mặt nạ hàn và mặt nạ kem hàn
Các vùng mở của lớp mặt nạ hàn được tạo tự động tại mỗi vị trí pad/via trên lớp Solder Mask. Mặt nạ hàn được định nghĩa theo dạng âm bản, nghĩa là các đối tượng được đặt sẽ xác định các vùng mở trên lớp Solder Mask. Các vùng mở của lớp mặt nạ kem hàn được tạo tự động tại mỗi vị trí pad trên lớp Paste Mask. Hình dạng được tạo trên lớp mặt nạ là hình dạng của pad/via, được mở rộng hoặc thu hẹp theo giá trị do các quy tắc thiết kế Độ mở rộng mặt nạ hàn và Độ mở rộng mặt nạ kem hàn quy định trong trình biên tập PCB hoặc theo thiết lập trong bảng Properties.

Các pad với mặt nạ hàn được hiển thị.
Khi chỉnh sửa pad hoặc via, bạn sẽ thấy các thiết lập độ mở rộng mặt nạ hàn và mặt nạ kem hàn lần lượt trong các vùng Pad Stack và Solder Mask Expansion của bảng Properties. Mặc dù các thiết lập này cho phép bạn kiểm soát riêng yêu cầu về độ mở rộng của từng pad/via, thông thường bạn sẽ không cần dùng đến chúng. Nhìn chung, việc kiểm soát các yêu cầu về mặt nạ kem hàn và mặt nạ hàn sẽ dễ dàng hơn khi định nghĩa các quy tắc thiết kế phù hợp trong trình biên tập PCB. Khi sử dụng quy tắc thiết kế, bạn có thể tạo một quy tắc để thiết lập độ mở rộng cho tất cả linh kiện trên bo mạch, rồi bổ sung các quy tắc khác nếu cần để áp dụng cho những trường hợp cụ thể, chẳng hạn như tất cả các phiên bản của một loại footprint được dùng trên bo mạch hoặc một pad cụ thể trên một linh kiện cụ thể, v.v.
Để thiết lập độ mở rộng mặt nạ trong các quy tắc thiết kế:
-
Xác nhận rằng tùy chọn Rule Expansion được chọn làm Shape trong vùng Pad Stack của bảng Properties (đối với pad) và/hoặc tùy chọn Rule được chọn trong vùng Solder Mask Expansion của bảng Properties (đối với via).
-
Trong trình biên tập PCB, chọn Design » Rules từ các menu chính và xem các quy tắc thiết kế thuộc danh mục Mask trong hộp thoại Trình biên tập quy tắc và ràng buộc PCB. Các quy tắc này sẽ được áp dụng khi footprint được đặt trên PCB.
Để ghi đè các quy tắc thiết kế về độ mở rộng và chỉ định độ mở rộng mặt nạ dưới dạng thuộc tính của pad/via, chọn Manual Expansion làm Shape trong vùng Pad Stack của bảng Properties (đối với pad) và/hoặc Manual trong vùng Solder Mask Expansion của bảng Properties (đối với via), rồi nhập các giá trị cần thiết.
Che phủ pad và via bằng mặt nạ hàn
Có thể che phủ một phần hoặc toàn bộ pad và via bằng cách định nghĩa giá trị phù hợp cho Độ mở rộng mặt nạ hàn. Ràng buộc về độ mở rộng này có thể được định nghĩa riêng cho từng đối tượng trong bảng Properties hoặc bằng cách định nghĩa các quy tắc thiết kế Độ mở rộng mặt nạ hàn phù hợp. Bằng cách thiết lập giá trị độ mở rộng thích hợp, bạn có thể thực hiện những việc sau:
- Để che phủ một phần pad/via – chỉ che phủ vùng đồng, hãy đặt Độ mở rộng thành một giá trị âm sao cho mặt nạ phủ kín đến sát lỗ pad/via.
- Để che phủ hoàn toàn pad/via – che phủ cả vùng đồng và lỗ, hãy đặt Độ mở rộng thành một giá trị âm có độ lớn bằng hoặc lớn hơn bán kính pad/via.
- Để che phủ tất cả pad/via trên một lớp, hãy đặt giá trị Độ mở rộng phù hợp và đảm bảo phạm vi (Truy vấn đầy đủ) của quy tắc Độ mở rộng mặt nạ hàn áp dụng cho tất cả pad/via trên lớp cần thiết.
- Để che phủ hoàn toàn tất cả pad/via trong một thiết kế có các via với kích thước khác nhau, hãy đặt Độ mở rộng thành một giá trị âm có độ lớn bằng hoặc lớn hơn bán kính pad/via lớn nhất. Khi che phủ một pad/via riêng lẻ, bạn có thể chọn tuân theo độ mở rộng được định nghĩa trong quy tắc thiết kế áp dụng hoặc ghi đè quy tắc đó và áp dụng trực tiếp một độ mở rộng cụ thể cho pad/via đang xét.
Điểm kiểm tra
Related page: Chỉ định điểm kiểm tra trên bo mạch
Phần mềm hỗ trợ đầy đủ các điểm kiểm tra, cho phép chỉ định pad (xuyên lỗ hoặc SMD) và via làm vị trí điểm kiểm tra trong quá trình kiểm tra chế tạo và/hoặc lắp ráp. Một pad/via được chỉ định làm điểm kiểm tra bằng cách thiết lập các thuộc tính điểm kiểm tra tương ứng – đó là điểm kiểm tra chế tạo hay lắp ráp, và được dùng làm điểm kiểm tra ở mặt nào của bo mạch. Các thuộc tính này nằm trong vùng Testpoint của bảng Thuộc tính .
Để đơn giản hóa quy trình và giảm nhu cầu thiết lập thủ công các thuộc tính điểm kiểm tra, phần mềm cung cấp phương pháp tự động chỉ định điểm kiểm tra dựa trên các quy tắc thiết kế đã định nghĩa và sử dụng Trình quản lý điểm kiểm tra (Tools » Testpoint Manager). Trong mỗi trường hợp, việc chỉ định tự động này sẽ thiết lập các thuộc tính điểm kiểm tra tương ứng cho pad/via.
Các đặc điểm riêng của pad
Ký hiệu pad
Mỗi pad nên được gán một ký hiệu (thường biểu thị số chân linh kiện) dài tối đa 20 ký tự chữ và số. Ký hiệu pad sẽ tự động tăng thêm một trong quá trình đặt nếu pad ban đầu có ký hiệu kết thúc bằng một chữ số. Hãy thay đổi ký hiệu của pad đầu tiên trước khi đặt trong bảng Thuộc tính .
Để tăng theo chữ cái, ví dụ 1A, 1B, hoặc tăng theo số với bước tăng khác 1, hãy sử dụng hộp thoại Thiết lập mảng dán được truy cập bằng cách nhấn nút Paste Array trong hộp thoại Dán đặc biệt (Edit » Paste Special).
Tính năng dán mảng
Bằng cách thiết lập ký hiệu pad trước khi sao chép vào bộ nhớ tạm, bạn có thể sử dụng hộp thoại Setup Paste Array để tự động áp dụng một chuỗi ký hiệu trong quá trình đặt pad. Sử dụng trường Text Increment trong hộp thoại Setup Paste Array, bạn có thể đặt các chuỗi ký hiệu pad sau:
- Dạng số (1, 3, 5)
- Dạng chữ cái (A, B, C)
- Kết hợp chữ và số (A1 A2, 1A 1B, A1 B1 hoặc 1A 2A, v.v.)
Để tăng theo số, hãy đặt trường Text Increment thành bước tăng mong muốn. Để tăng theo chữ cái, hãy đặt trường Text Increment thành chữ cái trong bảng chữ cái tương ứng với số vị trí chữ cái mà bạn muốn tiến tới. Ví dụ, nếu pad ban đầu có ký hiệu 1A, hãy đặt trường này thành A (chữ cái đầu tiên trong bảng chữ cái) để tăng ký hiệu theo bước 1. Nếu đặt trường này thành C (chữ cái thứ ba trong bảng chữ cái), các ký hiệu sẽ lần lượt là 1A, 1D (sau A ba vị trí), 1G, v.v.
Kết nối jumper
Kết nối jumper định nghĩa các kết nối điện giữa những pad của linh kiện không được đi dây vật lý bằng các đối tượng cơ bản trên PCB. Chúng đặc biệt hữu ích trên bo mạch một lớp, nơi dây dẫn được dùng để bắc qua các đường mạch trên lớp vật lý duy nhất.
Các pad trong một linh kiện có thể được gán một giá trị Jumper trong bảng Properties. Các pad có cùng Jumper và cùng net điện cho hệ thống biết rằng giữa chúng có một kết nối hợp lệ, dù không được nối với nhau về mặt vật lý.
Các kết nối jumper được hiển thị dưới dạng đường kết nối cong trong PCB Editor. Trình kiểm tra quy tắc thiết kế sẽ không báo cáo các kết nối jumper là net chưa đi dây.
Thông tin chi tiết về via
Định nghĩa thuộc tính via
Trong khi yêu cầu về phạm vi lớp (mặt phẳng Z) của từng loại via được định nghĩa trên tab Via Types của Layer Stack Manager, các thuộc tính kích thước của via được xác định bằng:
-
cách chỉnh sửa thủ công một via đã đặt trong bảng Properties, hoặc
-
các đối tượng cơ bản mặc định của PCB, khi via được đặt thủ công (Place » Via), hoặc
-
quy tắc thiết kế Routing Via Style, nếu via được đặt trong quá trình đi dây tương tác, ActiveRouting hoặc đi dây tự động.
Cấu hình quy tắc thiết kế Routing Via Style
Main page: Định nghĩa, thiết lập phạm vi và quản lý quy tắc thiết kế PCB
Các via được đặt trong quá trình đi dây tương tác, ActiveRouting hoặc đi dây tự động có thuộc tính kích thước được kiểm soát bởi quy tắc thiết kế Routing Via Style áp dụng cho chúng. Để giúp nhắm đến các via trong quy tắc thiết kế, có một tập hợp từ khóa truy vấn liên quan đến via mà bạn có thể sử dụng trong phạm vi áp dụng của quy tắc (Where the Object Matches); các từ khóa này được trình bày chi tiết bên dưới.
Khi bạn chuyển lớp trong lúc đi dây, phần mềm xem xét lớp bắt đầu và lớp kết thúc của lần chuyển lớp này, rồi chọn một loại via được phép từ Layer Stack Manager. Sau đó, phần mềm xác định quy tắc thiết kế Routing Via Style áp dụng có mức ưu tiên cao nhất và áp dụng các thiết lập kích thước via từ phần Constraints của quy tắc đó cho via sắp được đặt.
Ví dụ, bạn có thể có một nhóm net DRAM_DATA yêu cầu µVia cho việc chuyển từ lớp TopLayer sang lớp S2 và từ lớp S2 sang lớp S3, đồng thời yêu cầu via xuyên lỗ được khoan cho mọi lần chuyển lớp khác (loại via này cũng khác với loại via mà các net khác yêu cầu). Bạn có thể xử lý trường hợp này bằng cách tạo hai quy tắc thiết kế Routing Via Style nhắm đến các net DRAM_DATA này. Ví dụ về một quy tắc thiết kế µVia phù hợp được hiển thị bên dưới; hãy di con trỏ lên hình ảnh để xem quy tắc thiết kế via xuyên lỗ.

Có thể thiết lập phạm vi quy tắc thiết kế để áp dụng cho các loại via cụ thể.
Để đơn giản hóa quá trình thiết lập phạm vi cho các quy tắc thiết kế Routing Via Style, bạn có thể sử dụng các từ khóa truy vấn liên quan đến via sau:
| Via Type Query | Returns |
|---|---|
| IsVia | Tất cả đối tượng via, bất kể loại via. |
| IsThruVia | Tất cả via nối từ lớp trên cùng đến lớp dưới cùng. |
| IsBlindVia | Tất cả via bắt đầu ở một lớp bề mặt và kết thúc ở một lớp bên trong, không phải là µVia. |
| IsBuriedVia | Tất cả via bắt đầu ở một lớp bên trong và kết thúc ở một lớp bên trong khác, không phải là µVia. |
| IsMicroVia | Tất cả via có tùy chọn µVia được bật và kết nối các lớp liền kề. |
| IsSkipVia | Tất cả via có tùy chọn µVia được bật và có phạm vi trải qua 2 lớp. |
Đặt via trong quá trình đi dây tương tác
Khi bạn chuyển lớp trong quá trình đi dây tương tác, phần mềm sẽ tự động chèn một via. Via được chọn phụ thuộc vào:
- Các loại via có sẵn cho phạm vi lớp của lần chuyển lớp.
- Quy tắc thiết kế Routing Via Style áp dụng cho loại via được chọn cho lần chuyển lớp đó.
Các µVia xếp chồng được đặt khi chuyển lớp từ L1 sang L4. Chế độ Interactive Routing của bảng Properties hiển thị các loại via sẽ được đặt; nhấn 6 để lần lượt chuyển qua các cấu hình via xếp chồng khả dụng; nhấn 8 để hiển thị danh sách các cấu hình via xếp chồng khả dụng.
Kiểm soát via được đặt trong quá trình đi dây tương tác
-
Khi bạn chuyển lớp đi dây, phần mềm tự động chọn loại via phù hợp nhất với phạm vi lớp đó.
-
Nếu có nhiều loại via hoặc tổ hợp via (via xếp chồng) có thể sử dụng, hãy nhấn phím tắt 6 để chuyển lần lượt qua tất cả cấu hình via xếp chồng khả dụng cho lần chuyển lớp đó; nhấn phím tắt 8 để hiển thị danh sách. Các cấu hình via xếp chồng được trình bày theo thứ tự: dùng µVia, dùng Skip µVia, dùng via mù, dùng via xuyên lỗ. Có thể đặt via xếp chồng nếu lần chuyển lớp vượt quá một lớp và các loại via phù hợp đã được định nghĩa. Các loại via được đề xuất được trình bày chi tiết trên thanh trạng thái và trong màn hình Heads Up, ví dụ [µVia 1:2, µVia 2:3, µVia 3:4], như trong hình phía trên.
-
Cấu hình via xếp chồng được sử dụng gần nhất được giữ làm mặc định cho net tiếp theo mà bạn đi dây. Cấu hình via xếp chồng mặc định chỉ được giữ trong phiên chỉnh sửa hiện tại.
-
Các thuộc tính kích thước via được chỉ định bởi quy tắc thiết kế Routing Via Style áp dụng; các chiến lược định nghĩa quy tắc thiết kế Routing Via Style phù hợp đã được thảo luận ở trên.
-
Để thay đổi kích thước via theo cách tương tác khi đang chuyển lớp, hãy nhấn phím tắt 4. Thao tác này sẽ chuyển lần lượt qua các chế độ kích thước via:
Rule Minimum;Rule Preferred;Rule Maximum;User Choice; chế độ kích thước via hiện tại được hiển thị trong màn hình Heads Up và trên thanh trạng thái (như trong hình phía trên). Nếu chọn User Choice, hãy nhấn Shift+V để mở hộp thoại Choose Via Sizes và chọn kích thước via mong muốn. Danh sách kích thước via có sẵn hiển thị trong hộp thoại được lấy từ danh sách các via đã được sử dụng trong thiết kế; bạn có thể xem chúng trong chế độ Pad and Via Templates của bảng PCB.Nếu chế độ Template preferred được sử dụng trong quy tắc thiết kế Routing Via Style áp dụng, việc sử dụng phím tắt 4 sẽ chuyển lần lượt qua các mẫu via được bật.
-
Hình chiếu cạnh của các loại via được đề xuất được hiển thị trong bảng Properties, như minh họa ở trên.
-
Để đặt via và tiếp tục đi dây trên cùng một lớp, hãy nhấn phím tắt 2.
-
Để đặt via và tạm dừng đi dây cho kết nối này, hãy nhấn phím tắt / trên bàn phím số.
-
Nếu net đang được đi dây cần kết nối với một mặt phẳng nguồn bên trong, hãy nhấn phím / (trên bàn phím số) để đặt via kết nối với mặt phẳng nguồn thích hợp. Thao tác này hoạt động trong mọi chế độ đặt đường mạch, ngoại trừ chế độ Any Angle .
-
Nhấn Shift+F1 khi đi dây để mở menu chứa tất cả phím tắt trong lệnh.
Làm việc với các via xếp chồng
-
Các via xếp chồng tạo thành một kết nối liên tục có thể được thao tác như một via duy nhất; click and drag trên chồng via để di chuyển tất cả cùng với các đường mạch nối với chúng.
-
Nhấp một lần để chọn via trên cùng trong chồng via. Nếu không di chuyển chuột, các lần nhấp tiếp theo sẽ lần lượt chọn từng via còn lại trong chồng.
-
Ctrl+Click and drag để chỉ di chuyển via đã chọn cùng với các đường mạch nối với nó.
-
Để chọn tất cả via trong một chồng, nhấp một lần để chọn một via, sau đó nhấn Tab để mở rộng lựa chọn, bao gồm tất cả via trong chồng đó.
Cấu hình hiển thị via
Có nhiều tính năng hiển thị giúp bạn làm việc với via.
Màu via
Màu via được cấu hình trong bảng View Configuration. Vòng đồng của via được hiển thị theo thiết lập Multi-Layer hiện tại trong phần Layers . Màu lỗ via được hiển thị theo thiết lập Via Holes trong phần System Colors . Bạn cũng có thể tắt hiển thị lỗ bằng cách chuyển trạng thái
cho các thiết lập mong muốn.

Hình đầu tiên hiển thị một via xuyên lỗ. Via trong hình thứ hai là via mù; lỗ được hiển thị bằng màu của lớp bắt đầu và lớp kết thúc.
Via và lớp phủ chống hàn
Theo cách hiển thị lớp mặc định trong trình biên tập PCB, lớp Multi-Layer luôn được hiển thị trên cùng. Điều này có thể khiến bạn khó quan sát chính xác nội dung của các lớp phủ chống hàn, đặc biệt khi pad hoặc via sử dụng độ mở rộng âm cho lớp phủ chống hàn, vì nội dung của lớp phủ chống hàn sẽ bị che dưới đối tượng đa lớp. Bạn có thể thay đổi điều này bằng cách đổi thứ tự vẽ lớp trên trang PCB Editor – Display của hộp thoại Preferences. Đặt lớp hiện tại được vẽ ở trên cùng.
Bằng cách thay đổi thứ tự vẽ lớp để hiển thị lớp hiện tại ở trên cùng, khi bạn đặt Top Solder làm lớp hiện tại, các cửa sổ mở trên lớp phủ chống hàn sẽ được hiển thị chính xác như trong hình bên dưới. Các mũi tên màu xanh lá cho biết kích thước cửa sổ mở trên lớp phủ chống hàn của via ở bên trái, pad có cửa sổ mở được thu nhỏ ở giữa và pad có cửa sổ mở được mở rộng ở bên phải.

Cấu hình các thiết lập hiển thị để có thể kiểm tra các cửa sổ mở trên lớp phủ chống hàn.
Hiển thị các via xếp chồng
Nếu có các via xếp chồng, các số được hiển thị là lớp bắt đầu và lớp kết thúc của tất cả via trong chồng. Di con trỏ lên hình bên dưới để xem các via ở dạng 3D; bên phải hình là một chồng gồm ba via.
Các lớp mà via đi qua có thể được hiển thị trong via. Di con trỏ lên hình để xem các via ở dạng 3D.
Các thiết lập hiển thị via khác
Để hiển thị tên net của via và số lớp trong phạm vi lớp mà via đi qua, lần lượt bật các tùy chọn Via Nets và Via Span trong vùng Additional Options trên tab View Options của bảng View Configuration.
Duyệt các lỗ pad và via
Ở chế độ của bảng PCB Hole Size Editor, ba vùng chính của bảng thay đổi để hiển thị (theo thứ tự từ trên xuống):
- Bộ lọc chung cho các loại lỗ và trạng thái của chúng, cùng một phần phụ dành cho các cặp lớp khoan hiện được xác định cho bo mạch.
- Unique Holes được sắp xếp thành các nhóm theo kích thước và hình dạng.
- Các Pads/Vias riêng lẻ tạo thành từng nhóm đối tượng lỗ.

Các phần của bảng hiển thị kết quả lọc kết hợp áp dụng cho loại lỗ, kiểu lỗ và trạng thái.
Có thể chỉnh sửa đồng thời các nhóm lỗ trong vùng Unique Holes của bảng bằng cách nhập giá trị vào ô của cột tương ứng. Bạn có thể nhập giá trị số để thay đổi kích thước lỗ hiện tại của pad và via trong cột Hole Size .

Chỉnh sửa kích thước lỗ cho nhóm đã chọn gồm sáu kiểu lỗ giống nhau.
Bạn cũng có thể thay đổi các mục Hole Length, Hole Type và Plated tương ứng của lỗ, nếu áp dụng.

Thay đổi loại lỗ cho nhóm đã chọn gồm sáu kiểu lỗ giống nhau.
Các đối tượng pad/via riêng lẻ thuộc nhóm lỗ đã chọn được liệt kê trong phần Pad/Via phía dưới của bảng PCB. Nhấp chuột phải vào một đối tượng trong danh sách rồi chọn Properties (hoặc nhấp đúp trực tiếp vào mục đó) để mở chế độ tương ứng của bảng Properties cho đối tượng cơ bản đó, nơi bạn có thể xem và chỉnh sửa các thuộc tính của nó.
Để cập nhật bảng PCB ở chế độ Hole Size Editor bằng dữ liệu ký hiệu khoan hiện tại từ PCB, nhấp chuột phải trong một vùng của bảng ở chế độ này và chọn lệnh Refresh.
Hỗ trợ khoan ngược
Chế độ Hole Size Editor của bảng PCB cũng có thể được dùng để kiểm tra các pad và via cần khoan ngược. Các cặp lớp khoan ngược được hiển thị trong danh sách Layer Pairs và được nhận diện bằng phần văn bản [BD] thêm vào.
Khi chọn một kích thước lỗ khoan ngược, Kind của các đối tượng sẽ được hiển thị là Backdrill. Sử dụng chức năng này để nhanh chóng xác định vị trí và kiểm tra các lỗ khoan ngược. Lưu ý rằng không thể chỉnh sửa các thiết lập khoan ngược trong bảng.
Báo cáo khoan ngược
Để tạo báo cáo về tất cả các lần khoan ngược, nhấp chuột phải trong danh sách Unique Holes rồi chọn Backdrill Report từ menu ngữ cảnh.
Báo cáo trình bày chi tiết từng lần khoan ngược, bao gồm vị trí, kích thước mũi khoan và độ sâu khoan.
Hỗ trợ lỗ khoét bậc và lỗ khoét côn
Chế độ Hole Size Editor của bảng PCB cũng có thể được dùng để kiểm tra các pad đã bật tính năng khoét lỗ. Khi thiết kế PCB có các đối tượng pad được bật tính năng khoét lỗ (khoét bậc/khoét côn) ở một hoặc cả hai mặt, các nhóm Counterholes Top và/hoặc Counterholes Bottom tương ứng sẽ được hiển thị trong danh sách Layer Pairs. Các cột Counterhole Depth và Counterhole Angle có thể được hiển thị trong Unique Holes vùng của bảng điều khiển. Lưu ý rằng không thể chỉnh sửa các thiết lập lỗ khoét bậc trong bảng điều khiển.

Thông tin về các lỗ khoét bậc trong thiết kế được hiển thị ở chế độ Hole Size Editor của bảng điều khiển PCB.





