Thiết lập tài liệu Draftsman
Altium Essentials: Draftsman
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Sơ lược
- Tìm hiểu cách tạo tài liệu Draftsman mới, chọn mẫu và chỉ định đúng dự án cùng PCB nguồn.
- Xem cách Draftsman duy trì liên kết với dữ liệu PCB và cách cập nhật tài liệu khi thiết kế bo mạch thay đổi.
- Nắm rõ các tùy chọn tài liệu và thiết lập tham số quan trọng, quyết định cách tài liệu Draftsman hiển thị và hoạt động.
Draftsman tạo và lưu các tệp bản vẽ PCB ở định dạng tệp chuyên dụng (*.PCBDwf).
Tạo tài liệu Draftsman mới
Để tạo một tài liệu Draftsman mới, sử dụng lệnh File » New » Draftsman Document từ các menu chính hoặc nhấp chuột phải vào mục của dự án cần thiết trong bảng Projects rồi chọn lệnh Add New to Project » Draftsman Document từ menu ngữ cảnh. Hộp thoại New Document mở ra cho phép bạn chọn một mẫu tài liệu được định nghĩa sẵn hoặc tùy chọn [Default] để tạo một tài liệu A4 trống.

Tạo tài liệu Draftsman trống hoặc dựa trên mẫu từ một dự án và PCB được chỉ định.
Đối với các mẫu Workspace (được liệt kê bên dưới mục của Workspace đang kết nối theo định dạng <TemplateName> (v.<Revision>)), phiên bản sửa đổi mới nhất của mỗi mẫu có sẵn sẽ được sử dụng. Nhấp vào nút
để truy cập trang Quản lý dữ liệu – Mẫu của hộp thoại Preferences.
Cùng với mẫu tài liệu mong muốn, bạn có thể chọn một Project cụ thể (khi nhiều dự án đang mở trong Altium Designer) và Document PCB nguồn có trong dự án đã chọn. Tài liệu mới sẽ được thêm vào dự án được chỉ định và do đó sẽ lấy dữ liệu từ dự án này; dự án đó sẽ trở thành dự án đang hoạt động.
Các hộp kiểm Layers của hộp thoại xác định những lớp bo mạch nào (Signal/Plane, Mask, Paste và/hoặc Silk, theo định nghĩa của cấu trúc lớp) được dùng để tạo bản vẽ chế tạo trong tài liệu khi sử dụng mẫu tài liệu chế tạo. Các bản vẽ chế tạo sẽ được tạo với mỗi bản vẽ trên một trang, trong đó Layer của hình chiếu chế tạo bo mạch tương ứng được đặt thành All (for document template) trong mẫu đã chọn.
Giữ Draftsman đồng bộ với PCB
Draftsman trích xuất dữ liệu thiết kế trực tiếp từ các lớp đồng, linh kiện và cơ khí trong PCB. Khi dữ liệu PCB thay đổi, bạn có thể làm mới dữ liệu trong Draftsman bằng cách nhấp chuột phải vào bất kỳ đâu trên tài liệu và chọn Import Changes From <PCBDocumentName>.PcbDoc từ menu ngữ cảnh hoặc chọn lệnh Tools » Import Changes From <PCBDocumentName>.PcbDoc từ các menu chính.
Tùy chọn chung của tài liệu
Các thiết lập cho toàn bộ tài liệu Draftsman (có thể gồm nhiều trang bản vẽ/trang – tìm hiểu thêm) được xác định trong thẻ General của bảng Properties khi không có đối tượng nào được chọn trong không gian thiết kế. Các thiết lập này xác định dữ liệu thiết kế nguồn, kiểu đồ họa, cách thức vẽ và đơn vị áp dụng cho tài liệu. Các thay đổi đối với thiết lập sẽ ghi đè các thiết lập thuộc tính mặc định do mẫu tài liệu đang áp dụng xác định.
| Grid Size, Show Grid |
Sử dụng các tùy chọn này để cấu hình lưới của tài liệu. Để biết thêm thông tin, hãy tham khảo phần Cấu hình lưới và các tùy chọn bắt dính. |
| Snapping, Snapping Distance |
Sử dụng các tùy chọn này để cấu hình tính năng bắt dính. Để biết thêm thông tin, hãy tham khảo phần Cấu hình lưới và các tùy chọn bắt dính. |
| Document Font | Đặt kiểu phông chữ cơ sở và mọi thuộc tính bổ sung được sử dụng trong các trang bản vẽ của tài liệu. Thiết lập này xác định phông chữ cấp tài liệu được áp dụng cho các đối tượng bản vẽ, chẳng hạn như tiêu đề của hình chiếu lắp ráp bo mạch. Bạn có thể ghi đè phông chữ cấp tài liệu cho từng đối tượng bằng bảng Properties của các đối tượng đó. |
| Sheet Border | Đặt màu đường viền vùng và màu ký tự cho các trang bản vẽ của tài liệu. |
| Sheet Color | Đặt màu nền cho các trang bản vẽ của tài liệu. |
| Variants Display, Pattern, Not Fitted Text, Not Fitted Font, Font Size (Min/Max) |
Sử dụng các tùy chọn này để cấu hình cách hiển thị các linh kiện được đặt là không lắp trong biến thể thiết kế đã chọn trên các hình chiếu lắp ráp bo mạch. Để biết thêm thông tin, hãy tham khảo trang Hình chiếu lắp ráp bo mạch. |
| PCB Document | Đặt thiết kế bo mạch được sử dụng làm nguồn dữ liệu cho tài liệu Draftsman. Sử dụng menu thả xuống để chọn trong số các tài liệu PCB có sẵn trong dự án hiện tại. |
| Variants | Sử dụng menu thả xuống để chọn một biến thể thiết kế bo mạch sẽ được dùng làm nguồn dữ liệu cho tài liệu Draftsman. Để biết thêm thông tin, hãy tham khảo phần Hỗ trợ các biến thể thiết kế. |
| Scale | Đặt kích thước của các hình chiếu toàn bộ bo mạch mới được đặt (chẳng hạn như hình chiếu lắp ráp bo mạch, hình chiếu chế tạo bo mạch hoặc hình chiếu bản vẽ khoan) trong tài liệu hiện tại. Để tìm hiểu thêm về cách kiểm soát tỷ lệ của một hình chiếu đã đặt, hãy tham khảo trang Làm việc với các hình chiếu. |
| Dash Pattern | Các định nghĩa về độ dài nét/khoảng cách cho các tùy chọn nét đứt theo đơn vị 0,02 mm (khi ở chế độ hệ mét). Ví dụ: giá trị mẫu 20,10,20 xác định một chuỗi nét đứt lặp lại gồm 0,4 mm, 0,2 mm và 0,4 mm, với chiều dài chu kỳ là 1 mm (50 đơn vị). Bạn có thể tạo một tùy chọn nét đứt tùy chỉnh bằng nút |
| Line Thicknesses | Độ đậm hoặc độ dày của các tùy chọn kiểu đường nét có sẵn. Sử dụng nút |
| Units | Đặt loại đơn vị đo chính của tài liệu. |
| Dual Units | Đặt loại đơn vị đo phụ (kép) của tài liệu. Có thể bật đơn vị kép bổ sung cho một đối tượng bản vẽ trong bảng Properties của đối tượng đó. |
| Decimal Separator | Chọn ký tự dùng làm dấu phân cách thập phân từ menu thả xuống. |
| Remove Leading Zero | Bật để tự động bỏ số 0 đứng đầu khi sử dụng các giá trị nhỏ hơn "1". Ví dụ, "0.5" sẽ hiển thị thành ".5" khi bật tùy chọn này. Dimensioning and Tolerancing, ASME Y14.5, quy định rằng với các giá trị nhỏ hơn 1, số 0 đứng đầu sẽ được bỏ qua khi sử dụng đơn vị inch. |
| Primary Units |
|
| Dual Units |
|
Tham số tài liệu Draftsman
Tab Parameters của bảng Properties, khi không có đối tượng nào được chọn trong không gian thiết kế, hiển thị danh sách dạng bảng gồm các tham số có trong tài liệu hiện tại. Danh sách hiển thị các tham số dự án (bao gồm biến thể), hệ thống, PCB và mọi tham số tùy chỉnh đã thêm.
Sử dụng các nút
và
để tạo hoặc xóa các tham số tùy chỉnh của riêng bạn.
Sử dụng các hộp kiểm ở cuối danh sách để chọn các nhóm tham số hiển thị trong danh sách:
(dự án),
(hệ thống),
(PCB). Các mục tham số dự án, hệ thống và PCB ở chế độ chỉ đọc, còn mọi tham số tùy chỉnh đã thêm đều có thể chỉnh sửa và luôn xuất hiện trong danh sách.
Dưới đây là các tham số hệ thống và PCB được định nghĩa sẵn.
Tham số hệ thống
Application_BuildNumber |
Phiên bản và bản dựng của bản cài đặt Altium Designer hiện tại. |
BOMPageNumber |
Được sử dụng trong trường Title thuộc phần thuộc tính của bảng danh mục vật tư để hiển thị số trang hiện tại của bảng BOM. |
BOMTotalPages |
Được sử dụng trong trường Title thuộc phần thuộc tính của bảng danh mục vật tư để hiển thị tổng số trang của bảng BOM. |
ComponentName |
Được sử dụng trong trường Title thuộc phần thuộc tính của hình chiếu linh kiện để hiển thị chú thích của linh kiện mà hình chiếu được tạo cho. |
CurrentDate |
Ngày hiện tại, được tự động tính từ cài đặt hệ thống của bạn. |
CurrentTime |
Giờ hiện tại, được tự động tính từ cài đặt hệ thống của bạn. |
DocumentFullPathAndName |
Đường dẫn đầy đủ và tên tệp tài liệu Draftsman. Ví dụ: C:\MyTestDesign\Kame_FMU_asm_rm.PCBDwf. |
DocumentName |
Chỉ tên tệp tài liệu Draftsman (không bao gồm đường dẫn tệp). Ví dụ: Kame_FMU_asm_rm.PCBDwf. |
DocumentScale |
Tỷ lệ được chọn cho tài liệu Draftsman. |
DocumentUnits |
Đơn vị đo được chọn cho tài liệu Draftsman. |
FootprintName |
Được sử dụng trong trường Title thuộc phần thuộc tính của hình chiếu linh kiện để hiển thị tên footprint của linh kiện mà hình chiếu được tạo cho. |
HoleName |
Được sử dụng trong trường Title thuộc phần thuộc tính của hình chiếu lỗ khoét bậc để hiển thị tên pad (theo ký hiệu định danh, vị trí trên PCB và lớp của pad) mà hình chiếu được tạo cho. |
ModifiedDate |
Dấu thời gian ngày sửa đổi của tệp tài liệu Draftsman; giá trị này được tự động điền. |
ProjectName |
Tên thực tế của dự án chứa tài liệu Draftsman (bao gồm phần mở rộng). Ví dụ: Sample - Kame_FMU.PrjPcb. |
Revision |
Hiển thị giá trị được chỉ định cho tham số cấp tài liệu mặc định Revision. |
SheetNumber |
Khi được đặt dưới dạng chuỗi đặc biệt, hiển thị số thứ tự của trang hiện tại trong tài liệu Draftsman. |
SheetNumber_OneSheet |
Khi được đặt dưới dạng chuỗi đặc biệt, hiển thị số thứ tự của trang hiện tại trong tài liệu Draftsman. Không hiển thị giá trị nếu tài liệu Draftsman chỉ có một trang. |
SheetTotal |
Tổng số trang của tài liệu Draftsman. |
VersionControl_PCBDocumentRevNumber |
Số bản sửa đổi hiện tại của PCB nguồn của tài liệu Draftsman. Phải sử dụng quản lý phiên bản thì chuỗi này mới chứa thông tin. |
VersionControl_PCBDocumentRevNumberShort |
Mã băm Git dạng ngắn (tám ký tự đầu tiên) và trạng thái VCS của bản sửa đổi hiện tại của PCB nguồn của tài liệu Draftsman. Phải sử dụng quản lý phiên bản thì chuỗi này mới chứa thông tin. |
VersionControl_PrjFolderRevNumber |
Số bản sửa đổi hiện tại của dự án, tăng lên mỗi khi thực hiện commit toàn bộ dự án (tức là bao gồm cả tệp dự án). Phải sử dụng quản lý phiên bản thì chuỗi này mới chứa thông tin. |
VersionControl_PrjFolderRevNumberShort |
Mã băm Git dạng ngắn (tám ký tự đầu tiên) và trạng thái VCS của dự án. Phải sử dụng quản lý phiên bản thì chuỗi này mới chứa thông tin. |
VersionControl_RevNumber |
Số bản sửa đổi hiện tại của tài liệu Draftsman. Phải sử dụng quản lý phiên bản thì chuỗi này mới chứa thông tin. |
VersionControl_RevNumberShort |
Mã băm Git dạng ngắn (tám ký tự đầu tiên) và trạng thái VCS của bản sửa đổi hiện tại của tài liệu Draftsman. Phải sử dụng quản lý phiên bản thì chuỗi này mới chứa thông tin. |
ViewLabel |
Được sử dụng trong trường Title thuộc phần thuộc tính của hình cắt bo mạch hoặc hình chi tiết bo mạch để hiển thị Label được áp dụng cho hình chiếu. |
ViewLayerName |
Được sử dụng trong trường Title thuộc phần thuộc tính của hình chiếu chế tạo bo mạch để hiển thị Layer mà hình chiếu được tạo cho. |
ViewScale |
Được sử dụng trong trường Title thuộc phần thuộc tính của một hình chiếu để hiển thị Scale đã chọn của hình chiếu đó. |
ViewSide |
Được sử dụng trong trường Title thuộc phần thuộc tính của hình chiếu lắp ráp bo mạch, hình chiếu chế tạo bo mạch, hình chiếu linh kiện hoặc hình chiếu đẳng trục bo mạch để hiển thị View Side / Face side mà hình chiếu được tạo cho. |
ViewVariantName |
Được sử dụng trong trường Title thuộc phần thuộc tính của hình chiếu lắp ráp bo mạch hoặc hình chiếu đẳng trục bo mạch để hiển thị Variation mà hình chiếu được tạo cho. |
Thông số PCB
Arc_Count |
Số lượng đối tượng cung tròn trong PCB nguồn của tài liệu Draftsman. |
BoardArea |
Diện tích PCB nguồn của tài liệu Draftsman, được biểu thị theo đơn vị đo chính đã chọn cho tài liệu Draftsman. |
BoardDensity |
Mật độ của PCB nguồn của tài liệu Draftsman. |
BoardHeight |
Chiều cao PCB nguồn của tài liệu Draftsman, được biểu thị theo đơn vị đo chính đã chọn cho tài liệu Draftsman. |
BoardWidth |
Chiều rộng PCB nguồn của tài liệu Draftsman, được biểu thị theo đơn vị đo chính đã chọn cho tài liệu Draftsman. |
BlindVia_Count |
Số lượng via mù trên PCB nguồn của tài liệu Draftsman. |
BuriedVia_Count |
Số lượng via chôn trên PCB nguồn của tài liệu Draftsman. |
Component_Count |
Số lượng đối tượng linh kiện trong PCB nguồn của tài liệu Draftsman. |
ComponentMixed_Count |
Số lượng linh kiện có pad hỗn hợp (cả SMD và xuyên lỗ) trên PCB nguồn của tài liệu Draftsman. |
ComponentsArea |
Diện tích linh kiện của PCB nguồn của tài liệu Draftsman, được biểu thị theo đơn vị đo chính đã chọn cho tài liệu Draftsman. |
ComponentSMD_Count |
Số lượng linh kiện có pad SMD trên PCB nguồn của tài liệu Draftsman. |
ComponentThru_Count |
Số lượng linh kiện có pad xuyên lỗ trên PCB nguồn của tài liệu Draftsman. |
ComputerName |
Tên hệ thống của máy tính đã tạo tài liệu Draftsman. |
CopperInner_Weight_Max |
Định lượng đồng tối đa trên các lớp trong. |
CopperOuter_Weight_Max |
Định lượng đồng tối đa trên các lớp ngoài. |
Fill_Count |
Số lượng đối tượng vùng tô trong PCB nguồn của tài liệu Draftsman. |
Hole_Count |
Số lượng lỗ pad/via trong PCB nguồn của tài liệu Draftsman. |
Hole_Size_Min |
Đường kính lỗ nhỏ nhất trên PCB nguồn của tài liệu Draftsman, được biểu thị theo đơn vị đo chính đã chọn cho tài liệu Draftsman. |
Hole_Size_Num |
Số lượng đường kính lỗ khác nhau trên PCB nguồn của tài liệu Draftsman. |
Item |
Tên của mục thiết kế dự án PCB mới nhất mà dữ liệu nguồn của dự án đã được phát hành vào bằng Project Releaser. Ví dụ: SRC-Sample - Kame_FMU. |
ItemRevision |
Phiên bản mục của mục thiết kế dự án PCB mới nhất mà dữ liệu nguồn của dự án đã được phát hành vào bằng Project Releaser. Ví dụ: 01.A.1. |
ItemRevisionBase |
Phần cấp cơ sở của phiên bản mục của mục thiết kế dự án PCB mới nhất mà dữ liệu nguồn của dự án đã được phát hành vào bằng Project Releaser. Ví dụ: 1. |
ItemRevisionLevel1 |
Phần cấp 1 của phiên bản mục của mục thiết kế dự án PCB mới nhất mà dữ liệu nguồn của dự án đã được phát hành vào bằng Project Releaser. Ví dụ: A. |
ItemRevisionLevel2 |
Phần cấp 2 của phiên bản mục của mục thiết kế dự án PCB mới nhất mà dữ liệu nguồn của dự án đã được phát hành vào bằng Project Releaser. Ví dụ: 01. |
Layer_Count |
Số lượng lớp đồng trên PCB nguồn của tài liệu Draftsman. |
MicroVia_Count |
Số lượng microvia trên PCB nguồn của tài liệu Draftsman. |
Net_Count |
Số lượng net trong PCB nguồn của tài liệu Draftsman. |
Pad_Count |
Số lượng đối tượng pad trong PCB nguồn của tài liệu Draftsman. |
Pcb_File_Name |
Đường dẫn đầy đủ và tên tệp PCB nguồn của tài liệu Draftsman. Ví dụ: C:\MyTestDesign\Kame_FMU.PcbDoc. |
Pcb_File_Name_No_Path |
Chỉ tên tệp PCB nguồn của tài liệu Draftsman (không bao gồm đường dẫn tệp). Ví dụ: Kame_FMU.PcbDoc. |
PCBConfigurationName |
Tên của tập dữ liệu được dùng để tạo đầu ra, như được xác định trong chế độ xem Release (Project Releaser). |
PadSMD_Count |
Số lượng pad SMD trên PCB nguồn của tài liệu Draftsman. |
PadThru_Count |
Số lượng pad xuyên lỗ trên PCB nguồn của tài liệu Draftsman. |
Poly_Count |
Số lượng đối tượng vùng đổ đồng đa giác trong PCB nguồn của tài liệu Draftsman. |
SlotHole_Count |
Số lượng đối tượng pad có lỗ dạng rãnh trong PCB nguồn của tài liệu Draftsman. |
SolderMask_Bottom |
Sự hiện diện của lớp phủ chống hàn mặt dưới. Nếu không có lớp phủ chống hàn mặt dưới, thông số sẽ có giá trị No mask. Nếu có lớp phủ chống hàn mặt dưới nhưng chưa xác định màu, thông số sẽ có giá trị No color. Nếu có lớp phủ chống hàn mặt dưới và đã xác định màu, thông số sẽ hiển thị màu đó, dưới dạng tên (Green, Black, Blue, Red, v.v.) hoặc mã RGBA (ví dụ: #FF0065FF). |
SolderMask_Top |
Sự hiện diện của lớp phủ chống hàn mặt trên. Nếu không có lớp phủ chống hàn mặt trên, thông số sẽ có giá trị No mask. Nếu có lớp phủ chống hàn mặt trên nhưng chưa xác định màu, thông số sẽ có giá trị No color. Nếu có lớp phủ chống hàn mặt trên và đã xác định màu, thông số sẽ hiển thị màu đó, dưới dạng tên (Green, Black, Blue, Red, v.v.) hoặc mã RGBA (ví dụ: #FF0065FF). |
SquareHole_Count |
Số lượng đối tượng pad có lỗ hình chữ nhật trong PCB nguồn của tài liệu Draftsman. |
StackedVia_Count |
Số lượng via xếp chồng trên PCB nguồn của tài liệu Draftsman. |
String_Count |
Số lượng đối tượng văn bản trong PCB nguồn của tài liệu Draftsman. |
Thru_Via_Count |
Số lượng via xuyên lỗ trên PCB nguồn của tài liệu Draftsman. |
Total_Thickness |
Tổng độ dày của PCB nguồn của tài liệu Draftsman. |
Track_Count |
Số lượng đối tượng đường mạch trong PCB nguồn của tài liệu Draftsman. |
VariantName |
Tên biến thể thiết kế được chọn cho tài liệu Draftsman. |
Via_Count |
Số lượng đối tượng via trong PCB nguồn của tài liệu Draftsman. |
Cấu hình lưới và các tùy chọn bắt dính
Trước khi đặt đối tượng trong tài liệu Draftsman, hãy thiết lập lưới và cấu hình các tùy chọn bắt dính để thao tác đặt đối tượng dễ dàng hơn. Các tùy chọn lưới và bắt dính được cấu hình trong vùng General của tab General trên bảng Properties khi không có đối tượng nào được chọn trong không gian thiết kế.
Trong không gian thiết kế, các đường lưới được hiển thị dưới dạng nét chấm và cứ mỗi đường lưới thứ mười sẽ được vẽ bằng nét liền. Đặt khoảng cách giữa các đường lưới bằng trường Grid Size trên bảng Properties khi không có đối tượng nào được chọn trong tài liệu. Ngoài ra, có thể đặt giá trị lưới bằng hộp thoại Snap Grid (1..1000) , được truy cập bằng cách chọn lệnh View » Set Grid Size từ các menu chính (phím tắt: G).
Sử dụng tùy chọn Show Grid để điều khiển việc hiển thị các đường lưới trên các trang tài liệu. Sử dụng nút màu tương ứng để chỉ định màu của lưới trong không gian thiết kế.
Bắt dính là tính năng hỗ trợ khi đặt và di chuyển đối tượng trên các trang của tài liệu Draftsman. Tính năng này hút đối tượng nguyên thủy vào các điểm hoặc đường dẫn hướng được tạo bởi các đối tượng hiện có hoặc bởi lưới đã xác định cho tài liệu. Nhờ đó, bạn có thể căn chỉnh nhanh chóng và dễ dàng các thành phần trên các trang của tài liệu. Có thể bật/tắt tính năng bắt dính bằng tùy chọn Snapping trong bảng Properties hoặc lệnh View » Toggle Snapping từ các menu chính (phím tắt: Shift+E).
Khi tính năng bắt dính được bật, bạn có thể cấu hình thêm bằng cách bật/tắt riêng từng tùy chọn bên dưới.
| Snap to Grid | Khi được bật, con trỏ xem trước sẽ bắt dính (nhảy) vào các giao điểm của đường lưới khi trình biên tập ở chế độ đặt đối tượng. Lưu ý rằng tính năng bắt dính vào lưới không hoạt động khi lưới không được hiển thị (tức là khi tùy chọn Show_Grid bị tắt). |
| Snap to Vertices | Khi được bật, con trỏ xem trước sẽ bắt dính vào góc (đỉnh) của đối tượng khi trình biên tập ở chế độ đặt đối tượng. Đỉnh sẽ được đánh dấu bằng một chấm màu cam khi con trỏ xem trước bắt dính vào đó. |
| Snap to Boundaries | Khi được bật, con trỏ xem trước sẽ bắt dính vào đường bao của đối tượng (hoặc phần kéo dài của cạnh đó) khi trình biên tập ở chế độ đặt đối tượng. Các phần kéo dài đường bao đối tượng được hiển thị bằng nét đứt mảnh. |
| Snap to Line centers | Khi được bật, con trỏ xem trước sẽ bắt dính vào trung điểm của một đường bao đối tượng khi trình biên tập ở chế độ đặt đối tượng. Trung điểm của đường sẽ được đánh dấu bằng một chấm màu cam khi con trỏ xem trước bắt dính vào đó. |
| Snap to Circle centers | Khi được bật, con trỏ xem trước sẽ bắt dính vào tâm của đối tượng hình tròn khi trình biên tập ở chế độ đặt đối tượng. Tâm hình tròn sẽ được đánh dấu bằng một chấm màu cam khi con trỏ xem trước bắt dính vào đó. |
| Snap to component references | Khi được bật, con trỏ xem trước sẽ bắt dính vào các điểm tham chiếu của linh kiện. |
| Snap to Visible primitives | Khi được bật, con trỏ xem trước sẽ bắt dính (theo các tùy chọn bắt dính khác) vào các đối tượng nguyên thủy đang hiển thị trong khung nhìn hiện tại của trang. Khi bị tắt, con trỏ sẽ bắt dính vào tất cả các đối tượng có trên trang. ![]() |
Sử dụng tùy chọn Snapping Distance để nhập khoảng cách mà tại đó con trỏ xem trước sẽ bắt dính vào các thành phần được chỉ định làm mục tiêu bắt dính. Hoặc sử dụng danh sách thả xuống để chọn một giá trị tương đối so với lưới hiện tại (ví dụ: 0.5x Snap Grid).
Cấu hình các trang tài liệu
Tài liệu Draftsman có định dạng nhiều trang, cho phép chứa các trang riêng lẻ được dành cho từng loại thông tin sản xuất cụ thể của dự án bo mạch.
Có thể thêm hoặc xóa trang khỏi tài liệu hiện tại bằng các lệnh Add New Sheet và Remove Sheet trong các menu chính Tools hoặc menu chuột phải trong không gian thiết kế. Trang mới được chèn sau trang có con trỏ tại thời điểm chạy lệnh và sẽ có hình thức theo mẫu trang Draftsman hiện đang được áp dụng cho trang ngay trước đó.
Có thể xác định các thiết lập cho từng trang trong tài liệu Draftsman tại tab Page Options của bảng Properties khi không có đối tượng nào được chọn trong không gian thiết kế. Các thiết lập này xác định cấu trúc cơ bản của trang (kích thước, lề, v.v.).
Các thay đổi đối với thuộc tính tùy chọn trang có thể được áp dụng cho trang hiện tại hoặc tất cả các trang trong tài liệu. Chọn nút
ở đầu bảng Properties để áp dụng các thiết lập thuộc tính đã thay đổi cho trang hiện tại hoặc nút
để áp dụng thay đổi cho tất cả các trang của tài liệu. Số thứ tự của trang hiện tại được hiển thị trong và có thể được chọn từ danh sách thả xuống Current Page.
Sử dụng vùng Formatting and Size của bảng để chọn cách xác định định dạng trang.
| Template | Thiết lập kích thước và định dạng trang bằng cách chọn từ các mẫu trang Draftsman có sẵn. Đối với các mẫu Workspace (được liệt kê dưới mục Workspace mà bạn đã kết nối theo định dạng |
| Standard | Thiết lập kích thước trang theo một định dạng trang tiêu chuẩn. Sử dụng menu thả xuống Sheet Size để chọn từ danh sách kích thước trang tiêu chuẩn. |
| Custom | Thiết lập kích thước trang theo kích thước tùy chỉnh được chỉ định bằng các trường Width và Height. Lưu ý rằng giá trị chiều rộng hoặc chiều cao tối đa có thể nhập là 20000 mm. |
Các tùy chọn trong vùng Margin and Zones của bảng xác định kích thước của khung viền trang và các phần chia vùng của khung.
| Show Zones | Bật để hiển thị các phần chia vùng trong khung viền. |
| Vertical | Thiết lập số phần chia (hàng) trên lề dọc của trang. Kiểu nhãn vùng bằng chữ và số được xác định bởi các thiết lập Origin và Letter Position trong vùng này của bảng. |
| Horizontal | Thiết lập số phần chia (cột) trên lề ngang của trang. Kiểu nhãn vùng bằng chữ và số được xác định bởi các thiết lập Origin và Letter Position trong vùng này của bảng. |
| Margin | Thiết lập khoảng cách giữa mép trang và từng đường trong bốn đường viền. |
| Origin | Thiết lập góc của các trang tài liệu mà từ đó các ký hiệu vùng bằng chữ và số quanh khung viền sẽ bắt đầu (vị trí vùng A-1 hoặc 1-A). |
| Letter Position | Thiết lập vị trí đặt các ký hiệu vùng dạng chữ trên (các) trang tài liệu: trong các vùng ngang ở đường biên (cột) hoặc các vùng dọc (hàng). Chọn tùy chọn Iterate Columns Across Sheets để các ký hiệu chữ và số được gán cho cột tăng tuần tự trên tất cả các trang tài liệu (thay vì bắt đầu từ A hoặc 1 trên mỗi trang). |
Điều hướng tài liệu Draftsman bằng bảng Bookmarks
Bảng Bookmarks cung cấp một cách thuận tiện để điều hướng và quản lý các tài liệu Draftsman nhiều trang. Bảng hiển thị toàn bộ cấu trúc tài liệu dưới dạng cây có thể mở rộng, tương tự như bảng Projects, bao gồm tất cả các trang tài liệu và các đối tượng hình chiếu chính trong những trang đó.

Sử dụng bảng Bookmarks để di chuyển giữa các hình chiếu trong tài liệu Draftsman nhiều trang.
Bảng Bookmarks hiển thị các trang và đối tượng trong tài liệu Draftsman dưới dạng cây có cấu trúc, trong đó mỗi mục trang có thể được mở rộng hoặc thu gọn. Các mục trang trong cây được Draftsman tự động đặt tên theo thứ tự giảm dần. Nội dung con của mỗi mục trang trong bảng bao gồm các đối tượng thuộc loại hình chiếu Draftsman trên trang đó nhưng không bao gồm các đối tượng bản vẽ phụ như kích thước, chú dẫn, hình dạng đồ họa, v.v.
Bảng Bookmarks cung cấp khả năng điều hướng chủ động, trong đó trang hoặc đối tượng bản vẽ được chọn trong cây sẽ được đưa vào vùng hiển thị chính trong không gian thiết kế. Đối tượng được chọn trong cây cũng được chọn trong khung nhìn bản vẽ, đồng thời khung nhìn được thu phóng để vừa với đối tượng đó. Việc điều hướng trong cây có tính hai chiều, do đó mục được chọn trong cây cũng sẽ thay đổi theo trang hoặc đối tượng được chọn trong không gian thiết kế.
Bảng Bookmarks còn có các tính năng quản lý trang tài liệu, chẳng hạn như thêm, xóa trang và thay đổi thứ tự vị trí của chúng trong cấu trúc tài liệu Draftsman. Dãy nút chức năng ở đầu bảng được dùng để quản lý cách hiển thị và cấu trúc của các trang tài liệu:
-
Thiết lập kiểu hiển thị trang tài liệu bằng các nút Single/Continuous, trong đó nút
thiết lập không gian thiết kế để chỉ hiển thị một trang tại một thời điểm và nút
bật chế độ hiển thị liên tục, hiển thị tất cả các trang theo một chuỗi có thể cuộn.
-
Nhấp vào nút
để thêm một trang tài liệu mới sau trang đang được chọn. Nút
xóa trang đang được chọn khỏi danh sách cây hoặc, nếu một đối tượng bản vẽ đang được chọn, xóa đối tượng đó khỏi trang.
-
Sử dụng các nút
và
để di chuyển trang đang được chọn lên hoặc xuống một bậc trong thứ tự danh sách cây. Trang cùng các đối tượng bên trong sẽ thay đổi vị trí tương ứng và trang được đổi tên để phù hợp với vị trí mới trong cây.
Các tùy chọn khác có sẵn trong menu ngữ cảnh khi nhấp chuột phải vào một trang hoặc đối tượng trong cây.
-
Sử dụng các tùy chọn khi nhấp chuột phải vào trang để xóa trang được chọn, thêm trang mới vào tài liệu hoặc truy cập các thuộc tính của trang trong bảng Properties, bảng này sẽ mở nếu chưa được mở.
-
Sử dụng các tùy chọn khi nhấp chuột phải vào đối tượng để xóa đối tượng được chọn hoặc truy cập các thuộc tính của đối tượng trong bảng Properties, bảng này sẽ mở nếu chưa được mở.
Hỗ trợ các biến thể thiết kế
Trong Altium Designer, bạn có thể tạo các phiên bản khác nhau của một thiết kế bo mạch (biến thể thiết kế) và chuyển thông tin biến thể này sang Draftsman, qua đó cho phép áp dụng một biến thể thiết kế cho hình chiếu bản vẽ hoặc bảng BOM đã đặt. Có thể thêm tham số cho từng biến thể. Các tham số này thường được áp dụng dưới dạng chuỗi đặc biệt (được diễn giải) trong tài liệu Altium Designer để cho biết biến thể nào hiện đang được kích hoạt.
Trong Draftsman, biến thể hiện tại của dự án ở cấp tài liệu được chọn bằng danh sách thả xuống Variants trong vùng Properties thuộc thẻ General của bảng Properties khi không có đối tượng nào được chọn trong không gian thiết kế.
Các hình chiếu lắp ráp bo mạch, hình chiếu đẳng cự bo mạch và hình chiếu chân thực bo mạch đã đặt sẽ phản ánh biến thể được chọn. Đối với hình chiếu lắp ráp bo mạch, cách hiển thị các linh kiện không được lắp tuân theo các tùy chọn tài liệu đã cấu hình (tìm hiểu thêm). Đối với hình chiếu đẳng cự bo mạch hoặc hình chiếu chân thực bo mạch, các linh kiện không được lắp sẽ không xuất hiện trong hình chiếu Có thể chọn biến thể hiện tại cho một hình chiếu trong bảng Properties khi hình chiếu đó được chọn trong không gian thiết kế.
Các chuỗi đặc biệt, chẳng hạn như =VariantName và các tham số biến thể, có thể được đặt trong bản vẽ dưới dạng chuỗi tự do.
Để biết thêm thông tin về các đối tượng văn bản, hãy tham khảo trang Làm việc với chú thích.
)
)
)
)
).
)
).
).
)
).