本页列出了 Altium Designer 26、Altium Designer Develop 26 和 Altium Designer Agile 26 公开发布版本的发行说明。
有关 Altium Designer 26、Altium Designer Develop 26 和 Altium Designer Agile 26 的新功能及后续改进概述,请参阅Altium Designer 新功能。
正在查找 Altium Designer 早期版本的公开发行说明?有关 Altium Designer 25 至 20.0 的发行说明,请参阅历史公开发行说明。此外,您还可以访问其他安装程序页面的旧版文档部分,下载包含 Altium Designer 早期版本(最低至 15.1)文档离线 HTML“快照”的 Zip 压缩包。
版本 26.11.1
Altium Designer Develop – Released: 14 October 2026, Version 26.11.1 (build 5)
Altium Designer Agile – Released: 14 October 2026, Version 26.11.1 (build 28)
Altium Designer – Released: 14 October 2026, Version 26.11.1 (build 5)
Altium Designer 新功能
原理图
| 71187 |
在某些情况下,使用封装管理器尝试为集成库中的元件添加封装时,会发生访问冲突(位于“WorkspaceManager.DLL”模块中)。 |
| 71993 |
在某个特定设计中,其中一份原理图文档上某个连接器的引脚参数未显示。 |
| 72050 |
在本地打开受 VCS 控制的层次式项目,并使用“历史记录与版本控制 » 打开远程文档版本”命令同时打开该项目的某个远程文档(将其作为自由文档打开)后,尝试在本地项目中从图纸入口跳转到对应端口(或反向跳转)时,会发生访问冲突(位于“AdvSch.dll”模块中)。 |
| 72266 |
即使启用了仅包含“仅选定对象”的选项,“参数表编辑器”对话框仍会显示所有对象。(BC:28074) |
PCB
| 69927 |
对于某个特定设计,在线 DRC 未遵循已定义的板外形间距设计规则,允许在间距边界内布线。 |
| 70815 |
在某种特定情况下,尝试打开某个 PCB 时,会出现“未将对象引用设置到对象的实例”错误。 |
| 70982 |
在某些情况下,处理 PCB 文档时会发生访问冲突(位于“Altium.PCB.DataModel.X.dll”模块中)。 |
| 71068 |
对于与覆铜的连接方式设为“直接连接”的过孔,如果将其放置在同网络的网格覆铜(设置为“覆盖所有同网络对象”)内,但未接触覆铜的任何网格走线,该过孔在电气上将处于未连接状态,从而导致未布线网络规则违规。本版本增强了对以下情况的支持:焊盘/过孔放置在同网络的网格覆铜内,但未接触覆铜走线。现在,系统会通过附加走线将其连接到最近的覆铜走线。(需要启用 PCB.Polygon.AdvancedPour 高级设置选项)。(BC:26380、I:26384) |
| 71081 |
在 3D 布局模式下查看 PCB 时,双击元件(带有关联的 3D 实体),并在弹出的选择窗口中选择该元件后,“属性”面板始终显示 3D 实体,而非该元件。 |
| 71542 |
启用“自动收缩”选项并将布线宽度设为最大值进行交互式布线时,走线未遵循板外形间距设计规则中定义的约束。 |
| 71641 |
在某些情况下,在 3D 布局视图模式下处理 PCB 时,会发生访问冲突(位于“NvPresent64.dll”模块中)。 |
| 71749 |
在某些情况下,尝试将旧格式的 PCB 文档保存为较新格式时,会出现“EIntfCastError:不支持的接口...”错误。 |
| 71820 |
在某个特定设计中,启用 PCB.Polygon.AdvancedPour 选项(高级设置)后,重新铺设所有覆铜,然后关闭 PCB 而不保存更改,会导致 Altium Designer 无提示崩溃。 |
| 71917 |
在某些情况下,使用 PCB 协同设计功能时,尝试合并检测到的差异会出现“未将对象引用设置到对象的实例”错误。 |
| 71998 |
在某些情况下,移动/编辑设计图元并因此触发设计规则违规时,会发生访问冲突(位于“ADVPCB.DLL”模块中)。 |
| 72194 |
当禁布走线穿过网格覆铜,且适用的间距规则设为零时,尝试重新铺铜会导致仅部分覆铜得到重新铺设。(BC:3579,在评论中被提及的问题) |
| 72197 |
在某些情况下,启用 PCB.Polygon.AdvancedPour 选项(高级设置)并执行交互式操作(例如穿过覆铜布线)后,首次尝试重新铺铜时不会生效。(BC:28029、BC:28041) |
| 72222 |
当“对象”选项设为“仅选定对象”,并从覆铜挖空区域内的选定焊盘移除泪滴时,该挖空区域内其他未选定焊盘的泪滴也被错误地移除。 |
| 72224 |
对于某个特定 PCB,当启用了“焊盘顶点”和“焊盘边缘”选项(位于“板选项”的“捕捉对象”区域),且多层上存在焊盘尺寸(X/Y 尺寸)= 0、孔径 = 0 的已放置焊盘时,会发生内存泄漏,导致 Altium Designer 在 PCB 编辑期间的内存占用持续增加,且直到完全重启软件后才会释放。(BC:27907) |
| 72228 |
对于顶层和底层均定义了环形焊盘的 PCB 库元件,在从库中放置期间将元件从顶层翻转到底层(或直接从库中放置到底层)时,底层焊盘的 X 尺寸和 Y 尺寸值会错误地变为与顶层定义的值相同。(BC:27439) |
| 72236 |
使用“覆铜管理器”对话框删除覆铜时,对话框右键菜单中“删除”命令下方的对象也会被错误地操作。如果“删除”命令位于另一个覆铜条目上方,则除了删除正确的覆铜之外,该覆铜也会被错误地删除。如果“删除”命令位于层标题条目上方,则会发生访问冲突(位于“ADVPCB.DLL”模块中)。 |
| 72298 |
在某些情况下,启用 PCB.Rendering.DrawArcBaseGeometry 选项(高级设置)后,对于包含已放置图形(例如已定义的公司徽标)的封装模型的 PCB 库,无法在“元件”面板中渲染该封装模型的 3D 视图,并会发生访问冲突(位于“ADVPCB.DLL”模块中)。 |
| 72616 |
当 Windows 系统区域设置(在“区域设置”中)设为“中文(简体,中国)”,且在“首选项”的“系统 - 常规”页面启用了“使用本地化资源”选项时,重新启动 Altium Designer 并尝试打开任意 PCB 文档会导致访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 72715 |
尝试通过“配置物理网络”对话框编辑 PCB 的物理网络时,会导致访问冲突(位于模块“ADVPCB.DLL”中)。(BC:28181) |
| 72746 |
启用 PCB.Polygon.AdvancedPour 选项(高级设置)后,在包含已添加补强板的板区域的设计中,添加覆盖膜会错误地创建“零面积多边形”,导致覆盖膜在电路板的 3D 视图中不可见,也未包含在生成的制造文件中。(BC:28219) |
约束管理器
| 72052 |
在某些情况下,从 xNet 创建差分对时,可能会创建重复的 xNet 差分对,从而导致出现“已添加具有相同键的项...”错误。 |
引线键合
| 71824 |
在基于 Draftsman 的制造图纸文档 (*.PCBDwf) 中,引线键合未能在板剖视图、元件视图和板等轴测视图中正确显示。 |
线束设计
| 72478 |
在某些情况下,将线束设计的布局图中的更改导入其线束制造图后,布局图视图不可见。(BC:28069) |
| 72562 |
对于某个特定线束设计,尝试将底层布局图中的更改导入线束制造图时,会出现错误“System.ArithmeticException: 函数不接受浮点非数字值”。 |
平台
| 71586 |
在某些情况下,在 Altium Designer 中使用 WebView2 查看与浏览器相关的元素(例如主页)时,会出现错误“System.Runtime.InteropServices.COMException: 调用的对象已与其客户端断开连接...”。 |
| 72010 |
对于使用“EMI Design Rule Checker”或“Plane Resonance Analyzer”扩展的用户,尝试从 PCB 文档的主菜单中启动这些功能时,会导致 Altium Designer 终止。 |
| 72208 |
当多个用户使用同一台计算机时,只有最初安装 Altium Designer 的用户能够成功启动该软件。其他用户会遇到“运行时错误 217”。 |
| 72437 |
启用 UI.ProjectOptions.SearchPaths 选项(高级设置),并在“项目选项”对话框的“搜索路径”选项卡中添加搜索路径后,单击“刷新列表”按钮会出现错误“类型 ‘Altium.WorkspaceManager.DataModel.SourceDocumentAdapter’ 的父类型具有 ComVisible(false) 属性...”。(BC:28114) |
| 72461 |
本版本重新添加了在 Altium Designer 26.10 的“版权声明”对话框中移除的其他“第三方”声明。 |
数据管理
| 59358 |
在某些情况下,使用项目发布器时会遇到访问冲突(位于模块“ProjectReleaser.dll”中)。 |
| 63077 |
当元件编辑器配置为单元件编辑模式时,无法通过该编辑器重命名线束接线模型。在某些情况下,模型预览也会消失。 |
| 63161 |
在已共享设计的文档中放置评论,并将其作为任务分配给特定用户时,创建的任务未包含被分配人。 |
| 64044 |
将工作区项目共享给外部用户(非该工作区成员),并通过浏览器界面添加分配给该用户的任务后,除非该用户连接到该工作区,否则在打开“与我共享”项目后,该任务不会显示在其 Altium Designer 的“评论和任务”面板中。 |
| 65819 |
从已放置的评论创建新的 Jira 问题时,添加了“(可选)”标签,以更清楚地指明哪些字段(描述和被分配人)为可选字段。 |
| 69464 |
将工作区模型的更改发布为新修订版时,拥有相应操作权限的用户现在可以保留引用该模型的关联工作区元件的当前生命周期状态。模型本身的当前生命周期状态将不再保留。请注意,此功能仅适用于 Altium 平台上的工作区。(BC:27174) |
| 70222 |
在元件编辑器中使用批量元件编辑模式编辑元件时,无法将小数值粘贴到现有的源自模板的参数中。这些值会被四舍五入为最接近的整数。 |
| 71432 |
在已连接的工作区之间切换时,“项目活动”和“项目发布器”子菜单中提供的、为已连接工作区定义的基于流程的工作流未能更新,导致尝试调用这些工作流时出现“流程定义不可用”错误。 |
| 71524 |
首次将元件或设计项目发布到已连接的工作区,并在该工作区中创建相关条目时,不再在临时文件夹(例如 C:\Users\<UserName>\AppData\Local\Temp)中运行 CMD 脚本来将这些条目打包为 Zip 文件(使用 7za.exe)以上传到工作区。 |
| 71783 |
使用项目发布器发布设计项目时,可能会错误地进入一种状态,导致先前发布的现有数据(例如制造数据集)被后续发布的数据修改。 |
| 71798 |
增强了“评论和任务”面板中的筛选控件。默认筛选状态为启用所有类型(评论、任务和 Jira 问题),不启用范围筛选(“当前文档”;已从设置窗口移至此处),也不启用任何被分配人筛选(已分配的任务或 Jira 问题)。现在,仅当筛选状态不是默认状态时,筛选按钮才会变为蓝色。此外,还提供了“清除筛选”控件,可快速将筛选恢复为默认状态。 |
| 71807 |
新增了在编辑元件模板时复制和粘贴系统参数的功能,并支持在模板文档之间粘贴。(I:27691) |
| 71893 |
在元件编辑器的批量元件编辑模式下,如果已定义的元件使用参数定义其名称和/或描述,现在复制该元件时,新元件的“名称”/“描述”字段会保留对这些参数的使用,而不是转换为纯文本。 |
| 72320 |
通过“编辑操作权限”对话框为已连接的工作区定义操作权限时,如果从某个操作类型中移除了“工作区成员”实体,则无法将其重新添加。 |
| 72354 |
在 Explorer 面板(经典视图或元件视图)中对选定元件使用“操作 » 导出网格”命令时,如果启用了“仅显示最新版本”选项,现在将仅导出这些元件的最新修订版,而不再像以前那样导出所有修订版。 |
| 72566 |
配置物料清单报告(直接配置或通过 OutJob 配置)时,尝试通过“筛选器编辑器”对话框修改筛选条件会导致出现“未将对象引用设置到对象的实例”错误。 |
导入/导出
| 68628 |
导入 KiCad 版本 9 或 10 的设计文件时,层映射不正确,机械层被映射到了信号层。 |
| 72009 |
导入 KiCad 版本 10 的设计文件时,网络信息未被导入,导致铜图元被设置为“无网络”。 |
版本 26.10.1
Altium Designer Develop – Released: 9 September 2026, Version 26.10.1 (build 6)
Altium Designer Agile – Released: 9 September 2026, Version 26.10.1 (build 26)
Altium Designer – Released: 9 September 2026, Version 26.10.1 (build 5)
Altium Designer 新增功能
原理图
| 70630 |
在原理图库编辑器中,无法通过 SCHLIB List 面板添加或编辑当前符号引脚的引脚交换组。此外,如果尚未为某个引脚定义引脚交换,单击 SCHLIB List 面板中该引脚的“引脚交换组”单元格会导致出现“列表索引越界”错误。(BC:27524) |
| 70843 |
在原理图上放置覆盖区域时,如果在右键单击之前的最后一次左键单击未创建拐角,该操作会直接结束而不创建覆盖区域,而不是自动闭合轮廓。(BC:27593) |
| 71848 |
打开使用 Altium Designer 21.9 之前的版本创建的设计项目时,“图纸符号新索引方式”选项(位于“项目选项”对话框的“选项”选项卡中)虽然显示为已启用,但编译器却将其视为已禁用,除非在对话框中进行更改并保存,这容易造成混淆。现在,打开此类旧版设计时,该选项默认禁用,必须显式启用,以避免编译结果发生意外变化。 |
PCB
| 70006 |
某些情况下,在 PCB 文档中使用过孔屏蔽功能时,会出现访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 70007 |
某些情况下,在“PCB 规则与约束编辑器”对话框中使用“查询构建器”为规则定义自定义查询时,会出现访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 70192 |
在“PCB 规则与约束编辑器”对话框中引入了“规则集”概念,可高效地对一组特定于接口或制造商等的设计规则进行分组和复用。您可以快速查看和管理规则集中的规则、切换应用的规则集,以及导出和导入规则集,从而获得出色的可移植性。 |
| 70730 |
某些情况下,尝试导入使用 Altium CircuitMaker 创建的 PCB 文档时,会出现“未将对象引用设置到对象的实例”错误。 |
| 71136 |
在某个特定情况下,通过“PCB 规则与约束编辑器”对话框删除某条特定的等长设计规则后保存 PCB,会导致出现访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 71456 |
对于某个特定设计,使用自动长度调谐功能进行相位匹配(设置为“对内匹配”并指定特定约束)时,会导致差分对的一侧“过度调谐”,而不是按预期实现相位匹配。(BC:27828) |
| 71617 |
通过“视图配置”面板为丝印层上的对象配置高级对象可见性时,对走线可见性的更改未反映在设计空间中。 (BC:28130) |
| 71639 |
某些情况下,通过“多边形铺铜管理器”对话框根据板外形创建新的多边形铺铜,且在首选项中将多边形的默认铺铜模式设置为“网格”时,会出现“对象销毁后被访问...”错误。 在多边形自动生成仍在进行时尝试关闭“多边形铺铜管理器”对话框,也会出现此错误。(BC:28154) |
| 71642 |
某些情况下,将已放置的图元从信号层移至非信号层后使用“撤销”命令,会出现访问冲突(位于模块“X2.EXE”中)。 |
| 71694 |
使用“IPC 标准封装向导”创建 BGA、BQFP、CAPAE、CHIP、Chip Array、CQFP、DFN、LCC、LGA、MOLDED、PLCC、PQFP、PQFN、QFN、QFN-2ROW、SOIC、SON、SOP/TSOP、SOT143/343、SOT223、SOT23、SOT89、SOTFL 或绕线封装的封装模型时,生成的 STEP 模型错误地使用了“标称”尺寸,而不是预期的“最大”尺寸。(BC:27929) |
| 71739 |
新增高级设置选项“PCB.IPCWizard.DedicatedLayerAssignment”。启用后,通过“IPC 标准封装向导”创建封装时,会为元件中心和位号图元分配专用层,并自动创建装配层/庭院层对。请保持此选项禁用,以防止与使用 Altium Designer 26.7 之前的版本创建的现有库和模板出现兼容性问题。 |
| 71740 |
某些情况下,生成 ODB++ 制造数据时,小尺寸圆弧被错误地导出为圆,导致设计中不同网络之间出现意外短路。 |
| 71808 |
由于发现了一个影响 NC 钻孔和 ODB++ 输出的问题,本版本已将通过 PCB.ViaInstancing 选项(高级设置)提供的“过孔实例化”功能恢复为公开测试状态,以便开展调查。 |
| 71869 |
对于某个特定 PCB 中的一些 IPC 4761 Type 7 类型过孔,通过“PCB 焊盘过孔模板”面板放置这些过孔后,在焊盘过孔库中通过过孔模板定义的“盖镀”过孔特性未被带入 PCB 设计。选中此类过孔时,“属性”面板中没有“盖镀”特性;由于缺少此特性,PCB 设计空间的盖镀层以及生成的输出中均未显示这些过孔对应的盖镀内容。 |
| 71967 |
某些情况下,从“PCB 规则与约束编辑器”对话框切换到“文档视图”时,会出现“未将对象引用设置到对象的实例”错误。 |
| 72015 |
某些情况下,启用 PCB.ViaInstancing 选项(高级设置)并使用“移除未使用的焊盘形状”功能后,一些焊盘的焊环在设计空间中未正确显示(生成的制造文件中的所有内容均正确)。(BC:28010) |
| 72204 |
对于某块特定电路板,删除某个特定元件会导致出现访问冲突(位于模块“ADVPCB.DLL”中)。此外,对于同一块电路板,运行电路板健康检查后尝试修复问题,会导致 Altium Designer“无响应”。 |
引线键合
| 71242 |
将包含引线键合的设计导出为 HyperLynx ASCII 文件格式(*.HYP)时,会在底层下方额外添加一层,导致层叠无法使用。(BC:27701) |
线束设计
| 71006 |
新增了自由调整接线图中电缆、屏蔽或双绞对象宽度和高度的功能。选中对象后,可通过“属性”面板中的新控件在尺寸锁定(默认设置,保持高宽比为 2:1)与尺寸解锁(可按需自由调整尺寸)之间切换。通过拖动编辑手柄对对象进行图形化编辑时,也会遵循此控件的设置。(I:25518) |
| 71303 |
附加到线束束组的布局标签现在会随束组的方向变化。 |
| 71865 |
在布局图中选中束组的分段视图并将其删除后,选择“圆圈”仍会错误地显示在设计空间中。 |
平台
| 69062 |
新增了高级设置选项“PCB.UseOpenCascade790”。启用后,Altium Designer 将使用 7.9.0 版本的 Open CASCADE 库处理三维几何体。 |
| 71469 |
使用中文界面的 Altium Designer Develop 时,当所有创作席位均被占用时显示的警告文本翻译不正确。 |
| 71710 |
已从“帮助 » 关于”窗口中移除包含版权、商标和注册商标的详细信息部分。此外,还精简了“版权声明”对话框中的内容,并提供了指向 altium.com 上“版权与商标”页面的链接。 |
| 71832 |
禁用 System.ViewOnlyMode.Support 选项(高级设置)后,尝试创建或打开线束项目或多板项目会导致访问冲突(发生在“WorkspaceManager.DLL”模块中)。 (BC:28124) |
| 71845 |
尝试在用户没有写入权限的文件夹中创建新项目时,会出现错误“找不到路径‘<Path>’的一部分……”。 |
| 71982 |
在某些情况下,Altium Designer 的离线安装会失败,并出现错误“服务器 SSL 证书无效”。 |
| 72028 |
在某些情况下,使用 Smart PDF 功能生成 PDF 文档时,如果该 PDF 已在第三方 PDF 查看器中打开,会出现错误“发生一个或多个错误。(索引超出了数组界限)……”,而不是提示该 PDF 正被其他程序使用,需要先在该程序中将其关闭。 |
| 72314 |
启用 Windows 智能应用控制后,由于模块 Altium.PlatformAPIClient.dll 未签名而被阻止,启动时会出现“运行时错误 216”。(BC:28113) |
数据管理
| 57463 |
“打开项目”对话框及其关联的“选择列”对话框在处理列名时区分大小写,因此会显示多个独立的列,而不是单个列。 |
| 70907 |
增强了自定义元器件提供商同步功能,现在可在底层自定义元器件提供商同步配置文档 (*.PrtSync) 中包含额外的“类别”和“数据手册”系统参数。 |
| 70911 |
增强了自定义元器件提供商同步功能,现在支持在自定义元器件提供商同步配置文档 (*.PrtSync) 中使用自定义参数。 |
| 71005 |
在某些情况下,Altium Designer 尝试重新连接到之前的工作区时会卡死。 |
| 71193 |
在某些情况下,当“库健康状况”视图或项目视图处于活动状态时访问“资源管理器”面板,会导致在通过工作流提交元器件申请时无法选择工作区条目/修订版,并使活动的元器件申请工作流在当前 Altium Designer 会话的剩余时间内无法正常运行。 |
| 71286 |
使用 Altium Designer 自定义元器件提供商同步功能,将指定数据库来源的供应商数据映射到工作区供应链数据时,现在支持在“制造商元器件搜索”面板中显示“类别”和“数据手册”系统参数,以及任何自定义参数(在底层自定义元器件提供商同步配置文档 (*.PrtSync) 中定义)。这需要启用高级设置选项“EDMS.CustomOffersMerge”,该选项会将已配置的自定义元器件提供商的供应商数据与 Altium 元器件提供商的数据合并,以集中显示所有供应商信息(注意:“供应商数据合并”功能仅在连接到 Altium 平台上已启用 BOM Portal 的工作区时可用)。 |
| 71373 |
将受管元器件(来自已连接的工作区)手动添加到项目的 ActiveBOM 后,如果随后编辑该元器件并将其发布为更新的修订版,则无法在 ActiveBOM 中将其更新到该修订版(右键菜单中的“操作 » 更新到最新修订版”命令不可用,显示为灰色)。(BC:27687) |
| 71457 |
现在,在已连接的工作区中创建新元器件(或编辑已发布的现有元器件)时,可以使用参数来定义名称和/或描述(例如 [ParameterName1]_[ParameterName2]),前提是已为该元器件定义了这些参数及其值。 |
| 71598 |
由 EDMS.CloudLoginByJWT 选项(高级设置)提供的“使用 JWT 进行用户识别/身份验证”功能现已随此版本正式公开发布(默认开启)。 |
| 71724 |
在特定情况下,尝试访问“设计复用”面板会出现错误“字符串末尾存在其他无法解析的字符……”。 |
| 71795 |
对于某个特定设计,使用“变体管理器”(在高级设置中启用了 UI.ModernVariantsManager 选项)并通过“属性”面板更改元器件参数后,尝试从输出作业文件生成原理图打印件的 PDF 时,会出现错误“未将对象引用设置到对象的实例……”。 |
| 71830 |
在单元器件编辑模式下使用元器件编辑器时,“名称”字段的搜索功能已得到增强。现在,只有输入至少两个字符后才会开始搜索,并提供提示文本对此加以说明。 |
| 71841 |
创建数据库库时,无法直接在参数表格中为参数启用“添加时可见”选项。此外,虽然可以通过右键上下文菜单中的命令启用该选项,但保存并重新打开 DbLib 文件后,该选项会被禁用。 |
| 72173 |
对于某个特定设计,使用旧版变体管理功能(在高级设置中禁用了 UI.ModernVariantsManager 选项)并通过“变体管理”对话框更改元器件参数后,尝试从输出作业文件生成原理图打印件的 PDF 时,会出现错误“未将对象引用设置到对象的实例……”。 |
导入/导出
| 71440 |
导入某些 Allegro 设计时,部分元器件会错误地显示顶层锡膏层,尽管原始 Allegro 源文件中的这些元器件并没有该层。 |
| 71445 |
导入某个特定的 Allegro 设计时,顶层上某个特定元器件生成的焊盘尺寸不正确。 |
版本 26.9.1
Altium Designer Develop – Released: 5 August 2026, Version 26.9.1 (build 9)
Altium Designer Agile – Released: 5 August 2026, Version 26.9.1 (build 46)
Altium Designer – Released: 5 August 2026, Version 26.9.1 (build 10)
Altium Designer 新增功能
PCB
| 66357 |
引入了全新的高级多边形铺铜引擎,不仅提升了质量和性能,还能生成“真实圆弧”,而非近似圆弧。同时,还引入了全新的高级“动态多边形铺铜”功能:选中“修改后重新铺铜”选项(位于“首选项”的“PCB 编辑器 - 常规”页面)后,即可在执行交互式命令(例如交互式布线或交互式滑动)期间即时重新铺铜(动态铺铜)。请注意,这是新铺铜引擎的早期预览版本,在此初步实现中仅适用于实心多边形铺铜。 |
| 67639 |
在某个特定设计中,复制并粘贴跳层过孔会导致该过孔的层发生变化。(BC:26449) |
| 70679 |
新增了高级设置选项“PCB.Rendering.DrawArcBaseGeometry”。启用后,PCB 编辑器和 PCB 库编辑器的设计空间将支持渲染真实圆弧,而非近似圆弧。此支持涵盖二维/三维布局模式(以及 PCB 编辑器的板规划模式),适用于多边形铺铜(实心、网格、无填充)、多边形铺铜挖空区域、多边形铺铜和区域的选择轮廓、区域、阻焊和锡膏掩膜扩展、网络高亮显示、间距边界以及违规叠加显示(区域或多边形铺铜上的独立多边形铺铜)。注意:渲染真实圆弧还需要启用高级多边形铺铜引擎,即在“高级设置”对话框中启用 PCB.Polygon.AdvancedPour 选项。 |
| 70893 |
启用 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置)并在设计空间中选中一组焊盘后,尝试在“属性”面板的“标号”字段中使用字符串替换时,所有焊盘标号都会直接使用输入的字面内容,而不会按预期执行替换。(BC:27612) |
| 71113 |
增强了导入一个或多个与现有规则集同名的规则集(.rul 文件)时的规则处理功能。现在提供三种操作来处理规则集内的导入规则:“添加到现有规则”(添加导入的规则,并重命名同名规则)、“添加并替换匹配规则”(添加导入的规则,并替换现有的同名规则)和“全部替换”(删除规则集中的所有现有规则,然后导入所选规则)。(BC:27821) |
| 71331 |
使用“任意角度”拐角样式、弱平滑处理且冲突解决方式设为“绕障并推挤障碍物”进行交互式布线时,设置较高的斜接比率(例如 20x)会导致 Altium Designer 无响应,必须通过 Windows 任务管理器将其终止。(BC:27782) |
| 71349 |
在某些情况下,放置在信号层(而非禁止布线层)上的禁止布线区域未在设计空间中渲染显示。不过,这些区域仍可被选中,且功能正常。(BC:27919) |
| 71412 |
使用“编辑 » 移动 » 旋转选中对象”命令后,“旋转角度”对话框中输入的值未被记住。(BC:27805) |
| 71427 |
对于包含多个 PCB 库的项目,通过输出作业文件生成 PCBLIB 打印输出的 PDF 时,如果“数据源”设为“所有 PCBLIB 文档”,则会出现“对象引用未设置为对象的实例...”错误。 |
| 71543 |
在某个特定情况下,使用 IPC 标准封装向导创建 PQFN 封装时,在向导的“PQFN 封装尺寸”页面禁用“使用计算的封装值”选项,并将 X1 设为 0.25、Y1 设为 0.6,会导致 Altium Designer 无响应。(BC:27875) |
| 71595 |
在“对象类浏览器”对话框中,任何已定义的多边形类的“成员”区域均未显示多边形铺铜。(BC:27899) |
| 71638 |
直接通过 PCB 编辑器的“文件”菜单为 PCB 生成输出(例如 Gerber、ODB 等)时,如果在“项目选项”对话框的“选项”选项卡中启用了“为每种输出类型使用单独的文件夹”选项,生成的输出未被创建在预期的子文件夹中。 |
| 71669 |
在某些情况下,向设计中的某个网络添加缝合过孔后,在线 DRC 会错误地报告间距约束规则违规。(BC:27917) |
| 71809 |
在某个特定设计中,启用 PCB.ViaInstancing 选项(高级设置)后,部分 IPC 4761 过孔的钻孔未导出到生成的 NC Drill 和 ODB++ 输出中。 |
CAMtastic
| 67163 |
尝试将 ODB++ 数据(不含信号层)连续两次导入新的 CAMtastic 文档时,会出现访问冲突(位于“CAMDXP.dll”模块)。 |
| 70762 |
在某些情况下,在 CAMtastic 编辑器中处理生成的 ODB++ 制造数据时,会出现访问冲突(位于“CAMDXP.dll”模块)。 |
引线键合
| 66450 |
对于某个包含嵌入式元件的特定设计,在三维布局模式下查看电路板时,腔体内三维裸片实体上的裸片焊盘未被正确渲染。 |
线束设计
| 58777 |
新增了在布局图中“自由”旋转元件物理模型视图的支持。现在,您可以在设计空间中以图形方式旋转模型,或在“属性”面板中直接输入所需角度(需选中物理模型视图),从而设置自定义旋转角度。(I:25235) |
| 68450 |
新增了在布局图中重新分配线束束段对象的支持,适用于导线在源连接器与目标连接器之间存在多条可用路径的情况。默认情况下,导线会自动分配到最短的束段路径,但现在您可以手动更改此分配。选中设计空间中的束段后,“属性”面板的“束段对象”部分底部会出现新的“将对象分配到束段”控件,且仅在存在替代布线路径时显示。通过此控件可打开一个对话框,在适用且有效的束段之间移动对象(导线/电缆)。作为此功能的一部分,原有的“分配到束段的对象”下拉字段(及其相关对象选择条目)已被移除。 |
| 70569 |
新增了将所选束段的“分段视图”放置到布局图中的支持,用于呈现该束段内部的导线(单根导线、双绞线对以及电缆中的导线),以便清楚地查看这些导线在线束束段内部的实际排布方式。每根导线均带有标签,使用其定义的颜色显示,并根据其“粗细”参数值按比例显示线宽。 |
平台
| 70878 |
设计空间右上角的活动服务器控件菜单中新增了垂直滚动条,方便您访问所有可用的工作区,尤其适用于您拥有大量工作区共享访问权限的情况。 |
| 71353 |
在某些情况下,如果软件配置的自动保存目标文件夹尚未创建,就会出现错误“拒绝访问路径 "<PathName>"。”。 |
| 71518 |
如果 PCB 设计的工程文件因某种原因包含重复的节,尝试通过“打开工程”对话框打开该文件时会发生异常。如果将工程从 Windows 文件资源管理器拖到“工程”面板中,该工程则会显示为空,不加载任何文档。 |
| 71605 |
自动备份功能存在一些问题。在某些情况下,启用此功能后始终只会创建一个备份。而在另一些情况下,禁用此功能反而会创建备份。(BC:27924, BC:27992) |
数据管理
| 70755 |
改进了“元件”面板首次打开时的易用性。“全部”类别现在默认展开(在普通模式和紧凑模式下均如此),切换到普通模式时会显示“类别”窗格。此外,两种模式下都会显示并展开详细信息区域。 |
| 70863 |
连接到没有有效订阅的工作区时,在“打开工程”对话框的“位置”区域中选择该工作区,会在对话框内显示错误“未将对象引用设置到对象的实例”。 |
| 70944 |
尝试将正确定义的网络连接器元件发布到已连接的工作区时,运行元件规则检查会错误地报告“铜连接短路”违规。 |
| 71092 |
由 EDMS.CustomOffersMerge 选项(高级设置)提供的“供应商数据合并”功能在此版本中正式公开发布(默认启用)。 |
| 71325 |
当搜索字符串包含等号(“=”)时,“资源管理器”面板中的搜索功能会返回大量不相关的元件。(BC:27743) |
| 71356 |
尝试通过输出作业文件将输出生成到指定文件夹(在关联的输出容器中指定)时,如果操作系统未授予该文件夹写入权限,就会出现错误“拒绝访问路径 "<PathName>"。”。 |
| 71421 |
使用工程发布器发布某个特定的 PCB 设计工程,并在“检查数据”阶段对生成的 Gerber 制造数据使用“比较 Gerber”功能时,会出现错误“无法将类型为 'System.__ComObject' 的 COM 对象转换为接口类型 'DelphiObjects_Interfaces.IWSM_DelphiServiceConcentrator'...”。 |
| 71438 |
从外部 SVN 版本控制存储库检出设计工程后,该工程不会自动在“工程”面板中打开。(BC:27835) |
| 71541 |
尝试通过输出作业文件生成原理图打印输出的 PDF 时,如果命名(例如端口名称)中的方括号顺序不正确(例如使用 ][、[[ 或 ]],而非 []),就会发生错误。 |
| 71640 |
在当前活动的输出作业文件中运行脚本,以更改“文件夹结构”输出容器的输出路径时,初始路径中的最后一级目录/文件夹会丢失。(BC:27900) |
导入/导出
| 70329 |
增强了 OrCAD 导入器,支持导入 OrCAD 设计中定义的变体。(需要启用 Importer.Orcad.AdvancedEngine 高级设置选项)。 |
| 70733 |
对于某个特定的 OrCAD 设计,添加到特定元件的 DNP(不装配)参数未被导入。(需要启用 Importer.Orcad.AdvancedEngine 高级设置选项)。 |
SI Analyzer by Keysight
| 71019 |
对于某个特定的 PCB 设计,尝试访问 SI Analyzer by Keysight 工具时,会出现错误“索引超出范围。索引必须为非负数且小于集合的大小。(参数 'index')”。 |
版本 26.8.1
Altium Designer Develop – Released: 9 July 2026, Version 26.8.1 (build 9)
Altium Designer Agile – Released: 9 July 2026, Version 26.8.1 (build 50)
Altium Designer – Released: 9 July 2026, Version 26.8.1 (build 31)
Altium Designer 新增功能
原理图
| 69676 |
在某些情况下,在原理图中的不同评论之间切换时,会出现错误“窗口关闭后,无法设置 Visibility,也无法调用 Show、ShowDialog 或 WindowInteropHelper.EnsureHandle”。 |
| 70448 |
如果为“本地模板文件夹”(位于“首选项”的“数据管理 - 模板”页面)指定了非默认路径,在为已打开的原理图文档加载模板(使用“工具 » 设计 » 图纸模板 » 本地 » 从文件加载”)时导航到该文件夹,重新启动 Altium Designer 后,路径会恢复为默认模板文件夹(\Users\Public\Documents\Altium\AD<Version>\Templates)。 |
| 71126 |
在某些情况下,使用封装管理器向选中的原理图元件添加封装时,会出现错误“未将对象引用设置到对象的实例”。(BC:27729) |
| 71170 |
在某些情况下,从源原理图中移除部分元件(或使用编译屏蔽将其屏蔽)后,尝试重置板级标注时,会出现错误“无法将类型为 "Altium.WorkspaceManager.DataModel.DesignatorRecordAdapter" 的对象转换为类型 "Altium.WorkspaceManager.DataModel.DesignatorRecord"...”。在另一种情况下,会出现错误“startIndex ('-9') 必须为非负值。(参数 'startIndex')...”。(BC:27716) |
PCB
| 65296 |
新增了通过高级设置选项 'PCB.IncreaseSignalLayers' 将 PCB 设计的信号层数量从 32 层增加到 128 层的功能。(I:8785) |
| 65724 |
对于某个特定的设计,向采用规则驱动阻焊扩展的网络添加缝合过孔或屏蔽过孔时,会导致底层阻焊扩展不正确,且“链接”控件显示的状态错误。(BC:27568) |
| 69160 |
向 PCB 添加泪滴时,性能会明显下降,处理耗时很长,内存占用也显著增加。(BC:27045) |
| 69996 |
启用 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置)以及“修改后重新铺铜”选项(位于“首选项”的“PCB 编辑器 - 常规”页面)后,将元件移动到多边形铺铜上,为选中的焊盘启用热焊盘连接并更改连接方式时,会出现错误“值不能为 null。(参数 'source')”。 |
| 70430 |
在某些情况下,对“锐角”设计规则运行 DRC 时,会发生访问冲突(位于模块 "ADVPCB.DLL" 中)。 |
| 70570 |
在“PCB 规则与约束编辑器”对话框中创建新规则(通过添加或复制)时,现在默认将焦点置于“名称”字段。 |
| 70658 |
使用泪滴功能时,如果通过平移将包含铜禁布走线的区域移至可视显示区域之外,这些禁布走线会被忽略,从而生成错误的泪滴。 |
| 70676 |
在某些情况下,在层叠管理器中重新计算阻抗配置的阻抗时(例如,类型为“差分共面”,粗糙度模型类型为“半球形”),会出现错误“事务已中止。--- System.Reflection.TargetInvocationException: 调用的目标引发了异常…”。 |
| 70709 |
由 ODB.IntellectualPropertyProtection 选项(高级设置)提供的“ODB++ 知识产权保护”功能现已随此版本正式公开发布(默认开启)。 |
| 70727 |
使用 PCB CoDesign 功能时,比较空的等长调节蛇形线会导致无提示崩溃。 |
| 70874 |
在某些情况下,处理 PCB 库文档时会出现访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 70983 |
在某些情况下,在板规划模式下定义板区域或板形状时,会出现访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 70986 |
在某些情况下,将规则导入“PCB 规则和约束编辑器”对话框时,会出现访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 71135 |
在某些情况下,尝试从“PCB 规则和约束编辑器”对话框中访问“编辑规则优先级”对话框时,会出现访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 71137 |
在某些情况下,使用“PCB 规则和约束编辑器”对话框中的搜索/筛选字段时,会出现访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 71163 |
使用“显示差异”工具比较设计项目的网表与其 PCB 文档时,会出现错误“未将对象引用设置到对象的实例…”。(BC:27726) |
约束管理器
| 66118 |
创建高级间距规则时(从 PCB 访问约束管理器后,在“所有规则”视图中创建),现在可以使用控件在最小间距矩阵的“简单”和“高级”操作模式之间切换(与“PCB 规则和约束管理器”对话框一致)。(I:23850) |
| 69940 |
对于某个特定设计,尝试从原理图文档访问约束管理器时,会出现错误“已添加具有相同键的项…”,随后所有视图均变为空白且无法使用。 |
Draftsman
| 69992 |
通过按住鼠标右键并拖动来平移基于 Draftsman 的制造图纸文档(.PCBDwf、.HarDwf、.MbDwf)时,新增“手形”光标,使其与原理图和 PCB 编辑器保持一致。 |
引线键合
| 66236 |
在某些情况下,在 PCB 库中以 3D 模式查看包含引线键合(裸片焊盘和键合线)的封装时,裸片焊盘与其所放置的拉伸 3D 表面之间存在明显间隙。(BC:27016) |
多板设计
| 68881 |
尝试在多板原理图中放置线束分支时,如果相关的组连接在“起点”或“终点”列中显示“无配对条目”,则会出现错误“值不能为 null。(参数 "key")”。 |
线束设计
| 71277 |
将多板设计中的更改导入线束接线图时,未考虑线束项目的“HarnessDesignator”参数值,导致比较引擎检测到错误的差异。(BC:27708) |
平台
| 71139 |
从包含不同项目组的文件夹中打开项目组(.DsnWrk)时,会在父文件夹中随机错误地创建以 GUID 字符串命名的空文件。 (BC:27759) |
| 71266 |
如果 Windows 当前系统区域设置为“韩语”,且项目路径包含韩文字符,则首次打开项目后,再次启动 Altium Designer 时不会重新打开该项目。 |
数据管理
| 70324 |
使用 BOM CoDesign 功能比较 ActiveBOM 与生成的托管 BOM(从设计生成)时,如果设计中已放置元件的名称末尾带有空白字符,该元件会被错误地显示为在“已修改的参数 - 注释”字段中存在差异。(BC:27443) |
| 70326 |
使用 BOM CoDesign 功能且 Altium Designer 的 UI 主题设为“Altium 浅灰色”时,“属性”面板中“相关 BOM”选项卡上的元素不易阅读(浅灰色背景上的白色文字)。(BC:27443) |
| 70479 |
尝试将新元件发布到已连接的工作区时,如果该元件名称的开头字符串与现有元件名称的开头相同,元件规则检查会错误地报告“名称重复的元件”错误。(BC:27448) |
| 70859 |
由 EDMS.Requirements 选项(高级设置)提供的“需求管理”功能现已随此版本正式公开发布(默认开启)。 |
| 71159 |
如果输出作业文档包含使用特殊字符串(例如 =Item)作为自定义名称的输出容器,尝试直接打开该文档或运行项目发布器时,会出现错误“未将对象引用设置到对象的实例…”。(BC:27705) |
| 71269 |
尝试通过输出作业文件为项目生成原理图打印输出的 PDF 时,如果至少有一个图纸符号设为使用本地源但未指定“文件名”,则会出现错误“发生一个或多个错误。(值不能为 null。(参数 'path1'))…”。 |
导入/导出
| 63690 |
尝试导入某个特定的 OrCAD 设计时,部分元件未被导入,因此在生成的原理图文档中缺失。(需要启用 Importer.Orcad.AdvancedEngine 高级设置选项)。 |
| 65953 |
尝试导入某个特定的 OrCAD 设计时,生成的原理图文档中多个电源端口的名称被隐藏。(需要启用 Importer.Orcad.AdvancedEngine 高级设置选项)。 |
| 66570 |
尝试导入某个特定的 OrCAD 设计时,导入会因“无效元件”错误而失败。(需要启用 Importer.Orcad.AdvancedEngine 高级设置选项)。 |
| 67943 |
新增高级设置选项“Importer.Orcad.AdvancedEngine”。启用后,通过导入向导导入 OrCAD 设计和库时,将切换为使用新的高级 OrCAD 引擎。 |
| 69318 |
尝试导入某个特定的 OrCAD 设计时,部分元件导入后缺少“Value”参数,导致在生成的原理图文档中选中此类元件时,相应的“注释”字段为空。(需要启用 Importer.Orcad.AdvancedEngine 高级设置选项)。 |
| 70109 |
导入某个特定的 OrCAD 设计时,阻焊层导入不正确,生成的顶层阻焊层包含多余的开窗,而底层阻焊层缺少部分开窗。(需要启用 Importer.Orcad.AdvancedEngine 高级设置选项)。 |
版本 26.7.1
Altium Designer Develop – Released: 8 June 2026, Version 26.7.1 (build 13)
Altium Designer Agile – Released: 8 June 2026, Version 26.7.1 (build 25)
Altium Designer – Released: 8 June 2026, Version 26.7.1 (build 11)
Altium Designer 新增功能
原理图
| 70565 |
在某些情况下,在原理图或线束接线图中暂停(Tab)交互式操作(例如放置导线或旋转选定对象)时,会出现访问冲突(位于“AdvSch.dll”模块中)。 |
PCB
| 66901 |
将 PCB 导出为 STEP 格式时,如果使用编号大于“16”的机械层作为“铣削刀具路径”层,则导出的模型中不会包含铣削刀具路径。 |
| 69812 |
在某个特定情况下,尝试从现有走线重新布线(使用交互式布线或快速布线工具,并启用“自动移除回路”选项)会导致 Altium Designer 完全卡死。 |
| 69873 |
对于某个特定设计,将 PCB 中的更改推送到源原理图时,会出现错误“字典中不存在给定键‘eModification_AddNode’”。 |
| 70031 |
启用 PCB.Polygon.AdvancedPour 选项(高级设置),并通过导入 CSV 文件为已放置的多边形覆铜添加轮廓顶点后,再添加一个顶点会导致多边形覆铜损坏。 |
| 70059 |
通过 PCB.SimbeorVersion 选项(高级设置)控制 PCB 编辑器中用于计算延迟和阻抗的 Simbeor 版本的功能,现已在此版本中正式公开(默认值为 1)。 |
| 70207 |
对于某个特定 PCB,尝试将其导出为 STEP 3D 格式(使用“文件 » 导出 » STEP 3D”)会导致 Altium Designer 陷入“无限循环”而无响应。在另一种情况下,机械层对象被错误地导出为板切口。(BC:25654) |
| 70213 |
启用 PCB.ViaInstancing 选项(高级设置)时,PCB 编辑器“视图配置”面板的“视图选项”选项卡中,“附加选项”区域的“过孔网络”和“过孔跨层”控件无法正常工作。(BC:26989) |
| 70573 |
在某些情况下,启用 PCB.ViaInstancing 选项(高级设置)后,背钻过孔会错误地直接连接到多边形覆铜平面,而忽略适用的电源平面间隙设计规则中定义的间隙。(BC:27450) |
| 70607 |
通过 PCB.ViaInstancing 选项(高级设置)提供的“过孔实例化”功能,现已在此版本中正式公开(默认启用)。 |
Draftsman
| 57465 |
在某些情况下,处理制造图纸文档(.PCBDwf/.HarDwf/.MbDwf)时,会出现错误“未将对象引用设置到对象的实例”。 |
CAMtastic
| 69776 |
尝试将某个特定 KiCad 设计生成的 ODB++ 数据导入 Altium Designer 的 CAM 编辑器(CAMtastic)时,会出现错误“指定的文件路径:<FilePath> - 不存在”,且 CAM 文档仍为空。 |
引线键合
| 69905 |
在 2D 布局模式下查看 PCB 或封装时,现在可以使用“视图配置”面板的“视图选项”选项卡中“对象可见性”区域内新增的“键合线”条目(及相关控件),控制键合线的可见性。在 3D 布局模式下查看 PCB 或封装时,键合线和裸片焊盘的可见性现在由“视图配置”面板的“视图选项”选项卡中“常规设置”区域内的“显示 3D 实体”选项一并控制。(需要启用 PCB.Wirebonding.3DImprovements 高级设置选项)。 (BC:25470) |
多板设计
| 69427 |
在某些情况下,将子线束设计工程中的更改导入多板原理图时,如果已选中线束连接,并在“属性”面板中展开其“连接”部分,则会出现错误“未将对象引用设置到对象的实例”。 |
线束设计
| 70566 |
单击接线图中的网络连线会导致出现错误“字典中不存在给定键‘eHarnessLogicalSignal’”。 |
平台
| 69822 |
新增功能:使用 Altium Designer Develop(26.7 及更高版本)时,Altium Develop 工作区的管理员可以为指定的工作区成员预留一个创作席位,使其能够在订阅有效期内离线漫游使用,同时管理员可以随时撤销该漫游席位。 |
数据管理
| 69142 |
在某些情况下,使用元件编辑器(批量元件编辑模式)编辑多个元件时,从任意可编辑单元格复制内容都会导致出现错误“控件 "" 没有父窗口...”。 |
| 69378 |
在已连接的工作区中批量编辑大量(1500 个以上)封装后(例如更改机械层分配),将其发布回该工作区会耗费很长时间,且完成后 Altium Designer 不会释放所占用的大量内存。 |
| 70220 |
通过元件编辑器(批量元件编辑模式)编辑大量元件(500 个以上)并为这些元件添加器件选型时,会出现超时错误,最终元件虽能发布,但不包含所添加的器件选型。 |
| 70315 |
启用 EDMS.CloudLoginByJWT 选项(高级设置)时,无法从 Altium Designer 内部连接到 Altium 平台上的中国工作区(通过门户 portal.altium365.com.cn)。 |
| 70849 |
在某些情况下,将 PCB 工程上线至 Altium 平台上已连接的工作区后,通过工作区的 Web Viewer 界面打开和浏览该工程时,所有源文档(ActiveBOM 除外)均不可见。 |
导入/导出
| 69921 |
导入某个特定的 Allegro 设计时,层叠中各层的厚度值不正确。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
版本 26.6.0
Altium Designer Develop – Released: 19 May 2026, Version 26.6.0 (build 14)
Altium Designer Agile – Released: 19 May 2026, Version 26.6.0 (build 21)
Altium Designer – Released: 19 May 2026, Version 26.6.0 (build 10)
Altium Designer 新增功能
原理图
| 68892 |
在某些情况下,清除原理图中某个网络的名称后(通过“属性”面板),后续的动态编译会导致出现错误“参数为 null 或空”。 |
| 69519 |
对于形状为“阶梯状”(非矩形)的覆盖区,无法通过图形编辑将其形状调整为完整矩形,因为正在移动的边无法“放下”。(BC:27250) |
| 69781 |
在特定情况下,尝试打开设计项目中的任何原理图文档时,都会遇到“对象引用未设置为对象的实例”错误。 |
PCB
| 57322 |
在特定情况下,尝试拖动某些差分对布线时,会遇到访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 61449 |
在特定情况下,使用 IPC 标准封装批量生成器为 BGA 封装生成的 STEP 模型与其 PCB 封装不匹配。 |
| 61450 |
在特定情况下,使用 IPC 标准封装向导创建 PLCC 方形封装时,“引脚跨距范围 (D)”的值未正确反映在生成的 3D STEP 模型预览中,导致芯片引脚的长边未接触焊盘。 |
| 61495 |
使用 IPC 标准封装向导创建 LCC 封装时,如果“引脚数量 (E)”与“引脚数量 (D)”不同,生成的 3D STEP 模型预览会不正确。 |
| 61496 |
使用 IPC 标准封装向导创建 CFP 封装时,最小离板高度值的更改未正确反映在生成的 3D STEP 模型预览中。 |
| 61500 |
使用 IPC 标准封装向导创建 MOLDED(有极性)或 SODFL 封装时,现在会在生成的 3D STEP 模型中 用白色条带标识极性引脚(阴极)。(I:16813、I:17014) |
| 61503 |
使用 IPC 标准封装向导创建 CAPAE 封装时,如果采用确保模型具有最坏情况尺寸的设置,生成的 3D STEP 模型会不正确。模型的圆柱体部分会穿过器件底部。(BC:7032) |
| 61538 |
使用 IPC 标准封装向导创建 SOT89 封装时,通过 Y3 参数手动定义的中心区域高度(在向导的“封装尺寸”页面中,且禁用“使用计算的封装值”选项)未正确反映在生成的封装中。 |
| 61596 |
使用 IPC 标准封装向导创建 LCC 封装时,即使已定义相关属性(“散热焊盘尺寸(D 侧)”和“散热焊盘尺寸(E 侧)”)的最小值和最大值,生成的封装中仍未创建散热焊盘。 |
| 61597 |
使用 IPC 标准封装向导创建 SOT89 封装时,生成封装中的中心焊盘被分成了两个未电气连接的对象(一个焊盘和一个铜区域),最终导致该封装放置到 PCB 中后出现封装内部间距错误。 |
| 61598 |
在某些情况下,使用 IPC 标准封装向导创建 QFN 封装时,采用计算的尺寸值会导致生成的封装中焊盘相互接触。(BC:20868) |
| 61600 |
使用 IPC 标准封装向导定义 MOLDED 封装尺寸时,新增了“引脚跨距范围 (L)”参数,可用于指定引脚外侧之间距离的最小值和最大值。尺寸示意图已更新,“本体长度范围 (L)”参数已重命名为“本体长度范围 (L1)”。(BC:2423) |
| 61601 |
使用 IPC 标准封装向导或 IPC 标准封装批量生成器生成封装时,对于自定义参数,生成的 PCB 引脚参考标记会与焊盘图元重叠。 |
| 61602 |
使用 IPC 标准封装向导生成鸥翼形封装时,向导的“封装尺寸”页面新增了控制功能,可在使用计算的封装值时选择是否修剪焊盘。此外,使用 IPC 标准封装批量生成器生成鸥翼形封装时,相关 Excel 模板文件的“数据”选项卡中“封装规格”部分新增了“PadTrimming”参数,用于控制是否修剪焊盘。 |
| 61805 |
使用 IPC 标准封装批量生成器创建 CFP 封装时,生成的 STEP 模型不正确,其宽度与所处理的 Excel 文件中指定的宽度不一致。 |
| 61806 |
在两种特定情况下,无法使用 IPC 标准封装批量生成器创建 DPAK 封装。第一种情况下,尝试添加待处理的 Excel 文件时,会遇到“无效的流格式”错误。第二种情况下,处理结束时会出现“字段 "DensityLevel" 中的数量 "" 无效”错误。(BC:23015) |
| 61807 |
使用 IPC 标准封装批量生成器创建多个密度等级的片式阵列封装时,添加的待处理 Excel 文件中的“DensityLevel”字段及手动输入的封装规格会被忽略。(BC:8328) |
| 61808 |
使用 IPC 标准封装向导创建 CHIP、CAPAE、MOLDED 或 WIRE WOUND 封装时,生成的封装名称不正确,不符合 IPC-7351B 标准的命名规范。 (BC:2613) |
| 61809 |
使用 IPC 标准封装向导创建 CHIP 封装时,生成的封装预览未按预期遵循“X”和“Y”参数值,而是错误地将 X 显示为垂直方向,将 Y 显示为水平方向。最终放置到 PCB 中时,元件封装默认旋转了 90 度(而非预期的零度旋转)。 |
| 61810 |
使用 IPC 标准封装向导创建 DFN 封装时,生成的封装预览未正确响应“本体宽度范围 (E)”和“本体长度范围 (D)”参数值的更改,两种情况下均更改了错误的尺寸。 |
| 61812 |
在特定情况下,使用 IPC 标准封装向导创建 QFN-2ROW 封装时,采用计算的尺寸值会导致焊盘间距大于“本体跨距范围 (D)”。 |
| 61814 |
使用 IPC 标准封装向导创建 SOIC 封装时,采用计算的封装尺寸值会导致生成封装中的焊盘被过度修剪,无法满足最小焊接接触量(引脚与焊盘之间)的要求。 |
| 61893 |
在特定情况下,使用 IPC 标准封装批量生成器创建 DIP 封装时,如果所处理的 Excel 文件中未指定封装名称,则封装会生成失败,而不是使用自动生成的名称生成封装。 |
| 61894 |
使用 IPC 标准封装批量生成器创建 DIP 封装时,如果添加的待处理 Excel 文件中未指定封装名称,则封装会生成失败。此外,启用“生成 STEP 模型”选项时,生成的是拉伸实体,而不是通用 3D STEP 模型。 |
| 62111 |
使用 IPC 标准封装向导生成片式阵列封装时,如果将“壳体侧面类型”设为“凹形”、“凸形 E”或“凸形 S”,则封装名称的前缀不符合 IPC-7351 B 命名规范。 |
| 62112 |
对于多种封装,当禁用“使用计算的封装值”功能并手动输入“焊盘尺寸”和“焊盘间距”的值时,IPC 合规封装向导未能正确计算元件外形边界(Courtyard)。 |
| 62254 |
更新了 IPC 合规封装向导:创建 PQFP 或 CQFP 封装时,与 SOIC、SOP、TSSOP 和 SOT 封装保持一致,基于最大尺寸值(而非标称值)构建封装轮廓。 |
| 62283 |
使用 IPC 合规封装向导创建 SOT 类型封装时,生成的封装中元件外形边界余量值不正确。 |
| 62319 |
更新了 IPC 合规封装向导:创建 PQFP 封装时,采用与 QFN 封装相同的样式和方法生成丝印轮廓。现在,丝印轮廓沿最大封装轮廓向外偏移半个丝印线宽(默认丝印线宽为 0.127 mm)。 |
| 62378 |
使用 IPC 合规封装向导创建 SOIC 封装时,生成的封装中元件外形边界余量值不正确。 |
| 62430 |
更新了 IPC 合规封装向导,确保为当前所有受支持封装类型生成的封装均符合 IPC 7351 标准 B 版《表面贴装设计和焊盘图形标准通用要求》。 |
| 62669 |
使用 IPC 合规封装向导或 IPC 合规封装批量生成器创建 BGA 封装时,焊盘直径缩减百分比(用于可塌陷焊球)不符合 IPC 7351 标准 B 版《表面贴装设计和焊盘图形标准通用要求》。 |
| 67406 |
使用 IPC 合规封装向导创建 LCC 封装并禁用“倒角形状”选项时,STEP 模型预览和生成的封装中的 3D 实体均错误地包含倒角。此外,创建 BGA 或 LGA 封装并启用“倒角形状”选项时,STEP 模型预览和生成的封装中的 3D 实体均缺少倒角。 |
| 67407 |
使用 IPC 合规封装向导创建 PQFN 封装时,STEP 模型预览和生成的封装均未包含散热焊盘的过孔。 |
| 68167 |
在层叠管理器中进行影响传播延迟的更改(例如更改某一层的介电常数 (Dk) 值)后,未重新计算走线的延迟值。(BC:26356) |
| 69594 |
通过“属性”面板修改包含圆弧的多边形对象的轮廓顶点时,圆弧端点会缺失或不正确,导致对象形状不正确。 |
| 69836 |
启用 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置)并在设计空间中选中焊盘后,“属性”面板“焊盘堆栈”区域的相应部分中缺少“中心偏移 (X/Y)”字段。 |
| 69891 |
在“PCB 规则和约束编辑器”对话框中,从新建的 Width 规则(已选择“默认层叠”)切换到 Unconnected Pin 规则的空白区域(尚未创建此类型的规则),然后再切换回来时,会出现访问冲突(位于“ADVPCB.DLL”模块中)。 |
| 69895 |
编辑放置在 PCB 中的 OLE 对象,然后保存并关闭文档后,再次尝试打开该 PCB 时,Altium Designer 会完全“卡死”。(BC:27320) |
| 70013 |
对于位号和/或注释文本已设为隐藏的元件,如果这些字符串已被编辑为多行文本,则它们会错误地显示在生成的 ODB++ 制造输出中。(BC:25162) |
约束管理器
| 64638 |
在约束管理器的“物理”视图中重命名网络类后,在原理图上复制并粘贴关联的参数集(其中定义了该网络类),仍会使用原来的网络类名称。 |
Draftsman
| 69217 |
在某些情况下,尝试将 DXF 文件导入制造图文档(.PCBDwf/.HarDwf/.MbDwf)时,会出现“未将对象引用设置到对象的实例”错误。 |
CAMtastic
| 69260 |
将 Gerber 文件导入 CAM 编辑器 (CAMtastic) 时,如果导入的文件中缺少图层颜色信息,现在会根据图层类型分配默认图层颜色。这确保了颜色的一致性,避免了之前随机分配颜色的情况。 |
| 69875 |
将 ODB++ 数据导入 CAM 编辑器 (CAMtastic) 时,如果导入的数据中缺少图层颜色信息,现在会根据图层类型分配默认图层颜色。这确保了颜色的一致性,避免了之前随机分配颜色的情况。 |
线束设计
| 69256 |
尝试比较线束布局图与其线束设计项目之间的逻辑差异时,会出现“未实现该方法或操作...”错误。 |
| 69632 |
新增了将 Harness Draftsman 文档中的连接表“拆分”为多个“页面”显示的功能,并可控制页面高度上限。(I:27127) |
| 69804 |
在接线图中更改线束元件(使用“属性”面板中的“替换元件”功能)并将更改导入布局图后,虽然设计项 ID 已正确更新,但注释和描述仍为原元件的内容。BOM 中也存在此问题。 |
平台
| 68978 |
由 System.UseWebView2 选项(高级设置)提供的“WebView2”功能在此版本中正式公开发布(默认启用)。 |
数据管理
| 69356 |
在某些情况下,将项目的 ActiveBOM 作为自由文档打开并进行操作时,会出现“未将对象引用设置到对象的实例”错误。 |
| 69382 |
如果元件模板中定义了字典参数(具有默认值,但未标记为“必填”),则在基于此模板创建或编辑元件时,无法移除该默认值。 |
| 69489 |
连接到已定义环境配置的 Altium Platform 工作区时,如果用户属于多个组(可能适用多个环境配置),则在首次选择配置并在“选择配置”对话框中启用“记住我的选择”选项后,无法更改所应用的配置。为解决此问题,新增了“连接属性”对话框,可从“首选项”的“数据管理 - 服务器”页面中该工作区的“属性”菜单访问,便于您从可用配置中快速切换要使用的配置。 |
| 69576 |
在 Altium Platform 上已连接工作区的元件模板中定义用户参数时,新增支持一种带单位的数据类型——温度系数 (ppm/°C)。 |
| 69840 |
使用库导入器导入特定库时,所有相关元件的数据手册被错误地添加到新创建的元件模板文档中(作为 ComponentLink 参数对)。 |
| 69842 |
在特定情况下,打开属于 Workspace 项目的大型 ActiveBOM 文档时,如果该项目位于已连接且启用了 SiliconExpert 功能的 Workspace 中,会遇到错误“Exception of type 'Altium.Rest.Http.RestHttpClientUnexpectedResponseException' was thrown”。 |
| 69845 |
在属于 Workspace 项目的大型 ActiveBOM 文档中操作时,如果该项目位于已连接且启用了 SiliconExpert 功能的 Workspace 中,性能会明显下降(例如单击、滚动、访问对话框和刷新时)。此外,通过“属性”面板与 ActiveBOM 文档的各种元素交互时(例如更改 BOM 集和切换参数可见性),操作也明显缓慢。 |
| 69917 |
在某些情况下,尝试显示文档历史记录(历史记录与版本控制 » 显示文档历史记录)时,Altium Designer 会“卡死”。(BC:27282) |
导入/导出
| 61517 |
导入 Allegro 库 (*.dra) 时,特定封装的正确 3D 实体高度信息(内部和外部)未被导入。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 61945 |
导入在顶层或底层定义了“Layers - Components - Dev type”子类的 Allegro 设计时,现在会在生成的 PCB 文档中创建元件层对(“DEVICE_TYPE_TOP”和“DEVICE_TYPE_BOTTOM”),以容纳这些顶层和底层中的值,且这些层默认隐藏。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 62242 |
导入特定 Allegro 设计时,生成的 PCB 文档中的“PCB 规则和约束编辑器”缺少一条特定的“网络类”到“网络类”间距设计规则。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 66324 |
导入 Allegro 设计时,在所有层上定义为布线禁布区的实心填充形状被错误地导入为多层上的区域,而不是预期的禁止布线层上的区域。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 66325 |
导入 Allegro 设计时,在顶层上定义为封装禁布区的实心填充形状被错误地导入为铜走线,而不是预期的禁布区域。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 66593 |
导入 Allegro 设计时,生成的 PCB 文档中的“PCB 规则和约束编辑器”缺少已定义的差分对布线规则,而是仅创建了一条使用错误(默认)值的规则。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 67082 |
导入 Allegro 设计时,矩形焊盘的孔形状被错误地导入为槽孔,而不是矩形孔。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 67128 |
在某些情况下,导入 Allegro 设计时,元件 3D 实体的位置不正确。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 67146 |
导入特定 Allegro 库文件 (*.dra) 时,某个元件未能正确导入。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 67177 |
新增高级设置选项“Importer.Allegro.AdvancedEngine”。启用后,可增强 Allegro 导入向导的功能,支持导入焊盘(常规形状和自定义形状,包括盖油焊盘)及过孔的焊盘栈级阻焊和锡膏掩膜(涉及扩展量计算,并包括盖油面)。 |
| 67482 |
导入 Allegro 设计时,对于设计级 CSet,会创建多条值相同但优先级不同的网络级规则(针对“Spacing”和“Same Net Spacing”),而不是单条“All-All”规则。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 67844 |
尝试导入特定 Allegro 设计时,导入器会在“Fixup polygons”阶段停滞很长时间(约 22 小时)。作为阶段性改进,该导入时间已大幅缩短(目前约为 40 分钟),但等待时间仍然较长。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 67945 |
导入在顶层或底层定义了“Layers - Components - Comp value”子类的 Allegro 设计时,现在会在生成的 PCB 文档中创建元件层对(“COMPONENT_VALUE_TOP”和“COMPONENT_VALUE_BOTTOM”),以容纳这些顶层和底层中的值,且这些层默认隐藏。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 67990 |
在某些情况下,导入 Allegro 设计时,底层丝印层上的文本被错误地导入为镜像和/或镜像并旋转的状态。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 68013 |
导入特定 Allegro 设计时,某个元件焊盘的孔形状被错误地导入为“槽孔”,而不是“圆孔”,且尺寸也不正确。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 68115 |
导入丝印上两个文本块之间包含间隔(空格字符)的 Allegro 设计时,导入器会忽略这些空格,导致这两个文本块在生成的 PCB 文档中被放置在同一原点。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 68884 |
导入特定 Allegro 设计时,丝印上的一个实心区域未被填充。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 68900 |
导入在顶层或底层定义了“Layers - Components - Tolerance”或“Layers - Components - User part”子类的 Allegro 设计时,现在会在生成的 PCB 文档中分别创建相应的元件层对(“TOLERANCE_TOP”和“TOLERANCE_BOTTOM”)以及(“PART_NUMBER_TOP”和“PART_NUMBER_BOTTOM”),以容纳这些顶层和底层中的值,且这些层默认隐藏。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
| 69672 |
尝试导入特定 Xpedition 设计库时,某些元件焊盘的阻焊层未能正确导入到生成的 PCB 库文档中。 |
| 69946 |
尝试导入特定 Allegro 设计时,层未能正确导入。(需要启用 Importer.Allegro.AdvancedEngine 高级设置选项)。 |
版本 26.5.1 - 附加更新
Altium Designer Develop – Released: 6 May 2026, Version 26.5.1 (build 12)
Altium Designer Agile – Released: 6 May 2026, Version 26.5.1 (build 30)
Altium Designer – Released: 6 May 2026, Version 26.5.1 (build 12)
Altium Designer 新增功能
PCB
| 70303 |
在启用“包含挖空区域”选项的情况下,尝试运行“从板形创建图元”命令时,会遇到访问冲突(位于模块“ADVPCB.DLL”中)。(BC:27399) |
| 70304 |
在某些情况下,在 PCB 上移动元件(带文本)时,如果启用了“元件重新布线”选项并禁用了“移动元件及相关布线”选项(位于“首选项”的“PCB 编辑器 - 交互式布线”页面),会出现访问冲突(位于模块“ADVPCB.DLL”中)。(BC:27415, BC:27416) |
| 70305 |
在特定情况下,通过输出作业文件从电路板生成 Gerber X2 数据时,会出现访问冲突(位于模块“PolygonClipper.dll”中)。(BC:27391) |
| 70306 |
将包含元件且至少定义了一个差分对的原理图推送到 PCB 后(同时启用了自动创建 Room 功能),尝试移动生成的 Room(在随后显示的对话框中启用了“无网络对象”选项)会导致访问冲突(位于模块“ADVPCB.DLL”中)。在某些情况下,会出现“运行时错误 216”,或者 Altium Designer 会完全关闭。(BC: 27413) |
| 70307 |
在某些情况下,在 PCB 上移动元件时,如果启用了“元件重新布线”选项(位于“首选项”的“PCB 编辑器 - 交互式布线”页面),尝试右键单击以“取消”操作会导致访问冲突(位于模块“ADVPCB.DLL”中)。 |
版本 26.5.0
Altium Designer Develop – Released: 8 April 2026, Version 26.5.0 (build 11)
Altium Designer Agile – Released: 8 April 2026, Version 26.5.0 (build 17)
Altium Designer – Released: 8 April 2026, Version 26.5.0 (build 11)
Altium Designer 新增功能
原理图
| 66133 |
在某些情况下,在原理图或原理图库文档中围绕图元绘制选择框(从右向左)时,部分圆弧无法被选中。(BC:27379) |
| 67140 |
新增了为引脚的位号和名称定义自定义垂直边距的功能,既可在全局级别(作为原理图首选项的一部分)设置,也可在局部级别(作为引脚属性的一部分)设置。现在,您可以完全控制这两个属性的水平 (X) 和垂直 (Y) 边距,相关位置会显示“边距 (X/Y)”字段。使用 List 面板或“查找相似对象”对话框时,可分别通过新增的“引脚位号垂直边距”和“引脚名称垂直边距”字段定义垂直边距。 |
PCB
| 66537 |
新增了配置 ODB++ 设置的功能,可通过限制生成的内容来保护知识产权。您可以决定包含哪些信号层,控制是否包含网表,以及在包含网表时是否对网络名称进行匿名化处理(替换为“Net_[1-…]”),还可以控制是否包含元件,并可移除元件属性(参数)。生成的报告文件 ([Design name].REP) 和规则文件 (odb\user\[Design name].RUL) 中的文件夹路径信息也将被移除。(I:18317) |
| 69147 |
无法更改已放置 Room 的所在层。 |
| 69371 |
在设计空间(PCB 或 PCB 库文档)中选中已放置的文本字符串后,在 Properties 面板的“文本”字段中开始输入特殊字符串(例如 .<somecharacters>)时,文本自动补全功能无法正常工作。(BC:27130) |
| 69405 |
在设计空间(PCB 或 PCB 库文档)中选中已放置的标准尺寸标注后,无法通过 Properties 面板中的“宽度”字段更改尺寸标注的线宽。 |
| 69540 |
通过 PCB.Performance.PadViaTemplate.LoadingOptimization 选项(高级设置)提供的“焊盘/过孔模板加载优化”功能现已在此版本中正式公开发布(默认启用)。 |
| 69564 |
在某些情况下,从拼板 PCB(包含嵌入式板阵列)生成测试点报告时,部分数据缺失。(BC:27003) |
| 69581 |
在交互式布线过程中,如果启用了“应用走线居中”选项(并禁用了“调整过孔”选项),放置过孔时,该过孔会错误地根据居中设置(对象到走线的间距及间距比例)继承间距,而不是依据适用的设计规则。 |
| 69635 |
在某些情况下,拖动非 45 度布线时会出现错误(位于模块“RouterEntry.dll”中)。 |
| 69681 |
在某些情况下,使用较新版本的 Altium Designer 打开包含沉孔的 PCBLib 文件时,所有柱形沉孔和锥形沉孔均会缺失。此外,添加新的沉孔、保存并重新打开库后,这些沉孔也会缺失。(BC:27221) |
| 69774 |
在某些情况下,复制粘贴矩形后,尝试更改所粘贴矩形的尺寸会导致访问冲突(位于模块“ADVPCB.DLL”中)。 |
Draftsman
| 65656 |
向 PCB 设计添加新的 Draftsman 文档,并使用已连接的工作区中的特定 Draftsman 文档模板创建该文档时,会出现错误“宽度和高度必须为非负值...”。 |
引线键合
| 65571 |
新增了高级设置选项“PCB.Wirebonding.3DImprovements”,启用后可在电路板的 3D 视图中为键合线提供增强支持。其中包括:用于定义键合线形状/轮廓的额外编辑控件(可定义覆盖颜色,便于区分与引线键合机不同工作周期关联的不同键合线“层级”);在通用 3D 实体上放置裸片焊盘和键合线的功能;将 PCB 导出为 STEP 和 Parasolid 格式时包含键合线对象;以及在元件间距检查中纳入键合线对象,以检测 3D 空间中键合线与其他(非键合线)对象之间的间距违规。在 PCB 制造图中放置板制造视图、板装配视图和元件视图时,也会考虑 PCB 设计中为键合线设置的覆盖颜色。(BC:24977, BC:25032) |
| 69457 |
在某些情况下,从已有键合线接入的指状焊盘开始交互式布线时,会从新布设的走线自动(且错误地)创建另一根键合线。 |
| 69701 |
在某些情况下,对于包含引线键合的 PCB,在键合线完成渲染之前于 3D 视图中旋转电路板,会导致访问冲突(位于模块“ADVPCB.DLL”中)。 |
平台
| 69028 |
尝试从特定首选项文件 (*.DXPPrf) 加载 “系统 - 模板”设置时,会出现错误“值不能为 null。(参数‘value’)...”。(BC:27007) |
数据管理
| 67003 |
新增了高级设置选项“UI.ModernDesignReusePanel”,启用后,在处理复用块和代码片段时将使用最新的增强版 Design Reuse 面板。 |
| 69326 |
对于包含超过 10,000 个元件的工作区,超出该数量后新增的所有元件都会显示在 Components 面板的“未分类”类别中,且计数为负数。 |
| 69385 |
Item Manager 已得到增强,可处理以下情况:Workspace 元件定义了多个封装模型,而当前分配的模型随后被重命名。“自动匹配”和“更新到最新版本”功能现在能够正确分配封装模型(名称已更改)的最新修订版。(I:10242) |
| 69424 |
新增高级设置选项“VCS.AllowLFSRepos”,启用后可恢复此前在使用 Git 版本控制时对 LFS 仓库的部分支持。警告:Altium Designer 并不完全支持使用 LFS 仓库,在某些情况下,使用此类仓库可能导致用户数据丢失。(BC:27158) |
| 69444 |
当标准用户(非管理员)没有 Workspace 中最顶层项目文件夹的访问权限时,无法发布项目子文件夹中的项目。使用 Project Releaser 发布项目会失败,并出现错误“当前用户没有足够的权限来创建路径为……的文件夹”。 |
| 69456 |
在 ActiveBOM 中,元件的器件选型列表内标记为“未使用”的方案即使被删除,仍会保留在列表中。 |
| 69476 |
对于基于文件的库中的元件,Components 面板未显示其器件选型数据。 |
| 69514 |
编辑一个或多个 Workspace 元件时,如果 Component 编辑器处于批量元件编辑模式,现在能够正确执行“正在编辑的修订版不是最新版本”元件规则检查,确保在编辑非最新修订版的元件时标记违规情况。 |
| 69531 |
通过 Components 面板浏览 PCB 库(已启用模型显示)时,“选择列”对话框中没有“描述”“高度”和“焊盘数量”列可供选择。 |
导入/导出
| 56381 |
在某些情况下,尝试导入 KiCad 设计时会出现错误“对象引用未设置为对象的实例”。 |
Power Analyzer by Keysight
| 68908 |
对特定设计运行分析后,保存并访问完整报告时会出现错误“System.MissingMethodException: 未找到方法……”。 |
SI Analyzer by Keysight
| 69664 |
在某些情况下,尝试从 SI Analyzer by Keysight 文档中分析当前 PCB 的网络时,会出现错误“字典中不存在给定的键‘SIAnalyzer.Engine.Keysight.SectionKeys.ResultSectionKeyBase’”。 (BC:26953) |
版本 26.4.1
Altium Designer Develop – Released: 19 March 2026, Version 26.4.1 (build 13)
Altium Designer Agile – Released: 19 March 2026, Version 26.4.1 (build 25)
Altium Designer – Released: 19 March 2026, Version 26.4.1 (build 12)
Altium Designer 新增功能
原理图
| 67749 |
在某些情况下,切换到 Viewer 许可证后向项目添加新的原理图文档时,会出现错误“EIntfCastError: 不支持此接口”。 |
PCB
| 61119 |
对于某个特定的大型设计,通过 View Configuration 面板打开或关闭各层的可见性时,会出现明显的延迟。 |
| 64931 |
在 Constraint Manager 和旧版“PCB 规则与约束编辑器”对话框中新增了“Z 轴间距”设计规则(在文档视图中不可用),可用于检查不同铜层上各类图元之间的最小间距。(I:922) |
| 68736 |
在高级刚柔结合板设计的叠层中删除子叠层后,这些子叠层中的覆盖膜层和阻焊层会被错误地添加到默认的主“电路板层叠”中。移除所有重复层并尝试保存后,会出现错误“电路板层叠中的覆盖膜类型层数已达到上限……”,因为同一子叠层中无法同时存在覆盖膜和阻焊层。 |
| 68820 |
将 PCB 导出为 Specctra 设计文件 (*.dsn) 时,生成的文件中未包含禁止布线区域。 |
| 68973 |
当二元设计规则使用的作用域查询表达式非常长时,无法有效使用图元之间的“适用的二元规则”检查,因为随后显示的对话框中的作用域内容难以阅读,且无法调整对话框大小或列宽。 (I:10041) |
| 68983 |
在某些情况下,启用 PCB.Polygon.AdvancedPour 和 PCB.Polygon.AdvancedDynamicPour 选项(高级设置)后,在 PCB 文档中操作时会出现访问冲突(位于“ADVPCB.DLL”模块中)。 |
| 69010 |
由 PCB.SolderMaskZeroExpansion 选项(高级设置)提供的“阻焊零扩展”功能,在此版本中正式公开发布(默认启用)。 |
| 69031 |
在 PCB 或 PCB 库中放置走线宽度较小(例如 0.01 mm)的矩形时,单击以定义其第二个锚点后,矩形的尺寸(宽度和高度)会变小。此外,仍处于放置模式时,单击已放置矩形的任意角点都会创建一个正方形。在 PCB 库中复制并粘贴矩形也会导致其尺寸变小。(BC:27033, BC:27046) |
| 69059 |
对于某个特定设计,尝试访问 Layer Stack Manager 时会出现错误“未找到层类型……”。 |
| 69121 |
使用 PCB CoDesign 功能时,如果两位用户分别对同一个多边形覆铜进行了更改(一位用户更改几何形状,另一位用户搁置该多边形覆铜),合并更改后会得到一个“无网络”的多边形覆铜。 |
| 69155 |
启用 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置)后,无法通过 Properties 面板修改所选文本框的大小。(BC:27044) |
| 69423 |
在 PCB 库中,为已放置的过孔设置任一可用的 IPC 4761 选项后,保存并重新打开该库,该设置会恢复为“无”。在另一种情况下,从焊盘过孔库添加到封装中的过孔,在保存并重新打开 PCB 库后会丢失与该库的关联。这些过孔也不会出现在 PCB Pad Via Templates 面板的“本地焊盘与过孔库”区域中。(BC:27157) |
Constraint Manager
| 63142 |
在物理视图中定义布线过孔样式规则时,除了优先使用模板定义外,现在还可以为直径和孔径指定最小值、最大值和首选值。(BC:26530) |
| 67865 |
已更新并统一 Constraint Manager 所有页面(原理图端和 PCB 端)中的对象图标,以及“导入指令”和“刷新 Constraint Manager”对话框(将原理图源文档中的指令导入 Constraint Manager 时)和 Object Class Explorer 对话框中的对象图标。 |
| 68405 |
从原理图端访问 Constraint Manager 的物理视图时,对于从原理图导入的类,其对应的展开控件(用于访问类中的对象)无法正常工作。 |
| 69384 |
从 PCB 访问“所有规则”视图后,使用 Ctrl+单击将后续规则逐一添加到选择集中,然后通过右键快捷菜单中的“移除高级规则”命令尝试移除多个选中的高级规则时,会出现“未将对象引用设置到对象的实例”错误。 |
Draftsman
| 68897 |
使用包含已放置的板装配视图的 Draftsman 文档模板 (.DwfDot),为 PCB 设计项目创建新的 Draftsman 文档 (.PCBDwf) 后,设计空间中该视图的显示未正确遵循“属性”面板中“元件显示属性”区域定义的初始设置。 |
多板设计
| 66922 |
新增高级设置选项“System.MBAEngine.UseOpenCascade”。启用后,多板装配文档 (*.MbaDoc) 的几何建模将从使用 C3D 库切换为使用 Open CASCADE 库。请注意,在此版本中打开旧版软件创建的多板装配文档时(启用此选项的情况下),已创建的配合将被移除(您可以选择保留装配零件的相对位置,或将其排列成一行)。打开时,您可以选择为该旧版文档创建备份。 |
| 68125 |
将符号包含圆弧图元的元件(例如有极性电容)放置到多板原理图上时,圆弧在设计空间中的绘制不正确。随后单击错误渲染的图形以选择该元件时,会出现“未将对象引用设置到对象的实例”错误。 |
| 68890 |
将符号包含圆弧图元的元件(例如有极性电容)放置到多板原理图上时,圆弧在设计空间中的绘制不正确。随后单击错误渲染的图形以选择该元件时,会出现“未将对象引用设置到对象的实例”错误。 |
| 69173 |
对于某个特定的多板设计项目,尝试针对多板原理图上选定的特定模块从子 PCB 项目导入时,偶尔会出现“已添加具有相同键的项...”错误。 |
线束设计
| 59289 |
在接线图中将导线拖过接线点时,会错误地复制该接线点对象。(BC:27442) |
| 64350 |
在某些情况下,为线束设计生成打印输出时,会出现访问冲突(位于模块“WorkspaceManager.DLL”中的地址 0000000139490BC8)。 |
| 68050 |
对于布局图中设置为以实体样式显示物理模型的元件,无论模型是否被选中,都会使用“选择/高亮显示”系统颜色项(位于 PCB 编辑器的“视图配置”面板中)定义的颜色。 |
平台
| 47582 |
在某些情况下,无论处于停靠模式还是浮动模式,在普通视图与紧凑视图之间切换时,“元件”和“制造商零件搜索”面板都会出现显示或尺寸问题。此外,当这些面板处于弹出模式时,再次访问它们会导致其高度突然减小。 |
| 68635 |
Wi-Fi 连接短暂中断后,Altium Designer 会完全失去响应,需要使用 Windows 任务管理器将其关闭。(BC:26379, BC:26854) |
| 68981 |
在某些情况下,尝试将所有首选项重置为默认值时,会出现访问冲突(位于模块“PCBDLGS.DLL”中)。 |
| 69364 |
启用 WSM.DotNetECOImplementation 选项(高级设置)后,尝试将子项目中的引脚交换更改导入多板原理图时,无论执行多少次 ECO,后续 ECO 中列出并处理的已检测更改都不会被应用。 |
| 69375 |
启用 WSM.DotNetECOImplementation 选项(高级设置)后,尝试比较 PCB 库文档的两个版本之间的物理差异时,会出现错误:“进程无法访问文件 "C:\Users\<UserName>\AppData\Local\Temp\Compare HierarchicalPCBObjects.Log",因为该文件正由另一进程使用...”。 |
数据管理
| 61335 |
使用 BOM 协同设计功能,尤其是使用“属性”面板“差异”部分中的“查看建议元件”命令时,如果建议的元件不是最新修订版,现在将在“元件”面板中打开该特定修订版。 |
| 63880 |
对于名称中包含两个或更多下划线字符的工作区库元件,在“元件”面板中右键单击该元件所访问的菜单中,“放置 <ComponentName>”命令条目内元件名称的第一个下划线会被错误地移除。 |
| 63966 |
访问项目相关菜单时,“历史记录与版本控制”子菜单中已重新加入“创建标签”命令。此外,输入标签值时新增了验证功能,并提供相应提示,说明仅允许使用字母、数字、点(“.”)、连字符(“-”)、井号(“#”)和下划线(“_”)。 |
| 65936 |
新增直接在 ActiveBOM 中批量更改选定元件生命周期状态的功能。请注意,此过程仅包含来自已连接工作区的元件。 |
| 68242 |
新增高级设置选项“EDMS.CloudLoginByJWT”。启用后,从 Altium Designer 连接到 Altium 平台上的工作区时,将使用 JWT(JSON Web 令牌)进行用户身份识别和身份验证。 |
| 68709 |
在已连接的工作区中更改条目的修订版状态时(通过“批量状态更改”对话框),如果输入的备注超过 255 个字符,该过程会失败。(BC:24819) |
| 68762 |
在 ActiveBOM 文档中为元件添加备选零件并刷新后,未能显示同一供应商的所有报价。 |
| 68814 |
Altium Designer 的自定义零件提供商同步和元件同步功能已得到改进,现在支持 PostgreSQL 数据库。 |
| 68961 |
新增高级设置选项“EDMS.CustomOffersMerge”。启用后,将自定义零件提供商的供应商数据与 Altium 零件提供商的数据合并(适用于 Altium 平台上已启用 BOM Portal 的工作区),从而在软件用户界面中显示供应商数据 (SPN) 的所有位置,统一呈现全部供应商信息。 |
| 68962 |
通过“共享”对话框共享实时设计或设计快照时,原先通过“高级设置”控件访问的对话框已重新设计为弹出窗口。共享实时设计时,共享和下载选项现在按“成员权限”(适用于工作区成员)和“访客和外部共享权限”(适用于已与其共享项目的外部访客用户)进行分组。 |
| 69007 |
向文档添加评论/回复时,如果先输入文本,再粘贴网页 URL,随后在该 URL 后添加空格,先前输入的文本就会被删除,发布的评论/回复中只留下 URL。(BC:26998) |
| 69149 |
从旧版 Altium Designer(26.1 之前的版本)更新到较新版本(26.1 或更高版本)后,创建新的工作区元件时,未能应用默认的工作区封装模板(通过“首选项”的“数据管理 - 模板”页面添加)。(BC:26847, BC:27173) |
| 69186 |
在处理工作区项目中的 ActiveBOM 文档时,如果该项目位于已连接且启用了 SiliconExpert 功能的工作区中,性能会明显下降。 |
| 69287 |
打开工作区项目中的大型 ActiveBOM 文档时,如果该项目位于已连接且启用了 SiliconExpert 功能的工作区中,SiliconExpert 参数无法正确填充,并且会出现超时错误。 |
| 69298 |
尝试将首选项保存到已连接的工作区,并更改用于创建新 Altium Designer 首选项条目的文件夹时,会出现错误“只能对隐藏的窗口调用 ShowDialog...”。 |
| 69430 |
对于包含 PCB 库文档的 PCB 设计项目,尝试直接通过添加到该项目中的输出作业生成 PCBLIB 打印输出的 PDF 时,会出现访问冲突(位于模块“WorkspaceManager.DLL”中)。 |
| 69447 |
在某些情况下,当项目以可编辑权限共享给不属于该项目所属工作区的用户时,该用户在处理项目并保存更改的过程中,会频繁且不定时地收到“正在尝试重新连接到通知服务”的通知。 |
导入/导出
| 68875 |
导入特定的 xDX Designer 库时,多部件元件的符号引脚编号会重复。 |
| 68896 |
尝试导入特定的 Xpedition (Expedition) 设计时,会出现访问冲突(位于模块“Importer_Expedition.IWZ”中)。 |
| 68977 |
尝试导入 OrCAD PCB 封装库 (*.LLB) 时,会出现访问冲突(位于模块“ADVPCB.DLL”中)。(BC:26983) |
版本 26.3.0
Altium Designer Develop – Released: 5 February 2026, Version 26.3.0 (build 5)
Altium Designer Agile – Released: 5 February 2026, Version 26.3.0 (build 18)
Altium Designer – Released: 5 February 2026, Version 26.3.0 (build 6)
Altium Designer 新增功能
PCB
| 66876 |
使用 3D 实体时,新增对 SOLIDWORKS 2024 和 2025 模型 (*.SldPrt) 的支持。此外,将 PCB 导出为 Parasolid 文件格式时,现在使用 Parasolid 35.1 版。 |
| 67334 |
将特定 PCB 导出为 Parasolid 格式后,在 SOLIDWORKS 中打开导出的文件时,部分元件的 3D 模型无法转换,并出现错误“此文件中的数据可能无效”。(BC:25813) |
| 68348 |
在某些情况下,启用 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置)后,将层叠表放置到设计空间中时,会出现错误“对象已被销毁后仍被访问...”。 |
| 68359 |
在某些情况下,交互式布线期间使用回路移除功能时,会出现错误(位于模块“RouterEntry.dll”或“ADVPCB.DLL”中)。 |
| 68901 |
启用 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置)后,在 PCB 库文档中多次添加/移除铣刀路径层(或打开已执行过此操作的 PCB 库文档)时,会出现错误“调用的目标引发了异常...”。(BC:26959) |
| 68942 |
在特定情况下,尝试在更改后保存 PCB 文档时,会出现访问冲突(位于模块“ADVPCB.DLL”中)。 |
| 68945 |
在“PCB 规则和约束编辑器”对话框中定义制造/装配测试点样式规则时,对最小/最大尺寸约束所做的更改无法保存。(BC:26969) |
| 69025 |
对于特定的 PCB 文档,启用“元件重新布线”选项(位于“首选项”的“PCB 编辑器 - 交互式布线”页面)后,移动任意元件都会出现错误“对象已被销毁后仍被访问...”。(BC:27027) |
多板设计
| 68356 |
尝试在多板原理图中映射线束直通连接器之间的引脚时,Altium Designer 会完全卡死,并且无法通过 Windows 任务管理器终止。(BC:26806) |
线束设计
| 67903 |
增强了“从库更新”功能,现在还包括导线、孔位元件和关联零件(从接线图访问时),以及包覆物、标签和关联零件(从布局图访问时)。请注意,要在更新中包含上述对象,分配给该对象的元件必须包含指向原理图符号的链接。 (BC:27779) |
| 68314 |
接线图中定义的跳线现在能够在关联的布局图中得到正确处理。在布局图中选中线束束段后,“属性”面板的“束段对象”区域现在会包含起点和终点位于同一连接点的此类跳线,并将其作为该束段的一部分。此类导线只能手动定义长度。输入的数值随后会包含在线束项目的 ActiveBOM 文档和制造图纸(BOM 表和接线列表)中。 (I:23859) |
平台
| 67522 |
改进了 Altium Designer Develop 中针对以下情况显示的通知:订阅即将到期、订阅已到期(且 Altium Develop 工作区处于只读模式),以及没有可用的 Author 席位。 |
| 68634 |
安装 Altium Designer Develop 和 Altium Designer Agile 时,最终用户许可协议 (EULA) 现已替换为主服务协议 (MSA)。Altium Designer 仍使用 EULA(该协议也已更新)。 |
数据管理
| 63778 |
使用“制造商零件搜索”面板时,只有最后应用的筛选条件会在结果列表上方正确显示(名称和参数)。之前选择的筛选条件仅显示名称,缺少参数信息。 |
| 63779 |
当光标位于某些区域上方时,无法滚动“制造商零件搜索”面板的“详细信息”窗格中的内容。 |
| 66024 |
与新用户共享工作区中的条目时,该用户在“共享条目”对话框中的条目最初会错误地显示其电子邮件地址,而非其所属组织。 |
| 66242 |
在元件模板的“使用位置”视图(位于“Explorer”面板中)浏览元件时,更改一个或多个所选元件的修订状态后,视图不会自动反映这些更改。 |
| 66867 |
从 Explorer 面板放置复用块时,会出现错误“值不能为 null。(参数 'pcbSnippetGUID')...”。(BC:26812) |
| 67416 |
刷新 Components 面板后,模型的修订版状态未更新。(BC:24630) |
| 68164 |
自定义零件提供商同步功能通过自定义零件提供商同步配置文档 (*.PrtSync),将指定数据库源中的供应商数据映射到工作区供应链数据。现在,连接到托管于 Altium 365 GovCloud 的工作区时,也可以使用此功能。 |
| 68245 |
对于 ActiveBOM 中的元件,在设计中更新为使用该元件的较新修订版后,为已添加的手动解决方案指定的排名会丢失。 |
| 68247 |
使用 Library Importer 将 PCB 库文档中的封装导入已连接的工作区时,任何描述超过 256 个字符的封装都会导入失败,即使导入工具报告导入成功。 |
| 68705 |
在某些情况下,尝试发布对现有元件所做的更改(通过处于单元件编辑模式的元件编辑器)时,会出现错误“不支持此接口”。 |
| 68708 |
尝试将特定的器件选型(Texas Instruments 的 LM2940IMP-15)添加到工作区库中的任意元件时,会出现错误“值不能为 null。(参数 'source')”。 |
| 68907 |
在使用 Altium Designer 26.1 并连接到工作区的特定情况下,查看任何设计项目中已放置的评论时,上下文评论窗口以及 Comments and Tasks 面板中的用户名均显示为“匿名”,而非发表评论的人员姓名。 |
导入/导出
| 68664 |
将 PCB 导出为 Ansys EDB 格式时,无法识别以 fF(飞法)为单位指定的电容值,而是将其默认为 1nF。(BC:24118) |
版本 26.2.0
Altium Designer Develop – Released: 8 January 2026, Version 26.2.0 (build 10)
Altium Designer Agile – Released: 8 January 2026, Version 26.2.0 (build 28)
Altium Designer – Released: 8 January 2026, Version 26.2.0 (build 7)
Altium Designer 新增功能
原理图
| 65661 |
在某些情况下,尝试从活动原理图文档创建集成库(基于项目文档)时,会出现访问冲突(位于模块“IntegratedLibrary.DLL”中)。 |
| 67949 |
原理图库编辑器的符号向导中,按标识符对引脚进行字母数字排序的功能未正常工作,例如排序结果为“A1, A10, A11,...A19, A2, A20, A3, A4,...A9”,而非预期的“A1, A2, A3,...A18, A19, A20”。 |
| 67982 |
使用 Properties 面板中与 Design Item ID 字段关联的“...”控件,将基于文件的元件替换为工作区库元件时,参数未更新为工作区元件的参数。 |
PCB
| 67160 |
启用“实时高亮”选项(位于 Preferences 的 PCB Editor - Board Insight Display 页面)后,在放置过孔期间,反复切换背景中高亮显示的候选网络会导致出现错误“列表索引越界”。 |
| 67883 |
将包含高度为“0”的文本的 PCB 导出为 DXF 格式时,会出现错误“eInvalidInput”。 |
| 68177 |
在 View Configuration 面板的 Layers & Colors 选项卡中选择并删除多个元件层对条目后,这些条目仍会显示。(BC:26733) |
| 68420 |
对于某个特定设计,复制一个元件(其封装中定义了裸片焊盘、键合指焊盘和键合线)并粘贴多次后,尝试保存 PCB 文档会导致出现错误“不允许重复项...”。 |
| 68627 |
启用 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置)后,选择放置在极坐标栅格上的元件时,Properties 面板中缺少与该栅格相关的选项(范围/角度和旋转)。(BC:26858) |
| 68640 |
在某些情况下,启用 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置),并从 Properties 面板对选定的多边形覆铜多次重新铺铜后,切换到“分配网络”操作并在设计空间中单击,会导致出现错误“值不能为 null。(参数 'source')”。 |
| 68661 |
当走线宽度以 mm 为单位指定时,PCB 封装中使用的矩形的几何尺寸(宽度和高度)会因舍入误差而被错误更改。(BC:26867, BC:26885) |
PCB 协同设计
| 67921 |
在某些情况下,使用 PCB 协同设计功能时,完成比较后会出现与内存泄漏相关的错误(文件“Adv3D_GeometryMaker.pas”中的断言失败)。 |
引线键合
| 62571 |
新增支持从拼板 PCB 文档生成引线键合表报告。 |
| 63094 |
针对未布线网络违规的 DRC 检查被错误地应用于键合线。(BC:25803) |
| 66918 |
现在,以 3D 方式查看拼板 PCB 文档时,会显示键合线和裸片焊盘。 |
| 67657 |
在 PCB Rules and Constraints Editor 对话框中应用对引线键合设计规则约束的更改后,该规则显示为未保存(其名称旁带有星号),且无法导出和导入规则。(BC:25810) |
| 68042 |
现在,在构建用于筛选 PCB/PcbLib 中的对象或限定设计规则作用范围的逻辑查询表达式时,可以使用新的“IsBondwire”查询关键字(PCB 对象类型检查)。 |
多板设计
| 67619 |
当多板原理图文档中放置的自定义部件同一侧存在多个条目(代表已链接的元件)时,尝试多选这些条目并拖动,会导致出现错误“无法强制转换对象...”。(BC:26133) |
线束设计
| 61558 |
在布局图中放置线束束段时,束段现在会“跟踪”其绘制长度,并默认将该值填入 Length 字段。当设置的 Length 字段值(实际物理长度)与绘制长度不同时,束段会在其最长线段的中心显示折断符号,以指示该束段未按比例绘制 (NTS)。Properties 面板中会显示“绘制长度”,并提供新增的“添加折断符号”选项,用于控制折断符号的显示。 (I:25610) |
| 62933 |
在布局图中选择一个连接点(未分配任何对象)后,Properties 面板中 Assigned Objects 区域对应的“添加”按钮会显示为“已禁用”,直到单击该按钮。(BC:26250) |
| 65333 |
在某些情况下,与源布局图文档 (LdrDoc) 相比,放置在线束制造图文档 (HarDwf) 中的布局图视图的标签绘制顺序不正确,导致标签显示在线束束的“后面”,而不是前面。 (BC:26470) |
| 67904 |
在某些情况下,将元件(连接器)从项目的接线图导入其布局图时,虽然创建了关联的连接点,但未自动分配引脚,导致生成空的线束束对象。 |
数据管理
| 66497 |
在特定情况下,连接到某个 Altium 365 工作区时,在 Components 面板和 Properties 面板中查看某个元件时,显示的器件选型不同。 |
| 66581 |
新增了在工作区与元件数据库之间执行元件同步时保留生命周期状态的功能(适用于已获授相应操作权限的用户)。 |
| 67302 |
如果启用了“器件选型修订控制”选项(位于工作区浏览器界面的“管理 - 设置 - 元件”页面),并且未先重启 Altium Designer 就修改某个元件的器件选型列表(并将其发布为新的修订版),则该元件的器件选型列表会被覆盖。 |
| 67806 |
如果在“首选项”的“系统 - 默认位置”页面中清空“文档路径”字段或将其留空,然后重启 Altium Designer,则从已连接的工作区首次打开项目(此前没有本地副本)、修改项目并尝试将其保存回工作区时,会出现错误“无效的 URI:无法确定 URI 的格式……”。 |
| 67950 |
在 Altium Designer 的自定义器件提供商同步配置文档 (*.PrtSync) 中无法访问 Azure SQL 架构表,并出现错误“ERROR [42000] [Microsoft][ODBC Driver 18 for SQL Server][SQL Server]‘`’附近有语法错误”和“ERROR [42000] [Microsoft][ODBC Driver 18 for SQL Server][SQL Server]无法准备语句”。这是因为 Altium Designer 在查询中发送了 SQL Server/Azure SQL 不支持的反引号 (`)。 |
| 68005 |
在特定情况下,尝试从 PCB 设计项目的 ActiveBOM 生成物料清单报告时,会出现错误“无法排序,因为 IComparer.Compare() 方法返回的结果不一致……”。 |
| 68037 |
由 BOM.CoDesign 选项(高级设置)提供的“BOM 协同设计”功能现已随此版本正式公开发布(默认开启)。此外,由 BOM.CoDesign.Comparison.IncludeSupplierData 选项(高级设置)提供的“在 BOM 比较中包含/排除供应商数据”功能也已随此版本正式公开发布(默认关闭)。 |
| 68583 |
如果通过“首选项”的“数据管理 - 模板”页面添加默认工作区模板,则创建相应的新实体时不会加载该模板。(BC:26847) |
导入/导出
| 63867 |
导入某个特定的 xDX Designer 设计时,无法导入项目的库 (*.lmc),导致生成空项目。 |
| 67825 |
导入某个特定的 OrCAD 设计时,生成的原理图文档中某个元件实例所关联的封装不正确。 |
版本 26.1.1
Altium Designer Develop – Released: 3 December 2025, Version 26.1.1 (build 6)
Altium Designer Agile – Released: 3 December 2025, Version 26.1.1 (build 13)
Altium Designer – Released: 3 December 2025, Version 26.1.1 (build 7)
Altium Designer 新增功能
原理图
| 62751 |
新增高级设置选项“WSM.DotNetECOImplementation”,启用后可优化并加速 ECO 处理功能。 |
| 66529 |
双击已放置的元件时,可以正确打开 Properties 面板,并选中位号文本以便修改。但是,随后双击另一个元件时,不会选中位号文本,而是将光标置于字段开头。(BC:25802) |
| 67151 |
在某些情况下,处理原理图文档时,如果编译屏蔽区域下方的信号线束发生交叉(且已在“首选项”的“原理图 - 常规”页面启用“显示跨线”选项),会出现错误“EOleException:索引超出了数组界限”。 |
| 67186 |
在原理图库 (.SchLib) 中切换符号时,将属性加载到 Properties 面板的过程存在明显延迟。(BC:25112) |
| 67514 |
在某些情况下,在原理图中的批注之间切换时,会出现错误“窗口关闭后,无法设置 Visibility,也无法调用 Show、ShowDialog 或 WindowInteropHelper.EnsureHandle”。 |
| 67618 |
将参数名称设为在设计空间中可见后,将该参数拖动到其他位置时,参数名称会显示两次。 |
PCB
| 52067 |
当“违规叠加样式”设为“无(层颜色)”,且“缩小时的叠加行为”设为“基本图案缩放”(位于“首选项”的“PCB 编辑器 - DRC 违规显示”页面)时,打开或创建 PCB 会出现访问冲突(位于模块“ADVPCB.DLL”中)。(BC:19367) |
| 58670 |
新增选项 (PCB.Performance.PadViaTemplate.LoadingOptimization),可将未关联到外部焊盘过孔库的焊盘过孔模板存储在 PCB 文档中,从而缩短加载时间。 |
| 61493 |
新增高级设置选项 (PCB.ViaInstancing),启用后可提高构建过孔实例几何形状时的性能,同时减少内存消耗和场景构建时间。 |
| 63635 |
运行交互式命令(例如移动对象、交互式布线等)时,在设计空间中开始平移视图会出现明显延迟。 |
| 65474 |
根据 IPC-7351B 标准中有关焊盘堆叠默认值的规定,阻焊开窗尺寸通常与焊盘尺寸保持 1:1 的比例,因此,阻焊扩展规则(PCB 文档中)和规则驱动的阻焊扩展(PCB 库文档中)的默认值现已设为 0 mil(此前为 4 mil)。 |
| 65539 |
向 PCB 添加批注后,切换到 3D 视图模式,再切换为正交投影并旋转 PCB,会导致 PCB 显示异常。 |
| 65636 |
新增高级设置选项“PCB.SimbeorVersion”,用于控制计算延迟和阻抗时使用的 Simbeor 版本(Simbeor 2020.3 对应选项“0”,Simbeor 2023.1 对应选项“1”)。 |
| 65828 |
在 PCB 上选中多边形对象后,在 Properties 面板的“轮廓顶点”区域空白处右键单击并使用快捷菜单中的“粘贴”命令时,会出现错误“调用的目标引发了异常……”。 |
| 65866 |
作为 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置)的一部分,Properties 面板在使用交互式布线/差分对布线/多线布线、快速布线、交互式滑动和交互式过孔拖动功能时得到了进一步增强,以提高性能并优化属性访问,尤其适用于较大型设计。 |
| 65971 |
从 PCBLIB 向 PCB 文档放置(或复制/粘贴)对象时,未遵循层的物理顺序,导致图元被放置到 PCB 文档中的错误层上。请注意,作为此问题修复的一部分,您必须使用 Altium Designer 22.11 或更高版本重新保存 PCB 库。 |
| 66010 |
向先前受“移除未使用的焊盘形状”功能影响的焊盘布线时,DRC 无法再检测到缺失的焊环。(BC:24704) |
| 66318 |
使用 PCB 库面板中的“全选”命令(位于右键快捷菜单中)时,只有在列表中的第一个(最顶部)封装上执行该命令,才会选中列表中的所有封装。 |
| 66319 |
当热焊盘连接设置为“自动”且存在作用范围重叠的多边形连接样式规则时,设计规则检查(DRC)会错误地报告多个通过热焊盘方式连接到多边形铺铜的 SMT 焊盘存在未布线网络违规。 |
| 66678 |
在某些情况下,使用自动差分对长度调谐工具对差分对两侧进行相位匹配时,生成的锯齿形图案的实际测量齿宽与“自动调谐过程”对话框中指定的值不同。(BC:25941) |
| 66726 |
禁用 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置),并在设计空间中选择多个参数(元件位号和/或注释),或选择多个元件并在属性面板中点击进入其子项“位号”或“注释”时,属性面板中会缺少“自动定位”属性和“值”可见性控件(“眼睛”按钮)。(BC:26018) |
| 66879 |
包含长度调谐图案的网络和 xSignal 的延迟值未被计算,并在属性面板和 PCB 面板中错误地显示为 0 ps。(BC:26054) |
| 66948 |
对于通过“PCB 规则和约束编辑器”对话框定义的间距设计规则,如果其间距矩阵针对不同图元组合包含不同的值,则“适用的二元规则”对话框中的“间隙”值无法正确反映规则间距矩阵中为所选图元定义的间距值。 |
| 67027 |
在某些情况下,复制粘贴矩形后尝试更改粘贴所得矩形的尺寸,会导致出现访问冲突(位于模块“ADVPCB.DLL”中)。(BC:26086) |
| 67094 |
启用 PCB.DRC.OnlineOptimization 选项(高级设置)后,在“PCB 规则和违规”面板中对某个规则类别运行 DRC,会导致其他规则类别的违规被清除。 |
| 67123 |
将 PCB 导出为 Specctra 设计文件时,导出过程在某些情况下会明显变慢。 |
| 67161 |
在某些情况下,操作选中的多边形铺铜时,会出现“对象已销毁后仍被访问”错误。 |
| 67207 |
在 PCB 库编辑器或 PCB 编辑器中修改现有元件层对所分配的层编号时,Altium Designer 会错误地生成新的机械层。删除这些层会导致关联的层类型丢失,恢复为“不适用”。 |
| 67224 |
当优化强度设置为“弱”时,无法对采用圆角的差分对(贴靠样式 = 圆角)进行优化。(BC:26265) |
| 67238 |
由 PCB.Performance.InteractivePropertyPanel.Optimization 选项(高级设置)提供的“PCB 属性面板优化”功能,现已随此版本正式公开发布(默认开启)。 |
| 67466 |
在 PCB 文档中执行交互式操作期间进行平移(按住鼠标右键并拖动)时,新增“手形”光标。 |
| 67534 |
对于已定义覆盖膜层并将其添加到分配了挠性层叠的板区域的刚挠结合设计,将“活动层”字段(位于视图配置面板的“层与颜色”选项卡上)设置为覆盖膜层,会导致 Altium Designer 无响应。(BC:26402) |
| 67894 |
在某些情况下,在属性面板中操作时,会出现“对象引用未设置为对象的实例”错误。 |
PCB 协同设计
| 64925 |
对于某个特定的 PCB 设计,尝试运行 PCB 比较功能时,会出现“System.NullReferenceException: 对象引用未设置为对象的实例”错误。 |
| 67414 |
在某些情况下,运行比较时,会出现“对象引用未设置为对象的实例”错误。 |
约束管理器
| 64463 |
在“间距”视图中引入了“类筛选”功能。此功能支持构建类的筛选器(或分组),以便在间距矩阵中有针对性的子集之间切换并进行操作。 |
| 65702 |
处理使用约束管理的工作区项目时,如果在本地删除项目的 constraints.xml 文件(通过 Windows 文件资源管理器),则使用“保存到服务器”控件将项目保存回工作区时,不再显示“保存到服务器”对话框。 |
| 65937 |
现在,在间距矩阵中选中多个单元格时,可以设置/编辑爬电距离值。所做的更改会通过在“所有规则”视图中创建/更新爬电距离规则体现出来(从 PCB 访问约束管理器时)。 |
| 66146 |
对于与信号线束关联的参数集,如果其指令已导入约束管理器,随后在原理图上选择该参数集对象时,会出现“调用的目标引发了异常...”错误。(BC:25707) |
| 66590 |
增强了从旧版设计规则系统迁移到约束管理器时对包含自定义查询表达式的间距规则的处理。这包括更好地处理作用范围表达式针对内层(中间层)的规则,并确保将此类规则设为高级规则(而非基本规则)。 |
| 66788 |
对于某个特定设计,尝试从原理图文档访问约束管理器时,会出现“已添加具有相同键的项...”错误,随后所有视图均变为空白。 |
| 67392 |
在约束管理器的“间距”视图中创建新的间距规则后,交互式多线布线工具在布线时未遵守最小间距边界。 |
Draftsman
| 49410 |
对于某个特定项目,使用 PCB 的更改更新 Draftsman 文档后,再选择已放置的坐标尺寸标注,会导致软件崩溃。 |
| 63602 |
编辑工作区中的 Draftsman 文档模板时,放置钻孔图视图或传输线表会导致出现“对象引用未设置为对象的实例”错误。(BC:24492) |
| 65278 |
新增支持将包含样条曲线的 DXF 文件导入制造图纸文档(.PCBDwf/.HarDwf/.MbDwf)。(需要启用 Draftsman.TeighaNet 高级设置选项)。 |
| 65704 |
新增对将 DXF 文件(R12 及更高版本)导入制造图纸文档(.PCBDwf/.HarDwf/.MbDwf)的支持。 (需要启用 Draftsman.TeighaNet 高级设置选项)。 |
引线键合
| 63827 |
在 PCB 面板的图元区域(处于元件模式且已选中元件时)和 PCB 库面板的图元区域(已选中封装时)中,键合线现在会显示为正确的类型(键合线)。选择键合线图元将在主设计空间中选中/高亮显示该键合线。此外,区域的右键菜单中现在还提供了相应的“显示键合线”选项,用于切换键合线的可见性。 |
| 63869 |
运行 DRC 并在 PCB 规则和违规面板中查看键合线的长度违规后,保存、关闭并重新打开 PCB 文档时,这些违规会意外发生变化。 |
3D-MID 设计
| 65950 |
对于选中的走线,之前可以在属性面板的长度字段中输入新值,但实际长度并不会改变。为解决此问题,长度字段现已设为不可编辑。 |
| 67570 |
新增高级设置选项 '3DLayout.DRC',启用后,可针对 3D 基板上已布设的走线,批量执行宽度、间距、长度和匹配长度规则的设计规则检查(DRC)。请注意,虽然生成的 DRC 报告会提供所有这些检查的信息,但主设计空间中仅会高亮显示间距违规。 |
多板设计
| 64949 |
新增为多板原理图中选中的线束入口定义“端接类型”的功能。可选择“连接器”、“压接端子/套管”和“导线端接”。此信息会体现在所选线束本身的属性以及所选对应模块入口的属性中。 (I:25312) |
| 67391 |
在多板原理图中使用自定义零件时,数据可能损坏,从而导致数据丢失,并根据损坏的性质和程度出现各种错误或崩溃。 |
线束设计
| 61571 |
新增通过 OutputJob 生成单个 Excel 工作簿的功能,其中包含供线束制造商使用的数据。生成的工作簿包含以下工作表:“物料清单”(用于快速报价)、“接线表”(供导线加工设备使用)、“标签”(汇总需要为线束束组打印的实体标签,供 Zebra 或其他打印机使用)和“包覆物”(汇总需要应用于线束束组的包覆物)。 (I:25365) |
| 63973 |
通过导线断点连接的线束导线,即使具有不同的设计项 ID,现在也能被识别。此外,现在会比较具有相同位号且通过同一导线断点连接的所有导线段的零件编号、注释、颜色和所有参数;如果发现任何差异,将报告新的“相连导线段中的参数不匹配”违规。同时,属性面板中将显示冲突横幅,可将所有导线段同步为使用所选导线的参数。 (I:26785) |
| 65569 |
新增在汇合点(布局图中两个或更多束组汇合的连接点)上应用/延伸包覆物的功能。此外,包覆物的起点现在取其路径最左上方的点,且该路径现在仅包含包覆物所覆盖的束组。(I:24932) |
| 66016 |
对于定义了压接孔位的线束元件,如果其零件不包含符号,且有一个或多个参数的值为空,使用“从库更新”命令会遇到错误“System.ArgumentNullException:值不能为 null。(参数 "value")”。 |
| 66323 |
对于 ActiveBOM 或制造图纸文档(*.HarDwf)的 BOM 表中的导线、电缆和包覆物条目,数量字段现在显示为“按需”。 |
| 66740 |
改进了线束制造文档中放置的接线表的引脚排序。现在,对于导线数量最多的连接器,会自动进行分组,并将其所有孔位正确分组到“起点”列中。 |
| 66741 |
在线束制造图纸文档(*.HarDwf)中放置并配置连接表或接线表后,随后复制粘贴该对象会导致列和其他已配置参数重置为默认值。 (BC:22637) |
| 67130 |
对于已定义导线位号的导线断点,将导线连接到该断点时,位号未被保留。 |
| 67214 |
锁定布局图中所选束组的长度参数后,无法再次将其解锁。(BC:26239) |
平台
| 60238 |
新增高级设置选项 'System.UseWebView2',用于在 Altium Designer 中与浏览器相关的元素(例如主页)中启用 WebView2。这样,只需更新 Windows,即可在 Altium Designer 中使用最新的网页浏览器引擎。请注意,当此选项禁用或所连接的工作区不支持 WebView2 时,将自动使用 CefSharp v.126。 |
| 65737 |
从此版本开始,Altium Designer 从 .NET 6 切换为使用 .NET 8。 |
| 65961 |
当需要通过默认 Web 浏览器登录 Altium 账户时(由“统一登录”功能触发),登录过程完成后,Altium Designer 现在会自动显示在前台并获得焦点。 |
数据管理
| 59401 |
在设计评审中添加评论时,该评论的上下文评论窗口(位于设计空间中)现在会显示指向该评审的链接(“来自 <DesignReviewName>”)。 |
| 63542 |
原理图中所选零件与项目 ActiveBOM 文档中对应行之间的交叉选择功能无法正常工作。(BC:24441) |
| 63990 |
对于某个特定元件,无法从制造商零件搜索面板或添加备选零件对话框中打开其关联的数据手册。 |
| 64571 |
在网络连接不佳的某些情况下,会出现警告“推送通知服务未正确初始化。连接超时”,且 Altium Designer 会停止响应,需要通过任务管理器终止。(BC:24707) |
| 64777 |
在制造商零件搜索面板中为某种元件类型添加新列后,必须切换到其他元件类型再切换回来,该列才会显示。 |
| 64783 |
新增使用元件同步功能及其相关的元件同步配置文档(*.CmpSync)定义和同步备选零件信息的功能。 |
| 65063 |
在使用项目发布器时,某些情况下会遇到访问冲突(位于模块 "ProjectReleaser.dll" 中)。 |
| 65126 |
在某些情况下,从 ActiveBOM 生成 BOM 报告时,添加来自源 PCB 的数据列会导致出现“方法或操作未实现”错误。 |
| 65397 |
如果连接工作区时出现问题,且无法刷新项目文档的最新 VCS 状态,现在会在“项目”面板中相应项目条目的旁边显示一个新的“刷新 VCS 状态”控件(带有相应的工具提示警告)。连接恢复后,单击该控件即可重新同步 VCS 状态并查看最新更改。 |
| 65690 |
更改已连接工作区的名称后,PCB 设计的项目文件 (*.PrjPcb) 中为变体定义的所有替代器件仍会引用旧的工作区名称。因此,变体管理器和条目管理器会错误地显示旧名称。 |
| 65696 |
新增高级设置选项“VCS.HideProjectExternalRepositoriesLinks”。启用后,将隐藏指向外部 VCS 存储库的链接(将受外部 VCS 管理的项目提供给已连接的工作区时自动创建的链接)。 |
| 66071 |
新增支持使用已定义并启用的流程工作流创建工作区项目的副本(通过“项目”面板的右键菜单)。 |
| 66123 |
在特定情况下,为“制造商器件搜索”面板中选定的器件从 SiliconExpert 获取高级器件数据时,会出现“对象引用未设置为对象的实例”错误。(BC:25701) |
| 66241 |
批量更新设计项目中所有元件的生命周期状态后,第一个元件的生命周期完全没有更新。此外,所有其他元件的新生命周期状态也要在重启软件后才会刷新显示。 |
| 66273 |
当“资源管理器”面板配置为显示 Altium Content Vault(在“高级设置”对话框中启用“Explorer.ShowContentVault”选项)时,服务器文件夹列表中将不再显示“库健康状况”条目。 |
| 66293 |
对于某个特定项目,尝试访问其历史记录会导致出现“对象引用未设置为对象的实例...”严重错误。(BC:25786) |
| 66358 |
在 ActiveBOM 中,使用“添加解决方案 » 创建/编辑制造商链接”功能,尝试将来自自定义器件提供商数据源(在已连接的 Enterprise Server 工作区中定义)的解决方案添加到元件时,会出现“拉取数据失败”错误,并导致该元件的解决方案无法显示。 |
| 66419 |
尝试使用 Smart PDF 功能将项目当前的“项目历史记录”视图导出为 PDF 时,“当前文档”选项被错误地列为可选导出目标;启用该选项后会导致访问冲突(发生于“WorkspaceManager.DLL”模块)。 |
| 66445 |
在没有创建文件夹权限的情况下,尝试在已连接的工作区中创建线束模板文档会导致崩溃。 |
| 66510 |
在特定情况下,如果某个项目文件夹未启用权限继承,但其所在的父文件夹启用了权限继承,则尝试分离该项目文件夹会导致访问冲突。 |
| 66532 |
将仅包含一个封装的当前 PCB 库保存到已连接的工作区时,随后显示的对话框标题中本应使用的单词“Planned”存在拼写错误(“Choose Planed Item Revision”)。(BC:25864) |
| 66683 |
使用数据库到工作区元件同步 (.CmpSync) 功能创建带有器件选型的元件后,在元件编辑器中编辑该元件时(无论使用单个还是批量元件编辑模式),其器件选型数据均未显示,包括描述、关联的供应商解决方案 (SPN) 和价格。 |
| 66701 |
新增功能:具有所分配操作权限的用户可在将模型发布为新修订版时保留其当前生命周期状态。 |
| 66910 |
当设计中使用某个元件的多个实例时,通过 ActiveBOM 将该元件更改为另一元件后,后续 ECO 不会将此更改应用到所有实例。(BC:26132) |
| 66964 |
在某些情况下,尝试创建新的工作区库元件(通过“文件 » 新建 » 元件”)时,会出现“EOleException: 对象引用未设置为对象的实例”错误。 |
| 66995 |
改进了“打开项目”对话框的性能:当用户有权访问大量项目时,加载已连接工作区中项目的项目文件夹视图的速度得到提升。 |
| 67009 |
由于不支持嵌套复用块,因此创建新的复用块后或编辑现有复用块时,原理图和 PCB 编辑器的菜单及活动栏中均已移除放置复用块的命令。 |
| 67074 |
在元件编辑器中编辑元件(使用单个或批量元件编辑模式)并从自定义器件提供商添加器件选型时,该器件选型的数据未显示,包括描述、关联的供应商解决方案 (SPN) 和价格。 |
| 67195 |
作为设计评审的一部分添加评论时,现在会在“评论和任务”面板的相应条目中显示指向该评审的链接(“来自 <DesignReviewName>”)。 |
| 67357 |
新增高级设置选项“BOM.CoDesign.Comparison.IncludeSupplierData”,用于控制在使用 BOM CoDesign 功能比较 ActiveBOM 与选定的受管 BOM 时,结果是否包含供应商相关数据。禁用后,“差异”部分(从项目的 ActiveBOM 文档访问“属性”面板时,位于“相关 BOM”选项卡中)以及在 Altium 平台 Web Viewer 界面中生成的比较结果均不包含供应商相关数据。 |
| 67410 |
在 Altium 平台上已连接工作区的元件模板中定义用户参数时,新增支持以下具有单位识别能力的数据类型:面积 (mm2)、巴 (bar)、比特、坎德拉 (cd)、小数、整数、焦耳 (J)、流明 (lm)、毫米 (mm)、帕斯卡 (Pa)、磅/平方英寸 (psi)、转/分钟 (rpm)、西门子 (S)、特斯拉 (T)。 |
| 67803 |
尝试从某个特定的输出作业配置文件生成 PDF 数据会导致 Altium Designer 无响应,必须使用 Windows 任务管理器将其终止。 |
| 67948 |
对于非工作区库器件,在 ActiveBOM 中为元件创建解决方案后,解决方案区域中未显示与 DigiKey 相关的 SPN。 |
导入/导出
| 57602 |
导入某个特定的层次式 KiCad 设计时,层次结构中导入的子原理图页缺少元件。 |
| 61888 |
导入 KiCad v.8 设计时,圆弧图元未导入生成的原理图文档中。 |
| 61963 |
导入 KiCad 设计时,弧形走线的导入不正确,相关圆弧的起始角度和终止角度颠倒。(BC:20658) |
| 63187 |
导入特定的 v8.x KiCad 设计时,多边形未被导入。 |
| 63467 |
导入 KiCad 设计时,PCB 文档视图(位于导入向导的“常规导入选项”页面)被裁切且无法调整,导致无法查看输出项目结构。 |
| 63776 |
导入 8.x 版本的 KiCad 设计时,网络类未被导入。 |
| 65163 |
导入 xDX Designer 设计时,现在支持在生成的原理图和原理图库文档中使用元件的替代视图模式。 |
| 65451 |
导入特定的 xDX Designer 设计时,位号导入不正确。 |
| 65907 |
导入特定的 Allegro 设计时,生成的顶层丝印层和底层丝印层中缺少封装几何图形的丝印对象。 |
| 65913 |
导入特定的 Allegro 设计时,带槽孔焊盘的形状和坐标未能正确导入生成的 Altium Designer PCB 文档。(需要启用 Importer.Allegro.ReadPadLayers 高级设置选项)。 |
| 65925 |
在某些情况下,导入 xDX Designer 设计时,图像未被导入或未显示在生成的原理图文档中。 |
| 66138 |
导入特定的 Allegro 设计时,某些元件的封装焊盘未被正确导入。 |
| 66139 |
导入特定的 Allegro 设计时,板框几何图形未被正确导入生成的 PCB 文档。 |
| 66664 |
导入 OrCAD 设计时,文本中的日文(shift_jis 字符集)和韩文(hangeul 字符集)字符未被准确导入。 |
| 66961 |
导入特定的 OrCAD 设计时,生成的原理图文档中的电源端口名称位置不正确,与其关联的符号图形重叠。 |
| 67038 |
Allegro2Altium.bat 文件已得到改进,现包含使用该文件所需的所有配置文件。此批处理文件随 Altium Designer 安装提供,用于在 Allegro 设计或库与 Altium Designer 不在同一台 PC 上时,将 Allegro 二进制文件(*.brd 或 *.dra)转换为 ASCII 格式。 |
| 67084 |
在某些情况下,导入 Allegro 设计时,丝印层上的文本导入不正确。 |
| 67101 |
导入特定的 OrCAD 设计时,某些自定义端口在生成的原理图文档中发生旋转,在视觉上未与导线连接(尽管实际上已连接到相应的网络)。 |
| 67106 |
在某些情况下,导入 OrCAD 设计时,某些元件的位号和参数在生成的原理图文档中位置不正确,彼此重叠。 |
| 67139 |
导入包含机械元件的 Allegro 设计时,如果该元件在库级别的顶层和底层丝印层上定义了相同的几何图形,底层丝印层上的文本会被错误地重复导入。 |
| 67143 |
由 Importer.Allegro.ReadPadLayers 选项(高级设置)提供的“导入详细的 Allegro 焊盘堆叠”功能现已在此版本中正式公开发布(默认启用)。 |
| 67176 |
导入特定的 OrCAD 设计时,某个元件的隐藏参数错误地显示在生成的原理图文档中。 |
| 67182 |
导入 Allegro 设计时,即使原始设计中已禁用丝印层上元件值的可见性(“Layers - Components - Comp value”子类),元件值仍会错误地显示在生成的 PCB 文档的丝印层上。 |
| 67585 |
尝试将 PCB 导出为 Protel PCB 2.8 ASCII 文件格式时,会遇到访问冲突错误“对象在销毁后被访问”(位于“ADVPCB.DLL”模块中)。 |
Power Analyzer by Keysight
| 65355 |
在分析报告中查看任意网络的详细信息时,“此网络的功耗”字段始终显示为“0 瓦”,而非实际功耗。 |
| 66130 |
提高工作温度时,计算得到的压降错误地减小,而非随之增大。(BC:20248) |