Altium Designer Documentation

Status message

Altium Designer 17.0版本现已翻译至中文 跳转至中文界面

Altium Designer 全新功能

Created: January 5, 2022 | Updated: June 23, 2022

本页详细介绍了Altium Designer 22初始版本中的改进内容,以及后续更新中添加的改进内容。除了提供一系列有助于推动现有技术的发展和成熟的改进内容外,每次更新也根据客户通过AltiumLive社区的BugCrunch 系统提出的反馈,在整个软件中整合大量修复和强化功能,以帮助您继续创造前沿电子技术。

您可以选择继续使用当前版本、更新您的当前版本或同时安装Altium Designer 22 与当前版本以访问最新功能。您当前的版本可以在软件里的“扩展和更新”视图中进行更新。如果您选择同时安装Altium Designer 22 与当前版本,请访问“Altium下载”页面下载安装程序,然后在安装程序的“安装模式”页面选择“全新安装”

免费试用!

如果您喜欢我们的产品但还不是我们的客户,何不选择试用Altium Designer?只需填写一张简单的表格即可免费试用Altium Designer,并可在15天内访问完整软件。没错,您可以不受技术限制,完整地体验Altium Designer,自由访问世界上最好的PCB设计产品。单击下方链接,填写表格,亲自体会为什么相较于其他可用产品更多的工程师和设计师会选择 Altium!

Altium Designer免费试用

Altium Designer 22.6

发布日期:2022年6月16日– 版本22.6.1 (build 34)

Altium Designer Version 22.6发布说明

原理图设计改进(22.6)

多功能引脚自定义名称

此功能可实现多功能引脚的自定义命名。通过原理图库文档中Properties面板的Pin模式下新的Functions字段,输入所需的自定义名称。点击Enter后,自定义(可替换)名称将显示于下图所示字段的下方。该字段没有限制,可使用数字和/或特殊字符(&、*、%等)。自定义名称的所有字体设置与原始引脚名称相同。

自定义名称将显示于原理图文档中Properties面板下Component模式中的Pins选项卡上。

此外,还可在使用Symbol Wizard创建原理图符号时,确定自定义引脚名称。当Symbol WizardDisplay Names列中输入的引脚名称包含斜杠 (‘/')时,这些名称将作为自定义引脚名称添加到生成的符号引脚上。

请注意,使用斜杠字符分隔每个引脚函数属于硬编码,因此,假如引脚名称本来就包含斜杠而不是为其创建的自定义引脚名称(如,I/O)时,您可在创建符号后通过Properties面板中的Pin模式将这些额外的引脚名称删除。

Example of a pin name with slash characters in the Symbol Wizard. Hover the cursor over the image to see the properties of the generated symbol's pin.
Symbol Wizard中的带斜杠字符引脚名称示例。将光标悬停于图像上方,可查看生成的符号引脚属性。

可通过点击带自定义名称的引脚名称,来管理原理图符号上的引脚名称显示。在打开的弹出窗口中,点选要显示于原理图符号上的函数名。如果未选择列表中的自定义引脚名称,则将显示默认名称。

请注意,带自定义名称的引脚名称采用不同于元件体色的背景色,以便在设计空间中区分此类引脚(这不会影响到原理图的打印输出)。

Example of a pop-up menu for a pin with custom pin names. Hover the cursor over the image to see this pin after selecting some custom names.
带自定义引脚名称的引脚快捷菜单示例。将光标悬停于图像上方,可在选中某些自定义名称后查看该引脚。

当放置于原理图上的元件正在从其源库中更新,且元件引脚具有仅在原理图上定义的自定义命名时,更新将不会删除自定义引脚命名。
该功能处于开放测试阶段。如果需要,可使用Advanced Settings对话框中的 Schematic.CustomNamesForMultifunctionalPins 选项将其禁用。

支持多通道项目中的备用零部件

定义多通道设计的变量时,可跨通道选择特定/不同的备用零部件。因此,不支持的多通道备用条目选项已从Project Options对话框的Error Reporting选项卡中删除。

该功能处于开放测试阶段。如果需要,可使用Advanced Settings对话框中的 Schematic.SupportForAlternatePartsInMultichannels 选项将其禁用。

文本框中标识符与网络名称的可用性

文本框中的元件标识符与网络名称作为链接放置于原理图中,并在原理图和打印的PDF文件中提供交叉探测功能。采用Properties面板中Text Frame模式下的Properties区域,通过使用Text字段中的 ‘@'定义该链接,以此访问可能的选择列表。选择需搜索的基元;此时文本框包含下方图二中所示链接。

点击该链接可放大并突出显示图纸上的基元。

该功能处于开放测试阶段。如果需要,可使用Advanced Settings对话框中的 Schematic.LiveReferencesToDesignatorsAndNetsInTextFrames 选项将其禁用。

能够处理位于原理图外部的对象

此时,可选择并移动位于原理图页面边界外的任何原理图设计对象。当选中一个对象时,可执行与原理图页面边界内的对象相同的操作与命令集。

该功能处于开放测试阶段。如果需要,可使用Advanced Settings对话框中的 Schematic.AccessibilityOfObjectsOutsideTheOutlineOfSchematicPage 选项将其禁用。

PCB 设计改进(22.6)

新增电路板属性参数选项卡

为了可快速查看当前PCB设计参数,为Properties面板中Board模式新增了一个Parameters选项卡。该选项卡同时列出了系统参数(如,PCB文件名)和从PCB计算的参数(如,PCB上的元件数量及电路板厚度)。

使用面板顶部的“过滤器”按钮可缩小参数列表的范围。在面板中选中参数时,使用列表底部的Place按钮可将参数作为特殊字符串快速放置。

The Parameters tab for the Board mode of the Properties panel provides you with comprehensive parametric information on your PCB design.
Properties面板中Board模式下的Parameters选项卡可提供有关PCB设计的全面参数信息。

增加了对健康检查监测器中Unused xSignal和From-Tos 的检查

此版本中实施的新检查属PCB Health Check Monitor功能的一部分:Unused xSignalsUnused From-Tos。如果PCB设计包括未在任何设计规则下使用的xSignals或From-Tos,则其将触发相应PCB健康检查的问题。可通过Health Check选项卡上提供的Fix Issues按钮将Unused xSignals与Unused From-Tos从设计中删除。

New Unused xSignals and Unused From-Tos PCB health checks can be used to find xSignals and From-Tos that are not used in the design rules of the PCB design.   New Unused xSignals and Unused From-Tos PCB health checks can be used to find xSignals and From-Tos that are not used in the design rules of the PCB design.
可使用全新的Unused xSignalsUnused From-Tos PCB健康检查,查找未在PCB设计的设计规则下使用的xSignals与From-Tos。

通过PCB面板的xSignalsFrom-To Editor模式可分别检查当前PCB设计的xSignals与From-Tos。

DRC性能完美提升

Advanced Settings对话框中添加了以下选项,可大大提升DRC性能。

  • 启用 PCB.EngineX.RuleSystem 选项,以使用新的DRC功能。
  • 启用 PCB.EngineX.ExpressionEngine 选项,以使用新的Expression Engine功能。
  • 启用 PCB.EngineX.ClearanceRule 选项,以使用新的Clearance Rule功能。
该功能处于开放测试阶段。如果需要,可使用Advanced Settings对话框中的相关选项对其进行访问。

数据管理改进(22.6)

增加了本地文件与提交或发布的比较

将本地保存的原理图文档与Altium 365 Workspace项目(其中这些文档属该项目的一部分)的提交或发布进行比较的功能得以实现。如需将原理图文档与所需数据集进行比较,可以从Save to Server对话框中的Compare按钮菜单、 Projects面板中的项目或项目文档右键单击菜单的History & Version Control » Compare,或Project History视图中新的Local Changes图块的控制菜单中选择该命令。

选择命令后,比较结果将显示于默认网页浏览器的新选项卡中。

An example of schematic comparison results.
原理图比较结果示例。

如需了解有关Altium 365 Workspace提供的设计数据比较功能的更多信息,请参阅Design Data Comparisons

在属性面板中增加了设计复用模式

此版本实现了Properties面板中新的Design Reuse模式。如果选定的原理图或PCB元件属于设计中复用模块的一部分,则可通过点击面板的Component模式中提供的Reuse Block链接来访问该模式。元件的父级复用模块的属性将显示于面板中。要返回至初始选定的元件属性,请使用Component链接。

Access the reuse block properties from a component that is a part of this reuse block. The images above display accessing the properties from a schematic component. Hover the cursor over the image to see access from a PCB component.
从属于此复用模块的元件中访问复用模块属性。上方图像显示从原理图元件访问属性。将光标悬停于图像上方,可查看来自PCB元件的访问。

在注释和任务面板中显示一般任务

此时,一般任务(应用于当前项目但与项目注释或文档无关的任务)显示于Comments Tasks面板中。这些任务在项目条目下单独组中的面板中列出。对于一般任务,面板中显示的内容和属性(指定人、优先级等)与常规任务相同。

General tasks are now listed in the Comments and Tasks panel.
此时,一般任务在CommentsTasks面板中列出。

电路仿真改进(22.6)

仿真示例

Shared Documents文件夹中添加了一组快速启动仿真示例(C:\Users\Public\Documents\Altium\<PlatformAndVersion>\Examples 为默认安装)。每个示例均演示了真实的仿真用例,并提供了有关仿真器设置和结果阐释的信息。

Y轴的对数形式

在Sim Data Editor中,仿真结果中的Y轴此时可以对数形式显示,其方式与之前X轴显示方式相同。使用Y Axis Setting对话框配置Y轴,使其以对数形式显示。

Altium Designer 22.6公开发布的性能

以下功能已从公测版本中取出,并在此版本中转为开放:

 

Altium Designer 22.5

发布: 2022年5月19日 – 版本 22.5.1 (内部版本号 42) 

Altium Designer 22.5 版本发布说明

原理图输入改进 (22.5)

‘查找文本’增强

您现在可以通过启用“查找文本”对话框中的“遮蔽匹配”选项,在原理图文档中进行搜索(编辑» 查找文本,Ctrl+F)时遮蔽结果。启用此选项和“跳转到结果”选项后,所有找到的元素都将缩放,而其他元素将根据首选项对话框的系统-导航页面上的设置变暗。

自定义差分对后缀

之前版本中,差分对通过添加特定的后缀来定义,即 _P(正)和 _N(负),但是,预定义的后缀对用户来说过于有限。为了提供更多的灵活性,现在您可以使用“项目选项”-“选项对话框”的“差分对”区域中的自定义后缀来定义差分对。如果仅定义了某对差分对中的一个后缀,或者在另一对自定义后缀中已经使用了后缀,则无法再添加自定义后缀。后缀不能包含空格或下划线("_")。

该功能处于开放测试阶段。如果需要,可以通过禁用高级设置对话框中启用的 Schematic.EnableCustomDiffPairNaming选项将其关闭。

PCB设计改进 (22.5)

PCB健康检查监测

PCB设计的最终目标是获得一组正确可靠的组装和制造输出,任何设计工具的目的之一是为用户提供好用的工具,在设计投入生产之前发现并解决设计过程中可能出现的问题。在不断的开发过程中,Altium Designer在每个版本中都提供了增强功能和错误修复,为您提供更好的设计体验,避免在PCB中出现“不健康”布局。在某些情况下,从Altium Designer的DRC系统角度来看,电路板的某些区域布局良好,不会导致严重的构造问题。但是,在MCAD协同设计或生成PCB输出期间,它们可能会导致软件性能下降和其他问题。例如,在Altium Designer的之前版本中,PCB组件具有360度旋转值,但在当前版本中不再允许这种情况发生,软件将此类组件设置为0度。

这些“不健康”的电路板布局元素在某些区域改进和修复之前,可能存在于软件旧版本创建的设计中。为了帮助您检测和解决此类问题,以及在某些条件下可能出现的其他一些问题,该版本引入了PCB健康检查的概念。健康检查助您发现PCB设计中的常见问题并将其修复,避免在设计和制造过程的下一阶段出现潜在问题。可用的PCB健康检查列表将继续增加。

“属性”面板的“电路板”模式(在活动PCB文档未选择对象时可用)新增“健康检查”选项卡,可用于配置、执行和浏览PCB健康检查的结果。您也可在面板的该选项卡上找到修复特定类型问题的建议。

The new Health Check tab of the Properties panel is in the Board mode.
“属性”面板新增的“健康检查”选项卡在“Board”模式下。

如需了解关于此功能的更多信息,请参阅PCB健康检查监测

该功能处于开放测试阶段。如果需要,可以通过禁用高级设置对话框中启用的 PCB.HealthCheckMonitor选项将其关闭。使用以下设置配置所需的功能模式:默认值为1。
0-关闭
1-用户模式
2-调试模式(附加检查功能正在积极开发中)。

为电路板阵列设置板形外框可见性

在属性面板的“嵌入式板阵列”模式中添加了全新“板形外框”选项。此按钮允许您控制作为所选板阵列组成部分的PCB板形外框的可见性。

Use the Board Shape button to control the visibility of the board shape. Hover the cursor over the image to see the difference between the enabled and disabled states.
使用“板形外框”按钮来控制板形外框的可见性。将鼠标指针悬停在图像上,查看启用状态和禁用状态之间的差异。

改进配置PCB打印输出的打印对话框

“打印”对话框得到增强,简化PCB设计打印页面的配置。为提高用户的易读性,部分选项从项目符号重新定位并更新至高亮显示框中。“页面”选项卡目前包括用于显示表面贴装、通孔和设计视图的打印输出属性选项,以及用于配置特定图层的显示图层区域。

制造输出的默认单位

新版本中,毫米是配置Gerber、Gerber X2、ODB++ 和 NC Drill制造输出(文件”制造输出)时的默认单位,如下图中的Gerber X2设置和NC Drill设置对话框所示。

检测无网络分配的铜基元

检查“无网络”分配的所有铜质电路层。如需运行检查,请单击“工具”-“设计规则检查”。确保“设计规则检查器”对话框的DRC报告选项页面启用“报告死铜大于”选项。(此选项的值字段适用于平面。检查所有对象,无论大小尺寸如何。)默认启用此选项。错误在消息面板和设计规则验证报告中标记为未布线网络约束。

此检查不会检测已分配网络的铜区域。

该功能处于开放测试阶段。如果需要,可以通过禁用高级设置对话框中启用的 PCB.Rules.DeadCopperNoNet选项将其关闭。使用以下设置配置所需的功能模式:默认值为2。
0-无须检查。
1-检查所有。
2-检查除空闲焊盘、文本对象和元件中的对象之外的所有对象。

数据管理改进 (22.5)

改进项目版本控制状态

“项目”面板中为文档提供的版本控制状态图标更新为活动控件,单击即可接收文档VCS状态的更多信息以及执行相关操作的访问选项。例如,单击具有本地保存修改但尚未发送至工作区的文档图标会显示本地修改的保存日期和时间,以及将项目更改保存到工作区或恢复文档的本地修改。

Click a VCS status icon in the Projects panel to show more information on the document status and access-related actions.
单击“项目”面板中的VCS状态图标,可显示有关文档状态和访问相关操作的更多信息。

添加对从外部VCS移动到ConcordPro Workspace Native VCS的支持

当连接到Concord Pro工作区时,Altium Designer现在能够将使用外部VCS系统的项目全盘迁移到全托管工作区项目,该工作区将设计文件托管在工作区的Git中央存储库。转换后的设计项目将保留以前的VCS提交历史,同时使用工作区支持VCS的本机功能,例如高级项目共享、单一身份验证和基于事件的历史时间线。

目前不支持使用带有文件协议的外部SVN存储库的项目迁移

增加“新建库”对话框

引入“新建库”对话框,改进新库的创建。从主菜单中“选择文件”»“新建”»“库”来访问对话框。该功能提供了创建新的工作区库元件、元件模板、封装或符号或创建旧一代库(基于文件或数据库类型的库)的流程。

该功能处于开放测试阶段。如果需要,可以通过禁用高级设置对话框中的UI.CreateLibraryDialog选项将其关闭。

增加编辑本地片段属性的功能

现在您可以通过“片段属性”对话框编辑本地片段的名称、描述和路径,访问设计复用面板,单击本地片段的图块(或右键单击图块上的任何位置),然后从菜单中选择“编辑属性”命令。

Edit properties of a local snippet using the Snippet Properties dialog accessed from the Design Reuse panel.
访问“设计复用”面板,使用“片段属性”对话框编辑本地片段的属性。

Altium Designer 22.5公开发布的性能

以下功能已从公测版本中移除,并在此版本中转为公开:

Altium Designer 22.4

发布: 2022年4月13日 - 版本22.4.2(内部版本号48)

Altium Designer 22.4版本发布说明

原理图输入改进

显示备用元件参数

在已编译原理图文档选项卡上查看变量时,“属性”面板将显示备用零部件属性,而非先前版本所显示的原始元件属性(备用零部件属性为只读信息)。

在原理图上为元件定义了备用零部件。选择已编译选项卡时,“属性”面板将显示当前变量的元件属性。

数据管理改进

全新设计复用功能

重复使用设计内容的功能不仅有助于节省时间,而且还使您可以创建一组经验证的电路模块,从而降低元件库存并使您的设计团队能够专注开发新概念和新产品。为了扩展现有的设计片段概念,我们在此次发布中实施了新的“复用块”。与Altium 365工作区连接后,您即可创建、使用和管理“复用块”类型的新内容,以及基于工作区的原理图和PCB片段。通过新的设计复用面板,您可以重复使用电路块以及基于工作区的片段和本地片段。

The Design Reuse panel
设计复用面板

复用块可以包含PCB的电路原理图及其物理表示。在原理图上放置复用块时,其物理表示将在ECO过程中自动放置。

能够更好支持PCB面板的全新Gerber对话框

我们已将“Gerber设置”和“Gerber X2设置”对话框替换为带有特定选项的对话框,以适应各种Gerber格式的需要。新的对话框包含两个输出命名选项(分别是带唯一扩展名的PCB文件名和带通用扩展名的唯一文件名)。

PCB面板支持

为PCB面板(嵌入式板阵列)生成Gerber 或Gerber X2输出时,新的对话框中将包含一个面板列,以及一个面板内电路板层列。使用新增的电路板层列,您可以快速验证各个电路板层是否映射到正确的面板层。

了解更多关于 生成Gerber制造数据

此功能处于公测阶段。如有需要,可以通过启用高级设置对话框中的 UI.Unification.GerberDialog 选项来禁用此功能。

另请注意,Gerber 设置对话框中的镜像列处于开放测试阶段。如果需要,可以使用高级设置对话框中的 UI.Unification.GerberDialog.ShowMirrorColumn 选项启用它。

库迁移器增强功能

此次发布包含对“库迁移器”的多项增强和改进。

  • 为了更好地体现工具的用途,我们已将其名称改为“库导入器”。
  • 除了现有的“库导入器”访问方式(例如,通过从主菜单中选择“文件 » 库导入器”)以及从“元件”和“Explorer”面板(参见以下部分)进行访问的新方式外,您现在还可以为高级基于文件的库对话框的“已安装”选项卡上列出的已安装库启动“库导入器”。在对话框中选择需要导入的库后,单击对话框网格部分中的“导入”控件。

    此外,您还可以在打开集成库时为集成库启动“库导入器”。

  • 您现在可以通过单击“源库”区域内的顶部附近,轻松地从“库导入器”访问“属性”面板。

  • 在此次发布中,导入过程中需要创建的新元件类别以及未分类入口,均已用 图标标记。

  • 我们已为库拆分添加了默认值。

  • 验证将检查空工作区文件夹路径、冲突系统参数和重复模型。

工作区内元件UI改进

为了更快捷地使用“工作区库”,我们在“元件”和“Explorer”面板中添加了附加控件。

在当前Altium Designer会话中首次启动元件面板时,您可以在连接到工作区后使用以下控件:

  • 使用现有元件——单击以浏览面板顶部下拉菜单中当前选中的元件类型。
  • 删除现有元件——单击以打开“删除现有元件”对话框,接着打开工作区“设置”的“数据清理”页面,然后从中选择需要删除的内容类型。
  • 导入库——单击以打开标准的Windows“打开”对话框,然后选择保存在本地或网络文件夹中的数据库或基于文件的库。打开库文件后,“库导入器”将在“简易”模式下启动,并加载选定的库。
  • 创建元件——单击以打开创建新元件对话框后,“元件编辑器”处于单元件编辑模式,并准备开始定义新的元件。

在离线模式下,面板将显示警告以及继续使用缓存元件数据或清除缓存的控件。

创建新元件。现在,您也可以从“元件”面板菜单中启动现有库导入以及库清理。

Explorer面板中,当“元件”类型文件夹中尚无元件时,面板将显示一些控件以帮助您使用元件填充文件夹。使用此类控件执行适宜的操作:

  • 导入库——单击以打开标准的Windows“打开”对话框,然后选择保存在本地或网络文件夹中的数据库或基于文件的库。打开库文件后,“库导入器”将在“简易”模式下启动,并加载选定库。
  • 创建元件——单击以打开处于单元件编辑模式下的“元件编辑器”并准备开始定义新的元件。
  • 创建其他条目类型——单击以打开创建新条目对话框并创建任何类型的新条目。

无论文件夹中是否有元件,您均可使用与面板右上角的“添加元件”下拉菜单关联的菜单选项来执行上述操作。

Draftsman改进

为钻孔图视图和钻孔表设置不同钻孔符号大小

在先前版本中,“钻孔图视图”与“钻孔表”的钻孔符号大小相互关联。在此次发布中,您可以在“钻孔图视图”和“钻孔表”上设置不同的钻孔符号大小。您可以在“优选设置”对话框的“Draftsman——默认值”页面的钻孔符号选项卡上,或在钻孔符号配置对话框中为特定项目设置所需的默认符号大小,具体如下图所示。使用“符号大小表”和“符号大小视图”字段设置钻孔符号大小。如需为“钻孔图视图”和“钻孔表”设置不同的符号大小,请单击以删除两者的链接,然后分别为两者单独设置所需的符号大小。

新增IPC-4761过孔类型选项

我们在属性面板的过孔类型模式中添加了一个新选项。通过该选项,您可以选择从哪一侧进行覆盖。面板“属性”区域内的“侧面”选项包括一个下拉菜单,以便您可以选择所需的侧面。下拉菜单的选项取决于面板同一区域内的“过孔类型”选项中选定的过孔类型。

对于过孔类型1A、2A、3A、4A和6A,从“顶部”或“底部”中选择。对于过孔类型1B、2B、3B、4B、5、6b和7,选项本质上被禁用;“两侧”是唯一选项,并且也是此类过孔类型的默认选项。

电路仿真改进

新增基于.CSV文件的激励信号类型

电路模拟器现在支持使用CSV文件为插值VPWL和IPWL电压和电流源指定时间数值对。将“源激励信号类型”设置为“文件”,然后在“文件”参数中指定路径+文件名(例如,C:\Designs\Circuit Simulation\Analog Amplifier\PWL_test.csv)。

Altium Designer 22.4版中完全公开的功能

以下功能已退出公测,并在此次发布中对外开放:

 

 

Altium Designer 22.3

发布:2022年3月16日——版本22.3.1(内部版本号43)

Altium Designer 22.3版发布说明

原理图输入改进

通用元件

当连接到Altium 365 Workspace时,请注意标准订阅计划不支持通用元件功能。此功能在此级别的Altium 365访问中不可用。

另请注意,连接到Concord Pro工作区时不支持通用元件功能。

此版本引入了标准通用元件的概念,可以快速将其放入设计中,而无需查找和选择特定的制造元件。

通用元件作为占位符使用,在设计过程的后期可以方便地用参数匹配的实际元件替换。它们也可以被视为虚拟或参数元件。

如需了解有关使用通用元件的更多信息,请参阅“通用元件”页面。

该功能处于开放测试阶段。如果需要,可以通过禁用高级设置对话框中的 ComponentSearch.GenericComponents 选项将其关闭。

新的SheetSymbolDesignator特殊字符串

此版本增加了新的SheetSymbolDesignator特殊字符串。此特殊字符串可以放置在子原理图图纸上,显示放置在父原理图图纸上的关联图纸符号对象的指示符。SheetSymbolDesignator特殊字符串也可用于多通道设计。选择子原理图表的编译选项卡以显示特殊字符串的转换值。

Use the SheetSymbolDesignator special string to show the parent sheet symbol's designator. Hover the cursor over the image to see the special string's converted value on the compiled tab of the sheet.
使用SheetSymbolDesignator特殊字符串来显示父图纸符号的指示符。将鼠标指针悬停在图像上,可在工作表的已编译选项卡上查看特殊字符串的转换值。

该功能处于开放测试阶段。如果需要,可以通过禁用高级设置对话框中的 Schematic.EnableSheetSymbolDesignatorAsSpecialString 选项将其关闭。

更新变体中的替代元件

“工具”»“从库更新(原理图编辑器)”和“工具”»“更新原理图(原理图库编辑器)”命令现在可用于变体中的替代元件。运行任意这些命令都会更新替代元件的参数,参数在变体管理对话框和原理图的已编译选项卡中可见。

使用原理图编辑器主菜单中的“工具”»“从库更新”命令更新备用元件时,请确保在启动后打开的“从库更新”对话框首页上启用了“包含变体”和“更新到最新版本”选项命令。

Example of an updated alternate component from the Workspace library. Shown here is the alternate component before the update. Hover the c  ursor over the image to see the component after creating a new revision and updating the component using the Update from Libraries command.
工作区库中更新的备用元件示例。此处显示的是更新前的备用元件。在创建新修订并使用“从库更新”命令更新元件后,将鼠标指针悬停在图像上以查看元件。

支持电源端口取反

现在您可以对电源端口对象、端口、网络标签和工作表条目取反(包括顶部的栏)。如果在“优选设置”对话框的“原理图 - 图像编辑”页面上启用了“Single '\' Negation”选项设置电源端口取反,在“属性”面板“电源端口”模式的“名称”字段中的每个字符后添加“\”字符(例如,V\C\C\3\),或者在网络名称的开头添加“\”字符(例如,\VCC3 ) 。

特殊字符串识别标签

为了帮助识别使用特殊字符串的文本字符串对象,特殊字符串的名称现在可以显示在原理图上。当在“优选设置”对话框的“原理图 - 图形编辑”页面中启用新增的“特殊字符串的显示名称”选项,每个特殊字符串的名称均显示为上标。

PCB设计改进

过孔堆栈编辑的增强UI

为了提高在“Top-Middle-Bottom”或“全堆栈”模式下编辑过孔堆栈时 “属性”面板“过孔”模式的可用性,面板的“过孔堆栈”部分的用户界面已更改。现在可以用表格形式查看和编辑有关PCB设计不同层上的过孔堆栈的基本信息。在层名称单元格内单击时,可启用“热风焊盘”选项。“热风焊盘”选项启用后可自定义热风焊盘。

相对于所选目标xSignal的长度调整

在特定容差范围内调整和匹配布线长度是高速设计的重要组成部分,因为它可确保时序关键信号同时到达其目标引脚。在此版本中,我们增强了指定长度匹配要求的工具,当使用xSignal类(或设计的所有 xSignal)作为规则范围时,实现了选择xSignal作为匹配长度设计规则的目标的功能。之前的行为使用xSignal类中最长的xSignal作为长度匹配的目标。

When an xSignal class is selected as a Matched Length design rule scope, one of its xSignals can be selected as a source target.
当一个xSignal类被选为“匹配长度”设计规则范围时,可选择其中的一个xSignal为源目标。

被选为目标的xSignal将在PCB面板的xSignals模式新增的“边距”栏中被标记为目标,而与该目标长度的偏差将在该栏中显示为所选类别的其他xSignal。

Deviation from the target length is shown in the new Margin column.
与目标长度的偏差显示在新增的“边距”栏中。

在交互式长度调整期间,属性面板的交互式长度调整模式提供了在相对于选定的目标xSignal(新行为)或规则范围内xSignal类中最长的网络(先前行为)之间切换的功能。

Select a desired mode for the tuning target during interactive length tuning.
在交互式长度调整期间为调整目标选择所需的模式。

如需了解有关使用xSignals的更多信息,请参阅“使用xSignals定义高速信号路径”页面。如需了解有关交互式长度调整的更多信息,请参阅“长度调整”页面。

该功能处于开放测试阶段。如果需要,可以通过禁用高级设置对话框中的 PCB.Rules.RelativeTarget 选项将其关闭。

防止修改PCB元件基元

如果PCB元件基元被锁定(“属性”面板的“元件”模式中的“基元”选项所处状态),这些基元的大多数属性将无法再通过图形(例如,使用拖放)和非图形(例如,使用属性或列表面板)编辑方法修改。这将有助于防止元件基元的突然变动而导致不正确的装配和制造输出。

例如,“属性”面板的“焊盘”模式如下图所示,该焊盘是PCB元件的组成部分,其基元已锁定。请注意,焊盘的所有属性(Net和Testpoint属性除外)均显示为灰色,不可编辑。另请注意,图标显示在焊盘“元件”字段的最右侧,表示父元件已锁定其基元,且焊盘属性无法修改。

The Pad mode of the Properties panel (on the left) for a pad of a PCB component that has its primitives locked (on the right).
The  Pad mode of the Properties panel (on the left) for a pad of a PCB component that has its primitives locked (on the right). 属性面板(左侧)的焊盘模式,用于已锁定图元(右侧)的PCB元件的焊盘。

该功能处于开放测试阶段。如果需要,可以通过禁用高级设置对话框中启用的 PCB.Component.LockPrimitives选项将其关闭。

启用此功能后,即使其变体设置为未安装,未安装元件的铜形状和阻焊层仍会显示在PCB打印输出中。

该功能处于开放测试阶段。如果需要,可以通过禁用高级设置对话框中启用的 PCB.PrintNotFittedComponents选项将其关闭。

 

数据管理改进

“保存到服务器”对话框增强

“保存到服务器”对话框中增加提示,描述如何将现有任务与项目提交相连接。“评论”字段中会显示“添加任务ID,将此提交与任务相连接”的文字。

如提示所述,将任务ID添加至“评论”字段(同任务ID显示在“评论和任务”面板);该任务将链接到在对话框中单击“确定”后将创建的项目提交。

Altium 365 Workspace浏览器界面的“任务”页面项目详细管理页面的“任务”视图中选择任务块时,提交的链接将显示在任务详细信息窗格中。单击该链接打开项目的历史视图,并在时间轴上突出显示相关的提交。

The link to the connected commit will be shown in the task detail pane. Hover the cursor over the image to see the History page that opens after clicking the link and the related commit highlighted on the timeline.
连接提交的链接将显示在任务详细信息窗格中。将鼠标指针悬停在图像上可查看单击链接后打开的“历史记录”页面以及时间轴上突出显示的相关提交。

电路仿真改进

性能提高

运行分析时,模拟过程的速度得到了提高。此外,当使用“元件”面板浏览大型仿真模型库时,上传此类库内容的速度也有所提高。

仿真模型缓存

项目中使用的仿真模型现缓存在项目中,因此可以轻松地在不同机器上运行此类项目的仿真。

Altium Designer 22.3公开发布的功能

以下功能已从公测版本中移除,并在此版本中转为公开发布:

 

Altium Designer 22.2

发布:2022年2月14日 - 版本22.2.1(内部版本号43)

Altium Designer 22.2版本发布说明

原理图输入改进

增强图表符索引功能

任何数字或数值均可作为重复图表符的首个或最后一个索引,包括 0。负数无效。最后一个索引必须始终大于首个索引。

此功能处于开放测试阶段。必要时,启用“高级设置”对话框中的Schematic.NewIndexingOfSheetSymbols 选项,即可启动该功能。

增强元件类功能

使用此新功能可添加“元件类名称”,从而通过“属性”面板的“参数设置”模式为包含在内的元件设置参数。

“元件类名称”与元件(或元件组)关联后,与当前网络类一样,与元件类及其名称和成员有关的信息将发送至PCB。

此功能处于开放测试阶段。必要时,启用“高级设置”对话框中的Schematic.ComponentClassesAndEnhancementParameterSet选项,即可启动该功能。

添加了上拉/下拉电阻器图形符号

添加了将引脚标记为包含内部上拉或下拉电阻器的功能。选择路径:“属性”面板 - “引脚”模式 - “符号”区域 - “内部”下拉菜单 - “内部上拉/下拉”。

新的图形符号将显示在引脚旁边,如下图所示。左图是新的 “内部上拉”图形符号;右图为新的“内部下拉”符号。

此功能处于开放测试阶段。必要时,启用“高级设置”对话框中的Schematic.InternalPullUpDownResistorExist选项,即可启动该功能。

计算公式并解析文本框和注释中的特殊字符串

许多设计人员使用Altium Designer中可用的特殊字符串功能来创建复杂的字符串,以显示原理图上的重要信息。现在,“文本框”和“注释”中均已添加特殊字符串支持功能,您可以将复杂的特殊字符串定义创建为单个多行文本对象。

Altium Designer支持解析文本字符串中定义的数值计算以及经扩展包括在原理图“文本框”“注释”中定义的数值计算。

当此功能最初进入封闭测试时(如上所示),特殊字符串或公式必须被置于大括号内。在此版本中,特殊字符串和公式以“=”字符开头并以空格字符结尾。


可使用“=”字符在“文本框”或“注释”中计算特殊字符串和公式。

此功能处于开放测试阶段。必要时,启用“高级设置”对话框中的Schematic.CalculateFormulasInTextFrame,即可启动该功能。

保存项目最后选择的变量

在项目关闭之前设置的最后一个变量现可保存,并将成为项目重新打开后呈现的变量。之前项目打开时始终显示的是基本设计([无变化])。

PCB设计改进

反孔改进

对先前版本中实现的“反孔”功能作出了多项改进。

  • 现在,反孔可在PCB面板“孔大小编辑器”模式和“属性”面板“钻孔表”模式中的“反孔顶部”“反孔底部”层对中进行分组。

    The Counterholes Top and Counterholes Bottom groups in the Hole Size Editor mode of the PCB panel (the first image) and in the Drill Table mode of the Properties panel (the second image).   The Counterholes Top and Counterholes Bottom groups in the Hole Size Editor mode of the PCB panel (the first image) and in the Drill Table mode of the Properties panel (the second image).
    PCB面板 “孔大小编辑器”模式(第一张图)和“属性”面板“钻孔表”模式(第二张图)中的“反孔顶部”和“反孔底部”分组。 PCB面板“孔大小编辑器”模式(第一张图)和“属性”面板“钻孔表”模式(第二张图)中的“反孔顶部”“反孔底部”分组。

    请注意:钻孔表中的其他层对不包括反孔,所谓“其他层对”包括“所有层对”(复合表)和“所有层对”(独立表)

  • 在PCB面板的“孔大小编辑器”模式和“钻孔表”中添加了新的“反孔深度”“反孔角度”

    Enabling the Counterhole Depth and Counterhole Angle columns in the Hole Size Editor mode of the PCB panel.
    在PCB面板的 “孔大小编辑器”模式中启用“反孔深度”“反孔角度”列。

    Enabling the Counterhole Depth and Counterhole Angle columns for a Drill Table from the Columns dialog.
    从“列”对话框中启用钻孔表的 “反孔深度”“反孔角度”列。

  • 对于“NC Drill”、“Gerber”、“Gerber X2”和“ODB++”输出,现可为所有顶部和底部反孔生成文件,而非为每种反孔类型生成单独的文件。

    Example of Counterholes Top and Counterholes Bottom file options in the Gerber X2 Setup and ODB++ Setup dialogs.
    “Gerber X2设置”和“ODB++设置”对话框中的“反孔顶部”和“反孔底部”文件选项示例。

  • 如果反孔的尺寸大于或等于焊盘尺寸,则焊盘形状将从PCB的相应侧移除(因为在钻孔时会钻出此焊盘形状)。

    Example of a removed pad shape from the top layer.
    从顶层移除的焊盘形状示例。

访问高级刚柔结合板模式

以前的版本对Altium Designer中的刚柔结合板设计过程作出了重大改进。改进的内容包括新增在PCB编辑器“板规划模式”下的“板区域”和“弯折线”行为以及在“层栈管理器”中引入“板”模式。此新功能集被称为“刚柔结合板2.0”。

在此版本中,从主菜单中选择“设计 » 层栈管理器”命令,打开 “层栈管理器”,然后从“工具 » 功能”子菜单或按钮菜单中选择“刚柔结合板(高级)”,即可为当前的PCB设计启用“刚柔结合板2.0”功能。

Enable the Advanced Rigid-Flex mode to configure a Rigid-Flex board; either via the Tools menu or by clicking the features button (hover the cursor over the image to show this).
启用“高级刚柔结合板”模式以配置刚柔结合板:通过 “工具”菜单或单击功能按钮(将光标悬停在图像上以显示此内容)。

从相同的菜单中选择“刚柔结合板”即可启用“刚柔结合板1.0”模式。

请注意:当尝试禁用“刚柔结合板2.0”模式或为已使用该模式的PCB切换至“刚柔结合板1.0”模式时,将打开警告对话框以进行确认。

“刚柔结合板2.0”功能处于开放测试阶段。在“高级设置”对话框中启用PCB.RigidFlex2.0和PCB.RigidFlex.SubstackPlanning选项即可访问该功能。

在“爬电距离规则”中添加了“应用到多边形铺铜”选项

“爬电距离规则”中添加了“应用到多边形铺铜”选项。启用该选项后,将根据规则测试相关多边形与其他对象之间的爬电距离。

The new Apply to Polygon Pour option of the Creepage Distance rule.
“爬电距离规则”中新增的“应用到多边形铺铜”选项。

如果多边形铺铜和其他对象受“爬电距离”设计规则约束,并且“应用到多边形铺铜”选项已启用以及“间距”设计规则适用,则在多边形铺铜时会考虑这两个规则并应用最严格的约束集。例如,如果“爬电距离”规则的约束值大于“间距”规则,则以较大值为准。

请注意:对于现有“爬电距离”设计规则,该选项被禁用。对于新创建的“爬电距离”设计规则,该选项默认启用。

数据管理改进

在“注释和任务”面板中添加了“导出注释”选项

“注释和任务”面板中添加了访问“注释导出配置”对话框选项。单击面板右上角的按钮,然后从菜单中选择“导出注释”选项,即可打开对话框并将注释导出配置为独立文档。

Accessing the Comment Export Configuration dialog from the Comments and Tasks panel.
从“注释和任务”面板访问“注释导出配置”对话框。

Draftsman改进

新增“删除前导零”选项

ASME Y14.5“尺寸标注和公差”规定,对于小于1的值,在使用英寸单位时应省略前导零(例如,“.5”与“0.5”)。在“属性”面板的“文档选项”模式中添加了“删除前导零”选项,您可以自动删除密耳和英寸单位值的前导零。该选项默认禁用。

The Remove Leading Zero option on the Document Options mode of the Properties panelThe Remove Leading Zero option on the Document Options mode of the Properties panel “属性”面板“文档选项”模式中的“删除前导零”选项

钻孔表的附加默认值

现在可以在“优选设置”对话框的“Draftsman - 默认”页面上定义Draftsman“钻孔表”对象中部分附加属性的默认值。在“基元列表”中选择“钻孔表”后,页面“钻孔符号”选项卡上可进行新的设置,包括“符号大小”“符号线样式”“分组”

Default settings for some additional options of Draftsman's Drill Table can now be defined on the Drill Symbols tab of the Preferences Draftsman - Default page.
现在可以在“优选设置”对话框的 “Draftsman - 默认”页面的“钻孔符号”选项卡上定义Draftsman“钻孔表”部分附加选项的默认设置。

导入器/导出器改进

支持从xDxDesigner项目导入设计变量

增强了xDxDesigner导入器的功能,允许导入xDxDesigner项目后自动导入其定义变量。可按照以下步骤导入xDxDesigner项目变量:

  1. 在xDxDesigner中使用“变量管理器”“报告 » 分隔文本文档” 中导出变量。
  2. 确保在“设置”对话框中将“Unplaced”定义为“Unplaced”关键字
  3. 将变量文件作为ProjectVariants.txt保存在与要导入Altium Designer的.prj项目文件相同的位置。
  4. 运行“导入向导(文件 » 导入向导”中的xDxDesigner导入,并指向xDxDesigner项目文件(.prj)——此时将自动导入设计变量。

电路仿真改进

增强了灵敏度分析

此版本进一步改进了“灵敏度分析”工具。现在支持将“全局”参数的“组偏差”以及“温度”作为敏感参数。

在“灵敏度”分析的“组偏差”选项中添加了“全局参数”选项;将光标悬停在图像上即可显示参数的定义位置。

Altium Designer 22.1

发布时间:2021年1月20日——版本22.1.2(build 22)

Altium Designer 22.1发布说明

原理图输入改进

进一步增强图纸交叉引用功能

通过向项目添加交叉引用,您可以轻松跟踪项目中原理图之间的网络连接流。在本次发布中,通过为“图纸入口”“跨页连接器”对象添加“跳转至”命令,扩展了对交叉引用的支持。

当在“项目选项”对话框的“选项”选项卡上为“图纸入口”启用交叉引用时,使用图纸入口的“图纸入口操作”右键单击菜单跳转至子原理图上的匹配端口。

Use the Jump to command to jump to the matching port.
使用“跳转至”命令跳转至匹配的端口。

对于平行式设计,当在“项目选项”对话框中为“跨页连接器”启用交叉引用时,使用跨页连接器“跨页操作”右键单击菜单跳转至相关原理图上的匹配跨页连接器。

Use the Jump to command to jump to a matching off-sheet connector.
使用“跳转至”命令跳转至匹配的跨页连接器。

PCB设计改进

嵌入式板阵列中的禁止布线可见性

放置在PCB设计中的禁止布线对象现在可以在使用PCB作为源的嵌入式板阵列中显示。当在工作区内选择嵌入式板阵列时,在“属性”面板的“层”选项卡上启用“禁止布线层”的可见性。

The Keepout layer of the source PCB can now be shown in the Embedded Board Array.
现在可以在嵌入式板阵列中显示源PCB的 “禁止布线层”。

请注意,此功能仅提供“禁止布线层”的可视化表示。目前,在嵌入式板阵列上放置的铜对象不遵守源PCB的禁止布线规则。

能够更改PCB光标颜色

在“优选设置”对话框的“PCB编辑器—常规”页面中添加了“光标颜色”选项,使您可以在PCB编辑器中更改十字准线光标的颜色。这使您可以自定义颜色以区分光标和网格等。单击与新选项关联的颜色框以打开“选择颜色”对话框,然后为光标选择所需的新颜色。

增强焊盘堆栈编辑的用户界面

已对面板的“焊盘堆栈”部分的用户界面做出变更,以便在“上中下”“全堆栈”模式下编辑焊盘堆栈时,提高“属性”面板“焊盘”模式的可用性。现在可以以表格形式查看和编辑有关PCB设计不同层上焊盘堆栈的基本信息。在层名称单元格内单击,即可使用该层的其他选项:角半径(用于矩形形状)和热焊盘(显示焊盘当前散热参数;如果启用了“散热”选项,则可以设置自定义热焊盘)。

The updated Pad Stack section of Pad properties when editing a pad stack in Top-Middle-Bottom (the first image) or Full Stack (the second image) mode with the Top layer options expanded.   The updated Pad Stack section of Pad properties when editing a pad stack in Top-Middle-Bottom (the first image) or Full Stack (the second image) mode with the Top layer options expanded.
对在 “上中下”(第一张图)或“全堆栈”(第二张图)模式下编辑焊盘堆栈时的“焊盘”属性的“焊盘堆栈”部分进行了更新,并扩展了“Top层”选项。

数据管理改进

能够在项目面板中控制元器件和网络文件夹的可见性

验证PCB设计项目后,将在“项目”面板中显示列出项目元器件和网络的“元器件和网络”文件夹。为了管理这些文件夹的可见性,在“项目”面板的“设置”弹出窗口(单击面板顶部的图标时出现)和“优选设置”对话框的“系统—项目面板”页面的“常规”部分添加了“显示元器件和网络”文件夹选项。此选项默认启用。

The Show Components and Nets folders option in the Projects panel setting pop-up.
“项目”面板设置弹出窗口中的 “显示元器件和网络” 文件夹选项。

The Show Components and Nets folders option on the System – Projects Panel page of the Preferences dialog.
“优选设置”对话框的 “系统—项目面板”页面上的“显示元器件和网络”文件夹选项。

重命名注释面板

注释面板允许您将注释添加到工作区项目的活动文档中的确定区域或点,并将这些注释分配给工作区成员(从本质上来说,这是在为他们创建任务)。为了反映这一点,该面板已重命名为“注释和任务”。此外,通过面板过滤器菜单中新增的“仅限任务”选项,您可以只显示带任务的注释。

请注意,“标准订阅计划”不支持从“注释和任务”面板创建和管理任务的功能。因此,通过该计划访问Altium 365时用户将无法使用此项功能,并且面板名称仍为“注释”。

此项功能在连接到Concord Pro工作区时亦不可用。

电路仿真改进

敏感性分析

敏感性分析提供了一种确定对电路输出特性影响最大的具体电路元器件或因素的方法。有了这些信息,您可以减少消极特性的影响,或者基于积极特性提高电路性能。敏感性分析将敏感性作为与电路元器件相关给定测量值/电路元器件模型参数的数值,以及对温度/全局参数的灵敏度计算。分析结果是每个测量类型的敏感性数值范围表。

在此次发布中,“Simulation Dashboard”的“分析设置和运行”区域中新添加了一个“敏感性”选项。启用该选项后,可以如下所示在“高级分析设置”对话框中配置“敏感性”属性。

此功能处于公测阶段。如有需要,可以通过启用“高级设置”对话框中的Simulation.Sensitivity选项来开启此功能。

Draftsman改进

全新过孔类型视图

已在Draftsman文档中添加了“过孔类型视图”对象。该对象允许根据IPC-4761标准,《印制电路板过孔结构保护设计指南》使用图解说明过孔类型。可以通过从主菜单中选择“放置»其他视图»过孔类型视图”,放置“过孔类型视图”。该视图将在文档中显示。选择视图以访问其属性。

Altium Designer 22.0

发布时间:2021年12月29日——版本22.0.2(build 36)

Altium Designer 22.0发布说明

 

欢迎使用Altium Designer 22。Altium Designer的此次更新将继续改进和增强软件的核心技术,同时还解决了客户通过AltiumLive社区的 BugCrunch系统提出的多个建议。

原理图捕获改进

图纸入口和PDF输出的交叉选择

为项目添加交叉引用后,您可以轻松地跟踪项目原理图之间的网络连接流。在新发行版本中,扩展了“图纸入口”对象交叉引用的自动创建和更新支持。

“项目选项”对话框的“选项”选项卡上启用“自动交叉引用”“图纸入口”选项。“图纸入口”将在子原理图上以图纸和相应端口对象的位置坐标为标记。

在项目选项中启用“自动交叉引用”和“图纸入口”选项,以交叉引用值来标记图纸入口。
在项目选项中启用“自动交叉引用”“图纸入口”选项,以交叉引用值来标记图纸入口。

启动图纸入口的交叉引用。
启动图纸入口的交叉引用。

“交叉引用”值也显示在“属性”面板的“图纸入口”模式中,这简化了用于选定“图纸入口”的“交叉引用”识别任务。

可以在选定图纸入口的“属性”面板中浏览“交叉引用”。
可以在选定图纸入口的“属性”面板中浏览“交叉引用”。

同时也扩展了对原理图PDF输出的交叉引用支持。如果一个对象与多个连接的对象相关(例如,一个端口连接到父原理图上的一个图纸入口和其他图纸上的端口),则单击PDF输出中的对象将显示连接对象所在的图纸列表。选择一个列表项即可打开相应的页面。

在原理图PDF输出中,可以使用弹出菜单轻松导航多个连接对象。
在原理图PDF输出中,可以使用弹出菜单轻松导航多个连接对象。

必要时,禁用“高级设置”对话框中的 Schematic.UseAutomaticCrossReferences选项可关闭该功能。

设计改进

新的“平滑与重布”面板和优选设置页面

为了帮助您更好地控制线路优化处理的过程,引入了一个新的“平滑与重布”面板,用于配置“布线 » 选定对象平滑处理”“布线 » 选定对象退回重布”命令选项。新的面板可用于设置与您当前在设计中平滑或重布的选定布线最适合的平滑处理和重布的参数。

该面板可用于控制以下“平滑参数”和“重布参数”:

  • 避开多边形——启用该选项后,在运行“选定对象平滑处理”“选定对象退回重布”命令时将避免干扰现有多边形。如果该选项被禁用(如以前版本),则现有多边形将被忽略,受影响的多边形会重新铺铜。
  • 避开Room——启用该选项后(如以前版本),在运行“选定对象平滑处理”“选定对象退回重布”命令时将避免干扰现有Room。如果在设计中对该Room定义了特定布线宽度的要求,并且需要平滑/重布的布线也不经过该Room,则启用该选项时,生成的布线也不会穿过该Room。如果该选项被禁用,则现有Room可能会有布线穿过,并且这些Room内的布线宽度将以基于Room规则的约束定义的宽度为准。

对于以下两个选项,您可以在相应规则的“最小值”、“最大值”或“首选值”之间进行选择。选择“当前值”则保持现有宽度或间距不变,也可以输入新值。

  • 设置宽度——以前,该选项始终被配置为首选项。现在,您可以在下拉菜单中选择运行“选定对象退回重布”命令时要应用的宽度。
  • 设置差分对间距——以前,该选项始终被配置为首选项。您可以在下拉菜单中选择运行“选定对象退回重布”命令时要应用的差分对间距设置。

“平滑”和“重布”设置也可以在“优选设置”对话框的新“PCB编辑器——平滑和重布”页面中配置。只要在面板或“优选设置”对话框中进行了更改,所做更改将反映在另一个对话框中。安装默认值已预设为与早期版本匹配。

这些“平滑处理和退回重布”设置适用于“选定对象平滑处理”“选定对象退回重布” 命令。交互式布线或交互式滑动期间的平滑处理行为受控于“优选设置”对话框中“PCB编辑器——交互式布线”页面上的设置(在“属性”面板的“交互式布线”“交互式滑动”模式下工作时也可以进行配置)。

IPC-4761支持增强

该最新发布版本中扩展了对“IPC-4761过孔类型”的支持。当按照IPC-4761标准在属性中设置类型的过孔被置于PCB设计中时,新的机械层和元件层对类型会自动添加到设计中,并具有相应的形状。

IPC-4761过孔类型的机械层会自动添加到设计中。“顶部盖孔层”以示例方式显示在设计空间中。
IPC-4761过孔类型的机械层会自动添加到设计中。“顶部盖孔层”以示例方式显示在设计空间中。

新的层可用于以下输出:

  • PCB打印输出
  • Gerber和Gerber X2
  • ODB++
  • IPC-2581

ODB++设置对话框在全新IPC-4761 Via Type Features层组下列有全新机械层。

ODB++设置对话框中的IPC-4761 Via Type Features层组。
ODB++设置对话框中的IPC-4761 Via Type Features层组。

此功能处于开放测试阶段。必要时,禁用“高级设置”对话框中的 “PCB.IPC4761Support”选项即可关闭它。

设计规则中标识符的自动更新

在之前的版本中,对PCB元件标识符所做的更改并没有同步更新到自定义的、标识符特定的设计规则,而是必须手动更新。当PCB元件标识符出现以下情况时,启用该新功能可更改设计规则中的相应参考:重新标注;经ECO更新;或在板上手动编辑。

此功能处于开放测试阶段,在默认情况下禁用,可通过启用“高级设置”对话框中的“PCB.Rules.UpdateQueryOnComponentDesignatorChange 选项”来访问。

焊盘进出增强

由于物理尺寸较小,进出表贴器件的布线通常密集而复杂。在以前版本的软件中,如果无法遵守SMD规则,例如,当要求“到角距离”不可用时,布线器将无法放置任何线段(如以下视频所示)。为了改进焊盘的进出行为,做出了以下改进:

  • 一旦退出焊盘,则布线将远离焊盘。软件不再允许违反SMD规则重新布线进出焊盘。
  • 如果焊盘出口被阻挡,则会忽略SMD规则(在这种情况下,该规则在焊盘进入期间已被忽略)。请注意:如果存在遵守SMD到角规则的可用焊盘出口,则使用该出口。
  • 不再违反 SMD 规则创建斜接。该软件支持 SMD 对斜接的拐角规则,允许在必要时创建零斜接。
  • 现可在“任意角度”布线模式下创建遵循SMD规则的小线段。在这种模式下,一旦放置了第一个线段,则圆弧将包含在拐角中。如果您需要在第一个拐角处形成圆弧,请在尝试创建拐角之前放置出口小线段。

此功能处于开放测试阶段。必要时,禁用“高级设置”对话框中的“PCB.Routing.EnhancedPadEntry”选项即可关闭它。

支持沉孔

层压板中的沉孔为螺钉头预留了空间。埋头孔和扩孔是两种类型的沉孔,允许使用不同类型的螺钉。新的发布版本引入了选择扩孔或埋头孔的功能。扩孔和埋头孔螺钉的主要区别在于孔的大小和形状;扩孔较宽、较方,可添加垫圈。埋头孔则在平头螺钉下侧形成一个锥形孔,与角的形状相匹配。埋头孔是切入层压板的锥形孔。它通常用于使螺钉的锥形头与层压板的顶部齐平。相比之下,扩孔是一种平底孔,其侧面是直接向下钻的,通常用于安装六角头帽或螺钉。每个焊盘仅允许有一个埋头孔或扩孔。

使用“属性”面板“焊盘”模式中的新选项可选择所需的沉孔类型。 2D焊盘周围出现一条虚线,用于定义活动层上的沉孔轮廓,如下图所示。如图所示,“顶面”和“底面”的虚线位置不同。2D、3D和Draftsman中均支持使用沉孔。

在“属性”面板“钻孔表”模式和PCB面板“孔尺寸编辑器”模式的“属性”面板模式中,沉孔显示为“层对”,如下所示。

此功能处于开放测试阶段。必要时,禁用“高级设置”对话框中的PCB.CounterHoles选项即可关闭它。

数据管理改进

为项目添加了虚拟BOM条目

如果项目中有至少一个元件,可在“项目”面板中将“虚拟”BOM条目添加到项目中。您可以打开、保存或删除BOM条目。BOM生成的基本流程不会受到虚拟BOM条目的影响。单击面板上的+Add ActiveBOM可在预览模式下打开虚拟BOM。保存新的*.BomDoc后,它将成为标准项目文档。如果无需虚拟BOM,则在“项目”面板中右键单击选择“从项目中移除”

此功能处于开放测试阶段。必要时,禁用“高级设置”对话框中的BOM.ActiveBOMDesignPreview选项即可关闭它。

显示“独立”注释

当项目文档被移除或其UniqueID已更改时,文档的注释可以变成“独立”。这些注释仍然可以从面板的“独立注释”可折叠区域访问。单击面板上的独立注释平铺窗口即可在当前打开文档的设计空间中显示注释。选择注释后单击鼠标即可恢复注释。

在“Ansys EDB导出”中添加了覆盖元件号功能

在“Ansys EDB导出选项”对话框中添加了“覆盖元件号”选项。新选项可用于指定将作为“本地元件名称”的参数,而非默认使用“注释”。启用该选项后,从关联的下拉菜单中选择所需参数即可。

仅当您安装的“Ansys EDB导出器”扩展为1.0.12.180或更高版本时,方可使用该选项。

电路仿真改进

计算和查看仿真测量结果

本发行版本的重点是在分析仿真测量结果方面做出了多项改进。除了新增测量类型外,还添加了多项基于测量的新功能,包括:

  • 新增测量类型——新的测量类型已添加到可用测量列表中。
  • 测量统计——自动进行测量统计,并将结果显示在“仿真数据”面板的下部区域。
  • 在表格中显示测量结果——单击“展开”表格链接可在SDF主窗口中显示完整的测量结果表格。可以选择表格中的数据并将其复制到电子表格中。
  • 显示直方图——直接从测量结果生成直方图,使数据分布可视化。将光标悬停在下图即可显示蒙特卡罗分析结果的直方图。
  • 从测量中导出图——生成变量对比图。例如,如果在执行参数化扫描时扫描了两个分量值,则可以绘制出对比图。
  • 在图表上显示——单击“模拟数据”面板“测量”选项卡中的按钮。测量光标将显示在图表上,突出显示已计算测量值的图表区域。
  • 添加新测量——单击“仿真数据”面板中的“添加”按钮即可打开“ 在图中添加波形”对话框,在对话框中可定义新的测量。
  • 编辑现有测量——点击“编辑”按钮可编辑当前选择的测量;无需返回到“仿真仪表盘”面板。

图表上的“显示”功能可显示已计算测量值的测量光标。将光标悬停在图像上即可显示测量结果的直方图。

此功能处于开放测试阶段。必要时,禁用“仿真”即可关闭该功能。在“高级设置”对话框中可启用“测量”选项。

Draftsman改进

添加了沉孔支持

“沉孔视图”对象已添加到Draftsman文档中。从主菜单中选择“放置 » 新增视图 » 沉孔视图”即可放置“沉孔视图”。该视图将显示在文档中。选择视图可访问并查看和编辑属性。

Altium Designer 22.0 功能现已完整公开

以下功能已退出开放测试版,并在此次发布版本中公开:

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: