SI Analyzer von Keysight
Auf einen Blick
- Erfahren Sie, welche Funktionen die Erweiterung SI Analyzer by Keysight in Altium Designer bietet und welche Arten von Signalintegritätsprüfungen sie unterstützt.
- Lernen Sie, wie Sie die Erweiterung installieren, ein SI-Analyzer-Dokument öffnen, Netze oder Netzklassen hinzufügen und vordefinierte oder benutzerdefinierte Spezifikationen zuweisen.
- Machen Sie sich mit dem grundlegenden Workflow zur Vorbereitung von Randbedingungen und Analysedaten vertraut, um anschließend die Signalintegrität Ihres Designs prüfen zu können.
Immer mehr moderne elektronische Geräte enthalten High-Speed-Leiterplattendesigns, und mit der Weiterentwicklung der Technologien steigen auch die Signalgeschwindigkeiten (17 GHz bei DDR6, 400 Gbit/s bei QSFP++ usw.). Die Sicherstellung der Signalintegrität (SI) ist ein entscheidender Schritt beim High-Speed-Design. Werden die Anforderungen des Schnittstellenentwicklers nicht erfüllt, führt dies mit hoher Wahrscheinlichkeit zu Problemen in späteren Designphasen, bei der Fertigung und im Betrieb.
Um eine Signalintegritätsanalyse direkt in der Altium Designer-Umgebung durchzuführen, steht die Lösung SI Analyzer by Keysight zur Verfügung. Der als Softwareerweiterung bereitgestellte SI Analyzer by Keysight wird direkt in Altium Designer integriert und ermöglicht eine Reihe von SI-Prüfungen nach Abschluss des Layouts, die die wichtigsten Parameter von High-Speed-Designs abdecken:
-
Impedanz
-
Verzögerung
-
Einfügedämpfung (IL)
-
Rückflussdämpfung (RL)
Zugriff auf die Funktionen des SI Analyzer by Keysight
Um auf die Funktionen des SI Analyzer by Keysight in Altium Designer zuzugreifen, muss die Softwareerweiterung SI Analyzer by Keysight installiert sein. Diese Erweiterung kann manuell installiert oder entfernt werden.
Weitere Informationen zur Verwaltung von Erweiterungen finden Sie auf der Seite Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).
Wenn die Softwareerweiterung SI Analyzer by Keysight installiert ist, können Sie:
-
Ein neues SI Analyzer by Keysight-Dokument erstellen oder ein vorhandenes öffnen.
-
Netze für eine SI-Analyse hinzufügen und konfigurieren.
-
Vorhandene SI-Analyseergebnisse prüfen.
-
Einen SI-Analysebericht erstellen.
Um jedoch eine neue SI-Analyse durchzuführen, benötigen Sie ein gültiges Abonnement für den SI Analyzer by Keysight. Andernfalls wird beim Versuch, eine SI-Analyse zu starten, der Dialog Analyze Your Nets geöffnet, in dem Sie eine kostenlose Testversion anfordern können
Starten des SI Analyzer by Keysight
Um eine Signalintegritätsanalyse zu starten, öffnen Sie das PCB-Dokument des Projekts und wählen Sie Tools » SI Analyzer by Keysight in den Hauptmenüs.
Das SI Analyzer by Keysight-Dokument (<ProjectName> [SIK]) wird geöffnet und dem Bereich Source Documents des Projekts (im Panel Projects) hinzugefügt. Das Dokument ist zunächst noch nicht gespeichert. Verwenden Sie den Befehl File » Save As aus den Hauptmenüs, um das Dokument am gewünschten Speicherort zu speichern.
Vorbereitung der Analyse
Hinzufügen der zu analysierenden Netze
Nach dem Starten des SI Analyzer by Keysight werden die PCB-Daten (im ODB++-Format) in den Solver importiert. In dieser Phase können Sie die Liste der zu analysierenden Netze festlegen und ihnen Spezifikationen zuweisen. Klicken Sie dazu auf die Schaltfläche Manage Nets oben im SI Analyzer by Keysight-Dokument oder verwenden Sie den Befehl Edit » Manage Nets aus den Hauptmenüs. Wenn das Dokument noch keine Netze enthält, steht alternativ auch die Schaltfläche Manage Nets in der Mitte des Dokuments zur Verfügung. Der Dialog Manage Nets wird geöffnet und zeigt die Liste der Netz-, Differenzpaar- und xSignal-Klassen der Leiterplatte an.
Aktivieren Sie das Kontrollkästchen für jede benötigte Klasse (oder verwenden Sie das Kontrollkästchen in der Tabellenkopfzeile, um alle Klassen auszuwählen). Klicken Sie optional auf die Zelle in der Spalte Specifications, um ein Pop-up-Fenster anzuzeigen und die gewünschten Spezifikationen auszuwählen, die die Constraints für die ausgewählte Klasse festlegen. Diese können bei Bedarf später neu definiert werden – mehr erfahren. Sie können integrierte oder benutzerdefinierte Spezifikationen auswählen (auf der Registerkarte Specifications des Pop-up-Fensters) oder die erforderlichen Constraint-Werte für eine Klasse manuell festlegen (auf der Registerkarte Custom Constraints des Pop-up-Fensters).
Weitere Informationen zur Verwaltung integrierter oder benutzerdefinierter Spezifikationen finden Sie im Abschnitt Verwalten von Spezifikationen.
Sie können auch die Liste All Nets unten im Dialog erweitern, um einzelne Netze im Design auszuwählen und ihnen Spezifikationen zuzuweisen.
Nachdem Sie im Dialog auf OK geklickt haben, werden die ausgewählten Klassen im SI Analyzer by Keysight-Dokument angezeigt. Wenn im Bereich All Nets des Dialogs Manage Nets ein Netz ausgewählt wurde, wird es im Klasseneintrag All Nets angezeigt. Erweitern Sie einen Klasseneintrag, um dessen Netze/xSignals anzuzeigen.
Erweitern Sie den Eintrag eines Netzes/xSignals oder eines differenziellen Paars, um die zugehörigen Objekte (Pads, Leiterbahnen, Bögen und Vias) im Bereich Transmission Line anzuzeigen. Bewegen Sie den Mauszeiger über die Kachel eines Objekts und klicken Sie auf das Symbol
, um per Cross-Probing zu diesem Objekt auf der Leiterplatte zu navigieren.
Um eine Klasse oder ein einzeln hinzugefügtes Netz aus dem Dokument zu entfernen, klicken Sie auf die Schaltfläche
rechts neben dem jeweiligen Eintrag.
Spezifikationen verwalten
Im Dialog Manage Specifications, den Sie über die Schaltfläche Manage Specifications oben im Dokument SI Analyzer by Keysight öffnen, können Sie sowohl integrierte als auch benutzerdefinierte Spezifikationen verwalten. Spezifikationen können anschließend einer Klasse oder einem Netz zugewiesen werden, um schnell Constraints dafür zu definieren, wie im vorherigen Abschnitt beschrieben.
-
Auf der linken Seite des Dialogs wird die Liste der aktuell definierten Spezifikationen angezeigt. Jede Spezifikation wird mit ihrem Namen und einem oder mehreren von ihr definierten Constraint-Typen aufgeführt.
- Wählen Sie eine Spezifikation in der Liste aus, um ihre Details (Name, Angabe, ob es sich um eine Spezifikation vom Typ Built-In oder User-Defined handelt, und Constraints) auf der rechten Seite des Dialogs anzuzeigen.
-
Um eine neue Spezifikation zu erstellen, klicken Sie auf die Schaltfläche Add New unten links in der Spezifikationsliste. Auf der rechten Seite des Dialogs werden daraufhin Steuerelemente zum Definieren der Spezifikation angezeigt:
-
Legen Sie den Namen des neuen Constraints im Feld Specification Name fest.
-
Wählen Sie mithilfe der Kontrollkästchen die Constraint-Typen aus, die diese Spezifikation definieren soll: Impedance, Delay, Insertion Losses (IL) und/oder Return Losses (RL).
-
Legen Sie für die aktivierten Constraint-Typen die Constraint-Werte fest. Verwenden Sie für Constraints der Typen Impedance und Delay die vorgesehenen Textfelder. Für Constraints der Typen Insertion Losses (IL) und Return Losses (RL) können Sie Grenzen hinzufügen, bearbeiten und entfernen, um einen Bereich mit unzulässigen und zulässigen Verlustwerten im gewünschten Frequenzbereich festzulegen.
-
Sobald die Spezifikation wie gewünscht definiert ist, klicken Sie oben rechts im Dialog auf die Schaltfläche Save, um sie zu erstellen, oder auf Cancel, um den Vorgang ohne Erstellung abzubrechen.
-
-
Eine neue Spezifikation kann auch durch Duplizieren einer vorhandenen Spezifikation erstellt werden, unabhängig davon, ob diese benutzerdefiniert oder integriert ist. Wählen Sie die zu duplizierende Spezifikation in der Liste aus und klicken Sie anschließend auf die Schaltfläche Duplicate unten links in der Spezifikationsliste. Eine neue Spezifikation mit der vorläufigen Bezeichnung
<OriginalSpecificationName>(Copy)und denselben Constraints wie das Original wird angelegt und auf der rechten Seite des Dialogs zur Bearbeitung angezeigt. Nehmen Sie die gewünschten Änderungen vor und klicken Sie oben auf die Schaltfläche Save, um die Spezifikation zu erstellen, oder auf Cancel, um den Vorgang ohne Erstellung abzubrechen. -
Um eine benutzerdefinierte Spezifikation zu bearbeiten, wählen Sie sie in der Liste aus und klicken Sie auf die Schaltfläche
auf der rechten Seite des Dialogs. Nehmen Sie die gewünschten Änderungen vor und klicken Sie oben auf die Schaltfläche Save, um die Änderungen zu speichern, oder auf Cancel, um den Vorgang ohne Übernahme der Änderungen abzubrechen.
-
Um eine benutzerdefinierte oder integrierte Spezifikation zu entfernen, wählen Sie sie in der Liste aus und klicken Sie auf die Schaltfläche
auf der rechten Seite des Dialogs.
- Entfernte integrierte Spezifikationen können wiederhergestellt werden, indem Sie mit der rechten Maustaste in die Spezifikationsliste klicken und den Befehl Restore Built-In Spec auswählen. Benutzerdefinierte Spezifikationen sind von diesem Befehl nicht betroffen.
Constraints definieren
Jedes Netz wird daraufhin analysiert, ob es die festgelegten Constraints erfüllt. Wenn für die übergeordnete Klasse eine Spezifikation ausgewählt wurde, werden die Constraints durch diese Spezifikation definiert.
Um die aktuellen Constraints eines Netzes/xSignals oder eines differenziellen Paars einzusehen, wählen Sie bei erweitertem Eintrag die Registerkarte Constraints aus.
Klicken Sie auf einen Constraint-Wert, um diesen Constraint im daraufhin angezeigten Pop-up zu bearbeiten.
Beachten Sie, dass bei einer manuellen Änderung eines Constraint-Werts die Warnmeldung Custom constraints are used im entsprechenden Eintrag angezeigt wird.
Eine Analyse durchführen
Nach Abschluss der Konfiguration können Sie eine Analyse für alle hinzugefügten Netze, eine bestimmte Klasse oder ein bestimmtes Netz durchführen. Klicken Sie oben rechts im Dokument SI Analyzer by Keysight auf die Schaltfläche Analyze All, um alle Netze zu analysieren, oder auf die Schaltfläche Analyze im Eintrag einer bestimmten Klasse bzw. eines bestimmten Netzes, um nur diese Klasse bzw. dieses Netz zu analysieren.
Ergebnisse untersuchen
Nach Abschluss der Analyse werden die Ergebnisse im Dokument SI Analyzer by Keysight angezeigt. Oben rechts im Dokument erscheint die Meldung Analyzed. Wenn alle analysierten Netze die Constraints erfüllen, wird neben der Meldung der Text All Passed angezeigt. Andernfalls wird der Text Failed zusammen mit der Anzahl der Netze angezeigt, die die Constraints nicht erfüllen.
Wenn alle Netze einer Klasse die Analyse bestehen, wird für den entsprechenden Eintrag der Text Success angezeigt. Andernfalls wird der Text Failed angezeigt.
Erweitern Sie einen Klasseneintrag, um die berechneten Werte (Impedanz, Verzögerung, Einfügedämpfung und Rückflussdämpfung) für jedes analysierte Netz dieser Klasse anzuzeigen. Werte, die die Constraints erfüllen, werden grün dargestellt; Werte, die die Constraints nicht erfüllen, werden rot dargestellt.
Erweitern Sie einen Netzeintrag, um die berechneten Werte für dieses Netz auf der Registerkarte Results anzuzeigen. Außerdem erhalten die Kacheln von Netzobjekten, die die Constraints nicht erfüllen, im Bereich Transmission Line einen roten Rahmen, und der nicht konforme Wert wird rot dargestellt.
Um die Analyseergebnisse für eine Klasse oder ein Netz/xSignal/Differenzialpaar auf der Leiterplatte anzuzeigen, klicken Sie auf die zugehörige Schaltfläche Show on PCB.
Das Panel SI Analyzer by Keysight
Im PCB-Editor werden der Analyseprozess und die Ergebnisse über das Panel SI Analyzer by Keysight gesteuert. Beachten Sie, dass das Panel erst dann zur Liste der verfügbaren Panels (über die Schaltfläche Panels) hinzugefügt wird, nachdem eine Signalintegritätsanalyse durchgeführt und auf die Schaltfläche Show on PCB geklickt wurde.
Simuliertes Signal
- Simulated Signal – Wählen Sie hier die Klasse oder das Netz/xSignal/Differenzialpaar aus, das im Designbereich als Heatmap angezeigt werden soll.
- Only nets with violations – Wenn diese Option aktiviert ist, stehen in der Dropdown-Liste nur Elemente zur Verfügung, für die aktuell ein Verstoß vorliegt. Deaktivieren Sie diese Option, um alle analysierten Elemente aufzulisten.
- Show Heatmap – Wenn diese Option aktiviert ist, wird im Designbereich eine Heatmap für das aktuell in der Dropdown-Liste Simulated Signal ausgewählte Element angezeigt.
Unterhalb dieser Steuerelemente verfügt das Panel über zwei Registerkarten: General und Heatmap. Die Optionen auf diesen Registerkarten gelten für das aktuell in der Dropdown-Liste Simulated Signal ausgewählte Element.
Heatmap
Auf der Registerkarte Heatmap des Panels SI Analyzer by Keysight legen Sie fest, welche Daten als Heatmap dargestellt werden – Impedanz oder Laufzeit – und wie die Impedanz-/Laufzeitwerte farblich dargestellt werden. Beachten Sie, dass diese Steuerelemente für die Heatmap-Einstellungen nur verfügbar sind, wenn die Option Show Heatmap aktiviert ist.
Mit den Schaltflächen Impedance und Delay wechseln Sie zwischen den beiden Modi. Das gesamte Netz wird eingefärbt, um die Impedanz/Laufzeit an jeder Stelle entlang des Netzes wie folgt darzustellen:
- Bei der Impedanz gilt: Je näher die Impedanz am Z0-Zielwert liegt, desto grüner ist die Farbe. Je weiter sie vom Z0-Zielwert abweicht, desto röter ist die Farbe. Berechnete Werte unterhalb des Minimums und oberhalb des Maximums werden rot dargestellt.
- Bei der Laufzeit gilt: Je größer die Laufzeit, desto wärmer (röter) ist die Farbe. Je kleiner die Laufzeit, desto kälter ist die Farbe. Berechnete Werte unterhalb des Minimums werden blau und Werte oberhalb des Maximums rot dargestellt.
Die Farbskala zeigt die Zuordnung der Farben zu den Werten. Die Minimal- und Maximalwerte können durch Klicken und Ziehen am Schieberegler oder durch Eingabe eines neuen Werts in die darunterliegenden Felder angepasst werden. Die Skala wird außerdem als Farbbalken im Designbereich unterhalb der Leiterplatte angezeigt.
Aktivieren Sie die Option Color focus on results, um das aktuell in der Dropdown-Liste Simulated Signal ausgewählte Element hervorzuheben und andere Objekte auf der Leiterplatte auszublenden.

Beispiel einer Heatmap für Impedanzberechnungen.

Beispiel einer Heatmap für Laufzeitberechnungen.
Erkennung von Verstößen
Wenn die Analyse Constraint-Verstöße für das aktuell in der Dropdown-Liste Simulated Signal ausgewählte Element erkennt, werden diese im Bereich Violations auf der Registerkarte General des Panels SI Analyzer by Keysight aufgelistet.
- Mit den Schaltflächen oben im Bereich legen Sie fest, welche Arten von Verstößen in der Liste angezeigt werden sollen.
- Mit der Schaltfläche Analyze unten im Bereich führen Sie die SI-Analyse erneut aus. So können Sie nach Änderungen im PCB-Editor schnell prüfen, ob das Element den Constraint erfüllt, ohne zum Dokument SI Analyzer by Keysight zurückzukehren.
Messsonden
Im Bereich Probes des Panels SI Analyzer by Keysight können Sie Messsonden direkt auf der Leiterplatte platzieren. Die Sonden können entweder die Impedanz oder die Laufzeit messen. Die Art der Messung wird durch den aktuellen Heatmap-Modus der Leiterplatte bestimmt.
Sie können entweder eine Einzelsonde verwenden, um einen Absolutwert an der Sondenposition zu messen, oder eine Differenzsonde, um die Differenz zwischen zwei Sondenpositionen zu messen. Beide Sondentypen werden durch Klicken auf die Schaltfläche Add im Bereich Probes des Panels platziert. Um eine Einzelsonde zu platzieren, klicken Sie auf die gewünschte Position und anschließend mit der rechten Maustaste (oder drücken Sie Esc). Um eine Differenzsonde zu platzieren, klicken Sie einmal, um die erste Sondenposition festzulegen, und anschließend ein zweites Mal, um die zweite Sondenposition festzulegen. Sobald eine Sonde definiert wurde, werden die Messergebnisse im Panel angezeigt.
Klicken Sie auf einen Sondeneintrag im Panel, um die zugehörige(n) Position(en) auf der Leiterplatte anzuzeigen. Wählen Sie einen Sondeneintrag im Panel aus und klicken Sie auf die Schaltfläche
unten im Bereich, um die Sonde zu entfernen.
Klicken Sie auf die Schaltfläche Add to Report, um ein Bild der Leiterplatte an der ausgewählten Sondenposition zu erstellen. Das Bild wird im Bereich Image Captures des Panels angezeigt und mit einer Markierung Probe gekennzeichnet. Bewegen Sie den Mauszeiger über den Screenshot, um die Sondendetails anzuzeigen.
Bildaufnahmen
Mit der Bildaufnahmefunktion im Panel SI Analyzer by Keysight können Sie einen designspezifischen Screenshot erstellen, der anschließend in einen Bericht aufgenommen werden kann.
Um ein Bild eines bestimmten Leiterplattenbereichs aufzunehmen, richten Sie zunächst die Ansicht der Leiterplatte im Designbereich so ein, dass die gewünschten Elemente sichtbar sind. Klicken Sie anschließend auf die Schaltfläche Add im Bereich Image Captures des Panels, um den Screenshot aufzunehmen. Sie können die Ansicht der Leiterplatte weiterhin ändern und weitere Bilder hinzufügen.
Um ein Bild zu löschen, bewegen Sie den Mauszeiger darüber, sodass die Schaltfläche
eingeblendet wird, und klicken Sie darauf.
Ergebnisberichte erstellen
Um einen vollständigen Analysebericht zu erstellen, klicken Sie auf die Schaltfläche Full Report oben im Dokument SI Analyzer by Keysight. Der vollständige Bericht enthält einen Abschnitt für jede Klasse (sowie den Eintrag All Nets für einzeln hinzugefügte Netze außerhalb von Netzklassen).
Klicken Sie im vollständigen Bericht auf den Namen einer Netzklasse (oder auf den Netznamen in der Liste All Nets), um einen detaillierten Bericht mit folgenden Angaben anzuzeigen:
- Name der Netzklasse oder des Netzes.
- Zugewiesene Spezifikation(en).
- Zusammenfassung der Constraint-Prüfungen. Klicken Sie auf den Eintrag einer fehlgeschlagenen Prüfung, um Empfehlungen zur Behebung der zugehörigen Probleme anzuzeigen.
- Lagenaufbau der Leiterplatte.
- Constraint-Prüfungen für jedes Netz. Erweitern Sie einen Netzeintrag, um die Constraint-Prüfungen für jedes Objekt dieses Netzes anzuzeigen.
- Diagramm der Einfügedämpfung.
- Diagramm der Rückflussdämpfung.
Klicken Sie beim Erkunden eines detaillierten Berichts auf die Schaltfläche Show on PCB, um die Leiterplatte und das Panel SI Analyzer by Keysight zu öffnen und die Klasse bzw. das Netz zu untersuchen.
Arbeiten mit Diagrammen
Die Diagramme der Einfügedämpfung und Rückflussdämpfung zeigen die entsprechenden Kurven für jedes Netz der untersuchten Klasse. Der rote Bereich im Diagramm kennzeichnet den durch die Constraints definierten unzulässigen Bereich.
-
Verwenden Sie das Dropdown-Menü oben rechts im Diagramm der Einfügedämpfung oder Rückflussdämpfung, um festzulegen, welche Netze im Diagramm angezeigt werden. Sie können alle Netze, Netze mit fehlgeschlagenen Prüfungen oder bestimmte Netze anzeigen.
-
Klicken Sie rechts neben dem Diagramm auf einen Kurvennamen, um die zugehörige Kurve hervorzuheben und die anderen Kurven abzublenden. Klicken Sie erneut auf den Kurvennamen, um die Hervorhebung aufzuheben.
-
Drehen Sie das Mausrad, um relativ zur Position des Mauszeigers im Diagramm zu zoomen. Wenn sich der Mauszeiger auf einer Diagrammachse befindet, drehen Sie das Mausrad, um nur auf dieser Achse relativ zur Zeigerposition zu zoomen (die Skalierung der anderen Achse bleibt unverändert).
-
Mit Messcursorn können Messungen vorgenommen werden. Es stehen zwei Cursor zur Verfügung, die derselben oder unterschiedlichen Kurven in einem Diagramm hinzugefügt werden können. Klicken Sie mit der rechten Maustaste auf einen Kurvennamen rechts neben dem Diagramm und verwenden Sie die Befehle Cursor A und Cursor B im Kontextmenü, um die Cursor zu aktivieren bzw. zu deaktivieren. Verschieben Sie einen Cursor, indem Sie auf seine Registerkarte klicken und diese ziehen. Die Messdaten eines aktivierten Cursors werden am unteren Rand des Diagramms angezeigt.

Ein Beispiel für die Cursor A und B, die derselben Kurve hinzugefügt wurden.
Exportieren des Berichts
Klicken Sie auf die Schaltfläche Save Report, um den Bericht im HTML-Format zu speichern. Legen Sie im anschließend angezeigten Dialogfeld Report Settings fest, welche Netze (wenn das Dialogfeld aus dem vollständigen Bericht heraus aufgerufen wird) und welche spezifischen Daten in den Bericht aufgenommen werden.
Nach dem Klicken auf die Schaltfläche Generate Report wird der Bericht in einem Unterordner des Projektordners mit dem Namen \SiAnalyzerByKeysight_Output\HTMLReport\<ProjectName>.sik_<CurrentDate>_<CurrentTime> gespeichert. Alle Bilder des Berichts werden in einem Unterordner namens \Images gespeichert.
).
).

).
gekennzeichnet. Wenn ein Netz Teil eines differenziellen Paars ist, wird es zusammen mit seinem Gegenstück als differenzielles Paar zum Dokument SI Analyzer by Keysight hinzugefügt. Der entsprechende Eintrag ist mit dem Symbol
gekennzeichnet.














