Altium Designer Documentation

OrCAD CIS Import

Modified by Jason Howie on Jan 11, 2018
All Contents
The content on this page has not yet been updated to reflect look/feel/functionality in Altium Designer 18.0

Supporting the need to work with database component libraries from OrCAD® CIS, Altium Designer’s Import Wizard provides a flexible, automated OrCAD CIS library conversion option to create an equivalent Altium Designer Database Library and the associated schematic/PCB libraries.

Using a connectivity system that is not unlike OrCAD’s Component Information System (CIS), an Altium Designer Database Library hosts links to component data in an ODBC Compliant data source, such as a company component database. The records in the centralized database reference the source models (symbols, footprints, etc) and parameters for sets of company ratified components.

An Altium Designer Database Library provides library based links to those component definitions, which allows database sourced company components to be placed directly into designs, that are in turn synchronized back the data source.

The elementary database link mapping file for OrCAD CIS is a CIS Configuration file (*.dbc), and this is processed by the Import Wizard to create a corresponding Altium Designer Database Library structure (*.DBLib). The associated OrCAD library files (*.olb , *.llb), which are essentially the linked sources of component symbols and footprints, are also handled by the importer to create Altium Designer Library files (*.SchLib, *.PcbLib).

Enabling the Importer

If the Importer was not already added during Altium Designer’s initial installation, it can be enabled in the Configure Platform page in Altium Designer’s Extension & Updates view. Select DXP » Extensions and Updates, the Configure link under the view’s Installed tab and then check the OrCAD option in the Importers\Exporters section – this option serves both OrCAD and OrCAD CIS import functions.

Importing OrCAD CIS Files

The OrCAD CIS design file importer is available through Altium Designer's Import Wizard  (File » Import Wizard), where the option is selected in the wizard's Select Type of Files to Import page. The wizard provides page options for nominating the main component database, the source OrCAD CIS Configuration and library files, and the target Altium Designer Database Library.

Directly opening an OrCAD CIS file (*.dbc, *.olb, *.llb) in Altium Designer (File » Open) will activate the Import Wizard with that file already specified for import.

– See the OrCAD CIS Configuration Files and Libraries entry in the Import Wizard page for more information on the wizard's import steps.

File Processing

The Import Wizard translates or processes OrCAD CIS library-based files as follows:

  • The OrCAD CIS Configuration File (*.dbc), which defines the link to the external component database and includes the database field-to-design parameter mapping information, is interpreted to create an Altium Designer Database Library file (*.DBLib).
  • The relevant OrCAD library files (schematic and/or PCB libraries) are translated into Altium Designer library files:
    • The nominated OrCAD schematic libraries (*.OLB) are converted to Altium Designer Schematic Libraries (*.SchLib)
    • The nominated OrCAD pcb libraries (*.LLB) are converted to Altium Designer PCB Libraries (*.PcbLib).

The final result is that the OrCAD CIS linking structure that accesses data fields in the external component database (such as a Microsoft® Access *.mdb file) is replicated in the Altium Designer Database Library (DBLib). Also, the OrCAD library files that are used as sources for component symbols and models are converted to Altium Designer library files, which then become the symbol/model sources for the new DBLib database field mapping.

Using the Wizard

Altium Designer’s Import Wizard steps you through the processes of nominating the range of source and target files for the OrCAD CIS translation.

Ensure that you choose the Orcad CIS Configuration File and Libraries option as the type of files to import in the Wizard’s initial File Type page, and then use the subsequent pages to specify:

  • The location of the external database – typically, your ODBC-compliant company component database.
  • The location of the OrCAD CIS Configuration file.
  • The location of the target DBLib file – which will be created, or added to, in the final Wizard steps.
  • The OrCAD Schematic and/or PCB libraries referenced by the external database.

Note that the external database and OrCAD source files are not altered (written to) during the import process, as the wizard simply reads their data to create the new database linking structure.

Database Library Document

When the Import Wizard steps are complete, the specified Database Library file will be made active in Altium Designer.

The library document can be reviewed and edited if necessary. Points of note include:

  • The Import Wizard automatically adds a library search path to the DBLib file, which points to the nominated directory that contains the translated library files.
  • The defined lookup key determines the data relationship between the external database and the DBLib parameters (or properties, in OrCAD terms). If necessary, the key lookup field/parameter pair can be changed in the Field Settings region by selecting an alternative relationship from the drop down menus.
  • The parameter mapping information is taken directly from the OrCAD CIS Configuration file. In addition, the following two model mapping entries are prescribed automatically:
    • The Layout PCB Footprint or Allegro PCB Footprint field relates to a [Orcad Footprint] parameter setting.
    • The Schematic Part field relates to a [Orcad Library] parameter setting.
      The above two entries provide the link to the source schematic symbols for component records in the external database, and the applicable PCB Footprint models (where available) that are linked to those components.
  • Once the initial review and/or editing is complete, the DBLib must be saved.

When used as a source library in Altium Designer, components placed from the active Database Library will draw the mapped parameter and symbol/model data from the external database.

Use the Update From Libraries command to update a placed component in response to changes made in the external component database or the associated source libraries (Tools » Update From Libraries). To simply update the component’s parameters from the source database, select Tools » Update Parameters From Database.

– See Update From Libraries for information on Library updates.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.


Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.