Altium NEXUS Documentation

Managed Output Job Files

Modified by Jason Howie on Jun 21, 2018
This documentation page references Altium Vault, which is no longer a supported product. Altium Vault and its component management features have migrated to Altium Concord Pro.

Parent page: Server Items

Altium NEXUS, in conjunction with your managed content server, caters for the ability to create and manage Outputjob Items in that Server. Such Items are created directly from within the Server. Once an Outputjob Item has been created (and data released into a revision of it), and its lifecycle state set to a level that the organization views as ready for use at the design level, it can be reused in future board-level design projects.

In addition, and when using an Altium NEXUS Server as your managed content server, a managed Outputjob Item can be used as a configuration data item in one or more defined Environment Configurations. An environment configuration is used to constrain a designer's Altium NEXUS working environment to only use company-ratified design elements. Environment configurations are defined and stored within the Team Configuration Center - a service provided through the Altium NEXUS Server installation, and the facilitator of this concept of Environment Configuration Management.

For more information on working with an Output Job Configuration file, see Preparing Multiple Outputs in an Output Job.

Folder Type

When creating the folder in which to store Outputjob Items, you can specify the folder's type. This has no bearing on the content of the folder - releasing an Output Job Configuration file will always result in a corresponding Outputjob Item. It simply provides a visual 'clue' as to what is stored in a folder and can be beneficial when browsing a Server for particular content. To nominate a folder's use as a container for Outputjob Items, set its Folder Type as Output Jobs, when defining the folder properties in the Edit Folder dialog.


Specifying the folder type - its intended use - gives a visual indication of the content of that folder when browsing the Server!

Another important aspect of the parent folder is the Item Naming Scheme employed for it. This defines the format of the unique ID for each Item created in that particular folder. Several default example schemes are available, utilizing the short-form code for either the folder type (OUTC - OutputJob Collection) or the content type (OUT - OutputJob):

  • $CONTENT_TYPE_CODE-001-{0000} - for example, OUT-001-0001.
  • $CONTENT_TYPE_CODE-001-{A00} - for example, OUT-001-A01.
  • $FOLDER_TYPE_CODE-001-{0000} - for example, OUTC-001-0001.
  • $FOLDER_TYPE_CODE-001-{A000} - for example, OUTC-001-A001.

Using a default naming scheme, the software will automatically assign the next available unique ID, based on that scheme, having scanned the entire Server and identifiers of existing Items. This can be a great time-saver when manually creating Outputjob Items.

A custom scheme can also be defined for a folder, simply by typing it within the field, ensuring that the variable portion is enclosed in curly braces (e.g. OUTJOB-001-{0000}).


The Item Naming Scheme of the parent folder is applied to the Unique ID for each Item
created within that folder.

The Item Naming Scheme employed for the parent folder can be changed at any time. The modified scheme will then be applied to any subsequent newly-created Items within that folder.

Item Type

When creating a target Outputjob Item in which to store your Output Job Configuration, ensure that its Content Type is set to Outputjob, in the Create New Item dialog. If you are creating the Item in an Output Jobs type folder, this Item type will be available from the right-click context menu when creating the Item.


Creating an Outputjob Item within an Output Jobs folder - the correct Content Type is available on the context menu.

When defining an Outputjob Item, be sure to specify the type of lifecycle management to be used for the Item, and the naming scheme employed for its revisions, respectively.

Control over which Item types can use a particular lifecycle definition or revision naming scheme, can be defined and enabled at a global level from within the Content Types dialog, when defining each schema. The default schemes assigned for use by an Outputjob Item are: Simple Lifecycle and 1-Level Revision Scheme, respectively.

Once a template definition has been released into the initial revision of an Outputjob Item, these schemes cannot be changed for that particular Item.

Specify the required schemes in the Create New Item dialog, using the Lifecycle Definition and Revision Naming Scheme fields respectively.

If the option to control use of lifecycle definitions and revision naming schemes per content type is enabled for any definitions/schemes, and the Outputjob Item type is not set to use a particular definition/scheme, then that definition/scheme will not be available in the applicable drop-down list.


Selecting the Lifecycle Definition and Revision Naming schemes for a manually created Item.

Observing standard revision naming schemes and lifecycle definitions, across the various types of design item in a managed content server ensures smooth, consistent management of those items.
It is a good idea to add a Name and Description as part of the Item's definition. This information is used when searching the Server and enables quick identification of what an Outputjob Item offers.

Releasing an Output Job Configuration

So far, we've discussed the support for an Outputjob Item in the Server, in terms of related folder and item types. Releasing an actual defined Output Job Configuration into a revision of such an item can be performed in a streamlined way.

An Output Job Configuration can be edited and released into the initial revision of a newly-created Outputjob Item, courtesy of the Server's support for direct editing. Direct editing frees you from the shackles of separate version-controlled source data. You can simply edit a supported Item type using a temporary editor loaded with the latest source direct from the Server itself. And once editing is complete, the entity is released (or re-released) into a subsequent planned revision of its parent Item, and the temporary editor closed. There are no files on your hard drive, no questioning whether you are working with the correct or latest source, and no having to maintain separate version control software. The managed content server handles it all, with the same great integrity you've come to expect, and in a manner that greatly expedites changes to your data.

When you create an Outputjob Item, you have the option to edit and release an Output Job Configuration into the initial revision of that item, after creation. To do so, enable the option Open for editing after creation, at the bottom of the Create New Item dialog (which is enabled by default). The Item will be created and the temporary Outputjob Editor will open, presenting a .OutJob document as the active document in the main design window. This document will be named according to the Item-Revision, in the format: <Item><Revision>.OutJob (e.g. OUT-001-0001-1.OutJob).


Example of editing the initial revision of an Outputjob Item, directly from the managed content server - the temporary OutputJob Editor provides the document with which to
define your configuration.

Use the document to define the Output Job Configuration as required. For more information on doing this, see Preparing Multiple Outputs in an Output Job.

A number of innovative features are available when configuring your outputs to make the resulting Output Job Configuration as generic as possible. By keeping an OutJob generic, you can effectively maximize its ability to be reused across future design projects.

Generic Data Source Names

Many output generators use a specifically-named underlying document as their source, from which the applicable output data is generated - for example Gerber files generated from the PCB document FluxTriangulator.PcbDoc. However, doing so locks the Output Job Configuration to being useful only with that document's parent design project. To keep things non-specific, a generic entry for the underlying Data Source is available for selection across many of the output generators. The following table summarizes which output generators are supported, and the generic entry (entries) available.

Category Output Type Generic Data Source Entry
Netlist Outputs All [Project]
Simulator Outputs Mixed Sim [Project]
Documentation Outputs Composite
PCB 3D Print
PCB 3D Video
PCB Prints
PDF3D
[PCB Document]
  Schematic Prints [Project Physical Documents]
Assembly Outputs All [PCB Document]
Fabrication Outputs All [PCB Document]
Report Outputs Bill of Materials [Project]
[ActiveBOM Document]
  Component Cross Reference
Report Project Hierarchy
Report Single Pin Nets
[Project]
Validation Outputs Component states
Configuration compliance
Electrical Rules Check
[Project]
  Design Rules Check
Differences Report
Footprint Comparison Report
[PCB Document]
Export Outputs Ansoft Neutral (AutoPCB)
AutoCAD dwg/dxf File PCB
Export IDF
Export PARASOLID
Export STEP
Export VRML
Hyperlynx (AutoPCB)
P-CAD ASCII (AutoPCB)
Save As/Export PCB
SiSoft (AutoPCB)
Specctra Design PCB
[PCB Document]
 

AutoCAD dwg/dxf File Schematic
OrCAD v7 Capture Design (AutoSCH)
P-CAD V16 Schematic Design (AutoSCH)
Save As/Export Schematic

Web Review

[Project]
PostProcess Outputs Copy Files [Project]

Layer Classes

You have the ability to add named layer classes to configurations for the following output generators:

  • PCB Prints
  • Gerber Files
  • ODB++ Files

This makes these output generators generically reusable. For example, add a class 'signal layers' and refer to it in the OutJob - any design that has a 'signal layers' class will be able to use that output generator without modification.

There are three relevant controls when direct editing, readily available from the Quick Access Bar (at the top-left of the main application window), or from the Job Manager Toolbar toolbar:

  •  - Save Active Document. Use this button to save any changes made to the document. This allows you to save current changes, should you wish to come back at a later stage to make further changes before ultimately releasing to the managed content server.
  •  - Release Document. Use this button to release (effectively save and release) the defined configuration to the managed content server, storing it within the initial (planned) revision of the target Outputjob Item. The Edit Revision dialog will appear, in which you can change Name, Description, and add release notes as required. The document and editor will close after the release. The document containing the configuration, *.OutJob, will be stored in the revision of the Item.
  •  - Cancel Editing. Use this button if you wish to cancel editing. The document and editor will close, and nothing will be released to the target Outputjob Item.

These controls are also available as commands - Save (Shortcut: Ctrl+S), Release to Server (Shortcut: Alt+Ctrl+S), and Cancel Edit - from the main File menu.

The released data stored in the Server consists of the Output Job Configuration, defined in the Output Job Configuration file (<Item><Revision>.OutJob). In the Explorer panel, switch to the Preview aspect view to see the outputs defined within the configuration.


Browse the released revision of the Outputjob Item, back in the Explorer panel. Switch to the Preview aspect view to see the outputs contained within the configuration.

Reusing a Managed Outputjob Item

Related page: Controlling Access to Server Content

Once an Output Job Configuration has been released to a managed content server, and its lifecycle state set to a level that the organization views as ready for use at the design level, that configuration can be reused in future board-level design projects.

When you are signed in to your managed content server, you are free to manually reuse the revisions of any Outputjob Items that have been shared with you.

If you do not sign in to your managed content server you can still work with Altium NEXUS (under your valid Altium NEXUS License), but you will not be able to access your organization's managed content server, or any other services it provides. You will therefore not be able to reuse any managed Outputjob Items. You will only be able to use file-based configurations defined locally.

Choose a revision of an Outputjob Item to use, from the Managed OutputJobs tab of the Project Options dialog. Click th button - the Select configuration item (Output Jobs) dialog will appear, listing the latest revision of all Outputjob Items in the Server that are available to you (shared with you). Choose the required Item Revision and click OK.


Manually choosing a revision of an Outputjob Item from within the Managed OutputJobs tab of the Project Options dialog.

Continue adding further revisions of different OutputJob Items as required. After clicking OK to exit the Project Options dialog, save the project and recompile - the chosen OutputJob Item Revision(s) will appear in the Projects panel.

A managed OutputJob is distinguished in the Projects panel by the  icon.


The added revisions of OutputJob Items will be reflected in the Projects panel after the project is saved and recompiled.

In addition to using the revisions of managed Outputjob Items, you are also free to create and use unmanaged (local, file-based) Output Job files, should this be required.

Reuse as Part of an Environment Configuration

When using an Altium NEXUS Server as your managed content server, a released Output Job Configuration can also be used as a configuration data item in one or more defined Environment Configurations. An environment configuration is used to constrain a designer's Altium NEXUS working environment to only use company-ratified design elements. Environment configurations are defined and stored within the Team Configuration Center - a service provided through the Altium NEXUS Server installation.

Once you have signed in to the Altium NEXUS Server, and chosen (if applicable) from the selection of environment configurations available to you, Altium NEXUS will be configured, with respect to use of Output Job Configurations. If the chosen environment configuration has one or more defined Outputjob Item revisions, then only those defined configurations can be used. If the chosen environment configuration applicable to you does not have any Outputjob Item revisions specified/added, then these will remain manually definable. In other words, you are free to manually reuse a managed Output Job Configuration and/or use local templates. For more information, see Environment Configuration Management.

Under the enforcement of an environment configuration, Altium NEXUS will be configured, with respect to use of Output Jobs, in the following areas.

Revisions of Outputjob Items are specified for use from the Managed OutputJobs tab of the Project Options dialog, in much the same way when reusing them manually. The difference with their use under management of an environment configuration is that you can only add those revisions of Outputjob Items defined for that environment configuration.

Click th b utton - the Select configuration item (Output Jobs) dialog will appear. Use this dialog to choose which OutJob to use for the project, from the list of Outputjob Item revisions defined as part of the environment configuration currently in-force. Add additional Outputjob Item revisions as required.


Choose from the environment configuration's defined Outputjob Item Revisions, when adding OutJobs to a project. In the image, while there are four Outputjob Items defined
in the Server, only three are specified for use by the active environment configuration (PCB Design Engineers).

With all Outputjob Item revisions added as required, OK out of the Project Options dialog, save the project, and recompile - the chosen managed Outputjob Item revision(s) will appear in the Projects panel.

While you are only able to reuse the managed Outputjob Item revisions specified in the active environment configuration, you are still able to create new, file-based output jobs if required. Commands for creating a new OutJob - either using the File » New » Output Job File command, or right-clicking on a project's entry in the Projects panel and choosing Add New to Project » Output Job File, will therefore still be available for use.

Under configuration management, and when at least one OutJob is defined for the active environment configuration, this will no longer be possible. If you attempt to add an existing Output Job File to the project, by right-clicking on a project's entry in the Projects panel, choosing Add Existing to Project, and browsing for that file, a warning dialog will appear - alerting you to the fact that Output Jobs are being managed by the applied environment configuration, and that existing Output Job files cannot be added to the project.

OutputJob Editor

The OutputJob Editor - accessed when opening a managed OutJob - will reflect that the file is a Managed OutputJob Document, with an indication of the Item Revision, its description, and the parent managed content server in which that Item resides.


The Output Job Editor when viewing a managed Output Job.

Since the OutJob is managed, any controls that would otherwise effect its modification in some way, are disabled. So the following abilities ARE NOT available:

  • Addition of new Output Generators.
  • Configuration of existing Output Generators.
  • Cut, copy, paste, duplication or deletion of an existing Output Generator.
  • Addition of new Output Containers or Hard Copy Jobs.
  • Configuration of an existing Output Container or Hard Copy Job.
  • Cut, copy, paste or deletion of existing Output Containers or Hard Copy Jobs.
  • Toggle the inclusion state of an Output Generator with respect to a valid Output Container or Hard Copy Job.

You can, however, still determine variant usage for the OutJob.

Re-Releasing an Outputjob Item

At any stage, you can come back to any revision of an Outputjob Item in the Server, and edit it directly. Right-click on the revision and choose the Edit command from the context menu. Once again, the temporary editor will open, with the configuration contained in the revision opened for editing. Make changes as required, then commit the release of the document into the next revision of the item.

Right-clicking on the top-level entry for an Item itself, will edit the latest revision of that Item.


Accessing the command to launch direct editing of an existing revision of an Outputjob Item.

Downloading Released Data

Download the data stored in a revision of an Outputjob Item by right-clicking on that revision and choosing the Operations » Download command from the context menu. The Output Job Configuration file will be downloaded into a sub-folder under the chosen directory, named using the Item Revision ID. The file can be found in the Released folder therein.

Access the Download command from the top-level entry for an Outputjob Item itself, to download the Output Job Configuration file file stored in the latest revision of that Item.
Click the Explore button in the Download from Vault dialog, to quickly explore to the download folder.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.