Altium NEXUS Documentation

Managed Schematic Templates

Modified by Jason Howie on Jun 11, 2020

Parent page: Server Items

Altium NEXUS, in conjunction with your managed content server, caters for the ability to create and manage Schematic Template Items in that Server. Such Items are created directly from within the Server. Once a Schematic Template Item has been created (and data released into a revision of it), and its lifecycle state set to a level that the organization views as ready for use at the design level, it can be reused in future board-level design projects.

In addition, and when using an Altium NEXUS Server as your managed content server, a managed Schematic Template Item can be used as a configuration data item in one or more defined Environment Configurations. An environment configuration is used to constrain a designer's Altium NEXUS working environment to only use company-ratified design elements. Environment configurations are defined and stored within the Team Configuration Center - a service provided through the Altium NEXUS Server installation, and the facilitator of this concept of Environment Configuration Management.

Folder Type

When creating the folder in which to store Schematic Template Items, you can specify the folder's type. This has no bearing on the content of the folder - releasing a schematic template will always result in a corresponding Schematic Template Item. It simply provides a visual 'clue' as to what is stored in a folder and can be beneficial when browsing a Server for particular content. To nominate a folder's use as a container for Schematic Template Items, set its Folder Type as Schematic Templates, when defining the folder properties in the Edit Folder dialog.


Specifying the folder type - its intended use - gives a visual indication of the content of that folder when browsing the Server!

Another important aspect of the parent folder is the Item Naming Scheme employed for it. This defines the format of the unique ID for each Item created in that particular folder. Several default example schemes are available, utilizing the short-form code for either the folder type (STC - Schematic Template Collection) or the content type (SCHDOT - Schematic Document Template):

  • $CONTENT_TYPE_CODE-001-{0000} - for example, SCHDOT-001-0001.
  • $CONTENT_TYPE_CODE-001-{A00} - for example, SCHDOT-001-A01.
  • $FOLDER_TYPE_CODE-001-{0000} - for example, STC-001-0001.
  • $FOLDER_TYPE_CODE-001-{A000} - for example, STC-001-A001.

Using a default naming scheme, the software will automatically assign the next available unique ID, based on that scheme, having scanned the entire Server and identifiers of existing Items. This can be a great time-saver when manually creating Schematic Template Items.

A custom scheme can also be defined for a folder, simply by typing it within the field, ensuring that the variable portion is enclosed in curly braces (e.g. SCH-TMP-{0000}).


The Item Naming Scheme of the parent folder is applied to the Unique ID for each Item
created within that folder.

The Item Naming Scheme employed for the parent folder can be changed at any time. The modified scheme will then be applied to any subsequent newly-created Items within that folder.

Item Type

When creating a target Schematic Template Item in which to store your schematic template, ensure that its Content Type is set to Schematic Template, in the Create New Item dialog. If you are creating the Item in a Schematic Templates type folder, this Item type will be available from the right-click context menu when creating the Item.


Creating a Schematic Template Item within a Schematic Templates folder - the correct Content Type is available on the context menu.

When defining a Schematic Template Item, be sure to specify the type of lifecycle management to be used for the Item, and the naming scheme employed for its revisions, respectively.

Control over which Item types can use a particular lifecycle definition or revision naming scheme, can be defined and enabled at a global level from within the Content Types dialog, when defining each schema. The default schemes assigned for use by a Schematic Template Item are: Simple Lifecycle and 1-Level Revision Scheme, respectively.

Once a template definition has been released into the initial revision of a Schematic Template Item, these schemes cannot be changed for that particular Item.

Specify the required schemes in the Create New Item dialog, using the Lifecycle Definition and Revision Naming Scheme fields respectively.

If the option to control use of lifecycle definitions and revision naming schemes per content type is enabled for any definitions/schemes, and the Schematic Template Item type is not set to use a particular definition/scheme, then that definition/scheme will not be available in the applicable drop-down list.


Selecting the Lifecycle Definition and Revision Naming schemes for a manually created Item.

Observing standard revision naming schemes and lifecycle definitions, across the various types of design item in a managed content server ensures smooth, consistent management of those items.
It is a good idea to add a Name and Description as part of the Item's definition. This information is used when searching the Server and enables quick identification of what a Schematic Template Item offers.

Releasing a Schematic Template

So far, we've discussed the support for a Schematic Template Item in the Server, in terms of related folder and item types. Releasing an actual defined schematic template into a revision of such an item can be performed in a streamlined way.

A schematic template can be edited and released into the initial revision of a newly-created Schematic Template Item, courtesy of the Server's support for direct editing. Direct editing frees you from the shackles of separate version-controlled source data. You can simply edit a supported Item type using a temporary editor loaded with the latest source direct from the Server itself. And once editing is complete, the entity is released (or re-released) into a subsequent planned revision of its parent Item, and the temporary editor closed. There are no files on your hard drive, no questioning whether you are working with the correct or latest source, and no having to maintain separate version control software. The managed content server handles it all, with the same great integrity you've come to expect, and in a manner that greatly expedites changes to your data.

When you create a Schematic Template Item, you have the option to edit and release a schematic template into the initial revision of that item, after creation. To do so, enable the option Open for editing after creation, at the bottom of the Create New Item dialog (which is enabled by default). The Item will be created and the temporary Schematic Editor will open, presenting a .SchDot document as the active document in the main design window. This document will be named according to the Item-Revision, in the format: <Item><Revision>.SchDot (e.g. SCHDOT-001-0002-1.SchDot).


Example of editing the initial revision of a Schematic Template Item, directly from the managed content server - the temporary Schematic Editor provides the document with which
to define your schematic template.

Use the document to define the schematic template as required.

There are three relevant controls when direct editing, readily available from the Quick Access Bar (at the top-left of the main application window), or from the Schematic Standard toolbar:

  •  - Save Active Document. Use this button to save any changes made to the document. This allows you to save current changes, should you wish to come back at a later stage to make further changes before ultimately releasing to the managed content server.
  •  - Release Document. Use this button to release (effectively save and release) the defined schematic template to the managed content server, storing it within the initial (planned) revision of the target Schematic Template Item. The Edit Revision dialog will appear, in which you can change Name, Description, and add release notes as required. The document and editor will close after the release. The document containing the source schematic template, *.SchDot, will be stored in the revision of the Item.
  •  - Cancel Editing. Use this button if you wish to cancel editing. The document and editor will close, and nothing will be released to the target Schematic Template Item.

These controls are also available as commands - Save (Shortcut: Ctrl+S), Release to Server (Shortcut: Alt+Ctrl+S), and Cancel Edit - from the main File menu.

The released data stored in the Server consists of the source schematic template, defined in the Schematic Template file (<Item><Revision>.SchDot). In the Explorer panel, switch to the Preview aspect view to see the template graphics.


Browse the released revision of the Schematic Template Item, back in the Explorer panel. Switch to the Preview aspect view to see the template graphics.

Sending an Existing Template to Server

While direct editing is the preferred approach - and the only approach - for most design Items that can be stored in a managed content server, when it comes to existing schematic templates you also have the abiltiy to send a template directly to the Server. This requires that you have a planned revision of an existing Schematic Template Item, into which the sheet will be released. The process is simple, as follows:

  1. Create a new Schematic Template Item and initial planned revision, or have a planned revision of another existing Item, as required.
  2. Open the schematic template (*.SchDot) within Altium NEXUS.
  3. Choose the File » Send to server command from the main menus.
  4. The Choose Planned Item Revision dialog will appear. Use this to choose the target revision of the required Schematic Template Item (which must be in the Planned state), then click OK.
If the target Schematic Template Item doesn't exist, you can create it through the Choose Planned Item Revision dialog on-the-fly. If doing so, be sure to disable the Open for editing after creation option (in the Create New Item dialog), otherwise you'll enter direct editing mode.
  1. The Edit Revision dialog will appear, in which you can change Name, Description, and add release notes as required.
  2. After clicking OK, the template will be released and stored in the revision of the Item.

Example of sending an existing schematic template to the managed content server to which you are actively signed in. The release must be to an existing revision of a Schematic
Template Item, and that revision must be in the Planned state.

Reusing a Managed Schematic Template Item

Related pages: Managed Schematic Sheets, Controlling Access to Server Content

Once a schematic template has been released to a managed content server, and its lifecycle state set to a level that the organization views as ready for use at the design level, that template can be reused in future board-level design projects.

When you are signed in to your managed content server, use of available Schematic Template Items is automatic. If there are released revisions of Schematic Template Items, then only those available templates - shared with you - will be presented in the following areas of the software where a schematic template can be chosen.

When creating a new schematic document, either using the File » New » Schematic command, or right-clicking on a project's entry in the Projects panel and choosing Add New to Project » Schematic, the Select configuration item (Schematic Templates) dialog will appear. Use this dialog to choose which template to use for the new sheet, from the list of templates shared with you in the Server.

The latest revision of each available item will be used.


Choose from the latest revisions of Schematic Template Items, shared with you, when creating a new Schematic document.

Accessing the Properties panel for the active schematic document, with no design objects selected in the workspace, will present the Document Options. In the Formatting and Size region of the Page Options section of the panel (on its General tab), choose the Template mode and then use the Template field to choose which template to use for the sheet, from the list of templates shared with you in the Server.


The chosen revision of a Schematic Template Item is reflected in the Properties panel, when browsing the Document
Options for the active schematic sheet.

Switch to another available template using the Template field's associated drop-down menu. Alternatively, you can apply a different template by choosing from the templates available to you on the Design » Templates » Configuration Templates sub-menu. Remove use of the template by either switching to a different Formatting and Size mode (Standard or Custom) through the General - Page Options section of the Properties panel. Alternatively, use the Design » Templates » Remove Current Template command.

On the Schematic Editor's main Design » Templates sub-menu, the ability to freely select a different file-based Project or General template will be disabled. Instead, the Configuration Templates sub-menu will present all Schematic Template Item Revisions (latest) shared with you for use.


Only the latest revisions of those Schematic Templates shared with you, will be made available for use.

If there are no released revisions of Schematic Template Items in the Server, or if you sign out of your Server, then you will be able to use local, file-based templates.

If you do not sign in to your managed content server you can still work with Altium NEXUS (under your valid Altium NEXUS License), but you will not be able to access your organization's managed content server, or any other services it provides. You will therefore not be able to reuse any managed Schematic Template Items. You will only be able to use file-based templates defined locally.
When using an Altium NEXUS Server as your managed content server, a released schematic template can also be used as a configuration data item in one or more defined Environment Configurations. An environment configuration is used to constrain a designer's Altium NEXUS working environment to only use company-ratified design elements. Environment configurations are defined and stored within the Team Configuration Center - a service provided through the Altium NEXUS Server installation. Once you have signed in to the Altium NEXUS Server, and chosen (if applicable) from the selection of environment configurations available to you, Altium NEXUS will be configured, with respect to use of Schematic Templates. If the chosen environment configuration has one or more defined Schematic Template Items, then only those defined templates can be used. If the chosen environment configuration applicable to you does not have any Schematic Template Items specified/added, then these will remain manually definable. In other words, you are free to use local templates, or manually reuse a managed Schematic Template. For more information, see Environment Configuration Management.

Manual Reuse

When signed in to an Altium NEXUS Server and using an environment configuration that does not control the use of schematic templates, you are free to manually choose a revision of a Schematic Template Item. To do so, use the Design » Templates » Set Template from server command. This presents the Choose Template dialog, from where you can browse to, and select the required Item Revision in the Server.


Use the Set Template from server command to manually reuse (and switch between) managed Schematic Templates that are available to you.

You are also free to use local, unmanaged Schematic Templates in addition to using those from your managed content server, should this be required.

Re-Releasing a Schematic Template Item

At any stage, you can come back to any revision of a Schematic Template Item in the Server, and edit it directly. Right-click on the revision and choose the Edit command from the context menu. Once again, the temporary editor will open, with the template contained in the revision opened for editing. Make changes as required, then commit the release of the document into the next revision of the item.

Right-clicking on the top-level entry for an Item itself, will edit the latest revision of that Item.


Accessing the command to launch direct editing of an existing revision of a Schematic Template Item.

Downloading Released Data

Download the data stored in a revision of a Schematic Template Item by right-clicking on that revision and choosing the Operations » Download command from the context menu. The schematic template file will be downloaded into a sub-folder under the chosen directory, named using the Item Revision ID. The file can be found in the Released folder therein.

Access the Download command from the top-level entry for a Schematic Template Item itself, to download the schematic template file stored in the latest revision of that Item.
Click the Explore button in the Download from Vault dialog, to quickly explore to the download folder.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.