Creación de un modelo de simulación
De un vistazo
- Cómo crear u obtener modelos de simulación, incluidos archivos descargados de fabricantes, modelos basados en texto copiados y archivos de subcircuitos escritos manualmente.
- Cómo crear, guardar, vincular y editar modelos de simulación del espacio de trabajo en Altium Designer y en un espacio de trabajo conectado.
- Qué información se necesita para definir correctamente un modelo de simulación, incluidos los nombres de los modelos, los archivos de referencia y los parámetros a nivel de modelo.
Para simular un diseño de circuito con el simulador de circuitos de señal mixta de Altium Designer, todos los componentes del circuito deben estar preparados para la simulación; es decir, cada uno debe tener un modelo de simulación vinculado.
El tipo de modelo y la forma de obtenerlo dependerán en gran medida del componente y, hasta cierto punto, de las preferencias personales del diseñador. Muchos fabricantes de dispositivos proporcionan modelos de simulación correspondientes a los dispositivos que fabrican. Normalmente, basta con descargar el archivo de modelo necesario y vincularlo al componente del esquema. Obtenga más información sobre Cómo añadir modelos de simulación al diseño.
Es posible que algunos modelos deban escribirse desde cero; por ejemplo, utilizando la sintaxis jerárquica de subcircuitos para crear el archivo de modelo de subcircuito necesario (*.ckt).
Creación de un nuevo modelo de simulación
Los fabricantes y proveedores ofrecen algunos modelos como archivos de texto descargables. En ocasiones, los detalles del modelo se presentan como texto en una página del navegador en lugar de como un archivo descargable; en este caso, puede crear un nuevo archivo de modelo en Altium Designer y copiar y pegar el contenido de la página del navegador en el nuevo archivo. Utilice el comando correspondiente del submenú File » New » Mixed Simulation, como se muestra a continuación.

Comandos para crear un nuevo archivo de modelo vacío.
A continuación, puede copiar y pegar la información del archivo de modelo en el editor de modelos.

Ejemplo del contenido de texto de un modelo de simulación.
Creación de un modelo de simulación del espacio de trabajo
Altium Designer, junto con un espacio de trabajo conectado, permite crear y gestionar modelos de simulación del espacio de trabajo. Una vez creado un modelo de simulación del espacio de trabajo, puede utilizarse para crear uno o varios componentes del espacio de trabajo.
Aunque los modelos de simulación del espacio de trabajo se crean automáticamente al añadir un archivo de modelo de simulación a un componente que se está definiendo en el editor de componentes en su modo de edición de un solo componente y guardar después ese componente en el espacio de trabajo, también puede crear modelos de simulación directamente en el espacio de trabajo, como se describe a continuación.
-
Abra el panel Components y active la visualización de los modelos haciendo clic en el botón
de la parte superior del panel y seleccionando Models.
-
Vaya a la categoría Simulations y seleccione Create Component en el menú del botón
.

Vaya a los modelos de simulación en el panel Components y seleccione el comando para crear un nuevo modelo -
En el cuadro de diálogo Create New Item que se abre, introduzca la información necesaria, asegúrese de que la opción Open for editing after creation esté activada y haga clic en OK. Se creará el modelo de simulación del espacio de trabajo y se abrirá el editor temporal SimModel, con un documento
.SimModelcomo documento activo en el espacio de diseño. Este documento recibirá un nombre según el elemento y su revisión, con el formato:<Item><Revision>.SimModel(p. ej.,SIM-001-0001-1.SimModel).
Ejemplo de edición de la revisión inicial de un modelo de simulación del espacio de trabajo: el editor temporal SimModel proporciona el documento con el que definir el modelo de simulación. - Utilice el documento para definir el modelo de simulación del espacio de trabajo según sea necesario. Para obtener más información sobre cómo hacerlo, consulte Definición del modelo de simulación.
- Guarde el modelo en el espacio de trabajo mediante el control Save to Server situado a la derecha de la entrada del modelo de simulación en el panel Projects. Aparecerá el cuadro de diálogo Edit Revision, en el que puede cambiar el nombre y la descripción, y añadir notas de publicación según sea necesario. El documento y el editor se cerrarán después de guardar.
-
El documento que contiene la definición del modelo de simulación de origen,
*.SimModel, se almacenará en la revisión del modelo de simulación del espacio de trabajo. El modelo de simulación se mostrará en el panel Components, en la categoría Simulations.
Un modelo de simulación del espacio de trabajo guardado en el panel ComponentsLos datos guardados en el espacio de trabajo incluyen la definición del modelo en el archivo
.SimModel, así como cualquier archivo.mdlo.cktal que se haga referencia. En el panel Explorer, cambie a la pestaña de vista Preview y, a continuación, haga clic en un archivo referenciado para obtener una vista previa de su contenido. También se mostrarán los parámetros del modelo, cuando corresponda.
Examine el modelo de simulación del espacio de trabajo guardado en el panel Explorer. Cambie a la pestaña de vista Preview para ver los datos guardados.
Un modelo de simulación del espacio de trabajo guardado puede vincularse después a un componente del espacio de trabajo al definir el componente en el editor de componentes, en el modo de edición de un solo componente o de edición de componentes por lotes.
Definición del modelo de simulación
La información necesaria para definir el modelo en un archivo SimModel es la siguiente:
-
Model Name – utilice este campo para especificar el nombre del modelo. Al guardarlo de nuevo en el espacio de trabajo, esta entrada se utilizará como Name de la revisión del elemento de modelo de simulación.
Al hacer referencia a un archivo MDL, el nombre debe ser el que aparece en la línea
.MODELde la definición del modelo. Considere un modelo de diodo con la siguiente definición:.MODEL 1N4002 D(IS=2.55E-9 RS=0.042 N=1.75 TT=5.76E-6 CJO=1.85E-11 + VJ=0.75 M=0.333 BV=100 IBV=1E-5 )El nombre del modelo en este caso es
1N4002. Este es el nombre que debe introducirse en el campo Model Name.Al hacer referencia a un archivo CKT, el nombre debe ser el que aparece en la línea
.SUBCKTde la definición del modelo. Considere un modelo de fusible con la siguiente definición:.SUBCKT FUSE 1 2 PARAMS: CURRENT=1 RESISTANCE=1m SW1 1 2 3 0 SMOD OFF BNLV 3 0 V=(abs(v(1,2)))
.MODEL SMOD SW (VT=\{(CURRENT*RESISTANCE)\} RON=1g ROFF=\{RESISTANCE\})
.ENDS FUSEEl nombre del modelo en este caso es
FUSE. Este es el nombre que debe introducirse en el campo Model Name. -
Model File – para un modelo definido mediante un archivo
.mdlo.ckt, utilice el botón Browse para seleccionar el archivo necesario de una biblioteca disponible. - Description – introduzca una descripción del modelo, por ejemplo, su finalidad. Al guardarlo de nuevo en el espacio de trabajo, esta entrada se utilizará como Description de la revisión del modelo de simulación.
- Parameters – parámetros del modelo a nivel de modelo (consulte Parámetros a nivel de modelo).
-
Model Preview – visualización de solo lectura del contenido del archivo
.mdlo.cktal que se hace referencia.
Parámetros a nivel de modelo
Cuando corresponda, los parámetros a nivel de modelo pueden definirse directamente en el archivo SimModel, ya que forman parte de la propia definición del modelo. La región Parameters del documento se rellenará automáticamente con los parámetros aplicables al modelo elegido. Los valores de los parámetros pueden modificarse mediante la edición directa: haga clic en el campo Parameter Value asociado a un parámetro de la lista e introduzca directamente el valor necesario.

Defina los parámetros del modelo como parte de su definición mediante la edición directa.
Edición de un modelo de simulación del espacio de trabajo
En cualquier momento, puede volver a cualquier modelo de simulación del espacio de trabajo y editarlo directamente. Seleccione la categoría Simulations en el panel Components (la opción Models debe estar habilitada en el menú
del panel para acceder a esta categoría), haga clic con el botón derecho en la entrada de un modelo de simulación y elija el comando Edit del menú contextual. Se volverá a abrir el editor temporal, con el archivo que contiene la definición de origen del modelo de simulación, incluido en el modelo de simulación del espacio de trabajo, abierto para su edición. Realice los cambios necesarios y, a continuación, guarde el documento en la siguiente revisión del modelo de simulación del espacio de trabajo.
Generación de archivos SimModel
Los archivos SimModel pueden generarse a partir del documento activo de biblioteca de esquemas o de biblioteca de base de datos mediante el comando Tools » Generate SimModel Files.
Tras ejecutar el comando, aparecerá el cuadro de diálogo Generate SimModel Files. Cada archivo SimModel (y la definición del modelo de simulación que contiene) se crea a partir del vínculo al modelo de simulación de un componente de esquema de la biblioteca de esquemas activa (o de la información de simulación de un registro de componente de la biblioteca de base de datos activa). Utilice los controles del cuadro de diálogo para configurar la generación de uno o varios archivos SimModel según sea necesario. De forma predeterminada, se creará una subcarpeta denominada Sim Models. Cambie este nombre por otro más adecuado si es necesario. Si la carpeta indicada existe, se utilizará; de lo contrario, se creará.

El cuadro de diálogo Generate SimModel Files
Tras definir las opciones según sea necesario, haga clic en OK. Se iniciará la generación y, al finalizar el proceso, aparecerá un cuadro de diálogo de confirmación que indicará cuántos archivos SimModel se han generado. Los archivos .mdl, .ckt o .scb a los que se haga referencia también se almacenarán junto con los archivos SimModel.
Si está migrando desde una biblioteca integrada, puede obtener las bibliotecas de esquemas de origen (SchLib) abriendo la IntLib en Altium Designer y eligiendo la opción de extraer las bibliotecas de origen. Al generar archivos SimModel a partir de una biblioteca de base de datos, solo se tendrán en cuenta los componentes de las tablas habilitadas en ese momento.
El nombre de los archivos SimModel depende del tipo de biblioteca de origen:
- Schematic Library - cada archivo SimModel recibe el nombre del modelo de simulación. Si varios componentes de esquema incluyen la misma implementación de modelo de simulación (un modelo de simulación con el mismo nombre), solo se generará un archivo SimModel con ese nombre.
- Database Library - cada archivo SimModel recibe el nombre del modelo de simulación, tal como se especifica en el campo Sim Model Name de un registro de componente. Si varios registros de componentes (en las tablas habilitadas) incluyen la misma implementación de modelo de simulación (la misma entrada en el campo Sim Model Name), solo se generará un archivo SimModel con ese nombre.
Asistente para modelos SPICE
Ciertos modelos de dispositivos analógicos integrados en SPICE admiten un archivo de modelo asociado (*.mdl) en el que se definen paramétricamente características avanzadas de comportamiento (p. ej., resistencia semiconductora, diodo, BJT). Crear este archivo de modelo a mano y vincularlo después manualmente al componente del esquema correspondiente puede resultar bastante laborioso. El SPICE Model Wizard facilita esta tarea. Con el asistente, las características de estos dispositivos pueden definirse a partir de los datos obtenidos por el usuario. Los parámetros, introducidos directamente o extraídos de los datos proporcionados, se escriben automáticamente en un archivo de modelo, que se vincula al componente del esquema designado.
El SPICE Model Wizard ofrece una solución práctica y semiautomatizada para crear y vincular un modelo de simulación SPICE para diversos dispositivos analógicos: dispositivos integrados en SPICE que requieren un archivo de modelo vinculado (*.mdl). Las características de comportamiento del modelo se definen a partir de la información que se proporciona al asistente. La cantidad de información necesaria depende del tipo de dispositivo para el que se desee crear un modelo: desde la simple introducción de parámetros del modelo hasta la introducción de datos del dispositivo obtenidos de la hoja de datos del fabricante o de mediciones realizadas en el propio dispositivo físico.
En las siguientes secciones se describe el uso del asistente, desde el acceso hasta la verificación.
Acceso al asistente
Se accede al asistente desde el editor de símbolos esquemáticos seleccionando el comando Tools » XSpice Model Wizard en los menús principales.

La página inicial del SPICE Model Wizard
En las dos páginas siguientes del asistente, podrá elegir:
- El dispositivo concreto que desea modelar, de la lista de tipos de dispositivos compatibles.
- Si desea añadir el modelo SPICE generado posteriormente a un componente existente en el documento de biblioteca o a un componente nuevo que el asistente creará y añadirá a dicho documento.
Tipos de dispositivos compatibles
El asistente permite crear modelos SPICE para los siguientes tipos de dispositivos analógicos:
- Diodo
- Condensador semiconductor
- Resistencia semiconductora
- Interruptor controlado por corriente
- Interruptor controlado por tensión
- Transistor de unión bipolar
- Línea de transmisión con pérdidas
- Línea de transmisión RC con parámetros distribuidos uniformemente
Asignación de un nombre al modelo
Uno de los pasos más importantes al avanzar por las páginas del asistente es asignar un nombre al modelo que está creando. De hecho, no podrá pasar a la etapa de definición de parámetros del asistente hasta que haya introducido un nombre.
Tras la creación, este nombre aparecerá en el campo Model Name del cuadro de diálogo Sim Model. El propio archivo de modelo también se crea con este nombre (<ModelName>.mdl). Cuando se utiliza el asistente para añadir un modelo a un nuevo componente de biblioteca, el nombre especificado para el modelo también se utiliza para nombrar el componente.
Al asignar un nombre al modelo, también tiene la opción de introducir una breve descripción. Esta puede indicar la función del modelo (p. ej., Semiconductor Resistor) o una referencia más específica a un valor o una configuración (p. ej., NPN BJT).
Características que se van a modelar
Después de asignar un nombre al modelo, pasará a una o varias páginas dedicadas a las características que se van a modelar. Los tipos de modelos compatibles con el asistente pueden clasificarse en los dos grupos siguientes:
- Modelos que requieren introducir directamente los valores de diversos parámetros del modelo. Para obtener más información, consulte la sección Modelos de dispositivos creados mediante la introducción directa de parámetros.
- Modelos que requieren introducir datos de los que se extraen los parámetros que definen las características elegidas del dispositivo. Los datos introducidos se obtienen mediante mediciones directas del dispositivo físico o de la hoja de datos del fabricante. Para obtener más información, consulte la sección Modelos de dispositivos creados mediante la extracción de parámetros a partir de datos.
Generación del modelo
Después de definir los datos o parámetros necesarios, el asistente mostrará el modelo generado. Este es el contenido que se guardará en el archivo MDL.

Vista previa del contenido del archivo de modelo generado.
El modelo puede editarse directamente en esta página, lo que le proporciona el máximo control sobre su especificación.
Cuando esté satisfecho con la definición del modelo, haga clic en Next para pasar al final del asistente. Al hacer clic en Finish, podrá guardar el modelo. Utilice el cuadro de diálogo Save SPICE Model File para determinar dónde debe guardarse el archivo MDL resultante. De forma predeterminada, el archivo se guardará en el mismo directorio que el documento de biblioteca de esquemas. Si lo desea, también puede cambiar el nombre del archivo en este paso.
Si ha solicitado que el modelo se asocie a un componente nuevo, dicho componente se creará y se añadirá al documento de biblioteca.
Modelos de dispositivos creados mediante la introducción directa de parámetros
Para los siguientes modelos de dispositivos, el asistente no extrae información de parámetros a partir de los datos introducidos. En su lugar, los modelos se crean mediante la introducción directa de los valores de sus parámetros asociados. Al introducir los valores de los parámetros, hay un par de aspectos que debe tener en cuenta:
- Si no se especifica un valor para un parámetro, no se incluirá ninguna entrada para él en el archivo de modelo creado. En este caso, se utilizará el valor predeterminado almacenado internamente en SPICE. Dicho de otro modo, si se especifica un valor para un parámetro en un archivo de modelo, el valor del archivo sustituye al valor predeterminado de ese parámetro.
- Si la entrada predeterminada de un parámetro en el asistente es '-' y no se introduce expresamente un valor para dicho parámetro, se utilizará un valor predeterminado de cero (interno de SPICE) para los cálculos.
Condensador semiconductor
Los siguientes parámetros pueden definirse para este modelo de dispositivo mediante el asistente. Al introducir un valor, el parámetro correspondiente se escribirá en el archivo MDL generado.
CJ |
Capacitancia del fondo de la unión (en F/metros2). |
|
CJSW |
Capacitancia de la pared lateral de la unión (en F/metros). |
|
DEFW |
Anchura predeterminada del dispositivo (en metros). (Valor predeterminado = 1e-6). |
|
NARROW |
Estrechamiento debido al grabado lateral (en metros). (Valor predeterminado = 0). |
Resistencia semiconductora
Los siguientes parámetros se pueden definir para este modelo de dispositivo mediante el asistente. Al introducir un valor, el parámetro correspondiente se escribirá en el archivo MDL generado.
TC1 |
Coeficiente de temperatura de primer orden (en ohmios/˚C). (Valor predeterminado = 0) |
|
TC2 |
Coeficiente de temperatura de segundo orden (en ohmios/˚C2). (Valor predeterminado = 0) |
|
RSH |
Resistencia de lámina (en ohmios). |
|
DEFW |
Anchura predeterminada (en metros). (Valor predeterminado = 1e-6). |
|
NARROW |
Estrechamiento debido al grabado lateral (en metros). (Valor predeterminado = 0). |
|
TNOM |
Temperatura de medición de los parámetros (en ˚C). Si no se especifica ningún valor, se utilizará el valor predeterminado asignado a TNOM en la pestaña Advanced del cuadro de diálogo Advanced Analyses Settings (valor predeterminado = 27). |
Interruptor controlado por corriente
Los siguientes parámetros se pueden definir para este modelo de dispositivo mediante el asistente. Al introducir un valor, el parámetro correspondiente se escribirá en el archivo MDL generado.
IT |
Corriente de umbral (en amperios). (Valor predeterminado = 0). |
|
IH |
Corriente de histéresis (en amperios). (Valor predeterminado = 0). |
|
RON |
Resistencia en estado de conducción (en ohmios). (Valor predeterminado = 1). |
|
ROFF |
Resistencia en estado de corte (en ohmios). De forma predeterminada, se establece en 1/GMIN. GMIN es un parámetro avanzado de SPICE, especificado en la pestaña Advanced del cuadro de diálogo Advanced Analyses Settings. Establece la conductancia mínima (resistencia máxima) de cualquier dispositivo del circuito. Su valor predeterminado es de 1e-12 mhos, lo que da un valor predeterminado de 1000G ohmios para ROFF. |
Interruptor controlado por tensión
Los siguientes parámetros se pueden definir para este modelo de dispositivo mediante el asistente. Al introducir un valor, el parámetro correspondiente se escribirá en el archivo MDL generado.
VT |
Tensión de umbral (en voltios). (Valor predeterminado = 0). |
|
VH |
Tensión de histéresis (en voltios). (Valor predeterminado = 0). |
|
RON |
Resistencia en estado de conducción (en ohmios). (Valor predeterminado = 1). |
|
ROFF |
Resistencia en estado de corte (en ohmios). De forma predeterminada, se establece en 1/GMIN. GMIN es un parámetro avanzado de SPICE, especificado en la pestaña Advanced del cuadro de diálogo Advanced Analyses Settings. Establece la conductancia mínima (resistencia máxima) de cualquier dispositivo del circuito. Su valor predeterminado es de 1e-12 mhos, lo que da un valor predeterminado de 1000G ohmios para ROFF. |
Línea de transmisión con pérdidas
Los siguientes parámetros se pueden definir para este modelo de dispositivo mediante el asistente. Al introducir un valor (o activar un indicador), el parámetro correspondiente se escribirá en el archivo MDL generado.
R |
Resistencia por unidad de longitud (en ohmios/unidad). (Valor predeterminado = 0). |
|
L |
Inductancia por unidad de longitud (en henrios/unidad). (Valor predeterminado = 0). |
|
G |
Conductancia por unidad de longitud (en mhos/unidad). (Valor predeterminado = 0). |
|
C |
Capacitancia por unidad de longitud (en faradios/unidad). (Valor predeterminado = 0). |
|
LEN |
Longitud de la línea de transmisión. |
|
REL |
Control de puntos de ruptura (en unidades arbitrarias). (Valor predeterminado = 1). |
|
ABS |
Control de puntos de ruptura (en unidades arbitrarias). (Valor predeterminado = 1). |
|
NOSTEPLIMIT |
Indicador que, al activarse, elimina la restricción que limita los pasos de tiempo a valores inferiores al retardo de la línea. (Valor predeterminado = desactivado). |
|
NOCONTROL |
Indicador que, al activarse, impide limitar el paso de tiempo según los criterios de error de convolución. (Valor predeterminado = desactivado). |
|
LININTERP |
Indicador que, al activarse, permite utilizar la interpolación lineal en lugar de la interpolación cuadrática predeterminada para calcular las señales retardadas. (Valor predeterminado = desactivado). |
|
MIXEDINTERP |
Indicador que, al activarse, utiliza una métrica para determinar si la interpolación cuadrática es aplicable y, si no lo es, utiliza la interpolación lineal. (Valor predeterminado = desactivado). |
|
COMPACTREL |
Magnitud específica utilizada para controlar la compactación de los valores históricos utilizados para la convolución. De forma predeterminada, esta magnitud utiliza el valor especificado para el parámetro de tolerancia de error relativo de simulación (RELTOL), definido en la pestaña Advanced del cuadro de diálogo Advanced Analyses Settings. |
|
COMPACTABS |
Magnitud específica utilizada para controlar la compactación de los valores históricos utilizados para la convolución. De forma predeterminada, esta magnitud utiliza el valor especificado para el parámetro de tolerancia de error absoluto de corriente (ABSTOL), definido en la pestaña Advanced del cuadro de diálogo Advanced Analyses Settings. |
|
TRUNCNR |
Indicador que, al activarse, habilita el uso del método iterativo de Newton-Raphson para determinar un paso de tiempo adecuado en las rutinas de control del paso de tiempo. (Valor predeterminado = desactivado, en cuyo caso se utiliza un método de prueba y error que reduce a la mitad el paso de tiempo anterior en cada intento). |
|
TRUNCDONTCUT |
Indicador que, al activarse, elimina la reducción predeterminada del paso de tiempo destinada a limitar los errores en el cálculo de las magnitudes relacionadas con la respuesta al impulso. (Valor predeterminado = desactivado). |
Línea de transmisión RC uniformemente distribuida
Los siguientes parámetros se pueden definir para este modelo de dispositivo mediante el asistente. Al introducir un valor, el parámetro correspondiente se escribirá en el archivo MDL generado.
K |
Constante de propagación. (Valor predeterminado = 2). |
|
FMAX |
Frecuencia máxima de interés (en hercios). (Valor predeterminado = 1.0G). |
|
RPERL |
Resistencia por unidad de longitud (en ohmios/metro). (Valor predeterminado = 1000). |
|
CPERL |
Capacitancia por unidad de longitud (en faradios/metro). (Valor predeterminado = 1.0e-15). |
|
ISPERL |
Corriente de saturación por unidad de longitud (en amperios/metro). (Valor predeterminado = 0). |
|
RSPERL |
Resistencia del diodo por unidad de longitud (en ohmios/metro). (Valor predeterminado = 0). |
Modelos de dispositivos creados mediante la extracción de parámetros a partir de datos
Para los diodos y los transistores BJT, el asistente extrae información de los parámetros a partir de los datos que introduzca. Los parámetros específicos que se extraigan para incluirlos en el archivo del modelo dependerán de las características concretas del diodo o del transistor BJT que haya elegido modelar.
El método de introducción de datos varía según las características. En algunos casos, deberá introducir valores directamente y, en otros, datos de una gráfica. En cualquier caso, todos los datos procederán de mediciones directas del dispositivo, de una hoja de datos del fabricante o de una combinación de ambas fuentes.
Cuando deba introducir datos de una gráfica, introduzca una serie de puntos obtenidos de la gráfica de origen en la tabla que proporciona el asistente. Si tiene los datos almacenados en formato de valores separados por comas (*.csv), puede importarlos mediante el botón Import Data disponible. El asistente utilizará los datos que introduzca para extraer los parámetros necesarios del modelo. Los resultados de la extracción se presentan en una página posterior del asistente, tanto en forma de valores de los parámetros extraídos como en una gráfica comparativa de los datos introducidos y los valores calculados a partir de dichos parámetros. La siguiente imagen muestra un ejemplo de esta presentación de los resultados de los parámetros.

Introduzca los datos de origen para que el asistente pueda extraer los parámetros necesarios del modelo.
Puede editar los valores de los parámetros extraídos para mejorar aún más la precisión del modelo del diodo. La gráfica comparativa se actualizará para reflejar los cambios.
Diodo
Las siguientes secciones describen en detalle cada una de las características que puede elegir modelar para un diodo. Cada sección explica los parámetros que se extraen y los datos de origen que necesita el asistente para facilitar su extracción.
Flujo de corriente en polarización directa
Los siguientes parámetros se utilizan para describir las características de corriente-tensión en CC del diodo en la región de polarización directa:
IS |
Corriente de saturación (en amperios). |
|
N |
Coeficiente de emisión. |
|
RS |
Resistencia óhmica (en ohmios). |
Para extraer estos parámetros, se necesita una gráfica de la corriente directa del diodo (IF) en función de la tensión directa del diodo (VF). Esta gráfica puede obtenerse de una hoja de datos del fabricante o mediante mediciones realizadas en un dispositivo físico.
La siguiente imagen muestra un ejemplo de esta gráfica, obtenida de una hoja de datos, así como un ejemplo de circuito de prueba en el que se podrían realizar mediciones directas para obtener los datos de origen necesarios.

Ejemplo de gráfica y circuito para las características I-V del diodo en la región de polarización directa.
Los datos se introducen en el asistente como una serie de puntos obtenidos de la gráfica de origen.
Capacitancia de la unión en polarización inversa
Los siguientes parámetros se utilizan para describir la capacitancia del diodo cuando funciona en la región de polarización inversa:
CJO |
Capacitancia de la unión sin polarización (en faradios). |
|
M |
Coeficiente de gradación. |
|
VJ |
Potencial de la unión (en voltios). |
Para extraer estos parámetros, se necesita una gráfica de la capacitancia en polarización inversa (Cd) en función de la tensión inversa del diodo (VR). Esta gráfica puede obtenerse de una hoja de datos del fabricante o mediante mediciones realizadas en un dispositivo físico.
La imagen muestra un ejemplo de esta gráfica, obtenida de una hoja de datos, así como un ejemplo de circuito de prueba en el que se podrían realizar mediciones directas para obtener los datos de origen necesarios. Este último puede utilizarse si no se dispone de un medidor de capacitancia.

Ejemplo de gráfica y circuito para la capacitancia del diodo en la región de polarización inversa.
Los datos se introducen en el asistente como una serie de puntos obtenidos de la gráfica de origen.
El circuito de ejemplo de la imagen anterior se basa en la ecuación:
I = C * (dv/dt)
Al despejar C en esta ecuación, se obtiene:
C = I/(dv/dt)
El circuito genera una rampa de tensión a partir de la fuente V1. Calculando la pendiente de esta rampa de tensión, se puede obtener el término dv/dt de la ecuación. Al dividir la corriente medida del diodo entre la pendiente de la rampa de tensión, se puede obtener la curva de capacitancia del diodo.
Flujo de corriente en polarización inversa
Los siguientes parámetros se utilizan para describir el flujo de corriente en polarización inversa del dispositivo después de la ruptura:
BV |
Tensión de ruptura inversa (en voltios). |
|
IBV |
Corriente a la tensión de ruptura (en amperios). |
Para extraer estos parámetros, el asistente requiere que se introduzcan los dos valores siguientes:
-
Valor de la tensión de ruptura inversa.
-
Valor de la corriente que atraviesa el diodo en el punto de ruptura inversa.
Estos valores pueden obtenerse de una hoja de datos del fabricante o mediante mediciones realizadas en un dispositivo físico. Las hojas de datos suelen incluir las características eléctricas (CC) de un diodo en forma de tabla, por lo que basta con localizar estos valores e introducirlos exactamente como se indican.
Si los datos de origen se presentan en una gráfica, como suele ocurrir con las mediciones realizadas directamente en un dispositivo físico, deberá leer estos dos valores en el punto en el que el diodo comienza a entrar en ruptura. La siguiente imagen muestra un ejemplo de esta gráfica.

Obtención gráfica de los valores de corriente y tensión en el punto de ruptura inversa.
Aunque los valores puedan aparecer como negativos en la gráfica, al introducirlos en los campos correspondientes del asistente, deberán introducirse únicamente como valores positivos.
Características de recuperación inversa
El siguiente parámetro se utiliza para modelar el tiempo de recuperación inversa del diodo al conmutarlo de polarización directa a inversa:
TT |
Tiempo de tránsito (en segundos). |
Para extraer este parámetro, el asistente requiere que se introduzca el tiempo de recuperación inversa del diodo (Trr), en el punto en el que la corriente directa es igual a la corriente inversa (es decir, IR/IF=1). Este dato suele encontrarse en las hojas de datos del fabricante de los diodos de conmutación en forma de un simple valor numérico.
La siguiente imagen ilustra cómo aparece esta información en una hoja de datos del fabricante. El valor de interés en la imagen —el que debe introducirse en el asistente— es de 4 ns.

Obtención del tiempo de recuperación inversa de un diodo.
Transistor de unión bipolar (BJT)
Al crear un modelo de transistor de unión bipolar (BJT), el Asistente de modelos SPICE requiere que elija los datos de origen de los que se extraerá la información de los parámetros:
- Datos medidos: seleccione esta opción si los datos de origen proceden de mediciones realizadas en el dispositivo físico y desea desarrollar un modelo preciso que describa todos los aspectos del comportamiento en CC.
- Hoja de datos del fabricante: seleccione esta opción si los datos de origen proceden de una hoja de datos. Por lo general, las hojas de datos no contienen el nivel de información necesario para modelar todos los aspectos del dispositivo BJT. Sin embargo, suelen contener información suficiente para crear un modelo del dispositivo destinado a utilizarse únicamente en la región activa directa.
Las diferencias entre estas dos opciones afectan principalmente a la forma en que se extraen los parámetros que modelan las características de corriente-tensión en CC del BJT. En cuanto a las capacitancias de las uniones con polarización inversa y los tiempos de tránsito, el método de extracción de los parámetros es idéntico en ambas opciones.
Las siguientes secciones detallan cada una de las características que puede modelar para un dispositivo BJT según el tipo de datos de origen (datos medidos u hoja de datos). Se describen los parámetros extraídos en cada caso y los datos de origen que necesita el asistente para facilitar su extracción.
Características modeladas con datos medidos
Las siguientes características pueden modelarse utilizando datos obtenidos mediante mediciones directas realizadas en el dispositivo físico.
-
Forward-Bias Parameters
Los siguientes parámetros se utilizan para describir las características de corriente-tensión en CC del BJT en la región de polarización directa:
IS
Corriente de saturación de transporte (en amperios).
BF
Beta directa máxima ideal.
NF
Coeficiente de emisión de corriente directa.
RB
Resistencia de base sin polarización (en ohmios).
RC
Resistencia de colector (en ohmios).
RE
Resistencia de emisor (en ohmios).
IKF
Corriente de inicio de la caída de beta directa a corrientes elevadas (en amperios).
ISE
Corriente de saturación de fuga B-E (en amperios).
NE
Coeficiente de emisión de fuga B-E.
VAF
Tensión de Early directa (en voltios).
Las siguientes secciones detallan los datos de medición necesarios que, una vez introducidos, permitirán al asistente extraer estos parámetros.
-
Base-Emitter Voltage versus Base Current
Estos datos se utilizan para la extracción inicial del parámetro RC. La imagen siguiente muestra un ejemplo de gráfica de la tensión base-emisor (VBE) en función de la corriente de base (IB), así como un ejemplo de circuito de prueba en el que se podrían realizar mediciones para obtener los datos. El circuito inyecta una corriente en la base mientras mide la tensión base-emisor en circuito abierto.

Ejemplo de gráfica y circuito para VBE en función de IB.Los datos se introducen en el asistente como una serie de puntos de datos obtenidos de la gráfica de origen.
-
Collector-Emitter Voltage versus Base Current
Estos datos se utilizan para la extracción inicial del parámetro RE. La imagen siguiente muestra un ejemplo de gráfica de la tensión colector-emisor (VCE) en función de la corriente de base (IB), así como un ejemplo de circuito de prueba en el que se podrían realizar mediciones para obtener los datos. El circuito inyecta una corriente en la base mientras mide la tensión colector-emisor en circuito abierto.

Ejemplo de gráfica y circuito para VCE en función de IB.Los datos se introducen en el asistente como una serie de puntos de datos obtenidos de la gráfica de origen.
-
Forward Gummel Plot
Estos datos se utilizan principalmente para extraer los parámetros IS, BF, NF, RB, IKF, ISE y NE. También se utilizan para optimizar los parámetros RC, RE y VAF. La imagen siguiente muestra un ejemplo de gráfica de Gummel, así como un ejemplo de circuito de prueba en el que se podrían realizar mediciones para obtener los datos. La gráfica de Gummel representa:
-
La corriente de base en función de la tensión base-emisor (IB en función de VBE).
-
La corriente de colector en función de la tensión base-emisor (IC en función de VBE).
La tensión base-colector (VBC) se mantiene en cero voltios.

Ejemplo de gráfica de Gummel directa y circuito de prueba.Los datos se introducen en el asistente como una serie de puntos de datos obtenidos de la gráfica de Gummel de origen. Deben introducirse los valores de IB e IC sin procesar; el asistente aplicará la función LN a los datos de la curva.
-
-
Collector Current versus Base-Emitter Voltage
Estos datos se utilizan para la extracción inicial del parámetro VAF. La imagen siguiente muestra un ejemplo de gráfica de la corriente de colector (IC) en función de la tensión base-emisor (VBE), así como un ejemplo de circuito de prueba en el que se podrían realizar mediciones para obtener los datos. El circuito se utiliza para generar dos curvas de IC en función de VBE, para dos valores distintos de tensión base-colector (VBC). Las curvas deben medirse con corrientes lo más bajas posible y con VBC tan próxima a cero voltios como sea viable.

Ejemplos de gráficas y circuito para VBE en función de IC.Los datos se introducen en el asistente como una serie de puntos de datos en dos tablas, una para cada curva de datos de origen. También debe introducirse el valor utilizado para VBC en cada caso.
-
-
Reverse-Bias Parameters
Los siguientes parámetros se utilizan para describir las características de corriente-tensión en CC del BJT en la región de polarización inversa:
IS
Corriente de saturación de transporte (en amperios).
BR
Beta inversa máxima ideal.
NR
Coeficiente de emisión de corriente inversa.
RB
Resistencia de base sin polarización (en ohmios).
RC
Resistencia de colector (en ohmios).
RE
Resistencia de emisor (en ohmios).
IKR
Corriente de inicio de la caída de beta inversa a corrientes elevadas (en amperios).
ISC
Corriente de saturación de fuga B-C (en amperios).
NC
Coeficiente de emisión de fuga B-C.
VAR
Tensión de Early inversa (en voltios).
Las siguientes secciones detallan los datos de medición necesarios que, una vez introducidos, permitirán al asistente extraer estos parámetros.
-
Reverse Gummel Plot
Estos datos se utilizan principalmente para extraer los parámetros IS, BR, NR, RB, IKR, ISC y NC. También se utilizan para optimizar los parámetros RC, RE y VAR. La imagen siguiente muestra un ejemplo de gráfica de Gummel, así como un circuito de prueba de ejemplo en el que se podrían realizar mediciones para obtener los datos. La gráfica de Gummel representa:
-
Corriente de base frente a tensión base-colector (IB frente a VBC).
-
Corriente de emisor frente a tensión base-colector (IE frente a VBC).
La tensión base-emisor (VBE) se mantiene en cero voltios.

Ejemplo de gráfica de Gummel inversa y circuito de prueba.Los datos se introducen en el asistente como una serie de puntos obtenidos de la gráfica de Gummel de origen. Deben introducirse los valores de IB e IE sin procesar; el asistente aplicará la función LN a los datos de la curva.
-
-
Emitter Current versus Base-Collector Voltage
Estos datos se utilizan para la extracción inicial del parámetro VAR. La imagen siguiente muestra un ejemplo de gráfica de la corriente de emisor (IE) frente a la tensión base-colector (VBC), así como un circuito de prueba de ejemplo en el que se podrían realizar mediciones para obtener los datos. El circuito se utiliza para generar dos curvas de IE frente a VBC, para dos valores distintos de tensión base-emisor (VBE). Las curvas deben medirse con corrientes lo más bajas posible y con una VBE tan próxima a cero voltios como resulte viable.

Ejemplos de gráficas y circuito para IE frente a VBC.Los datos se introducen en el asistente como una serie de puntos en dos tablas, una para cada curva de datos de origen. También debe introducirse el valor utilizado para VBE en cada caso.
-
Características modeladas con datos de la hoja de datos del fabricante
Las siguientes características pueden modelarse utilizando datos obtenidos de la hoja de datos de un fabricante.
-
Forward-Bias Parameters
Los siguientes parámetros se utilizan para describir las características de corriente-tensión en CC del BJT en la región de polarización directa:
IS
Corriente de saturación de transporte (en amperios).
BF
Beta directa máxima ideal.
NF
Coeficiente de emisión de corriente directa.
RE
Resistencia de emisor (en ohmios).
IKF
Corriente de inicio de la caída de beta directa a altas corrientes (en amperios).
ISE
Corriente de saturación de fuga B-E (en amperios).
NE
Coeficiente de emisión de fuga B-E.
Las siguientes secciones detallan los datos necesarios que, una vez introducidos, permitirán al asistente extraer estos parámetros.
-
Base-Emitter Voltage versus Collector Current
Estos datos se utilizan para extraer los parámetros IS, NF, RE e IKF. La imagen siguiente muestra un ejemplo de gráfica de la tensión base-emisor (VBE) frente a la corriente de colector (IC), obtenida de una hoja de datos.
Los datos se introducen en el asistente como una serie de puntos obtenidos de la gráfica de origen. Deben introducirse los valores de IC sin procesar; el asistente aplicará la función LN a los datos de la curva.
También debe introducirse el valor de la relación beta forzada de la curva (β = IC/IB). En la gráfica de ejemplo de la imagen anterior, este valor se muestra en la esquina superior izquierda, por lo que se introduciría el valor 10.
-
DC Current Gain versus Collector Current
Estos datos se utilizan para extraer los parámetros BF, NE, ISE e IKF. La imagen siguiente muestra un ejemplo de gráfica de la ganancia de corriente en CC (hFE) frente a la corriente de colector (IC), obtenida de una hoja de datos.
Los datos se introducen en el asistente como una serie de puntos obtenidos de la gráfica de origen. Para garantizar la precisión, deben introducirse valores de ganancia de corriente en CC para valores bajos, medios y altos de corriente de colector.
-
-
Forward Early Voltage
El siguiente parámetro se utiliza para modelar el efecto de modulación del ancho de base en el modelo de transistor Gummel-Poon:
VAF
Tensión de Early directa (en voltios).
Para extraer este parámetro, deberá introducir un punto de la curva de admitancia de salida (hOE) frente a corriente de colector (IC). La imagen siguiente muestra un ejemplo de dicha curva.
Lea cualquier valor de la curva. En el ejemplo de la imagen anterior, podemos leer IC = 1mA y hOE = 30μmhos.
Normalmente, los datos aparecen en formato de tabla, como en el ejemplo que se muestra en la imagen siguiente.

Ejemplo de entrada en tabla para la admitancia de salida.Los valores de interés de la imagen, y los que deben introducirse en el asistente, son 1mA para la corriente de colector y 30μmhos para la admitancia de salida (normalmente se utiliza el valor máximo).
Características modeladas con datos medidos o del fabricante
Las siguientes características pueden modelarse utilizando datos obtenidos de la hoja de datos de un fabricante o de mediciones directas realizadas en un dispositivo físico.
-
Base-Emitter Capacitance
Los siguientes parámetros se utilizan para describir la capacitancia de la unión base-emisor en polarización inversa:
CJE
Capacitancia de agotamiento B-E con polarización nula (en faradios).
MJE
Factor exponencial de la unión B-E.
VJE
Potencial interno B-E (en voltios).
Para extraer estos parámetros, se necesita una gráfica de la capacitancia de la unión B-E en polarización inversa (Cj) frente a la tensión (VBE). Si no se dispone de un medidor de capacitancia, podría utilizarse el circuito de prueba de ejemplo de la imagen siguiente para obtener los datos. La imagen también muestra ejemplos de gráficas obtenidas con dicho circuito, que representan VBE y Cj en función del tiempo, respectivamente. A partir de estas gráficas, pueden leerse fácilmente los valores de VBE y Cj en los mismos instantes de tiempo.

Ejemplo de circuito y gráficas de la capacitancia de la unión B-E en polarización inversa.Los datos se introducen en el asistente como una serie de puntos obtenidos de las gráficas de origen.
El circuito de ejemplo de la imagen anterior se basa en la ecuación:
I = C * (dv/dt)Al despejar C en esta ecuación se obtiene:
C = I/(dv/dt)El circuito genera una rampa de tensión a partir de la fuente V1. Calculando la pendiente de esta rampa de tensión se puede obtener la parte
dv/dtde la ecuación. Dividiendo la corriente medida del diodo entre la pendiente de la rampa de tensión, se puede obtener la curva de capacitancia del diodo. Las dos gráficas de la imagen anterior se relacionan con el circuito de la siguiente manera:-
Gráfica superior: VBE es V1.
-
Gráfica inferior: Cj es q1[ie]/(dV1/dt).
-
-
Base-Collector Capacitance
Los siguientes parámetros se utilizan para describir la capacitancia de la unión base-colector en polarización inversa:
CJC
Capacitancia de agotamiento B-C sin polarización (en faradios).
MJC
Factor exponencial de la unión B-C.
VJC
Potencial interno de la unión B-C (en voltios).
Para extraer estos parámetros, se necesita una gráfica de la capacitancia de la unión B-C en polarización inversa (Cj) en función de la tensión (VBC). Si no se dispone de un medidor de capacitancia, se puede utilizar el circuito de prueba de ejemplo de la imagen siguiente para obtener los datos. La imagen también muestra ejemplos de gráficas obtenidas con dicho circuito, que representan VBC y Cj en función del tiempo, respectivamente. A partir de estas gráficas, se pueden leer fácilmente los valores de VBC y Cj en los mismos instantes de tiempo.

Circuito y gráficas de ejemplo para la capacitancia de la unión B-C en polarización inversa.Los datos se introducen en el asistente como una serie de puntos de datos obtenidos de la gráfica de origen.
El circuito de ejemplo de la imagen anterior se basa en la ecuación:
I = C * (dv/dt)Al despejar C en esta ecuación, se obtiene:
C = I/(dv/dt)El circuito genera una rampa de tensión a partir de la fuente V1. Calculando la pendiente de esta rampa de tensión se puede obtener la parte
dv/dtde la ecuación. Dividiendo la corriente medida del diodo entre la pendiente de la rampa de tensión, se puede obtener la curva de capacitancia del diodo. Las dos gráficas de la imagen anterior se relacionan con el circuito de la siguiente manera:-
Gráfica superior: VBC es V1.
-
Gráfica inferior: Cj es q1[ic]/(dV1/dt).
-
-
Collector-Substrate Capacitance
Los siguientes parámetros se utilizan para describir la capacitancia de la unión colector-sustrato en polarización inversa:
CJS
Capacitancia colector-sustrato sin polarización (en faradios).
MJS
Factor exponencial de la unión con el sustrato.
VJS
Potencial interno de la unión con el sustrato (en voltios).
Para extraer estos parámetros, se necesita una gráfica de la capacitancia de la unión C-S en polarización inversa (Cj) en función de la tensión (VCS). Si no se dispone de un medidor de capacitancia, se puede utilizar el circuito de prueba de ejemplo de la imagen siguiente para obtener los datos. La imagen también muestra ejemplos de gráficas obtenidas con dicho circuito, que representan VCS y Cj en función del tiempo, respectivamente. A partir de estas gráficas, se pueden leer fácilmente los valores de VCS y Cj en los mismos instantes de tiempo.

Circuito y gráficas de ejemplo para la capacitancia de la unión C-S en polarización inversa.Los datos se introducen en el asistente como una serie de puntos de datos obtenidos de la gráfica de origen.
El circuito de ejemplo de la imagen anterior se basa en la ecuación:
I = C * (dv/dt)Al despejar C en esta ecuación, se obtiene:
C = I/(dv/dt)El circuito genera una rampa de tensión a partir de la fuente V1. Calculando la pendiente de esta rampa de tensión se puede obtener la parte
dv/dtde la ecuación. Dividiendo la corriente medida del diodo entre la pendiente de la rampa de tensión, se puede obtener la curva de capacitancia del diodo. Las dos gráficas de la imagen anterior 24 se relacionan con el circuito de la siguiente manera:-
Gráfica superior: VCS es V1.
-
Gráfica inferior: Cj es q1[is]/(dV1/dt).
-
-
Transit Times
Los siguientes parámetros se utilizan para describir el tiempo de tránsito del BJT:
TF
Tiempo de tránsito directo ideal (en segundos).
TR
Tiempo de tránsito inverso ideal (en segundos).
Para extraer estos parámetros, el asistente requiere que se introduzca la frecuencia de ganancia unitaria del transistor (fT). Esta es la frecuencia a la que la ganancia de corriente del transistor se hace igual a uno. Este dato suele encontrarse en las hojas de datos del fabricante en forma de un simple valor numérico.
La imagen siguiente muestra cómo aparece esta información en la hoja de datos de un fabricante. El valor de interés en la imagen, que debe introducirse en el asistente, es 100 MHz.

Ejemplo de entrada en una tabla para el producto ganancia de corriente-ancho de banda.
Parámetros no extraídos por el asistente
Los siguientes parámetros son difíciles de extraer de los datos de medición y no suelen figurar en las hojas de datos del fabricante. El asistente no los extrae ni los añade al archivo de modelo resultante para un BJT. Aunque no estén presentes en el archivo MDL, SPICE utiliza estos parámetros al simular el dispositivo BJT, empleando sus valores predeterminados. Estos valores predeterminados se incluyen a continuación para facilitar su consulta.
IRB |
Corriente a la que la resistencia de base cae hasta el punto medio entre su valor inicial y su valor mínimo (en amperios). (Valor predeterminado = infinito). |
|
RBM |
Resistencia mínima de base a corrientes elevadas (en ohmios). (Valor predeterminado = RB). |
|
XTF |
Coeficiente de dependencia de TF con la polarización. (Valor predeterminado = 0). |
|
VTF |
Tensión que describe la dependencia de TF con VBC (en voltios). (Valor predeterminado = infinito). |
|
ITF |
Parámetro de corriente elevada para el efecto sobre TF (en amperios). (Valor predeterminado = 0). |
|
PTF |
Exceso de fase a la frecuencia=1.0/(TF*2PI)Hz (en grados). (Valor predeterminado = 0). |
|
XCJC |
Fracción de la capacitancia de agotamiento B-C conectada al nodo interno de base. (Valor predeterminado = 1). |
|
XTB |
Exponente de temperatura de beta directa e inversa. (Valor predeterminado = 0). |
|
EG |
Energía de la banda prohibida para el efecto de la temperatura sobre IS (en eV). (Valor predeterminado = 1.11). |
|
XTI |
Exponente de temperatura para el efecto sobre IS. (Valor predeterminado = 3). |
|
KF |
Coeficiente de ruido de parpadeo. (Valor predeterminado = 0). |
|
AF |
Exponente de ruido de parpadeo. (Valor predeterminado = 1). |
|
FC |
Coeficiente de la fórmula de capacitancia de la región de agotamiento en polarización directa. (Valor predeterminado = 0,5). |
|
TNOM |
Temperatura de medición del parámetro (en ˚C). (El valor predeterminado de este parámetro es igual al valor introducido para el parámetro TNOM en la página Opciones de SPICE del cuadro de diálogo Configuración del análisis. Este valor es de 27 ˚C de forma predeterminada). |
Por supuesto, puede añadir manualmente cualquiera de estos parámetros al archivo MDL y especificar los valores que desee utilizar según sus necesidades.
