Creación y mantenimiento de sus componentes y bibliotecas
Un diseño electrónico es un conjunto de componentes conectados. La parte gratificante del desarrollo de productos consiste en idear formas ingeniosas de resolver los retos de ingeniería y conectar esos componentes para crear un diseño único.
Sin embargo, una gran parte del trabajo, y para muchos diseñadores la más tediosa, consiste en crear los componentes. Aunque no resulte apasionante, los componentes se convierten en un recurso valioso para su empresa, y es esencial que representen fielmente el componente físico.
El componente que compra y suelda en la placa o utiliza en un arnés de cables es el componente físico, pero debe modelarse en cada uno de los dominios de diseño electrónico en los que desee utilizarlo.
Según los tipos de implementación de diseño que tenga previsto realizar, su componente podría incluir un símbolo para el esquema, un modelo de simulación para el simulador de circuitos, un modelo IBIS para el análisis de integridad de señal, un patrón o una huella para el diseño de la PCB, y un modelo 3D para la visualización, la comprobación de distancias de separación en 3D y la exportación al entorno CAD mecánico.
Gestión de componentes
La gestión eficaz de los datos de los componentes es esencial para el diseño electrónico, y la gestión de los componentes utilizados en un diseño siempre ha sido un elemento fundamental del software de diseño de Altium. A medida que el software ha evolucionado a lo largo de los años, las metodologías de gestión de componentes han recorrido un largo camino: desde simples bibliotecas independientes de modelos de esquemas y PCB, pasando por bibliotecas de bases de datos, hasta los componentes del espacio de trabajo, que permiten representar los componentes de diseño en un ámbito más amplio del desarrollo de productos, junto con funciones avanzadas y fáciles de usar que ofrecen una colaboración sin precedentes durante todo el proceso de diseño.
| Biblioteca del espacio de trabajo | Componentes almacenados en un espacio de trabajo conectado que proporciona una fuente única de datos de componentes actualizados y estandarizados para todo su equipo de diseño. Las funciones de búsqueda paramétrica y por facetas le permiten encontrar y colocar las piezas que necesita de forma rápida y eficiente. Estos componentes están estrechamente vinculados a la pieza física fabricada y a los datos de la cadena de suministro disponibles durante el diseño, lo que supone una mejora considerable en los costes y plazos de aprovisionamiento al fabricar el producto ensamblado. |
|
| Biblioteca de base de datos | ¿Desea vincular estrechamente los componentes de diseño con la base de datos de su empresa? Entonces, explore las bibliotecas de bases de datos. Cada registro es un componente que hace referencia a los modelos necesarios y a los datos paramétricos del componente. Los vínculos a los modelos y los parámetros se añaden al símbolo al colocarlo, convirtiéndolo en un componente de Altium Designer. | |
| Biblioteca de base de datos SVN | Una biblioteca de base de datos SVN es una extensión del modelo de biblioteca de base de datos, con la diferencia de que el símbolo y los modelos de origen se almacenan bajo control de versiones. Las bibliotecas de origen se crean, amplían y mantienen en un repositorio basado en Subversion. El vínculo al repositorio y a la base de datos externa se define en un archivo de biblioteca de base de datos SVN (*.SVNDbLib). |
|
| Vínculo a base de datos | Con este método, el archivo de vínculo a base de datos (*.DbLink) define la relación entre el componente del esquema y un registro coincidente en una base de datos. La coincidencia del registro se establece mediante la vinculación de campos clave, que puede utilizar un único campo clave (por ejemplo, un número de pieza) o varios campos clave (mediante la definición de una cláusula Where). |
|
| Biblioteca integrada | ¿Prefiere tener sus componentes empaquetados y verificados previamente en un solo archivo? Entonces, compile los modelos de origen de esquemas, PCB y simulación para generar una biblioteca integrada (*.IntLib). |
|
| Biblioteca de esquemas | Una biblioteca de esquemas (*.SchLib) puede ser una biblioteca de modelos que contiene símbolos de componentes; o bien, si se añaden vínculos a modelos y datos paramétricos a cada símbolo, se convierte en una biblioteca de componentes. |
|
| Biblioteca de PCB | Una biblioteca para almacenar modelos de huellas de PCB (*.PcbLib). Si es necesario, se puede añadir un modelo 3D a cada huella. Los modelos 3D se crean a partir de objetos de cuerpo 3D o de un modelo STEP importado en un objeto de cuerpo 3D. |
Biblioteca del espacio de trabajo
Los componentes se almacenan en su espacio de trabajo: una ubicación centralizada y segura para todos sus datos de diseño, accesible para todo su equipo de diseño. Las ventajas de utilizar componentes alojados en un espacio de trabajo son numerosas. Algunas de ellas son:
-
Single source of component data – con un espacio de trabajo accesible para todo el equipo, los ingenieros pueden obtener componentes actualizados y estandarizados desde una única ubicación segura, acceder a datos de la cadena de suministro en tiempo real y utilizar la búsqueda paramétrica y por facetas para encontrar exactamente los componentes que necesitan.
-
Design-time choice of physical components – para cualquier componente, puede elegir qué piezas de fabricante se pueden utilizar para implementar ese componente al ensamblar la placa.
-
Real-time supply-chain information – procedente de la base de datos agregada de piezas de Altium Parts Provider (que, a su vez, se conecta con los proveedores habilitados y recopila sus piezas), para que el diseñador conozca los costes y la disponibilidad actuales de las piezas elegidas, así como los de todos los proveedores que venden dichas piezas (según se define en el catálogo local de piezas del espacio de trabajo). Esta información puede añadirse a un componente en cualquier momento, incluso después de guardarlo en el espacio de trabajo, sin editarlo directamente y, por tanto, sin afectar a los diseños en los que ya se utiliza – y después puede utilizarse como parte de una lista de materiales.
-
Concurrent editing of the library – como la biblioteca del espacio de trabajo es, en esencia, un conjunto de elementos de componente alojados en dicho espacio de trabajo, varios usuarios pueden editar o crear nuevos componentes para la biblioteca de forma independiente, sin tener que esperar a que otros usuarios terminen su trabajo.
-
Component Models Reuse – un componente puede entenderse como un «contenedor» en el que se almacena toda la información paramétrica y los modelos de los distintos dominios, incluidos el símbolo del esquema, las huellas de PCB y los modelos de cableado de arneses y de simulación. Un componente no contiene los propios modelos de dominio, sino vínculos a los elementos de modelo correspondientes, que también se encuentran en un espacio de trabajo, de modo que un mismo modelo de dominio puede utilizarse en varios componentes. Si un modelo cambia, se le sugerirá actualizar todos los componentes que lo utilizan, lo que garantiza que ningún componente use un modelo desactualizado.
-
Direct Component Editing – si es necesario editar un componente, puede abrirlo para editarlo directamente desde su espacio de trabajo. Una instancia temporal del editor de componentes le permite editar todos los aspectos de ese componente, incluida la modificación de los modelos de dominio a los que hace referencia, sin necesidad de trabajar con documentos basados en archivos.
-
Use of Component Templates – aplique plantillas basadas en parámetros y en la taxonomía de componentes para que cada nuevo tipo de componente tenga automáticamente el conjunto correcto de parámetros conforme a la lista de materiales, además de automatizar los esquemas adecuados de nomenclatura, revisión y ciclo de vida.
-
Component Lifecycle Validation – si un componente se encuentra en estado de «fin de vida útil», «obsoleto» o «abandonado», recibirá una advertencia antes de intentar fabricar placas que lo utilicen.
-
Where-used Component Traceability – es posible rastrear los componentes en todos sus usos: si una pieza queda obsoleta, puede consultar en qué diseños se utilizó para saber cuáles deben actualizarse. Si un símbolo o una huella contiene un error, puede ver todos los componentes que utilizan ese símbolo o esa huella para poder corregirlos.
-
Requests of new components – un ingeniero puede enviar solicitudes de componentes nuevos (o faltantes) a los responsables de las bibliotecas y recibir una notificación cuando el componente esté disponible para que tanto el solicitante como los demás ingenieros de la empresa lo utilicen en sus diseños.
Creación de un nuevo componente de la biblioteca del espacio de trabajo
El componente físico que se monta en la placa o se utiliza en la fabricación del arnés de cables se representa como un símbolo esquemático durante la captura del diseño y como una huella de PCB para el diseño de la placa (opcionalmente, con un modelo 3D para la visualización, la comprobación de separaciones en 3D y la exportación al entorno de CAD mecánico). Un componente de diseño también puede incluir un modelo de simulación para el simulador de circuitos y un modelo IBIS para el análisis de integridad de señal. Para representar los componentes de diseño en un contexto más amplio de desarrollo de productos, se les pueden añadir una o varias opciones de piezas.
Los componentes de su proyecto de diseño pueden crearse y almacenarse en la biblioteca del espacio de trabajo de su empresa. Se colocan mediante el panel Components, que utiliza el motor de búsqueda avanzada de componentes de Altium Designer.
Los nuevos componentes de la biblioteca del espacio de trabajo se crean con el editor de componentes, donde puede definir manualmente todos los datos del componente (modelos de dominio, parámetros, opciones de piezas, etc.) o utilizar los datos obtenidos del panel Manufacturer Part Search.
Para crear un nuevo componente de la biblioteca del espacio de trabajo:
-
Seleccione un comando de creación de componentes. Puede acceder a él de las siguientes formas:
-
Seleccione el comando File » New » Component en los menús principales.
-
Seleccione File » New » Library en los menús principales y, a continuación, en el cuadro de diálogo New Library que se abre, seleccione Create Library Content » Component en la sección Workspace del cuadro de diálogo.
-
En el panel Componentes, haga clic con el botón derecho en la sección de la lista de componentes y seleccione el comando Create en el menú contextual.
-
-
En el cuadro de diálogo Create new component que se abre, elija un tipo de componente. Si hay una plantilla de componente vinculada al tipo de componente seleccionado, se utilizará para predefinir el componente con sus datos.

Acceda al cuadro de diálogo Create new component para seleccionar el tipo de componente que desea crear. -
Después de hacer clic en OK, se abre el editor de componentes en su modo de edición de un solo componente. Este proporciona una interfaz simplificada para definir o editar un único componente.
-
Defina el componente añadiendo sus detalles en el editor de componentes:
- En la sección Component del editor de componentes, defina el Name y la Description del componente. Estos detalles son esenciales para buscar el componente más adelante, cuando necesite utilizarlo en su proyecto de diseño.
-
Haga clic en el control Advanced Settings para definir o modificar otros detalles del componente, como el Id utilizado para el componente guardado en el espacio de trabajo y la Folder del espacio de trabajo de destino donde se guardará el componente.
-
En la sección Parameters del editor de componentes, defina otros detalles del componente: parámetros estándar, enlaces URL a páginas web (por ejemplo, el sitio web de un fabricante) y enlaces a hojas de datos (en cualquier formato).
-
En la sección Part Choices del editor de componentes, especifique una o varias opciones de piezas para el componente: las piezas de fabricante «permitidas» que pueden utilizarse para implementar el componente en la placa ensamblada.
-
En la sección Models del editor de componentes, añada enlaces a modelos de dominio guardados (o creados sobre la marcha) para que el componente los utilice. Un componente puede tener un símbolo esquemático y varios modelos de huella de PCB y de simulación, o bien un modelo de cableado de arnés. Un componente debe tener al menos un modelo.
-
Verifique el componente definido para asegurarse de que cumple los requisitos conforme a la configuración de la página Gestión de datos – Comprobaciones de reglas de componentes del cuadro de diálogo Preferences. Guarde el componente localmente (File » Save) y, a continuación, seleccione el comando Tools » Component Rule Check en los menús principales. Cualquier infracción detectada se mostrará en el panel Messages.
-
Una vez definido el componente, seleccione el comando File » Save to Server en los menús principales para guardarlo en el espacio de trabajo. Aparecerá el cuadro de diálogo Edit Revision, en el que podrá modificar el nombre y la descripción y añadir notas de publicación según sea necesario. El editor se cerrará después de guardar.
Podrá buscar y utilizar su nuevo componente a través del panel Componentes.
Notas
-
Para crear un nuevo componente similar a uno existente en su espacio de trabajo, puede hacer una copia de ese componente. En el panel Components, busque el componente deseado, haga clic con el botón derecho sobre él y seleccione el comando Operations » Make a copy. Se abrirá el editor de componentes con el componente predefinido a partir de los datos del componente elegido.
-
Un componente puede definirse utilizando los datos proporcionados por la funcionalidad Búsqueda de piezas del fabricante. Empiece a escribir en el campo Name y seleccione una pieza del fabricante que coincida o añada una opción de pieza al componente que está definiendo. Se abrirá el cuadro de diálogo Usar datos del componente, que ofrece controles para seleccionar los datos que desea aplicar al componente que se está creando o editando: nombre, descripción, parámetros, modelos y hojas de datos.

Los datos del componente pueden obtenerse mediante la búsqueda de piezas del fabricante. Aquí se muestra un ejemplo de cómo acceder a esta funcionalidad escribiendo el nombre de un componente en el campo Name y seleccionando una entrada coincidente en la lista emergente. -
El editor de componentes también puede funcionar en su modo de edición de componentes por lotes, que proporciona la interfaz para definir o editar varios componentes. Con el editor de componentes en su modo Single Component Editing, se accede al modo de edición por lotes seleccionando el comando Tools » Switch to Batch Editor en los menús principales del editor.
-
Para importar rápidamente sus bibliotecas existentes basadas en archivos y en bases de datos (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) al espacio de trabajo, puede utilizar el Importador de bibliotecas. El Importador de bibliotecas ofrece una solución con un solo clic que analiza automáticamente las bibliotecas seleccionadas y las importa al espacio de trabajo al que está conectado actualmente.
-
También puede crear un nuevo componente haciendo clic con el botón derecho en la entrada del espacio de trabajo conectado en el panel Projects y seleccionando el comando Create Component en el menú.
-
Para editar un componente del espacio de trabajo, haga clic con el botón derecho en la entrada de un componente en el panel Componentes y seleccione el comando Edit en el menú contextual. Se abrirá el editor de componentes en su modo Single Component Editing, con la definición del componente abierta para su edición. Realice los cambios necesarios y, a continuación, guarde la definición del componente como la siguiente revisión del componente del espacio de trabajo.
-
Del mismo modo, puede seleccionar varios componentes en el panel Componentes y seleccionar el comando Edit en el menú contextual. Si los componentes seleccionados hacen referencia a la misma plantilla de componentes, se abrirá una única instancia del editor de componentes en su modo de edición de componentes por lotes. De lo contrario, se abrirá una instancia independiente del editor de componentes para cada grupo de componentes que comparta la misma plantilla.
-
Los componentes del espacio de trabajo abiertos para su edición se muestran bajo la entrada Workspace Components en el panel Projects.
Desde el menú contextual de la entrada Workspace Component, al que se accede haciendo clic con el botón derecho, puede abrir los componentes del grupo, cerrarlos, guardarlos localmente, guardarlos en el espacio de trabajo conectado o descartar los cambios (cerrarlos sin modificaciones)
. Al utilizar el comando Close All, si se han modificado varios componentes del grupo, se mostrará un cuadro de diálogo de confirmación de guardado con opciones pertinentes para trabajar con una entidad del espacio de trabajo que se ha abierto para su edición
-
Si intenta abrir un componente del espacio de trabajo para editarlo como usuario con permisos de solo lectura, se abrirá el editor de componentes y podrá acceder a los detalles del componente, pero no podrá guardar ningún cambio en el espacio de trabajo. En este caso, la entrada de este componente del espacio de trabajo en el panel Projects se muestra con la etiqueta Local Edits Only
-
Al guardar un componente editado en la biblioteca de su espacio de trabajo, puede conservar el estado actual del ciclo de vida del componente. Esto se controla mediante la opción Preserve lifecycle state (not recommended), disponible en el cuadro de diálogo Edit Revision al volver a guardar (ver imagen). Cuando está activada, la nueva revisión del componente se establecerá automáticamente en el estado del ciclo de vida de la revisión anterior. Esta función está disponible para quienes tengan asignado el permiso de operación Allow to skip lifecycle state change for new revisions (obtenga más información sobre Cómo configurar los permisos de operaciones globales de un espacio de trabajo).
Bibliotecas de bases de datos
Altium Designer permite colocar componentes directamente desde una base de datos de la empresa mediante la creación y el uso de una Database Library. La colocación se realiza desde el panel Components, que, después de instalar una biblioteca de base de datos, permite explorar su base de datos.
Tras la colocación, la información de los parámetros de diseño puede sincronizarse entre los componentes colocados y sus correspondientes registros vinculados en la base de datos. Pueden realizarse actualizaciones completas de los componentes, incluidos el símbolo gráfico, las referencias a modelos y los parámetros. La información paramétrica de la base de datos también puede incluirse en la lista de materiales (BOM) final, lista para la adquisición de componentes.
Más información sobre Bibliotecas de bases de datos.
Bibliotecas basadas en archivos
Si necesita mantener sus componentes localmente, en su sistema de archivos, puede organizarlos en bibliotecas basadas en archivos.
Una biblioteca de Altium Designer basada en archivos es una colección arbitraria de modelos o componentes. Usted decide cómo organizar los modelos o componentes en bibliotecas. Puede estructurar sus bibliotecas por proveedores de dispositivos o agrupar los componentes por función, por ejemplo, con una biblioteca para todos los microcontroladores que utiliza su empresa.
Los símbolos de componentes de esquemáticos se crean en bibliotecas de esquemáticos (*.SchLib). Los componentes de estas bibliotecas hacen referencia a huellas y otros modelos definidos en bibliotecas de huellas independientes (*.PcbLib) y archivos de modelos. Como diseñador, puede colocar componentes desde estas bibliotecas de componentes independientes o compilar las bibliotecas de símbolos, las bibliotecas de huellas y los archivos de modelos en bibliotecas integradas (*.IntLib).
Más información sobre Bibliotecas de componentes basadas en archivos.
Modelos
Desde la perspectiva de un diseñador, un componente reúne en una sola entidad toda la información necesaria para representarlo en todos los ámbitos del diseño. En este sentido, puede considerarse un contenedor.
Cada componente es una colección de modelos vinculados y datos paramétricos del componente. Los modelos contienen la información detallada que necesita cada ámbito del diseño.
Pueden utilizarse los siguientes tipos de modelos:
| Símbolo de esquemático | El símbolo representa el componente en la hoja del esquemático. El símbolo se crea utilizando objetos de dibujo estándar y los pines añaden las propiedades eléctricas. |
| Modelo SPICE | Simule el comportamiento de los componentes conectados mediante el simulador SPICE. Los modelos SPICE suelen obtenerse de los proveedores de dispositivos. |
| Modelo de integridad de señal | Las interconexiones de la PCB se están convirtiendo en parte del circuito a medida que aumentan las velocidades de conmutación de los dispositivos y los circuitos. Los modelos IBIS describen el comportamiento de los pines, lo que permite al simulador de integridad de señal de Altium Designer analizar los trazados. |
| Huella de PCB | Cada componente necesita un lugar definido en la PCB donde montarse y conectarse; la huella es el modelo que define ese espacio en la PCB. Una huella de PCB se crea a partir de un conjunto de objetos estándar, y los pads proporcionan la conectividad. |
| Modelo 3D | Los productos electrónicos actuales son compactos, tienen sus componentes muy juntos, presentan formas poco habituales y pueden incluso incorporar una PCB plegada para encajar en la carcasa. Para diseñar un producto así, es necesario poder modelar la PCB en 3D, de modo que pueda visualizar la placa terminada, comprobar las distancias de separación en 3D y transferir la placa con sus componentes montados al entorno de CAD mecánico. Para ello, necesitará un modelo 3D de cada componente. |
Obtenga información sobre cómo crear y gestionar Símbolos, Modelos de huellas, Modelos de simulación y Modelos 3D en su espacio de trabajo.
El panel Componentes
El panel Components proporciona acceso directo a todos los componentes disponibles en Altium Designer, incluidos los del espacio de trabajo, las bases de datos y las bibliotecas basadas en archivos.
El panel obtiene los componentes de un Espacio de trabajo y de cualquier archivo de biblioteca abierto o instalado. Ofrece información detallada del componente seleccionado (parámetros, modelos, opciones de piezas, datos de proveedores, etc.), comparación de componentes y, para los componentes del espacio de trabajo, una función de búsqueda paramétrica basada en filtros que permite especificar los parámetros deseados. Gracias a los filtros dinámicos contextuales, la función de búsqueda del panel permite localizar rápidamente la pieza exacta que necesita en el espacio de trabajo conectado de su empresa.
Obtenga información sobre el panel Componentes.
El panel Búsqueda de piezas de fabricantes
También puede buscar piezas comerciales mediante el panel Manufacturer Part Search, que utiliza las funciones básicas del motor de búsqueda y la vista del panel Components. Una pieza de fabricante seleccionada puede servir de base para un nuevo componente en su espacio de trabajo conectado, o bien sus parámetros y hojas de datos pueden añadirse a un componente ya colocado.
El icono
en la entrada de una pieza indica que este componente tiene modelos asignados (símbolos esquemáticos, huellas de PCB, modelos de simulación). Al crear un nuevo componente basado en esta pieza de fabricante, también se incorporarán sus modelos. Como alternativa, puede descargar esta pieza localmente o colocarla directamente en su esquema.
Obtenga información sobre el panel Búsqueda de piezas de fabricantes.
¿Cómo continuar?
Creación de un símbolo esquemático
Creación de un componente de cableado de arnés



).
).



