Validación de un componente
Antes de guardar en el Workspace conectado un componente de Workspace Library definido/editado en el editor de componentes (en modo Single Component Editing o Batch Component Editing) y poner el componente a disposición para su uso en diseños, es fundamental asegurarse de que este componente cumple los requisitos de acuerdo con la configuración establecida. Cuando intenta guardar un componente de nuevo en el Workspace, el editor de componentes ejecuta una validación: un Component Rule Check. Esta función también puede ejecutarse manualmente en cualquier momento seleccionando el comando Tools » Component Rule Check en los menús principales. Asegúrese de haber guardado antes el componente localmente (File » Save).
Al igual que un proyecto de placa tiene un proceso de validación para detectar cualquier infracción, el editor de componentes dispone de una funcionalidad de validación de componentes. Cualquier infracción encontrada se muestra en el panel Messages.
La validación del componente comprueba una serie de posibles problemas del componente y de sus modelos definidos, tanto pruebas integradas como una variedad de tipos de infracción que el usuario puede definir a nivel global.
Las siguientes comprobaciones de validación integradas tienen todas un modo de informe de
:
Folder path not specified for component
Resumen
Esta infracción se produce cuando no se especifica una carpeta en el Workspace de destino donde debe guardarse un componente que se está definiendo en el Component Editor.
Notificación
Se mostrará una notificación en el panel Messages con el siguiente formato:
Folder path not specified for component <ItemID>
donde:
- ItemID es el ID utilizado para el componente en el Workspace.
Recomendación para la resolución
-
En el Component Editor en Single Component Editing mode, use el campo Folder en Component para especificar una carpeta en el Workspace de destino donde se guardará el componente. Para especificar manualmente una carpeta de destino, haga clic en el botón
para acceder al cuadro de diálogo Choose Folder. Busque y elija una carpeta existente o cree una nueva sobre la marcha.
-
En el Component Editor en Batch Component Editing mode, use el campo FolderPath (en el grupo de columnas Component) en la región de definición del componente del editor para especificar una carpeta en el Workspace de destino donde se guardará el componente. Para especificar manualmente una carpeta de destino, haga clic una vez dentro del campo FolderPath de un componente para mostrar el botón
y haga clic para acceder al cuadro de diálogo Choose Folder. Busque y elija una carpeta existente o cree una nueva sobre la marcha.
Component not having a unique Id
Resumen
Esta infracción se produce cuando el Item ID de un componente que se está definiendo en el Component Editor es el mismo que el Item ID de otro elemento del Workspace conectado.
Notificación
Se mostrará una notificación en el panel Messages con el siguiente formato:
Duplicate Component Id: "<ItemID>"
donde:
- ItemID es el ID utilizado para el componente en el Workspace.
Recomendación para la resolución
-
En el Component Editor en Single Component Editing mode, use el campo Id en la región Component para especificar otro ID que sea único para el contenido del Workspace conectado.
-
En el Component Editor en Batch Component Editing mode, use el campo Item ID en el grupo de columnas Component de la región de definición del componente para especificar otro ID que sea único para el contenido del Workspace conectado.
Nota
Esta infracción suele producirse cuando se sobrescribe manualmente un valor de Item ID asignado automáticamente a un componente. Para un componente nuevo creado mediante el comando File » New » Component o el panel Components panel, este campo se completa de acuerdo con la plantilla de componente definida para el tipo de componente elegido en el cuadro de diálogo Create new component dialog. Cuando no existe una plantilla, o cuando se elige la entrada <Undefined> en el cuadro de diálogo, se utiliza un esquema de nombres predeterminado; CMP-{00000}. Para un componente nuevo creado mediante el panel Explorer panel, este campo se completa de acuerdo con el esquema de nombres predeterminado especificado para la carpeta principal de ese componente. Si la carpeta principal tiene una plantilla de componente asociada, la nomenclatura de componentes definida se heredará de esa plantilla. El software asignará automáticamente el siguiente ID único disponible, basándose en ese esquema, después de analizar todo el Workspace y los identificadores del contenido existente.
Las comprobaciones definibles por el usuario se configuran en la página Data Management – Component Rule Checks page del cuadro de diálogo Preferences.
Cualquiera de las pruebas integradas que fallen o las comprobaciones definidas por el usuario con nivel de Error fatal impedirán guardar el componente en el Workspace.
Es posible que la configuración predeterminada de las comprobaciones definidas por el usuario no se adapte a sus componentes, por lo que es importante familiarizarse con las opciones y con la forma de configurarlas para que se adapten a sus diseños. A continuación encontrará información sobre cada comprobación de error definida por el usuario.
Infracciones asociadas a componentes
Duplicate component by Name
Default report mode:
Resumen
Esta infracción se produce cuando el nombre de un componente que se está definiendo en el Component Editor es el mismo que el nombre de un componente en el Workspace conectado.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Duplicate component by Name
Recomendación para la resolución
Asigne nombres diferentes y únicos a los componentes según sea necesario.
-
En el Component Editor en Single Component Editing mode, use el campo Name en la región Component para especificar otro nombre que sea único para los componentes del Workspace conectado.
-
En el Component Editor en Batch Component Editing mode, use el campo Item ID en el grupo de columnas Component de la región de definición del componente para especificar otro nombre que sea único para los componentes del Workspace conectado.
Duplicate component by PCL
Default report mode:
Resumen
Esta infracción se produce cuando un componente que se está definiendo en el Component Editor tiene una Part Choice que está siendo utilizada por otro componente en el Workspace conectado.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Duplicate component by Part Choice list
Recomendación para la resolución
Asigne Part Choices diferentes y únicas a los componentes según sea necesario.
-
En el Component Editor en Single Component Editing mode, use la región Part Choices para cambiar la lista de Part Choices del componente por una que sea única para los componentes del Workspace conectado.
-
En el Component Editor en Batch Component Editing mode, use el grupo de columnas Part Choice n de la región de definición del componente para cambiar la lista de Part Choices del componente por una que sea única para los componentes del Workspace conectado.
Invalid pin mappings
Default report mode:
Resumen
Esta infracción se produce cuando un componente que se está definiendo en el Component Editor tiene una asignación ambigua entre el símbolo del componente y la(s) huella(s). Por ejemplo, la infracción se produce si el símbolo tiene pines definidos en sus campos Designator como 1, 2, 3, mientras que la huella tiene pads definidos en sus campos Designator como B, C, E, o cuando el número de pines del símbolo es mayor que el número de pads de la huella.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Pin <PinDesignator> of the symbol <SymbolName> (<SymbolRevisionID>) does not have corresponding pad <PadDesignator> in footprint <FootprintName> (<FootprintRevisionID>)
donde:
-
PinDesignatores el Designator del pin del símbolo. -
SymbolNamees el nombre del símbolo. -
SymbolRevisionIDes el Item-Revision ID del símbolo. -
PadDesignatores el Designator del pad de la huella. -
FootprintNamees el nombre de la huella. -
FootprintRevisionIDes el Item-Revision ID de la huella.
Recomendación para la resolución
Edite el modelo agregado actualmente o seleccione otro modelo para asegurarse de que los pines del símbolo tengan una correspondencia uno a uno con los pads de la huella.
-
En el Component Editor en Single Component Editing mode:
-
haga clic en el control
situado en la parte superior derecha de la vista previa del modelo para modificar el modelo que actualmente está siendo utilizado (referenciado) por el componente en el editor temporal correspondiente para ese tipo de modelo;
-
haga clic en el control
situado en la parte superior derecha de la vista previa del modelo y elija la entrada Select Model del menú para buscar y elegir un modelo diferente o una revisión diferente de ese mismo modelo;
-
haga clic en el control
situado en la parte superior derecha de la vista previa del símbolo para acceder al panel Pins panel y cambiar directamente los destinos de pad/pin asignados haciendo clic en una celda del modelo e introduciendo el valor requerido.
-
-
En el Component Editor en Batch Component Editing mode:
-
haga clic con el botón derecho en la entrada del modelo en la región Model Links y elija el comando Edit del menú contextual para modificar el modelo que actualmente está siendo utilizado (referenciado) por el componente en el editor temporal correspondiente para ese tipo de modelo;
-
haga clic en el campo Item ID del modelo en la región Model Links y luego haga clic en el botón
para buscar y elegir un modelo diferente o una revisión diferente de ese mismo modelo.
-
Missing Component Description
Default report mode:
Resumen
Esta infracción se produce cuando no se especifica la descripción de un componente que se está definiendo en el Component Editor.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Component Description is not specified
Recomendación para la resolución
Especifique una descripción para los componentes infractores según sea necesario.
-
En el Component Editor en Single Component Editing mode, use el campo Description en la región Component para especificar una descripción.
-
En el Component Editor en Batch Component Editing mode, use el campo Description en el grupo de columnas Component de la región de definición del componente para especificar una descripción para los componentes infractores.
Missing Component Name
Default report mode:
Resumen
Esta infracción se produce cuando no se especifica el nombre de un componente que se está definiendo en el Component Editor.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Component Name is not specified
Recomendación para la resolución
Especifique un nombre para los componentes infractores según sea necesario.
-
En el Component Editor en Single Component Editing mode, use el campo Name en la región Component para especificar un nombre.
-
En el Component Editor en Batch Component Editing mode, use el campo Name en el grupo de columnas Component de la región de definición del componente para especificar un nombre para los componentes infractores.
Missing Component Type
Default report mode:
Resumen
Esta infracción se produce cuando no se especifica el tipo de un componente que se está definiendo en el Component Editor.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Component Type is not specified
Recomendación para la resolución
Especifique un tipo para los componentes infractores según sea necesario.
-
En el Component Editor en Single Component Editing mode, use el campo Type en la región Component para especificar un tipo.
-
En el Component Editor en Batch Component Editing mode, use el campo Type en el grupo de columnas Component de la región de definición del componente para especificar un tipo para los componentes infractores.
Model revision is in Inapplicable State
Default report mode:
Resumen
Esta infracción se produce cuando se detecta que un modelo vinculado que está siendo utilizado (referenciado) por una definición de componente se encuentra en un estado no aplicable. Por ejemplo, el modelo está actualmente Obsolete y, por lo tanto, no debería utilizarse. La aplicabilidad se determina mediante la opción Allowed to be used in designs en el cuadro de diálogo State Properties dialog. Desde el cuadro de diálogo Edit Lifecycle Definitions dialog, acceda a este cuadro de diálogo para el estado requerido, ya sea haciendo doble clic en la entrada del estado dentro de la definición de ciclo de vida principal o seleccionando su entrada y haciendo clic en el icono de edición que aparece Cuando esta opción está habilitada, se permite que un modelo en este estado se utilice en un componente. Se considera Applicable. Si esta opción está deshabilitada, un modelo en este estado no puede utilizarse válidamente y se considera Inapplicable (o no aplicable).
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
<ModeName> (<ModelRevisionID>) revision is in inapplicable state
donde:
-
ModelNamees el nombre del modelo. -
ModelRevisionIDes el Item-Revision ID del modelo.
Recomendación para la resolución
Elija un modelo de reemplazo o una revisión del mismo modelo que sea válida para su uso en el componente.
-
En el Component Editor en Single Component Editing mode, haga clic en el control
situado en la parte superior derecha de la vista previa del modelo y elija la entrada Select Model del menú para buscar y elegir un modelo diferente o una revisión diferente de ese mismo modelo.
-
En el Component Editor en Batch Component Editing mode, haga clic en el campo Item ID del modelo en la región Model Links y luego haga clic en el botón
para buscar y elegir un modelo diferente o una revisión diferente de ese mismo modelo.
Model revision is Out Of Date
Default report mode:
Resumen
Esta infracción se produce cuando se detecta que un modelo vinculado que está siendo utilizado (referenciado) por una definición de componente está desactualizado. Si hay disponible una revisión posterior del modelo, el campo Revision State lo reflejará mediante el texto Out of date, a la derecha del estado del ciclo de vida de la revisión actual bajo la vista previa del modelo (en el Component Editor en modo Single Component Editing), o el campo Revision Status en la región Model Links se marcará con el texto Out of date, mostrado en negrita (en el Component Editor en modo Batch Component Editing).
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
<ModelName> (<ModelRevisionID>) revision is Out of Date
donde:
-
ModelNamees el nombre del modelo. -
ModelRevisionIDes el Item-Revision ID del modelo.
Recomendación para la resolución
Actualice los enlaces de modelo del componente que estén desactualizados para que utilicen la revisión más reciente de los modelos.
-
En el Component Editor en Single Component Editing mode, haga clic en el control
situado en la parte superior derecha de la vista previa del modelo y elija la entrada Update to Latest del menú.
-
En el Component Editor en Batch Component Editing mode, haga clic con el botón derecho en cualquier parte de la entrada del modelo en la región Model Links región y elija Update to Latest Revision del menú.
Number of Pads exceeds Number of Pins
Default report mode:
Resumen
Esta infracción ocurre cuando un modelo de huella que está siendo utilizado (referenciado) por una definición de componente incluye más pads (pads SMD colocados en capas de cobre y pads pasantes metalizados) que pines de su símbolo esquemático referenciado.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Number of pads in the footprint <FootprintName> (<FootprintRevisionID>) (<FootprintNumberOfPads>) exceeds number of pins in the symbol <SymbolName> (<SymbolRevisionID>) (<SymbolNumberOfPins>)
donde:
-
FootprintNamees el nombre de la huella. -
FootprintRevisionIDes el ID de revisión del elemento de la huella. -
FootprintNumberOfPadses el número de pads de la huella. -
SymbolNamees el nombre del símbolo. -
SymbolRevisionIDes el ID de revisión del elemento del símbolo. -
SymbolNumberOfPinses el número de pines del símbolo.
Recomendación para la resolución
Edite el modelo actualmente agregado o seleccione otro símbolo/modelo de huella para asegurarse de que la huella tenga un número de pads que no exceda el número de pines del símbolo.
-
En el Editor de componentes en el modo Edición de componente único:
-
haga clic en el control
en la parte superior derecha de la vista previa del modelo para modificar el modelo que actualmente está siendo utilizado (referenciado) por el componente en el editor temporal correspondiente para ese tipo de modelo;
-
haga clic en el control
en la parte superior derecha de la vista previa del modelo y elija la entrada Select Model del menú para buscar y elegir un modelo diferente o una revisión diferente de ese mismo modelo.
-
-
En el Editor de componentes en el modo Edición por lotes de componentes:
-
haga clic con el botón derecho en la entrada del modelo en la región Model Links y elija el comando Edit del menú contextual para modificar el modelo que actualmente está siendo utilizado (referenciado) por el componente en el editor temporal correspondiente para ese tipo de modelo;
-
haga clic en el campo Item ID del modelo en la región Model Links y luego haga clic en el botón
para buscar y elegir un modelo diferente o una revisión diferente de ese mismo modelo.
-
Revision that is being edited is not latest
Default report mode:
Resumen
Esta infracción ocurre cuando la revisión del componente que se está editando no es la revisión más reciente disponible en el Workspace conectado.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
<ComponentName> (<ComponentRevisionID>) revision is Out of Date
donde:
-
ComponentNamees el Name del componente. -
ComponentRevisionIDes el ID de revisión del elemento del componente.
Recomendación para la resolución
Seleccione la revisión más reciente del componente para editarla. Para ello, busque el componente en el panel Components panel, haga clic con el botón derecho en su entrada en el panel y elija Edit.
Unrecognized combination of Manufacturer+Part Number in Part Choice
Default report mode:
Resumen
Esta infracción ocurre cuando se agrega una entrada incorrecta para la selección de pieza de un componente y el Workspace no puede recuperar la pieza.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Manufacturer+Part Number combination was not found in the available Part Sources ("Part Choice <n>")
donde:
-
nes el número secuencial de la selección de pieza infractora.
Recomendación para la resolución
Especifique una selección de pieza válida para el/los componente(s) infractor(es).
-
En el Editor de componentes en el modo Edición de componente único, elimine las selecciones de pieza no válidas de la región Part Choices y agregue nuevas selecciones de pieza correctas.
-
En el Editor de componentes en el modo Edición por lotes de componentes, introduzca valores correctos en los campos Part Choice n de la región de definición del componente. Tenga en cuenta que, mientras el valor de un campo de selección de pieza tenga una entrada incorrecta, el texto aparecerá atenuado y en cursiva. Una vez que ambas entradas sean correctas, el texto aparecerá normalmente, en color blanco.
Infracciones asociadas con huellas
Duplicate Pad Designator
Default report mode:
Resumen
Esta infracción ocurre cuando un modelo de huella vinculado a un componente que se está definiendo en el Editor de componentes tiene varios objetos Pad con el mismo valor de la propiedad Designator.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Duplicate Pad Designator On Pads Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
donde:
-
Identifier1es el identificador de la primera instancia del pad con designador duplicado, representado por la combinación red-designador y las coordenadas del pad. -
Layer1es la capa en la que está colocada la primera instancia del pad con designador duplicado. -
Identifier2es el identificador de la segunda instancia del pad con designador duplicado, representado por la combinación red-designador y las coordenadas del pad. -
Layer2es la capa en la que está colocada la segunda instancia del pad con designador duplicado.
Recomendación para la resolución
Asigne designadores diferentes y únicos a los pads del modelo de huella vinculado.
-
En el Editor de componentes en el modo Edición de componente único, haga clic en el control
en la parte superior derecha de la vista previa de la huella.
-
En el Editor de componentes en el modo Edición por lotes de componentes, haga clic con el botón derecho en la entrada de la huella en la región Model Links y elija el comando Edit del menú contextual.
El modelo de huella que actualmente está siendo utilizado (referenciado) por el componente se abrirá en el editor temporal de huellas PCB. Seleccione los pads infractores y cambie los valores de su propiedad Designator en el modo Pad mode of the Properties panel.
Duplicate Primitives
Default report mode:
Resumen
Esta infracción ocurre cuando un modelo de huella vinculado a un componente que se está definiendo en el Editor de componentes tiene objetos idénticos colocados en la misma ubicación y en la misma capa.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Duplicate Primitives: <ObjectType1> <Identifier1> on <Layer1> And <ObjectType2> <Identifier2> on <Layer2>
donde:
-
ObjectType1es el tipo de la primera instancia del objeto duplicado. -
Identifier1es el identificador de la primera instancia del objeto duplicado; la representación del identificador depende del tipo de objeto. -
Layer1es la capa en la que está colocada la primera instancia del objeto duplicado. -
ObjectType2es el tipo de la segunda instancia del objeto duplicado. -
Identifier2es el identificador de la segunda instancia del objeto duplicado; la representación del identificador depende del tipo de objeto. -
Layer2es la capa en la que está colocada la segunda instancia del objeto duplicado.
Recomendación para la resolución
Elimine los objetos duplicados del modelo de huella.
-
En el Editor de componentes en el modo Edición de componente único, haga clic en el control
en la parte superior derecha de la vista previa de la huella.
-
En el Editor de componentes en el modo Edición por lotes de componentes, haga clic con el botón derecho en la entrada de la huella en la región Model Links y elija el comando Edit del menú contextual.
El modelo de huella que actualmente está siendo utilizado (referenciado) por el componente se abrirá en el editor temporal de huellas PCB. Seleccione los objetos duplicados y elimínelos usando el atajo Delete.
Mirrored Footprint (designed on bottom layer)
Default report mode:
Resumen
Esta infracción ocurre cuando un modelo de huella vinculado a un componente que se está definiendo en el Editor de componentes tiene primitivas significativas (pads, pistas, arcos, rellenos, regiones, rectángulos, cadenas de texto, objetos keepout) colocadas en la Bottom Layer pero no tiene tales primitivas colocadas en la Top Layer.
En el editor de huellas PCB, la huella se construye para el lado superior de la placa; puede voltearse al lado inferior durante el proceso de diseño de PCB si es necesario.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Bottom Layer Component
Recomendación para la resolución
Voltee las primitivas de la huella de la Bottom Layer a la Top Layer.
-
En el Editor de componentes en el modo Edición de componente único, haga clic en el control
en la parte superior derecha de la vista previa de la huella.
-
En el Editor de componentes en el modo Edición por lotes de componentes, haga clic con el botón derecho en la entrada de la huella en la región Model Links y elija el comando Edit del menú contextual.
El modelo de huella que actualmente está siendo utilizado (referenciado) por el componente se abrirá en el editor temporal de huellas PCB. Seleccione las primitivas en la Bottom Layer y cambie su propiedad Layer en el modo correspondiente del panel Properties a la Top Layer.
Missing Pad Designator
Default report mode:
Resumen
Esta infracción ocurre cuando un modelo de huella vinculado a un componente que se está definiendo en el Editor de componentes tiene un objeto Pad sin ningún valor especificado para la propiedad Designator.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Missing Pad Designator on Pad: Pad <Identifier> on <Layer>
donde:
-
Identifieres el identificador del pad para el que no se ha especificado ningún designador, representado por la red del pad y sus coordenadas. -
Layeres la capa en la que está colocado el pad para el que no se ha especificado ningún designador.
Recomendación para la resolución
Especifique valores de designador para los pads del modelo de huella vinculado.
-
En el Editor de componentes en el modo Edición de componente único, haga clic en el control
en la parte superior derecha de la vista previa de la huella para abrir la huella que actualmente está siendo utilizada (referenciada) por el componente en el editor temporal de huellas PCB.
-
En el Editor de componentes en el modo Edición por lotes de componentes, haga clic con el botón derecho en la entrada de la huella en la región Model Links y elija el comando Edit del menú contextual.
El modelo de huella que actualmente está siendo utilizado (referenciado) por el componente se abrirá en el editor temporal de huellas PCB. Seleccione un pad infractor y especifique el valor de su propiedad Designator en el modo Pad mode of the Properties panel.
Offset Footprint Reference
Default report mode:
Resumen
Esta infracción ocurre cuando un modelo de huella vinculado a un componente que se está definiendo en el Editor de componentes tiene su punto de referencia (origen) fuera del rectángulo delimitador formado por los objetos de la huella.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Offset Component Origin
Recomendación para la resolución
Cambie la ubicación del punto de referencia para que quede dentro del rectángulo delimitador formado por los objetos de la huella.
-
En el Editor de componentes en el modo Edición de componente único, haga clic en el control
en la parte superior derecha de la vista previa de la huella para abrir la huella que actualmente está siendo utilizada (referenciada) por el componente en el editor temporal de huellas PCB.
-
En el Editor de componentes en el modo Edición por lotes de componentes, haga clic con el botón derecho en la entrada de la huella en la región Model Links y elija el comando Edit del menú contextual.
El modelo de huella que actualmente está siendo utilizado (referenciado) por el componente se abrirá en el editor temporal de huellas PCB. Utilice los comandos del submenú Edit » Set Reference de los menús principales para cambiar la ubicación actual de la referencia de la huella.
Shorted Copper
Default report mode:
Resumen
Esta infracción ocurre cuando un modelo de huella vinculado a un componente que se está definiendo en el Editor de componentes tiene objetos Pad que están conectados entre sí por objetos en una capa de cobre.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Shorted Copper Connection Between Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
donde:
-
Identifier1es el identificador de la primera instancia del pad en el par de pads en cortocircuito, representado por la combinación red-designador y las coordenadas del pad. -
Layer1es la capa en la que está colocada la primera instancia del pad en el par de pads en cortocircuito. -
Identifier2es el identificador de la segunda instancia del pad en el par de pads en cortocircuito, representado por la combinación red-designador y las coordenadas del pad. -
Layer2es la capa en la que está colocada la segunda instancia del pad en el par de pads en cortocircuito.
Recomendación para la resolución
Elimine los objetos de la capa de cobre que conectan los pads del modelo de huella vinculado.
-
En el Editor de componentes en el modo Edición de componente único, haga clic en el control
en la parte superior derecha de la vista previa de la huella.
-
En el Editor de componentes en el modo Edición por lotes de componentes, haga clic con el botón derecho en la entrada de la huella en la región Model Links y elija el comando Edit del menú contextual.
El modelo de huella que actualmente está siendo utilizado (referenciado) por el componente se abrirá en el editor temporal de huellas PCB. Seleccione los objetos de la capa de cobre que conectan los pads y luego modifíquelos para que no conecten los pads, o elimine dichos objetos.
Unconnected Copper
Default report mode:
Resumen
Esta infracción ocurre cuando un modelo de huella vinculado a un componente que se está definiendo en el Editor de componentes tiene objetos en una capa de cobre y estos objetos no están conectados a ningún objeto Pad. Cuando dicha huella se coloque en un diseño de PCB, no se asignará una red a esos objetos de la capa de cobre y se convertirán en cobre muerto.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Unconnected Copper on primitive : <ObjectType> <Identifier> on <Layer>
donde:
-
ObjectTypees el tipo de instancia del objeto que no está conectado a ningún objeto Pad en el modelo de huella. -
Identifieres el identificador del objeto que no está conectado a ningún objeto Pad en el modelo de huella; la representación del identificador depende del tipo de objeto. -
Layeres la capa en la que está colocada la instancia del objeto que no está conectado a ningún objeto Pad en el modelo de huella.
Recomendación para la resolución
Cambie el modelo de huella de modo que los objetos que actualmente no están conectados a ningún objeto Pad en el modelo de huella queden conectados a pads.
-
En el Editor de componentes en el modo Edición de componente único, haga clic en el control
en la parte superior derecha de la vista previa de la huella.
-
En el Editor de componentes en el modo Edición por lotes de componentes, haga clic con el botón derecho en la entrada de la huella en la región Model Links y elija el comando Edit del menú contextual.
El modelo de huella que actualmente está siendo utilizado (referenciado) por el componente se abrirá en el editor temporal de huellas PCB. Coloque objetos en la(s) capa(s) de cobre para formar una conexión entre los pads de la huella y los objetos que actualmente no están conectados a ningún objeto Pad, o elimine estos objetos no conectados.
Infracciones asociadas con símbolos
Different pins between modes
Default report mode:
Resumen
Esta infracción se produce cuando uno de los modos de visualización de un símbolo tiene un pin adicional.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Extra Pin in display mode <DisplayMode> of the symbol <SymbolRevisionID>. Part <PartDesignator>. Pin Name "<PinName>"
donde:
-
DisplayModees el modo específico de representación gráfica del símbolo en el que se han encontrado el/los pin(es) adicional(es). Un símbolo tiene un modo Normal y puede tener hasta 255 modos Alternate definidos. Obtenga más información sobre la creación de múltiples modos de visualización gráfica del mismo símbolo de componente. -
SymbolRevisionIDes el ID de revisión del elemento del símbolo. -
PartDesignatores el Designator de la parte del símbolo. -
PinNamees el Name del pin problemático.
Recomendación para la resolución
Esta infracción normalmente surge cuando se define un modo gráfico alternativo para un símbolo y ocurre una de las siguientes situaciones:
- Se ha agregado un pin adicional a un modo de visualización que no está especificado en otro modo de visualización, o
- Se ha especificado un pin con un Designator y/o Name diferentes de los de un pin especificado en otro modo de visualización.
No solo debe haber un número idéntico de pines entre los modos de visualización gráfica, sino que los pines también deben ser idénticos tanto en Designator como en Name. Obtenga más información sobre la creación de múltiples modos de visualización gráfica del mismo símbolo de componente.
Cambie el Designator y/o Name de los pines problemáticos para que el número de pines y sus propiedades Designator y Name sean las mismas entre los modos de visualización del símbolo, o elimine un pin adicional de un modo de visualización.
-
En el Component Editor en el modo Single Component Editing, haga clic en el control
en la parte superior derecha de la vista previa del símbolo.
-
En el Component Editor en el modo Batch Component Editing, haga clic con el botón derecho en la entrada del símbolo en la región Model Links y elija el comando Edit en el menú contextual.
El modelo de símbolo que el componente está usando actualmente (al que hace referencia) se abrirá en el editor temporal de Schematic Library. Seleccione los pines problemáticos y cambie los valores de sus propiedades Designator y/o Name en el modo Pin del panel Properties, o elimine estos pines usando el atajo Delete.
Duplicate Pin Designators
Default report mode:
Resumen
Esta infracción se produce cuando dos o más pines en el modelo de símbolo del componente tienen el mismo designador.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Duplicate Pin Designator(s) (mode <DisplayMode>): <PinDesignatorList>
donde:
-
DisplayModees el modo específico de representación gráfica del símbolo en el que se han encontrado los pines duplicados. Un símbolo tiene un modo Normal y puede tener hasta 255 modos Alternate definidos. -
PinDesignatorListes la lista separada por comas de los designadores de pin que están duplicados en el símbolo problemático.
Recomendación para la resolución
Cambie el designador de los pines problemáticos según corresponda, de modo que cada uno tenga una asignación única.
-
En el Component Editor en el modo Single Component Editing, haga clic en el control
en la parte superior derecha de la vista previa del símbolo.
-
En el Component Editor en el modo Batch Component Editing, haga clic con el botón derecho en la entrada del símbolo en la región Model Links y elija el comando Edit en el menú contextual.
El modelo de símbolo que el componente está usando actualmente (al que hace referencia) se abrirá en el editor temporal de Schematic Library. Seleccione los pines problemáticos y cambie los valores de su propiedad Designator en el modo Pin del panel Properties, o elimine estos pines usando el atajo Delete.
Missing Default Designator
Default report mode:
Resumen
Esta infracción se produce cuando el modelo de símbolo del componente no tiene especificado ningún designador predeterminado.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Missing Default Designator
Recomendación para la resolución
Especifique un designador predeterminado para el modelo de símbolo problemático.
-
En el Component Editor en el modo Single Component Editing, haga clic en el control
en la parte superior derecha de la vista previa del símbolo.
-
En el Component Editor en el modo Batch Component Editing, haga clic con el botón derecho en la entrada del símbolo en la región Model Links y elija el comando Edit en el menú contextual.
El modelo de símbolo que el componente está usando actualmente (al que hace referencia) se abrirá en el editor temporal de Schematic Library. Abra el modo Symbol del panel Properties (activo cuando no hay ningún objeto seleccionado en el espacio de diseño) y especifique el prefijo de designador requerido seguido del carácter '?' en el campo Designator (por ejemplo, C?). Los signos de interrogación en los designadores de los componentes colocados en una hoja esquemática se actualizarán con números reales durante el proceso de Design Annotation.
Missing Pin Designator
Default report mode:
Resumen
Esta infracción se produce cuando un pin en el modelo de símbolo del componente no tiene designador especificado.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Missing Pin Designator of the symbol <SymbolRevisionID>
donde:
-
SymbolRevisionIDes el ID de revisión del elemento del símbolo problemático.
Recomendación para la resolución
Especifique un designador para cada pin en el modelo de símbolo problemático.
-
En el Component Editor en el modo Single Component Editing, haga clic en el control
en la parte superior derecha de la vista previa del símbolo.
-
En el Component Editor en el modo Batch Component Editing, haga clic con el botón derecho en la entrada del símbolo en la región Model Links y elija el comando Edit en el menú contextual.
El modelo de símbolo que el componente está usando actualmente (al que hace referencia) se abrirá en el editor temporal de Schematic Library. Seleccione los pines problemáticos y especifique los valores de su propiedad Designator en el modo Pin del panel Properties, o elimine pines usando el atajo Delete.
Missing Pin Name
Default report mode:
Resumen
Esta infracción se produce cuando un pin en el modelo de símbolo del componente no tiene nombre especificado.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Missing Pin Name of the symbol <SymbolRevisionID>. Pin Designator "<PinDesignator>".
donde:
-
SymbolRevisionIDes el ID de revisión del elemento del símbolo problemático. -
PinDesignatores el Designator del pin problemático.
Recomendación para la resolución
Especifique un nombre para cada pin en el modelo de símbolo problemático.
-
En el Component Editor en el modo Single Component Editing, haga clic en el control
en la parte superior derecha de la vista previa del símbolo.
-
En el Component Editor en el modo Batch Component Editing, haga clic con el botón derecho en la entrada del símbolo en la región Model Links y elija el comando Edit en el menú contextual.
El modelo de símbolo que el componente está usando actualmente (al que hace referencia) se abrirá en el editor temporal de Schematic Library. Seleccione los pines problemáticos y especifique los valores de su propiedad Name en el modo Pin del panel Properties, o elimine estos pines usando el atajo Delete.
Nota
Solo se enumerará una instancia de infracción en el panel Messages para cada componente distinto. Un componente bien puede tener un símbolo con más de un pin sin nombre definido.
Missing Pins in Sequence
Default report mode:
Resumen
Esta infracción se produce cuando se detectan pines faltantes en la secuencia numérica de los valores de designador de pin del símbolo problemático. Por ejemplo, si el símbolo tiene pines con designadores 1, 2, 5, y no hay pines con designador 3 y 4.
Notificación
Se muestra una notificación en el panel Messages con el siguiente formato:
Missing Pin Designator In Sequence : <PinDesignatorList> [<LowerPinDesignator>..<UpperPinDesignator>]
donde:
-
PinDesignatorListes la lista separada por comas de los designadores de pin faltantes en la secuencia numérica detectada en el símbolo problemático. -
LowerPinDesignatores el valor numérico mínimo de los designadores de pin detectados en el símbolo problemático. -
UpperPinDesignatores el valor numérico máximo de los designadores de pin detectados en el símbolo problemático.
Recomendación para la resolución
En el modelo de símbolo problemático, agregue pines con los designadores de pin faltantes en la secuencia o cambie los designadores de pin para que formen una secuencia continua de valores enteros.
-
En el Component Editor en el modo Single Component Editing, haga clic en el control
en la parte superior derecha de la vista previa del símbolo.
-
En el Editor de Componentes en el modo edición por lotes de componentes, haga clic con el botón derecho en la entrada del símbolo en la región Model Links y elija el comando Edit en el menú contextual.
El modelo de símbolo que está siendo utilizado actualmente (referenciado) por el componente se abrirá en el editor temporal de Biblioteca de Esquemáticos. Usando el comando Place » Pin de los menús principales, agregue la cantidad requerida de pines y especifique los valores de su propiedad Designator en el modo Pin del panel Properties para que los designadores de pin en el símbolo formen una secuencia continua de valores enteros. También puede editar la propiedad Designator de los pines ya colocados en el símbolo.
Nota
Hay componentes que no usan numeración secuencial de pines, por ejemplo, un BGA con numeración de pines no secuencial: A1, A3, A5 (y así sucesivamente). En esta situación, se sugiere publicar el componente con esta infracción y anotar el motivo en las Notas de publicación. Como alternativa, establezca la verificación Missing Pins in Sequence en la página Data Management – Component Rule Checks del cuadro de diálogo Preferences en No Report.


