Creación de una huella de PCB

El área que ocupa el componente en la placa fabricada queda definida por su huella. Una huella típica incluye pads y la serigrafía del componente, y también puede incluir cualquier otro detalle mecánico necesario. En la huella de ejemplo que se muestra a continuación, la mayor parte del contorno del componente se define en una capa mecánica (las líneas verdes), en lugar de en la serigrafía (amarilla), porque este componente se montará de modo que sobresalga sobre un recorte de la placa.

La huella define el espacio que ocupa el componente y proporciona los puntos de conexión entre los pines/pads del componente y el trazado de pistas de la placa. 
La huella define el espacio que ocupa el componente y proporciona los puntos de conexión entre los pines/pads del componente y el trazado de pistas de la placa.

El componente que se monta sobre esa huella se puede modelar mediante objetos Cuerpo 3D. El objeto Cuerpo 3D se utiliza como contenedor en el que se puede importar un modelo en un formato MCAD genérico, como se muestra en la imagen siguiente.

Se puede importar un modelo MCAD adecuado en un objeto Cuerpo 3D.
Se puede importar un modelo MCAD adecuado en un objeto Cuerpo 3D.

Incluso con una amplia variedad de recursos que proporcionan componentes de PCB listos para usar (como el panel de búsqueda de piezas de fabricantes), es probable que en algún momento de su carrera necesite crear un componente de PCB personalizado. Las huellas de componentes de PCB se crean en el editor de huellas de PCB utilizando el mismo conjunto de objetos primitivos disponible en el editor de PCB. Además de las huellas, también se pueden guardar como componentes de PCB los logotipos de empresas, las definiciones de fabricación y otros objetos necesarios durante el diseño de la placa.

Creación de una nueva huella de PCB

Las huellas se pueden crear directamente en su espacio de trabajo conectado. Para ello:

  1. Seleccione File » New » Library en los menús principales y, a continuación, en el cuadro de diálogo New Library que se abre, seleccione Create Library Content » Footprint en la sección Workspace del cuadro de diálogo.

    Cree una nueva huella del espacio de trabajo mediante el cuadro de diálogo New Library
    Cree una nueva huella del espacio de trabajo mediante el cuadro de diálogo New Library

  2. En el cuadro de diálogo Create New Item que se abre, introduzca la información necesaria, asegúrese de que la opción Open for editing after creation esté habilitada y haga clic en OK. Se creará la huella del espacio de trabajo y se abrirá el editor temporal de huellas de PCB, con un documento .PcbLib como documento activo. Este documento recibirá un nombre según el elemento y su revisión, con el formato: <Item><Revision>.PcbLib (p. ej., PCC-001-0001-1.PcbLib). Utilice el documento para definir la huella como se describe a continuación.

    Ejemplo de edición de la revisión inicial de una huella del espacio de trabajo: el editor temporal de huellas de PCB proporciona el documento en el que definir la huella.
    Ejemplo de edición de la revisión inicial de una huella del espacio de trabajo: el editor temporal de huellas de PCB proporciona el documento en el que definir la huella.

  3. Una vez que la huella esté definida según sus necesidades, guárdela en el espacio de trabajo mediante el Save to Server control situado a la derecha de la entrada de la huella en el panel Projects. Aparecerá el cuadro de diálogo Edit Revision, en el que podrá cambiar el nombre y la descripción, y añadir notas de publicación según sea necesario. El documento y el editor se cerrarán después de guardar.

Una huella guardada en el espacio de trabajo se puede utilizar al definir un componente mediante el editor de componentes en su modo de edición de un solo componente o en su modo de edición de componentes por lotes.

Las huellas del espacio de trabajo se pueden explorar mediante el panel Components. Active la visibilidad de los modelos haciendo clic en el botón  de la parte superior del panel y seleccionando Models; a continuación, seleccione la categoría Footprints.

Para editar una huella del espacio de trabajo, haga clic con el botón derecho en su entrada en el panel Components y seleccione el comando Edit. Se abrirá de nuevo el editor temporal, con la huella abierta para su edición. Realice los cambios necesarios y, a continuación, guarde el documento como la siguiente revisión de la huella del espacio de trabajo.

 
 
 
 
 

Al guardar una huella editada en su espacio de trabajo, puede conservar su estado actual del ciclo de vida. Esto se controla mediante la opción Preserve lifecycle state (not recommended), disponible en el cuadro de diálogo Create Revision al volver a guardar (). Cuando esta opción está habilitada, la nueva revisión de la huella se establecerá automáticamente en el estado del ciclo de vida de la revisión anterior. Esta función está disponible para quienes tengan asignado el permiso operativo Allow to skip lifecycle state change for new revisions (obtenga más información sobre la configuración de permisos de operaciones globales para un espacio de trabajo).

  • Cuando realiza un cambio en una huella del espacio de trabajo, en el momento en que lo guarda como una nueva revisión de la huella, todos los componentes del espacio de trabajo que utilizan esa huella quedan desactualizados, ya que siguen utilizando la revisión anterior. En la mayoría de los casos, querrá volver a guardar esos componentes del espacio de trabajo, actualizando los enlaces a sus respectivos modelos para que utilicen las últimas revisiones disponibles. Para agilizar este proceso, el espacio de trabajo, junto con Altium Designer, permite actualizar los componentes superiores al volver a guardar una huella del espacio de trabajo, después de haber realizado modificaciones en ella mediante la función de edición directa.

    Para obtener más información sobre la actualización de componentes superiores al guardar un modelo de dominio, consulte la página Creación y edición de contenido.

  • También puede actualizar directamente, sobre la marcha, la huella del espacio de trabajo utilizada por un componente del espacio de trabajo como parte de la edición de ese componente en el editor de componentes, en su modo de edición de un solo componente o en su modo de edición de componentes por lotes.

  • Desde la perspectiva del diseñador, un componente del espacio de trabajo reúne en una sola entidad toda la información necesaria para representar ese componente en todos los dominios de diseño. Por tanto, puede considerarse un contenedor: un «depósito» en el que se almacenan todos los modelos de dominio y la información paramétrica. En cuanto a su representación en los distintos dominios, un componente del espacio de trabajo no contiene los propios modelos de dominio del espacio de trabajo, sino enlaces a esos modelos. Estos enlaces se especifican al definir el componente.

  • Las huellas de PCB también se pueden crear en el espacio de trabajo al importar bibliotecas de componentes existentes de generaciones anteriores (SchLib, PcbLib, IntLib, DbLib, SVNDbLib). La interfaz de este proceso, el Library Importer, presenta un flujo intuitivo que toma las bibliotecas seleccionadas inicialmente y las importa a su espacio de trabajo. Obtenga más información sobre el importador de bibliotecas.

  • También se puede crear una nueva huella del espacio de trabajo al definir un componente del espacio de trabajo en el editor de componentes en su modo de edición de un solo componente.

  • También se puede crear una huella como parte de una biblioteca de huellas de PCB basada en archivos.

Definición de una huella de PCB

Las huellas siempre se crean en la cara superior, independientemente de la cara de la placa en la que se coloquen finalmente, utilizando el mismo conjunto de herramientas y objetos de diseño disponibles en el editor de PCB. Los atributos específicos de cada capa, como los pads de montaje superficial y las definiciones de máscara de soldadura, se transfieren automáticamente a las capas correspondientes de la cara inferior cuando se voltea la huella al otro lado de la placa durante la colocación del componente.

Los objetos de diseño pueden colocarse en cualquier capa; sin embargo, el contorno suele crearse en la capa Top Overlay (serigrafía) y los pads en la capa multicapa (para los pines de componentes de orificio pasante) o en la capa de señal superior (para los pines de componentes de montaje superficial). Al colocar la huella en una PCB, todos los objetos que la componen se asignarán a las capas definidas para ellos.

Vistas 2D y 3D de una huella para un componente de tipo joystick. La imagen 3D muestra el modelo STEP importado para el componente. Observe que los pads y la serigrafía del componente pueden verse debajo del modelo STEP.
Vistas 2D y 3D de una huella para un componente de tipo joystick. La imagen 3D muestra el modelo STEP importado para el componente. Observe que los pads y la serigrafía del componente pueden verse debajo del modelo STEP.

Las huellas que se muestran en esta página solo sirven para ilustrar los procedimientos necesarios; sus dimensiones no son exactas. Compruebe siempre las especificaciones de una nueva huella con la hoja de datos del fabricante.

La secuencia habitual para crear manualmente la huella de un componente es la siguiente:

  1. Prepare el espacio de diseño: defina las opciones de ajuste, configure las rejillas y las guías - más información.

  2. Las huellas deben crearse alrededor del punto de referencia del espacio de diseño, situado en el centro del editor de huellas de PCB. Este punto de referencia es, en realidad, el origen relativo del espacio de diseño y es el punto por el que el cursor toma la huella del componente en las operaciones de colocación y movimiento (según el Object Snap Options actual en la página PCB Editor – General del cuadro de diálogo Preferences). Utilice las teclas de acceso rápido J, R para ir directamente al punto de referencia. Si ha olvidado desplazarse al punto de referencia antes de comenzar a crear la huella, puede llevar el pad de referencia a la huella mediante los comandos del submenú Edit » Set Reference:
    • Pin 1 - establecer el punto de referencia del componente en el pin 1 de la huella del componente.

    • Center - establecer el punto de referencia del componente en el centro de la huella del componente.

    • Location - establecer el punto de referencia del componente en una ubicación definida por el usuario.

    El punto elegido se establecerá en 0,0 : se convierte en el nuevo origen relativo y las ubicaciones de todas las primitivas se actualizarán con respecto a este punto.

  3. Coloque los pads (Place » Pad) según los requisitos del componente. Después de ejecutar el comando Colocar pad, pero antes de colocar el primer pad, pulse la tecla Tab para abrir el panel Properties y definir todas las propiedades del pad, incluidos Designator, Size and Shape, Layer y Hole Size (para un pad de orificio pasante). El designador se incrementa automáticamente al colocar los pads siguientes. Para un pad de montaje superficial, establezca Layer en Top Layer. Para un pad de orificio pasante, establezca Layer en Multi-Layer.

    Algunas huellas requieren pads con una forma irregular. Esto puede hacerse mediante objetos de pad de forma personalizada. Para obtener más información, consulte la página Personalización de una pila de pads.
    • Uno de los procedimientos más importantes al crear una nueva huella de componente es colocar los pads que se utilizarán para soldar el componente a la PCB. Estos deben colocarse en las posiciones exactas para que coincidan con los pines del dispositivo físico.
    • También debe prestarse atención al asignar designadores a los pads, ya que esta es la propiedad que Altium Designer utiliza para establecer la correspondencia con los números de pin del símbolo esquemático.
  4. Para garantizar una colocación precisa de los pads, considere configurar una rejilla específica para esta tarea. Utilice las teclas de acceso rápido Ctrl+G para abrir el cuadro de diálogo Editor de rejilla cartesiana y la tecla Q para cambiar la rejilla del sistema imperial al métrico.

  5. Para colocar un pad con precisión mientras lo mueve con el ratón, utilice las teclas de flecha del teclado para mover el cursor en incrementos de la rejilla actual. Además, si mantiene pulsado Shift, el movimiento se realizará en pasos de 10 veces el incremento de la rejilla. La ubicación X, Y actual se muestra en la barra de estado y también en la visualización superpuesta. La visualización superpuesta contiene tanto la ubicación como la diferencia entre la ubicación del último clic y la ubicación actual del cursor. Utilice el acceso rápido Shift+H para activar y desactivar la visualización superpuesta. También puede hacer doble clic para editar un pad ya colocado e introducir las ubicaciones X e Y necesarias en el panel Properties .

  6. Para comprobar la distancia entre dos puntos del espacio de diseño, utilice Reports » Measure Distance (acceso rápido Ctrl+M). Siga las indicaciones de la barra de estado.

  7. Los atributos específicos de los pads, como la máscara de soldadura y la máscara de pasta, se calculan automáticamente a partir de las dimensiones del pad y de las reglas de diseño de máscara aplicables. Aunque los ajustes de máscara pueden definirse manualmente para cada pad, hacerlo dificulta su modificación posterior durante el proceso de diseño de la placa. Normalmente, esto solo se hace cuando no es posible aplicar reglas de diseño a los pads en cuestión. Tenga en cuenta que las reglas se definen en el editor de PCB durante el diseño de la placa.

  8. Utilice pistas, arcos y otros objetos primitivos para definir el contorno del componente que aparece en la serigrafía de la PCB, en la capa Top Overlay. Si el componente se voltea a la cara inferior de la placa durante la colocación, la serigrafía se transfiere automáticamente a la capa Bottom Overlay.

  9. Coloque pistas y otros objetos primitivos en una capa mecánica para definir detalles mecánicos adicionales, como un área de colocación. Las capas mecánicas son capas de uso general. Debe asignar una función a estas capas y utilizarlas de forma coherente en todas las huellas.

  10. Coloque objetos de cuerpo 3D para definir la forma tridimensional del componente físico que se montará en la PCB.

    Un objeto de cuerpo 3D añadido a una huella puede hacer referencia a un modelo 3D cargado en el espacio de trabajo conectado.
  11. Las cadenas de designador y comentario se añaden automáticamente a la capa de serigrafía de la huella durante su colocación en el espacio de diseño de PCB. Se pueden incluir cadenas adicionales de designador y comentario colocando las cadenas especiales .Designator y .Comment en una capa mecánica.

    Al colocar cadenas de designador y comentario, es necesario definir un par de capas en el editor de PCB. Esto garantiza que las cadenas queden vinculadas a la cara de la placa en la que se monta el componente y que pasen a la otra cara de la placa cuando se voltee el componente. Para obtener más información, consulte la sección Gestión de requisitos especiales específicos de cada capa más abajo.
  12. Defina las propiedades de la huella (por ejemplo, su nombre y descripción) en la pestaña Footprint del panel Properties en su modo Library Options (activo cuando no hay ningún objeto seleccionado en el espacio de diseño; se puede acceder mediante Tools » Footprint Properties comando de los menús principales). Consulte la sección siguiente para obtener más información sobre las opciones y los controles disponibles en la pestaña Footprint del panel.

  • Para utilizar una definición estandarizada de pads y vías en todas las huellas, se puede utilizar la biblioteca de pads y vías (*.PvLib) para colocar pads y vías – más información.
  • El editor de huellas de PCB también ofrece algunos asistentes para agilizar el proceso de creación de huellas:
    • El IPC Compliant Footprint Wizard – genera una huella de PCB que cumple plenamente con la revisión B de la norma IPC 7351 – Generic Requirements for Surface Mount Design and Land Pattern Standard – más información.
    • El IPC Compliant Footprints Batch Generator – al trabajar con una biblioteca de huellas de PCB basada en archivos, utilice el IPC Compliant Footprints Batch Generator para generar rápidamente varias huellas con distintos niveles de densidad – más información.
    • El Footprint Wizard – permite seleccionar entre varios tipos de encapsulados e introducir la información correspondiente para, a continuación, crear la huella del componente – más información.

Preparación del espacio de diseño

De forma predeterminada, las cuadrículas se muestran mediante puntos. Si lo prefiere, las cuadrículas pueden mostrarse mediante líneas. Esto se configura en el cuadro de diálogo Grid Editor, al que se accede haciendo clic en el botón Properties del panel Properties, como se muestra en la imagen siguiente. También puede pulsar el atajo de teclado Ctrl+G para abrir el cuadro de diálogo.

En la imagen, la cuadrícula fina se muestra con puntos y la cuadrícula gruesa, con líneas.
En la imagen, la cuadrícula fina se muestra con puntos y la cuadrícula gruesa, con líneas.

Panel Propiedades

Al editar una huella en el editor de huellas de PCB, cuando no hay ningún objeto de diseño seleccionado en el espacio de diseño, el panel Properties muestra el Library Options.

Las siguientes secciones desplegables contienen información sobre las opciones y los controles disponibles en la pestaña General del panel:

Las siguientes secciones desplegables contienen información sobre las opciones y los controles disponibles en la pestaña Footprint del panel:

La posibilidad de definir las propiedades de la huella mediante la pestaña Footprint del panel Properties está disponible cuando la opción PCB.FootprintParameters está habilitada en el cuadro de diálogo Configuración avanzada. Cuando esta opción está deshabilitada, las propiedades de la huella se definen mediante el cuadro de diálogo PCB Library Footprint (), al que se accede seleccionando el comando Tools » Footprint Properties en los menús principales, seleccionando una entrada de huella en la región Footprints del panel PCB Library y haciendo clic en el botón Edit, o haciendo doble clic en una entrada de huella en la región Footprints del panel PCB Library.

Cuando se selecciona un objeto de diseño, el panel muestra opciones específicas para ese tipo de objeto. La siguiente tabla enumera los tipos de objetos disponibles para colocar en el espacio de diseño de huellas de PCB; haga clic en un enlace para acceder a la página de propiedades de ese objeto.

Cuerpo 3D Arco
Zona de exclusión de arco Relleno
Zona de exclusión de relleno Pad
Región Zona de exclusión de región
Texto (cadena, marco de texto) Pista
Zona de exclusión de pista Vía

Expansiones de las máscaras de soldadura y de pasta

Para comprobar que las máscaras de soldadura y/o de pasta se han definido correctamente en el editor de huellas de PCB, abra el panel Configuración de vista y active la opción de visualización () para cada capa de máscara.

El anillo que aparece alrededor del borde de cada pad, con el color de la capa de máscara de soldadura superior, representa el borde de la forma de la máscara de soldadura que sobresale desde debajo del pad multicapa en la medida definida por la expansión, porque multi-layer está en la parte superior del orden de dibujo de las capas; se dibuja encima. El Layer Drawing Order se configura en la página Editor de PCB - Visualización del cuadro de diálogo Preferences).

La imagen siguiente muestra una huella de PCB con un borde morado (el color de la capa de máscara de soldadura superior) que aparece alrededor del borde de cada pad.

Para recorrer rápidamente las capas, utilice el modo de capa única (Shift+S) en combinación con Ctrl+Shift+Wheel roll.

De forma predeterminada, la forma que se crea en las capas de máscara es la forma del pad, expandida o contraída según el valor especificado por las reglas de diseño de Expansión de la máscara de soldadura y Expansión de la máscara de pasta establecidas en la PCB en la que se coloca la huella. En algunos casos, puede que necesite anular las reglas de diseño de expansión y especificar una expansión de máscara como atributo del pad, seleccionar una forma de máscara de un conjunto estándar de formas predefinidas o crear su propia forma personalizada. En estas situaciones, puede configurar las máscaras de pasta/soldadura de un pad seleccionado en su panel Properties: más información. Como alternativa, puede colocar primitivas adecuadas (regiones, pistas, etc.) en la capa de máscara correspondiente.

En una biblioteca de PCB, todos los objetos cuya expansión de máscara de soldadura esté controlada por reglas tendrán un valor de expansión de 0 mil. Esta función está disponible cuando la opción PCB.SolderMaskZeroExpansion está activada en el cuadro de diálogo Configuración avanzada. Cuando esta opción está desactivada, el valor de expansión de la máscara de soldadura de estos objetos en una biblioteca de PCB es de 4 mil.

Compatibilidad con parámetros

Los parámetros aplicados a objetos en Altium Designer proporcionan un medio potente y flexible para añadir información adicional a un diseño de PCB. Como propiedades del objeto principal, los parámetros pueden aplicarse en distintos niveles, incluidos proyectos, documentos, plantillas y objetos individuales dentro de un documento de diseño.

Consulte el objeto Parámetro para obtener más información.

Los parámetros disponibles en el espacio de PCB pueden utilizarse para filtrar consultas, reglas de diseño, scripts y variantes, y pueden aplicarse en las huellas de componentes de PCB para invocar cadenas personalizadas en las huellas colocadas.

Parámetros mediante una orden de cambio de ingeniería

Las capacidades de gestión de parámetros de PCB se basan en funciones incluidas en el mecanismo ECO y en el documento de PCB, que permiten transferir al espacio de PCB los parámetros de componentes definidos por el usuario y conservarlos allí. Esta transferencia es unidireccional y los parámetros transferidos son de solo lectura en el entorno de PCB.

La transferencia de parámetros se realiza creando una ECO del esquemático a la PCB con el comando de menú Design » Update PCB Document.

Cuando se ejecuta la ECO (mediante el botón Execute Changes ), los nuevos parámetros de componentes del esquemático definidos por el usuario se transfieren a la referencia de huella correspondiente en el diseño de PCB. 

La detección y migración de parámetros a la PCB se determina mediante la configuración de las opciones del proyecto (Project » Project Options). En el cuadro de diálogo Project Options, configure el comportamiento de detección y modificación de diferencias en la sección Differences Associated with Parameters de la pestaña Comparator y en la sección Modifications Associated with Parameters de la pestaña ECO Generation.

Para ver los parámetros transferidos en el editor de PCB, haga doble clic en un componente para abrir el panel Properties y, a continuación, seleccione la pestaña Parameters . La pestaña mostrará los parámetros de usuario actuales que se han asignado a la huella del componente seleccionado. Los parámetros de una huella de componente seleccionada también están disponibles en el panel Components .

Enlaces a información de referencia

El entorno de PCB acepta automáticamente los parámetros predefinidos ComponentLink del esquemático. Estos se definen como pares de parámetros (descripción y URL del enlace) que normalmente establecen enlaces a datos de referencia en archivos o ubicaciones de Internet específicos, normalmente el sitio web de un fabricante o la URL de una hoja de datos.

Consulte Definición de enlaces a información de referencia en una biblioteca de esquemáticos y Acceso a enlaces a información de referencia en un documento de PCB para obtener información sobre los parámetros de enlaces de referencia.

Tanto en el espacio de diseño del esquemático como en el de la PCB, se accede a los enlaces desde el menú contextual del botón derecho al situar el cursor sobre un componente (en las opciones del submenú References). Los parámetros especializados se añaden en el panel Properties y, cuando se transfieren al espacio de PCB, aparecen como parámetros de la huella del componente. 

Parámetros en las huellas de origen

Los parámetros transferidos a la PCB pueden utilizarse para proporcionar información adicional sobre la fabricación o el funcionamiento de la placa mediante las huellas de componentes. Al añadir cadenas especiales de parámetros a las huellas en la biblioteca de origen, las cadenas personalizadas se interpretarán en la capa mecánica o de serigrafía de destino.

Puede añadirse una cadena especial que represente un parámetro definido por el usuario a la huella del componente de origen mediante el botón y la lista desplegable de cadenas especiales () del panel Properties .

En la huella de biblioteca que se muestra a continuación, la cadena especial .Designator se ha colocado en la capa Mecánica 2.

Puede añadirse una cadena especial que represente un parámetro de usuario a la huella del componente.

Cuando ese parámetro personalizado también se haya aplicado a los componentes del esquemático y los datos del parámetro se hayan transferido a la PCB, las cadenas interpretadas de la huella aparecerán tanto en la vista de la placa como en los archivos de salida generados. En este caso, la cadena especial del parámetro contiene un identificador personalizado de pieza del componente para facilitar el ensamblaje.

La aplicación de parámetros de usuario a las huellas de componentes como cadenas especiales puede satisfacer otros requisitos personalizados de PCB, incluidas las etiquetas de función para interruptores y conectores, en los que podría colocarse una cadena de parámetro «función» en la capa de serigrafía superior de las huellas de esos tipos de componentes.

Para ver el valor interpretado de las cadenas especiales en el diseño de la placa, active la opción Special Strings en la sección Additional Options de la pestaña View Options del View Configuration panel. Las cadenas especiales siempre se convierten en los archivos de salida generados.
En el editor de esquemas, si lo desea, active la opción Display Names of Special Strings that have No Value Defined en la página Schematic – Graphical Editing del cuadro de diálogo Preferences.

Consultas de parámetros

Las cadenas de parámetros del entorno PCB también son accesibles mediante el lenguaje de consultas de Altium Designer y, por tanto, están disponibles para las funciones de filtrado de objetos, incluida la función Buscar objetos similares.

Para seleccionar objetos similares, haga clic con el botón derecho en un componente y seleccione Find Similar Objects en el menú contextual para abrir el cuadro de diálogo Find Similar Objects.

El cuadro de diálogo Buscar objetos similares incluye una sección Parameters en la que se pueden seleccionar las opciones de filtrado según sea necesario.

El panel PCB Filter permite aplicar términos de consulta específicos de parámetros como criterios de filtrado y puede utilizarse para crear reglas de diseño basadas en parámetros de PCB.

Hay varios términos de consulta disponibles para trabajar con parámetros de huellas de PCB, incluidos términos de funciones específicas para convertir valores de cadena en números (como StrToNumber). Las conversiones de valores de cadena tienen en cuenta las unidades (V, mA, mV, kOhm, etc.) y permiten determinar el resultado de la consulta mediante el procesamiento numérico de una cadena de valor de parámetro.

Los tipos de unidades admitidos que pueden especificarse en las consultas son:

  • % – Porcentaje
  • A – Corriente
  • C – Temperatura
  • dB – Decibelios
  • F – Capacitancia
  • G – Conductancia
  • H – Inductancia
  • Hz – Frecuencia
  • Kg – Masa
  • m – Longitud
  • Ohm – Resistencia
  • Q – Carga
  • s – Tiempo
  • V – Tensión
  • W – Potencia
  • Z – Impedancia

Hay varios términos de consulta de parámetros disponibles para trabajar con los parámetros de huellas de componentes de PCB.

El ejemplo mostrado en el cuadro de diálogo Query Helper anterior procesa el parámetro de tensión nominal de cada componente (mediante la conversión de cadena a número – StrToNumber(Unit Value, Unit Type))  para determinar si su valor es superior a 50 V. Al aplicarlo en el panel PCB Filter, el diseño de la placa de ejemplo muestra un único componente de alta tensión, C1 (cuyo valor de tensión nominal es de 3 kV).

También se admite la notación científica E, por lo que, por ejemplo, una consulta para filtrar valores de condensadores superiores a 1 nF sería similar a:
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
Como alternativa, la función de conversión numérica podría utilizarse tanto para el ParameterValue devuelto and como para el valor de comparación:
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Reglas y scripts

Las consultas de parámetros de PCB también pueden aplicarse a scripts y reglas de diseño de Altium Designer. Estas últimas pueden realizar comprobaciones de validación del diseño físico, como detectar parámetros de huellas para evaluar la colocación de componentes o la asignación de capas. Tenga en cuenta que las funciones enumeradas en el cuadro de diálogo Query Helper anterior están disponibles en el lenguaje de scripting.

El siguiente ejemplo muestra la consulta de tensión nominal de condensadores (véase la consulta de filtrado anterior) aplicada a una regla de colocación de componentes que, al ejecutarse, comprueba valores de separación específicos para los componentes detectados como dispositivos de alta tensión (>50V).

Las reglas de diseño definidas mediante parámetros de huellas específicos, transferidos desde el entorno del esquema, pueden utilizarse para detectar condiciones personalizadas del diseño físico.

Del mismo modo, los parámetros personalizados de PCB pueden utilizarse para comprobar la compatibilidad de los componentes con las capas; por ejemplo, cuando un componente no admite soldadura por ola y, por tanto, no puede colocarse en la capa inferior. En este caso, podría aplicarse una consulta de coincidencia de objetos que procese un parámetro personalizado «WaveSoldering» (Yes/No) a la regla de capas permitidas.

La regla (por lotes) comprobará posteriormente el valor de ese parámetro del componente y generará una infracción si el componente no es compatible con su colocación en la capa inferior.

Variantes

Los parámetros transferidos a la PCB que se incluyen en variaciones del diseño (Variantes de diseño) se procesan con la selección de variantes.

En la práctica, un parámetro de componente modificado en el entorno PCB se detectará dinámicamente mediante una cadena de consulta o, por ejemplo, se mostrará en una capa de la placa mediante una cadena especial. 

Parámetros de huellas definidos por el usuario

Esta función está disponible cuando la opción PCB.FootprintParameters está activada en el cuadro de diálogo Configuración avanzada.

Altium Designer admite parámetros de huellas definidos por el usuario. La región Parameters de la pestaña Footprint del panel Properties  en su modo Library Options  puede utilizarse para ver y editar parámetros de huellas cuando no hay ningún objeto seleccionado en el espacio de diseño del editor de huellas de PCB.

Cuando el componente está colocado en la PCB, puede ver estos parámetros en el panel Properties  en el modo Component  de la pestaña Parameters .

  • Los parámetros de huellas de los componentes colocados en una PCB se propagarán a las huellas de las bibliotecas generadas mediante el comando Make PCB Library o Make Integrated Library del menú principal del editor de PCB.
  • Los parámetros de huellas son compatibles con el motor de comparación de Altium Designer y con las salidas de Pick and Place y ODB++ generadas.
Altium MCAD CoDesigner permite colocar componentes MCAD nativos en el entorno MCAD según la vinculación configurada. En algunos casos, se vinculan varias huellas con diferentes modelos a un componente (por ejemplo, un LED que puede montarse en una PCB de dos formas: verticalmente, con terminales rectos, u horizontalmente, con terminales doblados). Mediante los parámetros de huellas, ahora puede hacer referencia a los diferentes modelos MCAD desde esas distintas huellas. Obtenga más información sobre Vinculación de componentes de diseño nativos de ECAD y MCAD.

Cadenas de designador y comentario

Cadenas predeterminadas de designador y comentario

Cuando se coloca una huella en una placa, se le asignan un designador y un comentario basados en la información extraída de la vista del esquema del diseño. No es necesario definir manualmente los marcadores de posición de las cadenas de designador y comentario, ya que se añaden automáticamente cuando se coloca la huella en una placa. Las ubicaciones de estas cadenas se determinan mediante la Autoposition opción de las cadenas de designador y comentario en el panel Properties en el modo Parameter cuando se selecciona la cadena de designador o comentario en el espacio de diseño. La posición y el tamaño predeterminados de las cadenas de designador y comentario se configuran en la primitiva correspondiente de la página Editor de PCB - Valores predeterminados del cuadro de diálogo Preferences .

Cadenas adicionales de designador y comentario

Puede haber situaciones en las que necesite copias adicionales de las cadenas del designador o del comentario. Por ejemplo, su proveedor de ensamblaje necesita un plano de ensamblaje detallado con el designador dentro del contorno de cada componente, mientras que su empresa exige que el designador se sitúe justo encima del componente en la capa de serigrafía de componentes de la PCB final. Este requisito de un designador adicional se puede satisfacer incluyendo la cadena especial .Designator en la huella. También está disponible la cadena especial .Comment para especificar la ubicación de la cadena del comentario en otras capas o posiciones.

Para satisfacer los requisitos del proveedor de ensamblaje, la cadena .Designator se colocaría en una capa mecánica en el editor de huellas de PCB. Después, se podrían generar impresiones que incluyeran esta capa como parte de las instrucciones de ensamblaje del diseño.

Gestión de requisitos especiales específicos de cada capa

Un componente de PCB puede tener diversos requisitos especiales, como necesitar un punto de adhesivo o una definición de máscara de soldadura pelable. Muchos de estos requisitos especiales estarán vinculados a la cara de la placa en la que se monta el componente y deberán pasar a la otra cara de la placa cuando se voltee el componente.

En lugar de incluir un gran número de capas de propósito especial que quizá se utilicen muy pocas veces, el editor de PCB de Altium Designer permite satisfacer este requisito mediante una función denominada pares de capas. Un par de capas consta de dos capas mecánicas que se han definido como un par. Cada vez que se voltea un componente de una cara de la placa a la otra, los objetos de una capa mecánica emparejada pasan a la otra capa mecánica de ese par. Con este método, se selecciona una capa mecánica adecuada para incluir el punto de adhesivo (u otros requisitos especiales) y se define su forma utilizando los objetos disponibles. Al colocar esa huella en una placa, debe configurar el emparejamiento de capas. Esto indica al software a qué capa debe transferir los objetos cuando se voltee este componente a la otra cara de la placa. No se pueden definir pares de capas en el editor de huellas de PCB; esto se hace en el editor de PCB.

El emparejamiento de capas debe definirse before de voltear el componente. Si el emparejamiento se define después de que el componente se haya trasladado a la cara inferior, el contenido de las capas mecánicas se volteará, pero permanecerá en su capa original. Si olvida crear los pares de capas antes de voltear el componente, puede actualizar desde la biblioteca para renovar la instancia del componente colocada en la placa.

Los nombres de las capas mecánicas se pueden editar directamente desde el panel View Configurations haciendo clic con el botón derecho y seleccionando Edit Layer.

Un método habitual para gestionar el uso de las capas mecánicas consiste en asignar un número de capa específico a cada función de capa mecánica necesaria. Este método exige que todos los diseñadores sigan el mismo esquema de asignación y numeración de capas. También puede generar dificultades cuando se obtienen componentes de otras fuentes que no siguen el mismo esquema de asignación y numeración. Si se ha utilizado un esquema diferente, los objetos de diseño deben trasladarse de su capa mecánica actual a la capa mecánica asignada a esa función.

Este problema se resuelve con la introducción de la propiedad Layer Type. Cuando un componente se coloca desde una biblioteca en el editor de PCB, se copia de una biblioteca a otra o se crea mediante IPC Footprint Wizard, las asignaciones existentes de tipo de capa se hacen coincidir automáticamente, independientemente de los números de capa mecánica asignados a esos tipos de capa. Los objetos se reubican en las capas correctas según su tipo de capa. Si el software no puede encontrar una coincidencia por tipo de capa, recurrirá a la coincidencia por número de capa.

Tanto para las capas mecánicas individuales como para los pares de capas de componentes, puede seleccionar un tipo de capa de una lista predefinida. Puede acceder a los cuadros de diálogo que se muestran a continuación haciendo clic con el botón derecho en una capa individual y seleccionando el comando Edit Layer o Add Component Layer del menú.

Para obtener información detallada sobre los tipos de capas mecánicas relacionados con los componentes, consulte la página Trabajo con capas mecánicas.

Adición de altura a una huella de PCB

En el nivel más básico de representación 3D, se puede añadir información de altura a una huella de PCB. Para ello, abra el panel Properties en el modo Library Options (activo cuando no hay ningún objeto seleccionado en el espacio de diseño) e introduzca la altura recomendada para el componente en el campo Height de la pestaña Footprint del panel.

Las reglas de diseño de altura se pueden definir durante el diseño de la placa (haga clic en Design » Rules en el editor de PCB); normalmente, se comprueba la altura máxima de los componentes de una clase de componentes o dentro de una definición de recinto.

Una opción mejor para definir la información de altura sería incorporar cuerpos 3D a la huella de PCB.

Gestión de componentes con primitivas de enrutamiento

Cuando se transfiere un diseño, la huella especificada en cada componente se extrae de las bibliotecas disponibles y se coloca en la placa. A continuación, la propiedad de red de cada pad de la huella se establece con el nombre de la red conectada a ese pin del componente en el esquemático. Todos los objetos que tocan un pad se conectan a la misma red que el pad.

El editor de PCB incluye una herramienta completa de gestión de redes. Para iniciarla, seleccione Design » Netlist » Configure Physical Nets en los menús principales para abrir el cuadro de diálogo Configurar redes físicas. Haga clic en el botón Menu para acceder a un menú de opciones. Haga clic en el desplegable del encabezado New Net Name para seleccionar la red que se asignará a las primitivas sin asignar.

Huellas con varios pads conectados al mismo pin

La huella que se muestra a continuación, correspondiente a un transistor SOT223, tiene varios pads conectados al mismo pin lógico del componente en el esquemático: el pin 2. Para establecer esta conexión, se han añadido dos pads con el mismo designador: «2». Cuando se utiliza el comando Design » Update PCB en el editor de esquemáticos para transferir la información del diseño a la PCB, la sincronización resultante mostrará las líneas de conexión que llegan a ambos pads en el editor de PCB, es decir, ambos pertenecen a la misma red. Ambos se pueden enrutar.

Huella SOT223 que muestra dos pads con el designador 2.
Huella SOT223 que muestra dos pads con el designador 2.

Preparación de la serigrafía

Para ayudar a resolver los problemas habituales de diseño para fabricación (DFM) causados por la superposición de la serigrafía con el cobre expuesto y los orificios, el editor de huellas de PCB incluye una función específica para preparar la serigrafía de las huellas. Estos problemas se pueden abordar eficazmente mediante:

  • el recorte automático de líneas y arcos de serigrafía;
  • el recorte o desplazamiento automático de rellenos y regiones;
  • el desplazamiento automático de cadenas de texto de serigrafía.
También se puede acceder a la herramienta de preparación de la serigrafía al diseñar una PCB: más información.

Para acceder a la herramienta de preparación de la serigrafía en el editor de huellas de PCB, utilice el comando Tools » Silkscreen Preparation de los menús principales. Se abrirá el cuadro de diálogo Silkscreen Preparation.

Utilice el cuadro de diálogo para configurar los ajustes de recorte y desplazamiento de los objetos de serigrafía. Las opciones disponibles son:

  • Clip to Exposed Copper – active esta opción para recortar automáticamente los objetos en función del cobre expuesto.
  • Clip to Solder Mask Openings – active esta opción para recortar automáticamente los objetos en función de las aberturas de la máscara de soldadura.
  • Silkscreen Clearance – defina la separación mínima aceptable entre los objetos de serigrafía y el cobre expuesto, las aberturas de la máscara de soldadura y los orificios.
  • Min Remaining Length – si la longitud de la línea o del arco es inferior al valor definido después del recorte, los objetos se eliminarán de la huella. Tenga en cuenta que esta longitud se mide de vértice a vértice, no de borde a borde – ver imagen.
  • Move Text – active esta opción para alejar las cadenas de texto de serigrafía del cobre expuesto, de las aberturas de la máscara de soldadura y de los orificios si la distancia entre ellos es inferior a Silkscreen Clearance. El desplazamiento está limitado por el valor de Max Distance.
  • Fill & Region – seleccione una acción para los rellenos y las regiones cuando la distancia entre estos y el cobre expuesto, las aberturas de la máscara de soldadura y los orificios sea inferior a Silkscreen Clearance:
    • None – los rellenos y las regiones permanecen sin cambios.
    • Clip – los rellenos y las regiones se recortarán para mantener Silkscreen Clearance. Los rellenos se convierten en regiones cuando corresponde.
    • Move – los rellenos y las regiones se alejarán del cobre expuesto, de las aberturas de la máscara de soldadura y de los orificios. El desplazamiento está limitado por el valor de Max Distance.
  • Max Distance – defina la distancia máxima a la que pueden desplazarse las cadenas de texto, los designadores de componentes, los rellenos y las regiones para mantener Silkscreen Clearance.

Haga clic en OK para recortar o desplazar los objetos de serigrafía según la configuración del cuadro de diálogo.

Si no se puede realizar una acción en un objeto (por ejemplo, si una cadena de texto no puede desplazarse debido a la limitación de Max Distance), aparecerá un mensaje para ese objeto en el panel Messages.

A continuación se muestra un ejemplo del funcionamiento de la herramienta de preparación de serigrafía.

Javascript

Creación de una huella mediante el asistente de huellas conforme a IPC

El IPC Compliant Footprint Wizard genera una huella de PCB que cumple plenamente con la revisión B de la norma IPC 7351 - Generic Requirements for Surface Mount Design and Land Pattern Standard. En lugar de trabajar directamente con las dimensiones de la huella (como hace el Asistente de huellas), el IPC Compliant Footprint Wizard utiliza la información dimensional del propio componente y, a continuación, calcula las propiedades adecuadas de los pads y del resto de la huella de acuerdo con los algoritmos publicados por IPC.

En lugar de solicitarle que introduzca las propiedades de los pads y las pistas que se utilizan para definir la huella, el Wizard utiliza las dimensiones reales del componente como datos de entrada. Basándose en las fórmulas desarrolladas para la norma IPC-7351, el Wizard genera la huella utilizando objetos estándar de Altium Designer, como pads y pistas.

  • Este cuadro de diálogo cumple con la revisión B de la norma IPC 7351 - Requisitos genéricos para el diseño de montaje superficial y norma de patrones de conexión. IPC-7351B se publicó en 2010 y sustituye a IPC-7351A (publicada en 2007).

  • Para acceder al IPC Compliant Footprint Wizard en Altium Designer, debe estar instalada la extensión de software IPC Footprint Generator. Esta extensión se instala de forma predeterminada con Altium Designer. Puede instalarse o eliminarse manualmente.

    Para obtener más información sobre la gestión de extensiones, consulte la página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Para ejecutar el IPC Compliant Footprint Wizard, seleccione Tools » IPC Compliant Footprint Wizard en los menús principales de un documento de biblioteca de PCB.

En la página Select Component Type, elija la familia de componentes para la que desea crear una huella en la página Select Component Type. El área de vista previa situada a la derecha del asistente cambia dinámicamente para mostrar el componente seleccionado e indica también los tipos de encapsulados que se pueden generar. La siguiente tabla enumera los tipos de componentes y encapsulados compatibles con el asistente.

Nombre Descripción Encapsulados incluidos
BGA Matriz de bolas BGA, CGA
BQFP Encapsulado plano cuadrado con protectores en las esquinas BQFP
CAPAE Condensador electrolítico de aluminio CAPAE
CFP Encapsulado plano dual cerámico: terminales recortados y conformados en ala de gaviota CFP
Matriz de chips Matriz de chips Matriz de chips
DFN Encapsulado plano dual sin terminales DFN
CHIP Componentes de tipo chip, 2 pines Condensador, inductor, resistencia
CQFP Encapsulado plano cuadrado cerámico: terminales recortados y conformados en ala de gaviota CQFP
DPAK Encapsulado de transistor DPAK
LCC Portachip sin terminales LCC
LGA Matriz de contactos planos LGA
MELF Componentes MELF, 2 pines Diodo, resistencia
MOLDED Componentes moldeados, 2 pines Condensador, inductor, diodo
PLCC Portachip de plástico con terminales, cuadrado: terminales en J PLCC
PQFN Encapsulado plano cuadrado sin terminales, con contactos retraídos PQFN
PQFP Encapsulado plano cuadrado de plástico PQFP, PQFP con pad expuesto
PSON Encapsulado de contorno pequeño sin terminales, con contactos retraídos PSON
QFN Encapsulado plano cuadrado sin terminales QFN, LLP
QFN-2ROW Encapsulado plano cuadrado sin terminales, 2 filas, cuadrado QFN de doble fila
SODFL Diodo de contorno pequeño con terminales planos SODFL
Encapsulado de circuito integrado de contorno pequeño, paso de 1,27 mm: terminales en ala de gaviota SOIC, SOIC con pad expuesto SOJ
Encapsulado de contorno pequeño: terminales en J SOJ SON
Encapsulado de contorno pequeño sin terminales SON, SON con pad expuesto SOP, TSOP
Encapsulado de contorno pequeño: terminales en ala de gaviota SOP, TSOP, TSSOP SOT143/343
Transistor de contorno pequeño SOT143, SOT343 SOT223
Transistor de contorno pequeño SOT223 SOT23
Transistor de contorno pequeño 3 terminales, 5 terminales, 6 terminales SOT89
Transistor de contorno pequeño SOT89 SOTFL
Transistor de contorno pequeño con terminales planos 3 terminales, 5 terminales, 6 terminales BOBINADO
Inductor bobinado de precisión, 2 pines Inductor Las páginas siguientes del asistente cambian en función del tipo de componente seleccionado. Siga las páginas intuitivas del asistente para configurar la huella del componente según sea necesario. Algunas notas sobre el uso del IPC Compliant Footprint Wizard:
  • Todas las dimensiones se introducen en el asistente en unidades métricas (mm).

  • Las dimensiones generales del encapsulado, la información de los pines, la separación entre talones, los filetes de soldadura y las tolerancias pueden introducirse y visualizarse inmediatamente.

    La modificación de las tolerancias IPC puede dar lugar a huellas de PCB que no cumplan con IPC.

  • Se pueden introducir dimensiones mecánicas, como el área de exclusión (Courtyard), el ensamblaje y la información del cuerpo del componente (3D).

  • El Wizard permite volver a los pasos anteriores para facilitar la revisión y los ajustes.

  • Se muestran vistas previas de la huella en cada etapa. Para cada tipo de componente, la región Preview se actualiza dinámicamente para mostrar la nueva ubicación, el tamaño, etc., de varios ajustes. En la región Preview , puede hacer clic en  o  para alternar entre las vistas previas 2D y 3D.

  • Si lo desea, puede ver una vista previa del modelo STEP 3D antes de generarlo. Haga clic en Generate STEP Model Preview en cualquier página del Wizard después de seleccionar el tipo de componente para ver una vista previa del modelo STEP 3D en la región Preview.

  • Las máscaras de pasta se dividen en pequeños rellenos para los encapsulados con un pad térmico grande (de 2,1 mm x 1,6 mm o más).

  • En los encapsulados con terminales de ala de gaviota, los pads se recortan para evitar que se extiendan por debajo del cuerpo del encapsulado.

  • En los encapsulados pequeños con un pad térmico central grande, los pads periféricos se recortan para garantizar la separación requerida entre los pads de acuerdo con la norma IPC.

  • Cuando se aplica el recorte de pads, se muestra una advertencia en el cuadro de diálogo.

  • El nombre y la descripción de la huella se sugieren automáticamente según la información que introduzca en el Wizard , pero se pueden cambiar para adaptarlos a los requisitos de la organización.

  • De acuerdo con la norma IPC, el asistente admite tres variantes de huella (_L, _N, _M), cada una adaptada a una densidad de placa diferente.

  • El botón Finish se puede pulsar en cualquier etapa para generar la huella que se muestra en la vista previa actual. Si hace clic en Finish antes de completar todo el Wizard, la huella se creará utilizando los valores predeterminados del sistema para el tipo de componente seleccionado.

  • Cuando trabaje con una biblioteca de huellas de PCB basada en archivos, utilice el generador por lotes de huellas conformes con IPC para generar rápidamente varias huellas con distintos niveles de densidad.

Cuando se accede al asistente desde una biblioteca de huellas de PCB basada en archivos, está disponible la página Footprint Destination, donde puede seleccionar la ubicación en la que se guardará la huella recién creada – mostrar imagen:

  • Seleccione Existing PcbLib File si desea guardar la huella en un archivo de biblioteca de PCB existente. Puede introducir el archivo directamente en el cuadro de texto o utilizar  para abrir un cuadro de diálogo y buscar el archivo deseado.
  • Seleccione New PcbLib File si desea guardar la huella en un nuevo archivo de biblioteca de PCB. Introduzca el nombre del nuevo archivo de biblioteca de PCB en el cuadro de texto. El sistema añadirá la extensión .PcbLib al nombre del nuevo archivo de biblioteca.
  • Seleccione Current PcbLib File para guardar la huella en el archivo de biblioteca de PCB mostrado.
  • Active Produce 3D/STEP model para generar un modelo STEP 3D.
  • Si tiene una licencia válida de «MCAD Co-Designer - SOLIDWORKS(R)», puede guardar el modelo como un archivo de tipo Parasolid. Haga clic en el desplegable situado a la derecha de Format y, a continuación, seleccione Parasolid. El archivo que aparece en el cuadro de texto External File ahora es un archivo *.x_t. Este es el nombre y la ubicación del archivo que se guardará.
  • Seleccione Embedded (opción predeterminada) o External File. Seleccione External File para guardar su modelo STEP 3D como un archivo externo. El tipo de archivo predeterminado es STEP y el nombre del archivo aparece en el cuadro de texto External File con *.step como extensión de archivo. Si lo desea, haga clic en  para buscar y seleccionar la carpeta en la que guardar el modelo STEP 3D generado.

Creación de una huella mediante el asistente de huellas

El editor de huellas de PCB incluye un Footprint Wizard. Este Wizard le permite seleccionar entre varios tipos de encapsulado e introducir la información correspondiente para crear la huella del componente. Tenga en cuenta que, en el Footprint Wizard, debe introducir los tamaños necesarios para los pads y la serigrafía del componente.

Para iniciar el Footprint Wizard, seleccione Tools » Footprint Wizard en los menús principales o haga clic con el botón derecho en el espacio de diseño y elija el comando Tools » Footprint Wizard en el menú contextual.

Utilice la página Component patterns para especificar el patrón del componente que desea crear. Seleccione el patrón deseado en la lista y, a continuación, utilice el desplegable para seleccionar la unidad del componente (Imperial (mil) o Metric (mm)). Los patrones disponibles son:

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

Las páginas siguientes del asistente cambian en función del patrón de componente seleccionado. Siga las intuitivas páginas del asistente para configurar la huella del componente según sus necesidades.

Al configurar el estilo de nomenclatura de los pads para una huella del patrón Edge Connectors, Leadless Chip Carriers (LCC) o Quad Packs (QUAD), haga clic en la flecha verde para cambiar el orden o la dirección de la nomenclatura – mostrar imagen.

Generación de un informe de componente

Para generar un informe de la huella de PCB activa, elija el comando Reports » Component en los menús principales. Tras ejecutar el comando, se generará el informe (<PCBLibraryDocumentName>.CMP) en la misma carpeta que el documento de biblioteca de PCB de origen y se abrirá automáticamente como documento activo en la ventana principal de diseño. El informe incluye información sobre las dimensiones de la huella y un desglose de los objetos primitivos que la componen, así como las capas en las que se encuentran.

El informe se añadirá al panel Projects como documento independiente en la subcarpeta Documentation\Text Documents.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents