Guida di esempio di PDN Analyzer (by CST)

A colpo d'occhio

Questa guida illustra come utilizzare PDN Analyzer (by CST) in Altium Designer: dall'impostazione dei parametri delle reti per la simulazione PI-DC all'esecuzione dell'analisi, fino all'interpretazione dei risultati per migliorare in modo iterativo l'integrità dell'alimentazione nel progetto PCB. Presenta inoltre l'organizzazione dell'interfaccia, i progetti di esempio disponibili, il flusso di lavoro per l'identificazione delle reti, i controlli di simulazione e le principali opzioni del pannello per creare e gestire reti di alimentazione direttamente dai dati del progetto caricato. Se cerchi una panoramica pratica di come integrare PDN Analyzer nel processo di progettazione e di dove trovare gli strumenti necessari, questo articolo ti aiuterà a orientarti e a prepararti per ulteriori approfondimenti.

- Comprenderai il flusso di lavoro di base di PDN Analyzer, incluso come configurare, eseguire e riutilizzare le simulazioni man mano che il progetto PCB viene modificato.
- Scoprirai come è organizzata l'interfaccia di PDN Analyzer, comprese le modalità di disposizione, le opzioni di ancoraggio, le viste delle reti e i punti di accesso alla configurazione e ai risultati.
- Imparerai quali progetti di esempio e opzioni integrate sono disponibili per identificare le reti in corrente continua, gestire i file di simulazione e lavorare con le strutture delle reti di alimentazione.
Approfondisci con l'IA:

Per le più recenti funzionalità di analisi dell'integrità dell'alimentazione in continua, scopri Power Analyzer by Keysight di Altium.

L'applicazione PDN Analyzer (PDNA) è relativamente semplice da usare e prevede essenzialmente l'impostazione dei parametri delle reti per la simulazione PI-DC, l'esecuzione della simulazione e l'interpretazione dei risultati. I dati utilizzati in una simulazione delle reti di alimentazione con PDN Analyzer vengono ricavati direttamente dal progetto PCB attualmente caricato, che può essere modificato in modo iterativo per migliorare l'integrità dell'alimentazione lungo i percorsi di distribuzione. La simulazione PDN può quindi essere eseguita nuovamente per verificare i risultati.

Questa guida dimostrativa all'uso di PDN Analyzer utilizza due progetti di riferimento disponibili presso Altium:

Inoltre, l'installazione di PDN Analyzer include il progetto PCB SpiritLevel con diversi esempi di file di configurazione dell'analisi. Accedi al progetto e agli esempi tramite l'opzione di menu File » Explore Samples di PDNA, quindi decomprimili.

Le informazioni di questa guida presuppongono che PDN Analyzer sia disponibile nella tua installazione di Altium Designer e che tu abbia una conoscenza di base dei principi PI-DC (integrità dell'alimentazione in continua) utilizzati.

Consulta la pagina di PDN Analyzer per informazioni sull'accesso alle funzionalità di PDN Analyzer e sui concetti di base della simulazione PI-DC.

Interfaccia di PDN Analyzer

L'interfaccia dell'estensione PDN Analyzer si apre come finestra non modale di Altium Designer, che può essere posizionata in qualsiasi punto comodo dell'area di lavoro o su un altro schermo, se disponibile. Per aprire la finestra principale PDN Analyzer, apri un documento schematico o PCB di un progetto e seleziona l'applicazione dal menu Tools (Tools » PDN Analyzer).

L'interfaccia grafica di PDN Analyzer con una singola rete di alimentazione selezionata. Le configurazioni di visualizzazione e dei risultati sono disponibili nella sezione inferiore del pannello.L'interfaccia grafica di PDN Analyzer con una singola rete di alimentazione selezionata. Le configurazioni di visualizzazione e dei risultati sono disponibili nella sezione inferiore del pannello.

L'interfaccia grafica della finestra PDNA presenta una sezione superiore dedicata alla gestione di file e reti e a una rappresentazione interattiva delle reti di alimentazione attualmente selezionate, mentre la sezione inferiore del pannello consente di accedere alle opzioni di analisi, alle impostazioni di visualizzazione e ai dati dei risultati. La versione 2 di PDNA supporta più reti interconnesse, consentendo di analizzare l'integrità dell'alimentazione in continua di un intero progetto PCB come struttura gerarchica o come singole reti di alimentazione.

L'interfaccia grafica di PDN Analyzer con l'intera gerarchia delle reti di alimentazione selezionata. La visualizzazione delle reti e dei layer inclusi si controlla nella sezione inferiore del pannello.L'interfaccia grafica di PDN Analyzer con l'intera gerarchia delle reti di alimentazione selezionata. La visualizzazione delle reti e dei layer inclusi si controlla nella sezione inferiore del pannello.

L'interfaccia PDN offre anche una modalità di visualizzazione compatta (File » Compact Layout) che non include la sezione inferiore del pannello, ideale per l'ancoraggio orizzontale o verticale nella schermata principale di Altium Designer. Per abilitare l'ancoraggio nella modalità compatta o standard, fai clic con il pulsante destro del mouse sulla barra del titolo dell'interfaccia PDNA, seleziona Allow Dock dal menu contestuale e scegli l'opzione Horizontally o Vertically.

Consulta la sezione espandibile qui sotto per i dettagli sull'interfaccia utente del pannello PDN Analyzer. 

Identificazione delle net CC

Quando PDN Analyzer viene aperto per la prima volta per un progetto PCB, tenta di identificare tutte le reti di alimentazione CC a partire dai dati delle net del progetto, basandosi sulla nomenclatura comunemente utilizzata per le reti di alimentazione.  Se non sono state identificate tutte le potenziali net di alimentazione, deseleziona le opzioni di filtro Qualifiers appropriate oppure seleziona l'opzione Enable all nets for filtering per visualizzare tutte le net.

Utilizza le caselle di controllo Select per scegliere quali net di alimentazione rendere disponibili all'analizzatore PDNA e immetti i livelli di tensione appropriati nei rispettivi campi Nominal Voltage. Fai clic sul pulsante Add Selected per popolare l'elenco Currently Identified DC Nets e confermare queste net come reti di alimentazione identificate.

Nota che facendo doppio clic su una net nell'elenco della finestra di dialogo, questa verrà individuata nel layout PCB tramite il cross-probing.

È possibile identificare e applicare ulteriori reti durante la configurazione dell'analisi PDN selezionando il pulsante DC Nets nell'interfaccia grafica dell'analizzatore.

Gli esempi di analisi riportati di seguito illustrano le principali capacità e funzionalità di PDN Analyzer. Ogni esempio mostra solo una delle numerose configurazioni dei parametri che possono essere utilizzate per valutare l'integrità dell'alimentazione della rete in modi diversi, a seconda dell'aspetto di interesse. Un'analisi completata correttamente può essere salvata come file di configurazione PDNA (*.pdna) e ricaricata in qualsiasi momento – File » Save As e File » Open (per impostazione predefinita, nella cartella PDNAnalyzer_Config del progetto)

Esempio 1

Questo esempio illustra le nozioni di base per configurare una simulazione dell'integrità dell'alimentazione con una semplice rete di alimentazione e i relativi carichi di corrente. La simulazione è configurata per valutare la distribuzione della linea di alimentazione a 5 V e il relativo percorso di ritorno a massa nel progetto di riferimento SpiritLevel-SL1, con il display LCD del progetto come carico. In questo caso, la linea di alimentazione 5V viene considerata una semplice sorgente di tensione e le reti a essa collegate (ad esempio tramite l'interruttore S1) non sono incluse.

Le condizioni preliminari per questo esempio di simulazione PDN sono:

  • il progetto PCB Spirit Level è aperto in Altium Designer
  • l'applicazione PDN Analyzer è attiva (Tools » PDN Analyzer)
  • le reti CC del progetto PCB sono state identificate nella finestra di dialogo PDN Analyzer DC Net Identification, come descritto sopra.

Iniziare il processo di analisi specificando le reti di alimentazione e di massa. Fare doppio clic sugli elementi <Power Net> e <Ground Net> nella rappresentazione grafica della rete nell'interfaccia per aprire la finestra di dialogo Choose Net, che consente di scegliere tra le reti di alimentazione identificate.

Se necessario, utilizzare le opzioni di qualificazione/filtro della finestra di dialogo per restringere o ampliare l'elenco delle reti, oppure tornare alla schermata principale e selezionare il pulsante  per identificare nuovamente le reti di alimentazione CC.

Ora è possibile aggiungere un elemento sorgente o carico tra le reti di alimentazione e di massa specificate: gli indicatori di stato della massa e dell'alimentazione passano allo stato con segno di spunta (✔). Fare clic con il pulsante destro del mouse nell'area di lavoro della rappresentazione grafica della rete e selezionare Add Source (o Add Load) dal menu contestuale per aprire la finestra di dialogo Device Properties. I passaggi, come indicato nella finestra di dialogo, sono i seguenti:

  1. Per aggiungere una sorgente di alimentazione alla rete, in questo caso una semplice sorgente di tensione, selezionare l'opzione Voltage Source dal menu a discesa Device Type della finestra di dialogo.
  2. Nell'elenco delle connessioni della sorgente, PDNA tenterà di scegliere le opzioni di connessione alle reti corrette in base ai parametri della rete di alimentazione: in questo caso, tra le reti 5V e GND. Utilizzare le opzioni del menu a discesa Refdes per specificare i punti di connessione dei componenti per la tensione sorgente. In questo esempio, il punto della tensione sorgente è impostato su TP1 e il relativo ritorno a massa sulla presa di ingresso CC del progetto J1 (pin 2 e 3).
  3. Nella sezione inferiore della finestra di dialogo, i parametri della sorgente specificano gli attributi del modello di simulazione della sorgente di tensione. Qui, la tensione sorgente (Vout) è impostata su 5V e la resistenza interna del modello (Rout) viene lasciata sull'impostazione predefinita 0Ω.
  4. Infine, la corrente massima della sorgente e la corrente dei pin (per le sorgenti con più pin di uscita) vengono lasciate sulle impostazioni predefinite (0A: Don't Care). Quando i Limits sono impostati su valori di corrente specifici, l'analisi PDN segnalerà una violazione se i risultati della simulazione superano tali valori.

Seguendo lo stesso approccio utilizzato per aggiungere una sorgente alla rete, aggiungere un carico e specificarne i parametri nella finestra di dialogo Device Properties.

In questo caso viene aggiunto un carico ad assorbimento di corrente (Device Type: IC (Current)) per rappresentare la corrente assorbita dalla linea a 5 V dal componente LCD del progetto. È disponibile anche un'opzione di carico puramente resistivo, selezionando  Resistor come Device Type.

Impostare la connessione del carico su LCD1 e specificare la Load Current che assorbirà dall'alimentazione a 5 V: sono supportati i prefissi delle unità di misura (ad esempio, 500m per rappresentare 0.5A). Sebbene le impostazioni Limits della tensione siano facoltative, qui sono state impostate su  +/-10% (utilizzando il relativo pulsante), in modo da segnalare una violazione nella simulazione se la tensione sul carico stesso scende al di sotto di 4,5 V (o supera 5,5 V).

Una volta definita la rete di alimentazione e specificati tutti i parametri (tutti gli elementi della rete presentano lo stato ✔), è possibile eseguire l'analisi PDN selezionando il pulsante . L'avanzamento della simulazione viene mostrato nella scheda Messages sotto forma di flusso di eventi, che indica anche la causa di un eventuale errore della simulazione qualora il processo non riesca a completarsi.

Quando viene eseguita un'analisi, la configurazione corrente della simulazione, ovvero le reti, le sorgenti/i carichi specificati e i relativi parametri, viene memorizzata insieme ai dati dei risultati dell'analisi (File » Explore; vedere la cartella PDNAnalyzer_Ouput). Questa configurazione può essere ripristinata in qualsiasi momento per la simulazione corrente facendo clic con il pulsante destro del mouse sul nome della simulazione e scegliendo Revert dal menu contestuale.

I risultati immediati dell'analisi PDN sono visibili nella rappresentazione grafica della rete, che include i livelli di tensione e corrente calcolati per il carico/la sorgente (ove applicabile) ed evidenzia le sezioni della rete che hanno causato una violazione dei parametri. La scheda Visual è ora selezionata e attiva.

Passare il cursore su un qualsiasi elemento della rete (carico, sorgente o elemento in serie) per visualizzare ulteriori informazioni, come i parametri specificati e i risultati dell'analisi.

Visualizzazione grafica nell'editor PCB

I risultati della simulazione possono ora essere visualizzati graficamente nell'editor PCB di Altium Designer, in base alle impostazioni disponibili nella scheda Visual di PDNA.  Impostare le opzioni di visualizzazione per mostrare Voltage per entrambi i Layers (Top e Bottom) del 5V Net: si tratta delle impostazioni di visualizzazione predefinite iniziali. I risultati dell'analizzatore vengono rappresentati nell'editor PCB, sostituendo la sovrapposizione grafica esistente del PCB.

La caduta di tensione lungo il percorso della rete selezionata, in questo caso dalla sorgente a 5 V in TP1 al componente LCD1, viene rappresentata con un gradiente di colore che corrisponde alla scala di tensione riportata nella parte inferiore della vista. Questa viene mostrata come percentuale di tensione (l'opzione Per Rail in Color Scale) oppure come intervallo di valori di tensione effettivi (l'opzione Displayed).

Nell'immagine seguente, la transizione di colore lungo il percorso della rete sulla scheda rappresenta la caduta di tensione complessiva: il livello minimo (0%: blu), dovuto alle perdite IR, si trova in corrispondenza del componente LCD1, mentre il livello massimo (100%: rosso) si trova nel punto specificato della sorgente di tensione (TP1).

Per visualizzare l'analisi della corrente corrispondente per la rete, selezionare l'opzione Current Density della scheda Visual. In questo caso, i livelli di colore lungo il percorso della rete sulla scheda corrispondono alla percentuale di variazione della densità di corrente: il 100% (rosso) indica la densità di corrente massima calcolata nel layout del percorso della rete, mentre lo 0% (blu) indica il minimo, molto probabilmente 0A/mm2.

Si noti che, sebbene l'opzione di scala alternativa per tensione/corrente (Displayed) offra una rappresentazione più intuitiva per la visualizzazione di singole reti, fornisce informazioni utili limitate quando si visualizzano contemporaneamente più reti di tensione, ad esempio 5V and GND in questo esempio, oppure quando sono state analizzate diverse reti di alimentazione di un progetto.

Per visualizzare e analizzare i risultati dell'integrità dell'alimentazione nel percorso di ritorno GND dell'esempio, deselezionare l'opzione della rete 5V nell'elenco Net della scheda Visual di PDNA, quindi selezionare la rete GND. Il percorso di ritorno di massa attraversa sia il layer Top sia il layer Bottom del progetto, che possono essere visualizzati singolarmente nell'editor PCB selezionando ciascuna voce nell'elenco Layer di PDNA.

L'immagine seguente mostra la visualizzazione della tensione per il layer Bottom della rete GND, con la scala Color Scale impostata su Displayed. La caduta di tensione maggiore (rosso: circa 0,5 mV) si trova sul pin GND dell'LCD, mentre quella minore (blu: circa 0 V) si trova nel punto di ritorno della sorgente di tensione (J1).

Passando all'opzione Current Density di PDNA, vengono mostrati in rosso i punti critici con la corrente più elevata. Il valore massimo della densità di corrente (1.74 A/mm2) è molto basso e ampiamente entro i limiti accettabili.

Controllo e opzioni di visualizzazione

PDN Analyzer offre diverse opzioni di visualizzazione interattive che determinano come vengono rappresentati graficamente i risultati dell'analisi nell'editor PCB di Altium Designer. Oltre alle opzioni di visualizzazione Color Scale, è possibile passare dalla rappresentazione 2D a quella 3D; quest'ultima consente di esaminare in modo approfondito i risultati dell'analisi attraverso i via e tra i layer.

È inoltre disponibile un'opzione per Clear i risultati dell'analisi dalla visualizzazione dell'editor, ripristinando automaticamente la rappresentazione grafica del layout standard della scheda. L'opzione Overlay della vista, invece, abilita la visualizzazione del layout della scheda, che viene rappresentato insieme agli eventuali risultati dell'analisi attualmente visualizzati. Questa opzione è particolarmente utile per verificare dove si trova, nel layout della scheda, un punto di interesse individuato nei risultati dell'analisi.

Lavorare con i carichi

È possibile aggiungere altri carichi alla rete secondo necessità e rieseguire l'analisi dell'alimentazione per valutarne i risultati. Per aggiungere, ad esempio, la piccola corrente di carico (supponiamo 15mA) dovuta al LED di alimentazione del progetto, selezionare il relativo resistore in serie (R15) come collegamento alla linea 5V e il pin del LED come collegamento a GND.

PDN Analyzer consente inoltre di specificare i collegamenti ai pin del dispositivo per un carico, permettendo così di creare più modelli di carico per un singolo componente che assorbe correnti diverse attraverso pin diversi.

Il dispositivo LCD nel progetto di esempio illustra questa situazione: il collegamento a 5V sul pin 15 (LED+) alimenta la retroilluminazione del display, mentre quello sul pin 2 (VDD) alimenta la logica interna. Nella pratica, il pin 15 assorbe una corrente notevolmente superiore a quella del pin 2.

Quando è stato aggiunto in precedenza come singolo modello di carico PDNA, entrambi i pin di LCD1 sono stati designati (per impostazione predefinita) come collegamento del carico a 5V e l'analisi PDN ha distribuito equamente la corrente di carico di LCD1 tra questi pin. Per migliorare la precisione dell'analisi dell'alimentazione, il componente LCD1 può essere rappresentato mediante two modelli di carico: uno per ciascun pin a 5V e per la relativa corrente di carico. Questa modifica può essere effettuata modificando i parametri dei pin del modello di carico LCD1 esistente e aggiungendo poi un altro carico per il pin separato.

Aprire il modello di carico LCD1 esistente facendo doppio clic sulla relativa icona nella rappresentazione grafica della rete per aprire la finestra di dialogo Device Properties, quindi fare doppio clic nel campo Pins(s) della voce relativa alla rete di alimentazione 5V. La modalità di modifica dei pin così attivata consente di selezionare i singoli pin del dispositivo per quel carico. Deselezionare il pin 2 per riconfigurare il carico per il solo pin 15 (LED+) e impostare il parametro Load Current, ad esempio, su 75mA per rappresentare la corrente della retroilluminazione dell'LCD.

Creare quindi un altro carico della rete 5V per LCD1 e attivare il pin 2 (disabilitando il pin 15) per rappresentare il carico VDD, per il quale è possibile impostare un valore di Load Current opportunamente inferiore, ad esempio 20mA.

La rete di alimentazione 5V può quindi essere analizzata nuovamente per ottenere una rappresentazione più accurata del carico LCD1 lungo i percorsi della rete.

La differenza nella distribuzione della corrente di carico è visibile confrontando la densità di corrente nelle piste della rete di alimentazione di LCD1 tra la configurazione originale dei carichi e quella aggiornata. Le immagini dell'analisi della densità di corrente riportate di seguito mostrano a sinistra il risultato del modello LCD1 originale a carico singolo e a destra il risultato aggiornato con più carichi.

Si noti la densità di corrente nelle piste che alimentano i pin 2 (la piazzola dell'LCD verso sinistra) e 15. La versione aggiornata mostra correttamente che la maggior parte della corrente dell'LCD fluisce verso il pin 15 (la piazzola dell'LCD verso destra), anziché distribuirsi uniformemente tra i due pin come avveniva in precedenza (immagine a sinistra).

 

Impostazioni di simulazione

I risultati di un'analisi, e in particolare l'entità delle perdite IR nelle aree di rame della scheda, dipendono anche dai valori specificati per la conducibilità del rame della scheda e per lo spessore delle pareti dei via. Per visualizzare e modificare queste impostazioni, selezionare la scheda Simulation nella finestra di dialogo Settings. Per accedere alla finestra di dialogo, fare clic con il pulsante destro del mouse sul nome dell'analisi corrente e selezionare Settings dal menu contestuale.

Conducibilità del metallo

La sezione Metal Conductivity della finestra di dialogo fornisce dettagli e impostazioni relativi al valore di conducibilità (l'inverso della resistività; 1/R) del metallo utilizzato in un progetto. La conducibilità (o resistività) di base, il coefficiente di temperatura e/o la temperatura possono essere selezionati o modificati nella finestra di dialogo per rispecchiare le proprietà costruttive della scheda del progetto:

  • Pure Copper – in genere si considera che il rame abbia una conducibilità di 5.88e7S/m a 25°C e un coefficiente termico di conducibilità di 0.4%/°C. Questo coefficiente di temperatura positivo significa, ad esempio, che aumentando l'impostazione Temp. Compensation nella finestra di dialogo da 25°C a 125°C (una variazione di 100°C), la conducibilità utilizzata nella simulazione si riduce di 40%, scendendo a 3.53e7S/m.
  • PCB Copper – questa è l'impostazione predefinita per le simulazioni e rispecchia i valori di conducibilità riportati nella letteratura di settore come rappresentativi del metallo presente nel rame elettrodepositato (ED) dei PCB, la cui conducibilità misurata è pari a 4.7e7S/m a 25°C, con un coefficiente termico di 0.4%/°C.
  • Custom – scegliere questa opzione per inserire valori specifici di conducibilità o resistività per la simulazione.

Si noti che il valore Sim Conductivity visualizzato rappresenta la conducibilità finale dopo aver tenuto conto di tutti i parametri; il valore Sim Resistivity ne è l'inverso.

Via

Impostare il valore Via Wall Thickness della finestra di dialogo per specificare il peso del metallo delle pareti di tutti i via nell'analisi di simulazione del progetto.

L'impostazione può influire sensibilmente sulle perdite in continua della rete di alimentazione a causa della resistenza intrinseca di un via con pareti sottili, ossia con una metallizzazione sottile. Se di dimensioni/peso sufficienti, tuttavia, un via non compromette le prestazioni in continua del progetto e presenta la stessa densità di corrente delle piste di alimentazione che collega, senza perdite di tensione significative tra i suoi punti di collegamento. Un esempio di analisi in continua delle perdite attraverso i via è illustrato in una sezione successiva.

Ai fini della simulazione, le dimensioni del via e lo spessore della sua parete definiscono di fatto la quantità di materiale conduttivo rappresentata dal via e, di conseguenza, la sua resistenza/conducibilità. La simulazione presuppone che il diametro del via rappresenti la dimensione del foro finito; lo spessore della parete aumenta quindi il diametro del via. Pertanto: Finished Hole Diameter + (2 x Wall_Thickness) = Drill Diameter.

Esempio 2

Questo esempio mostra come implementare una serie di reti collegate che possono essere analizzate nel loro insieme, tenendo conto dei parametri degli elementi in serie che le interconnettono. Fornisce inoltre una panoramica dell'aggiunta di sorgenti basate su modelli di regolatori di tensione (VRM), che fungono anche da interconnessioni tra le reti, e illustra come sviluppare una gerarchia completa della rete di alimentazione di un progetto.

L'esempio modella la rete da PWR_IN a 5V del progetto di riferimento SpiritLevel-SL1 e include i VRM sia da 3,3 V (VCCO) sia da 1,8 V (VCCINT) per creare una struttura completa della rete di alimentazione.

Le condizioni preliminari per questo esempio di simulazione PDN sono:

  • il progetto PCB Spirit Level è aperto in Altium Designer
  • l'applicazione PDN Analyzer è attiva (Tools » PDN Analyzer)
  • le net in continua del progetto PCB sono state identificate nella finestra di dialogo PDN Analyzer DC Net Identification, come descritto sopra.

Iniziare a costruire la rete di alimentazione dell'esempio specificando la net di alimentazione in ingresso (PWR_IN) in una nuova simulazione (selezionare File » New Simulation, se necessario). Come indicato nello schema del progetto, il parametro <Power Net> della PDN è PWR_IN, <Ground Net> è GND e Source è J1.

Estensione delle reti tramite elementi in serie

Per modellare l'intero percorso di alimentazione dalla rete PWR_IN alla rete 5V, è necessario aggiungere i componenti in serie, ovvero il fusibile (F1) e l'interruttore (S1), insieme alla net intermedia. Nell'interfaccia PDNA, questi vengono aggiunti estendendo progressivamente la rete di alimentazione. Ogni «estensione» della net è collegata tramite un modello universale di elemento in serie.

Per estendere una net, fare innanzitutto clic con il pulsante destro del mouse nella rete da ampliare e scegliere l'opzione Extend Network dal menu contestuale. Nella finestra di dialogo Choose Net, selezionare la rete collegata a PWR_IN tramite un elemento in serie, che in questo caso è NetD1_2: la rete che collega F1 al pin 3 di S1, identificata dal pin 2 del diodo D1.

Poiché è improbabile che questa rete sia stata registrata nella fase iniziale di identificazione delle net in continua, deselezionare l'opzione List DC nets only nella finestra di dialogo Choose Net per rendere la net disponibile per la selezione.

Il processo di estensione della net aggiunge automaticamente un elemento in serie tra le due net: fare doppio clic su questo elemento per specificarne i collegamenti e i parametri nella finestra di dialogo Device Properties. Il modello dell'elemento in serie è composto da una sorgente di tensione in serie con un resistore e consente una modellazione di base di componenti quali resistori, induttori, diodi, interruttori ecc.

In questo caso l'elemento in serie è il fusibile F1, selezionato tramite le opzioni di collegamento RefDes, al quale viene assegnato un valore nominale interno di Resistance pari a 0.1Ω. Se l'elemento in serie fosse un dispositivo a semiconduttore, come un diodo, si specificherebbe il parametro Voltage Drop insieme al valore interno di Resistance del dispositivo.

Seguendo lo schema, il passaggio successivo consiste nell'estendere la net D1_2 alla net di alimentazione 5V tramite l'interruttore S1. Come sopra, scegliere Extend Net dal menu contestuale accessibile con il pulsante destro del mouse e selezionare la net a cui estendere il collegamento nella finestra di dialogo Choose Net.

In questo caso l'elemento in serie aggiunto è S1, che collega la net D1_2 alla rete di uscita 5V tramite i pin 3 e 2 (vedere lo schema). Poiché l'ingresso inutilizzato dell'interruttore S1 (pin 1) è collegato all'uscita (pin 2) e non conduce corrente di carico, a titolo di esempio è possibile rimuovere il pin 1 dall'analisi della rete tramite le opzioni di selezione dei pin della finestra di dialogo Device Properties: fare doppio clic sul campo Pin(s) della voce relativa al terminale OUT.

È ora possibile aggiungere un carico alla sezione a 5 V delle reti di alimentazione collegate: in questo caso, quello del modulo display LCD1.

Quando si esegue nuovamente l'analisi, sia i dati sia la rappresentazione grafica nell'editor PCB includeranno tutte e tre le reti di alimentazione collegate e mostreranno la corrente e la caduta di tensione calcolate sugli elementi in serie di interconnessione.

Inclusione dei modelli di regolatori di tensione

PDN Analyzer offre modelli attivi di regolatori di tensione (VRM) che possono essere inseriti tra le reti di tensione in ingresso e in uscita. Quando vengono aggiunti alle reti di alimentazione PDNA, fungono sia da carico sulla rete di tensione in ingresso sia da sorgente sulla rete di tensione in uscita. Le opzioni dei modelli VRM includono regolatori di tensione lineari, a commutazione e a commutazione con rilevamento remoto.

Il progetto di riferimento SpiritLevel-SL1 utilizza regolatori di tensione lineari per generare le linee di alimentazione a 3,3 V (VCCO) e 1,8 V (VCCINT). Quando il regolatore VCCO (U3) viene aggiunto alla rete di simulazione PDNA, viene rappresentato come un carico sulla rete di ingresso a 5 V e come una sorgente per la rete a 3,3 V. 

Per inserire il regolatore lineare U3 come carico sulla rete a 5 V (come nella procedura precedente), aggiungere un carico alla rete a 5 V e selezionare l'opzione VRM (Linear) come Device Type nella finestra di dialogo Device Properties. Impostare i collegamenti del modello come indicato nello schema e specificare il pin Ref come collegamento GND di R14. Questo punto di riferimento potrebbe trovarsi in una posizione diversa e forse più adatta nelle immediate vicinanze sul PCB, a seconda del layout della rete GND.

Per completare il VRM, impostarne il parametro della tensione di uscita (Vout: 3.3V) e, facoltativamente, la resistenza di uscita (interna), la corrente di polarizzazione a riposo ed eventuali Limits da rilevare durante l'analisi.

PDNA offre una funzione per aggiungere automaticamente il modello del lato di uscita del VRM come sorgente alla net della tensione di uscita di destinazione e, se necessario, creare tale rete.

Per questo esempio, fare clic con il pulsante destro del mouse sul modello di carico VRM appena creato (Load2: U3) e selezionare l'opzione Add VRM To New Network. Verrà creata automaticamente la rete VCCO con il modello del lato di uscita del VRM (Source 1: U3) come sorgente di tensione (3,3 V).

Si noti che le due rappresentazioni del VRM da 3,3 V, ossia il modello di ingresso come carico sulla net a 5 V e il modello di uscita come sorgente per la net a 3,3 V, interagiscono tra loro e costituiscono di fatto lo stesso modello. Pertanto, è possibile accedere al VRM e modificarlo da entrambe le reti nell'interfaccia PDNA.

È ora possibile selezionare la nuova rete VCCO e aggiungere un carico adeguato. In questo esempio, si tratta di una corrente di carico di 0,2 A assorbita da più pin del componente U1.

La configurazione completa della rete di alimentazione include ora due reti (PWR_IN e VCCO) collegate tra loro dal VRM di tipo lineare da 3,3 V. Quando si seleziona il livello superiore della gerarchia delle reti nella struttura del file PDNA corrente, la rappresentazione grafica delle reti fornisce una panoramica a blocchi delle interconnessioni tra le net di alimentazione.

In questo esempio, il VRM è stato aggiunto come carico alla rete da 5 V (tensione di ingresso), quindi utilizzato per creare automaticamente la rete di uscita da 3,3 V (VCCO), con il VRM come sorgente. È possibile anche procedere in senso inverso, il che in alcuni casi può risultare più comodo. In questo caso, il VRM viene aggiunto alla rete della tensione di uscita come sorgente e il relativo modello viene aggiunto a una rete della tensione di ingresso come carico (Add VRM To New Network o Add VRM To Existing Network).

L'analisi PDN fornisce risultati per la rete complessiva, incluso il VRM. Dal punto di vista grafico, l'editor PCB visualizza tutte le reti quando nell'interfaccia PDNA è selezionato il livello superiore della gerarchia delle reti. Selezionare una singola rete nell'elenco per limitare la rappresentazione grafica a quella rete e attivare o disattivare le opzioni Net e Layer del pannello inferiore per controllare ulteriormente la visualizzazione.

Si noti che il percorso della rete GND dell'esempio includerà ora i contributi della corrente di ritorno di entrambe le reti PWR_IN e VCCO.

La rete di distribuzione dell'alimentazione del progetto di esempio può essere completata aggiungendo il VRM rimanente (U4) e la relativa rete di uscita dell'alimentazione da 1,8 V (VCCINT).

Aggiungere un VRM lineare alla rete da 5 V come descritto in precedenza e impostarne il parametro Vout su 1.8V.

Aggiungere il VRM (in questo caso, Load 3) a una nuova rete per creare la rete di alimentazione da 1,8 V (VCCINT).

Aggiungere un carico appropriato alla rete VCCINT: in questo caso, i pin di alimentazione da 1,8 V del componente U1.

La gerarchia delle reti nell'interfaccia PDNA mostrerà ora tutte e tre le reti interconnesse.

L'analisi PDN fornisce risultati per la rete complessiva, inclusi i VRM.

Si noti ancora una volta che la rete GND include ora la corrente di ritorno di tutte e tre le reti, che utilizzano le aree di rame comuni del layer GND. Il suo livello massimo di densità di corrente (65.8 A/mm2) è ora elevato e probabilmente supera i limiti accettabili.

Individuazione dei problemi di integrità dell'alimentazione

PDN Analyzer offre un'ampia gamma di informazioni grafiche e dati che possono essere utilizzati per valutare l'integrità dell'alimentazione di un progetto PCB analizzato e risolverne i problemi.

Nell'esempio riportato sopra, l'analisi del percorso della rete GND Top Layer indica la presenza di una densità di corrente eccessiva, come evidenziato dal valore massimo della scala pari a 65.8A/mm2. La posizione dell'area problematica non è immediatamente evidente, ma può essere individuata utilizzando la funzione Highlight Peak Values di PDNA.

Quando questa funzione è selezionata, con l'opzione Filter impostata su Maxima, l'area del picco di densità di corrente viene evidenziata e contrassegnata nella rappresentazione grafica dell'analisi nell'editor PCB.

Fare clic sul pulsante per ripetere l'evidenziazione grafica oppure utilizzare i pulsanti associati () per scorrere in ordine i valori e le posizioni dei picchi più elevati. Impostare le opzioni Scope per evidenziare i picchi nell'area del PCB attualmente visibile (In View)) oppure tutti quelli dell'intero layout (Design): quest'ultima opzione sposta e ingrandisce la vista su ciascuna posizione man mano che si scorre l'elenco.

È possibile ricavare ulteriori informazioni su un'area critica abilitando la funzione Show Arrows di PDNA, che sovrappone alla vista più frecce indicanti la direzione della corrente (tramite l'angolazione della freccia) e la sua intensità relativa (tramite le dimensioni della freccia) in quella posizione. In questo esempio, ciò conferma che l'area ad alta densità è il percorso della corrente di ritorno da U1 (in alto) all'area GND sul bordo inferiore della scheda.

Un modo per risolvere questo problema consiste nell'aumentare la larghezza della pista nell'area critica.

La modifica del PCB può essere eseguita mentre PDN Analyzer è attivo, consentendo di migliorare il layout in modo iterativo e di analizzarlo nuovamente. Fare clic sul pulsante Clear nell'area Views per disattivare la visualizzazione dei risultati PDNA nell'editor PCB e procedere con la modifica necessaria al PCB.

È quindi possibile ripetere l'analisi PDN (fare clic su ) per verificare i risultati relativi all'integrità dell'alimentazione. Le due immagini seguenti illustrano la variazione della densità di corrente nella rete GND (su Top Layer) dovuta all'aumento della larghezza della pista in quel punto critico: l'immagine superiore mostra il risultato iniziale della densità di corrente, mentre quella inferiore ne mostra la rappresentazione grafica dopo la modifica del PCB.

Gli aspetti da notare in questo confronto tra prima (immagine superiore) e dopo (immagine inferiore) sono:

  • Il livello massimo di densità di corrente nel layer GND si è ridotto a un valore accettabile, pari a circa un decimo del valore precedente: da 65.8A/mm2  a 7.1A/mm2.
  • Le aree di corrente massima, i cui valori sono ora molto più bassi, sono distribuite in modo più uniforme lungo i percorsi di ritorno GND, anziché essere concentrate in un unico punto problematico.
  • Per un confronto grafico più diretto, impostare manualmente la scala della densità di corrente sul valore precedente: selezionare l'opzione di scala Manual, immettere 65.8 nel campo Max e fare clic sul pulsante per aggiornare la visualizzazione.

Violazioni dei limiti di densità di corrente

Un modo più oggettivo per individuare e risolvere i problemi di integrità dell'alimentazione nei percorsi di corrente di un progetto PCB consiste nel definire limiti specifici di densità di corrente, il cui superamento genera una violazione. Vedere di seguito per altri tipi di violazioni.

I limiti di densità di corrente per i layer esterni/interni e per i via vengono specificati nella scheda Limits della finestra di dialogo Settings, che si apre facendo clic con il pulsante destro del mouse sul nome della simulazione PDN corrente e selezionando Settings dal menu contestuale. I limiti impostati si applicano a tutti i layer esterni/interni e a tutti i via del progetto della scheda.

I limiti di densità di corrente specificati si applicano ai risultati dell'analisi corrente e possono essere modificati e rivalutati senza dover eseguire nuovamente la simulazione: il rilevamento dei superamenti dei limiti è un processo successivo all'analisi. Le reti che contengono violazioni vengono visualizzate con un contorno rosso tratteggiato.

Nell'esempio qui mostrato, la rete di alimentazione VCCO contiene violazioni della densità di corrente. Quando viene selezionata la rete VCCO, il contorno evidenziato del relativo percorso di alimentazione segnala la presenza di una violazione.

Passare il cursore sulla rete che presenta violazioni per visualizzare un elenco a comparsa delle violazioni correnti e dei relativi dettagli. L'unica voce presente in questo caso indica che la densità di corrente in un via (circa 34.5A/mm2) supera il limite definito (30A/mm2).

Fare doppio clic sulla voce della violazione per individuarne la posizione sulla scheda tramite cross-probing (spostando e ingrandendo la vista). Nell'immagine seguente, la vista grafica PDNA è impostata sulla modalità 3D, che mostra più chiaramente il via interessato e i suoi collegamenti ai layer superiore e inferiore.

Si noti che, al fine di mostrare una singola violazione, le dimensioni del via sono state ridotte nel progetto della scheda del progetto Spirit Level.

I dati relativi a questo via, inclusa un'indicazione della violazione della densità di corrente, sono disponibili nella scheda Via dell'interfaccia PDNA.

L'elenco delle informazioni sui via si riferisce a tutte le reti incluse nel progetto corrente. Fare clic sulle intestazioni delle colonne Net e Current Density per organizzare l'elenco in modo da mostrare i via della rete VCCO ordinati per densità di corrente. Tutti i valori di densità di corrente che superano il limite definito vengono evidenziati in rosso.

Fare doppio clic su una qualsiasi voce nell'elenco dei via per individuarne la posizione nella rappresentazione grafica della scheda in PDNA tramite cross-probing.

Altre violazioni

Oltre a rilevare i limiti specificati per la densità di corrente, PDN Analyzer rileva anche violazioni specifiche delle prestazioni della rete, come quelle dei parametri limite specificati nella configurazione della simulazione durante l'aggiunta di un carico, una sorgente o un elemento in serie.

Questi parametri limite della simulazione includono:

  • L'intervallo di tensione accettabile su un carico
  • La corrente di uscita massima di una sorgente
  • La dissipazione di potenza consentita in una sorgente con regolatore lineare e la relativa corrente di uscita massima.
  • La corrente di uscita massima di una sorgente con regolatore switching.
  • La corrente massima attraverso un elemento in serie.
A differenza dei parametri di simulazione degli elementi della rete (come le impostazioni della tensione della sorgente o della corrente del carico), che vengono elaborati durante l'esecuzione dell'analisi, il rilevamento delle violazioni dei parametri limite (come la tensione minima specificata su un carico) avviene dopo l'analisi. Ciò significa che una modifica al valore di un parametro limite viene rilevata immediatamente, senza dover eseguire nuovamente l'analisi di simulazione.

Quando è stato specificato un parametro limite (con un valore diverso da zero), una violazione del parametro determina l'evidenziazione dell'elemento della rete interessato nella rappresentazione grafica della rete nell'interfaccia PDNA. Passare il cursore sull'elemento per visualizzarne i parametri e i risultati dell'analisi.

Nell'esempio riportato di seguito, la dissipazione di potenza calcolata in Source 1 (regolatore di tensione U1) ha superato il valore massimo definito per il parametro Dissipazione di potenza, pari a 2W.

Informazioni più dettagliate sulle prestazioni di una rete di alimentazione sono disponibili nella relativa scheda, che presenta una vista tabellare dei risultati dell'analisi e include i valori calcolati del consumo di potenza della rete.

Esempio 3

Questo esempio illustra l'applicazione dei modelli di simulazione degli alimentatori switching (SMPS), ovvero i VRM, di PDN Analyzer in una rete di alimentazione e mostra come un modello di rete aggiornato possa fornire risultati più accurati nell'analisi dell'alimentazione. L'esempio offre inoltre una panoramica sull'utilizzo delle funzioni Sonda di tensione e Contorni di PDNA per visualizzare i dati di tensione in punti o aree specifici della sagoma della scheda nel layout.

L'esempio si basa sul progetto di riferimento DB46 Xilinx Daughter Board di Altium e si concentra sulla sezione SMPS (U5) utilizzata per la rete di alimentazione a 1,2 V del progetto (1V2).

Anche in questo caso, le condizioni preliminari per questo esempio di simulazione PDN sono:

  • il progetto DB46 Xilinx Daughter Board è aperto in Altium Designer
  • l'applicazione PDN Analyzer è attiva (Tools » PDN Analyzer)
  • le net in corrente continua del progetto PCB sono state identificate nella finestra di dialogo PDN Analyzer DC Net Identification, come descritto sopra. Si noti che per questo esempio sono necessarie anche le reti LX e AGND.

Iniziare a costruire la rete di alimentazione dell'esempio specificando la net di alimentazione in ingresso in una nuova simulazione (selezionare File » New Simulation, se necessario). Come indicato nello schema sopra, il parametro <Power Net> della PDN è 5V e il parametro <Ground Net> è GND. Il Source per la rete a 5 V è il connettore a pin HDR_T1 o HDR_B1.

VRM switching

Il modello del circuito SMPS del progetto viene aggiunto alla rete di alimentazione a 5 V scegliendo VRM(SMPS) come Device Type del carico nella finestra di dialogo Device Properties. Come indicato nello schema del modello nella finestra di dialogo, i gruppi di pin IN e OUT sono definiti separatamente.

Per definire correttamente questo modello per il circuito, specificare LX come uscita, U5 per le opzioni RefDes e 1.2V come parametro Vout, come mostrato nello schema sopra. Facoltativamente, impostare Rout e i parametri di efficienza/corrente in modo che corrispondano al dispositivo SMPS utilizzato.

Completare l'implementazione del modello SMPS aggiungendo il VRM alla relativa rete di uscita (Add VRM To New Network), che verrà selezionata automaticamente come rete LX. La rete LX può quindi essere estesa per includere la rete di alimentazione a 1,2 V, come indicato nello schema.

Le reti LX e 1V2 sono collegate dall'elemento in serie L1 (l'induttore buck dell'SMPS), che deve essere impostato in modo da presentare una resistenza in serie appropriata. Ai fini di questo esempio, viene impostato un valore piuttosto elevato, pari a 0.2Ω.

Infine, aggiungere U4 come carico 0.3A sulla rete 1V2 e specificare uno scostamento accettabile della tensione del carico pari a +/-5%. Si noti che le opzioni del limite di densità di corrente nella scheda Limits della finestra di dialogo Settings devono essere impostate su 0 (la condizione predefinita Nessun limite) per questo esempio.

Eseguire l'analisi e osservare che il carico sulla rete composita LX segnala una violazione, dovuta al fatto che la tensione della rete 1V2 sul carico (U4) è eccessivamente bassa (circa 1.14V).

Sonda dati

Oltre all'interpretazione visiva della rappresentazione grafica di PDNA e della scala nell'editor PCB, PDN Analyzer offre diversi strumenti per interpretare i risultati dell'analisi in aree o punti specifici del layout del progetto, come lo strumento attivo Probe.

Lo strumento Sonda consente di registrare e confrontare i dati di tensione o densità di corrente in punti selezionati del layout del progetto. La versatilità dello strumento permette di valutare con precisione i risultati dell'analisi su qualsiasi rete o layer. In questo esempio, tuttavia, può essere utilizzato per confermare l'origine della caduta di tensione inaccettabile sul carico della rete 1V2, chiaramente dovuta alla resistenza dell'elemento in serie L1.

Per eseguire una misura differenziale della tensione con la sonda sulla rete 1V2, impostare innanzitutto PDNA in modo da visualizzare solo Layer MidLayer 1 (che è il percorso principale a 1,2 V verso U4) e Net 1V2. Selezionare il pulsante per aprire la finestra di dialogo Probe e abilitare la prima posizione della sonda (). Utilizzare il cursore a croce per selezionare il punto a tensione più alta (la sorgente della rete 1V2 su questo layer), quindi selezionare l'opzione  Difference della sonda e indicare la seconda posizione (), ovvero il punto a tensione più bassa, sul carico U4.

Si noti che la lettura Difference della sonda indica una caduta di tensione di appena circa 3mV lungo il percorso della rete. Verificare in modo analogo il percorso della rete LX (con Top e Bottom Layer attivi), che mostrerà una caduta di tensione di appena circa 0.5mV.

L'esecuzione di una misura della differenza di tensione con la sonda between le due reti (Net LX e 1V2 abilitati, Top e Bottom Layer) mostra una caduta di 60mV ai capi dell'induttore L1, che costituisce la principale perdita di tensione responsabile di questa specifica violazione rilevata dall'analisi.

Sebbene l'indagine con la sonda di tensione mostrata qui abbia individuato la causa principale delle perdite IR nella rete di alimentazione, il problema avrebbe potuto essere identificato più direttamente esaminando i dati di tensione dei pin del dispositivo nella scheda Pins di PDNA. La funzione Sonda è particolarmente indicata per indagini più dettagliate, in cui è possibile sfruttarne appieno la precisione di posizionamento.

VRM SMPS con rilevamento della tensione

Il circuito di alimentazione switching utilizzato in questo esempio impiegherebbe normalmente un induttore (L1) con un valore di resistenza molto inferiore; tuttavia, i risultati dell'analisi evidenziano che il modello SMPS di base non può tenere conto delle perdite attraverso L1. In genere, però, questo non rappresenterebbe un problema in un circuito reale.

Nel circuito SMPS del progetto di esempio, la tensione di retroazione rilevata da U5 (al pin 8) è ricavata dalla catena di resistori R25–R26, posta tra la rete di uscita 1V2 e la rete di massa analogica AGND. Quest'ultima è collegata alla rete GND tramite un resistore di collegamento 0Ω R118.

Si noti che, ai fini di questo esempio, il progetto di riferimento originale DB46 Xilinx Daughter Board è stato modificato per includere un collegamento tra reti basato su resistore (R118) tra le reti GND e AGND, al posto del collegamento diretto in rame.

Per modellare con maggiore precisione il comportamento del circuito intorno a U5, è possibile utilizzare il modello switching con rilevamento remoto di PDNA al posto del dispositivo SMPS standard. Questo modello offre terminali separati per il rilevamento della tensione (S+ e S-), che possono essere collegati a qualsiasi pin delle reti di uscita specificate, ad esempio a quelli della catena di resistori per il rilevamento della tensione presente in questo circuito.

Il primo passo per creare un modello di rete più completo per il circuito SMPS U5 consiste nell'aggiungere la rete AGND alla rete esistente GND. Utilizzare l'opzione Extend Network e selezionare la rete AGND.

La rete AGND è collegata alla rete GND tramite il resistore R118, come mostrato nello schema elettrico riportato sopra; per questo resistore occorre impostare un valore di Resistance pari a 0Ω.

Per aggiornare il modello SMPS nella rete LX, eliminare il dispositivo sorgente U5 esistente (Source 1), quindi aggiungere al suo posto il modello alternativo SMPS Sense. Impostare i collegamenti dei terminali IN e OUT del modello come in precedenza. I terminali di rilevamento (S+/S-) vanno collegati alle due estremità della catena di resistori di retroazione del circuito, come indicato nello schema elettrico.

Propagare il modello SMPS sostitutivo dalla rete LX alla rete sorgente 5V, in modo che le reti corrispondano, eliminando il relativo carico U5 e quindi applicando l'opzione sorgente Add VRM To Existing Network » 5V nella rete LX.

È quindi possibile analizzare nuovamente il circuito aggiornato per valutarne i risultati.  Come mostrato nell'immagine seguente, la tensione sul carico rientra ora ampiamente nel requisito +/-5% e non viene segnalata alcuna violazione. In risposta al rilevamento della tensione di uscita sulla rete 1V2, l'SMPS ha compensato la caduta di tensione nell'elemento in serie L1: di conseguenza, la tensione sulla rete LX è superiore di 60mV.

Sebbene l'utilizzo del modello avanzato SMPS-sense per questo particolare circuito produca risultati di analisi più accurati, l'impiego pratico di dispositivi SMPS con funzionalità di rilevamento remoto può prevedere collegamenti diretti sul PCB dai terminali di rilevamento al carico stesso, anziché a una rete di retroazione vicina. In questo caso, entrambe le linee di rilevamento (S+ e S-)) verrebbero instradate mediante piste PCB dedicate fino alle rispettive estremità del carico o in prossimità di esse.

Curve di livello della tensione

La scelta del posizionamento ottimale delle linee di rilevamento remoto dell'SMPS (come descritto sopra) è uno dei numerosi possibili utilizzi della funzionalità Voltage Contour di PDN Analyzer, che indica graficamente i principali punti di transizione della tensione nel layout della scheda.

Questa funzionalità consente di sovrapporre curve di livello della tensione tratteggiate ai layer visualizzati nell'area grafica dell'editor PCB. È possibile specificare più curve di livello e visualizzarle come percentuale della caduta di tensione della rete oppure come valori di tensione effettivi: vedere le opzioni Indicate.

Oltre alla serie di curve di livello in corrispondenza di percentuali specificate, è possibile includere un'ulteriore curva utilizzando l'opzione Slider, che consente di regolarne in modo continuo il punto di transizione.

Per determinare, ad esempio, un punto adatto per il rilevamento positivo della tensione sul carico di un SMPS, sarebbe opportuno collegare la linea di rilevamento in un punto in cui lo scostamento rispetto alla tensione sul carico sia inferiore, ad esempio, a 20% della caduta di tensione. Per l'esempio SMPS-sense mostrato sopra, una pista di rilevamento proveniente da U5 (S+) si collegherebbe all'area di rame di alimentazione della rete 1V2 in un qualsiasi punto adatto tra i pin del carico U4 (a sinistra) e la curva di livello della tensione 20%.

Analogamente, per determinare punti di prelievo adatti per la linea di rilevamento negativa (S-) dell'SMPS (U5), si potrebbe impostare una curva di livello della tensione, ad esempio di 80%, per il percorso di ritorno del carico (U4) nel layer GND. In questo caso, poiché si tratta di una corrente di ritorno negativa del carico, il punto più adatto dell'area di massa a cui collegare la linea di rilevamento negativa si troverebbe all'interno del perimetro della curva di livello 80%.

Report di analisi

Per archiviare i risultati di un'analisi dell'integrità dell'alimentazione, così da poterli esaminare ulteriormente o distribuire alle parti interessate, PDN Analyzer offre una funzione Report per dati e documentazione. La funzione Report genera un documento HTML molto completo, che include elementi grafici e dati relativi sia ai risultati dell'analisi corrente sia al progetto della scheda.

Selezionare il pulsante per configurare le opzioni del report nella finestra di dialogo HTML Report. Selezionare le caselle di inclusione Results per impostare il livello di dettaglio del report e verificare le immagini acquisite da includere nella cartella del report (); utilizzare il pulsante nell'interfaccia principale per acquisire immagini dei risultati dell'analisi.

Fare clic sul pulsante per generare il report HTML interattivo e aprire la cartella che lo contiene, nella quale saranno presenti tutte le immagini (comprese quelle acquisite) e il relativo file di configurazione dell'analisi (*.pdna).

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents