Preparazione del progetto per la produzione
A colpo d'occhio
- Scopri come aggiungere e configurare gli output in un file OutJob, scegliendo anche origini dati che ne consentano il riutilizzo in più progetti.
- Comprendi come associare gli output a contenitori o processi di stampa e controllare dove vengono salvati i file generati.
- Segui il flusso di lavoro per il rilascio del progetto, comprese le opzioni di rilascio, la convalida se configurata, la generazione dei dati e la revisione.
La fase finale del ciclo di progettazione consiste nel generare i file di output necessari per realizzare il prodotto. A tale scopo, occorre generare diversi file di output in vari formati. Come progettista, puoi scegliere di configurare e generare singolarmente gli output tramite gli editor degli schemi e dei PCB oppure aggiungere tutti gli output necessari a un OutputJob e generarli nell'ambito del processo di rilascio del progetto.

L'obiettivo finale è realizzare il prodotto, ad esempio fabbricare e assemblare un PCB.
Preparazione dei dati di produzione con gli Output Job
Puoi configurare e generare singolarmente gli output direttamente tramite i menu File e Reports degli editor pertinenti. In questo caso, gli output vengono generati direttamente quando fai clic su OK nella finestra di dialogo delle impostazioni associata e salvati nel percorso specificato nel campo Output Path della scheda Options della finestra di dialogo Project Options.
I file Output Job, tuttavia, semplificano la preparazione degli output dei tuoi progetti e la loro successiva generazione tramite il processo di rilascio del progetto ad alta integrità. Un Output Job, abbreviato in "OutJob", è essenzialmente un insieme preconfigurato di output che ne memorizza le impostazioni e definisce dove verranno salvati gli output generati.
Per aggiungere un nuovo OutJob al progetto, fai clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects e seleziona il comando Add New to Project » Output Job File dal menu contestuale. Nell'area di progettazione si aprirà un OutJob predefinito.

L'OutJob appena creato sarà il documento attivo nell'area di progettazione.
Utilizzando il lato sinistro dell'OutJob, puoi aggiungere e configurare numerosi tipi di output per scopi diversi. Gli output sono raggruppati in categorie funzionali, come output di assemblaggio, output di fabbricazione e report.
Aggiungi un nuovo output del tipo desiderato facendo clic sul testo Add New <Type> Output appropriato in fondo a una categoria e scegliendo il tipo di output richiesto dal menu a comparsa. Per ciascuna voce relativa a un tipo di output è disponibile un sottomenu che consente di specificare l'origine dei dati, ovvero quali documenti sorgente utilizzare per generare l'output. Puoi aggiungere un numero qualsiasi di output.
Per determinati tipi di output, sono disponibili opzioni per configurare un output aggiunto facendo clic con il pulsante destro del mouse sull'output nell'elenco e selezionando il comando Configure dal menu contestuale. Si aprirà la finestra di dialogo di configurazione associata, che consente di definire le opzioni dell'output. Ad esempio, per un output Gerber X2 Setup si aprirà la finestra di dialogo Gerber X2 Setup.

Configura l'output secondo le tue esigenze nella finestra di dialogo di configurazione associata.
Per definire dove e in quale formato generare un output, si utilizzano contenitori di output e processi di stampa. Gli output possono essere salvati, ove applicabile, in tre tipi di contenitori: PDF, video o struttura di cartelle (file di output in un formato specifico, ad esempio un file Gerber). Alcuni output possono anche essere inviati direttamente a una stampante per produrre una copia cartacea, aggiungendo e configurando un processo di stampa.
Un nuovo OutJob contiene un contenitore di output per ciascun tipo e un processo di stampa per la stampante predefinita. Le relative voci sono visualizzate sul lato destro dell'OutJob. Se necessario, puoi aggiungere un nuovo contenitore di output o un processo di stampa facendo clic, rispettivamente, sul controllo Add New Output Container e selezionando il tipo di contenitore richiesto oppure sul controllo Add New Print Job e selezionando la stampante desiderata.

Aggiungi nuovi contenitori di output e/o processi di stampa secondo necessità.
Per specificare quali output generare utilizzando ciascun contenitore di output o processo di stampa, seleziona un contenitore o un processo, quindi seleziona la casella Enabled per ogni output desiderato nell'elenco. Una volta abilitato, l'output sarà collegato al contenitore di output o al processo di stampa selezionato tramite una linea verde. Gli output possono essere associati a contenitori di output o processi di stampa individuali o condivisi.

Associa gli output aggiunti ai contenitori di output e ai processi di stampa corrispondenti utilizzando le caselle Enabled.
Per configurare un contenitore di output o un processo di stampa, seleziona la relativa voce e fai clic sul controllo Change. Si aprirà la finestra di dialogo associata: ad esempio, quando selezioni un contenitore di output con struttura di cartelle, si apre la finestra di dialogo Folder Structure settings, in cui puoi configurare il percorso di destinazione dei file da generare e ulteriori opzioni relative alla generazione dei file.

Configura le impostazioni di un contenitore di output o di un processo di stampa nella finestra di dialogo associata.
Gli output configurati in un OutJob possono essere generati direttamente dall'OutJob oppure, per un progetto PCB, nell'ambito del processo di rilascio del progetto ad alta integrità. Per generare gli output associati a un contenitore di output o a un processo di stampa direttamente dall'OutJob, seleziona il contenitore o il processo e fai clic, rispettivamente, sul controllo Generate content o Print.

Puoi generare o stampare gli output direttamente dall'OutJob.
Rilascio del progetto della scheda
Utilizzando il processo di rilascio del progetto della scheda, puoi generare contemporaneamente tutti i dati di produzione configurati nei file OutJob del tuo progetto PCB. Questo processo offre diversi vantaggi rispetto alla generazione degli output singolarmente o direttamente dagli OutJob, tra cui la possibilità di convalidare il progetto come parte integrante del processo di rilascio ed evitare interventi manuali durante il processo stesso. Inoltre, quando il rilascio avviene nel Workspace connesso, viene garantita una stretta integrazione con il controllo di versione del Workspace.
Per avviare il rilascio di un progetto, fai clic con il pulsante destro del mouse sulla relativa voce nel pannello Projects e seleziona il comando Project Releaser dal menu contestuale. La vista Release si aprirà in una scheda separata.

Accedi alla vista Release – l'interfaccia utente per Project Releaser.
Il processo di rilascio è un flusso suddiviso in fasi; le voci sul lato sinistro della vista Release indicano la fase in cui ti trovi.
Nella fase iniziale del processo di rilascio, puoi fare clic sul pulsante Options in basso a sinistra nella vista per accedere alla finestra di dialogo Project Release Options e configurare le opzioni del processo di rilascio secondo le tue esigenze. Le opzioni includono la selezione della destinazione del rilascio (Workspace, cartella o file zip) e l'assegnazione degli OutJob.

Configura le opzioni di rilascio nella finestra di dialogo Project Release Options.
A seconda della destinazione di rilascio selezionata, le fasi del processo di rilascio variano leggermente. Di seguito è mostrato, come esempio, un rilascio in un Workspace connesso.
|
Nella fase Configure Server Release, puoi specificare i tipi di dati che desideri generare: dati sorgente (un'istantanea del progetto sorgente, sempre inclusa nel rilascio), dati di fabbricazione e dati di assemblaggio. Il numero di set di dati di assemblaggio corrisponderà al progetto base (senza varianti) e a tutte le varianti di progetto rilevate. Quando sei pronto, fai clic sul pulsante Prepare in basso a destra nella vista per procedere. Se vengono rilevati problemi, ti verranno proposte delle soluzioni per risolverli. La fase Validate Project viene eseguita automaticamente quando nei file OutJob assegnati vengono rilevati uno o più report di convalida, come un report di verifica delle regole di progettazione (DRC), e vengono eseguiti i relativi output di convalida. Il rilascio non andrà a buon fine se uno qualsiasi dei controlli di convalida non viene superato. La fase Generate Data viene eseguita automaticamente quando la fase precedente si conclude senza problemi. In questa fase vengono eseguiti tutti gli altri output definiti nei file OutJob assegnati per generare i dati da rilasciare. Una volta superati tutti i controlli di convalida e generati i dati di output, la fase Review Data ti consente di esaminare i dati generati. Procedi con il rilascio facendo clic sul pulsante Release in basso a destra nella vista e confermando il rilascio nella finestra di dialogo visualizzata. Dopo aver confermato il rilascio nella fase precedente, si passa automaticamente alla fase Upload Data. Questa mostra l'avanzamento del caricamento dei dati. La fase finale Execution Report del processo fornisce un riepilogo del rilascio. Una volta rilasciato il progetto, puoi chiudere la vista Release facendo clic sul pulsante Close in basso a destra nella vista. |






