Creare e mantenere i propri componenti e librerie
Un progetto elettronico è un insieme di componenti collegati tra loro. La parte gratificante dello sviluppo di un prodotto consiste nell'ideare soluzioni ingegnose per affrontare le sfide tecniche e collegare questi componenti per realizzare un progetto unico.
Tuttavia, gran parte del lavoro, che molti progettisti considerano la più tediosa, consiste nella creazione dei componenti. Anche se può non essere entusiasmante, i componenti diventano una risorsa preziosa per l'azienda ed è essenziale che rappresentino accuratamente il componente reale.
Il componente che acquisti e saldi sulla scheda o utilizzi in un cablaggio è il componente reale, ma deve essere modellato in ciascuno degli ambiti di progettazione elettronica in cui intendi utilizzarlo.
A seconda delle implementazioni progettuali che intendi realizzare, il componente può includere un simbolo per lo schema elettrico, un modello di simulazione per il simulatore circuitale, un modello IBIS per l'analisi dell'integrità del segnale, un pattern o footprint per il layout del PCB, e un modello 3D per la visualizzazione, la verifica delle distanze di sicurezza in 3D e l'esportazione nell'ambiente CAD meccanico.
Gestione dei componenti
Una gestione efficace dei dati dei componenti è essenziale per la progettazione elettronica e la gestione dei componenti utilizzati in un progetto è sempre stata un elemento fondamentale del software di progettazione Altium. Con l'evoluzione del software nel corso degli anni, le metodologie di gestione dei componenti hanno compiuto un lungo percorso: dalle semplici librerie separate di modelli schematici e PCB, passando per le librerie basate su database, fino ai componenti del Workspace, che estendono la rappresentazione dei componenti del progetto all'intero processo di sviluppo del prodotto, offrendo funzionalità all'avanguardia e facili da usare per una collaborazione senza precedenti durante l'intero processo di progettazione.
| Libreria del Workspace | Componenti archiviati in un Workspace connesso che offre un'unica fonte di dati dei componenti aggiornati e standardizzati per l'intero team di progettazione. Le funzionalità di ricerca parametrica e per faccette consentono di trovare e posizionare i componenti necessari in modo rapido ed efficiente. Questi componenti sono strettamente associati al componente fisico prodotto e ai dati della catena di approvvigionamento, accessibili durante la progettazione, offrendo un miglioramento significativo in termini di costi e tempi di approvvigionamento per la produzione del prodotto assemblato. |
|
| Libreria basata su database | Vuoi associare strettamente i componenti del progetto al database aziendale? Allora esplora le librerie basate su database. Ogni record è un componente che fa riferimento ai modelli richiesti e ai dati parametrici del componente. I collegamenti ai modelli e i parametri vengono aggiunti al simbolo durante il posizionamento, trasformandolo in un componente di Altium Designer. | |
| Libreria basata su database SVN | Una libreria basata su database SVN è un'estensione del modello di libreria basata su database, con la differenza che il simbolo e i modelli sorgente sono archiviati sotto controllo di versione. Le librerie sorgente vengono create, aggiunte e gestite all'interno di un repository basato su Subversion. Il collegamento al repository e al database esterno è definito in un file di libreria basata su database SVN (*.SVNDbLib). |
|
| Collegamento al database | Con questo metodo, il file di collegamento al database (*.DbLink) definisce il collegamento tra il componente schematico e un record corrispondente nel database. La corrispondenza tra i record viene stabilita tramite il collegamento dei campi chiave, che può utilizzare un singolo campo chiave (ad esempio un codice componente) o più campi chiave (definendo una clausola Where). |
|
| Libreria integrata | Preferisci avere i componenti già raggruppati e verificati in un unico file? Allora compila i modelli sorgente schematici/PCB/di simulazione per generare una libreria integrata (*.IntLib). |
|
| Libreria schematica | Una libreria schematica (*.SchLib) può essere una libreria di modelli contenente simboli dei componenti; se a ciascun simbolo vengono aggiunti collegamenti ai modelli e dati parametrici, diventa una libreria di componenti. |
|
| Libreria PCB | Una libreria per archiviare i modelli dei footprint PCB (*.PcbLib). Se necessario, è possibile aggiungere un modello 3D a ciascun footprint. I modelli 3D vengono creati a partire da oggetti corpo 3D oppure da un modello STEP importato in un oggetto corpo 3D. |
Libreria del Workspace
I componenti sono archiviati nel tuo Workspace: un'unica posizione centralizzata e sicura per tutti i dati di progettazione, accessibile all'intero team. I vantaggi dell'utilizzo di componenti ospitati in un Workspace sono numerosi. Eccone alcuni:
-
Single source of component data – con un Workspace accessibile all'intero team, gli ingegneri possono reperire componenti aggiornati e standardizzati da un'unica posizione sicura, ottenere dati della catena di approvvigionamento in tempo reale e utilizzare la ricerca parametrica e per faccette per trovare esattamente i componenti di cui hanno bisogno.
-
Design-time choice of physical components – per ogni componente, puoi scegliere quali componenti dei produttori possono essere utilizzati per implementarlo durante l'assemblaggio della scheda.
-
Real-time supply-chain information – provenienti dal database aggregato dei componenti del Altium Parts Provider (che a sua volta si interfaccia con i fornitori abilitati e ne raccoglie i componenti), per informare il progettista sui costi e sulla disponibilità attuali dei componenti scelti presso tutti i fornitori che li vendono (come definiti nel catalogo dei componenti locale del Workspace). Queste informazioni possono essere aggiunte a un componente in qualsiasi momento, anche dopo averlo salvato nel Workspace, senza modificarlo direttamente e quindi senza influire sui progetti in cui è già utilizzato – e possono poi essere utilizzate all'interno di una distinta base.
-
Concurrent editing of the library – poiché la libreria del Workspace è essenzialmente un insieme di elementi componente ospitati nel Workspace, più utenti possono modificare o creare nuovi componenti per la libreria in modo indipendente, senza dover attendere che gli altri utenti completino il proprio lavoro.
-
Component Models Reuse – un componente può essere considerato un «contenitore» in cui vengono archiviate tutte le informazioni parametriche e i modelli dei vari ambiti di progettazione, inclusi il simbolo schematico, i footprint PCB e i modelli di cablaggio e simulazione. Un componente non contiene i modelli stessi, ma i collegamenti ai relativi elementi modello, anch'essi presenti nel Workspace, quindi un singolo modello può essere utilizzato da più componenti. Se un modello cambia, ti verrà suggerito di aggiornare tutti i componenti che lo utilizzano, garantendo così che nessun componente utilizzi un modello non aggiornato.
-
Direct Component Editing – se un componente deve essere modificato, puoi aprirlo per la modifica direttamente dal Workspace. Un'istanza temporanea dell'editor dei componenti consente di modificarne tutti gli aspetti, inclusi i modelli dei vari ambiti di progettazione a cui fa riferimento, senza dover gestire alcun documento basato su file.
-
Use of Component Templates – applica modelli basati sui parametri e sulla tassonomia dei componenti, in modo che ogni nuovo tipo di componente disponga automaticamente del corretto insieme di parametri conforme alla distinta base, automatizzando anche l'applicazione degli schemi corretti di denominazione, revisione e ciclo di vita.
-
Component Lifecycle Validation – se un componente si trova nello stato «fine vita», «obsoleto» o «abbandonato», riceverai un avviso prima di tentare di produrre schede che lo utilizzano.
-
Where-used Component Traceability – è possibile tracciare tutti gli utilizzi dei componenti: se un componente diventa obsoleto, puoi verificare in quali progetti è stato utilizzato per sapere quali devono essere aggiornati. Se un simbolo o un footprint contiene un errore, puoi visualizzare tutti i componenti che lo utilizzano per poterli correggere.
-
Requests of new components – un ingegnere può inviare richieste di componenti nuovi o mancanti ai responsabili delle librerie e ricevere una notifica quando il componente diventa disponibile per l'utilizzo nei progetti da parte del richiedente e degli altri ingegneri dell'azienda.
Creazione di un nuovo componente nella libreria del Workspace
Il componente fisico montato sulla scheda o utilizzato nella produzione del cablaggio è rappresentato da un simbolo schematico durante l'acquisizione del progetto e da un footprint PCB per la progettazione della scheda (facoltativamente, con un modello 3D per la visualizzazione, la verifica delle distanze in 3D e l'esportazione nell'ambiente CAD meccanico). Un componente di progetto può anche includere un modello di simulazione per il simulatore di circuiti e un modello IBIS per l'analisi dell'integrità del segnale. Per rappresentare i componenti di progetto nel più ampio contesto dello sviluppo del prodotto, è possibile aggiungere una o più scelte di parti.
I componenti per il tuo progetto possono essere creati e inseriti nella libreria del Workspace della tua azienda. Vengono posizionati tramite il pannello Components, che utilizza il motore avanzato di ricerca dei componenti di Altium Designer.
Un nuovo componente della libreria del Workspace viene creato utilizzando l'editor dei componenti, dove puoi definire manualmente tutti i dati del componente (modelli di dominio, parametri, scelte di parti, ecc.) oppure utilizzare i dati acquisiti dal pannello Manufacturer Part Search.
Per creare un nuovo componente nella libreria del Workspace:
-
Seleziona un comando di creazione dei componenti. Puoi accedervi nei seguenti modi:
-
Seleziona il comando File » New » Component dai menu principali.
-
Seleziona File » New » Library dai menu principali, quindi, nella finestra di dialogo New Library che si apre, seleziona Create Library Content » Component nella sezione Workspace della finestra di dialogo.
-
Nel pannello Componenti, fai clic con il pulsante destro del mouse nell'area dell'elenco dei componenti e seleziona il comando Create dal menu contestuale.
-
-
Nella finestra di dialogo Create new component che si apre, scegli un tipo di componente. Se al tipo di componente selezionato è associato un template di componente, questo verrà utilizzato per predefinire il componente con i dati che contiene.

Accedi alla finestra di dialogo Create new component per selezionare il tipo di componente da creare. -
Dopo aver fatto clic su OK, si apre l'editor dei componenti nella modalità di modifica di un singolo componente. Questa modalità offre un'interfaccia semplificata per definire o modificare un singolo componente.
-
Definisci il componente aggiungendone i dettagli nell'editor dei componenti:
- Nella sezione Component dell'editor dei componenti, definisci Name e Description del componente. Questi dettagli sono essenziali per le successive ricerche dei componenti, quando dovrai utilizzare un componente nel tuo progetto.
-
Fai clic sul controllo Advanced Settings per definire o modificare altri dettagli del componente, come Id utilizzato per il componente salvato nel Workspace e Folder nel Workspace di destinazione in cui verrà salvato il componente.
-
Nella sezione Parameters dell'editor dei componenti, definisci ulteriori dettagli del componente: parametri standard, collegamenti URL a pagine web (ad esempio, il sito di un produttore) e collegamenti alle schede tecniche (in qualsiasi formato).
-
Nella sezione Part Choices dell'editor dei componenti, specifica una o più scelte di parti per il componente, ovvero le parti dei produttori «consentite» che possono essere utilizzate per implementare il componente sulla scheda assemblata.
-
Nella sezione Models dell'editor dei componenti, aggiungi collegamenti ai modelli di dominio salvati (o creati al momento) da utilizzare per il componente. Un componente può avere un simbolo schematico e più footprint PCB e modelli di simulazione, oppure può avere un modello di cablaggio. Un componente deve avere almeno un modello.
-
Verifica il componente definito per assicurarti che soddisfi i requisiti secondo le impostazioni della pagina Gestione dei dati – Verifiche delle regole dei componenti della finestra di dialogo Preferences. Salva il componente localmente (File » Save), quindi scegli il comando Tools » Component Rule Check dai menu principali. Le eventuali violazioni rilevate vengono elencate nel pannello Messages.
-
Una volta definito il componente, seleziona il comando File » Save to Server dai menu principali per salvarlo nel Workspace. Verrà visualizzata la finestra di dialogo Edit Revision, in cui puoi modificare il nome e la descrizione e aggiungere note di rilascio secondo necessità. L'editor si chiuderà dopo il salvataggio.
Il nuovo componente sarà disponibile per la ricerca e l'utilizzo tramite il pannello Componenti.
Note
-
Per creare un nuovo componente simile a uno esistente nel tuo Workspace, puoi creare una copia di quest'ultimo. Nel pannello Components, individua il componente desiderato, fai clic su di esso con il pulsante destro del mouse e seleziona il comando Operations » Make a copy. L'editor dei componenti si aprirà con il componente predefinito con i dati del componente scelto.
-
Un componente può essere definito utilizzando i dati forniti dalla funzionalità Ricerca parti del produttore. Inizia a digitare nel campo Name e seleziona una parte del produttore corrispondente oppure aggiungi una scelta di parte al componente che stai definendo: si aprirà la finestra di dialogo Usa dati del componente, con i controlli per selezionare i dati da applicare al componente attualmente in fase di creazione/modifica: nome, descrizione, parametri, modelli e schede tecniche.

I dati del componente possono essere acquisiti tramite la ricerca delle parti del produttore. Qui viene mostrato un esempio di accesso alla funzionalità digitando il nome di un componente nel campo Name e selezionando una voce corrispondente dall'elenco a comparsa. -
L'editor dei componenti può operare anche in modalità Modifica in batch dei componenti, che fornisce l'interfaccia per definire/modificare più componenti. Quando l'editor dei componenti è in modalità Single Component Editing, si accede alla modalità di modifica in batch scegliendo il comando Tools » Switch to Batch Editor dai menu principali dell'editor.
-
Per importare rapidamente le librerie esistenti basate su file e su database (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) nel Workspace, puoi utilizzare lo strumento di importazione delle librerie. Questo strumento offre una soluzione con un solo clic che analizza automaticamente le librerie selezionate e le importa nel Workspace a cui sei attualmente connesso.
-
Puoi anche creare un nuovo componente facendo clic con il pulsante destro del mouse sulla voce del Workspace connesso nel pannello Projects e scegliendo il comando Create Component dal menu.
-
Per modificare un componente del Workspace, fai clic con il pulsante destro del mouse sulla voce di un componente nel pannello Componenti e scegli il comando Edit dal menu contestuale. Si aprirà l'editor dei componenti in modalità Single Component Editing, con la definizione del componente aperta per la modifica. Apporta le modifiche necessarie, quindi salva la definizione del componente nella revisione successiva del componente del Workspace.
-
Allo stesso modo, puoi selezionare più componenti nel pannello Componenti e scegliere il comando Edit dal menu contestuale. Se i componenti selezionati fanno riferimento allo stesso modello di componente, si aprirà un'unica istanza dell'editor dei componenti in modalità Modifica in batch dei componenti. In caso contrario, si aprirà un'istanza separata dell'editor dei componenti per ogni gruppo di componenti che condividono lo stesso modello di componente.
-
I componenti del Workspace aperti per la modifica vengono mostrati sotto la voce Workspace Components nel pannello Projects.
Dal menu contestuale della voce Workspace Component, accessibile con il pulsante destro del mouse, puoi aprire i componenti del gruppo, chiuderli, salvarli localmente, salvarli nel Workspace connesso o scartare le modifiche (chiudere senza modificare)
. Quando utilizzi il comando Close All e più componenti del gruppo sono stati modificati, viene visualizzata una finestra di dialogo di conferma del salvataggio, con opzioni pertinenti alla gestione di un'entità del Workspace aperta per la modifica
-
Se tenti di aprire un componente del Workspace per modificarlo come utente con autorizzazioni di sola visualizzazione, si aprirà l'editor dei componenti, consentendoti di accedere ai dettagli del componente, ma senza poter salvare alcuna modifica nel Workspace. In questo caso, la voce relativa a questo componente del Workspace nel pannello Projects viene mostrata con l'etichetta Local Edits Only
-
Quando salvi un componente modificato nella libreria del Workspace, puoi mantenere lo stato attuale del ciclo di vita del componente. Questa possibilità è offerta dall'opzione Preserve lifecycle state (not recommended), disponibile nella finestra di dialogo Edit Revision quando salvi nuovamente il componente (mostra immagine). Quando l'opzione è abilitata, la nuova revisione del componente viene impostata automaticamente sullo stato del ciclo di vita della revisione precedente. Questa funzionalità è disponibile per gli utenti a cui è stata assegnata l'autorizzazione operativa Allow to skip lifecycle state change for new revisions (scopri di più su Impostazione delle autorizzazioni operative globali per un Workspace).
Librerie di database
Altium Designer consente di posizionare i componenti direttamente da un database aziendale, creando e utilizzando una Database Library. Il posizionamento viene eseguito dal pannello Components che, dopo l'installazione di una libreria di database, funge da strumento di esplorazione del database.
Dopo il posizionamento, le informazioni sui parametri di progetto possono essere sincronizzate tra i componenti posizionati e i corrispondenti record collegati nel database. È possibile eseguire aggiornamenti completi dei componenti, inclusi il simbolo grafico, i riferimenti ai modelli e i parametri. Le informazioni parametriche del database possono inoltre essere incluse nella distinta base (BOM) finale, pronta per l'approvvigionamento dei componenti.
Scopri di più sulle Librerie di database.
Librerie basate su file
Se devi conservare i componenti localmente, nel tuo file system, puoi organizzarli in librerie basate su file.
Una libreria di Altium Designer basata su file è una raccolta arbitraria di modelli o componenti. Spetta a te decidere come organizzare i modelli o i componenti nelle librerie. Puoi strutturare le librerie in base ai fornitori di dispositivi oppure raggruppare i componenti per funzione, ad esempio creando una libreria per tutti i microcontrollori utilizzati dalla tua azienda.
I simboli dei componenti dello schema vengono creati nelle librerie schematiche (*.SchLib). I componenti di queste librerie fanno quindi riferimento a footprint e ad altri modelli definiti in librerie di footprint separate (*.PcbLib) e in file di modello. Come progettista, puoi posizionare i componenti da queste singole librerie di componenti oppure compilare le librerie di simboli, le librerie di footprint e i file di modello in librerie integrate (*.IntLib).
Scopri di più sulle Librerie di componenti basate su file.
Modelli
Dal punto di vista del progettista, un componente raccoglie in un'unica entità tutte le informazioni necessarie per rappresentarlo in tutti gli ambiti di progettazione. In questo senso, può quindi essere considerato un contenitore.
Ogni componente è una raccolta di modelli collegati e di dati parametrici del componente. Sono i modelli a contenere le informazioni dettagliate necessarie per ciascun ambito di progettazione.
È possibile utilizzare i seguenti tipi di modello:
| Simbolo schematico | Il simbolo rappresenta il componente sul foglio dello schema. Il simbolo viene creato utilizzando oggetti di disegno standard, mentre i pin aggiungono le proprietà elettriche. |
| Modello SPICE | Simula il comportamento dei componenti collegati utilizzando il simulatore SPICE. I modelli SPICE vengono generalmente forniti dai produttori dei dispositivi. |
| Modello di integrità del segnale | Con l'aumento delle velocità di commutazione dei dispositivi e dei circuiti, le interconnessioni del PCB diventano parte del circuito. I modelli IBIS descrivono il comportamento dei pin, consentendo al simulatore di integrità del segnale di Altium Designer di analizzare le piste. |
| Footprint PCB | Per ogni componente è necessario definire una posizione sul PCB in cui montarlo e collegarlo: il footprint è il modello che definisce tale spazio sul PCB. Un footprint PCB viene creato da un insieme di oggetti standard, con i pad che forniscono la connettività. |
| Modello 3D | I prodotti elettronici di oggi sono compatti e densamente integrati, hanno forme insolite e possono includere un PCB ripiegato per adattarsi all'alloggiamento. Per progettare un prodotto di questo tipo, devi poter modellare il PCB in 3D, così da visualizzare la scheda finita, verificare le distanze di sicurezza in 3D e trasferire la scheda completa di componenti nell'ambiente CAD meccanico. Per farlo, avrai bisogno di un modello 3D di ciascun componente. |
Scopri come creare e gestire Simboli, Modelli di footprint, Modelli di simulazione e Modelli 3D nel tuo Workspace.
Il pannello Components
Il pannello Components consente di accedere direttamente a tutti i componenti disponibili in Altium Designer, inclusi quelli del Workspace, delle librerie basate su database e delle librerie basate su file.
Il pannello recupera i componenti da un Workspace e da tutti i file di libreria aperti o installati. Offre informazioni complete sul componente selezionato (parametri, modelli, scelte dei componenti, dati dei fornitori, ecc.), il confronto tra componenti e, per i componenti del Workspace, una funzione di ricerca parametrica basata su filtri che consente di specificare i parametri desiderati. Grazie a filtri dinamici contestuali, la funzione di ricerca del pannello permette di individuare rapidamente il componente esatto di cui hai bisogno nel Workspace connesso della tua azienda.
Scopri di più sul pannello Components.
Il pannello Manufacturer Part Search
Puoi anche cercare componenti effettivamente disponibili sul mercato utilizzando il pannello Manufacturer Part Search, che adotta le funzionalità di base del motore di ricerca e la visualizzazione utilizzate nel pannello Components. Un componente del produttore selezionato può essere utilizzato come base per un nuovo componente nel tuo Workspace connesso, oppure i suoi parametri e le sue schede tecniche possono essere aggiunti a un componente già posizionato.
L'icona
nella voce di un componente indica che a quel componente sono assegnati dei modelli (simboli schematici, footprint PCB, modelli di simulazione). Quando crei un nuovo componente basato su questo componente del produttore, vengono acquisiti anche i relativi modelli. In alternativa, puoi scaricare il componente in locale o posizionarlo direttamente nello schema.
Scopri di più sul pannello Manufacturer Part Search.
Come proseguire?
Creazione di un simbolo schematico
Creazione di un componente per il cablaggio di un cablaggio preassemblato



).
).



