Accesso, definizione e gestione delle opzioni di progetto
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Le schede General, Error Reporting e Options della finestra di dialogo Project Options
Riepilogo
A un progetto esistente o appena creato è associata una serie di impostazioni delle opzioni specifiche per quel progetto. Queste vengono memorizzate nel file di progetto (ad esempio, *.PrjPcb) e variano a seconda del tipo di progetto. Le impostazioni delle opzioni vengono configurate nella finestra di dialogo Project Options.
Accesso
È possibile accedere alla finestra di dialogo Project Options in uno dei seguenti modi:
- Fare clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects, quindi fare clic su Project Options nel menu contestuale.
-
Fare clic sull'icona
nel pannello Projects quando il progetto desiderato è selezionato nel pannello.
- Da qualsiasi editor, selezionare Project » Project Options dai menu principali.
Schede della finestra di dialogo
Generale

La scheda General della finestra di dialogo Project Options
La scheda General della finestra di dialogo Project Options consente di controllare la disponibilità online e la sincronizzazione di un progetto del Workspace.
Opzioni/Controlli
Quando si accede a questa scheda per un progetto senza essere connessi al relativo Workspace, l'unica opzione disponibile è il pulsante Turn Off Synchronization.
Quando si accede a questa scheda per un progetto non associato a un Workspace, la scheda General della finestra di dialogo Project Options mostra solo il pulsante Make Project Available Online. Fare clic sul pulsante per aprire la finestra di dialogo Rendi disponibile online, che aggiungerà il progetto al Workspace dopo aver completato i passaggi necessari. Al termine, tutte le opzioni della scheda saranno disponibili.
Generale
- Description - utilizzare questo campo per fornire una descrizione facoltativa del progetto, che verrà riportata nel campo della descrizione quando si esplora il progetto nell'interfaccia browser del Workspace.
Disponibilità online e sincronizzazione
-
Version Control - lo stato di questa casella riflette la modalità corrente di disponibilità online. Abilitare questa opzione per archiviare il progetto sotto controllo versione (VCS) nel repository di progettazione Git Versioned Storage del Workspace oppure disabilitarla per utilizzare la sincronizzazione semplice. L'abilitazione del controllo versione formale consente a più utenti di lavorare al progetto, che verrà quindi condiviso con tutti gli altri collaboratori connessi al Workspace.
-
Migrate to Altium 365 Versioned Storage - abilitare questa opzione per migrare un progetto che utilizza un sistema VCS esterno al VCS nativo del Workspace Altium 365. Il progetto convertito, che manterrà la cronologia precedente dei commit VCS, potrà quindi beneficiare delle funzionalità del Workspace basate sul VCS nativo, come la cronologia degli eventi. Questa opzione è disponibile solo per un progetto con mirroring.
-
Server Folder - la cartella del Workspace in cui si trova il progetto.
-
Enable Conflict Prevention Notifications - abilitare questa opzione per gestire l'accesso in modifica ai file ricevendo un avviso quando un membro del team sta modificando lo stesso documento di un progetto del Workspace, così da evitare possibili conflitti tra i dati.
-
Turn Off Synchronization - fare clic su questo pulsante per disattivare la sincronizzazione, in modo che la copia locale del progetto non sia più collegata a quella presente nel Workspace. Il progetto nel Workspace rimarrà invariato.
Requisiti
-
Link Requirements – se il blocco di Requirements Portal non è collegato al progetto, fare clic su questo pulsante per aprire la finestra di dialogo Link Requirements da cui è possibile selezionare il blocco da collegare al progetto.
-
Linked Requirements – se il blocco di Requirements Portal è collegato al progetto, questa voce mostra il blocco collegato Fare clic sul collegamento per modificare l'associazione corrente tra progetto e blocco. Fare clic sul pulsante Unlink per rimuovere il collegamento.
Per ulteriori informazioni, consultare la pagina Requisiti in un progetto.
Segnalazione degli errori

La scheda Error Reporting della finestra di dialogo Project Options (per un progetto PCB)
La scheda Error Reporting della finestra di dialogo Project Options consente di definire i livelli di segnalazione per ciascuna delle possibili violazioni elettriche e di disegno che possono essere presenti nei documenti schematici sorgente durante la convalida del progetto. Durante la convalida del progetto, queste impostazioni delle violazioni vengono utilizzate insieme alle impostazioni della scheda Matrice delle connessioni per verificare la presenza di violazioni di connettività nei documenti sorgente.
Opzioni/Controlli
Elenco delle violazioni
Questo elenco presenta tutte le possibili violazioni elettriche e di disegno che possono essere presenti nei documenti sorgente del progetto. Le violazioni sono raggruppate nelle seguenti categorie:
PCB Design:
Multi-board Design:
Harness Design:
Ogni tipo specifico di violazione viene presentato con i seguenti campi:
- Violation Type Description - una breve descrizione del tipo di violazione.
-
Report Mode - utilizzare questo campo per specificare il livello di gravità associato al mancato superamento del controllo. Utilizzare il menu a discesa per scegliere tra i seguenti livelli di segnalazione:
-
Menu contestuale
Nel menu contestuale sono disponibili i seguenti comandi:
- All Off - impostare Report Mode per tutti i tipi di violazione su No Report.
- All Warning - impostare Report Mode per tutti i tipi di violazione su Warning.
- All Error - impostare Report Mode per tutti i tipi di violazione su Error.
- All Fatal - impostare Report Mode per tutti i tipi di violazione su Fatal Error.
- Selected Off - impostare Report Mode per tutti i tipi di violazione selezionati su No Report.
- Selected To Warning - impostare Report Mode per tutti i tipi di violazione selezionati su Warning.
- Selected To Error - imposta Report Mode per tutti i tipi di violazione selezionati su Error.
- Selected To Fatal - imposta Report Mode per tutti i tipi di violazione selezionati su Fatal Error.
- Default - ripristina le impostazioni predefinite di Report Mode per tutti i tipi di violazione.
- Report Suppressed Violations in Messages Panel - abilita questa opzione per visualizzare le violazioni nel pannello Messages anche se sono state soppresse tramite questa scheda.
Opzione aggiuntiva
- Set To Installation Defaults - fai clic per ripristinare le opzioni della scheda ai valori predefiniti dell'installazione.
Matrice delle connessioni

La scheda Connection Matrix della finestra di dialogo Project Options
La scheda Connection Matrix della finestra di dialogo Project Options offre una matrice che consente di stabilire regole di connettività tra i pin dei componenti e gli identificatori delle net, come porte e ingressi di foglio. Definisce le condizioni logiche o elettriche da segnalare come avvisi o errori. Ad esempio, un pin di uscita collegato a un altro pin di uscita viene normalmente considerato una condizione di errore, mentre due pin passivi collegati tra loro no. Durante la validazione del progetto, queste impostazioni delle violazioni vengono utilizzate (insieme alle impostazioni definite nella scheda Segnalazione errori) per verificare la presenza di violazioni nei documenti sorgente.
Opzioni/Controlli
Matrice delle connessioni
La matrice presenta tutti i possibili controlli dei collegamenti tra combinazioni di pin, porte e ingressi di foglio, oltre a verificare la presenza di entità non collegate. La matrice si legge per righe e colonne e il colore dell'elemento all'intersezione tra riga e colonna specifica come il compilatore risponderà durante la verifica di quella particolare condizione.
Per modificare la modalità di segnalazione di un controllo delle violazioni nella matrice, fai clic sul quadrato colorato all'intersezione tra la riga e la colonna di due entità. A ogni clic, la modalità passa al livello di segnalazione successivo. Sono supportati i seguenti livelli:
- No Report
- Warning
- Error
- Fatal Error
Menu contestuale
Dal menu contestuale accessibile con il pulsante destro del mouse sono disponibili i seguenti comandi:
- All Off - imposta tutte le voci della matrice su No Report.
- All Warning - imposta tutte le voci della matrice su Warning.
- All Error - imposta tutte le voci della matrice su Error.
- All Fatal - imposta tutte le voci della matrice su Fatal Error.
- Default - ripristina i valori predefiniti di tutte le voci.
Opzione aggiuntiva
- Set To Installation Defaults - fai clic per ripristinare le opzioni della scheda ai valori predefiniti dell'installazione.
Generazione delle classi

La scheda Class Generation della finestra di dialogo Project Options
La scheda Class Generation della finestra di dialogo Project Options consente di configurare e controllare la generazione delle classi. Le classi sono raccolte logiche di un particolare tipo di oggetto di progettazione. Ad esempio, un gruppo di componenti correlati può essere riunito in una classe di componenti, che può quindi essere utilizzata come base per creare una regola mirata. Questa scheda offre controlli per determinare quali classi vengono generate automaticamente e quali classi definite dall'utente vengono generate quando i documenti schematici sorgente vengono sincronizzati con il documento di progettazione PCB.
Opzioni/Controlli
Classi generate automaticamente
-
Generate Net Classes for Buses - seleziona questa opzione per generare automaticamente una classe di net per ciascun bus del progetto. I membri di una classe saranno le singole net che compongono il bus da cui è stata generata la classe.
-
Generate Net Classes for Components - seleziona questa opzione per generare automaticamente una classe di net per ciascun componente del progetto. I membri di una classe saranno le net associate a cui sono collegati i pin del componente da cui è stata generata la classe.
-
Generate Separate Net Classes for Bus Sections - seleziona questa opzione per generare automaticamente una classe di net separata per ciascuna sezione di bus. Una sezione di bus viene creata specificando un bus che è in realtà una sezione di un bus più ampio, ad esempio
D[15..8], dal busD[15..0]. -
Generate Net Classes for Named Signal Harnesses - abilita questa opzione per generare automaticamente una classe di net per ciascun cablaggio di segnali con nome presente nel progetto. I membri di una classe saranno le net associate ai segnali raggruppati dal cablaggio di segnali con nome da cui è stata generata la classe.
-
Sheet-Level Class Generation Grid - quest'area consente di controllare la generazione automatica delle classi di componenti e/o di net a livello di singolo foglio schematico. Sono elencati tutti i fogli schematici sorgente del progetto, con le seguenti informazioni per ciascuno:
- Sheet Name - il nome del documento schematico.
- Full Path - il percorso assoluto della cartella in cui si trova il documento.
-
Component Classes - selezionare questa opzione per generare una classe di componenti per il foglio.
- Generate Rooms - selezionare questa opzione per generare una room per la classe di componenti.
-
Net Classes Scope - utilizzare questo campo per stabilire se generare una classe di net per il foglio e, in tal caso, l'ambito della generazione. Il menu a discesa del campo offre le seguenti opzioni:
- None - non generare una classe di net per questo foglio.
- Local Nets Only - generare una classe di net per questo foglio contenente soltanto le net appartenenti alla classe che sono locali al foglio.
- All Nets - generare una classe di net per questo foglio che contenga tutte le net associate al foglio (sia quelle locali sia quelle che si estendono altrove).
-
Structure Classes Generate Structure - selezionare questa opzione per generare una classe di struttura per il foglio.
Una classe di struttura è un tipo speciale di classe che può contenere, come membri, qualsiasi tipo di classe (classe di net, classe di componenti, ecc.). Generando automaticamente una classe di struttura da ciascun foglio schematico del progetto contenente componenti e/o net durante il trasferimento del progetto al PCB, è possibile rappresentare fedelmente la struttura del progetto sul PCB. Le classi di struttura consentono non solo di riprodurre la struttura dei documenti schematici nell'ambiente PCB, per una navigazione avanzata, ma possono anche essere utilizzate nelle query logiche, ad esempio per definire l'ambito di applicazione delle regole di progettazione o per applicare filtri.
Classi definite dall'utente
- Generate Component Classes - selezionare questa opzione per generare classi di componenti definite dall'utente quando il progetto viene trasferito al PCB. Le classi di componenti vengono definite manualmente nello schema aggiungendo un parametro ClassName ai componenti interessati e impostandone il valore sul nome di classe desiderato.
- Generate Rooms for Component Class - selezionare questa opzione per generare room basate sulle classi di componenti definite dall'utente. Questi componenti devono avere un parametro componente denominato 'ClassName'.
- Generate Net Classes - selezionare questa opzione per generare classi di net definite dall'utente quando il progetto viene trasferito al PCB. Le classi di net vengono definite manualmente nello schema mediante la direttiva Net Class. Per rendere una net membro di una classe di net, associare una direttiva Net Class al filo o al bus pertinente (oppure a una blanket) e impostare il valore del relativo parametro ClassName sul nome di classe desiderato.
► Scopri come creare una classe di net definita dall'utente
► Scopri come creare una classe di componenti definita dall'utente
Opzione aggiuntiva
- Set To Installation Defaults - fare clic per ripristinare le opzioni della scheda ai valori predefiniti dell'installazione.
Note
-
Per generare classi (automatiche e/o definite dall'utente) durante il trasferimento del progetto al PCB, è necessario assicurarsi che le rispettive impostazioni del comparatore siano impostate su Find Differences nella scheda Comparatore della finestra di dialogo Project Options, come segue:
- Classi di net - impostare il tipo di confronto Extra Net Classes (nella categoria Differences Associated with Nets) su Find Differences.
- Classi di componenti - impostare il tipo di confronto Extra Component Classes (nella categoria Differences Associated with Components) su Find Differences.
-
Inoltre, nella scheda Generazione ECO della finestra di dialogo Project Options , è necessario assicurarsi che le rispettive impostazioni ECO siano impostate su Generate Change Orders.
- Classi di net - impostare il tipo di modifica Add Net Classes (nella categoria Modifications Associated with Nets) su Generate Change Orders.
- Classi di componenti - impostare il tipo di modifica Add Component Classes (nella categoria Modifications Associated with Components) su Generate Change Orders.
Comparatore

La scheda Comparator della finestra di dialogo Project Options
La scheda Comparator della finestra di dialogo Project Options consente di definire quali tipi di differenze rilevare e quali ignorare durante il confronto dei documenti. Per ogni possibile confronto, è possibile scegliere se rilevare o ignorare le differenze utilizzando il menu a discesa associato nella colonna Mode. È possibile configurare il rilevamento delle differenze per componenti, net, parametri e oggetti fisici in base alle esigenze.
Opzioni/Controlli
Questa finestra di dialogo è suddivisa in due aree principali:
- L'area superiore, denominata Comparison Type Description/Mode, elenca la descrizione e la modalità di confronto di ciascun tipo di confronto disponibile.
- L'area inferiore, denominata Object Matching Criteria, consente di definire i criteri di corrispondenza per Net, Net Class, Component Class, Differential Pair e Structure Class.
Descrizione/Modalità del tipo di confronto
- Comparison Type Description - quest'area elenca le descrizioni di ciascun tipo di confronto disponibile nel progetto. Utilizzare la barra di scorrimento all'estrema destra per scorrere fino a Differences Associated with Components, Differences Associated with Nets, Differences Associated with Parameters, Differences Associated with Physical e Differences Associated with Structure Classes per visualizzare/modificare le modalità di confronto in ciascuna area.
-
Mode - fare clic su una voce per modificare la modalità di confronto utilizzando il menu a discesa:
-
Find Differences- selezionare questa opzione per rilevare le differenze per quel tipo di confronto. -
Ignore Differences- selezionare questa opzione per ignorare tutte le differenze per quel tipo di confronto (non verrà eseguito alcun confronto per quel tipo).
-
Criteri di corrispondenza degli oggetti
- Object Type - elenco dei tipi di oggetti, come Net, Net Class, Component Class, Differential Pair e Structure Class.
- Min Match % - immettere la percentuale minima di corrispondenza desiderata oppure fare clic sul lato destro della colonna e utilizzare i tasti freccia su e giù per aumentare o diminuire il valore.
- Min Matched Members - immettere il numero minimo desiderato di membri corrispondenti oppure fare clic sul lato destro della colonna e utilizzare i tasti freccia su e giù per aumentare o diminuire il valore.
- Use Name Matching - fare clic sulla voce oppure utilizzare il menu a discesa per selezionare After member matching o Never.
- Show Manual Matching Dialog - fare clic sulla voce o utilizzare il menu a discesa per selezionare For unmatched objects o Never.
Opzioni aggiuntive
- Ignore Rules Defined in PCB Only - selezionare questa opzione per ignorare le regole definite solo nel PCB all'interno del progetto. Ad esempio, quando si esegue un ordine di modifica tecnica (ECO), le modifiche possono essere applicate dallo schema al PCB e, se questa opzione è abilitata, le regole presenti solo nel PCB vengono ignorate. Se non sono presenti regole corrispondenti nei fogli schematici dello stesso progetto, il comparatore non tenterà di aggiungere nuove regole.
- Set To Installation Defaults - fare clic per ripristinare le opzioni della scheda ai valori predefiniti di installazione.
Generazione ECO

La scheda ECO Generation della finestra di dialogo Project Options
La scheda ECO Generation della finestra di dialogo Project Options consente di configurare i tipi di modifica che possono essere inclusi quando si genera un ordine di modifica tecnica (Engineering Change Order, ECO) in base alle differenze rilevate dal comparatore.
Opzioni/Controlli
Elenco dei tipi di modifica
Questo elenco presenta tutte le possibili modifiche che possono essere apportate tramite un ordine di modifica tecnica durante la sincronizzazione dei documenti schematici sorgente con il documento di progettazione PCB. Le voci dell'elenco includono categorie per i tipi di modifica associati a Components, Nets, Parameters, Structure Classes, ecc.
Ogni tipo di modifica specifico include i seguenti campi:
- Modification Type Description – una breve descrizione del tipo di modifica (l'azione che deve essere eseguita dal sincronizzatore).
-
Mode – utilizzare questo campo per controllare se il tipo di modifica viene incluso o meno negli ECO generati. Utilizzare il menu a discesa per scegliere tra le seguenti opzioni:
- Generate Change Orders - includere il tipo di modifica in un ECO generato.
- Ignore Differences - escludere il tipo di modifica da un ECO generato.
Menu contestuale
Il seguente comando è disponibile nel menu contestuale accessibile con il pulsante destro del mouse:
- Report – utilizzare questo comando per generare un report delle modalità di modifica attualmente configurate. Verrà visualizzata la finestra di dialogo Report Preview con il report già caricato. Utilizzare questa finestra di dialogo per esaminare il report tramite i vari controlli di pagina e zoom prima di esportarlo in un file o stamparlo.
Opzioni aggiuntive
- Push Component Designator Changes to Annotation File (if any) – selezionare per includere le modifiche ai designatori dei componenti nel file di annotazione.
- Set To Installation Defaults – fare clic per ripristinare le opzioni della scheda ai valori predefiniti di installazione.
Opzioni

La scheda Options della finestra di dialogo Project Options
La scheda Options della finestra di dialogo Project Options consente di specificare il percorso di output e le relative opzioni per gli output generati per il progetto. È inoltre possibile specificare varie opzioni di generazione della netlist e l'ambito degli identificatori di net.
Opzioni/Controlli
-
Output Path – il percorso di output predefinito per la generazione dei file di output dal progetto corrente (
*.PrjPcb). - ECO Log Path – il percorso di output predefinito per i file di log ECO.
-
Schematic Template Location – utilizzare questo campo per specificare una directory da cui recuperare i file dei modelli schematici (
*.SchDot,*.SchDoc) per il progetto.
Opzioni di output
- Open outputs after compile – abilitare per aprire i file generati dopo la compilazione del progetto. Per un progetto di tipo pacchetto di libreria integrata, abilitare l'opzione per installare la libreria integrata dopo la compilazione del progetto del pacchetto.
-
Timestamp folder – abilitare per creare una cartella con data e ora per l'output generato, ad esempio un report della distinta base (Reports » Bill of Materials). Il nome della cartella è nel formato
<FolderName> Date Time, dove<FolderName>è specificato nel campo Output Path eDateeTimehanno lo stesso formato delle impostazioni di sistema. - Archive project document – abilitare per archiviare il documento di progetto. Ad esempio, quando si generano gli output di produzione da un progetto PCB (File » Fabrication Outputs e File » Assembly Outputs), la cartella di output di destinazione includerà una copia del relativo documento PCB.
- Use separate folder for each output type – abilitare per creare cartelle separate per ciascun tipo di output generato per il progetto. Questa struttura di cartelle verrà rappresentata anche nel pannello Projects.
Opzioni netlist
- Allow Ports to Name Nets – abilitare per assegnare un nome a una net utilizzando la proprietà Name di una porta collegata tramite filo, anziché utilizzare un nome di net predefinito generato dal sistema.
- Allow Sheet Entries to Name Nets – abilitare per assegnare un nome a una net utilizzando il nome dell'ingresso del foglio, anziché utilizzare un nome di net predefinito generato dal sistema.
- Allow Single Pin Nets – abilitare per consentire la presenza di net contenenti un solo pin.
-
Append Sheet Numbers to Local Net – abilitare per aggiungere il valore del parametro Sheet Number di un documento schematico (un parametro a livello di documento) alle net locali di quel foglio. Una net locale è una net che non esce dal foglio. Per una net che esce dal foglio (e quindi non è locale), questa opzione non si applica.
- Higher Level Names Take Priority – abilitare affinché le etichette di net utilizzate nei fogli ai livelli superiori della gerarchia assegnino i nomi alle net dei fogli ai livelli inferiori.
-
Power Port Names Take Priority – il software consente di rendere locale una net di alimentazione globale collegando una porta di alimentazione a una porta normale. In questo modo, tutti i pin di quel foglio collegati a quella porta di alimentazione vengono inseriti in una net separata. Abilitando questa opzione, si impone l'assegnazione del nome alla net utilizzando il nome della net assegnata alla porta di alimentazione.
Ambito degli identificatori di net
I progetti multifoglio sono definiti a livello elettrico (o di connettività) dagli identificatori di net. Gli identificatori di net (etichette di net, porte, ingressi di foglio, porte di alimentazione e pin nascosti) creano connessioni logiche tra punti appartenenti alla stessa net. Queste connessioni possono trovarsi all'interno di un foglio o estendersi su più fogli. Le connessioni fisiche esistono quando un oggetto è collegato direttamente a un altro oggetto elettrico tramite un filo. Le connessioni logiche vengono create quando due identificatori di net dello stesso tipo (ad esempio due etichette di net) hanno lo stesso valore della proprietà Net .
Quando viene creato il modello di connettività del progetto, è necessario definire come devono collegarsi tra loro gli identificatori di net: questa operazione corrisponde all'impostazione di Net Identifier Scope. Esistono essenzialmente due modi per collegare i fogli in un progetto multifoglio: orizzontalmente, direttamente da un foglio all'altro e così via, oppure verticalmente, da un sottofoglio al simbolo di foglio che lo rappresenta nel foglio padre. Nella connettività orizzontale, le connessioni avvengono da porta a porta (è disponibile anche il collegamento da etichetta di net a etichetta di net). Nella connettività verticale, le connessioni avvengono da ingresso di foglio a porta.
Utilizzare l'elenco a discesa per scegliere tra i seguenti ambiti:
-
Automatic (Based on project contents) – questa modalità seleziona automaticamente la modalità degli identificatori di net da utilizzare in base ai seguenti criteri: se nel foglio di livello superiore sono presenti ingressi di foglio, viene utilizzata Hierarchical; se non sono presenti ingressi di foglio, ma sono presenti porte, viene utilizzata Flat; se non sono presenti né ingressi di foglio né porte, viene utilizzata Global.
- Flat (Only ports global) – le porte si collegano globalmente su tutti i fogli del progetto. Con questa opzione, le etichette di net sono locali a ciascun foglio, ovvero non si collegano tra fogli diversi. Tutte le porte con lo stesso nome vengono collegate su tutti i fogli. Questa opzione può essere utilizzata per progetti multifoglio non gerarchici. Non è consigliata per progetti di grandi dimensioni, poiché può essere difficile seguire una net attraverso i fogli.
- Hierarchical (Sheet entry <-> port connections, power ports global) – collega verticalmente una porta all'ingresso di foglio corrispondente. Questa opzione realizza le connessioni tra fogli esclusivamente tramite gli ingressi dei simboli di foglio e le porte corrispondenti dei sottofogli. Utilizza le porte sui fogli per portare le net o i bus agli ingressi dei simboli di foglio corrispondenti nel foglio padre. Le porte prive di un ingresso di foglio corrispondente non vengono collegate, anche se su un altro foglio esiste una porta con lo stesso nome. Le etichette di net sono locali a ciascun foglio, ovvero non si collegano tra fogli diversi. Le porte di alimentazione, invece, sono globali: tutte le porte di alimentazione con lo stesso nome sono collegate nell'intero progetto. Questa opzione può essere utilizzata per creare progetti con qualsiasi profondità gerarchica e consente di seguire una net in tutto il progetto sullo schema stampato.
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) – questa modalità di connettività si comporta come la modalità Hierarchical , con la differenza che le porte di alimentazione rimangono locali a ciascun foglio, ovvero non si collegano a porte di alimentazione con lo stesso nome presenti su altri fogli.
- Global (Netlabels and ports global) – le porte e le etichette di net si collegano su tutti i fogli del progetto. Con questa opzione, tutte le net con la stessa etichetta di net vengono collegate tra loro su tutti i fogli. Inoltre, tutte le porte con lo stesso nome vengono collegate su tutti i fogli. Se una net collegata a una porta ha anche un'etichetta di net, il suo nome sarà quello dell'etichetta di net. Anche questa opzione può essere utilizzata per progetti multifoglio non gerarchici; tuttavia, è difficile seguire i collegamenti da un foglio all'altro, poiché individuare visivamente i nomi delle net sullo schema non è sempre semplice.
Consenti lo scambio dei pin con questi metodi
Nell'editor PCB, gli scambi di pin, coppie differenziali e parti vengono eseguiti scambiando le net sui pad dei componenti e il relativo rame. Quando le modifiche vengono integrate negli schemi, lo scambio dei pin può essere gestito in due modi:
-
Adding / Removing Net-Labels – abilitare per consentire lo scambio dei pin su un simbolo di componente. Lo scambio sullo schema tramite lo scambio delle etichette di net può essere eseguito solo se la connettività è stabilita tramite le etichette di net, ovvero se i pin non sono collegati fisicamente tra loro mediante fili.
-
Changing Schematic Pins – abilitare per consentire lo scambio delle etichette di net sui fili collegati ai pin di un componente. Lo scambio dei pin sarà l'unica opzione disponibile quando le net sono state collegate fisicamente a un componente mediante fili. Questo metodo può essere utilizzato su componenti semplici (come una rete di resistori) o quando la struttura dello schema non consente alternative.
Generale
- Automatic Sheet Numbering – abilitare questa opzione per numerare automaticamente i fogli dello schema in questo progetto. Ciò consente di controllare le designazioni dei fogli e di memorizzarle come parametri nei rispettivi documenti schematici.
-
Automatic Cross References – abilitare questa opzione per aggiungere automaticamente le informazioni di riferimento incrociato per porte, connettori fuori foglio e ingressi di foglio a tutti i documenti schematici sorgente del progetto attivo. Questa funzionalità aiuta a seguire la connettività delle net in un progetto non gerarchico.
- New Indexing of Sheet Symbols – abilitare per utilizzare qualsiasi cifra o numero come primo o ultimo indice di un simbolo di foglio ripetuto, incluso 0. I numeri negativi non sono consentiti. L'ultimo indice deve essere sempre maggiore del primo.
Riferimenti incrociati
-
Sheet Style – scegli uno dei seguenti stili di foglio per i riferimenti incrociati delle porte su uno o più fogli dello schema all'interno di un progetto.
-
None– non viene aggiunto alcuno stile di foglio alla stringa dei riferimenti incrociati di tutte le porte. -
Name– i nomi dei fogli a cui sono collegate le porte vengono aggiunti alle stringhe dei riferimenti incrociati. -
Number– i numeri dei fogli a cui sono collegate le porte vengono aggiunti alle stringhe dei riferimenti incrociati.
-
-
Location Style – scegli uno dei seguenti stili di posizione per i riferimenti incrociati delle porte su uno o più fogli dello schema all'interno di un progetto.
-
None– non viene aggiunto alcuno stile di posizione alla stringa dei riferimenti incrociati di tutte le porte. -
Zone– la numerazione delle zone di riferimento (le zone sono indicate sui bordi del foglio) viene aggiunta alle stringhe dei riferimenti incrociati di tutte le porte associate agli oggetti padre, ad esempio per indicare la posizione dei simboli di foglio. -
Location X,Y– le posizioni delle porte vengono riportate tra parentesi nelle stringhe dei riferimenti incrociati di tutte le porte associate agli oggetti padre, ad esempio per indicare la posizione dei simboli di foglio.
-
- Follow Cross References settings in Preferences – quando questa opzione è abilitata, i valori delle opzioni Sheet Style e Location Style vengono ereditati dalle opzioni nell'area Port Cross References della pagina Schema – Generale della finestra di dialogo Preferences.
-
Display Cross References for:
-
Ports – usa il menu a discesa per selezionare la modalità di visualizzazione dei riferimenti incrociati per le porte.
-
Disabled– non viene aggiunto alcun riferimento incrociato alle porte. -
Only Related Sheet Entry– visualizza il riferimento incrociato all'entrata di foglio associata sul foglio dello schema padre. -
Only Related Ports– visualizza i riferimenti incrociati alle porte associate. -
Sheet Entry & Ports– visualizza i riferimenti incrociati sia all'entrata di foglio sia alle porte.
-
- Off-sheet Connectors – abilita questa opzione per visualizzare i riferimenti incrociati per gli oggetti connettore fuori foglio.
- Sheet Entries – abilita questa opzione per visualizzare i riferimenti incrociati per gli oggetti entrata di foglio.
-
Ports – usa il menu a discesa per selezionare la modalità di visualizzazione dei riferimenti incrociati per le porte.
Coppie differenziali
-
Custom Diff Pair Suffix Grid – elenca i suffissi predefiniti delle coppie differenziali (
_P/_N) e tutti i suffissi personalizzati definiti per le coppie differenziali, in termini di:- Positive Suffix – il suffisso per la net positiva di una coppia differenziale.
- Negative Suffix – il suffisso per la net negativa di una coppia differenziale.
- Add – fai clic per aggiungere una nuova coppia di suffissi all' elenco.
- Remove – fai clic per eliminare dall'elenco le coppie di suffissi selezionate.
Creazione di xNets
- Sources/Destinations – definisci un elenco separato da virgole di prefissi per i designatori dei componenti che possono essere utilizzati come componenti di origine o destinazione nelle xNets.
- Discretes – definisci un elenco separato da virgole di prefissi per i designatori dei componenti che possono essere utilizzati come componenti in serie nelle xNets.
Multicanale

La scheda Multi-Channel della finestra di dialogo Project Options
La scheda Multi-Channel della finestra di dialogo Project Options consente di definire lo schema di denominazione delle room e il formato dei designatori dei componenti da utilizzare nei progetti multicanale. La progettazione multicanale consente di fare riferimento più volte allo stesso sottofoglio nel progetto. Ciò può essere fatto posizionando più simboli di foglio che fanno riferimento allo stesso sottofoglio oppure includendo la parola chiave Repeat nel designatore di un simbolo di foglio per istanziarlo più volte.
Altium Designer offre una vera progettazione multicanale, il che significa che puoi fare riferimento ripetutamente a singoli fogli in un progetto. Le eventuali modifiche necessarie possono essere applicate in un unico punto e, ricompilando il progetto, vengono propagate a ogni istanza. Altium Designer non solo supporta più canali, ma consente anche di annidarli.
La corrispondenza tra il singolo componente logico sullo schema e le molteplici istanze fisiche sul PCB è controllata dallo schema dei designatori multicanale definito in questa scheda.
Opzioni/Controlli
Denominazione delle room
-
Room Naming Style - usa questo campo per specificare lo stile da utilizzare per assegnare i nomi alle room. Quando selezioni uno stile dall'elenco, l'immagine sottostante viene aggiornata per riflettere la convenzione di denominazione che apparirà nel progetto. Quando il progetto viene compilato, viene creata una room per ogni foglio del progetto, inclusi ciascun banco e ciascun canale di livello inferiore. Sono disponibili cinque stili: due piatti e tre gerarchici (quelli che includono il percorso):
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths - usa questo campo per specificare il carattere/simbolo richiesto per separare le informazioni del percorso quando si utilizzano gli stili di denominazione gerarchici (quelli che includono il percorso). Per impostazione predefinita, viene utilizzato il carattere di sottolineatura (_).
- Preview - quando apporti modifiche a Room Naming Style e/o Designator Format, l'immagine in quest'area si aggiorna dinamicamente per riflettere la convenzione di denominazione che apparirà nel progetto. L'immagine mostra un esempio di progetto con canali annidati 2 x 2. Le aree tratteggiate più grandi rappresentano i due canali di livello superiore (o banchi), mentre le aree ombreggiate al loro interno rappresentano i canali di livello inferiore (con due componenti di esempio mostrati in ciascuno).
Denominazione dei componenti
-
Designator Format - utilizzare questo campo per specificare il formato da usare per assegnare i designatori ai componenti del progetto. Nell'elenco a discesa del campo sono disponibili i seguenti otto formati predefiniti: cinque piatti e tre utilizzabili in un contesto gerarchico (che includono la denominazione dei canali):
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
Definizione di un formato personalizzato per i designatori
È anche possibile definire un formato personalizzato per i designatori dei componenti digitandolo direttamente nel campo Designator Format. Per creare la stringa di formato è possibile utilizzare le seguenti parole chiave:
- $RoomName - il nome del canale associato, determinato dallo stile scelto nel campo Room Naming Style .
- $Component- il designatore logico del componente.
- $ComponentPrefix - il prefisso del designatore logico del componente (ad esempio, U per U1).
- $ComponentIndex - l'indice del designatore logico del componente (ad esempio, 1 per U1).
- $ChannelPrefix - il designatore logico del simbolo di foglio.
- $ChannelIndex - l'indice del canale.
- $ChannelAlpha - l'indice del canale espresso come carattere.
Note
- L'indicizzazione alfabetica di un canale è realmente utile solo se il progetto contiene meno di 26 canali in totale o se si utilizza un formato di designatore di tipo gerarchico.
- Per un progetto multicanale, nella parte inferiore del foglio schematico nella finestra di progettazione vengono visualizzate delle schede, una per ciascun canale (o banco). I nomi delle schede sono costituiti dai nomi dei simboli di foglio seguiti dal numero del canale, ad esempio BANKA. Queste sono le viste compilate (viste fisiche) del progetto, mentre il progetto logico rimane invariato nella scheda Editor.
Stampe predefinite

La scheda Default Prints della finestra di dialogo Project Options
La scheda Default Prints della finestra di dialogo Project Options consente di impostare gli output di stampa predefiniti per i vari editor di Altium Designer. Queste impostazioni predefinite vengono utilizzate quando si eseguono i seguenti comandi di stampa dai menu principali degli editor:
- File » Print
- File » Print Preview » Print
È possibile accedere alla scheda Default Prints della finestra di dialogo Project Options anche dall'editor degli schematici e dall'editor PCB, scegliendo il comando File » Default Prints dai menu principali.
Opzioni/Controlli
L'area principale della scheda presenta un elenco di tutti gli output di stampa supportati che è possibile generare dagli editor degli schematici e PCB. I tipi di output sono raggruppati nelle seguenti categorie:
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
Per ogni voce vengono visualizzate le seguenti informazioni:
- Output Description – ciò che viene prodotto utilizzando questo tipo di output di stampa.
- Supports – l'editor per il quale è supportato questo tipo di output di stampa.
-
Default Print – indica se questo tipo di output di stampa deve essere utilizzato come tipo di stampa predefinito (abilitato) o meno (disabilitato).
Opzioni aggiuntive
-
Configure – fare clic su questo pulsante per accedere alla finestra di dialogo associata, con cui configurare l'output di stampa attualmente selezionato. Le finestre di dialogo disponibili includono:
- Finestra di dialogo Stampa – per configurare disegni di assemblaggio, disegno composito, stampe PCB, stampe PCBLIB, stampe degli schematici, disegno di foratura composito, disegno/guide di foratura, stampe degli esecutivi finali, stampe dei piani di alimentazione e stampe delle maschere di saldatura/pasta saldante.
- Finestra di dialogo Impostazioni di stampa PCB 3D – per configurare le stampe PCB 3D.
- Finestra di dialogo Video PCB 3D – per configurare gli output video PCB 3D.
- Finestra di dialogo PDF3D – per configurare gli output PDF3D e PDF3D MBA.
- Finestra di dialogo Proprietà avanzate di stampa del testo – per configurare le stampe dei report e dei testi. Definire le opzioni per l'output stampato (ad esempio, intestazione e numerazione di pagine/righe). È inoltre possibile specificare l'utilizzo di un determinato carattere.
- Wave Print Properties Form finestra di dialogo – per configurare le stampe SimView.
- Finestra di dialogo Configurazione report stack di layer – per configurare gli output dei report dello stack della scheda.
- Finestra di dialogo Gestione report – per configurare i report della distinta base e di confronto delle BOM.
- Finestra di dialogo Configurazione esportazione commenti – per configurare un report di esportazione dei commenti.
- Finestra di dialogo Configurazione differenze – per configurare un report delle differenze.
- Finestra di dialogo Configurazione controllo regole elettriche – per configurare un report di validazione del controllo delle regole elettriche.
- Page Setup – fare clic per accedere alla finestra di dialogo di impostazione della pagina per l'output di stampa attualmente selezionato. Nella finestra di dialogo è possibile configurare la stampa con la stampante scelta in termini di carta, scala e impostazioni dei colori. È inoltre possibile accedere alla finestra di dialogo di configurazione pertinente e a quella di impostazione della stampante, visualizzare l'anteprima di stampa e infine stampare l'output con la stampante selezionata.
Percorsi di ricerca

La scheda Search Paths della finestra di dialogo Project Options
La scheda Search Paths della finestra di dialogo Project Options consente di specificare i percorsi di ricerca dei file di libreria e dei modelli per il progetto.
Opzioni/Controlli
Elenco ordinato dei percorsi di ricerca
Questa griglia mostra l'elenco ordinato dei percorsi di ricerca dei file di libreria e dei modelli (ad esempio, librerie di footprint PCB, modelli di simulazione e di integrità del segnale). Per ciascun percorso è possibile specificare il filtro e le impostazioni di ricerca ricorsiva.
- Path - posizione del percorso di ricerca.
- Filter - il filtro per la ricerca. Per impostazione predefinita, il filtro cerca tutti i file.
- Recursive - selezionare per cercare in tutte le sottocartelle della cartella del percorso di ricerca. Fare doppio clic su un percorso di ricerca per modificarlo.
- Add - consente di aprire la finestra di dialogo Edit Search Path per aggiungere un nuovo percorso di ricerca.
Sono supportati i seguenti tipi di file: librerie di footprint (*.PcbLib), file di modelli di simulazione (*.mdl), file di sottocircuiti di simulazione (*.ckt), file di modelli IBIS (*.ibs).
- Delete - consente di rimuovere un percorso di ricerca selezionato.
- Properties - consente di accedere alla finestra di dialogo Edit Search Path per modificare le proprietà del percorso di ricerca selezionato.
- Move Up - consente di spostare il percorso di ricerca selezionato di una riga verso l'alto.
- Move Down - consente di spostare il percorso di ricerca selezionato di una riga verso il basso.
File trovati in tutti i percorsi di ricerca
Questa griglia mostra i file di librerie e modelli trovati nei percorsi dell'elenco Ordered List of Search Paths. Utilizzare il pulsante Refresh List per visualizzare un elenco aggiornato.
Parametri

La scheda Parameters della finestra di dialogo Project Options
La scheda Parameters della finestra di dialogo Project Options consente di gestire i parametri definiti per il progetto, spesso indicati come project-level parameters. I parametri definiti a livello di progetto possono essere utilizzati in tutti i fogli schematici e i documenti PCB del progetto tramite stringhe speciali: =<ProjectParameterName> in uno schema (ad esempio, =Project) e .<ProjectParameterName> in un PCB (ad esempio, .Project). I parametri possono essere utilizzati per fornire informazioni di progettazione aggiuntive. I parametri a livello di progetto, ad esempio, possono essere utilizzati globalmente come origine dei dati parametrici delle stringhe speciali da aggiungere ai fogli schematici e/o al documento PCB; quest'ultimo non supporta parametri locali.
I parametri di progetto lato Workspace vengono salvati nel Workspace insieme al progetto e possono essere modificati solo dall'interfaccia browser del Workspace (ulteriori informazioni su Editing a Project in Altium 356 Workspace o On-Prem Enterprise Workspace). I parametri di progetto lato progettazione, invece, vengono salvati nel file di progetto (*.PrjPcb) e possono essere modificati in Altium Designer. I parametri di progetto lato Workspace vengono visualizzati nella scheda Parameter della finestra di dialogo Project Options con un'icona blu , mentre i parametri di progetto lato progettazione vengono visualizzati con un'icona arancione
Opzioni/Controlli
-
Parameters Grid – l'area principale elenca tutti i parametri attualmente definiti per il progetto, in termini di:
- Name – il nome del parametro.
- Value – il valore del parametro.
-
Add – fare clic per aprire la finestra di dialogo Parameter Properties, in cui è possibile aggiungere un parametro. Utilizzare i campi Name e Value per assegnare al parametro rispettivamente un nome significativo che ne rifletta lo scopo e il relativo valore. Entrambi i campi consentono un massimo di 255 caratteri.
- Remove – fare clic per eliminare i parametri selezionati dall'elenco dei parametri. Questa opzione non è disponibile per i parametri di progetto lato Workspace, poiché possono essere rimossi o modificati solo nel Workspace.
- Edit – fare clic per aprire la finestra di dialogo Parameter Properties, in cui è possibile modificare il contenuto del parametro attualmente selezionato. Questa opzione non è disponibile per i parametri di progetto lato Workspace, poiché possono essere rimossi o modificati solo nel Workspace.
- Refresh – fare clic per annullare le ultime modifiche apportate al parametro di progetto lato progettazione. Per i parametri di progetto lato Workspace, fare clic per assicurarsi di disporre della versione più recente del parametro. Le modifiche apportate ai parametri di progetto lato Workspace all'interno del Workspace non verranno riportate in questa finestra di dialogo finché non si utilizza questa opzione.
Menu contestuale
Nel menu contestuale sono disponibili i seguenti comandi:
-
Edit – consente di modificare il parametro attualmente selezionato nella finestra di dialogo Parameter Properties. Questo comando non è disponibile per i parametri di progetto lato Workspace, poiché possono essere rimossi o modificati solo nel Workspace.
-
Add – consente di aggiungere un nuovo parametro lato progettazione all'elenco nella finestra di dialogo Parameter Properties.
-
Remove – consente di eliminare i parametri selezionati dall'elenco. Questo comando non è disponibile per i parametri di progetto definiti nel Workspace, poiché possono essere rimossi o modificati solo nel Workspace.
-
Copy – consente di copiare i parametri selezionati negli appunti di Windows.
-
Paste – consente di incollare i parametri presenti negli appunti di Windows nell'elenco dei parametri. Questo comando non è disponibile per i parametri di progetto definiti nel Workspace, poiché possono essere rimossi o modificati solo nel Workspace.
Fogli dispositivo

La scheda Device Sheets della finestra di dialogo Project Options
La scheda Device Sheets della finestra di dialogo Project Options consente di specificare le cartelle in cui si trovano i fogli dispositivo e il loro ordine.
Opzioni/Controlli
- Main region - elenca i Device Sheet Folders percorsi del progetto corrente. Selezionare Include Sub-folders per includere le sottocartelle delle cartelle principali elencate.
- Move Up - consente di spostare la cartella dei fogli dispositivo selezionata verso l'alto di una posizione alla volta.
- Move Down - consente di spostare la cartella dei fogli dispositivo selezionata verso il basso di una posizione alla volta.
- Add - consente di aprire una finestra di dialogo per cercare una nuova cartella da aggiungere.
- Remove - consente di rimuovere la cartella dei fogli dispositivo selezionata.
OutputJob gestiti

La scheda Managed OutputJobs della finestra di dialogo Project Options
La scheda Managed OutputJobs della finestra di dialogo Project Options consente di configurare un elenco di modelli di job di output disponibili nel Workspace connesso da utilizzare con il progetto.
Opzioni/Controlli
- Outputjob List - elenca tutti gli OutputJob del Workspace in termini di Item Revision, Revision State, Description e Name.
- Add - fare clic per aprire la finestra di dialogo Select configuration item (Output Jobs) e selezionare gli OutputJob desiderati.
- Remove - fare clic per rimuovere i job di output selezionati.
Opzioni della libreria

La scheda Library Options della finestra di dialogo Project Options
La scheda Library Options della finestra di dialogo Project Options consente di selezionare il formato per un progetto di libreria integrata.
Opzioni/Controlli
-
Integrated Library Format
- Original - selezionare per utilizzare il formato originale della libreria integrata. Questo formato viene utilizzato per la compatibilità con il software Protel DXP (DXP 2002), precedente all'introduzione di Altium Designer.
-
Altium Designer- selezionare per utilizzare Altium Designer come formato della libreria integrata (utilizzato in tutte le versioni del software a partire dalla versione originale Altium Designer 2004).
).
