Ispezione dei dati di fabbricazione con il CAM Editor
A colpo d'occhio
- Impara a selezionare, eseguire, ripetere e annullare i comandi nell’editor CAM.
- Comprendi come le modalità CAM e NC visualizzano in modo diverso le immagini di fabbricazione, i punti di foratura e i percorsi di fresatura.
- Scopri come gestire la visibilità dei layer, selezionare il layer corrente e accedere ai comandi dei layer tramite il pannello CAMtastic.
L'editor CAMtastic (CAM) di Altium Designer offre una varietà di strumenti, i più basilari dei quali consentono di visualizzare e modificare i dati CAM. Dopo aver importato i file immagine e di foratura, è possibile fornire all'editor CAM le istruzioni che definiscono i tipi di layer e lo stackup; a quel punto, si può estrarre una netlist e confrontarla con una netlist IPC generata dal software di progettazione PCB originale. Queste netlist gestiscono non solo i componenti a foro passante, ma anche i via ciechi e interrati. L'editor CAM offre inoltre strumenti per il controllo delle regole di progettazione, la pannellizzazione e la fresatura NC.
Nozioni di base sulle operazioni CAM
L'ambiente dell'editor CAM utilizza metodi leggermente diversi da quelli a cui potresti essere abituato per eseguire operazioni e procedure.
L'azione prima della selezione
Il modo in cui si eseguono le operazioni nell'editor CAM può sembrare invertito ai nuovi utenti abituati a selezionare gli oggetti before indicare al programma cosa farne. Analogamente ad altri strumenti CAM, l'editor CAM inverte questo processo: prima scegli l'azione, poi selezioni gli oggetti su cui intervenire e infine impartisci un comando di esecuzione.
Se non sei abituato a lavorare in questo modo, puoi affidarti a un paio di accorgimenti finché non avrai preso dimestichezza. Innanzitutto, osserva il cursore. Quando appare come un mirino a croce nell'area di progettazione, significa che non è in modalità di selezione (durante la modalità di selezione viene visualizzato un cursore con un riquadro quadrato). Il fatto che i pulsanti di selezione siano tutti disattivati può ricordarti che non hai ancora scelto un'azione, o almeno non una che richieda selezioni generiche. La barra di stato, situata nella parte inferiore della finestra principale di modifica, è particolarmente utile durante le procedure composte da più passaggi, quando ti chiedi perché non succeda nulla: ti indica quale operazione l'editor CAM sta aspettando che tu esegua.
Esecuzione con il pulsante destro del mouse
Prima scegli un comando, poi selezioni un insieme di oggetti. A questo punto, l'editor CAM attende un comando di esecuzione. Questo ti permette di comporre con cura la selezione su diversi layer e gruppi di oggetti. Il modo più semplice per inviare il comando di esecuzione è fare clic con il pulsante destro del mouse. I messaggi in Status Bar indicano quando è possibile usare il pulsante destro in questo modo. Puoi anche usare la scorciatoia da tastiera Shift+F9 per eseguire la funzione corrente dopo aver selezionato tutti gli oggetti necessari.
Potresti notare che, dopo aver eseguito una funzione, il cursore non torna allo stato inattivo. Il riquadro di selezione rimane invece visibile e la barra di stato ti invita a iniziare una nuova selezione. Questo accade quando l'opzione Auto Repeat Functions è abilitata nella pagina CAM Editor - General della finestra di dialogo Preferences.
Il pulsante destro del mouse può talvolta essere usato per annullare le procedure in corso. Questo funziona quando non hai ancora completato un passaggio obbligatorio, come la selezione degli oggetti. Il tasto Esc è tuttavia una scelta più sicura per annullare le operazioni in generale.
Modalità di modifica
L'editor CAM supporta due modalità di modifica: CAM e NC (fresatura). Le modalità vengono abilitate tramite i rispettivi comandi CAM Editor e NC Editor, disponibili selezionando View » CAM Editor oppure View » NC Editor dal menu principale. In alternativa, puoi impostare la modalità di modifica direttamente dal menu a discesa disponibile nel pannello CAMtastic . Essenzialmente, queste modalità differiscono per il modo in cui vengono visualizzati i dati. La modalità CAM Editor mostra le immagini esattamente come verranno tracciate o impresse sulla pellicola fotografica utilizzata per la fabbricazione del PCB. La modalità NC Editor aggiunge marcatori ai fori e ai percorsi di fresatura.
Un percorso di fresatura visualizzato in modalità NC Editor.
L' CAM Editor si troverà sempre in una di queste due modalità di modifica. In modalità CAM Editor, gli strumenti di fresatura nei menu saranno disattivati. Analogamente, quando è attiva la modalità NC Editor, i normali strumenti di modifica CAM sono disabilitati. Quando è attiva la modalità CAM Editor , il pannello CAMtastic consente di accedere rapidamente, tramite un elenco a discesa, ai DCode definiti nell'elenco delle aperture. Quando è attiva la modalità NC Editor, questo elenco a discesa mostra invece l'insieme degli utensili per la foratura e la fresatura. Soprattutto, l'area di progettazione rispecchia la modalità di modifica corrente. La modalità NC Editor indica i punti di foratura e i percorsi di fresatura con marcatori speciali: ogni punto di foratura è contrassegnato da una X, mentre i percorsi di fresatura contengono punti di affondamento e di retrazione e, quando necessario, anche marcatori di direzione. Questi marcatori di istruzione non sono visibili quando si lavora in modalità CAM Editor.
Il pannello CAMtastic
Il pannello, disponibile ogni volta che è attivo un documento CAM, contiene le informazioni principali relative a quel documento, tra cui i layer, il DCode o l'utensile corrente, le impostazioni di griglia/unità e la posizione assoluta del cursore nell'area di progettazione. Puoi anche passare tra le sezioni Info, DRC, Nets e Steps del pannello per consultare altre informazioni specifiche del progetto.
La sezione Layers mostra tutti i layer creati/importati e il relativo stato di visibilità. Il layer corrente presenta una X bianca sul relativo campione di colore ed è indicato anche nella parte superiore della sezione. Puoi fare doppio clic sul nome di un altro layer per renderlo corrente.
Quando sono presenti dei layer, facendo clic con il pulsante destro del mouse in un punto qualsiasi di questa sezione puoi accedere rapidamente ai comandi dei layer, tra cui quelli per bloccarli, rinominarli o aggiungerli. Se hai creato un nuovo documento e desideri iniziare ad aggiungere layer, usa il comando Edit » Layers » Add per aggiungere il primo layer.
Puoi evidenziare qualsiasi layer in questo elenco e quindi usare i tasti Up Arrow e Down Arrow della tastiera per scorrere i dati CAM in modalità a layer singolo. Il tasto Right Arrow rende visibili tutti i layer, mentre il tasto Left Arrow isola il layer evidenziato. È possibile selezionare più layer utilizzando le funzionalità standard Shift+Click e Ctrl+Click, che consentono di mostrare, nascondere o eliminare più layer contemporaneamente. Puoi usare i tasti +/- e * del tastierino numerico per scorrere, rispettivamente, tutti i layer visibili o solo i layer di segnale/piano.
È possibile eliminare i layer dal pannello, ma si tratta di un'operazione irreversibile. Il comando Undo nel menu Edit non ripristina i layer eliminati.
È possibile passare dal pannello CAMtastic al documento CAM attivo e viceversa utilizzando la scorciatoia da tastiera Shift+F5. Il tasto F4 attiva o disattiva la visibilità di tutti i pannelli mobili.
Contenuto e utilizzo del pannello CAMtastic
Funzionalità del pannello
L'elenco a discesa nella parte superiore del pannello consente di passare rapidamente dalla modalità Editor CAM alla modalità Editor NC e viceversa. La sezione immediatamente sotto questo campo elenca tutti i layer disponibili nel documento CAM corrente (*.cam). I layer sono elencati nello stesso ordine in cui compaiono nella finestra di dialogo Layers Table, accessibile selezionando Tables » Layers dal menu principale.
Per ogni layer nell'elenco vengono indicati il nome e il numero, insieme a un'opzione per controllarne la visibilità (attivata o disattivata). È inoltre disponibile un riquadro colore, che mostra il colore attualmente assegnato al layer. Facendo clic sul colore si apre la finestra di dialogo Change Layer Color , che offre una varietà di colori tra cui scegliere.
Nella parte superiore dell'elenco dei layer viene visualizzato il nome del layer corrente. Il layer corrente è quello utilizzato per posizionare nuovi oggetti, come linee, polilinee e punti di foratura. Il layer corrente è inoltre contrassegnato da una croce bianca nel riquadro colore della relativa voce. Per rendere corrente un layer, fare doppio clic sulla sua voce nell'elenco.
Facendo clic con il pulsante destro del mouse sulla voce di un singolo layer nell'elenco, viene visualizzato un menu contenente i seguenti comandi relativi ai layer:
- Type - utilizzare questo comando per visualizzare il tipo assegnato al layer nella finestra di dialogo Layers Table.
- ON - consente di attivare o disattivare la visibilità del layer. Quando il layer è attivo (ovvero è visibile nell'area di progettazione), viene visualizzato un segno di spunta a sinistra del comando e viene abilitata la corrispondente opzione di visibilità del layer.
- Current - consente di rendere corrente il layer selezionato. Viene visualizzato un segno di spunta a sinistra del comando, il nome del layer compare nel campo Current Layer (nella parte superiore dell'elenco dei layer) e una croce bianca viene visualizzata nel riquadro colore associato al layer.
- Lock / Lock Selected - consentono di bloccare i layer selezionati, impedendo qualsiasi operazione di disegno su di essi. Quando l'opzione è abilitata, viene visualizzato un segno di spunta a sinistra del comando.
- RESCan / RESCan Selected - consentono di confrontare, per il layer selezionato, le date dei dati (Gerber/ODB ++ Feature) presenti nel documento CAM attivo e di quelli generati più di recente dallo stesso documento PCB sorgente. Se i dati generati più di recente sono successivi a quelli esistenti, il comando Reload viene abilitato.
- Reload / Reload Selected - consentono di rigenerare i dati del layer selezionato per il quale il processo Rescan ha rilevato modifiche. Tutte le modifiche al layer vengono importate nel documento CAM attivo per risincronizzarlo con il documento PCB sorgente.
- All On - consente di rendere visibili (attivi) tutti i layer nell'area di progettazione.
- All Off - consente di rendere invisibili (disattivati) tutti i layer nell'area di progettazione.
- Isolate - consente di rendere invisibili (disattivati) tutti i layer nell'area di progettazione, ad eccezione del layer scelto (attivo).
- Scroll Up - consente di scorrere verso l'alto i layer nell'elenco, a partire da quello attualmente selezionato. Ogni layer selezionato viene reso corrente e tutti gli altri layer vengono resi invisibili nell'area di progettazione.
- Scroll Down - consente di scorrere verso il basso i layer nell'elenco, a partire da quello attualmente selezionato. Ogni layer selezionato viene reso corrente e tutti gli altri layer vengono resi invisibili nell'area di progettazione.
- Compare - consente di aprire la finestra di dialogo Compare Layers, in cui è possibile confrontare due layer, modificare la tolleranza del layer e cambiare la risoluzione del layer di mappatura.
- Compress Layers - consente di combinare in un unico layer i layer per i quali è specificato lo stesso tipo nella tabella dei layer. Questo vale solo per i layer di cui dovrebbe esistere una sola istanza per progetto (ad es. superiore, inferiore, solder mask, serigrafia, foratura superiore, foratura inferiore).
- Rename - consente di rinominare il layer attualmente selezionato. Dopo aver avviato il comando, viene visualizzata la finestra di dialogo Enter Value. Digitare un nuovo nome per il layer (solo in minuscolo) e fare clic su OK: il nuovo nome sostituisce quello precedente.
-
Add Layer - consente di creare un nuovo layer e aggiungerlo all'elenco. Dopo aver avviato il comando, viene visualizzata la finestra di dialogo Enter Value. Immettere un nome per il nuovo layer (solo in minuscolo) e fare clic su OK: il layer viene aggiunto in fondo all'elenco.
Se nell'elenco sono selezionati più layer, la voce Tipo nel menu visualizza Selezione multipla e i seguenti comandi non sono disponibili: Attivo, Corrente, Blocca, Scorri verso l'alto, Scorri verso il basso e Aggiungi layer. - Turn On / Turn On Selected - consente di rendere visibili (attivi) tutti i layer selezionati nell'area di progettazione. Questo comando è disponibile solo se almeno uno dei layer selezionati è attualmente disattivato.
- Turn Off / Turn Off Selected - consente di rendere invisibili (disattivati) tutti i layer selezionati nell'area di progettazione. Questo comando è disponibile solo se almeno uno dei layer selezionati è attualmente attivo.
- Lock / Lock Selected - consente di bloccare i layer selezionati, impedendo qualsiasi operazione di disegno su di essi. Quando il layer è bloccato, viene visualizzato un segno di spunta a destra del comando. Per sbloccare i layer, fare nuovamente clic sui layer bloccati.
- Delete / Delete Selected - consente di eliminare i layer selezionati dal documento CAM.
Scheda Info
La scheda Info
La scheda Info visualizza informazioni dopo l'esecuzione di uno dei comandi di interrogazione (Oggetto, Gruppo, Rete, Anello anulare minimo), disponibili nel menu Analysis .
Scheda DRC
La scheda DRC
La scheda DRC elenca le violazioni presenti dopo l'esecuzione di un controllo delle regole di progettazione (DRC) sul documento corrente. Per ogni controllo che rileva violazioni, viene visualizzata una cartella di primo livello, con sottocartelle per tutti i singoli oggetti che violano le regole. Facendo clic su una sottocartella, gli oggetti interessati vengono selezionati, ingranditi e centrati nella finestra dell'editor di progettazione.
Se l'errore DRC può essere corretto mediante la funzione di correzione automatica, è possibile fare clic con il pulsante destro del mouse sulla sottocartella dell'errore e selezionare Correggi errore DRC dal menu a comparsa.
Scheda Reti
La scheda Nets
La scheda Nets visualizza le reti incluse nel progetto dopo che la netlist è stata estratta selezionando il comando Tools » Netlist » Extract. Per ogni voce viene indicata anche la lunghezza totale della rete. Facendo clic sulla voce di una rete, tutti gli oggetti associati a tale rete vengono selezionati, ingranditi e centrati nella finestra dell'editor di progettazione.
Scheda Step
La scheda Steps
La scheda Steps visualizza gli Step ODB attualmente definiti per il documento. Il nome dello Step corrente è visualizzato nella parte superiore della scheda. Facendo doppio clic sulla voce di uno Step, questo diventa lo Step corrente.
Fare clic con il pulsante destro del mouse sulla voce di uno Step nella scheda per accedere a un menu a comparsa contenente i seguenti comandi:
- Current - consente di impostare lo Step selezionato come Step corrente. A sinistra della voce del comando viene visualizzato un segno di spunta.
- Delete - consente di eliminare lo Step selezionato dal documento di progettazione. Non è possibile eliminare lo Step corrente né uno Step inserito in un altro Step.
- Rename - consente di rinominare lo Step selezionato. Dopo aver avviato il comando, viene visualizzata la finestra di dialogo Enter Value. Inserire il nuovo nome dello Step (solo in minuscolo) e fare clic su OK: il nuovo nome sostituirà tutte le occorrenze del nome corrente.
-
Add Insert - consente di inserire uno Step all'interno di un altro. Viene visualizzata la finestra di dialogo Add Insert to ODB Step. Utilizzare questa finestra per selezionare lo Step da inserire (dall'elenco degli Step disponibili) e definirne la posizione, le dimensioni della matrice e l'orientamento. Facendo clic su OK, l'inserimento viene aggiunto nella scheda come sotto-Step dello Step padre designato, nel formato: n: NomeStep (Righe, Colonne), dove [n] è il numero successivo disponibile assegnato allo Step inserito, a partire da 1.
Nella finestra dell'editor di progettazione, lo Step inserito viene visualizzato come una serie di rettangoli bianchi vuoti, il cui numero è determinato dalle dimensioni della matrice scelte nella finestra di dialogo Add Insert to ODB Step. Vengono visualizzate anche delle croci bianche, una per ogni Step della matrice; la croce in basso a sinistra si trova alle coordinate del punto base scelto, anch'esse definite nella finestra di dialogo. Queste croci definiscono dove verranno posizionati gli oggetti dello Step inserito se si sceglie di esplodere la matrice di Step. Il comando per esplodere la matrice di Step è disponibile facendo clic con il pulsante destro del mouse sulla voce del sotto-Step nella scheda. Il menu a comparsa che viene visualizzato contiene anche i comandi per modificare ed eliminare la matrice di Step inserita. - Add Step - consente di creare un nuovo Step. Viene visualizzata la finestra di dialogo Enter Value. Inserire un nome per il nuovo Step (solo in minuscolo) e fare clic su OK: lo Step verrà aggiunto in fondo all'elenco e impostato come Step corrente.
-
Move Objects - consente di spostare oggetti da uno Step a un altro. Questo comando è disponibile solo se lo Step di origine dello spostamento è quello corrente.
Dopo aver avviato il comando, il cursore assume la forma di un piccolo quadrato e viene richiesto di selezionare gli oggetti da spostare. Posizionare il cursore sui singoli oggetti e fare clic per selezionarli oppure utilizzare uno dei numerosi strumenti di selezione disponibili.
Una volta effettuata la selezione, fare clic con il pulsante destro del mouse per aprire la finestra di dialogo New Step for Objects. Selezionare lo Step in cui si desidera spostare gli oggetti e fare clic su OK: gli oggetti verranno rimossi dallo Step corrente e aggiunti allo Step di destinazione. - Copy Objects - consente di copiare oggetti da uno Step a un altro. Questo comando è disponibile solo se lo Step di origine della copia è quello corrente. Il comando è simile a Sposta oggetti, con l'unica differenza che gli oggetti selezionati non vengono rimossi dallo Step di origine, ma soltanto copiati.
- Add Venting - consente di aggiungere un motivo di venting attorno ai PCB disposti in un pannello. Questo comando è disponibile solo se i PCB sono stati pannellizzati mediante il comando Tools » Panelize PCB o caricando dati ODB++ contenenti un pannello.
- Remove Venting - consente di rimuovere qualsiasi motivo di venting da un PCB pannellizzato. Può essere utilizzato, ad esempio, se i contorni del PCB sono stati modificati dopo l'aggiunta del venting.
- Refresh Inserts - consente di aggiornare gli inserimenti disponibili per riflettere le modifiche.
La parte inferiore del pannello contiene i seguenti campi:
- 1 - A seconda che si stia utilizzando la modalità Editor CAM o Editor NC, questo controllo consente di selezionare rispettivamente il codice D o l'utensile di foratura corrente.
- 2 - Questo controllo consente di selezionare la modalità corrente di aggancio agli oggetti.
- 3 - Questo controllo consente di modificare le unità di misura correnti dello spazio di progettazione, scegliendo tra millimetri e pollici.
- 4 - Questo campo del pannello visualizza le coordinate X-Y della posizione del cursore nello spazio di progettazione principale. Utilizza le unità di misura selezionate nel controllo 3.
Ulteriori informazioni sugli Step
- Ogni Step ODB definito nel progetto contiene lo stesso elenco di layer. La differenza tra gli Step risiede negli oggetti contenuti in tali layer.
- Prima di poter inserire uno Step in un altro, è necessario definire almeno due Step per il documento corrente.
- A differenza di una normale matrice Step & Repeat, quando uno Step viene inserito in un altro, la matrice risultante è costituita interamente da elementi rappresentati solo dal contorno. L'elemento in basso a sinistra non visualizza tutti gli oggetti dello Step. Facendo clic sulla voce di primo livello dello Step inserito (non sulla relativa voce sotto lo Step padre definito), gli oggetti contenuti nello Step inserito vengono visualizzati nella posizione contrassegnata dalla croce bianca in basso a sinistra. Lo Step padre e tutti gli altri elementi della matrice nello Step inserito non vengono visualizzati.
-
La scheda Steps viene aggiornata automaticamente ogni volta che si fa clic su OK nella finestra di dialogo Steps Table, che si apre selezionando Tables » Steps dal menu principale.
Il codice D, la modalità di aggancio agli oggetti e le unità di misura dello spazio di progettazione possono essere modificati durante il posizionamento di elementi grafici (ad esempio linee, polilinee, rettangoli, ecc.). Ad esempio, è possibile posizionare una linea con segmenti tracciati utilizzando codici D diversi, tutti nella stessa sessione di posizionamento. È possibile disegnare una polilinea e cambiare il codice D durante il posizionamento; al termine, il codice D corrente verrà applicato all'intera polilinea.
Note
- Per impostazione predefinita, i colori Draw e Flash assegnati a un layer sono identici. Modificando il colore assegnato al layer nel pannello, verranno aggiornati entrambi i colori Draw e Flash nella finestra di dialogo Layers Table. Per modificare singolarmente i colori Draw o Flash, occorre modificare le rispettive voci nella finestra di dialogo. Quando si modificano i colori tramite la finestra di dialogo, solo il colore assegnato a Draw verrà riportato nel pannello.
- Selezionare una voce nell'elenco dei layer e premere il tasto Left Arrow per disattivare tutti i layer tranne quello selezionato. Selezionare una voce nell'elenco dei layer e premere il tasto Right Arrow per attivare tutti i layer.
- I comandi basati su Rescan e Reload saranno disponibili solo se l'opzione Reset auto-load options after generation è stata abilitata prima della generazione iniziale dell'output Gerber/ODB++. Questa opzione si trova nella finestra di dialogo Output Job Options, accessibile dal menu Tools quando il file Output Job associato (*.OutJob) è attivo. Abilitando questa opzione, si impedisce che i dati di output vengano caricati in un nuovo documento CAM quando vengono successivamente generati dal documento PCB sorgente.
- Dopo l'estrazione della netlist dalle informazioni Gerber contenute nel documento corrente, le net vengono elencate nella scheda Nets del pannello con nomi predefiniti. Questi nomi hanno il formato $Netn (dove n è il numero intero progressivo assegnato in base all'ordine di estrazione). Se è stata importata una netlist in formato IPC-D-356, generata dal documento PCB, è possibile rinominare le net con i nomi più significativi assegnati nel progetto PCB originale. A tale scopo, scegliere Tools » Netlist » Rename Nets dai menu principali.
- È possibile selezionare più net nella scheda Nets: tutte verranno quindi selezionate nella finestra dell'editor di progettazione.
- Quando si esaminano gli errori DRC, selezionando una voce nella scheda DRC verranno attivati solo i layer su cui si trovano gli oggetti che violano le regole. Tutti gli altri layer verranno disattivati. Quando si esaminano le net, i layer pertinenti devono essere attivati in precedenza, altrimenti potrebbe non essere visualizzato nulla.
