製造に向けた設計準備
概略
- プロジェクト間での再利用に適したデータソースの選択など、OutJobに出力を追加して設定する方法を学びます。
- 出力をコンテナや印刷ジョブに割り当て、生成ファイルの保存先を管理する方法を理解します。
- リリースオプション、設定に応じた検証、データ生成、レビューを含む、プロジェクトのリリースワークフローを順に確認します。
設計サイクルの最終段階は、製品の製造に必要な出力ファイルを生成することです。そのためには、さまざまな形式の出力ファイルを生成する必要があります。設計者は、回路図エディターとPCBエディターで出力を個別に設定して生成するか、必要なすべての出力をOutputJobに追加して、プロジェクトのリリースプロセスの一環として生成するかを選択できます。

最終的な目標は、製品を製造することです。たとえば、PCBの製造と実装がこれに当たります。
Output Jobによる製造データの準備
各エディターの File メニューと Reports メニューから、出力を個別に設定して直接生成できます。この場合、対応する設定ダイアログで OK をクリックすると出力が生成され、Project OptionsダイアログのOptionsタブにある Output Path フィールドで指定した場所に書き込まれます。
一方、Output Jobファイルを使用すると、設計の出力準備を効率化し、整合性の高いプロジェクトリリースプロセスを通じて出力を生成できます。Output Job(略して「OutJob」)は、基本的には事前設定された出力のセットであり、各出力の設定を保存するとともに、生成される出力の書き込み先を定義します。
設計プロジェクトに新しいOutJobを追加するには、Projects パネルでプロジェクトの項目を右クリックし、コンテキストメニューから Add New to Project » Output Job File コマンドを選択します。デフォルトのOutJobがデザインスペースに開きます。

新しく作成したOutJobが、デザインスペースのアクティブドキュメントになります。
OutJobの左側では、さまざまな用途に応じた多数の出力タイプを追加して設定できます。出力は、実装用出力、製造用出力、レポート出力など、機能別のカテゴリに分類されています。
必要なタイプの出力を新しく追加するには、カテゴリの下部にある該当する Add New <Type> Output テキストをクリックし、ポップアップメニューから必要な出力タイプを選択します。各出力タイプの項目にはサブメニューがあり、データソース、つまり出力の生成時に使用するソースドキュメントを指定できます。出力はいくつでも追加できます。
特定の出力タイプでは、リスト内の出力を右クリックし、コンテキストメニューからConfigureコマンドを選択することで、追加した出力を設定できます。出力のオプションを定義するための設定ダイアログが開きます。たとえば、Gerber X2 Setup出力の場合はGerber X2 Setupダイアログが開きます。
出力の生成先と形式を定義するには、出力コンテナと印刷ジョブを使用します。出力は、対応している場合、PDF、動画、フォルダー構造(ガーバーファイルなど、特定の形式の出力ファイル)の3種類の出力コンテナに書き込めます。また、一部の出力は、印刷ジョブを追加して設定することで、印刷デバイスに直接送信して紙に印刷することもできます。
新しいOutJobには、各タイプの出力コンテナが1つずつと、デフォルトプリンター用の印刷ジョブが含まれています。これらの項目は、OutJobの右側に表示されます。 必要に応じて、Add New Output Containerコントロールをクリックして必要なコンテナタイプを選択すると、新しい出力コンテナを追加できます。また、Add New Print Jobコントロールをクリックして必要なプリンターを選択すると、新しい印刷ジョブを追加できます。
どの出力をどの出力コンテナ/印刷ジョブで生成するかを指定するには、コンテナまたはジョブを選択し、出力リストで必要な各出力のEnabledフラグにチェックを入れます。有効にすると、出力と選択した出力コンテナ/印刷ジョブが緑色の線で結ばれます。出力は、個別の出力コンテナ/印刷ジョブにも、共有の出力コンテナ/印刷ジョブにも割り当てられます。

Enabledフラグを使用して、追加した出力を対応する出力コンテナや印刷ジョブに割り当てます。
出力コンテナ/印刷ジョブを設定するには、その項目を選択してChange コントロールをクリックします。対応するダイアログが開きます。たとえば、フォルダー構造の出力コンテナを選択した場合は、Folder Structure settingsダイアログが開き、生成するファイルの出力先や、ファイル生成に関するその他のオプションを設定できます。

対応するダイアログで、出力コンテナ/印刷ジョブの設定を行います。
OutJobで設定した出力は、OutJobから直接生成することも、PCB設計プロジェクトの場合は、整合性の高いプロジェクトリリースプロセスの一環として生成することもできます。出力コンテナ/印刷ジョブに関連付けられた出力をOutJobから直接生成するには、そのコンテナまたはジョブを選択し、それぞれ Generate content またはPrintコントロールをクリックします。
基板設計のリリース
基板設計のリリースプロセスを使用すると、PCBプロジェクトのOutJobファイルで設定したすべての製造データを一度に生成できます。このプロセスには、出力を個別に生成する場合やOutJobから直接生成する場合と比べて、いくつもの利点があります。たとえば、リリースプロセスの一環として設計を検証でき、リリース中の手動操作をなくすことができます。また、接続先のWorkspaceにリリースする場合は、Workspaceのバージョン管理と緊密に連携できます。
プロジェクトのリリースを開始するには、Projectsパネルでプロジェクトの項目を右クリックし、コンテキストメニューから Project Releaserコマンドを選択します。Releaseビューが別のタブとして開きます。

Project Releaserのユーザーインターフェースである Release ビューにアクセスします。
リリースプロセスは段階的に進みます。Release ビューの左側にある項目で、現在の段階を確認できます。
リリースプロセスの初期段階で、ビューの左下にある Options ボタンをクリックすると、Project Release Options ダイアログを開き、必要に応じてリリースプロセスのオプションを設定できます。オプションには、リリース先(Workspace、フォルダー、またはzipファイル)の選択やOutJobの割り当てなどがあります。

Project Release Options ダイアログでリリースオプションを設定します。
選択したリリース先によって、リリースプロセスのステージは多少異なります。以下では、接続されたWorkspaceへのリリースを例として示します。
|
Configure Server Release ステージでは、生成するデータの種類を指定できます。指定できるのは、ソースデータ(ソース設計のスナップショットで、常にリリースに含まれます)、製造データ、および実装データです。 実装データセットは、ベース設計(バリアントを適用していない設計) と、検出されたすべての設計バリアントに対応する数だけ生成されます。準備ができたら、ビューの右下にある Prepare ボタンをクリックして次に進みます。問題が見つかった場合は、その解決策が提示されます。 割り当てられたOutJobファイルで、デザインルールチェックレポートなどの検証タイプのレポートが1つ以上検出されると、Validate Project ステージが自動的に実行され、対応する検証出力が 実行されます。 いずれかの検証チェックに合格しなかった場合、リリースは失敗します。 前のステージが問題なく完了すると、Generate Data ステージが自動的に実行されます。このステージでは、割り当てられたOutJobファイルで定義されているその他すべての出力が 実行され、リリースするデータが生成されます。 すべての検証チェックに合格し、出力データが生成されると、Review Data ステージで生成されたデータを確認できます。ビューの右下にある Release ボタンをクリックし、表示されるダイアログでリリースを確認して、リリースを進めます。 前のステージでリリースを確認すると、自動的に Upload Data ステージに移行します。このステージには、データのアップロードの進行状況が表示されます。 プロセスの最終ステージである Execution Report ステージには、リリースの概要が表示されます。プロジェクトのリリースが完了したら、ビューの右下にある Close ボタンをクリックして、 Release ビューを閉じることができます。 |









