設計プロジェクトのリリース
概略
- 設計バリアントの実装用出力を含め、ソース、基板製造、実装の各データがどのように整理・保存されるかを理解します。
- バージョン管理、一括リリース、オプションの検証チェックが、リリースの整合性を保つうえでどのように役立つかを学びます。
- Project Releaserの使用に向けた準備とアクセス方法、確定前に生成された出力を確認する方法、およびサポートされている公開オプションを通じてリリース済みデータを共有する方法を確認します。
設計を広く世に送り出す準備が整ったら、リリースが必要です。しかし、このプロセスの重要性は軽視されがちです。
規律があり、基本をしっかり押さえたリリースプロセスがなければ、成熟を続ける製品を長期にわたって追跡する際に、さまざまな問題が生じかねません。たとえば、製品の以前のリビジョンに戻ってリリースする必要が生じたとき、そのリリースに必要なすべての設計ソースファイルがスナップショットとして保存されていなかったとしたらどうでしょう。それでも、そのリリースに対応するフォルダーから、生成済みの出力ファイルを取り出せばよいと思うかもしれません。頼りになるガーバーファイルと、その他の基板製造・実装情報さえあれば、実際には十分だからです。しかし、その「頼りになる」出力が上書きされていたり、何らかの理由で破損していたりしたらどうでしょう。リリースプロセスがもっと堅牢であれば、こうした事態は防げたはずです。
Altium Designerは、強力で高い整合性を備えた設計プロジェクトのリリース管理により、この課題に応えます。プロジェクトの設計リリースプロセスが自動化されるため、手動のリリース手順に伴うリスクなしに設計プロジェクトをリリースできます。特定のプロジェクトをリリースすると、設計ソースのスナップショットが取得され、生成されたすべての出力とともにアーカイブされます。これらは、その設計プロジェクトから製造され、企業が販売する実際の製品を表すものです。リリースデータは、ハードドライブ上の指定したフォルダーまたはZipファイル、あるいは対象のWorkspace内にある、該当するプロジェクト関連アイテムのリビジョンに保存されます。
- Source Data (PCB Project Design Item) – すべてのソースドキュメントを含む、プロジェクトの主要な設計ファイルのタイムスタンプ付きコピー(スナップショット)です。Workspace内の独立したアイテムにリリースされるため、製品の製造を外部に委託する際に必要な基板製造・実装データと、貴重な知的財産を分けて管理できます。
- Fabrication Data (PCB Fabrication Data Item) – 基板製造業者がベアボードを製造するために必要なデータセットです(ガーバーファイル、NCドリルファイルなど)。
- Assembly Data (PCB Assembly Data Item) – 実装業者が部品表に従い、指定された部品をベアボードに実装するために必要なデータセットです (ピックアンドプレースファイル、実装図、BOMなど)。ベースとなる設計(すべての部品を実装した設計)と、設計に定義された各バリアント(実装バリアント)には、それぞれ固有のアイテムが使用されます。

設計プロジェクトから生成されたデータは、プロジェクト関連アイテムのリビジョン内に、Workspaceで安全に保存されます。この高い整合性を持つデータをサプライチェーンで使用し、必要なリビジョンの製品を製造します。
その結果、設計プロジェクトのリリース管理において、極めて高い整合性を実現できます。実際の設計プロジェクトが厳密に監視され、バックアップされ、バージョン管理されるだけでなく、リリースデータも対象のWorkspace内で同様に管理されます。堅牢性、安全性、セキュリティを備えた管理が可能になります。
主な利点
- バージョン管理との統合。プロジェクトがバージョン管理下にある場合、リリースする前にすべてのファイルがチェックインされ、最新の状態であることが求められます。これにより、重要な設計ドキュメントの「個人用コピー」がエンジニアのハードドライブ上に残され、失われる可能性を防げます。このシンプルなルールによって、リリース済み製品の生成に使用した正しい設計ドキュメント一式を後から探し出すために、多くの時間とコストを費やさずに済みます。
- 「一度限りのリリース」。対象アイテムの特定のリビジョンに対して、リリースできるのは一度だけです。実際には、リリースが成功すると、参照先のアイテムリビジョンにリリースデータがコミット(保存)され、そのリビジョンはクローズされます。同じリビジョンに追加のデータを生成してリリースすることはできません。
- 自動化された、再現性のある設計リリースプロセス。ワンタッチでリリースでき、手作業の工程も、それに伴うリスクもありません。設計ファイルのスナップショット取得から検証、出力の生成まで、ユーザーの操作は不要です。プロセスの一部が失敗すれば、リリースも失敗します。仕組みはいたってシンプルです。また、対象のWorkspace内のアイテムリビジョンにリリースデータを最終的にコミットする前に、生成されたすべてのデータを確認できます。
-
設計リリースプロセスの一環として設計を検証できます。リリースプロセスは、依存関係も含めて変更できないように固定された設計ソースのスナップショットに基づいて実行されます。また、通常はリリースを開始する前に、リリース前の検証がすでに実施されているはずです。ただし、さらに安心を得て設計データの整合性を確保するために、適切に設定した出力ジョブ設定を通じて、リリースプロセスの「フロー」に検証チェックを任意で追加できます。ソース回路図の標準的なERCチェックやPCBのDRCチェックに加えて、ソースプロジェクトとPCBが同期していることの確認や、基板上のフットプリントとソースライブラリの比較による、最新状態での一致の確認も可能です。いずれかの検証チェックに合格しなかった場合、リリースは失敗します。
- 設計リリースプロセスで生成されるすべてのデータファイルには、必要に応じてアイテムIDとアイテムリビジョンIDを接頭辞として付加できます。これにより、そのデータをどのアイテムのどのリビジョンの製造に使用すべきかが明確になります。
- 公開。Workspaceから、Amazon S3、FTPサーバー、Box.com、または通常のネットワークフォルダーなどの共有ストレージに、リリースデータを直接公開できます。これにより、外部関係者にWorkspaceへのアクセス権を与えることなく、Workspaceのデータを安全かつ簡単に共有できます。
Project Releaser
Altium Designerは、Project Releaserにより、強力で高い整合性を備えた設計プロジェクトのリリース管理を実現します。直感的なユーザーインターフェースを使用して、基板製造データ、実装データ、設計ソースなど、プロジェクトのすべての製造データを同時に生成できます。Project Releaserでは、PCB設計で検出された複数のバリアントの実装データを同時に生成することもできます。Output Jobファイルを作成していない場合でも心配はありません。必要に応じて自動的に作成できます。
Project Releaserを使用すると、高い整合性を維持しながら、製造データを簡単に生成できます。また、リリースを確定する前に、生成されたデータを確認することもできます(たとえば、CAMエディターでGerber/ODB++データを表示できます)。これにより、生成されたデータが、設計を初回から予定どおりに製造するために必要なデータであることを確認できます。
設計プロジェクトをWorkspaceにリリースするための前提条件は次のとおりです。
- Altium Designerが、リリース先のリポジトリをホストするWorkspaceに接続されていること。
- プロジェクトに適切なOutput Jobs(印刷、ファイル、PDFなどの出力に使用する設計データ出力ジェネレーター)が含まれていること。OutJobがない場合、Project Releaserは、処理に必要な適切なOutJobの作成を提案します。
- リリース処理の対象となるプロジェクトに、必要な要素がすべて揃っていること。たとえば、ソースデータが有効かつ最新であり、ユーザーがそのプロジェクトをWorkspaceにリリースするための十分な権限を持っていることなどです。
Project Releaserへのアクセス
リリース処理は、Altium DesignerのProject Releaserを使用して実行します。そのユーザーインターフェースは、専用のビューであるReleaseビューに用意されています。次の方法でアクセスできます。
- メインメニューからProject » Project Releaserコマンドを選択します(対象プロジェクトのソースドキュメントをアクティブなドキュメントとして開いておきます)。
- Projectsパネルで対象プロジェクトのエントリを右クリックし、コンテキストメニューからProject Releaserコマンドを選択します。

Releaseビュー — Project Releaserのユーザーインターフェース。
PLMへのパブリッシュ
Related page: PLM連携(Altium 365 Workspace、Enterprise Server Workspace)
Project Releaserの一部としてPLMインスタンスにパブリッシュするプロセスが有効化されている場合、そのプロセスがプロジェクトのProject Releaserサブメニューに表示されます。このプロセスを開始すると、パブリッシュを行うためのステージがビューに追加されます。
Workspaceには、Project Activitiesプロセステーマの一部として、Publish to PLM (User selects)サンプルプロセス定義が用意されています。この定義は、標準のパブリッシュ(前述のProject Releaserの一部として行うパブリッシュではないもの)を実行するためのものです。このプロセスでは、リリース済みのプロジェクト出力を連携先のPLMインスタンスにパブリッシュでき、パブリッシュする出力をユーザーが個別に選択できます。ワークフロー図を以下に示します。

デフォルトの Publish to PLM (User selects) サンプルプロセス定義のワークフロー図
標準のPLMパブリッシュプロセスには、Altium Designer内で、アクティブなプロジェクトのProject » Project Activitiesサブメニューからアクセスできます。

Altium Designer内から、Workspaceプロジェクトのリリース済みデータをPLMインスタンスに標準パブリッシュするための、有効化済みプロセスにアクセスする様子。
リリースモード/リリース先
Project Releaserは、ローカルでバージョン管理されていないプロジェクト、外部VCSで管理されているプロジェクト、接続先のWorkspaceのネイティブなバージョン管理下にあるプロジェクトなど、あらゆる種類の設計プロジェクトに対応し、次の2つの動作モードを提供します。
- Managed (Online) Mode — 生成されたすべてのデータを、リリース先Workspace内のアイテムのリビジョンにリリースします。アイテムのリビジョンを上げることを覚えておく必要もありません。すべて自動的に処理されます。また、Project Releaserを通じてPLMインスタンスにリリースするプロセスが定義されている場合、そのプロセスを開始すると、リリースを行うためのステージがビューに追加されます。
- Unmanaged (Offline) Mode — 生成されたすべてのデータをフォルダー構造にリリースします。必要に応じて、1つのZipファイルにまとめることもできます。
Project Releaserは、使用するリリースモードとリリース先の自動検出を試みます。選択肢がある場合、通常はプロジェクトがあるWorkspaceにリリース済みで、現在は別のWorkspaceに接続している場合には、利用可能な選択肢が表示されます。
Output Jobファイルの検出
Altium Designerで設計出力を生成する基本的な方法は、用意されている各種の設計出力ジェネレーターを使用することです。これらは、設計を実際の製品として製造するために必要なデータファイルやアートワークを生成します。具体的には、設計の基板製造と実装に必要な回路図およびPCBの印刷出力、GerberおよびNCドリルの基板製造ファイル、部品表(BOM)、ピックアンドプレース実装ファイル、製造図面などです。
選択した出力ジェネレーターと、それらが設計用に作成する具体的な出力ファイルは、Output Job Editorを使用してまとめて定義します。ジェネレーターと出力の対応付け設定は、File » New » Output Job Fileコマンドで作成したOutput Jobファイル(*.OutJob)に保存されます。
Altium DesignerのOutput Jobsは、設計の製造ファイルを一括生成するための中核的な仕組みであり、さらに次の機能を備えています。
- 1つの設計に任意の数のOutJobを追加できるため、基板製造、実装、アーカイブ、調達、ドキュメント作成など、特定の作業向けの出力設定を用意できます。
-
OutJobファイルは再利用可能であり、標準化された一式の設計出力が必要な任意の設計プロジェクトに適用できます。たとえば、ドキュメントソースのオプションとして特定の設計ファイルではなく
[Project]を選択すると、汎用的な(したがって他のプロジェクトにも適用可能な)Output Jobを作成できます。 - OutJobには、電気的ルールチェック(ERC)、デザインルールチェック(DRC)、フットプリントとソースの比較など、設計の検証チェック用ファイルを含めることができます。このように、検証用の出力ジョブは、設計をチェックし、実際の出力(PDFドキュメントなど)に検証処理の結果を示す、特殊な「アクティブ」な用途に当たります。
- OutJobは、実装基板設計のバリエーションに対応しています。追加の部品や異なる種類の部品を使用した製品の標準版や高性能版など、設計の別バージョンを製造するために、それぞれ異なる出力ファイル一式が必要となる場合に使用します。基板設計のバリエーションの詳細については、設計バリアントを参照してください。
現在、プロジェクトにOutput Jobファイルが関連付けられていない場合、Project Releaserがこれを検出し、デフォルトのファイルを追加するかどうかを確認します。追加を選択すると、次のファイルが作成されます。
-
PCB設計プロジェクトの場合:
-
Assembly.OutJob– 次の出力が定義されています:-
Documentation Outputs:
PCB 3D Print,Schematic Prints -
Assembly Outputs:
Generates pick and place files,Assembly Drawings -
Report Outputs:
Bill of Materials -
Export Outputs:
Export STEP
-
Documentation Outputs:
-
Fabrication.OutJob– 次の出力が定義されています:-
Documentation Outputs:
PCB Prints -
Fabrication Outputs:
Gerber Files,NC Drill Files, およびIPC-2581 -
Validation Outputs:
Design Rules Check,Footprint Comparison Report -
Export Outputs:
Save As/Export PCB
-
Documentation Outputs:
これらのデフォルトのOutput Jobファイルは、次のデフォルトのインストールフォルダーから取得されます:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs。 -
-
ハーネス設計プロジェクトの場合:
-
Assembly.OutJob– 次の出力が定義されています:- Documentation Outputs: Draftsman
-
Report Outputs:
Bill of Materials -
Validation Outputs:
Electrical Rules Check
このデフォルトのOutput Jobファイルは、次のデフォルトのインストールフォルダーから取得されます:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs\Harness。 -
バリアントの検出
PCBプロジェクトでは、Project Releaserの非常に強力な機能として、設計に定義されているバリアントを検出し、それぞれについてリリース可能な実装データセットを作成できます。各実装データセットには、デフォルトで次の形式のターゲットアイテム名が表示されます。
PCBA-[ProjectName]-[VariantName]
[VariantName]サフィックスにより、割り当てられたOutJobファイルからデータを生成する際に、正しいバリアントが使用されます。

設計に定義されたバリアントの検出に基づいて作成された追加の実装データセット。
リリースプロセス
リリースプロセスは段階的に進行します。Releaseビューの左側にある項目で、現在の段階を一目で確認できます。
オンラインリリースモードのリリースプロセスについては、 Workspaceへのリリース ページを参照してください。オフラインリリースモードの詳細については、 ローカルへのリリース ページを参照してください。
リリース済みデータの公開
Related page: 公開先の操作
PCB設計プロジェクトから生成されたリリース済みデータ(PCB製造データ、PCB実装データ、PCBプロジェクト設計アイテムのみ)は、WorkspaceまたはOutput Jobから、Box.com、Amazon S3、FTPサーバー、共有ネットワーク上の通常のフォルダーなどのストレージに直接公開できます。設計チーム、製造チーム、そして製品の構想を実現するプロセスに関わるすべての人々からなる「製品チーム」のメンバーが世界各地に分散していることも多い現在、これは配布とコラボレーションの面で大きな利点となります。
公開するには、Publishing Destinationを定義し、必要なアイテムリビジョンのリリース済みデータをその公開先にアップロードします。中国の製造工場、キーウ、スタンステッド・アボッツ、サンディエゴの設計チーム、さらには太平洋上を飛行中のプロジェクトディレクターまで、新しいリリースについて知る必要があるすべての人を、公開フォルダーへのリンクで招待できます。共有され、管理されたアクセスを通じて、アイテムの製造に必要なデータを閲覧し、議論し、活用できます。

リリース済みデータをストレージに公開し、世界各地のチームメンバー間で情報を共有できます。
製造パッケージデータのグローバル共有
Altium 365 Workspaceに保存された設計プロジェクトの重要な特長の1つは、リリース用のBuild Packageを作成し、他のユーザーと共有できることです。製造業者と直接共有する場合、製造業者が閲覧、ダウンロードし、基板の製造と実装に使用できるパッケージであることから、Manufacturing Packageと考えることができます。
このようなパッケージを他のユーザーや、通常は組織外にいる製造業者と共有できるよう、Altium 365プラットフォームは専用のManufacturing Package Viewerを提供しています。これはプラットフォームのGlobal Sharingサポートの一部で、他のユーザーが世界中のどこからでも、任意のWebブラウザーで製造パッケージを閲覧できるようにします。閲覧はWorkspaceの外部で行われるため、設計そのものやその他の貴重な知的財産へのアクセスは制限されたままです。
共有相手の各ユーザーには、Manufacturing Package Viewerで製造パッケージを閲覧するためのリンクが記載された招待メールが届きます。共有された製造パッケージは、ブラウザーベースのAltium 365プラットフォームインターフェースのShared with Meページに表示されます。
Manufacturing Package Viewer自体では、主要な関係者、特に製造担当者が、主要な基板データを含む設計の概要を確認できます。また、ソースデータ、製造データ、実装データの構造を参照し、必要に応じて個々のファイルをダウンロードすることもできます。ビューアーには製造、実装、BOMデータのサブページも用意されています。製造ページにはGerberビューアーが表示され、パッケージを共有されたすべてのユーザーがコメントを追加できます。
最終的に、製造担当者は閲覧したリリースのビルドパッケージをビューアーのどのページからでもダウンロードし、そのリビジョンの基板を実際に製造できます。
Webビューアー
Related page: Web Viewer (Altium 365 Workspace、Enterprise Server Workspace)
WorkspaceのWeb Viewerインターフェースでは、標準的なWebブラウザーからPCBプロジェクトのドキュメントに幅広くアクセスできます。単なるWebベースのビューアーにとどまらず、Web Viewer'sの高度なブラウザー技術により、プロジェクト構造の閲覧、設計ドキュメントの操作、設計内の要素に関する情報の抽出、コメントを付ける領域やオブジェクトのハイライト表示が可能です。
ドキュメントの表示では、Web形式であっても回路図やPCBの表示品質は損なわれません。また、パンやズームのほか、設計全体にわたるコンポーネントやネットの検索、クロスプローブ、選択、詳細確認にも対応しています。

WorkspaceのWeb Viewerインターフェースは、設計プロジェクト内のソース回路図やPCBドキュメントなどをレビューする際に、没入感のあるインタラクティブな操作環境を提供します。ここでは、Altium 365のWeb Viewerインターフェースで表示した回路図を示しています。画像にマウスポインターを重ねると、PCBの3D表示に切り替わります。
独立したブラウザーベースの表示プラットフォームであるWeb Viewerインターフェースでは、設計編集環境でプロジェクトを開かなくても、設計ドキュメントに読み取り専用でアクセスし、インタラクティブに操作できます。Web Viewer内での操作は、関連するコメント通知を除き、設計の担当エンジニアなど、その設計に取り組んでいるほかのユーザーには影響しません。
