프로세스 생성 및 관리

Altium Designer는 강력한 협업 설계 환경을 제공합니다. 그중 하나가 Workflows 지원으로, 이를 통해 회사의 설계자들이 다음과 같은 일반적이고 일상적인 설계 프로세스를 따라갈 수 있습니다:

  • 새 Workspace 라이브러리 부품 요청
  • 설계 검토 수행
  • 새 Workspace 프로젝트 생성

특정 설계 프로세스를 구현하는 데 사용되는 각 Workflow는 Process Definition의 일부로 생성됩니다. 따라서 해당 프로세스의 기반 Workflow, 또는 간단히 Process Workflow라고 부를 수 있습니다.

프로세스와 해당 Workflow는 Enterprise Server Workspace의 브라우저 인터페이스를 통해 생성 및 관리되며, 이는 해당 Workspace의 관리자가 수행합니다.

앞서 언급한 세 가지 설계 영역에 대해 사전 정의된 프로세스 워크플로가 서버 설치와 함께 제공됩니다. 이들 중 일부는 기본적으로 바로 사용할 수 있도록 활성화되어 있습니다. 이를 그대로 사용하거나, 수정하거나, 필요에 따라 회사 요구사항에 맞는 자체 프로세스를 만들 수 있습니다. 나머지는 샘플로 제공되며, 있는 그대로는 활성화하여 사용할 수 없습니다. 따라서 각각은 일종의 '템플릿'에 가깝습니다. 회사의 요구사항과 명칭에 맞게 편집한 뒤 새 프로세스 정의로 저장하고, 이후 can 활성화하여 다른 모든 정의와 함께 사용할 수 있습니다.

강력한 Process Workflow Editor는 회사 요구사항에 맞춰, 필요한 만큼 단순하거나 복잡한 Workflow를 갖는 프로세스를 구축할 수 있는 유연성을 제공합니다.

프로세스 액세스

모든 프로세스 관리는 Enterprise Server Workspace 브라우저 인터페이스의 Processes 영역(Admin – Processes)에서 수행됩니다.

인터페이스의 Processes 영역을 보려면 Enterprise Server Workspace의 관리자로 로그인되어 있어야 합니다.

Enterprise Server Workspace 브라우저 인터페이스의 Processes 영역에 액세스하는 모습 – 프로세스 및 관련 워크플로 작업을 위한 중앙 허브입니다.Enterprise Server Workspace 브라우저 인터페이스의 Processes 영역에 액세스하는 모습 – 프로세스 및 관련 워크플로 작업을 위한 중앙 허브입니다.

Processes 인터페이스는 다음 네 개의 탭으로 구성됩니다:

  • Browser – 모든 프로세스(활성 또는 종료됨)의 요약 목록을 제공합니다. 말하자면 중앙화된 '프로세스 대시보드'입니다.
  • Part Requests – 부품 요청 테마와 관련된 프로세스를 관리하기 위한 전용 영역을 제공합니다.
  • Project Activities – 설계 검토 및 PLM 시스템으로의 게시와 같은 Workspace 프로젝트 관련 프로세스를 관리하기 위한 전용 영역을 제공합니다.
  • Project Creations – 새 Workspace 설계 프로젝트 생성 테마와 관련된 프로세스를 관리하기 위한 전용 영역을 제공합니다.
마지막 세 개의 탭은 Process Themes라고 할 수 있습니다. Process Theme를 사용하면 다양한 프로세스를 설계 영역별로 직관적으로 그룹화할 수 있습니다. 또한 특정 영역에 필요한 워크플로 요소만 지원하여 새 프로세스 생성을 보다 효율적으로 수행할 수 있게 하며, 필요한 Workflow 구축을 간소화합니다. 앞으로 이 접근 방식은 필요 시 추가 테마를 더해 인터페이스를 확장할 수 있는 기반을 Altium에 제공합니다.

다음 섹션에서는 이러한 여러 탭을 좀 더 자세히 살펴봅니다.

브라우저 탭

이 탭은 모든 프로세스 테마에 걸쳐 활성 또는 종료된 모든 프로세스를 중앙에서 탐색하는 데 사용합니다. 기본적으로 이 탭에는 모든 Active(실행 중) 프로세스가 표시됩니다. 목록 위의 드롭다운 필드를 사용하여 모든 Closed 프로세스(예: 완료, 거부 또는 종료됨) 보기로 전환할 수 있습니다.

편리한 한 위치에서 모든 활성 프로세스를 탐색할 수 있습니다. 이미지를 가리키면 모든 종료된 프로세스를 탐색하는 예를 볼 수 있습니다.
편리한 한 위치에서 모든 활성 프로세스를 탐색할 수 있습니다. 이미지를 가리키면 모든 종료된 프로세스를 탐색하는 예를 볼 수 있습니다.

각 항목에 대해 다음 정보가 표시됩니다(해당하는 경우):

  • Status – 프로세스의 상태입니다. 다음 중 하나일 수 있습니다:
    • Active – 프로세스가 현재 활성 상태이며, 관련 워크플로가 진행 중입니다.
    • On hold – 프로세스가 현재 활성 상태이지만, 워크플로가 진행되기 전에 담당자 할당과 같은 초기 입력을 기다리고 있습니다.
    • Closed – 프로세스가 종료되었으며, 예를 들어 성공적으로 완료되었거나 거부되었습니다.
    • Terminated – 프로세스가 종료되었으며, Workspace 관리자가 직접 중단했습니다.
  • Process Name – 프로세스 정의의 이름입니다.
  • Title – 이 필드는 동일한 프로세스의 여러 인스턴스를 구분하는 데 사용됩니다. 제목은 프로세스 이름에 인스턴스 접미사(#1, #2 등)를 붙인 형태입니다.
  • State – 프로세스와 연결된 워크플로에서 현재 도달한 상태입니다.
  • Assignee (활성 프로세스에만 해당) – 현재 워크플로 상태에서 프로세스를 다음 단계로 진행시키기 위해 작업을 수행해야 하는 사용자입니다.
  • Started By – 프로세스를 시작한 사용자입니다.
  • Started At – 프로세스가 시작된 날짜와 시간입니다.
  • Ended At (종료된 프로세스에만 해당) – 프로세스가 종료된 날짜와 시간입니다.

활성 프로세스의 경우 Terminate 컨트롤()도 제공됩니다. 이를 클릭하면 프로세스를 강제로 종료할 수 있습니다. 그러면 해당 프로세스는 Closed 프로세스 목록으로 이동합니다.

컨트롤이 있는 모든 열을 기준으로 프로세스를 정렬할 수 있습니다. 컨트롤이나 열 이름을 클릭하면 됩니다. 목록 상단의 Search 필드를 사용해 검색할 수도 있습니다. Status, Started At, Ended At, Terminate를 제외한 모든 필드의 데이터를 검색에 사용할 수 있습니다.
  • 이전에 내보낸 프로세스 정의를 파일에서 직접 Browser 탭 안에서 가져올 수도 있습니다. 이렇게 하려면 버튼을 클릭합니다. 표시되는 Open 대화상자에서 필요한 Workflow 파일(*.aaw)을 찾아 열면 됩니다. 올바른 프로세스 테마가 감지되고, 파일 내용이 Process Workflow Editor에 로드됩니다. 자세한 내용은 프로세스 정의 가져오기/내보내기를 참조하십시오.
  • 버튼을 사용하면 현재 목록에 표시된 활동(Process Workflows)에 대한 보고서를 상세한 쉼표 구분 *.csv 파일로 내보낼 수 있습니다 – 예 보기. Active 또는 Closed 활동을 내보낼 수 있으며, 포함할 항목은 프로세스 이름 Search 필드를 사용해 필터링할 수 있습니다. 설계 측면에서는 Altium Designer의 Explorer panel에도 동등한 버튼이 포함되어 있으며, 프로젝트를 탐색할 때(Activites 탭의 기본 Project 보기 사용) 해당 프로젝트와 관련된 현재 목록 활동 데이터를 다운로드할 수 있습니다.

프로세스 항목을 클릭하면 목록 아래의 Diagram 탭에서 해당 기반 워크플로의 다이어그램을 볼 수 있으며, 프로세스가 완료되기 위해 무엇이 필요한지와 현재 흐름상 어디에 있는지, 즉 다음 진행을 위해 현재 누가 작업을 수행해야 하는지를 확인할 수 있습니다.

오른쪽 아래의 컨트롤을 클릭하면 워크플로에서 현재 도달한 지점이 강조 표시되며, 사용자 항목이 잠시 깜박입니다.

선택한 프로세스의 Diagram 탭에서 기반 워크플로를 보는 모습입니다. 각 워크플로는 다이어그램 형식으로 구성되어 있어, 프로세스가 현재 워크플로의 어느 위치에 있는지와 프로세스를 계속 진행시키기 위해 다음 작업을 수행해야 하는 사람이 누구인지 한눈에 확인할 수 있습니다.선택한 프로세스의 Diagram 탭에서 기반 워크플로를 보는 모습입니다. 각 워크플로는 다이어그램 형식으로 구성되어 있어, 프로세스가 현재 워크플로의 어느 위치에 있는지와 프로세스를 계속 진행시키기 위해 다음 작업을 수행해야 하는 사람이 누구인지 한눈에 확인할 수 있습니다.

다음과 같은 추가 탭도 제공됩니다:

  • Data – 프로세스와 관련된 모든 중요 데이터를 표시합니다. 예를 들어 설계 검토 프로세스의 경우 프로젝트와 해당 데이터 세트, 검토 유형, 검토 참여자, 추가 첨부파일 등이 포함될 수 있습니다. 부품 요청 프로세스의 경우 첨부된 데이터시트, 파라메트릭 데이터, 예비 컴포넌트 등이 포함될 수 있습니다.

    첨부파일, 데이터시트, 프로젝트 및 프로젝트 데이터 세트(Item-Revision)와 같은 해당 엔터티는 빠르게 이동하거나 열 수 있도록 하이퍼링크로 표시됩니다. 또한 이 탭에서 표준 사용자에게 표시할 파라메트릭 데이터를 구성할 수도 있습니다. 프로세스의 워크플로를 편집할 때 아무 요소도 선택하지 않으면, Data 탭에 표시할 수 있는 데이터가 오른쪽 창에 나열됩니다. 관련 양식(<ProcessName> Data)에 액세스하려면 Edit 컨트롤을 클릭하십시오.
  • History – 프로세스의 워크플로를 따라 수행된 작업 이력을 표시합니다.

    Data 및 History 탭을 사용하여 각각 프로세스의 세부 정보와 워크플로 활동 이력을 더 자세히 탐색할 수 있습니다.DataHistory 탭을 사용하여 각각 프로세스의 세부 정보와 워크플로 활동 이력을 더 자세히 탐색할 수 있습니다.

Part Requests/Project Activities/Project Creations 탭

이 탭들은 프로세스를 특정 테마별로 모아 새 Workspace 라이브러리 부품 요청, 설계 검토 수행 또는 PLM 시스템으로 게시, 그리고 새 설계 프로젝트 생성 시 사용할 프로세스 워크플로를 보고, 만들고, 관리하는 데 사용됩니다.

기본적으로 탭의 상단 영역에는 해당 테마 내 정의된 프로세스의 모든 Latest 버전이 표시됩니다. 목록 위의 드롭다운 필드를 사용하여 All 정의된 프로세스(즉, 모든 버전) 보기로 전환할 수 있습니다.

특정 테마(이 경우 Project Activities 테마)에 대해 정의된 프로세스의 최신 버전을 탐색하는 예입니다.특정 테마(이 경우 Project Activities 테마)에 대해 정의된 프로세스의 최신 버전을 탐색하는 예입니다.

각 항목에 대해 다음 정보가 표시됩니다:

  • Process Name : version – 프로세스 정의 이름과 해당 버전입니다. 항상 최신 버전을 보고 작업하려면, 목록 위 버전 드롭다운 필드가 Latest로 설정되어 있는지 확인하십시오.
  • Instances (active / all) – 현재 활성 상태인 이 버전의 프로세스 정의 인스턴스 수와, 지금까지 시작된 총 인스턴스 수입니다.
  • Created By – 이 버전의 프로세스 정의를 만든 사용자입니다.
  • Created At – 이 버전의 프로세스 정의가 생성된(저장 및 배포된) 날짜와 시간입니다.
  • Active – 이 버전의 프로세스 정의가 활성 상태()여서 사용할 수 있는지, 일시 중지됨() 상태인지, 또는 샘플(템플릿) 정의()이어서 사용할 수 없는지를 보여줍니다. 활성 프로세스 정의만 설계자가 사용할 수 있도록 Altium Designer GUI의 관련 영역에 표시됩니다. 해당하는 경우 아이콘을 클릭하여 활성 상태를 전환할 수 있습니다.

    프로세스 정의의 최신 버전만 사용할 수 있습니다(활성화 및 시작 가능). 이전 버전은 사용할 수 없지만, 수정하여 이후 버전을 만들 수는 있습니다. 또한 Active 상태가 로 구분되는 샘플 프로세스 정의는 기본 상태 그대로는 사용할 수 없습니다. 각각은 일종의 '템플릿'에 가깝기 때문에, 회사 요구사항에 맞게 편집하고 이름을 지정한 뒤 새 프로세스 정의로 저장해야 하며, 이후 can 활성화하여 다른 모든 정의와 함께 사용할 수 있습니다.
  • Actions –   컨트롤을 클릭하면 프로세스 정의에 대한 작업 메뉴에 액세스할 수 있습니다:
    • Start관리자는 이 명령을 선택하여 이 버전의 프로세스 정의에 대한 새 인스턴스를 시작할 수 있습니다. 이 기능은 프로세스 정의가 활성화되어 있을 때만 사용할 수 있습니다. 프로세스가 일시 중지되었거나 샘플(템플릿) 정의인 경우, 이 명령은 비활성화되어 인스턴스를 시작할 수 없습니다.
    • Edit – 선택하면 프로세스 정의의 기반 워크플로를 수정합니다. 이 버전의 프로세스 정의에 대한 워크플로 다이어그램이 작업 시작점으로 Process Workflow Editor에 표시됩니다. 원래 누가 정의를 만들었는지와 관계없이, 모든 관리자는 모든 사용자 정의 프로세스 정의를 수정하고 다음 버전으로 저장 및 배포할 수 있습니다. Altium에서 제공하는 기본 프로세스 정의의 경우, 이를 편집해 새 프로세스 정의를 만드는 것(사실상 포크)은 가능하지만 기본 정의 자체를 수정할 수는 없습니다. 프로세스 정의 편집에 대한 자세한 내용은 기존 프로세스 정의 편집을 참조하십시오.
    • Assign – 선택하면 Assign Access to This Workflow 창이 열리며, 여기서 어떤 사용자 및/또는 그룹이 기반 워크플로에 액세스할 수 있는지 정의할 수 있습니다. 워크플로 액세스 관리에 대한 자세한 내용은 프로세스 워크플로 액세스 관리를 참조하십시오.
    • Remove – 선택하면 이 버전의 프로세스 정의를 제거(삭제)합니다. Altium에서 제공하는 일부 기본 프로세스 정의는 제거할 수 없으므로(따라서 해당 컨트롤도 없음) 유의하십시오. 프로세스 정의의 인스턴스가 하나라도 시작된 적이 있으면, 현재 활성 상태인지 여부와 관계없이 그 정의는 제거할 수 없습니다(메뉴에 해당 명령이 표시되지 않음).
컨트롤이 있는 모든 열을 기준으로 프로세스 정의를 정렬할 수 있습니다. 컨트롤이나 열 이름을 클릭하면 됩니다. 목록 상단의 Search 필드를 사용하여 검색할 수도 있습니다. Process Name : version Created By 열의 데이터를 검색에 사용할 수 있습니다.

프로세스 정의 항목을 클릭하면 목록 아래의 Diagram 탭에서 다이어그램 형식의 워크플로를 볼 수 있습니다. 현재 활성 인스턴스가 있는 경우, 해당 보기는 현재 흐름상 어디에 있는지, 즉 다음 진행을 위해 현재 누가 작업을 수행해야 하는지를 보여줍니다.

프로세스의 활성 인스턴스가 여러 개인 경우 Diagram 보기는 결합된 상태를 표시합니다. 오른쪽 아래의 컨트롤을 클릭하면 워크플로에서 현재 도달한 지점이 강조 표시되며, 사용자 항목이 잠시 깜박입니다.

선택한 프로세스의 Diagram 탭에서 기반 워크플로를 보는 모습입니다.선택한 프로세스의 Diagram 탭에서 기반 워크플로를 보는 모습입니다.

기본 프로세스 정의

Enterprise Server 설치의 일부로, 세 가지 프로세스 테마 전반에 걸쳐 여러 프로세스 정의가 Altium에서 제공됩니다. 이들 중 일부는 기본적으로 즉시 사용할 수 있도록 활성화되어 있으며 그대로 사용할 수 있고, 나머지는 샘플이므로 직접 활성화하여 사용할 수 없습니다. 하지만 모두 필요에 따라 자체 프로세스 정의를 만들기 위한 시작점으로 사용할 수 있습니다. 아래의 접기 가능한 섹션을 사용해 제공되는 프로세스 정의 정보를 확인하십시오.

Enterprise Server 설치에는 Enterprise Server와 대상 PLM 인스턴스 간의 컴포넌트 데이터를 동기화하는 LibSync 프로세스도 포함됩니다. 이것은 내장된 읽기 전용 프로세스 워크플로이므로 편집할 수 없으며, Workspace의 Processes 페이지(Admin » Processes)의 프로세스 목록에도 포함되지 않습니다. 자세한 내용은 PLM Component Synchronization을 참조하십시오.

새 프로세스 정의 추가

Related page: 프로세스 워크플로 정의

새 프로세스는 전용 Process Workflow Editor를 사용해 생성할 수 있습니다. 편집기에 액세스하려면 새 프로세스를 만들고자 하는 테마의 탭을 활성화한 다음, 페이지 오른쪽 상단의 버튼을 클릭하십시오.

먼저 테마를 활성화하는 것이 중요합니다. 그래야 올바른 Type로 프로세스가 생성됩니다.

Process Workflow Editor에 액세스하는 모습입니다. 원하는 프로세스 테마를 먼저 활성화하면 새 프로세스 정의가 올바른 테마 유형으로 설정됩니다.Process Workflow Editor에 액세스하는 모습입니다. 원하는 프로세스 테마를 먼저 활성화하면 새 프로세스 정의가 올바른 테마 유형으로 설정됩니다.

새 프로세스 정의에 의미 있는 이름을 지정한 다음, 워크플로를 그래픽 방식으로 구성하고 해당 흐름의 각 요소에 필요한 항목을 정의하십시오. 사용자 작업의 경우 User Form Editor를 사용해 필요한 양식을 구성하며, 해당 양식은 워크플로의 관련 지점에서 사용자가 작업을 할당받았을 때 입력을 받기 위해 사용자에게 표시됩니다.

강력한 Process Workflow Editor는 회사 요구사항에 맞춰, 필요한 만큼 단순하거나 복잡한 Workflow를 갖는 프로세스를 구축할 수 있는 유연성을 제공합니다.강력한 Process Workflow Editor는 회사 요구사항에 맞춰, 필요한 만큼 단순하거나 복잡한 Workflow를 갖는 프로세스를 구축할 수 있는 유연성을 제공합니다.

프로세스가 필요에 맞게 정의되면 버튼을 클릭하여 해당 프로세스 테마에서 사용 가능한 프로세스 목록에 추가하십시오. 새 프로세스 정의는 즉시 사용할 수 있도록 활성화됩니다.

Editor는 저장 및 배포를 막는 워크플로 다이어그램의 문제를 표시해 줍니다. 예를 들어 다이어그램에는 Start 이벤트와 최소 하나의 End 이벤트가 정의되어 있어야 합니다. 또한 User Task에는 최소 하나의 Form 필드와 Assignee가 있어야 합니다.

기존 프로세스 정의 편집

모든 관리자는 원래 해당 정의를 누가 만들었는지와 관계없이 모든 사용자 정의 프로세스 정의를 수정하고 다음 버전으로 저장 및 배포할 수 있습니다. 이렇게 하려면   Actions 열에서 수정하려는 프로세스 정의의 컨트롤을 클릭한 다음, 나타나는 메뉴에서 Edit을 선택합니다. 작업의 시작점으로 사용할 수 있도록, 이 버전의 프로세스 정의에 대한 워크플로 다이어그램이 Process Workflow Editor에 표시됩니다.

Altium에서 제공하는 프로세스 정의의 경우, 이들 중 하나를 편집하여 새 프로세스 정의를 만들 수는 있지만(즉, 포크), 기본 정의 자체는 수정할 수 없습니다.

기존 프로세스 정의 편집 예 - 필요한 변경을 수행하기 위해 Process Workflow Editor에 액세스한 모습입니다.기존 프로세스 정의 편집 예 - 필요한 변경을 수행하기 위해 Process Workflow Editor에 액세스한 모습입니다.

프로세스의 도식적 워크플로를 필요에 따라 변경하고, 사용자 작업에 연결된 양식에 대한 변경도 포함한 다음, 버튼을 클릭하여 해당 정의를 다음 버전으로 저장합니다. 여기 예에서는 원래 프로세스 정의 Company Pre-release Review : 1(버전 1)을 수정하여 Company Pre-release Review : 2(버전 2)로 저장합니다.

수정이 완료되면 저장하고 해당 프로세스 정의의 다음 버전으로 배포합니다.수정이 완료되면 저장하고 해당 프로세스 정의의 다음 버전으로 배포합니다.

왼쪽 상단의 드롭다운 필드에서 항목을 All(으)로 설정하면 기존 프로세스 정의의 모든 버전을 볼 수 있습니다. 아래 이미지에서는 Company Pre-release Review 프로세스 정의의 두 버전을 모두 볼 수 있습니다.

예시 프로세스 정의 Company Pre-release Review의 모든 버전을 표시한 모습입니다. 최신 버전(버전 2)만 활성화하여 사용할 수 있습니다.예시 프로세스 정의 Company Pre-release Review의 모든 버전을 표시한 모습입니다. 최신 버전(버전 2)만 활성화하여 사용할 수 있습니다.

프로세스 정의는 최신 버전만 사용할 수 있습니다(활성화 및 시작 가능). 하지만 이전 버전은 이후 버전을 만드는 시작점으로 사용할 수 있습니다. 프로세스 정의의 최신 버전을 삭제하면, 그 이전 버전이 사실상 최신 버전이 되며 다시 활성화하여 사용할 수 있습니다(인스턴스 시작 가능).

프로세스 정의 가져오기/내보내기

프로세스 정의는 내보내기 및 가져오기가 가능하므로 Enterprise Server 인스턴스 간에 빠르게 재사용할 수 있습니다. 특히 프로세스의 기본 워크플로가 상당히 복잡한 경우, 처음부터 다시 만드는 수고를 크게 줄여 줍니다.

가져오기:

  1. 가져오려는 프로세스 정의에 해당하는 테마 탭(Part Requests, Project Activities, Project Creations)에 액세스합니다.

    잘못된 테마로 프로세스 정의를 가져오려고 하면 소프트웨어가 이를 알려 주며, 가져오기는 차단됩니다.
  2. 버튼을 클릭하여 새 프로세스 정의를 만들고 Process Workflow Editor에 액세스합니다.
  3. 버튼을 클릭합니다. 나타나는 Open 대화상자에서 필요한 Workflow 파일(*.aaw)로 이동하여 엽니다. 파일의 내용은 현재 프로세스 정의에 정의된 모든 내용(이름, 다이어그램 등)을 완전히 덮어씁니다.
인터페이스의 Browser 탭 내에서 직접, 이전에 내보낸 프로세스 정의를 파일에서 가져올 수도 있습니다. 이렇게 하려면 버튼을 클릭합니다. 나타나는 Open 대화상자에서 필요한 Workflow 파일(*.aaw)로 이동하여 엽니다. 올바른 프로세스 테마가 감지되며, 파일의 내용이 Process Workflow Editor에 로드됩니다.

내보내기:

  1. 내보내려는 프로세스 정의의 필요한 버전에 대해 Actions 열의  컨트롤을 클릭하고, 나타나는 메뉴에서 Edit를 선택하여 편집 모드로 들어갑니다.
  2. Process Workflow Editor에서 버튼을 클릭합니다. 프로세스 정의가 Workflow 파일(<ProcessDefinitionName>.aaw)로 내보내지며, 브라우저에 설정된 기본 다운로드 폴더에 저장됩니다.
  3. Workspace의 브라우저 인터페이스 왼쪽 탐색 트리에서 Processes 항목을 클릭하여, 프로세스 정의를 변경하지 않고 Process Workflow Editor에서 빠져나옵니다.

프로세스 워크플로 접근 권한 관리

관리자는 어떤 사용자 및/또는 그룹이 프로세스 워크플로에 접근할 수 있는지 정의할 수 있습니다. 이렇게 하려면, 기반 워크플로에 대한 접근을 구성하려는 프로세스 정의의 Actions 열에서  컨트롤을 클릭한 다음, 나타나는 메뉴에서 Assign를 선택합니다. 그러면 Assign Access to This Workflow 창이 열립니다.

텍스트 필드에 사용자 전체 이름 또는 사용자 이름, 혹은 그룹 이름을 입력하기 시작하면 일치하는 사용자/그룹 목록이 팝업으로 표시됩니다. 여러 사용자/그룹을 추가할 수 있습니다. 추가된 사용자/그룹의 워크플로 접근 권한을 제거하려면 이름 맨 오른쪽에 있는 삭제 아이콘을 클릭합니다.

필요에 따라 사용자/그룹을 정의한 후 을 클릭하여 워크플로 할당을 적용합니다. 이제 아래의 Designer Access to Process Workflows 섹션에 설명된 방식으로 접근할 때, 이 워크플로는 추가된 사용자/그룹(및 Administrators 그룹의 구성원)에게만 제공됩니다.

Assign Access to This Workflow 창에 명시된 대로, 사용자/그룹을 추가하지 않으면 워크플로는 모든 사용자에게 제공됩니다.

디자이너의 프로세스 워크플로 접근

Related pages: 설계 검토 수행, PLM에 게시, 프로세스 기반 부품 요청

사용 가능한 각 프로세스 테마에 대해 회사 요구사항에 맞는 프로세스 정의 세트를 준비한 뒤, 활성화된 정의는 Enterprise Server Workspace에 연결된 후 assigned users가 사용할 수 있게 됩니다. 다음 섹션에서는 디자이너가 이러한 활성 프로세스에 어디서 접근하고 시작할 수 있는지, Altium Designer와 Workspace의 브라우저 인터페이스 양쪽에서 살펴봅니다.

앞서 언급했듯이 Workspace 관리자는 Workspace 브라우저 인터페이스의 Processes 영역 내 해당 프로세스 테마 탭에서 Actions 열의  컨트롤을 클릭하고 나타나는 메뉴에서 Start를 선택하여, 활성화된 모든 프로세스 정의의 새 인스턴스를 직접 시작할 수 있습니다.

부품 요청

Related page: 프로세스 기반 부품 요청

Altium Designer 내에서는 Part Requests 테마에 속한 활성 프로세스 정의에 다음 위치에서 접근할 수 있습니다.

  • Components panel에서. 패널의 메인 영역 안에서 마우스 오른쪽 버튼을 클릭하면 활성 부품 요청 프로세스 정의가 Operations » Submit Request 하위 메뉴에서 제공됩니다. 또는 Need more components? 섹션 아래의 Submit request 링크를 클릭합니다.

Part Requests 프로세스 테마에 대해 사용 가능한 활성 프로세스 정의가 없으면 Submit Request 하위 메뉴는 표시되지 않습니다. 새로 고치려면 Workspace에서 로그아웃했다가 다시 로그인하거나 Altium Designer를 다시 시작해야 할 수 있습니다.
  • Manufacturer Part Search panel 내에서. 현재 선택된 검색 항목에 아이콘이 있으면, 를 클릭해 접근하는 Information 창에 버튼이 표시됩니다. 버튼의 드롭다운 부분을 클릭하면 활성 부품 요청 프로세스 정의 메뉴에 접근할 수 있습니다. 버튼의 메인 부분을 직접 클릭하면 목록의 첫 번째 프로세스 정의가 실행됩니다.
Manufacturer Part Search 패널을 통해 부품을 요청하면 데이터시트와 파라미터 정보 등 핵심 정보가 자동으로 채워진다는 추가 이점이 있습니다.

Part Requests 프로세스 테마에 대해 사용 가능한 활성 프로세스 정의가 없으면 버튼은 표시되지 않습니다. 새로 고치려면 Workspace에서 로그아웃했다가 다시 로그인하거나 Altium Designer를 다시 시작해야 할 수 있습니다.

현재 선택된 검색 항목에 아이콘이 있으면, 활성 부품 요청 프로세스 정의는 버튼에 연결된 메뉴에서 사용할 수 있습니다(버튼의 드롭다운 부분 클릭).

활성 부품 요청 프로세스 정의는 패널 메인 영역의 오른쪽 클릭 메뉴에 있는 Submit Request 하위 메뉴에서도 접근할 수 있습니다.

Part Requests 프로세스 테마에 대해 사용 가능한 활성 프로세스 정의가 없으면 Submit Request 하위 메뉴는 표시되지 않습니다. 새로 고치려면 Workspace에서 로그아웃했다가 다시 로그인하거나 Altium Designer를 다시 시작해야 할 수 있습니다.
  • Explorer panel에서, Part requests 폴더 내 또는 검색 수행 후. 버튼이 제공되며, 이를 누르면 선택 가능한 활성 부품 요청 프로세스 정의가 표시됩니다.

Legacy Part Requests feature가 활성화된 경우 버튼이 로 표시됩니다. 또한 해당 레거시 기능을 사용하는 새 부품 요청과 관련된 추가 항목도 메뉴에 나타납니다. 이 항목에는 (Legacy) 접미사가 붙습니다. Part Requests 프로세스 테마에 대해 사용 가능한 활성 프로세스 정의가 없고 Legacy Part Requests 기능도 활성화되지 않은 경우, Submit Request 버튼은 표시되지 않습니다. 새로 고치려면 Workspace에서 로그아웃했다가 다시 로그인하거나 Altium Designer를 다시 시작해야 할 수 있습니다.

Workspace의 브라우저 인터페이스에서는 Part Requests 테마에 속한 활성 프로세스 정의에 Part Requests 페이지에서 접근할 수 있으며, 페이지 오른쪽 상단의 버튼을 클릭하면 됩니다.

Workspace 브라우저 인터페이스의 Part Requests 페이지에서 활성화된 Part Requests 정의에 접근하는 모습입니다.Workspace 브라우저 인터페이스의 Part Requests 페이지에서 활성화된 Part Requests 정의에 접근하는 모습입니다.

Part Requests 프로세스 테마에 대해 사용 가능한 활성 프로세스 정의가 없으면 버튼을 사용할 수 없습니다. 프로세스 정의가 하나만 있으면 버튼에 드롭다운 기능이 나타나지 않으며, 클릭 즉시 해당 프로세스가 바로 시작됩니다.

프로젝트 활동

Related pages: 설계 검토 수행, PLM에 게시, PLM 통합.

Project Activities 테마에 속한 활성 프로세스 정의는 여러 위치에서 접근할 수 있습니다.

설계 검토 및 표준 PLM 게시

Altium Designer 내에서, Project Activities 테마에 속한 활성 설계 검토 및 게시 프로세스 정의는 Projects panel에서 설계 프로젝트 항목을 오른쪽 클릭하여 접근하는 Project Activities 컨텍스트 하위 메뉴 또는 메인 Project » Project Activities 메뉴에서 접근할 수 있습니다.

Project Activities 프로세스 테마에 대해 사용 가능한 활성 설계 검토 및 표준 PLM 게시 프로세스 정의가 없으면 해당 메뉴는 보이지 않습니다.

Workspace의 브라우저 인터페이스에서는 Project Activities 테마에 속한 활성 설계 검토 및 게시 프로세스 정의에 인터페이스의 Projects 페이지에서 접근할 수 있습니다. 필요한 프로젝트를 선택한 다음 버튼을 클릭합니다.

Workspace 브라우저 인터페이스의 Projects 영역에서 Workspace 프로젝트에 대한 활성화된 Project Activities 정의(설계 검토 및 표준 PLM 게시)에 접근하는 모습입니다.Workspace 브라우저 인터페이스의 Projects 영역에서 Workspace 프로젝트에 대한 활성화된 Project Activities 정의(설계 검토 및 표준 PLM 게시)에 접근하는 모습입니다.

Project Activities 프로세스 테마에 대해 사용 가능한 활성 설계 검토 및 표준 PLM 게시 프로세스 정의가 없으면 버튼은 표시되지 않습니다.

Project Releaser를 통한 PLM 게시

Altium Designer 내에서, Project Releaser의 일부로 PLM 인스턴스에 게시하는 프로세스는 활성 프로젝트의 Project » Project Releaser 하위 메뉴에서, 또는 Projects panel에서 설계 프로젝트 항목을 오른쪽 클릭한 후 Project Releaser 컨텍스트 메뉴 항목에서 해당 프로세스를 선택하여 접근할 수 있습니다.

프로젝트 생성

Altium Designer 내에서, Project Creations 테마에 속한 활성 프로세스 정의는 세 곳에서 접근할 수 있습니다.

  • 메인 File » New » Project in <WorkspaceName> 하위 메뉴에서.

  • Projects 패널에서 로컬 프로젝트 항목을 오른쪽 클릭하여 접근하는 Convert to Managed Project 컨텍스트 하위 메뉴에서.

  • Workspace 위치가 선택된 상태에서 Open Project dialog의 프로젝트 항목을 오른쪽 클릭하여 접근하는 Clone 컨텍스트 하위 메뉴에서.

Project Creations 프로세스 테마에 대해 하나 이상의 프로세스 정의가 활성화되면, File » New » Project(Create Project dialog)를 통해 새 Workspace 프로젝트를 생성하는 기능은 비활성화됩니다. 연결된 Workspace는 대상 위치로 사용할 수 없습니다. Regular (로컬) 및 VCS 유형 프로젝트는 이 대화상자를 통해 평소처럼 생성할 수 있습니다.

Project Creations 프로세스 테마에 대해 사용 가능한 활성 프로세스 정의가 없으면(이는 새 Enterprise Server 설치의 기본 상태입니다), 프로세스 메뉴는 보이지 않으며 Create Project 대화상자를 통해 평소처럼 Workspace 프로젝트를 만들 수 있습니다.

또한 이 기본 구성에서는 Convert to Managed Project 명령이 Make Project Available on Server(으)로 변경된다는 점도 유의하십시오.

Workspace의 브라우저 인터페이스에서는 Project Creations 테마에 속한 활성 프로세스 정의에 다음 위치에서 접근할 수 있습니다.

  • 인터페이스의 메인 Projects 페이지에서 버튼을 클릭합니다.

Workspace 브라우저 인터페이스의 메인 Projects 영역에서 활성화된 Project Creations 정의에 접근하는 모습입니다.Workspace 브라우저 인터페이스의 메인 Projects 영역에서 활성화된 Project Creations 정의에 접근하는 모습입니다.

  • 특정 프로젝트를 복제하려는 경우, 인터페이스의 Projects 페이지에서 접근합니다. 필요한 프로젝트를 선택한 다음 버튼을 클릭하여 메뉴의 프로세스에 접근합니다.

Workspace 브라우저 인터페이스의 Projects 영역에서 Workspace 프로젝트를 복제하려 할 때 활성화된 Project Creations 정의에 접근하는 모습입니다.Workspace 브라우저 인터페이스의 Projects 영역에서 Workspace 프로젝트를 복제하려 할 때 활성화된 Project Creations 정의에 접근하는 모습입니다.

  • Project Creations 프로세스 테마에 대해 사용 가능한 활성 프로세스 정의가 없으면(이는 새 Enterprise Server 설치의 기본 상태입니다), 메뉴에는 기본 프로젝트 복제 기능(Clone)이 제공됩니다. 이는 프로세스 워크플로 기능과는 관련이 없습니다.
  • 프로세스 기반 Workspace PCB 프로젝트의 설계 제약을 관리하기 위해 Constraint Manager를 사용하려면, 해당 프로젝트를 만들 때 적절한 프로젝트 템플릿을 할당해야 합니다. 이 템플릿은 Create Project dialog에서 Constraint Management 옵션을 활성화한 상태로 생성된 PCB 프로젝트에서 저장된 템플릿이어야 합니다.
AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
콘텐츠