항목 탐색
Altium Essentials: Workspace Folder Structure
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
워크스페이스의 콘텐츠는 여러 가지 방법으로 탐색할 수 있습니다.
- Explorer Panel의 Server Folders Region에서 콘텐츠를 살펴볼 폴더를 클릭합니다.
- Panel 상단의 주소 표시줄을 사용합니다. 주소 표시줄에는 현재 탐색 중인 폴더와 해당 폴더의 계층 경로가 표시됩니다.
-
워크스페이스의 검색 기능을 사용합니다. Comment나 설명을 바탕으로 키워드를 입력한 다음 Enter 키를 누르거나 돋보기 아이콘을 클릭합니다. 전체 워크스페이스를 검색하여 일치하는 Item을 검색 결과로 표시합니다.
선택한 폴더의 콘텐츠는 Panel의 Item Region에 표시됩니다.
Item Region의 명령
-
Place – 배치가 지원되는 위치에 현재 선택한 Item-리비전의 인스턴스를 배치합니다. 예를 들어, 활성 Schematic 시트에 컴포넌트나 관리형 시트를 배치할 수 있습니다. 컴포넌트 심볼 또는 관리형 시트 심볼이 커서에 붙어 배치할 수 있는 상태로 나타납니다.
-
Edit – 컴포넌트, 관리형 시트, 템플릿 등의 Item을 연결된 Editor에서 엽니다. 편집 후에는 해당 Item의 새 리비전으로 워크스페이스에 다시 저장됩니다.
-
Upload – 새 리비전 생성 대화 상자를 통해 Item에 구성 객체를 업로드합니다. 예를 들어, 관리형 Schematic 시트에 Schematic 문서를 업로드하거나 Output 작업 템플릿에 OutJob 파일을 업로드할 수 있습니다.
-
Operations – 다음 명령이 포함된 하위 메뉴에 액세스합니다.
-
Add to Content Cart – Content Cart 대화 상자를 사용하여 현재 선택한 Item을 Content Cart에 추가합니다.
-
Download – Browse for Folder 대화 상자를 사용하여 현재 선택한 Item을 다운로드하고 다른 위치에 저장합니다.
-
Change state – 일괄 상태 변경 대화 상자를 열어 현재 선택한 Item 리비전의 상태를 변경합니다.
-
Make a copy – 현재 선택한 Item-리비전을 복사합니다. 복사된 Item은 연결된 Editor에서 편집할 수 있도록 열립니다. 예를 들어 컴포넌트를 복제하면 컴포넌트 Editor에서 열립니다.
-
Change component type – 선택한 컴포넌트의
ComponentType파라미터를 다른 유형으로 설정할 수 있는 Choose component type 대화 상자에 액세스합니다. -
Export Grid – 데이터 내보내기용 열 선택 대화 상자를 열어 내보낼 열 데이터를 지정합니다. 내보낸 세미콜론으로 구분된 CSV 파일에는 현재 목록 Grid 보기에 있는 모든 Item의 데이터가 포함됩니다.
-
-
Create Item – 현재 폴더와 일치하는 유형의 새 콘텐츠 Item(컴포넌트, 템플릿, 관리형 Schematic 시트 등)을 추가하고 연결된 Editor에서 엽니다. 다른 유형의 Item을 생성하려면 Other Item Type 하위 옵션을 선택한 다음 새 Item 생성 대화 상자의 Content Type 메뉴에서 다른 유형을 선택합니다.
-
Delete Item – Item을 삭제합니다.
-
History – 현재 선택한 Item의 상세 보기에 액세스합니다. 이 보기는 소프트웨어 내에서 새 탭으로 열립니다. Item 보기에서는 특정 Item의 리비전 및 수명 주기 이력을 매우 상세하게 볼 수 있으며, 해당 Item을 구성하는 모든 요소도 표시됩니다. 이 보기에는 타임라인도 포함되어 있습니다. 타임라인을 사용하면 해당 Item의 리비전 수준 또는 수명 주기 상태가 변경된 정확한 날짜와 시간, 그리고 변경한 사용자를 확인할 수 있습니다.
-
Properties – 현재 선택한 Item의 속성을 볼 수 있는 View Item Properties 대화 상자에 액세스합니다. 해당 Item의 리비전이 아직 릴리스되지 않았다면 속성을 수정할 수 있습니다.
-
Navigate To <item> – Item ID 열에서 선택한 Item의 미리보기를 Explorer Panel에 엽니다.
워크스페이스의 각 Item 리비전에 대해 Explorer Panel에서는 해당하는 경우 리비전의 다양한 측면을 살펴볼 수 있습니다. Panel 하단의 탭을 사용하여 해당 리비전에 대한 하나 이상의 보기를 표시할 수 있습니다.
기본 보기는 Preview입니다. 다른 탭을 클릭하면 추가 정보를 볼 수 있습니다. 사용 가능한 탭은 현재 선택한 Item의 유형에 따라 달라집니다.
-
Preview – 문서 및 모델의 그래픽 표현, 파라미터 데이터, 관련 하위 Item 등을 포함하여 선택한 Item을 종합적으로 표시합니다. 이 보기는 Item 유형과 컴포넌트 및 프로젝트에 대해 Classic 보기 모드 또는 해석된 보기 모드(위 참조)가 선택되어 있는지에 따라 자동으로 설정됩니다.
-
Lifecycle – Item의 리비전 수준과 수명 주기 상태 변경을 살펴봅니다. 수명 주기는 Item 유형에 할당된 상태를 따라 진행할 수 있습니다. 예를 들어, 컴포넌트의 경우 컴포넌트 수명 주기 상태(
Draft,Prototype등)를 따릅니다. -
Children – 릴리스된 프로젝트의 제작 패키지(
FAB-<project name>)에 포함된 생성된 제작 문서(Gerber, NC Drill 등)나 관리형 Schematic 시트에 사용된 Schematic 문서 및 컴포넌트 등 Item의 하위 요소를 봅니다. -
Part Choices – 컴포넌트에 할당된 부품 선택 항목(관련 공급업체 데이터가 포함된 제조업체 부품 항목)을 확인하거나 추가합니다.
-
Where-used – 선택한 Item 리비전이 다른 워크스페이스 Item에서 사용되는 위치를 확인합니다. 예를 들어 현재 선택한 컴포넌트를 사용하는 프로젝트를 확인할 수 있습니다.
-
Origin – Altium의 클라우드 리소스에서 가져온 컴포넌트와 같이 Item의 출처를 확인합니다. 가능한 경우 원본 Item의 전체 세부 정보가 표시됩니다.
-
Data Sheet – 선택한 컴포넌트와 함께 저장된 파일 기반 데이터시트를 확인하거나 추가합니다.

연결된 보기를 사용하여 Item 리비전의 다양한 측면을 살펴볼 수 있습니다.
클릭 가능한 URL
워크스페이스의 사용 편의성을 더욱 높이기 위해 Explorer Panel은 클릭 가능한 URL을 지원합니다. 이 기능은 다음을 비롯한 다양한 관련 영역에서 사용할 수 있습니다.
- 값이 URL인 컴포넌트 파라미터를 클릭하면 외부 웹 브라우저에서 타겟 페이지가 열립니다.
- 컴포넌트의 공급망 데이터에서 URL을 클릭하면 외부 웹 브라우저에서 타겟 페이지가 열립니다.
- PCB 제작 데이터 Item, PCB 조립 데이터 Item 또는 PCB 프로젝트 설계 Item 리비전의 Preview 상세 보기 탭에 있는 Released Documents Region에서 문서를 클릭하면 해당 문서가 열립니다.
클릭 가능한 공급망 URL
워크스페이스에 릴리스된 각 컴포넌트에는 부품 선택 항목 형태로 공급망 데이터를 정의할 수 있습니다. 이 데이터는 Part Choices 상세 보기 탭에 표시됩니다. 실제 공급망 정보는 워크스페이스의 로컬 Part Catalog 및 관련 부품 소스에서 가져옵니다. 부품 소스는 Altium Parts Provider의 통합 부품 데이터베이스(활성화된 공급업체와 연동하여 부품 정보를 수집) 또는 연결된 로컬 부품 데이터베이스(Custom 데이터베이스 부품 공급자로 구성된 부품 소스로, 사용 중인 워크스페이스 유형에서 지원하는 경우)입니다. 각 부품 선택 항목과 관련된 클릭 가능한 URL은 다음과 같습니다.
- 제조업체 이름 및 제조업체 부품 번호 – 해당 제조업체 부품에 대한 자세한 정보를 제공하는 제조업체 사이트로 연결되는 클릭 가능한 링크입니다.
- 공급업체 부품 번호(SPN 타일 내) – 공급업체 사이트의 해당 부품으로 연결되는 클릭 가능한 링크입니다.
URL을 클릭하면 외부 브라우저에서 열립니다.
클릭 가능한 릴리스된 문서 URL
보드 설계 프로젝트를 제작된 베어 보드(PCB 제작 데이터 Item) 또는 조립된 보드(PCB 조립 데이터 Item)로 릴리스한 후에는 해당 설계의 모든 문서를 열 수 있습니다. 먼저 필요한 프로젝트의 폴더가 클래식 보기로 표시되어 있는지 확인하세요(Explorer Panel 오른쪽 상단의
버튼을 클릭하고 컨텍스트 메뉴에서 Classic View 명령을 선택). 해당 Item 리비전으로 이동한 다음 해당 리비전의 Preview 상세 보기 탭으로 전환합니다. 그런 다음 Released Documents Region에서 생성된 출력 문서 위로 마우스를 가져가면 커서가 URL을 나타내는 손 모양으로 바뀝니다. 이러한 URL 중 하나를 클릭하면 해당 문서가 열립니다. Altium Designer 기본 형식의 문서는 Altium Designer에서 직접 열어 볼 수 있습니다. 출력 PDF 파일이나 Excel 형식의 BOM처럼 Altium Designer 형식이 아닌 문서는 해당 소프트웨어 애플리케이션이 설치되어 있는 경우 그 애플리케이션에서 바로 열립니다.

클릭하여 릴리스된 문서를 엽니다. Altium Designer 기본 형식이 아닌 문서 유형은 해당 애플리케이션이 있는 경우 그 애플리케이션에서 열립니다.
리비전 보기
아이콘을 클릭하여 리비전 선택 드롭다운을 열면 Panel에 표시할 리비전을 구성할 수 있습니다.
- Load all pages – 모든 리비전을 로드하려면 선택합니다.
- Show Hidden Revisions – 숨겨진 리비전을 표시하려면 선택합니다.
- Show only latest – 최신 리비전만 표시하려면 선택합니다.
- View – Item을 Classic View 보기 또는 해석 보기(Components View/Project View) 중 어떤 방식으로 표시할지 선택합니다.
폴더 콘텐츠 로드
Explorer Panel의 Server Folders 구조 Region에서 폴더를 클릭하면, 가능한 경우 해당 폴더 콘텐츠의 일부만 처음에 로드됩니다. 이를 통해 폴더의 초기 로드 시간이 크게 단축됩니다. 처음 로드된 콘텐츠의 끝까지 스크롤하면 폴더 콘텐츠의 다음 부분이 로드됩니다.
숨겨진 리비전 표시
Related page: 워크스페이스의 수명 주기 정의 구성 – Item 리비전의 표시 여부 및 적용 가능성 제어
Item 리비전이 Visible in Vault panels 속성이 비활성화된 수명 주기 상태로 전환되면 해당 리비전은 기본적으로 Explorer Panel에 표시되지 않습니다. 또한 해당 리비전이 Item의 최신 리비전이면 해당 Item의 전체 Entry가 화면에서 숨겨집니다. 상태 수준에서 정의되는 이 표시 설정은 모든 Item에 대해 전역적으로 재정의할 수 있습니다.
현재 표시되지 않는 모든 Item 리비전을 표시하려면 Panel의 Items Region 오른쪽 상단에 있는
컨트롤을 클릭하고 관련 메뉴에서 Show Hidden Revisions 옵션을 활성화합니다.

Explorer Panel에서 콘텐츠를 탐색하는 동안 숨겨진 Item 리비전을 표시하는 모습입니다. 이미지 위에 마우스 포인터를 올리면 결과를 확인할 수 있습니다.
최신 Item 리비전만 표시
시간이 지남에 따라 워크스페이스의 콘텐츠는 발전하면서 변경될 수 있으며, 변경될 때마다 수정된 데이터를 반영하는 새 리비전이 생성됩니다. Item을 탐색할 때는 일반적으로 최신 리비전만 필요합니다. 이전 리비전은 설계자의 시야를 복잡하게 만드는 불필요한 정보가 되기 쉽습니다. 이를 줄이기 위해 Explorer Panel은 기본적으로 Item의 최신 리비전만 표시합니다.
Explorer Panel에서 Item의 모든 리비전을 표시하려면 Panel의 Items Region 오른쪽 상단에 있는
컨트롤을 클릭하고 관련 메뉴에서 Show only latest 옵션을 비활성화합니다.

기본적으로 Explorer Panel에는 Item의 최신 리비전만 표시됩니다. 이미지 위에 마우스 포인터를 올리면 이 명령이 비활성화된 예를 확인할 수 있습니다.
해석 보기
이 Panel은 컴포넌트와 프로젝트에 적용되는 두 가지 특수 해석 보기도 제공합니다. Panel 표시 옵션을 Classic View 모드로 변경하지 않은 경우, 컴포넌트나 프로젝트를 선택하면 보기가 자동으로 이 스타일로 전환됩니다.
특수 Item 유형 중 하나를 선택하면 보기 메뉴에서 클래식 보기 또는 해석 보기(Component View / Project View) 옵션을 사용할 수 있습니다.
- Classic View – Item과 해당 리비전만 표시하려면 선택합니다.
- Components View – 리비전과 해석된 컴포넌트 데이터를 표시하려면 선택합니다. 자세한 내용은 컴포넌트 보기를 참조하세요.
- Project View – 프로젝트 릴리스 데이터와 프로젝트 파라미터에 접근할 수 있는 구조화된 그래픽 형태로 프로젝트를 표시하려면 선택합니다. 자세한 내용은 프로젝트 보기를 참조하세요.
Item 리비전 비교
워크스페이스는 Altium Designer의 기본 파일 형식 비교 기술을 활용하여, 지원되는 다양한 콘텐츠 유형에 대해 동일한 Item 또는 서로 다른 Item의 두 리비전을 Explorer Panel에서 직접 시각적으로 비교할 수 있도록 지원합니다. 다음 콘텐츠 유형의 Item 리비전을 비교할 수 있습니다.
- 컴포넌트 Item
- 심볼 Item
- 풋프린트 Item
- 관리형 Schematic 시트 Item
- Schematic 템플릿 Item
- PCB 제작 데이터 Item
- PCB 조립 데이터 Item
- PCB 프로젝트 설계 Item
Explorer Panel에서 관련 폴더로 이동하여 비교할 두 Item 리비전을 선택한 다음, 마우스 오른쪽 버튼을 클릭하고 컨텍스트 메뉴에서 Operations » Compare을 선택합니다.
두 컴포넌트 Item 리비전 비교
두 컴포넌트 Item 리비전을 비교할 때 Compare을 클릭하면 다음 작업이 순서대로 수행됩니다.
- 참조된 풋프린트 Item 리비전을 비교합니다.
- 참조된 심볼 Item 리비전을 비교합니다.
- 두 컴포넌트 Item 리비전의 파라미터 데이터를 비교합니다.
비교 결과는 Compare component revisions 대화 상자에 표시됩니다.
대화 상자는 세 개의 구역으로 나뉘어 파라미터 데이터, 풋프린트, 심볼의 비교 결과를 표시합니다. 파라미터 값이 동일하지 않으면 붉은색 배경으로 강조 표시됩니다. 풋프린트와 심볼의 경우 동일함 또는 동일하지 않음이라는 텍스트가 표시됩니다.
두 심볼 Item 리비전 비교
심볼 Item의 두 리비전을 비교할 때 Compare을 클릭하면 그래픽 비교가 수행되며, 감지된 차이점이 Differences Panel에 나열됩니다. 두 리비전의 SchLib 문서가 설계 공간에서 열립니다. 설계 Editor 창에 두 문서를 나란히 표시하면 차이점을 그래픽으로 살펴볼 수 있습니다. 감지된 차이점의 최상위 폴더를 클릭하면 두 문서에서 해당 차이점이 동시에 강조 표시됩니다.
두 풋프린트 Item 리비전 비교
풋프린트 Item의 두 리비전을 비교할 때 Compare을 클릭하면 그래픽 비교가 수행되며, 감지된 차이점이 Compare Components 대화상자에 나열됩니다.

풋프린트의 두 리비전 비교 예시. 원본 라이브러리는 설계 공간에서 열리지 않습니다. 여기에는 실제 차이점을 보여주기 위해 풋프린트 미리보기가 포함되어 있습니다.
풋프린트는 정사각형 셀로 나뉘며, 각 셀의 차이점이 분석됩니다. 차이점이 있는 셀은 전체 색상으로 표시되고 차이점은 강조 표시됩니다. 레이어 탭에는 비교한 각 레이어에서 차이점이 있는 프리미티브 객체의 수가 표시되며, 탭을 클릭하면 차이점을 더 자세히 살펴볼 수 있습니다.
Grid 데이터 Export
Explorer Panel은 Grid 보기의 데이터를 csv 또는 xls 형식 파일로 Export하는 기능을 지원합니다. 이 기능을 사용할 수 있는 위치의 예는 다음과 같습니다.
- 컴포넌트 Item Grid(클래식 보기 및 컴포넌트 보기 모두).
- Item Grid.
- Preview 상세 보기 탭의 연결된 모델 Grid(선택한 컴포넌트 Item에 해당).
- 검색 결과 Grid.
- Where-used 상세 보기 탭의 Item Grid.
- Children 상세 보기 탭의 Item Grid.
Grid 내부를 마우스 오른쪽 버튼으로 클릭하고 상황에 맞는 메뉴에서 Operations » Export Grid 명령을 선택하세요. Select columns for data export 대화상자가 나타납니다. 열 목록의 체크박스를 사용하거나 Select All / Deselect All 버튼을 클릭하여 Export할 데이터를 활성화하거나 비활성화하세요. 대화상자에는 해당 Grid에서 사용할 수 있는 모든 열이 포함되며, 현재 Panel에 표시된 열은 기본적으로 Export하도록 활성화되어 있습니다. OK을 클릭하면 표준 Windows Save As 대화상자가 나타납니다. 이 대화상자에서 Export한 파일을 저장할 위치와 이름을 지정하세요. Save as type 필드에서 파일 형식을 쉼표로 구분된 값 파일(*.csv) 또는 Excel 파일(*.xls) 중에서 선택하세요.

데이터(선택한 컴포넌트 Item 리비전에 연결된 모델)를 Excel 형식 파일로 Export하는 예시.
프로젝트 보기
Panel의 해석된 Project View은 선택한 프로젝트를 프로세스 중심 보기로 표시하여 관련 프로젝트 데이터와 릴리스에 직접 액세스할 수 있도록 합니다.
Project View에는 프로젝트 미리보기, 주요 설명, 파라미터 및 릴리스가 표시됩니다.
Releases Region에는 선택한 프로젝트와 연결된 프로젝트 릴리스가 모아서 표시되며, 각 릴리스와 이를 구성하는 패키지의 요약이 포함됩니다. 이 Region에서
버튼을 클릭하면 일괄 상태 변경 대화상자가 열립니다. 이 대화상자를 사용하면 동일한 릴리스와 관련된 여러 Item의 수명주기 상태를 하나의 일괄 처리로 한 번에 변경할 수 있습니다.
프로젝트 보기 오른쪽 상단의 컨트롤은 다음과 같습니다.
- Open – 타겟 프로젝트를 Altium Designer에서 여는 데 사용합니다.
- Open in Web – 워크스페이스의 브라우저 기반 인터페이스에서 프로젝트를 열 때 사용합니다.
- Share – 소프트웨어 내에서 직접 전 세계 어디에 있는 다른 사용자와도 설계 프로젝트를 공유할 수 있는 공유 대화상자를 열 때 사용합니다.
-
– 버튼을 클릭하면 다음 명령에 액세스할 수 있습니다.
-
복사본 만들기 – 프로젝트를 복사하는 데 사용되는 Create Project Copy 대화상자를 열 때 사용합니다. 복사한 프로젝트는 연결된 워크스페이스에 저장됩니다. 기본적으로 원본 프로젝트 이름에 접미사
' - Copy'이(가) 추가됩니다. - History – 해당 프로젝트의 상세 CAD 중심 관리 페이지에서 프로젝트의 기록 보기를 열 때 사용합니다.
- Delete – 프로젝트, 해당 폴더 및 모든 프로젝트 콘텐츠를 삭제할 때 사용합니다. 삭제가 완료되기 전에 확인 메시지가 표시됩니다.
-
복사본 만들기 – 프로젝트를 복사하는 데 사용되는 Create Project Copy 대화상자를 열 때 사용합니다. 복사한 프로젝트는 연결된 워크스페이스에 저장됩니다. 기본적으로 원본 프로젝트 이름에 접미사










