부품 검색 및 배치

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

모든 전자 설계의 핵심은 부품입니다. 최종적으로 보드에 납땜하게 되는 부품은 각 설계 도메인에서 표현되거나 모델링되어야 합니다. 즉, 회로도에서는 심볼로, 시뮬레이터에서는 SPICE 모델로, 보드에서는 풋프린트로, 그리고 기구 설계자에게 전달하는 파일에서는 3D STEP 모델로 나타나야 합니다.

부품 및 라이브러리 구축과 유지 관리에 대해 자세히 알아보세요.

Altium Designer의 Components 패널은 Workspace 및 비-Workspace를 포함한 모든 부품과 상호작용할 수 있는 강력한 인터페이스를 제공합니다. 카테고리를 지정하고 검색 필드에 질의어(전체 또는 일부 부품명, 값 등)를 입력하는 간단한 검색 모드를 사용해 필요한 부품을 검색할 수 있습니다. 또한 이 패널은 Workspace 부품에 대해 대상 부품 파라미터를 지정할 수 있는 필터 기반의 파라메트릭(패싯) 검색 기능도 제공합니다. 아울러 단일 부품 편집 모드의 Component Editor를 통해 Workspace 부품을 편집하고, 원본 Workspace에서 해당 부품을 확인하며, 부품 생성 및 복제 또는 선택한 부품의 Part Choices 및 Type 편집과 같은 부품 관리 기능도 수행할 수 있습니다. 부품은 드래그하거나 부품의 오른쪽 클릭 메뉴에서 Place  명령을 사용하여 회로도에 배치할 수 있습니다.

물론 직접 부품을 만들 수도 있지만, Altium Designer는 실제 제조된 부품을 검색할 수 있는 강력한 Manufacturer Part Search panel 도 제공합니다. Workspace가 있는 경우 해당 부품을 Workspace에 저장한 다음 Components 패널을 통해 액세스할 수 있습니다. 이 과정에는 단일 부품 편집 모드의 Component Editor를 사용해 새 Workspace 부품을 생성하고, 이를 Workspace에 저장하는 작업이 포함됩니다.

Components 패널은 Altium Designer에서 사용 가능한 Workspace components 및 database, file-based 라이브러리 부품에 직접 액세스할 수 있도록 합니다.

이 패널은 connected Workspace와 열려 있거나 설치된 모든 라이브러리에서 부품을 가져옵니다. 패널은 선택된 부품의 전체 세부 정보(Parameters, Models, Part Choices, Supplier data 등), 부품 비교 기능, 그리고 Workspace 부품의 경우 대상 부품 파라미터를 지정할 수 있는 필터 기반 파라메트릭 검색 기능을 제공합니다.

Components 패널 일반 모드

Components 패널 컴팩트 모드

 

Components 패널은 Manufacturer Part Search panel에 적용되는 기본 검색 엔진 기능과 보기를 사용합니다. Manufacturer Part Search 패널은 Altium Parts Provider 서비스를 활용하여 부품 제조사 및 공급업체 데이터 검색에 중점을 두는 반면, Components 패널은 connected Workspace와 데이터베이스 및 파일 기반 라이브러리 소스에서 바로 배치할 수 있는 부품으로 채워집니다.

Workspace 부품의 경우, 각 부품의 최신 리비전만 패널에 표시됩니다.
부품 작업을 위한 많은 기능이 Components 패널을 통해 제공되지만, Explorer panel도 사용할 수 있습니다. 본질적으로 전자는 후자가 제공하는 기능의 일부 집합이며, 부품 관리에 초점을 맞추고 있습니다. 부품 자체와 관련된 일부 기능은 여전히 Explorer 패널을 통해서만 수행할 수 있습니다(편집 없이 데이터시트 추가, 상태 변경, 부품 및 모델의 일괄 삭제 등). 하지만 이러한 기능은 일반적이지 않은 예외적인 경우이거나 관리/Workspace 구조화 작업의 일부인 경우가 많습니다. 부품은 하나의 콘텐츠 유형에 불과하다는 점을 기억하세요. Explorer 패널은 Workspace가 지원하는 전체 콘텐츠 유형 범위를 다룰 때 진가를 발휘합니다. 예를 들어, 부품 템플릿의 생성 및 관리는 부품과 매우 밀접한 관련이 있는 항목이지만 Explorer 패널 내에서만 수행할 수 있습니다(Library Importer를 사용한 라이브러리 가져오기 시점에 템플릿을 생성하는 경우는 예외).

Components Panel Access

Components 패널을 열려면 메인 메뉴에서 View » Panels » Components를 선택하거나 메인 화면 오른쪽 하단의 Components 버튼 메뉴에서 옵션을 선택합니다. 반응형 설계 구성을 사용하면 패널 레이아웃이 전체 화면 일반 모드()와 Categories/Filters 옵션이 메뉴로 축소되는 컴팩트 모드() 사이에서 동적으로 전환됩니다.

회로도 문서 내에서는 P, P 키보드 단축키를 사용하여 Components 패널을 열 수 있습니다. 또한 메인 메뉴의 Place » Part 명령, 회로도 편집기 디자인 공간의 오른쪽 클릭 메뉴에 있는 Place » Part 명령, 또는 Active BarPart 버튼()을 사용할 수도 있습니다.

PCB 문서 내에서는 P, C 키보드 단축키를 사용하여 Components 패널을 열 수 있습니다. 또한 메인 메뉴의 Place » Component 명령, PCB 편집기 디자인 공간의 오른쪽 클릭 메뉴에 있는 Place » Component 명령, 또는 Active BarComponent 명령()을 사용할 수도 있습니다.

현재 Altium Designer 세션에서 Components 패널을 처음 실행하면, Workspace에 연결된 상태에서 다음과 같은 컨트롤을 사용할 수 있습니다.

  • Use Existing Components – 클릭하면 패널 상단 드롭다운에서 현재 선택된 부품 유형을 탐색합니다.

  • Delete Existing Components – 클릭하면 Delete Existing Components 대화상자를 연 다음 Workspace의 Data Cleanup 페이지로 이동하여 제거할 콘텐츠 유형을 선택할 수 있습니다.

  • Import Library – 클릭하면 표준 Windows Open 대화상자가 열리며, 로컬 또는 네트워크 폴더에 저장된 데이터베이스 또는 파일 기반 라이브러리를 선택할 수 있습니다. 라이브러리 파일을 열면 선택한 라이브러리가 로드된 상태로 단순 모드의 Library Importer가 실행됩니다.

  • Create Component – 클릭하면 Create New Component dialog가 열리고, 이어서 새 부품을 정의할 준비가 된 단일 부품 편집 모드의 Component Editor가 열립니다.

패널의 Categories 창(또는 컴팩트 모드의 드롭다운 메뉴)에는 All 카테고리 항목 아래의 사용 가능한 모든 Workspace 부품과 사용 가능한 라이브러리가 나열됩니다. 패널이 일반 모드일 때는 Categories 목록 아이콘 또는 « 아이콘을 클릭하여 열 표시를 접거나 펼칠 수 있으며, 버튼(오른쪽 상단)을 사용하여 부품 Details 창의 표시 여부를 전환할 수 있습니다. Categories 창에서 항목을 살펴볼 때는 Up/DownPgUp/PgDn 키보드 단축키를 사용해 목록을 이동할 수 있습니다. Left/Right 키보드 단축키를 사용하면 개별 분기를 열고 닫을 수 있습니다.

Workspace 부품의 Categories 그룹화는 각 부품과 연결된 Component Type 파라미터에서 파생됩니다. 예를 들어, 부품의 Component TypeResistor로 지정되어 있으면 해당 부품은 Components 패널의 Resistor 카테고리 아래에 나열됩니다(해당 부품이 저장된 Workspace 폴더와는 무관).

부품의 유형을 즉시 지정하거나 변경하려면 해당 항목을 오른쪽 클릭한 다음 컨텍스트 메뉴에서 Operations » Change Component Type 옵션을 선택하여 Choose component type dialog를 여세요.

부품의 Type 파라미터는 다음 시점에 설정됩니다.

Component Types는 Preferences 대화상자의 Data Management – Component Types page에서 관리(생성/편집/제거)됩니다. 이 대화상자의 Templates 버튼을 클릭하면 Edit Templates 대화상자가 열리며, 여기서 각 Component Type과 연결된 Component Template을 지정하거나 변경할 수 있습니다.

NOTE: Category 부품이 나열되는 위치는 해당 부품의 Component Type 파라미터로 정의되며, 저장된 Workspace 폴더와는 관련이 없습니다. 따라서 Explorer panel을 통해 부품을 다른 폴더로 이동하더라도 이러한 변경은 Components 패널에 반영되지 않습니다.

Operations Menu

작업 메뉴 옵션을 사용하면 파일 기반 라이브러리 기본 설정 지정, 검색 수행, 부품 모델 컬렉션 표시 여부 지정 등을 할 수 있습니다. 이러한 옵션에 액세스하려면 패널 오른쪽 상단의 작업 메뉴 버튼을 선택하세요.

  • Create Component – 선택하면 Create new component 대화상자가 열리고, 이어서 새 부품을 정의할 준비가 된 단일 부품 편집 모드의 Component Editor가 열립니다.
  • Import Library – 선택하면 표준 Windows Open 대화상자가 열리며, 로컬 또는 네트워크 폴더에 저장된 데이터베이스 또는 파일 기반 라이브러리를 선택할 수 있습니다. 라이브러리 파일을 열면 선택한 라이브러리가 로드된 상태로 단순 모드의 Library Importer가 실행됩니다.
  • Clean-up Library – 선택하면 Delete Existing Components 대화상자가 열리고, 이어서 Workspace의 Data Cleanup 페이지로 이동하여 제거할 콘텐츠 유형을 선택할 수 있습니다.
  • Models – 선택하면 라이브러리 모델 컬렉션 항목이 Categories 목록에 포함됩니다. 이 탐색 모드에서 추가로 표시되는 항목에는 연결된 Workspace에서 가져온 Symbol, Footprint, Simulation 모델 컬렉션과 설치된 PCB 풋프린트 라이브러리(*.PcbLib)가 포함됩니다.
  • File-based Libraries Preferences – 선택하면 Available File-based Libraries 대화상자가 열리며, 여기서 현재 프로젝트에 데이터베이스 및 파일 기반 라이브러리를 추가하거나 제거하고, 라이브러리를 설치하고, 라이브러리 검색 경로를 지정할 수 있습니다. 자세한 내용은 Searching for Components in File-based & Database Libraries 페이지의 Managing Available Database and File-based Libraries 섹션을 참조하세요.
  • File-based Library Search – 선택하면 File-based Libraries Search 대화상자가 열리며, 어떤 데이터베이스 또는 파일 기반 라이브러리에 원하는 부품이 들어 있는지 모르거나, 해당 부품이 실제로 उपलब्ध한지도 모를 때 검색할 수 있습니다. 자세한 내용은 Searching for Components in File-based & Database Libraries 페이지의 Searching for Components in Database and File-based Libraries 섹션을 참조하세요.
  • Refresh – 클릭하면 패널을 빠르게 새로 고칩니다. 현재 선택된 부품은 유지됩니다.

Components List

부품 목록 그리드 자체에 포함되는 콘텐츠는 다음 방식으로 관리됩니다.

  • 부품 목록 정렬 순서 설정 – 열 제목을 클릭하면 해당 열의 데이터 기준으로 부품 목록이 정렬됩니다. 정렬 순서를 반대로 하려면 제목을 다시 클릭하세요.

  • 표시되는 열 순서 설정 – 열 제목을 드래그 앤 드롭하여 새 위치로 이동합니다.

  • 표시할 파라미터 열 지정 – 열 헤더에서 오른쪽 클릭하고 Select Columns를 선택하면 Select Columns 대화상자가 열리며, 여기서 파라미터 열의 표시 여부를 제어하고 위치 순서를 변경할 수 있습니다.

    Select columns 대화상자
    Select columns 대화상자

    • 이 대화상자에는 Components 패널에 표시할 수 있는 모든 가능한 열이 나열됩니다. 항목에 가 표시되면 해당 열이 Components 패널에 표시됩니다. 항목에 가 표시되면 해당 열은 Components 패널에 not 표시되지 않습니다. 기호를 클릭하여 표시/숨기기 기능을 전환하세요.

    • 열 헤더 바의 / 아이콘을 클릭하여 모든 열의 표시도 제어할 수 있습니다. 일부 열은 표시되고 다른 열은 숨겨진 경우에는 아이콘이 표시됩니다.

    • 두 번째 열의 헤더 바 위에 커서를 올리고 아이콘을 클릭하면 드롭다운이 열리며, 여기서 표시할 열을 선택할 수 있습니다.

    •  /  버튼을 사용하여 선택한 항목을 목록에서 위나 아래로 이동할 수 있습니다. 표시로 설정된 항목()만 이동할 수 있습니다. 이 설정은 열이 Components 패널에 표시되는 순서를 결정합니다.

  • 열 데이터로 목록 그룹화 – 열 헤더에서 오른쪽 클릭한 뒤 Enable Columns Grouping 옵션을 선택하고, 목록 상단의 그룹화 영역으로 열 헤더(예: Footprint)를 드래그합니다. 그러면 목록 항목이 지정된 그룹화 열의 각 고유 파라미터(예: 풋프린트 유형) 아래로 모아집니다.

    목록에서 부품을 정리하기 위해 Grouping를 사용할 경우, 수용 가능한 항목 수는 최대 10,000개입니다.

  • 특정 열 항목으로 목록 필터링 – 열 헤더에서 를 선택하면 해당 열의 고유 파라미터 항목 목록이 표시됩니다. 여기서 항목을 선택하면 지정된 파라미터(예: 풋프린트 유형 코드)를 포함하는 부품만 목록에 표시되도록 제한할 수 있습니다. 필터를 재설정하려면 All 옵션을 선택하세요. 선택한 열에서 필터링을 더 세부적으로 조정하려면 (Custom)을 선택하여 Filter Editor 대화상자를 여세요.

열 표시

Components 패널 내 콘텐츠를 표시하는 방법은 여러 가지가 있습니다. 각 열 이름(Name, Description, Footprint)을 오른쪽 클릭하면, 부품을 원하는 방식으로 표시하기 위해 다음 옵션 중에서 선택할 수 있습니다.

  • Best FitNameDescriptions 열의 내용을 서로 가깝게 배치되도록 병합하며, 열 사이의 불필요한 여백이 없어집니다.

  • Best Fit All Columns – 모든 열의 내용을 서로 가깝게 배치되도록 병합하며, 열 사이의 불필요한 여백이 없어집니다.

  • Clear Sorting – 열 정렬을 취소할 때 사용합니다.

  • Enable Columns Grouping – 특정 열을 기준으로 열 헤더를 드래그할 수 있게 하여 Name, Description, Footprint 열의 순서를 변경할 수 있습니다.

  • Select ColumnsSelect Columns 대화상자를 열며, 이 섹션에서 표시할 다른 열을 선택할 수 있습니다.

  • Apply Column Visibility to Child Categories – 선택한 카테고리에 하위 카테고리가 있는 경우, 부모 카테고리의 열 표시 설정을 하위 카테고리로 전달할 수 있도록 하는 명령입니다. 이 명령은 하위 카테고리가 존재할 때만 사용할 수 있습니다.

부품 검색 및 기능

부품 검색

Components 패널에서 사용 가능한 부품을 검색하려면 Search 필드에 검색어를 입력하고/하거나 패널의 CategoriesFilters 선택 항목을 사용하여 부품 목록을 원하는 조건으로 좁히세요. 필터는 Workspace components에만 지원되며, Manufacturer Part Search panel과 마찬가지로 Components 패널은 단위 인식(텍스트를 숫자로 해석하는) 검색 필터를 지원합니다. 검색 기능은 입력한 검색 기준에 따라 결과의 우선순위를 정합니다.

Search 기능을 사용하면 현재 활성 Search 문자열을 선택한 뒤 편집하거나 내용을 추가할 수 있습니다.

'활성' 검색 문자열을 클릭하면 해당 문자열이 Search 필드에 입력됩니다. Search 필드에서 그 검색을 다시 사용하거나 편집할 수 있습니다.

Search 필드는 문자열 내에 별표(*)로 표시되는 와일드카드 검색도 지원합니다.

목록에 있는 부품을 오른쪽 클릭한 뒤 Find Similar Components를 선택하여 여는 Find Similar Components 대화상자에서는 선택한 부품을 기준으로 검색 기본 설정을 정의할 수 있습니다.

최종 검색 결과는 선택한 부품 유형(Workspace 또는 비-Workspace 부품)과 Workspace 연결 상태에 따라 달라집니다. 예를 들어, Workspace 부품은 비-Workspace 부품보다 더 많은 파라미터를 표시하는 경우가 많습니다. 선택한 부품과 동일하거나 다른 부품 및 파라미터를 구체적으로 찾으려면 드롭다운을 사용하여 Same, Any, 또는 Different 옵션을 선택할 수 있습니다.

부품 배치

선택한 부품은 드래그 앤 드롭하거나, 오른쪽 클릭 컨텍스트 메뉴에서 Place를 선택하거나, Details 창의 버튼을 사용하거나, 원하는 부품 항목을 더블클릭하거나, Enter 단축키를 사용하여 회로도에 배치할 수 있습니다.

패널에서 부품을 배치하는 방법은 다음과 같습니다.

  • Component Details 창의 Place 버튼을 클릭하면 커서가 자동으로 회로도 시트 경계 안으로 이동하고, 부품이 커서에 매달린 상태로 나타납니다. 위치를 정한 뒤 클릭하여 배치하세요. 부품을 하나 배치한 뒤에는 같은 부품의 또 다른 인스턴스가 다시 커서에 나타납니다. 배치 모드를 종료하려면 오른쪽 클릭하세요.

    Components panel, placing from component details pane

  • 부품을 오른쪽 클릭한 다음 컨텍스트 메뉴에서 Place를 선택합니다. 부품이 커서에 매달린 상태로 나타나며, 위치를 정한 뒤 클릭하여 배치하세요. 패널이 디자인 공간 위에 떠 있는 경우, 회로도를 보고 부품을 배치할 수 있도록 패널이 희미하게 표시됩니다. 부품을 하나 배치한 뒤에는 같은 부품의 또 다른 인스턴스가 다시 커서에 나타납니다. 배치 모드를 종료하려면 오른쪽 클릭하세요.

  • Click, Hold&Drag – 패널의 그리드 영역에서 컴포넌트를 클릭한 채로 회로도 시트 위로 끌어다 놓습니다. 이 모드에서는 커서를 누른 상태로 유지해야 하며, 커서를 놓는 순간 컴포넌트가 배치됩니다. 컴포넌트를 배치한 후에는 다른 컴포넌트나 다른 명령을 자유롭게 선택할 수 있습니다.

    드래그 앤 드롭으로는 해당 컴포넌트의 인스턴스 1개만 배치됩니다. 여러 인스턴스를 배치해야 하는 경우에는 Place 명령/버튼을 사용하거나, 컴포넌트 항목을 더블클릭하십시오.

컴포넌트 배치는 정말 매우 간단합니다. 하지만 작업을 시작하기 전에 먼저 컴포넌트를 받아들일 회로도 시트(또는 PCB 문서)가 Altium Designer에서 열려 있고 활성 문서인지 확인하십시오. 여러 창에 걸쳐 문서가 열려 있다면, 활성 회로도 문서를 포함한 창에 포커스가 있는지도 함께 확인해야 합니다.

여러 창에 걸쳐 Altium Designer를 사용하는 경우, 대상 회로도가 없는 창에 Components 패널 또는 Explorer 패널이 어떤 모드로든 도킹되어 있으면 Place 명령은 계속 회색으로 비활성화된 상태로 남아 있습니다. 이는 도킹된 패널 내부를 클릭하면 그 패널이 연결된 창으로 포커스가 이동하기 때문입니다. 반면 패널이 부동 상태이면 필요한 Altium 창(활성 대상 회로도가 있는 창)에 포커스를 줄 수 있고, 패널 내부에서 작업하는 동안에도 그 창의 포커스가 유지됩니다.

멀티파트 컴포넌트 배치

배치하려는 컴포넌트가 여러 파트를 가지고 있는 경우, 패널의 Models 영역에서 심볼 미리보기 이미지 아래에 선택된 파트가 먼저 배치됩니다.

멀티파트 컴포넌트의 한 파트를 배치한 후에는, 해당 파트가 선택된 상태에서 Properties 패널의 Part 드롭다운을 사용해 이 컴포넌트의 다른 파트로 변경할 수 있으며, 또는 메인 메뉴의 Edit » Increment Part Number 명령이나 파트의 오른쪽 클릭 메뉴에 있는 Part Actions » Increment Part Number 명령을 사용해 다음 사용 가능한 파트로 전환할 수 있습니다.

Altium Designer는 정의된 Normal 및 Alternate 표시 모드(예제 보기)를 사용하여, 하나의 컴포넌트만으로 멀티파트 컴포넌트를 단일 심볼(모든 서브파트) 또는 다중 심볼(각 개별 서브파트당 하나)로 표시할 수 있도록 지원합니다.

  • 멀티파트 컴포넌트가 해당 표시 모드(normal 또는 alternate)에서 비어 있는 서브파트를 포함하는 경우, 이러한 서브파트는 배치 시 생략됩니다 (예제 보기).

  • 멀티파트 컴포넌트에서 프리미티브가 하나의 서브파트에만 정의되어 있으면, 그 서브파트를 회로도 시트에 배치할 때 설계자 접미사는 숨겨집니다 (예제 보기).

  • 현재 선택된 표시 모드에 대해 서브파트에 프리미티브가 없거나, 현재 선택된 서브파트에 대해 표시 모드에 프리미티브가 없는 경우, 컴포넌트의 Properties 패널에 있는 Part / Mode 드롭다운의 해당 항목은 회색으로 비활성화됩니다 (). 이러한 항목이 드롭다운에서 선택되면 경고 아이콘이 표시됩니다 ().

  • 컴포넌트에 프리미티브가 없는 서브파트가 있고 이러한 서브파트가 회로도에 배치되지 않은 경우, 설계 검증 실행 시 Unused sub-part in component 위반은 발생하지 않습니다.

컴포넌트 필터링

Workspace 컴포넌트를 볼 때 Filters 창에는 현재 검색 및 사용 가능한 파라미터를 기준으로 선택된 필터 옵션이 채워집니다. 나열된 컴포넌트에 대한 파라메트릭 필터링은 특정 컴포넌트 또는 컴포넌트 유형을 찾기 위한 추가 옵션을 제공합니다. Categories 창 위의 버튼에서 Filters 창을 엽니다. 패널의 컴팩트 모드에서는 버튼을 클릭하여 Filters를 패널 확장으로 팝아웃할 수 있습니다.

필터는 Workspace components에 대해서만 지원된다는 점에 유의하십시오. 특정 파라미터 필터를 찾으려면 창 내부의 Filter Search 필드를 사용하십시오.

Javascript ID: Pnl_Components_Filter
  • 패널의 Filters에 있는 파라메트릭 검색 기능은 Workspace 컴포넌트를 호스팅하는 Workspace에서 적절한 컴포넌트 파라미터 데이터가 전달되는 것에 의존합니다. 따라서 소프트웨어가 오래된 Altium 서버 제품에 연결되어 있으면 Filter 기능이 비활성화될 수 있습니다. 이전 서버 버전에서 Filter를 활성화하려면 ComponentSearch.LegacyAFS.Filters 옵션을 Advanced Settings dialog에서 활성화하십시오.

  • 파라미터가 Filters 창에 표시되려면, 선택된 카테고리의 컴포넌트들에서 해당 파라미터에 대해 최소 두 개 이상의 서로 다른 값이 사용되어야 합니다. 또한 Filters 창에는 가장 많이 사용되는 파라미터 최대 100개만 표시됩니다(연결된 Workspace 전체의 모든 컴포넌트 유형에서 더 많은 컴포넌트가 사용하는 파라미터). 다음 파라미터(또는 다음 이름으로 시작하는 파라미터)는 항상 창 상단에 표시됩니다: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

패널 Filters 옵션은 특정 파라미터 유형을 Favorites로 지정하여 필요에 맞게 조정할 수 있으며, 그렇게 지정하면 해당 항목들이 현재 컴포넌트 Category의 목록 상단으로 이동합니다. 파라미터 필터 이름 오른쪽으로 마우스를 올리고 아이콘을 클릭하면 해당 필터를 Favorite로 설정할 수 있습니다. Favorite 필터 설정은 개별 컴포넌트 Category별로 적용되고 저장됩니다.

Workspace 컴포넌트의 경우, 오른쪽 클릭 메뉴에서 Component Editor를 통한 컴포넌트 편집(Edit)과 컴포넌트 생성 및 복제 같은 컴포넌트 관리 기능 수행, 또는 선택한 컴포넌트의 Part Choices 및 Type 편집(Operations) 옵션을 제공합니다.

 
 
 
 
 

컴포넌트 Details 창의 추가 정보 옵션에는 모델 이미지 보기, 온라인 데이터시트 보기(References), 실시간 Supplier 정보 보기(Part Choices), 해당 부품이 Workspace 프로젝트, 관리 시트, 재사용 블록에서 어디에 사용되었는지 확인(Where Used), 그리고 오른쪽 클릭 메뉴를 통해 선택한 또는 모든 컴포넌트 파라미터 데이터(기술 세부사항)를 탭 구분 형식으로 복사하고, 즐겨찾기로 표시된 파라미터를 기본 5개 파라미터로 재설정하는 기능이 포함됩니다.

연결된 Altium 365 Workspace에서 컴포넌트를 탐색할 때 선택한 컴포넌트의 상태와 관련된 문제가 발견되면, 컴포넌트 파라미터 목록 위의 Component issues 줄에 있는 아이콘(오류) 또는 아이콘(치명적 오류)으로 표시됩니다. 아이콘 오른쪽의 숫자는 발견된 문제 수를 나타냅니다. 문제의 간단한 설명을 보려면 숫자 오른쪽의 아래쪽 화살표를 클릭하십시오.

발견된 라이브러리 상태 문제의 예입니다.
발견된 라이브러리 상태 문제의 예입니다.

Workspace 라이브러리 상태는 Altium 365 Workspace 브라우저 인터페이스에서 접근할 수 있는 Library Health 대시보드 페이지를 통해 더 자세히 확인할 수 있습니다. 자세한 내용은 Library Health Dashboard를 참조하십시오.

사용자 지정 필터링 기능을 사용하여 Components 패널에서 필터링을 더 세부적으로 조정할 수 있습니다. ​​​​​​

이 기능은 다음과 같이 사용할 수 있습니다:

  1. 헤더의 필터() 아이콘을 클릭하여 Filter 드롭다운을 표시합니다.

  2. 이 드롭다운은 Filter Value(기본값)을 선택하여 필터링하거나, 사용자 정의 Filter Rule를 구성하여 필터링하는 것을 지원합니다. 목록에서 값을 선택하면 자동으로 식(expression)으로 변환되며(이후 편집 가능),

  3. 직접 필터를 정의하기 위해 Filter Rules를 선택한 경우, 먼저 첫 번째 드롭다운에서 연산자를 선택한 다음, 그다음 두 번째 드롭다운에서 필터 값을 선택하거나 입력합니다.

  4. 현재 필터는 결과 목록 아래에 표시되며, 필터를 열어 편집하려면 버튼을 클릭하여 Filter Editor 대화상자를 여십시오.

사용 위치

Components 패널에서 Workspace 컴포넌트를 선택하면 최신 리비전이 현재 어디에서 사용되고 있는지에 대한 정보를 Where Used 영역에서 볼 수 있습니다. 이 영역은 다음에 대한 빠른 필터 정보를 제공합니다:

  • Projects – 해당 컴포넌트가 사용된 Workspace 프로젝트. 프로젝트가 Workspace에 저장된 후에 only 정보가 표시됩니다.

  • Managed Sheets – 해당 컴포넌트가 사용된 관리 회로도 시트. 

  • Reuse Blocks – 연결된 Workspace 라이브러리의 일부로 저장된 Reuse Block.

선택한 컴포넌트를 사용하는 엔터티가 Workspace에 존재하는 경우에만 탭이 표시된다는 점에 유의하십시오.

컴포넌트가 Workspace 프로젝트의 모든 design variants에서 사용되는 것이 아닌 경우, Where Used 영역의 프로젝트 항목에는 해당 컴포넌트가 사용되는 변형 수와 이 프로젝트의 총 변형 수, 그리고 컴포넌트가 사용되는 변형 목록이 표시됩니다 ().

컴포넌트 데이터 캐싱

Components 패널을 사용할 때 Workspace 컴포넌트의 데이터는 Workspace에서 로컬 머신으로 캐시됩니다. 이는 Altium Designer가 Workspace에 연결되어 있지 않을 때 Workspace 컴포넌트에 대한 오프라인 액세스 모드를 제공하며, 따라서 일반적인 컴포넌트 탐색 및 배치 등을 가능하게 합니다.

현재 Altium Designer 세션에서 Components 패널을 처음 실행할 때 오프라인 모드이면 패널에 경고가 표시되며, 캐시된 컴포넌트 데이터를 계속 사용할지 또는 캐시를 지울지 선택할 수 있는 컨트롤도 함께 제공됩니다.

캐시된 컴포넌트를 사용하려면 Use Cached Data를 클릭하십시오. 이 상태는 패널의 컴포넌트 목록 창 하단 바에 있는 Offline mode – cached data is being used 경고 텍스트로 표시됩니다. 이 모드에서는 Filters이 활성화되지 않는다는 점에 유의하십시오.

캐시는 시간이 지남에 따라 컴포넌트 데이터를 축적하며, Preferences 대화상자의 Data Management – Servers page에 있는 Known Servers 아래에서 사용할 수 있는 Clear Cache 옵션을 사용하여 언제든지(모든 Workspace에 대해) 지울 수 있습니다.

캐싱 동작은 Altium 365 Workspace와 같이 현재 연결된 Workspace의 캐시된 컴포넌트만 표시하므로, 일부 캐시 데이터는 비활성화될 수 있습니다. 이 동작은 Preferences 대화상자의 Data Management – Servers 페이지에서 관리할 수 있습니다.

Part Choices 목록

Workspace 컴포넌트와 연결된 Part Choices List를 편집하려면 항목의 오른쪽 클릭 메뉴에서 Operations » Create/Edit Part Choices 옵션을 선택하십시오.

다음 Edit Part Choices 대화상자의 버튼을 사용해 Add Part Choices 대화상자를 열 수 있으며, 여기서는 선택한 컴포넌트의 Name 파라미터를 기준으로 부품 제조업체를 자동 검색합니다. 미리 정의된 검색어를 선택 해제하면 대안을 수동으로 검색할 수 있습니다. 기능적으로 이 대화상자는 Manufacturer Part Search panel의 모달 버전입니다.

Part Choice 목록은 적절한 별 아이콘 수준을 선택하여 순위를 지정할 수 있으며, 그러면 목록은 가장 높은 순위의 제조업체 선택이 맨 위로 오도록 자동으로 재정렬됩니다.

Part Choices는 회로도 설계, BOM 문서, 출력 보고서 등과 같이 해당 데이터가 적용되는 모든 곳에서 컴포넌트와 함께 유지됩니다.

Components 패널에서 컴포넌트를 선택하면 그 Part Choice 목록을 Details 창의 Part Choices 영역에서 볼 수 있습니다. 관련 Part Choice의 기본 정보(재고, 중간 단가, 제조업체 라이프사이클)도 Details 창 상단에서 확인할 수 있습니다. 연결된 색상 스트라이프는 추론된 라이프사이클 상태를 기준으로 해당 부품의 사용 적합성을 기본적으로 나타냅니다. 예를 들어 Obsolete (빨간색)으로 표시된 컴포넌트는 Volume Production (녹색)으로 평가된 컴포넌트보다 권장되지 않습니다. 색상 스트라이프 위에 마우스를 올리면 Manufacturer Lifecycle 상태를 볼 수 있습니다.

Silicon Expert 또는 Z2 Data 통합 기능을 사용하는 경우, 추가 데이터와 컨트롤이 Details 창 상단에 제공될 수 있습니다. 자세한 내용은 Pulling Part Data from SiliconExpert 및 Pulling Part Data from Z2Data 페이지를 참조하십시오.

Workspace에 대해 Part Choice Revision Control 기능이 활성화되어 있는 경우, Operations » Create/Edit Part Choices 옵션을 선택하면 Edit Part Choices 대화상자 대신 Component Editor가(Single Component Editing 또는 Batch Component Editing 모드로) 열립니다. 필요한 Part Choice 변경을 적용한 후 컴포넌트를 다음 컴포넌트 리비전으로 Workspace에 다시 저장하십시오.

Components 패널 오른쪽 클릭 메뉴

패널의 오른쪽 클릭 팝업 메뉴는 다음 명령을 제공합니다:

  • Place [ComponentName/FootprintName/SimulationModelName] – 현재 선택된 컴포넌트 또는 시뮬레이션 모델을 활성 회로도 문서에 배치하거나, 현재 선택된 풋프린트를 활성 PCB 문서에 배치하는 데 사용합니다.

  • Find Similar ComponentsFind Similar Components dialog를 열어 선택된 컴포넌트와 유사한 컴포넌트를 찾기 위한 검색 기준을 설정하는 데 사용합니다.

  • Navigate to [ComponentName] – 선택한 Workspace 컴포넌트를 Explorer panel에서 여는 데 사용하며, 여기에서 상세 Item 정보에 접근하고 Item의 리비전 및 라이프사이클 설정을 관리할 수 있을 뿐 아니라, 사용 위치 및 공급망 세부정보 등 다른 옵션도 사용할 수 있습니다.

  • Edit – 클릭하면 선택한 Workspace 컴포넌트를 Component Editor(Single Component Editing 또는 Batch Component Editing 모드)로 편집하거나, 선택한 도메인 모델(심볼, 풋프린트 또는 시뮬레이션 모델)을 해당 편집기에서 편집합니다. 현재 컴포넌트 유형이 현재 사용 중인 템플릿과 다르면 Change component type 대화상자가 열립니다 (). 이 대화상자를 사용하여 선택한 컴포넌트의 유형을 변경하십시오.

  • Create – 클릭하면 새 컴포넌트를 추가할 때 컴포넌트 유형을 선택하는 Create new component 대화상자가 열립니다.

  • Delete – 클릭하면 연결된 Workspace에서 선택한 컴포넌트를 삭제합니다.

  • Operations – 아래에 설명된 Workspace 컴포넌트용 추가 기능의 드롭다운 메뉴에 접근하는 데 사용합니다.

    • Submit Request – 활성 부품 요청 프로세스 정의에 접근하는 데 사용합니다. Part Requests 프로세스 테마에 대해 활성 프로세스 정의가 없으면 Submit Request 버튼이 회색으로 비활성화됩니다(사용 불가). 새로 고치려면 Workspace에서 로그아웃했다가 다시 로그인하거나 Altium Designer를 다시 시작해야 할 수 있습니다.

    • Download – 선택한 컴포넌트를 압축된 컴파일 Integrated Library (*.IntLib)로 다운로드하는 데 사용하며, 해당 소스 라이브러리 패키지(*.LibPkg) 및 라이브러리 파일도 함께 포함됩니다. 여러 컴포넌트 항목을 선택하면 하나의 세션에서 해당 컴포넌트들을 함께 다운로드할 수 있습니다.

    • Make a copy – 클릭하면 선택한 컴포넌트를 복사합니다. 컴포넌트 편집기가 Single Component Editor 모드로 열립니다.

    • Change Component TypeChoose component type 대화상자 ()를 여는 데 사용하며, 여기서 현재 컴포넌트의 유형을 목록에 있는 다른 기존 정의 유형 중 하나로 변경할 수 있습니다. 이 대화상자는 컴포넌트 유형과 연결된 컴포넌트 템플릿 정보와, 연결된 Workspace 내에서 해당 유형의 컴포넌트를 찾거나 저장할 수 있는 폴더에 대한 정보를 표시합니다. 를 클릭하십시오.사용 가능한 Component Types 목록을 관리하는 버튼으로, Data Management – Component Types 페이지의 Preferences 대화상자 에서 사용합니다.

    • Change State – 선택한 컴포넌트의 리비전 상태를 변경하는 데 사용합니다. 이 명령을 사용하면 Batch state change dialog가 열리며, 여기서 컴포넌트의 리비전 상태를 변경할 수 있습니다.

    • Create/Edit Part Choices – Edit Part Choices 대화상자 에 액세스하는 데 사용하며, 여기서 Workspace 컴포넌트에 연결된 파트 선택 목록을 생성하거나 편집할 수 있습니다.

      Workspace에 대해 Part Choice Revision Control 기능이 활성화되어 있는 경우, 이 명령을 선택하면 Component Editor가 Single Component Editing 또는 Batch Component Editing 모드로 열립니다.
    • Full Item History – 현재 선택된 컴포넌트의 상세 보기를 여는 데 사용하며, Altium Designer 내에서 새 탭 보기로 열립니다. Item View는 특정 Item의 리비전 및 라이프사이클 이력을 매우 자세하게 보여주며, 해당 Item을 구성하는 모든 요소도 함께 표시합니다. 이 보기에는 Timeline도 포함됩니다. Timeline을 사용하면 해당 Item의 리비전 레벨 또는 라이프사이클 상태에 대한 변경이 정확히 언제 이루어졌는지와 누가 변경했는지를 확인할 수 있습니다.

     

  • Refresh – 패널을 빠르게 새로 고치려면 클릭합니다. 현재 컴포넌트 선택은 유지됩니다.

컴포넌트 비교 기능

Compare 기능을 사용하면 선택한 두 컴포넌트(파트)의 파라미터를 비교할 수 있습니다. 이 기능은 그리드 영역에서 아이콘이 활성화된(파란색) 상태로 두 컴포넌트를 선택하여 사용할 수 있습니다. Selected Component Details 영역이 그리드 영역의 오른쪽에 열립니다. 상단 영역(아래 이미지의 영역 1)에는 선택한 컴포넌트의 이미지, 이름, 설명, 가격이 나란히 표시됩니다. Datasheet 버튼을 클릭하면 해당 컴포넌트의 제조사 데이터시트(있는 경우)를 열 수 있습니다. Place 버튼을 클릭하면 컴포넌트를 설계 공간에 배치할 수 있습니다. 컴포넌트는 설계 공간에서 커서에 붙은 상태로 나타나며, 클릭하여 원하는 위치에 배치합니다. 추가 컴포넌트를 계속 배치할 수도 있고, 마우스 오른쪽 버튼을 클릭하거나 Esc를 눌러 배치 모드를 종료하고 Components 패널로 돌아갈 수 있습니다.

하단 영역(아래 이미지의 영역 2)에는 컴포넌트 파라미터가 나란히 표시되며, 차이점은 쉽게 비교할 수 있도록 빨간색 텍스트로 강조됩니다.

Compare 기능은 Components 패널이 compact 모드일 때도 사용할 수 있지만, 동작 방식이 약간 다릅니다. 이 기능은 그리드 영역에서 두 컴포넌트를 선택하여 액세스합니다. Selected Component Details 영역이 그리드 영역 아래에 열립니다. 상단 영역에는 컴포넌트의 이름, 가격, 파라미터 보기가 표시되며, 차이점은 쉽게 비교할 수 있도록 빨간색 텍스트로 강조됩니다. 하단 영역에는 컴포넌트의 SymbolsModels가 나란히 표시됩니다.

Compare 기능 및 관련 기능은 Manufacturer Part Search panel에서도 사용할 수 있습니다.

컴포넌트 심볼 및 풋프린트 편집

특정 컴포넌트의 심볼과 풋프린트는 우측 상단의 Info button를 클릭하여 액세스하는 Details 창의 Models 섹션 내에서 숨길 수 있습니다. 한 번 숨기면 심볼과 풋프린트는 클릭 가능한 링크로 대체되며, 이를 클릭하면 숨겨진 항목이 원래 보기로 복원됩니다. 또한 표시된 모델의 크기를 조정하는 기능도 포함되어 있습니다. 심볼과 풋프린트 모두에서 모델 영역의 아래쪽 경계를 클릭하여 드래그하면 이미지 크기를 조정할 수 있습니다.

모델 보기 숨기기 및 크기 재조정 기능은 Manufacturer Part Search panelDetails 창에서도 사용할 수 있습니다.

*.SchLib 파일인 Schematic Library를 Components 패널에서 탐색하는 경우, 선택한 컴포넌트의 심볼과 풋프린트는 모델 미리보기의 오른쪽 하단에 있는 버튼을 사용해 편집할 수 있습니다.

풋프린트 편집 기능은 Components에 액세스할 때 사용할 수 있으며, 유효하고 연결된 풋프린트가 이미 존재하는 경우에 한합니다.

컴포넌트 선택 대화상자

Components 패널에서 사용되는 검색 엔진과 보기는 컴포넌트 선택이 이루어지는 다른 Altium Designer 애플리케이션에도 동일하게 적용됩니다. 컴포넌트 검색 기능은 이러한 (모달) 대화상자에 포함되어 있으며, OK 확인 버튼과 함께 사용 가능한 작업 명령에는 약간의 차이가 있을 수 있습니다. 이 대화상자의 이름은 일반적으로 Component Search입니다.

  • ActiveBOM 문서 – Components 검색 보기는 Workspace component를 대체 컴포넌트로 변경할 때 사용됩니다. 목록에 있는 컴포넌트 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Change [component name]를 선택하면 Replace Component 대화상자가 열립니다.
  • Item Manager – Components 검색 보기는 현재 컴포넌트를 대체할 Workspace component를 수동으로 선택할 때 사용됩니다. 목록에 있는 컴포넌트 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Choose manually를 선택하면 Replace Component dialog가 열립니다.
  • Variant Management – Components 검색 보기는 대체 컴포넌트 프로젝트 변형을 선택할 때 사용됩니다. Alternate part를 Component Variation으로 선택한 다음, Edit Component Variation dialog에서 Choose를 선택하면 Replace Component dialog가 열립니다.

일반 컴포넌트 액세스 및 배치

이 기능은 Open Beta 상태이며, Advanced Settings dialog에서 ComponentSearch.GenericComponents 옵션이 활성화되어 있을 때 사용할 수 있습니다.

설계 초기 단계의 레이아웃 작업을 더 빠르게 진행할 수 있도록, 표준 기본 Generic Components  개념이 제공됩니다. 일반 컴포넌트는 사용 가능한 컴포넌트 소스에서 특정 제조사 파트를 찾고 선택할 필요 없이 설계에 빠르게 배치할 수 있습니다. 일반 컴포넌트는 설계 프로세스 후반에 적절한 컴포넌트로 쉽게 대체할 수 있는 플레이스홀더 용도로 사용되며, 가상 또는 파라메트릭 컴포넌트로 간주할 수도 있습니다.

일반 컴포넌트 생성에 대해 더 알아보려면 Creating Generic Components 페이지를 참조하십시오.

Altium Designer가 Workspace에 연결되어 있으면, 사용 가능한 Generic Components는 Categories 창에서 All 옵션을 선택했을 때 표시되는 패널에서 액세스할 수 있으며, 패널이 compact 모드일 때는 상단 드롭다운 메뉴에서도 액세스할 수 있습니다. Generic Component 타일 내의 버튼을 클릭하면 활성 회로도 문서에 배치할 수 있도록 해당 컴포넌트가 커서에 붙습니다. 컴포넌트를 회로도에 배치하면 심볼의 핀, 선, 테두리 프리미티브, 즉 외곽선이 빨간색으로 표시되어 현재 일반 컴포넌트가 사용되고 있음을 나타냅니다. Components 패널에서 타일 자체를 선택하면 해당 컴포넌트 유형 카테고리가 패널에 열립니다.

Components 패널에서 일반 컴포넌트 배치
Components 패널에서 일반 컴포넌트 배치

Generic Components는 최종 설계에 사용되어서는 안 되므로, 회로도에 배치되면 ERC 위반인 Generic Component가 발생합니다. 해당 위반의 수준은 기본적으로 Fatal Error이며, Project » Project Options (Project Options 대화상자)의 Error Reporting settingsViolations Associated with Components 섹션에서 결정됩니다.

배치된 Generic Component를 선택하면 Properties panel에서 해당 속성에 액세스할 수 있으며, 여기에는 이 유형의 컴포넌트와 관련된 설정 및 파라미터만 제공됩니다. 사용 가능한 파라미터는 관련된 Component Template에 의해 결정됩니다(여기 예시에서는 Resistors). 파라미터 값은 수동으로 입력하거나, 해당 유형의 사용 가능한 모든 컴포넌트에서 가져온 값을 제공하는 드롭다운 메뉴 목록에서 선택할 수 있습니다.

Javascript ID: GenericComponents_Parameters

일반 컴포넌트의 파라미터 지정 – 드롭다운에서 파라미터 값을 선택합니다.

일반 컴포넌트의 파라미터 지정 – 결과.

점퍼 컴포넌트 지원

점퍼는 와이어 링크라고도 하며, 라우팅을 점퍼 컴포넌트로 대체할 수 있게 해 줍니다. 이는 단면 보드를 성공적으로 설계하는 데 종종 필수적인 요소입니다. Altium Designer는 Jumper라는 특수 컴포넌트 유형을 통해 점퍼 컴포넌트 사용을 지원합니다.

점퍼 풋프린트를 PCB에 직접 배치하는 것으로 시작할 수도 있지만, 권장되는 워크플로는 회로도에서 시작하는 것입니다. 자세한 내용은 Working with Jumper Components 페이지를 참조하십시오.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

콘텐츠