Draftsman Placement & Editing Techniques in Altium Designer

Created: 04.01.2023 | Updated: 04.01.2023

Parent page: Streamlining Board Design Documentation with Draftsman

A variety of objects are available for use in creating a PCB drawing. The Draftsman editor's design space can contain a large number of design objects that make up the drawing. During the course of the drawing creation process, the placement and properties of these objects need to change as you work to achieve the required look of your drawing.

Object Placement and Editing Commonality

In Altium Designer's Draftsman, the process of placing an object is roughly the same regardless of the object being placed. At its simplest level, the process is as follows:

  1. Select the object to be placed from one of the following locations:
    • the main Place menu;
    • the Active Bar located at the top of the design space;
    • the Place submenu of the design space right-click menu;
    • the Drawing Views or the Drawing Annotations toolbar.
  2. When an object is selected for placement, drawing data is retrieved from the source PCB file (where applicable), and the cursor will change to a crosshair, indicating that you are in editing mode, and if relevant, the object will appear "floating" under the cursor. Position the cursor then left-click or press Enter to place the object. For some objects, such as dimensions, you must continue the position-and-click procedure to define all relevant locations of the object.
  3. After placing a non-view type object, you will remain in placement mode (indicated by the crosshair cursor), allowing you to immediately place another object of the same type. To end placement mode, right-click or press the Esc key. In some cases such as placing a Region object, you may need to do this twice; once to finish placing the object and once to exit placement mode. When you exit placement mode, the cursor will return to its default shape.

Editing Prior to Placement

The default properties for an object can be changed at any time on the PCB Editor – Defaults page of the Preferences dialog. Most properties of an object, or those that can logically be pre-defined, are available as editable default settings. These properties will be applied when placing subsequent objects. Select an object in the Primitive List to reveal its options on the right.

Use the Primitive List column to access properties for objects and edit default values as required.
Use the Primitive List column to access properties for objects and edit default values as required.

Editing After Placement

Once an object has been placed, there are a number of ways in which it can be edited. These are described below.

The Associated Properties Panel

This method of editing uses the associated Properties panel mode and dialog to modify the properties of a placed object.

The panel automatically changes its mode and content to match the selected drawing view or object.
The panel automatically changes its mode and content to match the selected drawing view or object.

To open the Properties panel and access the properties of a placed object:

  • After selecting the object, select the Properties panel from the button at the bottom right of the design space or select View » Panels » Properties from the main menus.
  • Double-click on the object in the design space.
  • Right-click on the object then select Item Properties from the context menu.

If the Properties panel is already active, click on the object to access its properties in the panel. The panel will automatically populate its content to match the property settings for the currently selected object in the design space.

In practice, the Properties panel changes to that object 'mode', which, along with the changed property options, is indicated by the panel's heading text. For example, selecting a placed Assembly View object will change the panel to its Assembly View mode, or selecting a drawing object such as a Linear Dimension will change the panel to its Linear Dimension mode.

When a drawing view is selected, press F1 to access documentation for that object. For a selected Board Assembly View, for example, this will open the Board Assembly View object documentation, which also includes a section describing Board Assembly View Properties in details.

Each entry in the following list of Draftsman objects links to its associated properties information (Properties panel mode) section.

Graphical Editing

This method of editing allows you to select a placed object directly in the design space and change its size, shape, or location graphically. Modification of shape and/or size (where applicable) is performed through the use of editing 'handles' that appear once the object is selected.

An example editing handle for a selected Board Assembly View object. Drag the handle to change the view's scale.
An example editing handle for a selected Board Assembly View object. Drag the handle to change the view's scale.

Click anywhere on an object away from editing handles (where they exist) to drag the object to reposition it. Press Spacebar to rotate the object counterclockwise or Shift+Spacebar for clockwise rotation with 90-degree increments.

Selected Draftsman objects can be 'nudged' by the current grid value by pressing the arrow keys. Selected objects can also be 'nudged' by the grid value x10 by pressing the arrow keys while holding down the Shift key.

Movement and Rotation Commands

Objects can also be moved and rotated using the command of the Move pop-up menu accessed by pressing the M shortcut key.

Select the object(s) to move, open the Move pop-up menu, then choose a command:

  • Move Selection – after launching the command, click in the design space then move the cursor with the selection attached and click again once the object(s) are in the desired location.
  • Move Selection By XY – after launching the command, The Get X / Y Offsets dialog opens. Use the dialog to specify the distance by which the selection(s) should be moved along the horizontal (X) axis or vertical (Y) axis.

    The Get X / Y Offsets dialog
    The Get X / Y Offsets dialog

    • X Offset - use this field to specify the distance by which the selection should be moved along the horizontal axis. Positive and negative values can be specified depending on the direction of movement required.
    • Y Offset - use this field to specify the distance by which the selection should be moved along the vertical axis. Positive and negative values can be specified depending on the direction of movement required.
  • Rotate Selection – after launching the command, the Rotation Angle (Degrees) dialog will open. Enter the required Angle of rotation from 0.001° to 360.00°(resolution 0.001°). Enter a positive value for counterclockwise rotation or a negative value for clockwise rotation. Click OK to close the dialog then position the cursor and click to define the reference point for rotation. The selected objects will be rotated about the reference point by the entered angle.

    The Rotate Angle (Degrees) dialog
    The Rotate Angle (Degrees) dialog

Using Copy and Paste

In Draftsman, you can cut, copy and paste objects within or between Draftsman documents using the commands of the Edit main menu or standard shortcuts.

Note that the software does not use the Windows clipboard for normal copy operations in Draftsman documents. Instead, a separate internal clipboard is maintained for this document type. Also, the internal Draftsman clipboard is entirely independent of the internal clipboards used by any other editors in the software. You can only copy and paste between, or within, Draftsman documents.

Editing Multiple Objects

The Properties panel supports multiple object editing. Note that while it is not possible to make changes to different object types at the same time through the Properties panel, you can make simultaneous changes to multiple selected objects of the same type. Use standard Shift+click to multi-select - the panel will present the values for the last object added to the selection.

Format Painter

The Format Painter feature offers a simple and fast way to transfer an existing text style to other Draftsman text elements.

As demonstrated in the animation below, select an existing text element that has the style properties (as defined in the Properties panel) that you would like to propagate, and then choose the Format Painter tool from the Drawing Document Standard toolbar – or Edit » Format Painter from the main menu. This action effectively captures the style properties of the currently selected text.

Use the cursor, which changes to the Format Painter tool icon (), to locate and select other text elements that will adopt the style properties. Compatible text objects include editable text elements such as object Titles, Text items and Note items.

Text Search

The Draftsman editor allows you to quickly find specific text, or partial text, in accordance with defined search options. Choose the Edit » Find Text command from the main menus or use the Ctrl+F keyboard shortcut to access the Find Text dialog. Use this dialog to specify the existing text to find, along with scoping and additional options.

The Find text dialog
The Find text dialog

Text To find

  • Text To Find - use this field to enter the text string for which you want to search. Either enter the full word or search for a partial string. The latter requires the Whole Words Only option to be disabled. The string can contain the wildcard characters ? (single character) and * (any group of characters).

    Wildcards are always case insensitive.
    Each string searched will be added to the field's drop-down list for quick retrieval.

Scope

  • Sheet Scope - use this field to determine the scope of the text search in terms of the draftsman documents involved. Choose from the following options:
    • Current Page - search the current active page.
    • Entire Document - search across the entire draftsman document.
  • Selection - use this field to further constrain the scope of the search based on the current selection status of objects. Choose from the following options:
    • Selected Objects - limit the search to only those objects that are currently selected.
    • DeSelected Objects - limit the search to only those objects that are currently deselected.
    • All Objects - no limitation; search all objects irrespective of their selection status.
  • Identifiers - use this field to further constrain the scope of the search based on the type of text-based object. Choose from the following options:
    • All Identifiers - no limitation; search across all text-based objects (text strings, text frames, pins, net identifiers, and designators).
    • Texts - limit the search to only text.
    • Designators Only - limit the search to only component designators.

Options

  • Case sensistive - enable this option to perform a case-sensitive search, meaning the target text must match the case of the search text entered into the Text To Find field.
  • Whole Words Only - enable this option to restrict the search to whole words only. This means the search text must exist fully as is and not be part of a larger text string. For example, if this option is enabled, when looking for "cat", the software will not consider the first three letters of "category" - a valid search match. Disable this option to freely search for partial strings.

Where a search yields multiple matches, the Find text - Jump dialog opens. Use this dialog to jump between the matching search results.

The Find text - Jump dialog
The Find text - Jump dialog

  • Prev - click this button to browse to the previous matching text item. Click repeatedly to sequentially step back through the items.
  • Next - click this button to browse to the next matching text item. Click repeatedly to sequentially step forward through the items.

    As you step back and forth through the matching occurrences of found text, the upper region of the dialog will reflect the original search text and the current item being viewed in the workspace in terms of the type of object and its matching text.
  • Close - click this button to close the dialog.

Jump to another resulting occurrence of the searched text by:

  • Using the Previous and Next buttons in the Find Text - Jump dialog.
  • Using the Edit » Find Next command (through its F3 shortcut).

DXF Import

Draftsman provides further graphical options through the import of standard DXF files, which are loaded into the drawing space from the File » Import from DXF menu command. Use the Windows file browser to select a *.DXF or *.DWG file then configure the import options from the DXF Import Settings dialog that opens.

  • If you want to import into a specific sheet within a multi-sheet document, ensure that that sheet is the current sheet. This is done by clicking within the sheet - verify you have the right sheet, by using the information in the Status Bar.
  • Note that the DXF source graphic is interpreted using Draftsman’s standard graphical shape objects and each primitive object is therefore editable. The following object types are supported for import from a DXF file: ArcCircleLineRectangleRegionText.

DXF Export

Draftsman documents can be exported in .dxf format. This allows exporting Draftsman documents in a vectorial format.

Select the File » Export to Dxf command from the main menus and use the Save As dialog that opens to define the file name and location.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: