Mẫu linh kiện
Sơ lược
- Tìm hiểu cách thiết lập thư mục Workspace và các mục Mẫu linh kiện với quy tắc đặt tên, quản lý phiên bản và sơ đồ vòng đời phù hợp.
- Hiểu cách các mẫu kiểm soát tham số linh kiện, bao gồm các giá trị bắt buộc và giá trị mặc định chỉ đọc.
- Khám phá cách chỉnh sửa mẫu trực tiếp và lưu lại vào Workspace dưới dạng phiên bản mới.
Để giúp đơn giản hóa việc tạo linh kiện, Altium Designer, kết hợp với Workspace được kết nối của bạn, hỗ trợ tạo và định nghĩa Component Templates (các Mục mẫu linh kiện) trong Workspace đó. Tương tự như cách sử dụng mẫu sơ đồ nguyên lý để định sẵn thông tin trên các trang sơ đồ nguyên lý tham chiếu đến mẫu đó, mẫu linh kiện được một linh kiện thư viện Workspace tham chiếu và cung cấp các thiết lập định sẵn để sử dụng khi định nghĩa linh kiện đó.
Đặc biệt, các mẫu linh kiện được phát triển với trọng tâm là thông tin tham số, cho phép bạn định nghĩa tại một nơi duy nhất một tập hợp tham số sẽ được cung cấp cho linh kiện tham chiếu đến mẫu. Thông qua mẫu, bạn có thể kiểm soát tham số nào sẽ hiển thị, điền các giá trị mặc định và thậm chí đánh dấu những tham số bắt buộc phải có. Các bước kiểm tra xác thực được thực hiện khi lưu linh kiện để đảm bảo tuân thủ.
Các mẫu linh kiện này được tạo trực tiếp từ bên trong Workspace. Sau khi mẫu linh kiện được tạo (và dữ liệu được lưu vào một bản sửa đổi của mẫu), bạn có thể tái sử dụng mẫu để tạo một hoặc nhiều linh kiện.
Loại thư mục
Khi tạo thư mục để lưu trữ các mẫu linh kiện, bạn có thể chỉ định loại thư mục. Điều này không ảnh hưởng đến nội dung của thư mục – việc phát hành mẫu linh kiện luôn tạo ra một Mục mẫu linh kiện tương ứng. Loại thư mục chỉ cung cấp một dấu hiệu trực quan về nội dung được lưu trong thư mục và có thể hữu ích khi duyệt Workspace để tìm nội dung cụ thể. Để chỉ định thư mục dùng làm nơi chứa các mẫu linh kiện, hãy đặt Folder Type thành Component Templates khi định nghĩa các thuộc tính thư mục trong hộp thoại Edit Folder.

Việc chỉ định loại thư mục – mục đích sử dụng của thư mục – giúp nhận biết trực quan nội dung của thư mục đó khi duyệt Workspace.
Quy tắc đặt tên Mục
Một khía cạnh quan trọng khác của thư mục cha là Item Naming Scheme được áp dụng cho thư mục đó. Quy tắc này xác định định dạng mã định danh duy nhất cho mỗi Mục được tạo trong thư mục đó. Có sẵn một số quy tắc mẫu mặc định, sử dụng mã viết tắt cho loại thư mục (CTC – Bộ sưu tập mẫu linh kiện) hoặc loại nội dung (CMPT – Mẫu linh kiện):
-
$CONTENT_TYPE_CODE-001-{0000}– ví dụ:CMPT-001-0001. -
$CONTENT_TYPE_CODE-001-{A00}– ví dụ:CMPT-001-A01. -
$FOLDER_TYPE_CODE-001-{0000}– ví dụ:CTC-001-0001. -
$FOLDER_TYPE_CODE-001-{A000}– ví dụ:CTC-001-A001.
Khi sử dụng quy tắc đặt tên mặc định, phần mềm sẽ tự động gán mã định danh duy nhất khả dụng tiếp theo dựa trên quy tắc đó, sau khi quét toàn bộ Workspace và các mã định danh của nội dung hiện có. Điều này có thể tiết kiệm đáng kể thời gian khi tạo mẫu linh kiện theo cách thủ công.
Bạn cũng có thể định nghĩa quy tắc tùy chỉnh cho thư mục bằng cách nhập trực tiếp vào trường, đảm bảo phần biến được đặt trong dấu ngoặc nhọn (ví dụ: CMP-TMP-{0000}).

Quy tắc đặt tên Mục của thư mục cha được áp dụng cho mã định danh duy nhất của mỗi Mục được tạo trong thư mục đó.
Loại nội dung
Khi tạo Mục mẫu linh kiện đích để lưu trữ mẫu linh kiện, hãy đảm bảo Content Type của Mục được đặt thành Component Template trong hộp thoại Create New Item. Nếu bạn đang tạo Mục trong thư mục loại Component Templates, loại nội dung này sẽ có sẵn trong menu ngữ cảnh khi nhấp chuột phải để tạo Mục.

Tạo mẫu linh kiện trong thư mục Component Templates – Content Type phù hợp có sẵn trong menu ngữ cảnh.
Định nghĩa vòng đời và đặt tên bản sửa đổi của Mục
Related pages: Định nghĩa quy tắc đặt tên bản sửa đổi cho Workspace, Thiết lập các định nghĩa vòng đời cho Workspace
Khi định nghĩa mẫu linh kiện, hãy nhớ chỉ định loại quản lý vòng đời sẽ sử dụng cho mẫu linh kiện và quy tắc đặt tên áp dụng cho các bản sửa đổi của mẫu.
Việc kiểm soát loại nội dung nào có thể sử dụng một định nghĩa vòng đời hoặc quy tắc đặt tên bản sửa đổi cụ thể có thể được thiết lập và bật ở cấp toàn cục trong hộp thoại Content Types khi định nghĩa từng lược đồ. Các quy tắc mặc định được gán để sử dụng cho mẫu linh kiện lần lượt là: Generic Lifecycle và 1-Level Revision Scheme.
Chỉ định các quy tắc cần dùng trong hộp thoại Create New Item, sử dụng lần lượt các trường Lifecycle Definition và Revision Naming Scheme.

Chọn định nghĩa vòng đời và quy tắc đặt tên bản sửa đổi cho mẫu linh kiện được tạo thủ công.
Lưu mẫu linh kiện
Related page: Tạo & chỉnh sửa nội dung
Đến đây, chúng ta đã thảo luận về khả năng hỗ trợ mẫu linh kiện trong Workspace xét về các loại thư mục và nội dung liên quan. Việc lưu một mẫu linh kiện đã được định nghĩa vào một bản sửa đổi của Mục mẫu linh kiện như vậy có thể được thực hiện một cách đơn giản, hiệu quả.
Mẫu linh kiện có thể được chỉnh sửa và lưu vào bản sửa đổi đầu tiên của Mục mẫu linh kiện vừa tạo nhờ khả năng hỗ trợ chỉnh sửa trực tiếp của Workspace. Chỉnh sửa trực tiếp giúp bạn không còn bị ràng buộc bởi dữ liệu nguồn được quản lý phiên bản riêng biệt. Bạn chỉ cần chỉnh sửa loại nội dung được hỗ trợ bằng một trình chỉnh sửa tạm thời, trong đó dữ liệu nguồn mới nhất được tải trực tiếp từ chính Workspace. Sau khi chỉnh sửa xong, đối tượng được lưu (hoặc lưu lại) vào một bản sửa đổi dự kiến tiếp theo của Mục cha, rồi trình chỉnh sửa tạm thời được đóng lại. Không có tệp nào trên ổ cứng, không cần băn khoăn liệu bạn có đang làm việc với đúng dữ liệu nguồn hoặc dữ liệu nguồn mới nhất hay không, và cũng không cần duy trì phần mềm quản lý phiên bản riêng biệt. Workspace xử lý tất cả với tính toàn vẹn dữ liệu cao, đồng thời giúp đẩy nhanh đáng kể việc thay đổi dữ liệu của bạn.
Khi tạo một Mục mẫu linh kiện, bạn có thể chỉnh sửa và lưu mẫu linh kiện vào bản sửa đổi đầu tiên của Mục đó sau khi tạo. Để thực hiện, hãy bật tùy chọn Open for editing after creation ở cuối hộp thoại Create New Item (tùy chọn này được bật theo mặc định). Mục sẽ được tạo và Trình chỉnh sửa mẫu linh kiện tạm thời sẽ mở ra, hiển thị tài liệu .CMPT làm tài liệu đang hoạt động trong cửa sổ thiết kế chính. Tài liệu này sẽ được đặt tên theo Mục-Bản sửa đổi, với định dạng: <Item><Revision>.CMPT (ví dụ: CMPT-0001-1.CMPT).
Sử dụng tài liệu này để định nghĩa mẫu linh kiện theo yêu cầu. Để biết thêm thông tin về cách thực hiện, xem Định nghĩa mẫu.
Khi chỉnh sửa trực tiếp, có ba nút điều khiển liên quan, sẵn có từ Quick Access Bar (ở góc trên bên trái cửa sổ ứng dụng chính) hoặc từ thanh công cụ Component Template Standard:
-
– Save Active Document. Sử dụng nút này để lưu cục bộ mọi thay đổi đã thực hiện đối với tài liệu. Nhờ đó, bạn có thể lưu các thay đổi hiện tại nếu muốn quay lại sau để chỉnh sửa thêm trước khi lưu vào Workspace.
-
/
– Save to Server. Sử dụng nút này để lưu mẫu linh kiện đã định nghĩa vào Workspace, trong bản sửa đổi đầu tiên (đã lên kế hoạch) của Mục mẫu linh kiện đích. Hộp thoại Edit Revision sẽ xuất hiện, cho phép bạn thay đổi Tên, Mô tả và thêm ghi chú phát hành theo yêu cầu. Tài liệu và trình chỉnh sửa sẽ đóng sau khi lưu. Tài liệu chứa mẫu linh kiện nguồn, *.CMPT, sẽ được lưu trong bản sửa đổi của Mục. -
/
– Discard Local Changes. Sử dụng nút này nếu bạn muốn hủy chỉnh sửa và loại bỏ mọi thay đổi đã thực hiện. Tài liệu và trình chỉnh sửa sẽ đóng, đồng thời không có nội dung nào được phát hành vào Mục mẫu linh kiện đích.
Các nút điều khiển này cũng có sẵn dưới dạng lệnh – Save (Phím tắt: Ctrl+S), Save to Server (Phím tắt: Ctrl+Alt+S) và Discard Local Changes – từ menu chính File và menu chuột phải của mục mẫu linh kiện trong bảng Projects.
Dữ liệu được lưu trong Workspace bao gồm mẫu linh kiện nguồn, được định nghĩa trong tệp Mẫu linh kiện (<Item><Revision>.CMPT).
Kế thừa mẫu linh kiện
Bạn có thể sử dụng mẫu linh kiện từ loại linh kiện gốc nếu loại con chưa được liên kết với mẫu linh kiện nào. Khi xây dựng cấu trúc phân cấp các loại linh kiện, các loại linh kiện con sẽ kế thừa mẫu linh kiện được gán cho loại linh kiện gốc/cha.
Trình chỉnh sửa CMPT (Mẫu linh kiện)
Định nghĩa mẫu
Về cơ bản, Trình chỉnh sửa mẫu linh kiện được chia thành hai vùng chính, được minh họa trong hình dưới đây và tóm tắt ngay sau đó.
- Upper Region – để định nghĩa các tùy chọn ở cấp linh kiện (vòng đời, cách đặt tên và tùy chọn thư mục) cho linh kiện tham chiếu đến mẫu.
- Lower Region – để định nghĩa các tham số được sử dụng cho linh kiện tham chiếu đến mẫu.
Chỉ định các tùy chọn linh kiện
Nửa trên của trình chỉnh sửa dành cho việc định nghĩa các giá trị mặc định cho những thuộc tính linh kiện sau:
-
Lifecycle Definition – chọn định nghĩa vòng đời áp dụng cho linh kiện được tạo bằng mẫu. Trường danh sách thả xuống liệt kê tất cả các định nghĩa đã được thiết lập cho Workspace và được phép sử dụng cho linh kiện.
-
Revision Naming – chọn quy tắc đặt tên bản sửa đổi áp dụng cho linh kiện được tạo bằng mẫu. Trường danh sách thả xuống liệt kê tất cả các quy tắc đã được thiết lập cho Workspace và được phép sử dụng cho linh kiện.
-
Component Naming – sử dụng trường này để xác định quy tắc đặt tên Item mặc định cho linh kiện được tạo bằng mẫu, bảo đảm linh kiện được tạo ra có ID duy nhất trong Workspace. Nội dung nhập tại đây sẽ được dùng làm mẫu để tự động đặt tên linh kiện (trong trường Id tương ứng (khi sử dụng trình biên tập linh kiện ở chế độ Single Component Editing), hoặc trường Item ID (khi sử dụng trình biên tập linh kiện ở chế độ Batch Component Editing)). Phần mềm sẽ tự động gán ID duy nhất khả dụng tiếp theo dựa trên quy tắc đó, sau khi quét toàn bộ Workspace và mã định danh của nội dung hiện có. Một quy tắc đặt tên Item mặc định –
CMP-{00000}– được cung cấp sẵn, nhưng tất nhiên bạn có thể tạo quy tắc riêng bằng cách nhập vào trường này, bảo đảm phần biến đổi được đặt trong dấu ngoặc nhọn (ví dụ:CMP-001-{0000}). -
Default Folder – để chỉ định thư mục mặc định trong Workspace đích dùng để lưu linh kiện. Thực hiện bằng cách nhấp vào nút Choose để mở hộp thoại Choose Folder (một phiên bản của bảng Explorer), từ đó bạn có thể duyệt đến và chọn một thư mục hiện có trong Workspace hoặc tạo thư mục mới ngay tại chỗ.
Khi mẫu được tham chiếu, các mục được chỉ định trong vùng này sẽ được dùng để điền sẵn các trường tương ứng trong trình biên tập linh kiện (nếu có):
- Single Component Editing mode – các trường Id và Folder, trong khu vực Advanced Settings của vùng Component.
- Batch Component Editing mode – trên thẻ Document Options của hộp thoại Document Options và do đó cả các trường Item ID và FolderPath, trong khu vực Component của vùng định nghĩa linh kiện.

Khi mẫu được tham chiếu, các mục này được dùng để điền sẵn các trường tương ứng khi chỉnh sửa linh kiện trong trình biên tập linh kiện ở chế độ Single Component Editing (trái) và chế độ Batch Component Editing (phải).
Định nghĩa tham số
Nửa dưới của trình biên tập dành cho việc định nghĩa và quản lý các tham số sẽ được cung cấp cho linh kiện tham chiếu đến mẫu.
Các tham số hệ thống mặc định
Nhiều tham số hệ thống được đưa vào theo mặc định khi tạo mẫu linh kiện mới, như minh họa trong hình sau và được mô tả chi tiết bên dưới.
-
ComponentType– tham số này cho phép bạn chỉ định loại linh kiện. Điều này hỗ trợ tìm kiếm có mục tiêu thông qua chức năng tìm kiếm mạnh mẽ của Workspace – một chức năng không chỉ cho phép tìm kiếm theo loại linh kiện mà còn cho phép tìm kiếm thông minh hơn nhờ hỗ trợ các tham số linh kiện có nhận biết đơn vị. Khi duyệt các linh kiện trong Workspace của bạn bằng bảng Components, cách phân nhóm Categories cho các linh kiện được xác định từ các tham sốComponentTypegắn với từng linh kiện. Nhấp vào trường Default Value tương ứng, rồi nhấp vào nút
để mở hộp thoại Choose component type. Sử dụng hộp thoại này để chọn loại linh kiện cần thiết rồi nhấp vào OK – loại đã chọn sẽ được chèn làm giá trị cho tham số ComponentType trong bảng tham số chính.

Ví dụ về mẫu linh kiện, với tham số hệ thống ComponentType được đặt thànhDiodes. -
SCHLIBvàPCBLIB– hai tham số này cho phép bạn chỉ định lần lượt mô hình ký hiệu và mô hình footprint mặc định. Nhấp vào trường Default Value tương ứng của từng tham số, rồi nhấp vào nút
để mở hộp thoại cho phép chọn mô hình cần thiết.

Chỉ định các mô hình ký hiệu và footprint trong mẫu của bạn. -
NamevàDescription– hai tham số này cho phép bạn định nghĩa lần lượt tên và mô tả cho linh kiện. Nhập các chuỗi cần thiết vào trường Default Value tương ứng của từng tham số.
Thêm tham số người dùng mới
Để thêm một tham số người dùng mới vào danh sách, nhấp vào nút
(hoặc sử dụng lệnh Add từ menu ngữ cảnh khi nhấp chuột phải) – tham số sẽ được thêm vào cuối danh sách hiện tại.

Ví dụ về việc thêm một tham số người dùng mới vào mẫu.
Mỗi tham số được hiển thị trong danh sách dạng lưới với các thông tin sau:
-
Name – sử dụng trường này để đặt tên cho tham số, thường là một tên có ý nghĩa thể hiện mục đích của tham số. Khi mới được thêm vào, các tham số sẽ được gán tên mặc định (
Parameter,Parameter 1,Parameter 2, v.v.). -
Type – kiểu tham số. Ban đầu, mục này có giá trị mặc định là
Text, nhưng hệ thống hỗ trợ nhiều kiểu dữ liệu có nhận biết đơn vị, cũng như kiểuPCBLIB, cho phép định nghĩa nhiều footprint, vàHarnessWiring, cho phép định nghĩa linh kiện đấu dây bộ dây dẫn. Các kiểu tham số được định nghĩa bởi những từ điển có sẵn cũng được hỗ trợ – tìm hiểu thêm. -
Visible – bật tùy chọn này (đây là trạng thái mặc định đối với tham số mới được thêm) để bật tùy chọn Show tương ứng cho tham số khi chỉnh sửa một hoặc nhiều linh kiện trong Component Editor (được cấu hình ở chế độ Batch Component Editing). Qua đó, tùy chọn này kiểm soát việc hiển thị cột tương ứng với tham số đó ở vùng phía dưới của Component Editor, nơi định nghĩa các linh kiện. Thuộc tính này không có tác dụng khi định nghĩa linh kiện bằng chế độ Single Component Editing của trình biên tập.
-
Read Only – bật tùy chọn này để đặt tham số ở chế độ chỉ đọc. Khi chỉnh sửa linh kiện tham chiếu đến mẫu, giá trị của tham số sẽ không thể chỉnh sửa.
-
Required – bật tùy chọn này để đặt tham số thành 'tham số bắt buộc'. Khi chỉnh sửa linh kiện tham chiếu đến mẫu, tham số phải được gán giá trị; nếu không, sẽ không thể lưu linh kiện. Trong Component Editor, khi chưa nhập giá trị, tham số như vậy được nhận biết bằng ô giá trị có viền màu đỏ (ở chế độ Batch Component Editing) hoặc chứa biểu tượng
(ở chế độ Single Component Editing).
-
Default Value – sử dụng trường này để nhập giá trị mặc định cho tham số.
-
Description – thêm mô tả bất kỳ cho tham số, chẳng hạn như ghi chú ngắn gọn về thông tin mà tham số cung cấp. Nếu một tham số trong mẫu đã có mô tả, cột Description sẽ được hiển thị tương ứng trong vùng Parameters của Component Editor ở Single Component Editing.
Danh sách tham số cũng hỗ trợ các thao tác sao chép và dán đơn giản, cho phép bạn nhân bản một hoặc nhiều tham số người dùng hiện có. Các tham số được dán sẽ được thêm vào cuối danh sách.
Thứ tự và kích thước cột
Bạn có thể tùy chỉnh thứ tự các cột. Nhấp vào tiêu đề cột và kéo theo chiều ngang đến vị trí mới mong muốn. Các vị trí hợp lệ được đánh dấu bằng mũi tên định vị theo chiều dọc.
Sắp xếp
Có thể sắp xếp các tham số theo một cột cụ thể bằng cách nhấp vào tiêu đề cột đó. Nhấp một lần để sắp xếp theo thứ tự tăng dần (dựa trên nội dung của cột). Nhấp lần nữa để sắp xếp theo thứ tự giảm dần.
Bạn có thể sắp xếp theo nhiều cột. Khi các tham số đã được sắp xếp theo một cột cụ thể, hãy Shift+Click vào một cột khác để 'sắp xếp phụ' theo nội dung của cột đó.
Các kiểu dữ liệu tham số linh kiện có nhận biết đơn vị
Component Template Editor cho phép xác định rõ kiểu dữ liệu cho các tham số linh kiện được định nghĩa trong mẫu linh kiện (*.CMPT). Ngoài ra, các kiểu dữ liệu này có khả năng nhận biết đơn vị và hỗ trợ nhiều tiền tố đơn vị phổ biến. Nhờ đó, bạn có thể nhập giá trị tham số theo nhiều định dạng – chẳng hạn như 2.2k, 2k2, 4M, 2.5GHz – và Workspace được trang bị khả năng cần thiết để nhận biết giá trị số của các mục nhập đó.
Tính năng này của mẫu linh kiện hỗ trợ tìm kiếm có mục tiêu thông qua chức năng Tìm kiếm nâng cao của máy chủ – một chức năng không chỉ cho phép tìm kiếm theo loại linh kiện mà còn cho phép tìm kiếm thông minh hơn theo khoảng giá trị. Nhờ các tham số linh kiện có nhận biết đơn vị, bạn có thể nhanh chóng thiết lập tìm kiếm, chẳng hạn như tìm tất cả các tụ điện có điện dung từ 47uF đến 220uF.
Sử dụng các phần có thể thu gọn dưới đây để tìm hiểu thêm về các tham số có nhận biết đơn vị.
Các đơn vị được hỗ trợ
Các kiểu dữ liệu có nhận biết đơn vị sau đây được hỗ trợ khi định nghĩa tham số người dùng trong mẫu linh kiện:
-
Số nguyên
-
Số thập phân
-
Ampe (A)
-
Diện tích (mm2)
-
Bit
-
Candela (cd)
-
Độ C (C)
-
Decibel (dB)
-
Farad (F)
-
Gam (g)
-
Henry (H)
-
Hertz (Hz)
-
Jun (J)
-
Lumen (lm)
-
Mét (m)
-
Milimét (mm)
-
Ôm
-
Phần trăm (%)
-
Pascal (Pa)
-
Bar (bar)
-
Pound trên inch vuông (psi)
-
Vòng trên phút (rpm)
-
Giây (s)
-
Siemens (S)
-
Hệ số nhiệt độ (ppm/°C)
-
Tesla (T)
-
Vôn (V)
-
Oát (W)
Các tiền tố đơn vị được hỗ trợ
Bảng sau liệt kê các tiền tố đơn vị được hỗ trợ khi nhập giá trị cho kiểu tham số có nhận biết đơn vị.
| Tiền tố | Tên gọi | Giá trị (dạng khoa học) | Giá trị (dạng thông thường) |
|---|---|---|---|
| T | Tera | 1 x 1012 | 1,000,000,000,000 |
| G | Giga | 1 x 109 | 1,000,000,000 |
| M | Mega | 1 x 106 | 1,000,000 |
| k | kilo | 1 x 103 | 1,000 |
| m | milli | 1 x 10-3 | 1 / 1,000 |
| u | micro | 1 x 10-6 | 1 / 1,000,000 |
| n | nano | 1 x 10-9 | 1 / 1,000,000,000 |
| p | pico | 1 x 10-12 | 1 / 1,000,000,000,000 |
| f | femto | 1 x 10-15 | 1 / 1,000,000,000,000,000 |
Thêm tham số linh kiện có nhận biết đơn vị
Khi thêm tham số vào mẫu (nhấp vào
trong vùng Parameters), hãy sử dụng trường Type tương ứng để chọn kiểu dữ liệu có nhận biết đơn vị cần dùng từ danh sách thả xuống.

Chọn kiểu dữ liệu có nhận biết đơn vị được hỗ trợ cho tham số người dùng trong mẫu linh kiện. Trong ví dụ này, Ampere là kiểu tham số.
Khi nhập giá trị cho tham số linh kiện sử dụng kiểu dữ liệu có nhận biết đơn vị – dưới dạng Default Value trong mẫu linh kiện hoặc giá trị yêu cầu trong định nghĩa linh kiện – cần lưu ý những điều sau:
-
Bạn có thể nhập giá trị theo nhiều định dạng khác nhau:
-
Chỉ nhập giá trị số (ví dụ:
10). Lưu ý rằng nếu kiểu dữ liệu có đơn vị, đơn vị đó sẽ được áp dụng tự động. Với các kiểu có đơn vị, đơn vị được ghi trong ngoặc sau tên kiểu. -
Giá trị số ở dạng ký hiệu khoa học (ví dụ:
1e10,1E6). -
Giá trị số và đơn vị (ví dụ:
10F). -
Giá trị số kèm tiền tố (ví dụ:
10k). Đơn vị phù hợp sẽ được thêm tự động (nếu áp dụng). -
Giá trị số kèm tiền tố và đơn vị (ví dụ:
10kF). -
Giá trị số kèm tiền tố theo định dạng kỹ thuật thông dụng (ví dụ, đối với điện trở:
2k2,2K2,10r2,10R2). Giá trị sẽ tự động được chuẩn hóa tương ứng (ví dụ:2K2sẽ trở thành2.2k).
-
Chỉ nhập giá trị số (ví dụ:
-
Bạn có thể nhập tiền tố và/hoặc đơn vị có hoặc không có dấu cách sau giá trị số (ví dụ:
10uFhoặc10 uF). Dấu cách sẽ được tự động loại bỏ.
Xác thực dữ liệu
Khi sử dụng kiểu dữ liệu có nhận biết đơn vị cho tham số linh kiện, giá trị đã nhập sẽ được kiểm tra tính hợp lệ theo kiểu dữ liệu đã chỉ định. Điều này đảm bảo sử dụng đúng đơn vị đo cho kiểu dữ liệu đó. Ví dụ, tham số kiểu Celsius không thể có giá trị 10V!
Việc xác thực được thực hiện ở bất cứ nơi nào sử dụng tham số linh kiện có kiểu dữ liệu nhận biết đơn vị và cung cấp giá trị cho tham số đó:
- Khi xác định giá trị mặc định cho tham số trong mẫu linh kiện.
- Khi xác định giá trị cho tham số trong phần định nghĩa linh kiện ở trình chỉnh sửa linh kiện.
- Khi cấu hình tìm kiếm theo khoảng dựa trên giá trị tham số trong một cấu hình tìm kiếm đã lưu.

Ví dụ về việc xác thực dữ liệu trong trình chỉnh sửa mẫu linh kiện.
Các kiểu dữ liệu tham số được định nghĩa bằng từ điển
Từ điển là các kiểu tham số tùy chỉnh có một số giá trị được xác định sẵn. Từ điển được quản lý bởi quản trị viên Workspace trên trang Settings – Vault – Dictionaries của giao diện trình duyệt Workspace. Bạn có thể truy cập trang này từ trình chỉnh sửa mẫu linh kiện bằng cách chọn tùy chọn Add New Dictionary từ danh sách thả xuống Type hoặc nhấp vào điều khiển Manage Dictionaries ở góc trên bên phải vùng Parameters.

Truy cập trang quản lý từ điển trong giao diện trình duyệt Workspace từ trình chỉnh sửa mẫu linh kiện.
Các từ điển đã được định nghĩa có sẵn dưới dạng kiểu tham số trong danh sách thả xuống Type.

Chọn kiểu tham số được định nghĩa bằng từ điển trong danh sách thả xuống Kiểu.
Các giá trị được xác định cho kiểu do từ điển định nghĩa đã chọn có sẵn trong danh sách thả xuống Default Value. Chọn giá trị cần dùng làm giá trị mặc định của tham số hoặc chọn <None>.

Chọn một giá trị mặc định trong số các giá trị được xác định cho kiểu do từ điển định nghĩa đã chọn.
Định nghĩa nhiều footprint
Trình chỉnh sửa mẫu linh kiện cũng hỗ trợ định nghĩa nhiều footprint PCB trong một mẫu linh kiện. Bạn có thể chỉ định số lượng liên kết mô hình footprint tùy ý. Đây sẽ là tính năng hữu ích cho những người muốn tạo linh kiện tham chiếu đến 3 footprint, đáp ứng các yêu cầu IPC cho các mức mật độ khác nhau: L (ít nhất, hay lượng đồng tối thiểu), M (nhiều nhất, hay lượng đồng tối đa) và N (danh định, hay lượng đồng trung bình).
Để thêm một định nghĩa mô hình footprint vào mẫu, nhấp vào
để thêm tham số mới, sau đó chọn mục PCBLIB trong menu thả xuống của trường Type.

Chuyển tham số mới thêm thành định nghĩa mô hình footprint bằng cách đặt Type của tham số thành PCBLIB.

Ví dụ về một linh kiện được định nghĩa trong Trình chỉnh sửa linh kiện (chế độ Single Component Editing), sử dụng một Mẫu linh kiện được tham chiếu. Mẫu này có ba mô hình footprint được định nghĩa sẵn và được đưa vào định nghĩa linh kiện. Lưu ý rằng mục mô hình PCBLIB trong mẫu được dùng làm mô hình footprint mặc định (được nhận biết bằng biểu tượng ở góc trên bên trái) khi định nghĩa linh kiện. Di chuột lên hình ảnh để xem cùng linh kiện đó được định nghĩa bằng Trình chỉnh sửa linh kiện ở chế độ Batch Component Editing. Trong trường hợp này, footprint mặc định được gọi là PCBLIB (default).
Nhập và xuất mẫu linh kiện
Bạn có thể nhập tệp mẫu linh kiện hiện có (*.CMPT) hoặc tệp thư viện linh kiện (*.CMPLIB) vào trình chỉnh sửa mẫu linh kiện, đồng thời xuất mẫu linh kiện đang chỉnh sửa thành tệp mẫu linh kiện (*.CMPT). Sử dụng các lệnh File » Import » Component Template, File » Import » Component Library và File » Export trong menu chính của trình chỉnh sửa linh kiện để chọn thao tác mong muốn, rồi dùng hộp thoại Windows tiêu chuẩn mở ra để duyệt đến vị trí cần thiết và chọn tệp cần nhập hoặc đặt tên cho tệp sẽ xuất.
Tái sử dụng mẫu linh kiện
Bạn có thể sử dụng một bản sửa đổi của mẫu linh kiện – hay chính xác hơn là tham chiếu đến bản sửa đổi đó từ bản sửa đổi của linh kiện đang chỉnh sửa – theo những cách sau.
Khi tạo linh kiện mới
Khi tạo linh kiện mới bằng lệnh File » New » Component từ các menu chính, bạn có thể chọn mẫu trong hộp thoại Create new component.

Liên kết nhanh một mẫu linh kiện từ danh sách tất cả các mẫu có sẵn khi tạo linh kiện mới.
Thực hiện thủ công trong Trình chỉnh sửa linh kiện
Việc tái sử dụng một bản sửa đổi của mẫu linh kiện từ Trình chỉnh sửa linh kiện phụ thuộc vào chế độ hoạt động của trình chỉnh sửa.
Ở chế độ Chỉnh sửa từng linh kiện
Khi chỉnh sửa một linh kiện ở chế độ này của Trình chỉnh sửa linh kiện, hãy chọn Mẫu linh kiện cần dùng từ menu thả xuống của trường Template – thuộc nhóm Advanced Settings, trong vùng Component của trình chỉnh sửa. Tất cả các mẫu linh kiện hiện có trong cùng Workspace với linh kiện đều được liệt kê theo tên, kèm bản sửa đổi mới nhất trong dấu ngoặc đơn. Chọn mẫu cần dùng để áp dụng.

Liên kết nhanh một mẫu linh kiện từ menu chứa tất cả các mẫu có sẵn khi chỉnh sửa bản sửa đổi của linh kiện bằng Trình chỉnh sửa linh kiện ở chế độ Single Component Editing.
Ở chế độ Chỉnh sửa hàng loạt linh kiện
Có hai cách để liên kết một bản sửa đổi của Mẫu linh kiện với bản sửa đổi linh kiện đang chỉnh sửa:
-
Từ thẻ Template của hộp thoại Tùy chọn tài liệu (Edit » Document Options). Nhấp vào nút Choose ở bên phải trường Item Revision. Thao tác này mở hộp thoại Choose Item (một dạng của bảng Explorer). Sử dụng hộp thoại này để duyệt đến và chọn bản sửa đổi của mẫu linh kiện cần dùng. Sau khi nhấp vào OK, một liên kết sẽ được tạo giữa bản sửa đổi của linh kiện và bản sửa đổi đích của mẫu linh kiện. Bạn có thể thấy liên kết này khi quay lại thẻ Template của hộp thoại Document Options.

Liên kết thủ công một linh kiện với một bản sửa đổi của mẫu linh kiện trong Workspace đích. -
Từ menu Add tương ứng với vùng Required Models/Parameters của Trình biên tập linh kiện. Menu con Templates liệt kê theo tên tất cả các mẫu linh kiện hiện có trong cùng Workspace chứa linh kiện đó, với phiên bản sửa đổi mới nhất được ghi trong ngoặc. Nhấp vào một mục để tạo liên kết đến phiên bản sửa đổi mới nhất của mẫu linh kiện đó. Bạn cũng có thể kiểm tra liên kết trên thẻ Templates của hộp thoại Document Options.

Liên kết nhanh một mẫu linh kiện từ menu chứa tất cả các mẫu có sẵn.
Kế thừa từ thư mục Components trong Workspace
Bạn có thể chỉ định một mẫu linh kiện để tự động sử dụng cho tất cả các linh kiện (và các phiên bản sửa đổi của chúng) được lưu trong một thư mục Components thuộc Workspace.
Chỉ định mẫu cần dùng bằng trường Component Template khi xác định thuộc tính của thư mục trong hộp thoại Edit Folder. Danh sách thả xuống của trường này liệt kê theo tên tất cả các mẫu linh kiện hiện có trong cùng Workspace chứa thư mục Components đó, với phiên bản sửa đổi mới nhất được ghi trong ngoặc. Chọn một mục để tạo liên kết đến phiên bản sửa đổi mới nhất của mẫu linh kiện đó cho từng linh kiện được tạo sau này trong thư mục.

Chỉ định mẫu linh kiện mặc định để áp dụng cho tất cả các linh kiện được tạo trong thư mục Components mẹ.
Nếu một mẫu linh kiện được chọn ở cấp thư mục, mẫu đó cũng sẽ được sử dụng theo mặc định khi tạo linh kiện trong các thư mục con bên dưới. Điều này giúp tất cả các linh kiện trong thư mục con nhanh chóng kế thừa mẫu.
Ảnh hưởng đến mô hình và tham số linh kiện khi sử dụng mẫu linh kiện
Khi chỉnh sửa một phiên bản sửa đổi của linh kiện và liên kết/tham chiếu đến một phiên bản sửa đổi của mẫu linh kiện, những điều sau sẽ xảy ra trong Trình biên tập linh kiện đối với mô hình và tham số:
- Các mô hình được xác định trong mẫu được tham chiếu sẽ được thêm vào vùng Models (chế độ Single Component Editing) và vùng Model Links (chế độ Batch Component Editing).
- Mô hình được tham chiếu hiện có sẽ được giữ lại và linh kiện sẽ tiếp tục sử dụng mô hình đó trừ khi chủ động thay đổi thủ công.
-
Các tham số được xác định trong mẫu được tham chiếu sẽ được thêm vào vùng Parameters (chế độ Single Component Editing) và vùng Required Models/Parameters (chế độ Batch Component Editing).

Ví dụ về các tham số sau khi liên kết đến một phiên bản sửa đổi của mẫu linh kiện, khi sử dụng Trình biên tập linh kiện ở chế độ Single Component Editing (trái) và chế độ Batch Component Editing (phải). -
Chỉ trong chế độ Batch Component Editing, các tham số dựa trên mẫu được đặt để hiển thị sẽ được nhóm lại trong vùng định nghĩa linh kiện của trình biên tập, với
Template Parametersđược dùng làm tiêu đề.
Ví dụ về cách hiển thị các tham số dựa trên mẫu trong vùng định nghĩa linh kiện khi sử dụng Trình biên tập linh kiện ở chế độ Batch Component Editing. -
Các trường giá trị của tham số dựa trên mẫu được đánh dấu là chỉ đọc sẽ không thể chỉnh sửa. Với tất cả các tham số dựa trên mẫu khác không được đánh dấu là chỉ đọc, bạn có thể tự do thay đổi giá trị theo nhu cầu.
-
Nếu một tham số dựa trên mẫu được đánh dấu là bắt buộc nhưng chưa được gán giá trị trong mẫu, trường giá trị của tham số đó sẽ có viền đỏ (ở chế độ Batch Component Editing) hoặc chứa biểu tượng
(ở chế độ Single Component Editing), nhắc bạn rằng tham số này cần có giá trị. Bạn sẽ không thể lưu linh kiện vào Workspace cho đến khi tất cả các tham số bắt buộc đều được xác định giá trị.
Lưu lại mẫu linh kiện
Bất cứ lúc nào, bạn cũng có thể quay lại bất kỳ phiên bản sửa đổi nào của mẫu linh kiện trong Workspace và chỉnh sửa trực tiếp. Nhấp chuột phải vào phiên bản sửa đổi và chọn lệnh Edit từ menu ngữ cảnh. Trình biên tập tạm thời sẽ mở lại, đồng thời mở mẫu chứa trong phiên bản sửa đổi đó để chỉnh sửa. Thực hiện các thay đổi cần thiết, rồi lưu mẫu linh kiện vào phiên bản sửa đổi tiếp theo của mục.

Truy cập lệnh để bắt đầu chỉnh sửa trực tiếp một phiên bản sửa đổi hiện có của mẫu linh kiện.
Tải xuống dữ liệu đã lưu
Tải xuống dữ liệu được lưu trong một phiên bản sửa đổi của mẫu linh kiện bằng cách nhấp chuột phải vào phiên bản sửa đổi đó (trong bảng Explorer) và chọn lệnh Operations » Download từ menu ngữ cảnh. Tệp mẫu linh kiện sẽ được tải xuống một thư mục con nằm trong thư mục đã chọn, được đặt tên theo ID phiên bản sửa đổi của mục. Bạn có thể tìm thấy tệp trong thư mục Released bên trong đó.
Xóa mềm
Khi kết nối với Workspace, bạn có thể sử dụng chức năng linh hoạt để xóa mẫu linh kiện trực tiếp từ bảng Explorer trong Altium Designer. Nhấp chuột phải vào mục của mẫu linh kiện trong bảng và chọn lệnh Delete Item từ menu ngữ cảnh. Hộp thoại Delete Items sẽ xuất hiện để bạn xác nhận việc xóa. Thao tác này thực chất là “xóa mềm”, theo đó mẫu linh kiện sẽ được chuyển vào khu vực Trash của Workspace. Về cơ bản, Trash là thùng rác, nơi có thể chuyển bất kỳ nội dung nào trong Workspace vào (thông qua thao tác xóa mềm). Khu vực này được tách biệt với phần còn lại của Workspace.

Xóa mềm một mẫu linh kiện. Mẫu sẽ được chuyển vào khu vực Trash của Workspace.
Để tiếp tục xóa, hãy nhấp vào nút
. Mục sẽ bị xóa và hộp thoại Deletion Summary sẽ xác nhận việc xóa thành công. Nếu có sự cố khi xóa, bạn sẽ nhận được thông báo.
Tất cả nội dung bị xóa theo cách này đều có thể được tìm thấy trên trang Trash trong giao diện trình duyệt của Workspace. Lưu ý rằng bạn chỉ có thể xem nội dung do chính bạn xóa tạm thời. Quản trị viên có thể xem toàn bộ nội dung trên trang Trash – tức là tất cả nội dung đã bị xóa tạm thời.
Những điều cần lưu ý đối với mẫu linh kiện đã bị xóa tạm thời:
- Mẫu linh kiện sẽ không còn khả dụng trong phần mềm thiết kế hoặc giao diện Web.
- Tất cả những nơi đang sử dụng mẫu linh kiện này sẽ hiển thị thông tin cho biết mẫu linh kiện đã bị xóa.
- Bạn có thể khôi phục hoặc xóa vĩnh viễn mẫu linh kiện từ trang Trash, miễn là bạn có quyền chỉnh sửa. Chỉ có thể xóa vĩnh viễn khi mẫu không được một Mục cấp trên sử dụng.








).