Chuẩn bị tệp PDF 3D

Sơ lược

Chia sẻ chế độ xem 3D tương tác của thiết kế PCB với các nhà sản xuất, đơn vị lắp ráp và khách hàng bằng tính năng xuất PDF3D của Altium Designer. Bài viết này hướng dẫn cách tạo tệp PDF 3D, cấu hình nội dung và hình thức hiển thị của thiết kế, cũng như khám phá bo mạch đã xuất trong Adobe Acrobat Reader. Hãy đọc tiếp để tạo tệp PDF 3D phù hợp với những gì người xem cần thấy.

- Tìm hiểu cách truy cập tính năng xuất PDF3D và cấu hình hình học, bảng màu, góc nhìn ban đầu cùng các góc nhìn Key Frame đã lưu nếu cần.
- Hiểu cách nội dung thiết kế được đưa vào ảnh hưởng đến kích thước tệp và hiệu suất xem.
- Khám phá cách thanh công cụ 3D và Cây mô hình (Model Tree) của Acrobat Reader hỗ trợ điều hướng, tô sáng và kiểm soát việc hiển thị các linh kiện và mạng kết nối.
Tìm hiểu sâu hơn với AI:

Từ lâu, người dùng Altium Designer đã có thể xem tương tác các thiết kế PCB ở dạng 3D được kết xuất đầy đủ, qua đó có được cái nhìn sâu sắc về cấu trúc thực tế của thiết kế bo mạch, các linh kiện và những bộ phận cơ khí liên quan.

Việc mang khả năng 3D này đến những người ngoài nhóm thiết kế trực tiếp, chẳng hạn như các đơn vị chế tạo và lắp ráp, và đặc biệt là khách hàng, mang lại nhiều lợi ích đáng kể. Điều này được thực hiện thông qua tính năng xuất PDF 3D của Altium Designer. Bất kỳ ai có phiên bản gần đây của phần mềm Adobe® Acrobat® Reader phổ biến đều có thể truy cập định dạng 3D tương tác này.

Xem tương tác thiết kế 3D đã xuất trong Adobe Reader – thu phóng, xoay và chọn các phần tử thiết kế bạn muốn xem.
Xem tương tác thiết kế 3D đã xuất trong Adobe Reader – thu phóng, xoay và chọn các phần tử thiết kế bạn muốn xem.

Không giống như hình ảnh cố định của thiết kế bo mạch 3D chỉ thể hiện một góc nhìn cụ thể, định dạng PDF 3D được xuất về cơ bản tương đương với 3D Layout Mode tương tác của Altium Designer. Do đó, tệp PDF 3D được xuất cung cấp các khả năng xoay, thu phóng và dịch chuyển khung nhìn tương tự, cùng với các dấu trang đến từng linh kiện và mạng kết nối, đồng thời có thể áp dụng một trong nhiều bảng màu được định sẵn.

Để sử dụng tính năng xuất PDF 3D trong Altium Designer, bạn phải cài đặt tiện ích mở rộng phần mềm PDF3D Exporter. Tiện ích mở rộng này được cài đặt mặc định cùng với Altium Designer. Bạn có thể cài đặt hoặc gỡ bỏ tiện ích này theo cách thủ công.

Để biết thêm thông tin về cách quản lý tiện ích mở rộng, hãy tham khảo trang Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

3D trong Acrobat Reader

Khả năng xem 3D tương tác trong tệp PDF xuất hiện khi các tính năng xem 3D nâng cao được đưa vào Acrobat Reader, bắt đầu từ Phiên bản 7. Được cải tiến dần qua các phiên bản Acrobat Reader tiếp theo, mức độ chi tiết cao và các tùy chọn cấu hình do tính năng xuất PDF 3D của Altium Designer tạo ra tương thích với phiên bản 9 trở lên.

Nền tảng của khả năng 3D mới này là định dạng Universal 3D (U3D) dành cho các tệp đồ họa máy tính do ngành công nghiệp phát triển, được Hiệp hội các nhà sản xuất máy tính châu Âu (ECMA) chuẩn hóa thành Tiêu chuẩn ECMA-363 - Định dạng tệp 3D phổ quát. Định dạng PDF hỗ trợ U3D sẵn có, cho phép nhúng (và nén) dễ dàng nội dung này vào tệp PDF để xem 3D tương tác trong Acrobat Reader.

Kết quả là một định dạng tệp 3D đa nền tảng có kích thước vừa phải, không yêu cầu phần mềm xem 3D chuyên dụng. Đối với các tệp PDF 3D được xuất từ Altium Designer, nội dung nhúng bao gồm phần lớn dữ liệu có thể xem trong chế độ xem 3D của chính Altium Designer – gồm tất cả đường mạch, pad, via, vùng đa giác, v.v., toàn bộ linh kiện và đầy đủ các lớp của bo mạch.

Tạo tệp PDF

Để xuất tệp PDF 3D, hãy mở tài liệu thiết kế PCB mong muốn trong không gian thiết kế và chọn lệnh File » Export » PDF3D từ các menu chính (tệp PDF 3D sẽ được tạo ở định dạng 3D, bất kể chế độ xem hiện tại của Trình chỉnh sửa PCB là 2D hay 3D).

Khác với hình ảnh cố định của thiết kế bo mạch 3D ở một góc nhìn cụ thể, tệp PDF 3D mới được xuất về cơ bản tương đương với chế độ xem 3D tương tác của chính Altium Designer.

Do đó, tệp PDF 3D được xuất cung cấp các khả năng xoay, thu phóng và dịch chuyển khung nhìn tương tự, đồng thời có thể áp dụng bất kỳ bảng màu nào được xác định trong Cấu hình hiển thị đang hoạt động. Để kiểm tra hoặc chỉnh sửa cấu hình hiện tại, qua đó điều chỉnh các màu kết xuất có sẵn cho tệp PDF được xuất, hãy chuyển sang xem bo mạch ở dạng 3D (phím tắt: 3) và mở bảng View Configuration. Bạn có thể xem các màu kết xuất trong phần 3D Settings, trên thẻ View Options của bảng.

Bạn có thể truy cập nhanh thẻ View Options của bảng View Configuration bằng phím tắt Ctrl+D.

Tệp PDF 3D sẽ được tạo ở định dạng 3D, bất kể chế độ xem hiện tại của trình chỉnh sửa PCB là 2D hay 3D.

Các tùy chọn xuất

Sau khi bắt đầu xuất PDF 3D (File » Export » PDF3D) và chỉ định tên/vị trí tệp đích trong hộp thoại Export File tiêu chuẩn của Windows, hộp thoại Export 3D sẽ mở ra để bạn xác định cách kết xuất, hành vi và nội dung thiết kế được đưa vào tệp PDF.

Hộp thoại Export 3D cho phép bạn cấu hình cách hiển thị và hoạt động của tệp PDF được xuất.
Hộp thoại Export 3D cho phép bạn cấu hình cách hiển thị và hoạt động của tệp PDF được xuất.

Sử dụng hộp thoại Export 3D để cấu hình các tùy chọn xuất theo yêu cầu, sau đó nhấp vào nút Export để tạo tệp PDF 3D.

Các tệp 3D có thể có dung lượng lớn, ngay cả khi định dạng này vốn đã có khả năng nén dữ liệu, vì vậy hãy cân nhắc mức độ nội dung thiết kế cần thiết đối với người dùng mục tiêu. Ví dụ, nội dung của các lớp đồng (đường mạch, pad, v.v.) có thể không cần thiết đối với người đang xem xét các khía cạnh cơ khí của thiết kế bo mạch.

  • Lưu ý rằng Acrobat Reader cho phép người dùng bật/tắt hiển thị các phần tử của mô hình (theo nhóm hoặc riêng lẻ) để phù hợp với nhu cầu của mình – xem bên dưới.

  • Các khung hình chính được xác định trong tài liệu PCB có thể được tích hợp vào bản xuất PDF 3D bằng cách chọn tùy chọn Use 3D Movie views trong hộp thoại Export 3D. Các khung hình chính được xuất sang tài liệu PDF 3D sau đó sẽ có sẵn dưới dạng các chế độ xem có thể chọn trong Acrobat Reader.

Khi lựa chọn nội dung 3D cần đưa vào, bạn cũng nên cân nhắc khả năng kết xuất 3D của máy tính người xem. Mặc dù dung lượng tệp PDF 3D tạo ra có thể ở mức hợp lý, CPU và hệ thống đồ họa của máy tính đích vẫn có thể gặp khó khăn khi kết xuất mượt mà một thiết kế nhiều lớp phức tạp.

Các tùy chọn trên xác định những thiết lập ban đầu khi mở PDF trong Acrobat Reader và có thể dễ dàng thay đổi theo ý muốn từ thanh công cụ 3D của trình đọc. Lưu ý rằng nếu thanh công cụ bị vô hiệu hóa trong các tùy chọn xuất PDF 3D, người dùng sẽ không thể thay đổi chế độ xem.

Xem PDF 3D

Như bạn có thể hình dung, việc xem PDF 3D trong Acrobat Reader khá đơn giản, với các lệnh và menu được mở rộng một cách hợp lý từ những chức năng 2D quen thuộc.

Các đối tượng 3D có thể được di chuyển trong khung nhìn, thu phóng và xoay bằng các thao tác kéo chuột và cuộn con lăn đơn giản, với các chức năng được chọn từ thanh công cụ nổi 3D.

Thanh công cụ 3D của Acrobat cung cấp các điều khiển để điều hướng 3D và thiết lập ánh sáng/chế độ xem.
Thanh công cụ 3D của Acrobat cung cấp các điều khiển để điều hướng 3D và thiết lập ánh sáng/chế độ xem.

Một tính năng đặc biệt hữu ích trong trình đọc là ngăn điều hướng Model Tree, có thể mở (nếu chưa mở) bằng nút . Tính năng này cho phép người dùng duyệt qua tất cả các đối tượng trong PDF 3D, chọn và tô sáng những đối tượng quan tâm, đồng thời bật/tắt khả năng hiển thị của chúng.


Ngăn điều hướng Cây mô hình đặc biệt hữu ích
để điều khiển việc hiển thị các linh kiện và net cụ thể.

Ngăn điều hướng Model Tree cung cấp một phương thức mạnh mẽ để kiểm tra mọi khía cạnh của thiết kế 3D với độ chi tiết cao. Dù là xem xét kỹ vị trí và cách bố trí linh kiện hay kiểm tra chi tiết cấu trúc bên trong bo mạch, bạn đều có thể sử dụng cây điều hướng để tìm và hiển thị các đối tượng phù hợp.

Thiết kế được hiển thị khi đã bỏ chọn các linh kiện và các lớp in trên bo mạch, minh họa mức độ kiểm soát 3D có sẵn trong Acrobat Reader.
Thiết kế được hiển thị khi đã bỏ chọn các linh kiện và các lớp in trên bo mạch, minh họa mức độ kiểm soát 3D có sẵn trong Acrobat Reader.

Khi được chọn trong ngăn Model Tree, từng đối tượng sẽ được tô sáng trong cửa sổ xem bằng màu được xác định ở đầu ngăn (trong trường hợp này là màu đỏ). Điều này giúp dễ dàng xác định vị trí của một linh kiện hoặc net cụ thể mà không cần bật/tắt hiển thị đối tượng để tìm vị trí của nó. Tương tự, việc chọn một đối tượng trong cửa sổ xem 3D sẽ tô sáng mục tương ứng của đối tượng đó trong ngăn Model Tree.

Để biết thêm thông tin về cách sử dụng các điều khiển, chức năng và thiết lập khác nhau trong Acrobat Reader, hãy xem nội dung trợ giúp tương ứng của Adobe: Hiển thị mô hình 3D trong PDF.

Siêu dữ liệu thiết kế cơ bản từ Altium Designer cũng được đưa vào tài liệu PDF 3D đã xuất. Dữ liệu bao gồm tệp nguồn thiết kế, tác giả, phiên bản Altium Designer, ngày tạo/sửa đổi, v.v. Có thể xem thông tin này trong Adobe Reader tại thẻ Description trong hộp thoại Document Properties – File » Properties.

Xuất PDF 3D bằng OutJob

Để đưa tác vụ xuất tệp PDF 3D vào OutJob của dự án, nhấp vào Add New Documentation Output bên dưới mục Documentation Outputs, chọn PDF3D rồi chọn nguồn tài liệu mong muốn – một tài liệu PCB cụ thể để xuất (hoặc [PCB Document] để giữ cho OutJob có thể tái sử dụng chung).

Thêm trình tạo đầu ra PDF3D vào tệp Cấu hình tác vụ đầu ra.Thêm trình tạo đầu ra PDF3D vào tệp Cấu hình tác vụ đầu ra.

Có thể cấu hình trước các thiết lập tạo PDF 3D bằng cách chọn mục của trình tạo đầu ra, nhấp chuột phải rồi chọn Configure từ menu ngữ cảnh. Thao tác này mở hộp thoại cấu hình Export 3D (như đã trình bày trước đó).

Khi Tác vụ đầu ra được chạy hoặc được kích hoạt thủ công, tệp PDF 3D sẽ được xuất theo cấu hình trong phần Output Containers của OutJob. Đích xuất là Workspace và đường dẫn đã cấu hình, hoặc đích xuất bản cục bộ/từ xa được xác định trên trang Quản lý dữ liệu – Đích xuất bản của hộp thoại Preferences.

Tạo tệp PDF 3D vào vùng chứa đầu ra PDF đã xác định, từ bên trong một OutJob đã cấu hình.
Tạo tệp PDF 3D vào vùng chứa đầu ra PDF đã xác định, từ bên trong một OutJob đã cấu hình.

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nav
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents