Tạo Kết Nối Mạch Trong Sơ Đồ Nguyên Lý Của Bạn
Altium Essentials: Creating Hierarchy
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Sơ lược
- Tìm hiểu sự khác biệt giữa kết nối vật lý và kết nối logic, cũng như khi nào nên sử dụng từng phương thức trong sơ đồ nguyên lý.
- Xem những đối tượng sơ đồ nguyên lý nào tạo nên kết nối, bao gồm dây dẫn, nhãn net, cổng, cổng nguồn, bus và điểm kết nối trang.
- Hiểu cách Altium Designer hỗ trợ bạn kiểm tra và điều hướng các kết nối bằng Connectivity Insight cùng các công cụ chọn và tô sáng liên quan.
Chính các linh kiện và cách chúng kết nối với nhau tạo nên mạch điện tử độc đáo của bạn. Trên sơ đồ nguyên lý, bạn tạo biểu diễn logic cho thiết kế bằng cách nối các chân linh kiện với nhau; để thiết kế bo mạch in, bạn bố trí các linh kiện vật lý và tạo các kết nối tương ứng bằng cách đi dây.
Kết nối vật lý và kết nối logic
Trên sơ đồ nguyên lý, bạn có thể tạo kết nối bằng cách vẽ dây từ linh kiện này sang linh kiện khác — cách này được gọi là kết nối vật lý.
Bạn cũng có thể nối chân này với chân khác bằng cách đặt một đoạn dây ngắn và một nhãn net trên mỗi chân linh kiện. Phần mềm nhận diện hai đoạn net này và nối chúng thành một net duy nhất. Kiểu kết nối này được gọi là kết nối logic.
Kết nối vật lý cho phép người dùng lần theo từng dây khi nghiên cứu mạch, nhưng quá nhiều dây có thể khiến sơ đồ nguyên lý trở nên dày đặc và rối mắt. Ngược lại, nhãn net giúp giảm số lượng dây, nhưng người dùng phải rà soát trang sơ đồ để tìm tất cả các kết nối có thể có. Là người thiết kế, bạn có thể tự do quyết định mô hình kết nối phù hợp nhất với thiết kế của mình, kể cả kết hợp cả hai kỹ thuật.
Đặt dây để tạo kết nối vật lý hoặc sử dụng nhãn net để tạo kết nối logic.
Ngoài việc tạo kết nối logic within trong một trang sơ đồ nguyên lý, còn có các đối tượng để tạo kết nối logic between giữa các trang sơ đồ nguyên lý. Cách tạo kết nối này sẽ phụ thuộc vào cách bạn tổ chức sơ đồ nguyên lý: theo thiết kế phẳng hoặc thiết kế phân cấp. Nội dung này được trình bày chi tiết hơn ở bên dưới.

Có nhiều loại định danh net khác nhau có thể được sử dụng để kết nối giữa các trang.
Connectivity Insight
Chức năng Connectivity Insight của Altium Designer (thuộc tính năng Design Insight) hiển thị tức thời các mối quan hệ kết nối trong một dự án. Được trình bày dưới dạng cây tài liệu với tùy chọn xem trước sơ đồ nguyên lý, các phần tử có thể chọn giúp bạn điều hướng nhanh chóng và trực quan qua cấu trúc kết nối của dự án.
Ở thiết lập mặc định, tính năng Connectivity Insight hiển thị:
- Thông tin kết nối net liên quan khi con trỏ di chuột lên một đối tượng kết nối trên sơ đồ nguyên lý (dây, cổng, v.v.).
- Sơ đồ xem trước kết nối dạng cây khi sử dụng Alt+Double-click trên đối tượng.
Bổ sung cho khả năng này là một tính năng được truy cập bằng cách di chuột lên đối tượng thuộc một net tín hiệu, sau đó nhấn Ctrl+Alt. Thao tác này mở một chế độ xem dạng cây cho phép chọn. Nhấp vào trang mong muốn trong cây để chuyển nhanh đến tài liệu đó.
Bạn có thể bật/tắt tính năng này trên trang System - Design Insight của hộp thoại Preferences bằng cách chọn/bỏ chọn tùy chọn Mouse Hover cho mục Document Tree .
Các đối tượng dùng để tạo kết nối
Trình biên tập sơ đồ nguyên lý bao gồm các đối tượng sau dùng để tạo kết nối. Các đối tượng này được gọi chung là net identifiers.
| Định danh net | Chức năng |
|---|---|
| Bus | Dùng để gộp một tập hợp các net, ví dụ: Data[0..7]. Các net phải được đặt tên tuần tự theo một quy tắc đặt tên cụ thể (ví dụ: Data0, Data1,... Data7). Cách đặt tên này sau đó quyết định tên bus, ví dụ: Data[0..7]. |
| Điểm vào bus | Đối tượng đồ họa hỗ trợ tách hai net khác nhau từ hai phía đối diện của một đường bus mà không gây ngắn mạch giữa hai net. Không cần thiết trong các trường hợp khác. |
| Đầu nối ngoài trang | Dùng để kết nối một net từ trang sơ đồ nguyên lý này sang trang khác (không phải trong cùng một trang). Chỉ hỗ trợ kết nối ngang (thiết kế phẳng). Đầu nối ngoài trang có chức năng hạn chế hơn so với cổng. |
| Nhãn net | Một định danh net dùng để tạo kết nối với các nhãn net khác có cùng tên trên cùng một trang sơ đồ nguyên lý. Net được tự động đặt tên theo nhãn net. Có thể đặt nhãn net trên chân linh kiện, dây và bus. Lưu ý rằng nhãn net không kết nối giữa các trang trừ khi các tùy chọn dự án được cấu hình để sử dụng Net Identifier Scope là Global. |
| Chân | Chân được đặt trong trình biên tập ký hiệu sơ đồ nguyên lý để biểu diễn các chân vật lý trên linh kiện. Chỉ một đầu của chân có khả năng kết nối điện, đôi khi được gọi là đầu nóng của chân. |
| Cổng | Dùng để kết nối một net từ trang sơ đồ nguyên lý này sang trang khác. Kết nối có thể theo chiều dọc trong thiết kế phân cấp hoặc theo chiều ngang trong thiết kế phẳng (thiết kế theo chiều dọc và chiều ngang được giải thích bên dưới). Tên cổng được dùng để đặt tên net nếu tùy chọn Allow Ports to Name Nets được bật trong tab Tùy chọn của hộp thoại Project Options . Trong trường hợp này, các cổng cũng sẽ kết nối trong cùng một trang sơ đồ nguyên lý, nhưng không kết nối với các nhãn net có cùng tên (tìm hiểu thêm). |
| Cổng nguồn | Tạo kết nối với mọi cổng nguồn khác có cùng tên trong toàn bộ dự án sơ đồ nguyên lý, bất kể cấu trúc thiết kế. Net được tự động đặt tên theo cổng nguồn. Net này có thể được giới hạn trong một trang sơ đồ nguyên lý cụ thể nếu cần (tìm hiểu thêm). |
| Điểm vào trang | Được đặt bên trong một ký hiệu trang để tạo kết nối với cổng có cùng tên trên trang con của ký hiệu trang đó. Điểm vào trang được dùng làm tên net nếu tùy chọn Allow Sheet Entries to Name Nets được bật trong tab Options của hộp thoại Project Options . |
| Bó tín hiệu | Dùng để gộp tổ hợp bất kỳ gồm các net, bus và các bó tín hiệu cấp thấp hơn. |
| Dây | Một đối tượng thiết kế điện cơ bản dạng đường gấp khúc, được dùng để tạo kết nối điện giữa các điểm trên sơ đồ nguyên lý. Dây trên sơ đồ tương đương với dây dẫn vật lý. |
Nhãn net
Nhãn net xác định và kết nối điện các điểm khác nhau trong sơ đồ nguyên lý.
Tổng quan
Có thể tạo kết nối điện giữa các chân linh kiện trên sơ đồ nguyên lý bằng cách đặt dây nối giữa các chân đó. Đây được gọi là kết nối vật lý vì các chân được physically nối với nhau bằng dây. Cũng có thể tạo kết nối logic bằng cách sử dụng các định danh net phù hợp, chẳng hạn như nhãn net. Ngoài việc cung cấp một định danh dễ đọc cho net, nhãn net còn cho phép bạn kết nối các điểm trên mạch mà không cần thực sự đi dây nối chúng với nhau.
Khả năng sử dụng
Chỉ có thể đặt nhãn net trong Trình chỉnh sửa sơ đồ nguyên lý bằng các cách sau:
-
Chọn Place » Net Label từ các menu chính.
-
Nhấp vào nút Net Label trong danh sách thả xuống các đối tượng đồ họa trên Active Bar nằm ở phía trên không gian thiết kế. (Nhấp và giữ một nút Active Bar để truy cập các lệnh liên quan khác. Sau khi một lệnh được sử dụng, lệnh đó sẽ trở thành mục trên cùng trong phần tương ứng của Active Bar.)
-
Nhấp chuột phải trong không gian thiết kế rồi chọn Place » Net Label từ menu ngữ cảnh.
-
Nhấp vào nút
trên thanh công cụ Đi dây .
Đặt nhãn
Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ vào chế độ đặt nhãn net, với một nhãn net di chuyển theo con trỏ:
-
Nhấn Tab để mở chế độ Net Label của bảng Thuộc tính với trường Net Name được chọn và sẵn sàng chỉnh sửa; nhập tên net mới.
-
Định vị nhãn net sao cho góc dưới bên trái của nhãn chạm vào đối tượng mà bạn muốn gán nhãn, sau đó nhấp chuột hoặc nhấn Enter để đặt nhãn net.
-
Tiếp tục đặt các nhãn net khác, hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ đặt.
Các thao tác bổ sung có thể thực hiện trong khi đặt, khi nhãn net vẫn đang di chuyển theo con trỏ và trước khi điểm tâm của nhãn net được cố định, bao gồm:
- Nhấn phím Tab để tạm dừng thao tác đặt và truy cập chế độ Nhãn net của bảng Properties , nơi bạn có thể thay đổi ngay các thuộc tính của nhãn. Nhấp vào nút tạm dừng hiển thị đè trên không gian thiết kế để tiếp tục đặt.
- Nhấn phím X hoặc Y để lật nhãn net theo trục X hoặc trục Y.
- Nhấn Spacebar để xoay nhãn net ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Mỗi lần xoay một góc 90°.
Các điểm cần lưu ý khi đặt:
- Điểm kết nối điện của nhãn net nằm ở góc dưới bên trái, do đó góc này must chạm vào dây, bus hoặc bó tín hiệu để tạo kết nối hợp lệ.
- Nếu thuộc tính Net của nhãn net được nhập trước khi đặt và giá trị nhập kết thúc bằng số, mỗi nhãn net tiếp theo sẽ tự động tăng giá trị số này. Hành vi này được cấu hình trong các tùy chọn Auto-Increment During Placement trên trang Sơ đồ nguyên lý – Chung của hộp thoại Preferences. Đối với nhãn net, chỉ trường Primary được áp dụng; trường Secondary áp dụng khi đối tượng có nhiều trường, chẳng hạn như Chân.
Chỉnh sửa đồ họa
Có thể chỉnh sửa nhãn net bằng phương pháp đồ họa được gọi là chỉnh sửa in-place. Để chỉnh sửa trực tiếp chuỗi nhãn net tại chỗ, nhấp một lần để chọn, đợi một chút rồi nhấp lần thứ hai để vào chế độ chỉnh sửa.
![]() |
Nhấp một lần để chọn chuỗi. |
![]() |
Đợi một chút, sau đó nhấp lần thứ hai để vào chế độ chỉnh sửa tại chỗ. |
![]() |
Chuỗi đã được chọn, sẵn sàng để nhập chuỗi thay thế. |
Sau khi chỉnh sửa xong, nhấn Enter hoặc nhấp ra ngoài chuỗi để thoát chế độ chỉnh sửa tại chỗ.
Ghi chú
- Nhãn net tạo kết nối logic trong một trang sơ đồ nguyên lý; chúng không tạo kết nối giữa các trang sơ đồ nguyên lý. Để làm điều này, phải sử dụng Cổng.
-
Để biểu thị đảo logic cho nhãn net (thêm một gạch ngang phía trên), hãy sử dụng một trong các phương pháp sau:
-
Thêm một ký tự gạch chéo ngược sau mỗi ký tự trong tên net (ví dụ:
E\N\A\B\L\E). -
Bật tùy chọn Single '\' Negation trên trang Sơ đồ nguyên lý - Chỉnh sửa đồ họa của hộp thoại Preferences, sau đó thêm một ký tự gạch chéo ngược ở đầu tên net (ví dụ:
\ENABLE).
-
Thêm một ký tự gạch chéo ngược sau mỗi ký tự trong tên net (ví dụ:
- Khi các net riêng lẻ tạo thành một bus, có những yêu cầu cụ thể về cách đặt tên chúng. Để biết thêm thông tin, hãy tham khảo trang Bus.
-
Các định danh net khác loại không tự động kết nối với nhau ngay cả khi có cùng tên. Ví dụ: một nhãn net có tên
AGNDsẽ không tự động kết nối với cổng nguồn có tênAGND; phải đặt dây để nối chúng với nhau.
Thuộc tính nhãn net
Vị trí
-
(X/Y)
- X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của đối tượng, tính theo gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí X của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) - tọa độ Y (dọc) hiện tại của điểm tham chiếu của đối tượng, tính theo gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Rotation - sử dụng danh sách thả xuống để chọn góc xoay.
Thuộc tính
- Net Name - sử dụng danh sách thả xuống để chọn tên net hoặc nhập trực tiếp tên.
- Font - sử dụng các tùy chọn điều khiển để chọn phông chữ, cỡ chữ, màu sắc và các thuộc tính như in đậm, in nghiêng, v.v. nếu muốn.
- Justification - chọn cách căn chỉnh bằng cách nhấp vào mũi tên tương ứng với cách căn chỉnh mong muốn hoặc nhấp vào hình tròn để căn giữa.
Đầu nối ngoài trang
Đầu nối ngoài trang được dùng để tạo kết nối giữa các trang sơ đồ nguyên lý.
Tổng quan
Đầu nối ngoài trang là một đối tượng thiết kế điện cơ bản. Đầu nối ngoài trang được dùng để kết nối các net trên nhiều trang sơ đồ nguyên lý cùng thuộc một ký hiệu trang mẹ.
Khả năng truy cập
Chỉ có thể đặt đầu nối ngoài trang trong Trình chỉnh sửa sơ đồ nguyên lý bằng các cách sau:
-
Chọn Place » Off Sheet Connector từ các menu chính.
-
Tìm và sử dụng lệnh Off Sheet Connector trên Active Bar.
-
Nhấp chuột phải trong không gian thiết kế, sau đó chọn Place » Off Sheet Connector từ menu ngữ cảnh.
Đặt đối tượng
Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ vào chế độ đặt đầu nối ngoài trang, với một đầu nối ngoài trang bám theo con trỏ:
- Nhấn Tab để mở chế độ Đầu nối ngoài trang của bảng Properties với Net Name được chọn và sẵn sàng chỉnh sửa; nhập tên net mới.
- Định vị đầu nối ngoài trang sao cho điểm kết nối điện của nó (đầu nằm tại con trỏ) chạm vào dây dẫn bạn muốn kết nối, sau đó nhấp chuột hoặc nhấn Enter để đặt.
- Tiếp tục đặt các đầu nối ngoài trang khác hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ đặt.
Các thao tác bổ sung có thể thực hiện trong quá trình đặt khi đầu nối ngoài trang vẫn đang bám theo con trỏ:
- Nhấn phím Tab để tạm dừng việc đặt và truy cập chế độ Off Sheet Connector của bảng Properties , nơi bạn có thể thay đổi ngay các thuộc tính của đối tượng. Nhấp vào nút tạm dừng hiển thị trên vùng làm việc để tiếp tục đặt.
- Nhấn phím X hoặc Y để lật đầu nối ngoài trang theo trục X hoặc trục Y.
- Nhấn Spacebar để xoay đầu nối ngoài trang ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Mỗi lần xoay một góc 90°.
Chỉnh sửa đồ họa
Có thể chỉnh sửa đầu nối ngoài trang bằng phương pháp đồ họa thông qua cách chỉnh sửa được gọi là in-place. Để chỉnh sửa tại chỗ chuỗi văn bản của đầu nối ngoài trang, nhấp một lần để chọn, chờ một chút, rồi nhấp lần thứ hai để vào chế độ chỉnh sửa.
Nhấp một lần để chọn chuỗi văn bản.
Chờ một chút, rồi nhấp lần thứ hai để vào chế độ chỉnh sửa tại chỗ.
Chuỗi văn bản đã được chọn, sẵn sàng để nhập chuỗi thay thế.
Có thể chỉnh sửa Đầu nối ngoài trang tại chỗ.
Sau khi chỉnh sửa xong, nhấn Enter hoặc nhấp ra ngoài chuỗi văn bản để thoát chế độ chỉnh sửa tại chỗ.
Lưu ý
-
Cần nhớ rằng mặc dù đầu nối ngoài trang và ký hiệu trang được chia nhỏ có thể hữu ích trong một số trường hợp, chúng vẫn có những hạn chế. Chúng sẽ không tạo đúng các lớp linh kiện tự động và bạn cần tạo lại các lớp này thủ công trong PCB nếu chọn sử dụng chúng.
-
Để kết nối thành công một net cụ thể trên hai hoặc nhiều trang, các đầu nối ngoài trang trên mỗi trang phải được gán cho cùng một net.
-
Không thể áp dụng Tham chiếu chéo cổng cho đầu nối ngoài trang, vì vậy nên sử dụng Cổng bất cứ khi nào có thể.
Thuộc tính đầu nối ngoài trang
Vị trí
-
(X/Y)
- X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của đối tượng, tính từ gốc tọa độ hiện tại của vùng làm việc. Chỉnh sửa để thay đổi vị trí X của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ inch; hãy kèm theo đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) - Tọa độ Y (dọc) hiện tại của điểm tham chiếu của đối tượng, tính từ gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ inch; hãy kèm theo đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
-
Rotation - sử dụng danh sách thả xuống để chọn góc xoay. Các lựa chọn gồm:
0 Degrees,90 Degrees,180 Degreesvà270 Degrees.
Thuộc tính
-
Net Name - nhập tên net.
-
Cross Ref - trường này hiển thị các giá trị tham chiếu chéo được áp dụng cho đầu nối ngoài trang.
-
Style - sử dụng danh sách thả xuống để chọn giá trị mặc định từ các lựa chọn có sẵn:
LefthoặcRight. Nhấp vào ô màu để mở danh sách thả xuống, từ đó bạn có thể chọn màu mặc định.
Chung (Net)
Hiển thị các thuộc tính của các net được gán cho đầu nối ngoài trang. Cập nhật nếu cần.
Tham số (Net)
- Selection buttons - nhấp vào các đối tượng muốn hiển thị trong bảng.
- Add - sử dụng danh sách thả xuống để thêm (các) đối tượng mong muốn, sau đó xác định các giá trị.
Cổng nguồn
Tóm tắt
Cổng nguồn là một đối tượng cơ bản trong thiết kế điện. Đây là một đối tượng sơ đồ nguyên lý đặc biệt dùng để xác định net nguồn hoặc net nối đất. Cổng nguồn cho phép bạn dễ dàng chỉ định một net nguồn tại bất kỳ vị trí nào trong thiết kế, sau đó có thể kết nối net đó với các chân linh kiện hoặc dây dẫn. Các net nguồn có cùng tên tự động kết nối với nhau trong toàn bộ thiết kế, ngoại trừ hai trường hợp sau:
-
Nếu một cổng nguồn được nối dây trực tiếp với đối tượng Cổng trong thiết kế phân cấp (tức là trong thiết kế có Net Identifier Scope được đặt thành
Hierarchicalhoặc trong thiết kế có các điểm kết nối trang trên trang cấp cao nhất và Net Identifier Scope được đặt thànhAutomatic), thì net nguồn đó chỉ có phạm vi cục bộ trên trang mà nó được đặt – khi đó, các kết nối net ra ngoài trang phải được xác định bằng cách nối dây tổ hợp Cổng/Điểm kết nối trang (tìm hiểu thêm). -
Nếu Net Identifier Scope được đặt thành
Strict Hierarchical. Thiết lập này giới hạn tất cả các net nguồn trong phạm vi cục bộ của từng trang. Tìm hiểu thêm về Thiết lập phạm vi định danh net.
Khả năng truy cập
Có thể đặt cổng nguồn trong Trình chỉnh sửa sơ đồ nguyên lý theo các cách sau:
-
Nhấp vào Place » Power Port từ các menu chính.
-
Nhấp vào nút
trên thanh công cụ Wiring để đặt cổng nguồn kiểu thanh, được gán sẵn cho net VCC. -
Nhấp vào nút
trên thanh công cụ Wiring để đặt cổng nguồn kiểu nối đất nguồn, được gán sẵn cho net GND. -
Chọn một lệnh trong danh sách thả xuống cổng nguồn trong Active Bar.
-
Nhấp vào nút
trên thanh công cụ Utilities để mở danh sách thả xuống cung cấp nhiều lệnh cổng nguồn, bao gồm các kiểu khác nhau và một số cổng nguồn đã được gán sẵn net.
-
Nhấp chuột phải trong không gian thiết kế, sau đó chọn Place » Power Port từ menu ngữ cảnh.
Đặt đối tượng
Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ vào chế độ đặt cổng nguồn. Một ký hiệu cổng nguồn sẽ xuất hiện và di chuyển theo con trỏ.
- Định vị đối tượng rồi nhấp chuột hoặc nhấn Enter để đặt.
- Tiếp tục đặt các cổng nguồn khác hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ đặt.
Các thao tác bổ sung có thể thực hiện trong quá trình đặt, khi cổng nguồn vẫn đang di chuyển theo con trỏ, bao gồm:
- Nhấn phím Tab để tạm dừng việc đặt và truy cập chế độ Power Port của bảng Properties , nơi bạn có thể thay đổi ngay các thuộc tính của cổng nguồn. Nhấp vào nút tạm dừng hiển thị phủ trên không gian thiết kế để tiếp tục đặt.
- Nhấn phím Alt để giới hạn hướng di chuyển theo trục ngang hoặc trục dọc, tùy thuộc vào hướng di chuyển ban đầu.
- Nhấn Spacebar để xoay cổng nguồn ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Mỗi lần xoay là 90°.
- Nhấn phím X hoặc Y để lật đối xứng cổng nguồn theo trục X hoặc trục Y.
Chỉnh sửa bằng đồ họa
Phương pháp chỉnh sửa này cho phép bạn chọn trực tiếp một đối tượng cổng nguồn đã đặt trong không gian thiết kế, sau đó thay đổi vị trí của đối tượng bằng thao tác đồ họa. Cổng nguồn có kích thước và hình dạng cố định. Do đó, các điểm điều khiển chỉnh sửa sẽ không xuất hiện khi đối tượng cổng nguồn được chọn:
- Nhấp vào bất kỳ vị trí nào bên trong khung nét đứt rồi kéo để định vị lại cổng nguồn theo yêu cầu. Trong khi kéo, có thể xoay cổng nguồn (Spacebar/Shift+Spacebar) hoặc lật đối xứng (phím X hoặc Y để lật theo trục X hoặc trục Y).
-
Có thể chỉnh sửa trực tiếp net được gán cho đối tượng cổng nguồn bằng cách:
- Nhấp một lần vào cổng nguồn để chọn.
- Nhấp một lần nữa (hoặc nhấn Enter) để vào chế độ chỉnh sửa tại chỗ. Cần có khoảng thời gian đủ dài giữa hai lần nhấp để đảm bảo phần mềm không hiểu hai lần nhấp đơn là một lần nhấp đúp (thao tác này sẽ mở bảng Properties ).
- Để kết thúc chỉnh sửa văn bản tại chỗ, nhấn Enter hoặc dùng chuột nhấp ra ngoài cổng nguồn.
Kiểu cổng nguồn
Các kiểu đồ họa sau đây có sẵn cho cổng nguồn và có thể được thiết lập bằng cách chỉnh sửa thuộc tính Style của đối tượng trong bảng Properties .
|
Mũi tên |
|
Thanh ngang |
|
Hình tròn |
|
Nối đất |
|
Mũi tên GOST |
|
Thanh ngang GOST |
|
Nối đất GOST |
|
Mass nguồn GOST |
|
Mass nguồn |
|
Mass tín hiệu |
|
Dạng sóng |
Ghi chú
-
Để biểu thị trạng thái đảo của cổng nguồn (thêm một gạch ngang phía trên tên), hãy sử dụng một trong các phương pháp sau:
-
Thêm một ký tự gạch chéo ngược sau mỗi ký tự trong tên net (ví dụ:
V\C\C\3\). -
Bật tùy chọn Single '\' Negation trên trang Schematic - Graphical Editing của hộp thoại Preferences, sau đó thêm một ký tự gạch chéo ngược ở đầu tên net (ví dụ:
\VCC3).
-
-
Khi cập nhật tài liệu PCB từ sơ đồ nguyên lý, hệ thống sẽ đề xuất thêm quy tắc thiết kế Supply Nets cho mỗi net có chứa cổng nguồn.
Thuộc tính cổng nguồn
Vị trí
-
(X/Y)
- X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của đối tượng, tính theo gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí X của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) - tọa độ Y (dọc) hiện tại của điểm tham chiếu của đối tượng, tính theo gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Rotation - sử dụng danh sách thả xuống để chọn góc xoay.
Thuộc tính
-
Name - tên của cổng nguồn. Sử dụng biểu tượng con mắt để hiện/ẩn tên.
-
Style - sử dụng danh sách thả xuống để chọn kiểu của đối tượng nguồn. Hình xem trước sẽ cập nhật theo lựa chọn của bạn. Nhấp vào ô màu để chọn màu.
-
Font - sử dụng các điều khiển để chọn phông chữ, cỡ chữ, màu sắc và các thuộc tính in đậm, in nghiêng, v.v. theo ý muốn.
Thông tin chung (Net)
Hiển thị các thuộc tính của các net được gán cho cổng nguồn. Cập nhật khi cần.
Tham số (Net)
- Selection buttons - nhấp vào các đối tượng mong muốn để hiển thị trong bảng.
- Add - sử dụng danh sách thả xuống để thêm các đối tượng mong muốn, sau đó xác định các giá trị.
Dây nối
Dây nối được sử dụng để tạo kết nối điện trong sơ đồ nguyên lý.
Tổng quan
Dây nối là một đối tượng thiết kế điện cơ bản dạng đường gấp khúc, được sử dụng để tạo kết nối điện giữa các điểm trên sơ đồ nguyên lý. Nó tương đương với một dây dẫn vật lý.
Khả năng sử dụng
Chỉ có thể đặt dây nối trong Trình chỉnh sửa sơ đồ nguyên lý theo các cách sau:
- Chọn Place » Wire từ các menu chính.
- Nhấp vào nút Wire trong danh sách thả xuống trên Active Bar nằm ở phía trên cùng của không gian thiết kế. (Nhấp và giữ nút Active Bar để truy cập các lệnh liên quan khác. Khi một lệnh đã được sử dụng, lệnh đó sẽ trở thành mục trên cùng trong phần tương ứng của Active Bar).
-
Nhấp vào nút
trên thanh công cụ Wiring.
- Nhấp chuột phải trong không gian thiết kế rồi chọn lệnh Place » Wire từ menu ngữ cảnh.
- Sử dụng phím tắt Ctrl+W.
Đặt dây
Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ vào chế độ đặt dây. Thực hiện đặt dây theo trình tự thao tác sau:
- Nhấp chuột hoặc nhấn Enter để cố định điểm bắt đầu của dây nối.
- Đặt con trỏ rồi nhấp chuột hoặc nhấn Enter để cố định một chuỗi điểm đỉnh xác định hình dạng của dây.
- Sau khi đặt điểm đỉnh cuối cùng, nhấp chuột phải hoặc nhấn Esc để hoàn tất việc đặt dây.
- Tiếp tục đặt các đối tượng dây khác hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ đặt.
- Sử dụng phím Backspace hoặc Delete để xóa đoạn dây vừa đặt.
Các chế độ đặt
Khi đặt dây, có ba chế độ đặt “thủ công”, trong đó hai chế độ có các chế độ phụ Bắt đầu và Kết thúc. Chế độ đặt quy định cách tạo góc khi đặt dây và các góc có thể đặt dây. Trong khi đặt:
-
Nhấn Shift+Spacebar để chuyển lần lượt qua các chế độ.
-
Khi ở chế độ
90 Degreehoặc45 Degree(được gọi là các chế độ trực giao thực), nhấn Spacebar để chuyển đổi giữa các chế độ phụ Bắt đầu và Kết thúc. -
Trong khi đặt, chế độ đặt hiện tại được hiển thị trên thanh trạng thái. Bạn có thể thay đổi chế độ bất kỳ lúc nào trong quá trình đặt dây.
-
Ở các chế độ khác ngoài
Any Angle, đoạn dây gắn với con trỏ là đoạn look-ahead. Đoạn dây bạn thực sự đang đặt nằm trước đoạn xem trước này.
Đi dây có hướng dẫn
Sơ đồ nguyên lý có một lưới điện có thể cấu hình, giúp dễ dàng xác định các kết nối điện giữa các đối tượng. Trong khi đặt dây, khi dây nằm trong phạm vi lưới điện của một đối tượng điện khác, con trỏ sẽ bắt dính vào đối tượng cố định đó và một điểm kết nối (Hot Spot, dấu chữ thập màu xanh lam) sẽ xuất hiện.
Điểm kết nối hướng dẫn bạn đến vị trí có thể tạo kết nối hợp lệ và tự động bắt dính con trỏ vào các điểm kết nối điện.
Có thể thiết lập lưới điện trên thẻ General của bảng Properties ở chế độ Document Option. Bạn nên đặt lưới điện nhỏ hơn một chút so với lưới bắt dính hiện tại, nếu không sẽ khó đặt các đối tượng điện cách nhau một bước lưới bắt dính.
Chỉnh sửa bằng đồ họa
Phương pháp chỉnh sửa này cho phép bạn chọn trực tiếp một đối tượng dây đã đặt trong không gian thiết kế và thay đổi kích thước và/hoặc hình dạng của dây bằng thao tác đồ họa.
Khi chọn một đối tượng dây, các điểm điều khiển chỉnh sửa sau sẽ xuất hiện.
Một dây được chọn, sẵn sàng để chỉnh sửa bằng đồ họa.
- Nhấp và kéo A để định vị lại các điểm đầu cuối của dây.
- Nhấp và kéo B để di chuyển một đỉnh của dây. Các điểm đầu cuối sẽ vẫn được cố định.
- Nhấp và kéo trên một đoạn dây để grab đoạn đó và định vị lại. Các điểm đầu cuối và các đỉnh khác sẽ vẫn được cố định.
-
Nhấp chuột phải vào một điểm đỉnh rồi chọn lệnh Edit Wire Vertex n để mở hộp thoại Wire, trong đó mục của đỉnh
nthđã được chọn và sẵn sàng chỉnh sửa. Chỉnh sửa đỉnh và/hoặc các thuộc tính khác của dây theo nhu cầu. Tham khảo phần Thuộc tính dây để tìm hiểu thêm. - Nhấp và giữ một đỉnh rồi nhấn Delete trên bàn phím để xóa đỉnh đó.
Thông tin về thao tác kéo
- Trong khi kéo, các điểm kết nối được dùng để chỉ báo trực quan những vị trí sẽ tạo nút nối tự động.
- Các nút nối tự động không cần thiết/dư thừa sẽ được xóa sau khi kết thúc thao tác kéo.
Chỉ báo tạo nút nối tự động mới
Tùy thuộc vào phần dây bị ảnh hưởng, thao tác kéo có thể tạo các nút nối tự động ở những vị trí mới. Các điểm kết nối được dùng để chỉ báo trực quan vị trí của những nút nối mới này. Bật việc sử dụng các điểm kết nối này và thiết lập màu của chúng cho dây và bus trong vùng Auto-Junctions trên trang Schematic - Compiler của hộp thoại Preferences .
Chọn và xóa
Khi dây đã được chọn, nhấp vào một đoạn để chọn riêng đoạn đó. Thao tác “chọn con” này được phân biệt bằng việc các điểm điều khiển chỉnh sửa tương ứng chuyển sang màu đỏ.
Sau đó có thể chỉnh sửa trực tiếp các đỉnh tương ứng của đoạn dây bằng bảng SCH List và mọi thay đổi sẽ hiển thị ngay trên sơ đồ nguyên lý.
Bạn cũng có thể xóa các đoạn dây đã chọn bằng cách nhấn phím Delete . Bạn có thể xóa nhiều đoạn thuộc các dây khác nhau — hãy bảo đảm từng đoạn đều được chọn (Shift+Click hai lần trên mỗi đoạn tiếp theo để thêm đoạn đó vào tập hợp các đoạn được chọn). Các nút nối tự động cũng được tính đến — cho phép bạn chỉ xóa một đoạn dây đến nút nối đó (và xóa cả nút nối nếu sau đó chỉ còn hai đoạn dây khác nối với nút này).
Nút nối tự động
Một điểm nối chữ T trên dây dẫn được tự động kết nối bằng một nút nối (Nút nối do trình biên dịch tạo). Nếu tùy chọn Break Wires At Autojunctions được bật trên trang Sơ đồ nguyên lý - Chung của hộp thoại Preferences , một đoạn dây hiện có sẽ được chia thành hai tại vị trí chèn nút nối tự động. Ví dụ, khi tạo điểm nối chữ T, đoạn dây vuông góc sẽ được chia thành hai đoạn, mỗi đoạn ở một phía của nút nối. Khi tùy chọn Break Wires At Autojunctions bị tắt, đoạn dây sẽ không bị chia tại nút nối.
Thuộc tính dây dẫn
Chung (Net)
Hiển thị các thuộc tính của các net được gán cho dây dẫn.
Các đỉnh
- Width - sử dụng danh sách thả xuống để chọn độ rộng mong muốn. Nhấp vào ô màu để chọn màu mong muốn cho đối tượng.
-
Vertices Grid - liệt kê tất cả các điểm đỉnh hiện được xác định cho đối tượng theo:
- Index - chỉ số được gán cho đỉnh (không thể chỉnh sửa).
- X - tọa độ X (ngang) của đỉnh. Nhấp để chỉnh sửa.
- Y - tọa độ Y (dọc) của đỉnh. Nhấp để chỉnh sửa.
-
Add - nhấp để thêm điểm đỉnh mới. Đỉnh mới sẽ được thêm bên dưới mục đỉnh đang được chọn và ban đầu sẽ có cùng tọa độ X,Y với mục đó. Nhấp vào
để xóa đỉnh đang được chọn.
Tham số (Net)
- Selection buttons - nhấp vào các đối tượng muốn hiển thị trong bảng.
- Add - sử dụng danh sách thả xuống để thêm các đối tượng mong muốn, sau đó xác định các giá trị.
Nút nối do trình biên dịch tạo

Trình biên dịch sơ đồ nguyên lý tự động thêm nút nối tại mỗi điểm nối chữ T để hoàn tất kết nối điện.
Tóm tắt
Nút nối là một đối tượng thiết kế điện cơ bản. Đây là một đối tượng hình tròn nhỏ dùng để nối các dây dẫn (hoặc bus, hoặc bó tín hiệu) giao nhau trên trang sơ đồ nguyên lý. Nút nối do trình biên dịch tạo là nút nối được tính năng Tự động tạo nút nối đặt tự động khi hai dây dẫn/bus/bó tín hiệu được nối theo hình chữ T, hoặc khi một dây dẫn/bus/bó tín hiệu kết nối vuông góc với chân linh kiện, cổng nguồn hoặc đối tượng điện khác.
Khả năng sử dụng
Loại nút nối này được đặt tự động bởi tính năng Tự động tạo nút nối của Trình chỉnh sửa sơ đồ nguyên lý. Vì vậy, đây không phải là đối tượng thiết kế mà người dùng có thể truy cập và đặt.
Đặt đối tượng
Các nút nối do trình biên dịch tạo được đặt tự động mỗi khi xuất hiện điểm nối chữ T trong quá trình đi dây, chẳng hạn như 2 dây dẫn/bus/bó tín hiệu gặp nhau theo hình chữ T, hoặc một dây dẫn/bus/bó tín hiệu đi qua vuông góc với đầu chân linh kiện hay một đối tượng điện khác, chẳng hạn như Cổng nguồn.
Chỉnh sửa
Không thể chỉnh sửa nút nối do trình biên dịch tạo theo cách thông thường (thông qua hộp thoại hoặc thao tác đồ họa trên trang sơ đồ nguyên lý). Các thuộc tính hiển thị của nút nối do trình biên dịch tạo được cấu hình trên trang Schematic - Compiler của hộp thoại Preferences, như minh họa trong hình bên dưới. Lưu ý rằng việc tắt hiển thị các nút nối do trình biên dịch tạo không làm ngắt kết nối điện tại điểm nối đó.
Cấu hình các tùy chọn hiển thị cho nút nối do trình biên dịch tạo (nút nối tự động) trong hộp thoại Tùy chọn.
Chỉ báo tạo nút nối tự động mới
Tùy thuộc vào phần dây dẫn bị ảnh hưởng, thao tác kéo có thể tạo ra các nút nối tự động tại những vị trí mới. Các điểm đánh dấu được sử dụng để cung cấp phản hồi trực quan về vị trí của những nút nối mới này. Bạn cũng có thể bật các điểm đánh dấu này và chỉ định màu của chúng cho dây dẫn và bus trong phần tùy chọn.
Kiểm soát việc hiển thị các nút nối tự động dự kiến trong khi kéo.

Ví dụ minh họa các nút nối tự động mới dự kiến được tạo ra từ thao tác kéo.
Chỉ báo trực quan về thay đổi kết nối
Khi kéo một linh kiện, bạn có thể vô tình kéo hơi quá xa hoặc lệch hướng, dẫn đến việc tạo nút nối tự động ngoài ý muốn và có thể gây ra thay đổi nghiêm trọng đối với kết nối của mạch. Để cung cấp chỉ báo đồ họa kịp thời về trạng thái kết nối trong khi kéo, hai biểu tượng được sử dụng:
- OK - thao tác kéo không làm thay đổi kết nối của mạch.
- Alert - thao tác kéo đang làm thay đổi kết nối của mạch.
Biểu tượng tương ứng được hiển thị gần con trỏ trong khi bạn kéo.

Cung cấp cảnh báo trực quan rằng thao tác kéo sẽ làm thay đổi kết nối.
Chuyển đổi nút nối chữ thập
Bạn có thể nhanh chóng chuyển đổi một nút nối 4 nhánh (được tạo bằng các đối tượng dây dẫn hoặc bus) thành hai nút nối 3 nhánh liền kề. Để thực hiện, chọn lệnh Tools » Convert » Convert Cross Junctions từ các menu chính. Sau khi khởi chạy lệnh, hộp thoại Junctions Conversion sẽ xuất hiện. Sử dụng hộp thoại này để xác định phạm vi chuyển đổi (tài liệu hiện tại, các tài liệu của dự án hoặc tất cả tài liệu sơ đồ nguyên lý đang mở), đồng thời xác định xem sẽ xét tất cả các vị trí có thể tạo nút nối 4 nhánh hay chỉ những vị trí liên quan đến dây dẫn/bus được chọn trong các tài liệu đích. Sau khi cấu hình các tùy chọn chuyển đổi theo ý muốn, nhấp vào OK trong hộp thoại để thực hiện chuyển đổi.

Hộp thoại Chuyển đổi điểm nối
Các tùy chọn/điều khiển trong hộp thoại Chuyển đổi điểm nối
Phạm vi
-
Sheet Scope - chọn một trong các tùy chọn sau để xác định phạm vi cập nhật:
- Current Document - chỉ cập nhật tài liệu sơ đồ nguyên lý đang hoạt động theo các thay đổi của mẫu hiện tại.
- Project Documents - cập nhật tài liệu sơ đồ nguyên lý đang hoạt động cũng như tất cả các tài liệu sơ đồ nguyên lý khác trong dự án đang hoạt động theo các thay đổi của mẫu hiện tại tương ứng. Các sơ đồ nguyên lý hiện đang đóng sẽ được mở.
- Open Documents - cập nhật tài liệu sơ đồ nguyên lý đang hoạt động cũng như tất cả các tài liệu sơ đồ nguyên lý khác đang mở (bất kể thuộc dự án nào) theo các thay đổi của mẫu hiện tại tương ứng.
-
Selection - sử dụng danh sách thả xuống để chọn các đối tượng mong muốn trong phạm vi:
- Selected Objects - chỉ chọn những đối tượng đang được chọn trên (các) trang đã chọn từ Sheet Scope.
- All Objects - chọn tất cả các đối tượng trên (các) trang đã chọn từ Sheet Scope.
Tùy chọn
- Miter Size - nhập giá trị để xác định kích thước phần vát góc.
Cấu trúc thiết kế ảnh hưởng đến kết nối như thế nào
Related page: Thiết kế nhiều trang & phân cấp
Nếu thiết kế không vừa trên một trang sơ đồ nguyên lý, có thể chia thiết kế ra nhiều trang. Có hai mô hình riêng biệt để tổ chức và tạo kết nối trong sơ đồ nguyên lý nhiều trang: thiết kế phẳng, có thể hình dung như một trang sơ đồ nguyên lý lớn được chia thành nhiều trang nhỏ hơn; hoặc thiết kế phân cấp, trong đó các trang được liên kết theo cấu trúc kiểu ông bà-cha mẹ-con.
Thiết kế nhiều trang được triển khai bằng cách đặt một Ký hiệu trang trên trang cha để đại diện và liên kết đến trang con, như minh họa trong hình bên dưới.

Các Ký hiệu trang đại diện (và liên kết đến) các trang ở cấp thấp hơn. Trong thiết kế phẳng, cấu trúc này chỉ có thể sâu một cấp; trong thiết kế phân cấp, độ sâu không bị giới hạn.
Thiết kế phẳng
Related page: Thiết kế nhiều trang & phân cấp
Một thiết kế được gọi là thiết kế phẳng khi kết nối được tạo trực tiếp từ trang này sang trang khác. Kết nối không đi qua các Ký hiệu trang trên trang cha. Trong thiết kế phẳng, các ký hiệu trang chỉ đơn giản là đại diện (và tham chiếu) đến các trang con. Tất cả các trang trong thiết kế đều xuất hiện ở cùng một cấp trong bảng Projects vì không có sự phân cấp. Cả hai hình bên dưới đều minh họa thiết kế phẳng.
Thiết kế phẳng dễ tạo hơn. Thiết kế phẳng có thể bao gồm một trang cấp cao nhất với một Ký hiệu trang cho mỗi trang con, nhưng điều này không bắt buộc vì trang cấp cao nhất này không được dùng để tạo kết nối giữa các trang. Với một thiết kế nhỏ chỉ có hai hoặc ba trang sơ đồ nguyên lý, bạn có thể thấy rằng trang cấp cao nhất không mang lại giá trị bổ sung. Khi số lượng trang tăng lên, trang cấp cao nhất có thể giúp người đọc hiểu chức năng của thiết kế mạch thông qua cách bố trí các khối logic (Ký hiệu trang) trên trang.

Cùng một thiết kế, được hiển thị không có trang cấp cao nhất (trái) và có trang cấp cao nhất (phải) - cả hai đều là ví dụ về thiết kế phẳng.
Trong thiết kế phẳng, các kết nối giữa các trang có thể được tạo bằng Cổng, Đầu nối ngoài trang, Cổng nguồn và Nhãn net, như minh họa trong phần kính lúp ở hình trên. Cách làm được khuyến nghị là sử dụng Nhãn net within mỗi trang và Cổng để kết nối between các trang. Cổng cung cấp nhiều tính năng hơn Đầu nối ngoài trang, bao gồm khả năng thêm Tham chiếu chéo cổng, giúp thêm một SheetName[GridReference] vào mỗi cổng để tham chiếu đến cổng tương ứng trên trang khác, như minh họa trong hình bên dưới.
Không có giới hạn về số lượng trang trong thiết kế phẳng.

Tham chiếu chéo cổng đã được thêm bên cạnh mỗi Cổng để chỉ ra trang đích và tọa độ lưới của Cổng tương ứng.
Thiết kế phân cấp
Main page: Thiết kế nhiều trang & phân cấp
Một thiết kế được gọi là phân cấp khi kết nối giữa các trang đi từ một Ký hiệu trang xuống trang con được Ký hiệu trang đó tham chiếu. Ở cấp net, kết nối được tạo giữa một Điểm vào trang trong Ký hiệu trang đó và một Cổng có cùng tên với điểm vào trang trên trang con. Kiểu kết nối này còn được gọi là kết nối dọc vì kết nối giữa các trang chỉ được tạo theo chiều lên và xuống giữa trang cha và trang con của nó.

Trong thiết kế phân cấp, kết nối ở cấp net đi từ một Điểm vào trang trên trang cha xuống một Cổng tương ứng trên trang con.
Thiết kế phân cấp có hai ưu điểm chính.
- Ưu điểm thứ nhất là khả năng thể hiện chức năng của thiết kế cho người đọc thông qua cách các trang sơ đồ nguyên lý được tổ chức và trình bày dưới dạng các khối logic (Ký hiệu trang). Sơ đồ nguyên lý cấp cao nhất trình bày thiết kế dưới dạng một tập hợp các khối chức năng cấp cao với cách bố trí phản ánh vị trí của chúng trong luồng tín hiệu truyền thống từ trái sang phải, từ đầu vào đến đầu ra của toàn bộ mạch. Nếu cần, các khối này có thể được chia tiếp thành các khối nhỏ hơn, cho phép các sơ đồ nguyên lý ở cấp thấp nhất chứa linh kiện có cấu trúc tương đối đơn giản với số lượng linh kiện ít. Vì mỗi trang tương đối đơn giản, kích thước trang có thể được giữ nhỏ, đây là một lợi thế lớn khi in sơ đồ nguyên lý.
- Một ưu điểm lớn khác là việc lần theo tín hiệu trong thiết kế phân cấp thường dễ dàng hơn nhiều, vì người đọc chỉ cần đối chiếu một Sheet Entry trên trang sơ đồ cha với Port tương ứng trên trang sơ đồ con, rồi lần theo tín hiệu dọc theo các đường dây trong từng trang.
Việc xây dựng một thiết kế phân cấp đòi hỏi thêm một số công đoạn. Các Sheet Symbol cần có Sheet Entry và trang sơ đồ trên cùng phải được nối dây để truyền tín hiệu từ Sheet Symbol này sang Sheet Symbol khác. Phần mềm có công cụ giúp đồng bộ Sheet Entry với Port trên trang sơ đồ con (Design » Synchronize Sheet Entries and Ports cho tất cả Sheet Symbol, hoặc nhấp chuột phải vào một Sheet Symbol rồi chọn Sheet Symbol Actions » Synchronize Sheet Entries and Ports cho riêng Sheet Symbol đó). Phần mềm cũng có các công cụ giúp chia một thiết kế lớn thành các phần nhỏ (Edit » Refactor » Move Selected Subcircuit to Different Sheet). Để tìm hiểu thêm về các công cụ tái cấu trúc này, hãy tham khảo trang Tái cấu trúc thiết kế.
Thiết kế phân cấp có thể có số cấp bất kỳ và bao gồm số lượng trang sơ đồ nguyên lý bất kỳ.
Thiết kế đa kênh
Main article: Tạo thiết kế đa kênh
Việc một thiết kế điện tử có các khối mạch lặp lại là điều khá phổ biến. Đó có thể là bộ khuếch đại stereo hoặc bàn trộn âm thanh 64 kênh. Kiểu thiết kế này được hỗ trợ đầy đủ bởi một bộ tính năng có tên là multi-channel design. Trong thiết kế đa kênh, bạn chỉ cần vẽ khối mạch lặp lại một lần, sau đó yêu cầu phần mềm lặp lại khối mạch đó bằng cách đặt nhiều Sheet Symbol cùng tham chiếu đến một sơ đồ nguyên lý con, hoặc cấu hình một Sheet Symbol duy nhất để lặp lại sơ đồ nguyên lý con được tham chiếu theo số lần cần thiết. Thiết kế sau khi biên dịch được triển khai trong bộ nhớ máy tính, với toàn bộ linh kiện và kết nối được lặp lại theo số lần yêu cầu, tuân theo quy tắc đặt tên do người dùng xác định.

Ở bên trái là bốn Sheet Symbol cùng tham chiếu đến một trang sơ đồ con (PortIO.SchDoc). Ở bên phải, InputChannel.SchDoc được lặp lại tám lần bằng từ khóa Repeat .
Thiết kế logic mà bạn vẽ thực tế không bao giờ bị làm phẳng; nó luôn được giữ dưới dạng sơ đồ nguyên lý đa kênh. Khi bạn chuyển thiết kế sang bố trí PCB, các linh kiện và net vật lý được nhân bản theo số lần yêu cầu, đồng thời bạn có thể sử dụng đầy đủ các công cụ dò chéo và chọn chéo khi Làm việc giữa sơ đồ nguyên lý và bo mạch. Trình chỉnh sửa PCB cũng có công cụ sao chép cách bố trí và đi dây của một kênh sang tất cả các kênh khác, cho phép dễ dàng di chuyển và đổi hướng toàn bộ một kênh. Tham khảo tài liệu thiết kế đa kênh để tìm hiểu thêm về thiết kế đa kênh.
Thiết kế đa kênh phải có cấu trúc phân cấp vì phần mềm sử dụng mô hình cấu trúc này để tạo các thực thể kênh trong bộ nhớ.
Thiết lập phạm vi định danh net
Dialog page: Tùy chọn cho dự án
Phần mềm sử dụng thiết lập hiện tại của Net Identifier Scope để xác định cách tạo kết nối giữa các trang sơ đồ nguyên lý. Net Identifier Scope được cấu hình trong thẻ Tùy chọn của hộp thoại Project Options (Project » Project Options).

Chọn chế độ Net Identifier Scope phù hợp với cấu trúc thiết kế của bạn.
Cách hoạt động của các tùy chọn Global, Flat và Hierarchical được minh họa trong các hình bên dưới.

Các ví dụ đơn giản về cách tạo kết nối trong từng chế độ chính: Toàn cục, Phẳng, Phân cấp.
Ngoài ba tùy chọn nêu trên, còn có tùy chọn Automatic. Nhìn chung, tốt nhất nên để Net Identifier Scope ở giá trị Automatic. Phần mềm sẽ chọn tùy chọn phù hợp nhất trong ba tùy chọn dựa trên cấu trúc các trang và việc có hay không có Port và Sheet Entry.
Khi được đặt thành Automatic, phần mềm tự động chọn một trong ba chế độ định danh net chính dựa trên các tiêu chí sau:
-
Nếu có Sheet Entry trên trang trên cùng, chế độ
Hierarchicalsẽ được sử dụng. -
Nếu không có Sheet Entry nhưng có Port, chế độ
Flatsẽ được sử dụng. -
Nếu không có Sheet Entry và cũng không có Port, chế độ
Globalsẽ được sử dụng.
Cách đặt tên net
Mỗi khi đặt một đường dây giữa các chân linh kiện, bạn đang tạo kết nối. Mỗi net trong thiết kế đều được gán một tên. Nếu bạn chưa đặt định danh net có thể dùng để đặt tên cho net, phần mềm sẽ đặt tên net đó dựa trên một trong các chân thuộc net, ví dụ, NetR7_1 như minh họa trong hình bên dưới. Nếu ký hiệu định danh linh kiện thay đổi ở một thời điểm nào đó, tên net do hệ thống tạo cũng sẽ thay đổi, và các thay đổi này phải được cập nhật giữa sơ đồ nguyên lý và PCB để duy trì sự đồng bộ.

Các net không có định danh net sẽ được gán tên do hệ thống tạo dựa trên một trong các chân thuộc net đó.
Nhiều định danh net trên cùng một net
Bạn không thể đặt nhiều nhãn net có tên khác nhau trên cùng một net trong một trang sơ đồ nguyên lý. Tình huống này sẽ được phát hiện và đánh dấu là lỗi trong quá trình xác thực. Tuy nhiên, việc sử dụng nhiều định danh net cho cùng một net trên các trang khác nhau có net đó là hợp lệ.
Khả năng này cho phép bạn:
- Thay đổi tên của một net ở các cấp khác nhau trong cấu trúc phân cấp để phản ánh rõ hơn chức năng của net trên trang đó.
- Tái sử dụng một trang sơ đồ nguyên lý con mà không cần đổi tên các net trên trang.
Các tùy chọn kiểm soát cách đặt tên net
Dialog page: Tùy chọn dự án
Cuối cùng, mỗi net chỉ có thể có một tên trên PCB (một net trên PCB không thể có hai tên trừ khi bạn chủ ý nối hai net bằng một Net Tie). Phần mềm tự động xử lý các net có nhiều tên để mỗi net chỉ có một tên duy nhất trong dự án, nhưng đó có thể không phải là tên bạn mong muốn. Có một số tùy chọn để kiểm soát cách chọn tên trong phần Netlist Options trên tab Options của hộp thoại Project Options. Tham khảo trang hộp thoại Tùy chọn dự án để biết thêm chi tiết về từng tùy chọn.
Một cách thiết lập hợp lý là bật các tùy chọn Allow Ports to Name Nets và Higher Level Names Take Priority. Kết hợp các tùy chọn này với việc sử dụng nhãn net một cách hợp lý cho các net quan trọng trên mỗi trang để đảm bảo tất cả các net quan trọng, bao gồm cả những net đi qua nhiều trang, đều được đặt tên, đồng thời tên được gán trên các sơ đồ nguyên lý cấp cao hơn sẽ được sử dụng trên các sơ đồ nguyên lý cấp thấp hơn.
Hai net riêng biệt có cùng tên
Một vấn đề khác có thể xảy ra khi đặt tên net là sử dụng cùng một tên net trên các trang sơ đồ nguyên lý khác nhau để gán nhãn cho các net khác nhau. Trường hợp này sẽ được phát hiện trong quá trình xác thực bằng mục kiểm tra lỗi Duplicate Nets. Bạn không thể chuyển thiết kế sang PCB khi vẫn còn tình trạng này. Hai net riêng biệt đó sẽ bị gộp thành một net duy nhất trên PCB trong quá trình chuyển thiết kế.
Bạn có thể giải quyết tình trạng này bằng cách bật tùy chọn Append Sheet Numbers to Local Nets trên tab Tùy chọn của hộp thoại Project Options . Khi bật tùy chọn này, giá trị của tham số SheetNumber sẽ được thêm vào cuối tên của tất cả các net cục bộ, như minh họa trong các hình bên dưới.

Vì nhãn net Input đã được sử dụng trên nhiều trang, tùy chọn Append Sheet Numbers to Local Net đã được bật để tránh lỗi net trùng lặp.
Bạn có thể thấy tác dụng của thiết lập này bằng cách nhấp vào tab trang đã biên dịch (hình bên phải); lưu ý rằng _2 đã được thêm vào cuối tên net.
Chủ ý nối hai net
Có những tình huống bạn cần chủ ý nối hai net khác nhau. Đây không đơn thuần là vấn đề đặt tên, mà là trường hợp hai net cần được nối tắt theo yêu cầu thiết kế. Ví dụ, bạn có thể cần nối mass analog và mass số theo cách có kiểm soát.
Điều này được thực hiện bằng cách nối hai net thông qua một linh kiện Net Tie. Linh kiện Net Tie thực chất là một điểm nối tắt có kiểm soát, cho phép bạn quyết định vị trí trên bo mạch nơi các net được nối với nhau. Trên sơ đồ nguyên lý, linh kiện Net Tie có hai chân trở lên, mỗi chân được nối với một trong các net cần nối tắt. Thuộc tính Component Type của linh kiện được đặt thành Net Tie, như minh họa bên dưới.

Một linh kiện Net Tie được sử dụng để dẫn một tín hiệu clock duy nhất tới hai chân clock của FPGA trên sơ đồ nguyên lý.
Lưu ý rằng các chân not được đi dây nối với nhau trên sơ đồ nguyên lý (chúng không được nối tắt trên sơ đồ nguyên lý), nhưng chúng are được nối với nhau bên trong footprint PCB.
Ở phía PCB, footprint có số pad bằng với số chân của ký hiệu sơ đồ nguyên lý, với phần đồng nối giữa các pad. Trong hình ví dụ bên dưới, điều này được thực hiện bằng cách nối hai pad vuông bằng một đoạn đường mạch. Thao tác này được thực hiện bên trong footprint trong trình chỉnh sửa thư viện PCB. Thuộc tính Component Type trên PCB cũng được đặt thành Net Tie.
Phần mềm tự động bỏ qua các kết nối ngắn mạch được tạo bên trong linh kiện Net Tie trên PCB, do đó không phát sinh lỗi DRC.

Cùng linh kiện Net Tie đó trên PCB; các pad (đang được chọn) trong footprint Net Tie được nối tắt bằng một đường mạch.
Khi sử dụng linh kiện Net Tie để nối hai net khác nhau, mỗi net vẫn giữ nguyên tên riêng của mình trên toàn bộ sơ đồ nguyên lý và trên PCB.
Các net nguồn
Theo mặc định, các thiết lập coi các net nguồn là toàn cục, tức là bạn muốn chúng có sẵn trên mọi trang sơ đồ nguyên lý. Để truy cập một net nguồn, hãy đặt một Cổng nguồn với tên net cần thiết, sau đó nối dây từ các linh kiện đến cổng nguồn đó. Khi thiết kế được biên dịch, tất cả các chân nối với từng net nguồn sẽ được kết nối với nhau, trên tất cả các trang trong dự án.

Chính tên net quyết định cổng nguồn được nối với net nào, chứ không phải kiểu của ký hiệu — cả ba cổng nguồn được tô sáng đều nối với net nguồn GND.
Cục bộ hóa net nguồn — Trên toàn thiết kế
Như đã đề cập trước đó, có thể cục bộ hóa các net nguồn cho từng trang sơ đồ nguyên lý trong một thiết kế phân cấp bằng cách chọn tùy chọn Strict Hierarchical cho Phạm vi định danh net. Cách này cục bộ hóa tất cả các net nguồn trên mọi trang, vì vậy bạn phải nối dây chúng với nhau theo cách thủ công, tương tự như với các net tín hiệu. Nếu không được nối dây với nhau, mỗi net nguồn hiện diện trên mỗi trang sơ đồ nguyên lý sẽ phát sinh một lỗi Duplicate Net Name. Bạn cũng cần điều chỉnh các thiết lập Ma trận kết nối để cho phép nối Cổng với Cổng nguồn.

Nếu Net Identifier Scope được đặt thành Strict Hierarchical, mọi net nguồn đều phải được nối dây đến từng trang có sử dụng net đó.
Kết nối net nguồn đã cục bộ hóa giữa các trang
Bạn kết nối một net nguồn đã được cục bộ hóa trong thiết kế phân cấp theo cách tương tự như bất kỳ net nào khác: từ một cổng trên trang con đến một đầu nối trang trong ký hiệu trang trên trang cha. Lưu ý rằng đối với các net nguồn, kỹ thuật này chỉ hỗ trợ từng net nguồn riêng lẻ, không hỗ trợ các net nguồn được gộp thành bus
Nếu bạn đang tạo một thiết kế đa kênh và muốn cấp một net nguồn riêng biệt, duy nhất cho mỗi kênh bằng câu lệnh Repeat (như minh họa bên dưới), cách này được hỗ trợ vì bạn chỉ truyền một net vào mỗi kênh thông qua cặp đầu nối trang–cổng. Miễn là thiết kế chỉ kết nối một net nguồn riêng lẻ từ trang cha đến trang con qua mỗi cặp đầu nối trang–cổng, danh sách kết nối sẽ được tạo chính xác.
Có thể phân phối các net nguồn đã cục bộ hóa đến từng kênh trong thiết kế đa kênh nếu chúng đi lên và xuống các cấp phân cấp dưới dạng các net riêng lẻ, không phải dưới dạng bus.
Cục bộ hóa net nguồn — Riêng lẻ
Một net nguồn cụ thể trong thiết kế phân cấp (tức là trong thiết kế có Net Identifier Scope được đặt thành Hierarchical hoặc trong thiết kế có các đầu nối trang trên trang cấp cao nhất và Net Identifier Scope được đặt thành Automatic – tìm hiểu thêm về Thiết lập phạm vi định danh net) cũng có thể được cục bộ hóa trên một trang cụ thể bằng cách nối dây từ Cổng nguồn đến một Cổng trên trang sơ đồ nguyên lý đó.

Ở đây, net nguồn 3V3 chỉ được cục bộ hóa cho riêng trang này, vì vậy nó cũng phải được nối dây thủ công trên trang cha. Các net GND và 5V vẫn là các net nguồn toàn cục.
Biên dịch động
Related page: Kiểm tra tính hợp lệ của dự án thiết kế
Khi nối hai chân bằng dây, bạn đang thể hiện ý định thiết kế của mình, chứ chưa tạo ra một net thực sự. Net chỉ được tạo khi dự án được biên dịch. Ngoài việc trích xuất thông tin chi tiết về các linh kiện và cách chúng được kết nối, quá trình biên dịch còn trích xuất thông tin tham số chi tiết của linh kiện và thiết kế. Mô hình đã biên dịch của dự án được gọi là Mô hình dữ liệu hợp nhất.
Mô hình dữ liệu thiết kế được cập nhật từng phần sau mỗi thao tác của người dùng thông qua quá trình biên dịch động — tạo nên mô hình được gọi là Mô hình dữ liệu động (DDM). Không cần biên dịch dự án theo cách thủ công; tất cả đều được thực hiện tự động. Nhờ biên dịch động, mô hình kết nối của thiết kế được cập nhật từng phần sau mỗi thao tác của người dùng. Đối với một dự án thiết kế, quá trình biên dịch tự động thực hiện ba chức năng:
- Khởi tạo cấu trúc phân cấp của thiết kế.
- Thiết lập kết nối net giữa tất cả các trang thiết kế.
- Xây dựng Mô hình dữ liệu động (DDM) nội bộ của thiết kế.
Điều này bảo đảm mọi thay đổi đối với thiết kế đều được phản ánh ngay lập tức trong Navigator và bảng Dự án .
Để kiểm tra các lỗi logic, lỗi điện và lỗi trình bày bản vẽ bằng cách đối chiếu DDM với các thiết lập của trình biên dịch, bạn phải kiểm tra tính hợp lệ của dự án. Bạn có thể truy cập lệnh này bằng cách chọn lệnh Project » Validate Project từ các menu chính hoặc nhấp chuột phải vào mục của dự án trong bảng Dự án, rồi chọn lệnh Validate Project từ menu ngữ cảnh.
Mọi vi phạm được Trình biên dịch phát hiện sẽ được liệt kê dưới dạng cảnh báo và/hoặc lỗi trong bảng Messages. Khi kiểm tra các tài liệu nguồn để tìm vi phạm, Trình biên dịch sử dụng các tùy chọn được xác định trên các tab Báo cáo lỗi và Ma trận kết nối của hộp thoại Project Options (tùy theo loại dự án).
Mô hình dữ liệu động
Một thành phần nền tảng của phần mềm là Mô hình dữ liệu hợp nhất (Unified Data Model – UDM). Thông qua quá trình biên dịch động tự động, một mô hình duy nhất, thống nhất được tạo ra và đóng vai trò trung tâm trong quy trình thiết kế. Các trình biên tập và dịch vụ khác nhau trong phần mềm, bao gồm trình biên tập sơ đồ nguyên lý và PCB, có thể truy cập và thao tác dữ liệu trong mô hình. Thay vì sử dụng một kho dữ liệu riêng cho từng lĩnh vực thiết kế, UDM được cấu trúc để chứa toàn bộ thông tin từ mọi khía cạnh của thiết kế, bao gồm các linh kiện và kết nối giữa chúng. Mô hình duy nhất, thống nhất đóng vai trò trung tâm trong quy trình thiết kế này được tạo ra nhờ quá trình biên dịch thiết kế động. Điều này có nghĩa là Mô hình dữ liệu hợp nhất có sẵn ngay khi mở dự án và không cần biên dịch thủ công thêm – một Mô hình dữ liệu động (Dynamic Data Model – DDM) thực thụ. Do đó, mô hình được cập nhật (biên dịch) từng phần sau mỗi thao tác của người dùng. Bạn có thể tự do đặt, đi dây, sắp xếp lại, đổi tên, thêm và xóa nội dung trong thiết kế sơ đồ nguyên lý.
Quá trình biên dịch thiết kế PCB được quản lý bằng mã nằm ngoài các trình biên tập sơ đồ nguyên lý và PCB. Cách tiếp cận này mang lại nhiều lợi ích, trong đó lợi ích lớn nhất là Mô hình dữ liệu hợp nhất của thiết kế nằm ngoài từng trình biên tập sơ đồ nguyên lý và PCB riêng lẻ. UDM bao gồm các mô tả chi tiết về mọi linh kiện trong thiết kế và cách chúng kết nối với nhau.

Phần mềm quản lý dữ liệu kết nối giữa sơ đồ nguyên lý và PCB.
Các vị trí và thao tác sau không yêu cầu thêm bất kỳ thao tác thủ công nào để biên dịch thiết kế vì quá trình biên dịch diễn ra động:
- Navigator và bảng Projects
- ActiveBOM
- Thực hiện ECO
- Định vị chéo
- Tô sáng net bằng màu
- Hoán đổi chân
- Tham chiếu chéo linh kiện
Vậy bạn tương tác với Mô hình dữ liệu hợp nhất như thế nào, chẳng hạn để lần theo một net xuyên suốt thiết kế? Bạn thực hiện việc đó thông qua bảng Navigator.
Kiểm tra kết nối
Panel page: Bảng Navigator
Nếu thiết kế lớn và trải rộng trên nhiều trang sơ đồ, việc theo dõi và xác minh các kết nối trong thiết kế có thể trở nên khó khăn. Để hỗ trợ quá trình này, bạn có thể sử dụng bảng Navigator. Bảng này cung cấp chế độ xem toàn bộ thiết kế đã biên dịch.
Cách sử dụng cơ bản của bảng như sau:
-
Thiết lập cách duyệt bằng cách nhấp vào nút
ở đầu bảng để mở hộp thoại Preferences và bật các Highlight Methods bạn muốn. Ngoài ra, hãy nhấp chuột phải vào đối tượng cần xem trong bảng và sử dụng các tùy chọn trong menu để cấu hình cách điều hướng, như minh họa trong hình bên dưới.
-
Đặt phạm vi duyệt trong vùng Documents for của bảng; để duyệt toàn bộ thiết kế, hãy chọn
Flattened Hierarchy. - Nhấp vào một linh kiện trong phần Instance của danh sách để chuyển đến linh kiện đó; mở rộng mục linh kiện để tìm hoặc chuyển đến một chân.
- Nhấp vào một net hoặc bus trong phần Net /Bus để chuyển đến net hoặc bus đó.
- Giữ phím Alt khi nhấp để chuyển đến đối tượng đó trên cả sơ đồ nguyên lý và PCB.

Nhấp vào một linh kiện hoặc net trong bảng Navigator để định vị linh kiện hoặc net đó và lần theo các kết nối xuyên suốt thiết kế. Nhấp chuột phải để truy cập các tùy chọn hiển thị. Di con trỏ lên hình ảnh để xem cách điều hướng đồng thời đến một linh kiện trên sơ đồ nguyên lý và PCB (giữ Alt khi nhấp trong bảng Navigator để bao gồm cả đối tượng PCB).
Điều hướng đến các linh kiện trên bo mạch
Ngoài việc định vị linh kiện trên sơ đồ nguyên lý và PCB (nếu giữ Alt) từ bảng Navigator, bạn cũng có thể điều hướng đến các chân/linh kiện/net/bus/bó dây trên PCB ngay từ sơ đồ nguyên lý.
Ví dụ: khi nhấp để định vị một linh kiện trên sơ đồ nguyên lý, bạn cũng có thể định vị chính linh kiện đó trên PCB.
Để thực hiện:
- Bật tùy chọn Selecting trong Highlight Methods, đồng thời bật các tùy chọn mong muốn trong phần Cross Select Mode trên trang System - Navigation của hộp thoại Preferences.
- Bật tính năng Chọn chéo (Tools » Cross Select Mode) trong cả trình biên tập sơ đồ nguyên lý và PCB.

Các tùy chọn này cấu hình cách điều hướng và chọn chéo.
Giờ đây, khi bạn chọn các chân/linh kiện/net/bus/bó dây trên sơ đồ nguyên lý, các đối tượng đó cũng sẽ được chọn trên PCB, như minh họa trong hình bên dưới.

Khi chọn linh kiện và net trên sơ đồ nguyên lý, các đối tượng đó cũng được chọn trên PCB. Tính năng chọn chéo cũng hoạt động theo chiều từ PCB sang sơ đồ nguyên lý.
Tìm kiếm linh kiện và net trong cấu trúc dự án
Duyệt qua cấu trúc trong bảng để tìm linh kiện hoặc net cần quan tâm, sau đó nhấp đúp vào đối tượng để hiển thị các phiên bản của đối tượng đó trong các tài liệu sơ đồ nguyên lý của dự án. Sử dụng các tùy chọn trên trang Hệ thống - Điều hướng của hộp thoại Preferences để chỉ định cách tô sáng đối tượng (Thu phóng, Làm mờ, Chọn, v.v.).
Tính năng điều hướng đối tượng dự án cũng có trong bảng Navigator, nơi cung cấp cấu trúc phân cấp chi tiết của các đối tượng thiết kế và dữ liệu liên quan. Các thiết lập tùy chọn Hệ thống - Điều hướng quyết định cách tô sáng đối tượng của cả hai bảng Project và Navigator.
Tô sáng kết nối
Tùy chọn điều hướng kết nối hiển thị các mối quan hệ kết nối của đối tượng được chọn trong bảng Projects. Nhấp đúp vào một mục, chẳng hạn như Net, trong danh sách phân cấp đối tượng của bảng để tô sáng các kết nối của mục đó trên sơ đồ nguyên lý.
Tính năng xem trước được bật bằng tùy chọn Connectivity Graph trong phần Highlight Methods trên trang Hệ thống – Điều hướng của hộp thoại Preferences. Chọn thêm tùy chọn Include Power Parts để xem cả các kết nối của những đối tượng nguồn liên quan đến đối tượng đã chọn.
Tô sáng net trên toàn thiết kế
Có thể tô sáng các kết nối của net trên tất cả sơ đồ nguyên lý trong thiết kế bằng cách giữ phím Alt khi chọn net bằng thao tác nhấp vào dây dẫn (Alt+Click). Mọi vị trí xuất hiện của net trên sơ đồ nguyên lý đều được tô sáng, trong khi các đối tượng khác bị làm mờ, giúp hiển thị rõ đường truyền tín hiệu/nguồn trong thiết kế chỉ bằng một thao tác đơn giản.
Hiệu ứng tô sáng net được xóa khi nhấp vào vùng trống, và cách thức hoạt động của tính năng này được xác định bởi các thiết lập Highlight Methods trên trang Hệ thống - Điều hướng của hộp thoại Preferences. Lưu ý rằng việc bỏ chọn tùy chọn Dimming sẽ tắt tính năng tô sáng net.
Cấu hình màu của net
Main page: Áp dụng màu cho net
Để sơ đồ nguyên lý dễ đọc hơn và thuận tiện hơn khi làm việc với net cũng như các đường mạch trong trình biên tập PCB, bạn có thể áp dụng màu cho dây dẫn trên sơ đồ nguyên lý, cũng như các net và đường mạch trên PCB.
Có thể áp dụng màu tô sáng cho net hoặc bus trong trình biên tập sơ đồ nguyên lý bằng các lệnh trong menu con View » Set Net Colors, như minh họa trong hình bên dưới. Có thể chuyển các màu này sang trình biên tập PCB bất cứ lúc nào thông qua lệnh Update PCB.
Trong trình biên tập PCB, màu mặc định và trạng thái hiển thị của Connection Lines được cấu hình trong phần System Colors của bảng Cấu hình chế độ xem PCB. Lưu ý rằng màu mặc định này được áp dụng khi các net được tạo (trong lần chuyển thiết kế đầu tiên từ sơ đồ nguyên lý); màu của các đường kết nối hiện có sẽ không thay đổi khi tùy chọn này được thay đổi.
Trong trình biên tập PCB, màu được áp dụng cho từng net được hiển thị trong chế độ Net của bảng PCB. Hãy chú ý màu nền phía sau hộp kiểm cạnh tên net, như minh họa ở góc dưới bên phải của hình bên dưới.
Màu luôn được áp dụng cho các net chưa đi dây (đường kết nối). Để hiển thị màu trên các net đã đi dây, hãy chọn hộp kiểm cạnh tên net trong bảng PCB và cấu hình các tùy chọn hiển thị trên trang Ghi đè màu Board Insight của hộp thoại Preferences. Trong hình bên dưới, Mẫu nền của màu ghi đè được đặt thành Solid, còn Cách hiển thị khi thu nhỏ được đặt thành Override Color Dominates.
Các màu net được áp dụng trên sơ đồ nguyên lý sẽ được chuyển sang PCB bằng lệnh Update PCB. Hãy cấu hình các tính năng ghi đè màu PCB để kiểm soát cách hiển thị chúng trên bo mạch.
Thay đổi màu của net trên PCB
Không phải lúc nào cũng có thể áp dụng màu cho dây dẫn trên sơ đồ nguyên lý rồi chuyển sang PCB. Trong trường hợp này, bạn vẫn có thể áp dụng màu cho các đường kết nối và đường mạch trong trình biên tập PCB. Để thay đổi màu của net sau khi thiết kế đã được chuyển, hãy nhấp đúp vào tên net trong chế độ Nets của bảng PCB. Có thể chỉnh sửa màu của từng net trong hộp thoại Chỉnh sửa net.
Để thay đổi màu của nhiều net, hãy sử dụng chế độ Nets của bảng PCB:
- Sử dụng các thao tác chọn nhiều mục tiêu chuẩn của Windows (Shift+click hoặc Ctrl+click) để chọn nhiều lớp net hoặc nhiều net riêng lẻ.
- Nhấp chuột phải vào một đối tượng đã chọn và chọn lệnh Change Net Color từ menu ngữ cảnh để gán màu mới cho các net đã chọn.
- Nhấp chuột phải lần nữa và chọn Display Override » Selected On để bật tính năng ghi đè màu cho các net đã chọn.

Cải thiện khả năng quan sát các net bằng cách thay đổi màu của các đường kết nối và bật tính năng ghi đè hiển thị.



















).

