Chuẩn bị đầu ra và phát hành dự án

Main page: Chuẩn bị thiết kế để sản xuất

Giờ đây, khi đã hoàn tất thiết kế và bố trí PCB, bạn đã sẵn sàng tạo bộ tài liệu đầu ra cần thiết để kiểm tra, chế tạo và lắp ráp bo mạch.

Do có nhiều công nghệ và phương pháp khác nhau trong sản xuất PCB, Altium Designer có thể tạo nhiều loại đầu ra cho các mục đích khác nhau, bao gồm tệp Gerber, tệp ODB++, tệp Pick and Place, báo cáo danh mục vật tư, v.v.

Thêm tệp Output Job vào dự án

Main page: Chuẩn bị dữ liệu sản xuất bằng Output Job

Mặc dù bạn có thể tạo riêng từng đầu ra cần thiết từ các trình biên tập tương ứng (ví dụ: sử dụng các lệnh trong menu con Fabrication Outputs và Assembly Outputs của menu chính File trong trình biên tập PCB), Altium Designer hỗ trợ các tệp Output Job. Tệp Output Job (gọi tắt là 'OutJob') lưu các thiết lập cho từng loại đầu ra. OutJob cho phép bạn cấu hình từng loại đầu ra, cách đặt tên, định dạng và vị trí lưu đầu ra. Các đầu ra có thể được tạo trực tiếp từ OutJob hoặc trong quy trình phát hành dự án tích hợp.

  1. Nhấp chuột phải vào mục dự án trong bảng Projects và chọn lệnh Add New to Project » Output Job File từ menu ngữ cảnh. Một tệp Output Job mới sẽ mở ra và mục tương ứng sẽ xuất hiện, được liên kết với dự án trong bảng Projects, bên dưới mục Settings\Output Job Files.

    Javascript ID: Tutorial_AddNewOutJob_AD25_4
  2. Nhấp chuột phải vào mục OutJob trong bảng Projects và chọn lệnh Save As. Hộp thoại Save As sẽ mở ra, sẵn sàng lưu tài liệu vào cùng vị trí với tệp dự án. Nhập tên Fabrication vào trường File name và nhấp vào nút Save.

  3. Việc thêm OutJob đã làm thay đổi dự án, vì vậy hãy lưu dự án cục bộ bằng cách nhấp chuột phải vào mục dự án trong bảng Projects và chọn Save.

Thêm và cấu hình đầu ra chế tạo

Main page: Chuẩn bị dữ liệu chế tạo

Trong phần này của hướng dẫn, bạn sẽ cấu hình các đầu ra cần thiết để chế tạo bo mạch: tệp Gerber và NC Drill. 

  1. Để thêm đầu ra Gerber mới, nhấp vào liên kết Add New Fabrication Output trong phần Fabrication Outputs thuộc vùng Outputs của OutJob và chọn Gerber Files » [PCB Document].

    Nếu bạn chọn tùy chọn [PCB Document], tài liệu PCB của dự án sẽ tự động được sử dụng làm nguồn đầu ra. Lựa chọn này cũng giúp dễ dàng sao chép OutJob giữa các dự án, vì bạn sẽ không cần cập nhật thiết lập này. Nếu dự án có nhiều tài liệu PCB, bạn cần chọn bo mạch cụ thể.

  2. Nhấp đúp vào mục đầu ra Gerber Files vừa thêm. Hộp thoại Gerber Setup sẽ mở ra. Cấu hình các tùy chọn trong hộp thoại như sau:

    1. Vì bo mạch được thiết kế theo hệ mét, hãy đảm bảo tùy chọn Units được đặt thành Millimeters.

    2. Đơn vị nhỏ nhất được sử dụng trên bo mạch là 0,25 mm cho việc đi dây và khoảng cách cách ly. Tuy nhiên, do hầu hết linh kiện có điểm tham chiếu tại tâm hình học (và được đặt trên lưới 1 mm), một số pad của chúng thực tế sẽ nằm trên lưới 0,01 mm. Đặt tùy chọn Decimal thành 0.001 mm. Điều này đảm bảo độ phân giải của dữ liệu đầu ra đủ cao để biểu diễn chính xác các vị trí trên lưới này.

    3. Nhấp vào nút  ở cuối thẻ Layer to plot và chọn Select Used. Các lớp được sử dụng trong thiết kế sẽ được bật trong cột Plot của bảng phía trên.

  3. Nhấp vào Apply để chấp nhận các thiết lập mặc định khác và đóng hộp thoại Gerber Setup.

  4. Vì bo mạch có các lỗ khoan, bạn cũng cần tạo tệp NC Drill. Tương tự, thêm đầu ra NC Drill vào tệp OutJob – nhấp vào liên kết Add New Fabrication Output trong phần Fabrication Outputs thuộc vùng Outputs của OutJob và chọn NC Drill Files » [PCB Document].

  5. Nhấp đúp vào mục đầu ra NC Drill Files vừa thêm để mở hộp thoại NC Drill Setup. Để đảm bảo các tệp NC Drill được tạo cùng định dạng với các tệp Gerber, đặt Units thành Millimeters và Format thành 4:3. Đảm bảo tùy chọn Coordinate Position được đặt thành Reference to relative origin.

  6. Nhấp vào OK để chấp nhận các thiết lập mặc định khác và đóng hộp thoại NC Drill Setup.

  7. Sau khi đã cấu hình các thiết lập Gerber và NC Drill, bước tiếp theo là cấu hình cách đặt tên và vị trí lưu đầu ra. Bạn thực hiện việc này bằng cách ánh xạ chúng tới một vùng chứa đầu ra ở phía bên phải OutJob. Đối với các tệp riêng lẻ có định dạng riêng, hãy sử dụng vùng chứa Folder Structure. Một OutJob mới có sẵn một số vùng chứa mặc định. Chọn mục Folder Structure trong danh sách vùng chứa đầu ra, sau đó nhấp vào các nút chọn cho Gerber và NC Drill Files trong cột Enabled thuộc vùng Outputs để ánh xạ các đầu ra này tới vùng chứa đã chọn, như minh họa bên dưới.

  8. Bước cuối cùng là cấu hình vùng chứa. Để thực hiện, nhấp vào liên kết Change trong mục vùng chứa khi mục đó đang được chọn để mở hộp thoại Folder Structure settings. Ở đầu hộp thoại có một nhóm điều khiển dùng để cấu hình vị trí lưu đầu ra. Đảm bảo điều khiển đầu tiên được đặt thành Release Managed. Phần dưới của hộp thoại sẽ hiển thị cách tên và cấu trúc thư mục thay đổi khi bạn chọn các tùy chọn khác nhau.

  9. Nhấp vào OK để đóng hộp thoại Folder Structure settings.

Thêm và cấu hình báo cáo xác thực DRC

Main page: Chuẩn bị báo cáo xác thực

Altium Designer cung cấp một số phép kiểm tra xác thực có thể được đưa vào làm đầu ra trong quá trình tạo đầu ra. Mỗi phép kiểm tra tạo ra một tệp báo cáo HTML. Trong quy trình phát hành dự án, các phép kiểm tra này sẽ được thực hiện trước khi tạo các đầu ra khác. Nếu bất kỳ phép kiểm tra xác thực nào không đạt, quá trình phát hành sẽ thất bại.

  1. Để thêm đầu ra xác thực DRC mới, nhấp vào liên kết Add Validation Output trong phần Validation Outputs thuộc vùng Outputs của OutJob và chọn Design Rules Check » [PCB Document].

  2. Ánh xạ báo cáo vừa thêm tới vùng chứa Folder Structure hiện có. Chọn mục Folder Structure trong danh sách ở phía bên phải OutJob, sau đó nhấp vào nút chọn cho đầu ra Design Rules Check trong cột Enabled thuộc vùng Outputs.

  3. Lưu tệp Output Job cục bộ bằng cách nhấp chuột phải vào mục tương ứng trong bảng Projects và chọn Save từ menu ngữ cảnh.

  4. Đóng tệp Output Job bằng cách nhấp chuột phải vào tab của tệp ở phía trên vùng thiết kế và chọn lệnh Close Fabrication.OutJob từ menu ngữ cảnh. 

Thêm và cấu hình đầu ra lắp ráp

Main page: Cấu hình BOM trong Report Manager

Tệp BOM đầu ra thực tế được tạo bằng hộp thoại Report Manager – một công cụ tạo báo cáo có khả năng cấu hình linh hoạt, hỗ trợ tạo đầu ra ở nhiều định dạng bao gồm văn bản, CSV, PDF, HTML và Excel. BOM ở định dạng Excel cũng có thể áp dụng mẫu bằng một trong các mẫu được xác định sẵn hoặc mẫu của riêng bạn.

  1. Thêm tệp OutJob mới vào dự án bằng cách nhấp chuột phải vào mục dự án trong bảng Projects và chọn lệnh Add New to Project » Output Job File từ menu ngữ cảnh.

  2. Nhấp chuột phải vào mục OutJob trong bảng Projects và chọn lệnh Save As. Hộp thoại Save As sẽ mở ra, sẵn sàng lưu tài liệu vào cùng vị trí với tệp dự án. Nhập tên Assembly vào trường File name và nhấp vào nút Save.

  3. Lưu dự án trên máy cục bộ bằng cách nhấp chuột phải vào mục dự án trong bảng Projects và chọn Save.

  4. Để thêm đầu ra BOM mới, nhấp vào liên kết Add New Report Output trong phần Report Outputs của OutJob và chọn Bill of Materials » [ActiveBOM Document].

  5. Nhấp đúp vào đầu ra Bill of Materials vừa thêm để mở hộp thoại Report Manager.

  6. Trong vùng Export Options của khung Properties ở bên phải hộp thoại, sử dụng danh sách thả xuống File Format để chọn Generic XLS (*.xls, *.xlsx, *.xlsm) rồi sử dụng danh sách thả xuống Template để chọn mẫu BOM Template Single Supplier trong số các mẫu có trong Workspace của bạn.

  7. Nhấp vào OK để lưu thay đổi và đóng hộp thoại Report Manager.

  8. Thêm đầu ra Draftsman mới bằng cách nhấp vào liên kết Add New Documentation Output trong phần Documentation Outputs của OutJob và chọn Draftsman » All Draftsman Documents.

  9. Liên kết các đầu ra BOM và Draftsman vừa thêm với bộ chứa đầu ra PDF hiện có. Để thực hiện, chọn mục PDF trong danh sách các bộ chứa đầu ra ở bên phải OutJob, sau đó nhấp vào các nút chọn cho đầu ra Bill of Materials và Draftsman trong cột Enabled của vùng Outputs.

  10. Khi mục bộ chứa PDF được chọn, nhấp vào liên kết Change trong mục đó để mở hộp thoại PDF settings.

  11. Nhấp vào mục Assembly.PDF ở phía trên hộp thoại PDF settings, chọn Separate file for each output using output name và nhấp vào nút . BOM và bản vẽ đầu ra sẽ được gán tên đã thiết lập cho đầu ra trong OutJob (lần lượt là Bill of Materials.pdf và Draftsman.pdf), có thể xem trong vùng Preview của hộp thoại.

    Javascript ID: Tutorial_Dlg_PDFsettings_Path_AD24
  12. Nhấp vào OK để đóng hộp thoại.

  13. Thêm đầu ra Pick & Place mới bằng cách nhấp vào liên kết Add New Documentation Output trong phần Documentation Outputs của OutJob và chọn Generates pick and place files » [PCB Document].

  14. Nhấp đúp vào đầu ra Generates pick and place files vừa thêm để truy cập hộp thoại Pick and Place Setup.

  15. Trong vùng Output Setting ở phía dưới bên trái hộp thoại, đặt Units thành Metric.

  16. Nhấp vào OK để chấp nhận các thiết lập mặc định còn lại và đóng hộp thoại Pick and Place Setup.

  17. Liên kết đầu ra Pick & Place vừa thêm với bộ chứa đầu ra Folder Structure hiện có. Để thực hiện, chọn mục Folder Structure trong danh sách các bộ chứa đầu ra ở bên phải OutJob, sau đó nhấp vào nút chọn cho đầu ra Generates pick and place files trong cột Enabled của vùng Outputs.

  18. Lưu tệp Output Job trên máy cục bộ bằng cách nhấp chuột phải vào mục của tệp trong bảng Projects và chọn Save từ menu ngữ cảnh.

  19. Đóng tệp Output Job bằng cách nhấp chuột phải vào tab của tệp ở phía trên vùng thiết kế và chọn lệnh Close Assembly.OutJob từ menu ngữ cảnh.

Phát hành dự án

Main page: Phát hành dự án thiết kế

Sau khi tài liệu đầu ra đã được cấu hình trong các tệp Output Job, dự án đã sẵn sàng để phát hành lên Workspace được kết nối. Quy trình phát hành thiết kế bo mạch được tự động hóa, cho phép bạn phát hành các dự án thiết kế bo mạch mà không gặp những rủi ro liên quan đến quy trình phát hành thủ công. Khi một dự án cụ thể được phát hành, một bản chụp của dữ liệu thiết kế nguồn sẽ được tạo và lưu trữ cùng với mọi đầu ra được tạo – đại diện cho một sản phẩm hữu hình được tạo từ dự án thiết kế đó và được công ty bán ra.

Quy trình phát hành được thực hiện bằng Project Releaser của Altium Designer, với giao diện người dùng được cung cấp thông qua một chế độ xem chuyên dụng – chế độ xem Release. Quy trình phát hành diễn ra theo từng giai đoạn; các mục ở bên trái chế độ xem giúp bạn nhanh chóng biết mình đang ở giai đoạn nào.

  1. Nhấp chuột phải vào mục dự án trong bảng Projects và chọn lệnh Project Releaser từ menu ngữ cảnh. Chế độ xem Release sẽ mở trong một tab tài liệu riêng.

  2. Trong giai đoạn đầu tiên – 1. Configure Server Release – bạn chỉ định loại dữ liệu muốn tạo. Nhấp vào các điều khiển Details ở ngoài cùng bên phải tiêu đề của mỗi bộ dữ liệu để xem chi tiết chính xác những gì bộ dữ liệu đó sẽ tạo ra.

  3. Nhấp vào nút  ở phía dưới bên trái chế độ xem để truy cập hộp thoại Project Release Options. Trên tab Release Options của hộp thoại, hãy đảm bảo Managed - <WorkspaceName> được chọn làm Release Target, Fabrication được gán cho bộ Fabrication Data và Assembly được gán cho bộ Assembly Data.

  4. Nhấp vào OK để đóng hộp thoại và quay lại chế độ xem Release.

  5. Đảm bảo cả hai tùy chọn Include Fabrication Data và Include Assembly Data for No Variant đều được bật.

  6. Nhấp vào nút  ở phía dưới bên phải chế độ xem để tiếp tục.

  7. Hộp thoại Item Creation sẽ mở ra với danh sách các mục phát hành đích sẽ được tạo trong Workspace. Chọn tùy chọn Create items để xác nhận việc tạo các mục.

  8. Trong hộp thoại Project Modified vừa mở, chọn tùy chọn Save and Commit changes để lưu các thay đổi trên máy cục bộ và tiếp tục lưu các thay đổi vào Workspace.

  9. Trong hộp thoại Commit to Version Control vừa mở, nhập một nhận xét có ý nghĩa vào trường Comment (ví dụ: The project is ready for release), rồi nhấp vào nút .

  10. Giai đoạn tiếp theo của quy trình phát hành – 2. Validate Project – được chạy tự động vì tệp Output Job Fabrication có bao gồm báo cáo kiểm tra quy tắc thiết kế.

    Nếu bất kỳ bước kiểm tra xác thực nào không đạt, quá trình phát hành sẽ thất bại. Đối với việc phát hành dự án trong hướng dẫn này, điều đó có nghĩa là tài liệu PCB có ít nhất một vi phạm DRC. Trong trường hợp này, hãy dừng quy trình phát hành bằng nút  ở góc dưới bên phải của chế độ xem, mở tài liệu PCB, khắc phục các vi phạm DRC, rồi bắt đầu lại quy trình phát hành.

  11. Sau khi xác thực thành công, giai đoạn tiếp theo của quy trình phát hành – 3. Generate Data – được chạy tự động. Đây là lúc tất cả các đầu ra khác – được xác định trong các tệp OutJob được gán cho các mục dữ liệu có trong bản phát hành – được tạo để cung cấp dữ liệu phát hành vào các mục đích tương ứng trong Workspace.

  12. Khi tất cả các bước kiểm tra xác thực đã đạt và dữ liệu đầu ra đã được tạo, giai đoạn tiếp theo của quy trình phát hành – 4. Review Data – cho phép bạn xem lại dữ liệu đã tạo. Tiếp tục phát hành bằng cách nhấp vào nút  ở góc dưới bên phải của chế độ xem.

  13. Hộp thoại Confirm Release sẽ mở, tóm tắt các cấu hình của dự án sẽ được phát hành lên Workspace. Nhập Release Note (ví dụ: Initial Release), rồi nhấp vào OK.

  14. Sau khi xác nhận phát hành ở giai đoạn trước, quy trình sẽ tự động chuyển sang giai đoạn tiếp theo – 5. Upload Data. Giai đoạn này chỉ hiển thị tiến trình tải dữ liệu lên các phiên bản của những mục dữ liệu tương ứng trong Workspace.

  15. Giai đoạn cuối cùng của quy trình – 6. Execution Report – cung cấp bản tóm tắt về lần phát hành. Đóng chế độ xem Release bằng cách nhấp vào nút  ở góc dưới bên phải của chế độ xem.

Thiết kế cộng tác với Workspace

Thông thường, nhiều người cùng tham gia thiết kế và phát triển một sản phẩm điện tử. Để thực hiện việc này hiệu quả, các thành viên trong nhóm thiết kế cần có khả năng làm việc cộng tác. Altium Designer, kết hợp với một Workspace được kết nối, hỗ trợ nhiều tính năng thiết kế cộng tác. Một số tính năng được liệt kê dưới đây.

  • Project history – chế độ xem History chuyên dụng là một dòng thời gian lịch sử dự án nâng cao được trình bày bằng đồ họa, thể hiện các sự kiện quan trọng liên quan đến dự án theo trình tự thời gian – tạo dự án, commit, phát hành, sao chép và trao đổi MCAD – đồng thời hỗ trợ nhiều thao tác khi phù hợp (). Bạn có thể truy cập chế độ xem History của dự án Workspace từ Altium Designer bằng cách nhấp chuột phải vào mục dự án trong bảng Projects và chọn lệnh History & Version Control » Show Project History từ menu ngữ cảnh.

    Tìm hiểu thêm: Lịch sử dự án, Project History (Altium 365 Workspace, Workspace trên Enterprise Server)

  • Web Viewer – giao diện Web Viewer của Workspace cho phép truy cập các tài liệu dự án từ mọi nơi thông qua trình duyệt tiêu chuẩn. Không chỉ là một trình xem trên trình duyệt, công nghệ trình duyệt tiên tiến của giao diện này cho phép người dùng điều hướng trong cấu trúc dự án, tương tác với tài liệu thiết kế, đánh dấu các vùng hoặc đối tượng để thêm nhận xét, đồng thời tìm kiếm, dò chéo, chọn và kiểm tra các linh kiện cũng như net trong toàn bộ thiết kế. Bạn có thể truy cập Web Viewer của dự án Workspace từ Altium Designer bằng cách nhấp chuột phải vào mục dự án trong bảng Projects và chọn lệnh Show in Web Browser từ menu ngữ cảnh.

    Tìm hiểu thêm: Web Viewer (Nền tảng Altium 365, Workspace trên Enterprise Server)

  • Document commenting – nhận xét là một ghi chú do người dùng thêm, được gán cho một điểm, đối tượng hoặc vùng cụ thể (tùy trường hợp) trên chế độ xem dữ liệu được hỗ trợ và có thể được người dùng khác trả lời. Nhận xét thúc đẩy sự cộng tác giữa người dùng mà không làm thay đổi chính dữ liệu được chia sẻ, vì Workspace lưu trữ nhận xét độc lập với dữ liệu đó. Các nhận xét được thêm trong giao diện Web Viewer tại những vị trí sau sẽ xuất hiện trong Altium Designer và ngược lại. Trong Altium Designer, tính năng nhận xét được quản lý thông qua bảng Comments and Tasks ().

    Tìm hiểu thêm: Nhận xét trên tài liệu, Web Viewer (Nền tảng Altium 365, Workspace trên Enterprise Server)

  • Sharing a project – sau khi dự án được lưu vào Workspace, bạn có thể xác định những người dùng nào được phép truy cập dự án đó để cộng tác thiết kế và/hoặc xem xét dự án. Việc này được thực hiện bằng cách chia sẻ dự án, hay chính xác hơn là cấu hình quyền truy cập của dự án. Trong Altium Designer, việc chia sẻ dự án được quản lý thông qua hộp thoại Share (), được truy cập bằng cách nhấp chuột phải vào mục dự án trong bảng Projects và chọn lệnh Share từ menu ngữ cảnh.

    Tìm hiểu thêm: Chia sẻ thiết kế, Workspace Projects (Altium 365 Workspace, Workspace trên Enterprise Server)

Chúc mừng! Bạn đã bắt đầu từ một trang sơ đồ nguyên lý trống và hoàn thành một PCB với các đầu ra được phát hành lên Workspace — đó chính là toàn bộ quy trình thiết kế trong Altium Designer!

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents