Schnellstartanleitung für Power Analyzer von Keysight

Auf einen Blick

Diese Schnellstartanleitung zeigt Ihnen, wie Sie mit Power Analyzer by Keysight das Gleichstromversorgungsnetzwerk eines PCB-Designs direkt in Altium Designer bewerten. Statt sich auf Vermutungen zu verlassen, können Sie prüfen, ob Kupferstrukturen, Flächen, Leiterbahnen und Vias den Leistungsbedarf Ihres Designs decken können. Sie erfahren, wie sich die Erweiterung direkt in Ihr aktuelles Projekt integriert, wie Sie sie installieren und starten, welche Angaben vor einer Analyse erforderlich sind und wie Sie mit dem Definieren und Simulieren von Versorgungsnetzen beginnen. Wenn Sie einen klaren Einstieg in die Nutzung von Power Analyzer by Keysight innerhalb Ihres bestehenden Workflows suchen, führt Sie dieser Artikel durch die wesentlichen Schritte. Lesen Sie weiter, um sich mit dem Werkzeug vertraut zu machen und es sicher einzusetzen.

- Erfahren Sie, welche Funktionen Power Analyzer by Keysight in Altium Designer bietet und wie die Erweiterung anhand der vorhandenen Designdaten Ihres Projekts die Analyse der Gleichstromversorgungsintegrität unterstützt.
- Lernen Sie den grundlegenden Workflow kennen: von der Installation der Erweiterung über das Öffnen des Analysedokuments bis zur Vorbereitung Ihrer Leiterplatten- und Netzeinstellungen für die Simulation.
- Machen Sie sich mit den wichtigsten Einrichtungsvoraussetzungen vertraut, darunter die Synchronisierung zwischen Schaltplan und PCB, Konfigurationsoptionen, erforderliche Abonnements und die Auswahl der Versorgungsnetze.
Mit KI tiefer einsteigen:

Bei modernen digitalen Designs mit Hochgeschwindigkeitsschaltungen, dicht bestückten Leiterplatten und mehreren Niederspannungs-Versorgungsschienen erfordern die Anforderungen an das Gleichstrom-Versorgungsnetzwerk einen analytischen Ansatz bei dessen Auslegung. Die Gleichstromanalyse eines Versorgungsnetzwerks bzw. die Ergebnisse seiner DC-Power-Integrity-Analyse (PI-DC) sollen sicherstellen, dass auf dem Weg von den Spannungsquellen zu den Lasten ausreichend Kupfer vorhanden ist. Anders ausgedrückt: Die Kupferflächen, Leiterbahnen und Vias auf der Leiterplatte müssen ausreichend dimensioniert sein und geeignete Eigenschaften aufweisen, um den Leistungsbedarf der Bauteile auf der Leiterplatte zu decken.

Glücklicherweise lässt sich das Versorgungsnetzwerk einer Leiterplatte ohne Rätselraten beurteilen: mit einem Simulationstool für DC Power Integrity (PI-DC), das das Gleichstromverhalten eines Leiterplattendesigns anhand seiner elektrischen und physikalischen Eigenschaften analysiert. Ein solches Tool ist für Altium Designer verfügbar: der Power Analyzer by Keysight.

Der Power Analyzer wird als herunterladbare Altium-Erweiterung bereitgestellt und ist direkt in Altium Designer integriert, um die PI-DC-Simulation und -Analyse des aktuellen Leiterplattenprojekts zu ermöglichen. Da der Power Analyzer innerhalb von Altium Designer arbeitet, sind weder ein manueller Datenimport oder -export noch Datenkonvertierungen oder separate Anwendungen erforderlich. Starten Sie den Power Analyzer einfach im Schaltplan- oder PCB-Editor, legen Sie die gewünschten Testparameter fest und führen Sie dann die Simulation aus. Die Ergebnisse werden hauptsächlich anhand von 2D-/3D-Modellen des Kupferlayouts der Leiterplatte dargestellt. So lassen sich die Ergebnisse schnell beurteilen und verschiedene „Was wäre, wenn“-Szenarien für das Leiterplattenlayout untersuchen.

Zugriff auf die Funktionen von Power Analyzer by Keysight

Um auf die Funktionen von Power Analyzer by Keysight in Altium Designer zugreifen zu können, muss die Power Analyzer by Keysight Softwareerweiterung installiert sein. Diese Erweiterung kann manuell installiert oder entfernt werden.

Weitere Informationen zum Verwalten von Erweiterungen finden Sie auf der Seite Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Wenn Sie auf die Option zum Herunterladen und Installieren der Erweiterung klicken, wird End-User License Agreement geöffnet (). Mit einem Klick auf Accept akzeptieren Sie die Bedingungen der Endbenutzer-Lizenzvereinbarung (EULA); anschließend wird die Installation fortgesetzt. Mit einem Klick auf Close geben Sie an, dass Sie die EULA-Bedingungen nicht akzeptieren. Der Installationsvorgang wird daraufhin abgebrochen.

Wenn die Softwareerweiterung Power Analyzer by Keysight installiert ist, können Sie:

 
 
 
 
 
  • ein neues Power-Analysis-Dokument hinzufügen oder ein vorhandenes öffnen; 

  • Button, Manage Power Nets den Power Analyzer und die Versorgungsnetze konfigurieren; 

  • Button, Show Power Net in Tree die Baumstruktur der Netze untersuchen;

  • Button, Show the Power Net Analysis on the PCB vorhandene Ergebnisse der Versorgungsanalyse untersuchen;

  • Button, View the Power Net Analysis results as a Report vorhandene Berichte anzeigen und neue Berichte aus vorhandenen Ergebnissen der Versorgungsanalyse erstellen.

Um jedoch eine neue Versorgungsanalyse durchzuführen, benötigen Sie ein gültiges Abonnement für Power Analyzer by Keysight. Andernfalls wird beim Versuch, eine Versorgungsanalyse zu starten, das Dialogfeld Analyze Your Power Nets geöffnet, in dem Sie eine kostenlose Testversion anfordern können ().

Starten des Power Analyzer

Um mit dem Power Analyzer zu arbeiten, öffnen Sie das Leiterplattendokument des Projekts oder einen seiner Schaltpläne und wählen Sie in den Hauptmenüs Tools » Power Analyzer by Keysight aus.

Das Power-Analyzer-Keysight-Dokument (<ProjectName>.pdnaK) wird geöffnet und dem Bereich Source Documents des Projekts (im Panel Projects) hinzugefügt, wie unten dargestellt.

Der Befehl Power Analyzer by Keysight ist im Menü nicht verfügbar? Prüfen Sie, ob die Erweiterung installiert ist und Sie über ein entsprechendes Abonnement verfügen (mehr erfahren).

Der Power Analyzer kann sowohl über die Menüs des Schaltplaneditors als auch über die des PCB-Editors gestartet werden. Da der Power Analyzer jedoch die Leiterplattenstrukturen simuliert, müssen alle am Schaltplan vorgenommenen Designänderungen mit der Leiterplatte synchronisiert werden, bevor sie im Analysedokument erkannt werden können (*.pdnaK). Falls eine Designänderung nicht erkannt wurde, speichern und schließen Sie das Analysedokument und öffnen Sie es erneut.

Vorbereitung der Analyse

Sie sind bereit für eine Analyse, aber beim Klicken auf die Schaltfläche Analyze öffnet sich ein Dialog, der Zugang zu einer Testversion anbietet? Prüfen Sie, ob die Erweiterung installiert ist und Sie über ein entsprechendes Abonnement verfügen (mehr erfahren).

Der Power Analyzer benötigt die physikalischen Eigenschaften Ihrer Leiterplatte. Dazu gehören die maximalen Stromdichten für die Außen- und Innenlagen, die minimalen und maximalen Via-Durchmesser, die Kupferart, die Betriebstemperatur usw. Diese Eigenschaften werden im Bereich Configuration des Analysedokuments definiert.

Konfigurationsoptionen

  • Die Werte für die maximale Stromdichte und den maximalen Via-Strom sind für alle Netze gleich, da sie von der Kupfergeometrie abhängen.

  • Die Einstellungen unter Max Current Density for Surface / Internal Layers geben den zulässigen Wert für die entsprechenden Lagen der Leiterplatte an.

  • Der maximale Strom in Vias wird für die kleinsten und größten im Projekt verwendeten Bohrungen angegeben. Die Bohrungsdurchmesser werden in den Feldern Min Via Diameter und Max Via Diameter definiert, zusammen mit dem für die jeweilige Bohrungsgröße zulässigen Wert für Max Current.

  • Die Software unterteilt das Leiterplattenlayout während der Simulation in ein Berechnungsnetz. Standardmäßig wird eine dynamische Maschenweite verwendet. Durch Aktivieren des Kontrollkästchens Simulation Mesh Size können Sie die gewünschte Maschenweite festlegen.

  • Standardmäßig wird das Massennetz von den Heatmap-Ergebnissen ausgeschlossen. Um das Massennetz einzubeziehen, deaktivieren Sie das Kontrollkästchen Skip Ground und wählen Sie dann das GND-Netz in der Dropdown-Liste Network / Net oben im Panel Power Analysis by Keysight aus, um die Heatmap-Ergebnisse zu untersuchen. Beachten Sie, dass die Heatmap Polygonstrukturen auf Signallagen unterstützt, das Verhalten einer Versorgungslage jedoch nicht simuliert werden kann.

  • Das Feld Copper Type legt die verwendete Kupferart zusammen mit den zugehörigen Parametern und den Temperaturparametern fest. 

  • Work Temperature dient zur Bestimmung des spezifischen Widerstands der Leiter, während Temperature Compensation eine materialeigene Kenngröße im Zusammenhang mit der Wärmeleitfähigkeit ist. Verschiedene Materialien haben unterschiedliche Wärmeleitkoeffizienten und beeinflussen dementsprechend die Erwärmung des Materials in Abhängigkeit von der Last. Diese Erwärmung beeinflusst den Innenwiderstand des Materials, was sich wiederum auf den Spannungsabfall auswirkt.

  • Der im Bereich Global PCB Parameters angezeigte Wert für Via Plating Thickness wird im Panel Properties des Layer Stack Manager definiert – mehr erfahren.

Passen Sie diese Standardwerte bei Bedarf an Ihr Design an.

Neben der maximalen Stromdichte und dem maximalen Via-Strom muss für jedes definierte Versorgungsnetz der zulässige Spannungsabfall angegeben werden. Konfigurieren Sie DC Drop Limit für jedes Netz, indem Sie entweder einen vordefinierten Prozentsatz auswählen oder einen Wert für Custom eingeben.

Die Auto-Define Settings werden vom Power Analyzer verwendet, wenn er versucht, die Versorgungsnetze Ihres Designs automatisch zu bestimmen. Dazu muss er wissen, wie Schaltungselemente wie Spannungsregler, Steckverbinder und in Reihe geschaltete Bauteile erkannt werden können. Neben Hinweisen wie den Präfixen der Bauteilbezeichner können Sie bestimmten Bauteilen auch Parameter hinzufügen, um die automatische Erkennung zu verbessern. Weitere Informationen finden Sie im Abschnitt Anforderungen für die automatische Erkennung.

Ein Versorgungsnetz für die Simulation hinzufügen

Um ein Versorgungsnetz für die Simulation hinzuzufügen, klicken Sie oben links auf die Schaltfläche , um den Dialog Manage Nets zu öffnen. Aktivieren Sie das Kontrollkästchen für Power Net Name und konfigurieren Sie die zugehörigen Reference Net. Wenn ein Netz im Schaltplan kein Power-Port-Objekt besitzt, wird es nicht in der Liste Power Net Name angezeigt. Klicken Sie auf Show Custom Nets, um alle Netze des Designs einzubeziehen. Bei Bedarf können mehrere Versorgungsnetze aktiviert werden. Hierarchische Beziehungen zwischen Versorgungsnetzen werden automatisch aufgelöst, sobald das Versorgungsnetz vollständig konfiguriert ist.

Jedes Versorgungsnetz benötigt eine Stromquelle. Diese werden als Nächstes konfiguriert.

Sie können auch auf die Schaltfläche  klicken, damit die Software die Versorgungsnetze für Sie erstellt. Dazu versucht sie, die Topologie des Projekts anhand der aktuellen Einstellungen im Bereich Auto-Define Settings des Abschnitts Configuration im Analysedokument (*.pdnaK) automatisch zu erkennen.

Eine Stromquelle hinzufügen

Um eine Stromquelle hinzuzufügen, klicken Sie im Abschnitt Sources des gewünschten Versorgungsschaltkreises auf + (oder auf das zugehörige Bedienelement Verwalten). Wenn der Schaltkreis mehrere Stromquellen enthält, klicken Sie auf Verwalten und wählen Sie die übrigen Bauteile aus.

Damit ein Bauteil als Quelle verfügbar ist, muss es mit dem ausgewählten Power Net verbunden sein. Die Verbindung zum ausgewählten Reference Net kann jedoch über ein beliebiges Bauteil erfolgen, das mit diesem Reference Net verbunden ist.

Die Bauteilkarte

Jedes Bauteil, das als Quelle oder Last einbezogen wird, wird im Power Analyzer-Dokument durch eine Component Card dargestellt.

  • Bewegen Sie den Mauszeiger über die Bauteilkarte, um die Schaltflächen Edit und Delete anzuzeigen.
  • Doppelklicken Sie auf die Bauteilkarte, um den Dialog Properties für dieses Bauteil zu öffnen.
  • Klicken Sie auf den Wert Design Item Id, um das entsprechende Bauteil im Schaltplan per Cross-Probing aufzurufen. Die Zoomstufe für das Cross-Probing wird im Abschnitt Highlight Methods auf der Seite System - Navigation des Dialogs Preferences festgelegt.
  • Bearbeiten Sie den Hauptanalysewert dieses Bauteils direkt in der Karte (oder bearbeiten Sie das Bauteil, um auf alle Eigenschaften zuzugreifen).

Ein Netz erweitern

Versorgungsnetze auf der Leiterplatte können durch passive Elemente wie Sicherungen oder Widerstände verlaufen, auf deren anderer Seite sich ein anderes Netz befindet. In diesem Fall wird empfohlen, extend the net, indem ein dazwischenliegendes Bauteil und dessen zweites Netz als Teil des Hauptnetzes einbezogen werden. Hierzu dient die Funktion Extend Nets.

Um ein Netz zu erweitern, klicken Sie auf das Symbol +Netze erweitern neben seinem Namen, um den Dialog <PowerNet> Extensions Manager zu öffnen. Klicken Sie auf +, um das gewünschte Netz zu erweitern. Der Power Analyzer zeigt nur Netze an, die über ein einzelnes Erweiterungsbauteil verbunden werden können. Sobald Sie das Netz mit Add erweitern, wird im Dialog <PowerNet> Extensions Manager automatisch ein zugehöriges Bauteil hinzugefügt, das Sie bei Bedarf ändern können.

Versorgungsnetze können über ein in Reihe geschaltetes Bauteil erweitert werden.Versorgungsnetze können über ein in Reihe geschaltetes Bauteil erweitert werden.

Anschließend können Sie das Netz weiter erweitern, indem Sie auf das Symbol + klicken, wie in der folgenden Abbildung gezeigt. Klicken Sie abschließend im Dialog <PowerNet> Extensions Manager auf Speichern.

Fügen Sie weitere in Reihe geschaltete Bauteile und Netze hinzu.Fügen Sie weitere in Reihe geschaltete Bauteile und Netze hinzu.

Hinweise zum Erweitern eines Netzes

  • Für jedes in Reihe geschaltete Bauteil können Sie den Spannungsabfall, den Widerstand und den maximal zulässigen Strom festlegen. Diese Werte werden bei der Analyse berücksichtigt (Bild anzeigen).

  • Wenn Sie ein falsches Netz definieren, können Sie es löschen, indem Sie den Mauszeiger über seinen Namen bewegen und auf das eingeblendete Löschsymbol klicken.

  • Sobald das erweiterte Netz gespeichert wurde, erscheinen die daran angeschlossenen Bauteile in der Liste der Lasten und können hinzugefügt werden.

  • Neben dem Namen des Versorgungsnetzes sehen Sie die Anzahl der hinzugefügten Erweiterungen. Bewegen Sie den Mauszeiger über die Zahl, um die Namen der Erweiterungsnetze anzuzeigen (wie in der obigen Abbildung gezeigt).

  • Die Simulationsunterstützung für parallel geschaltete Bauteile in einem erweiterten Netz wurde mit Version V1.0.6 der PABK-Erweiterung hinzugefügt, die Unterstützung in der Benutzeroberfläche mit Version V1.0.9. Um parallel geschaltete Bauteile zu definieren, wählen Sie das Netz im eingeblendeten Dialog Extensions Manager aus und aktivieren Sie dann alle parallel geschalteten Bauteile, wie in der folgenden Abbildung gezeigt. Bewegen Sie den Mauszeiger über die Abbildung, um den Dialog nach Abschluss der Netzerweiterung anzuzeigen.

    Wählen Sie alle parallel geschalteten Bauteile im Netz aus.Wählen Sie alle parallel geschalteten Bauteile im Netz aus.

Eine Last festlegen

Um ein Lastbauteil hinzuzufügen, klicken Sie im Abschnitt Loads auf + (oder das zugehörige Steuerelement Verwalten) und wählen Sie anschließend das gewünschte Bauteil aus. Ein Bauteil wird im Dialog aufgeführt, wenn es mit dem Hauptnetz oder einem erweiterten Netz verbunden ist.

Nachdem Sie ein Bauteil hinzugefügt haben, können Sie seinen Verbrauch entweder direkt in seiner Bauteilkarte festlegen oder durch Klicken auf die Schaltfläche  den Dialog <NetName>/<LoadName> Load Properties öffnen.

Hinweise zum Konfigurieren einer Last

  • Definieren Sie die Lasteigenschaften, einschließlich Load Type, Total Load Current sowie Min und Max Voltage.
  • Prüfen Sie, ob das Versorgungsnetz IN sowie die Optionen Reference und Connected to reference through korrekt konfiguriert sind.
  • Der Laststrom wird automatisch gleichmäßig auf alle erkannten Versorgungspins verteilt. Passen Sie diese Werte bei Bedarf an.
  • Wenn Sie eine Last des Typs IC (Current) konfigurieren, sehen Sie alle Pins des Lastbauteils, die es über verschiedene in Reihe geschaltete Bauteile mit der Quelle verbinden, und können die benötigten Pins auswählen.

Der Dialog Manage Loads (oder Add Sources) enthält eine Spalte Design Item Id. Klicken Sie auf einen Eintrag in dieser Spalte, um über Cross-Probing zum entsprechenden Bauteil im Schaltplan zu springen. So können Sie leichter überprüfen, ob Sie das richtige Bauteil auswählen.

Die Zoomstufe für das Cross-Probing wird im Abschnitt Highlight Methods auf der Seite System - Navigation des Dialogs Preferences festgelegt.

Ein VRM festlegen

Um ein Spannungsreglermodul (VRM) zu definieren, fügen Sie es zunächst als Last hinzu. Öffnen Sie anschließend den Dialog Load Properties des Bauteils (klicken Sie auf die Schaltfläche ), um es zu konfigurieren.

Sobald eine Last als VRM konfiguriert wurde, erscheint sie auch als Quelle für das Versorgungsnetz, das als ihr Netz OUT festgelegt ist.Sobald eine Last als VRM konfiguriert wurde, erscheint sie auch als Quelle für das Versorgungsnetz, das als ihr Netz OUT festgelegt ist.

Hinweise zum Konfigurieren eines VRM

  • Legen Sie Load Type als VRM des gewünschten Typs fest.
  • Geben Sie die Ausgangsspannung im Feld Vout zusammen mit den übrigen Reglereigenschaften an.
  • Konfigurieren Sie die Netze IN und OUT im Bereich Nets Management des Dialogs.
  • Wenn das VRM nicht direkt mit dem Referenznetz verbunden ist oder eine andere Referenz verwendet, konfigurieren Sie die Optionen Reference und Connected to reference through entsprechend.
  • In der Hierarchie wird automatisch ein untergeordnetes Versorgungsnetz mit diesem VRM als Quelle erstellt (wie oben gezeigt).
  • Wenn das VRM mehr als ein Ausgangsnetz besitzt, fügen Sie alle erforderlichen Netze über den Link +Ausgangsnetz hinzufügen im Dialog Load Properties hinzu und geben Sie deren Ausgangsstrom in den jeweils eingeblendeten Feldern an.

Das konfigurierte Versorgungsnetz

Jedes konfigurierte Versorgungsnetz wird im Dokument *.pdnaK als separate, einklappbare Definition dargestellt. Das konfigurierte Netz PWR_IN ist unten mit seinen beiden untergeordneten Versorgungsnetzen 3V3 und 1V8 dargestellt, die leicht eingerückt sind, um ihren untergeordneten Status anzuzeigen.

Die Versorgungsnetzdefinition verstehen

  • Jedes Versorgungsnetz wird als separate, einklappbare Power Net Definition dargestellt.
  • Die Kopfzeile der Versorgungsnetzdefinition enthält:
    • Den Namen des Versorgungsnetzes 
    • Das Referenznetz 
    • Eine Anzeige der Anzahl zusätzlicher Netze (), falls das Netz erweitert wurde. Bewegen Sie den Mauszeiger darüber, um die Namen der untergeordneten Netze anzuzeigen.
    • Eine  -Schaltfläche. Klicken Sie darauf, um die Verbindungsstruktur der Bauteile in diesem Netz im Kontext der gesamten Versorgungsnetzhierarchie anzuzeigen.
    • Eine  -Schaltfläche. Klicken Sie darauf, um dieses Netz zusammen mit allen untergeordneten Netzen aus dem Analyseprozess zu entfernen.
    • Eine  -Schaltfläche. Klicken Sie darauf, um dieses Netz zusammen mit allen untergeordneten Netzen zu analysieren.
  • Jedes Bauteil im Netz wird durch eine Bauteilkarte dargestellt.
  • Nach der Analyse des Netzes werden die Ergebnisse für Voltage Drop, Current Density und Max Via Current für dieses Netz in der Versorgungsnetzdefinition angezeigt, wie in der obigen Abbildung gezeigt.
    • Jede Anzeige stellt den simulierten Wert im Verhältnis zum festgelegten Grenzwert dar. Liegt der Wert deutlich innerhalb des Grenzwerts, ist die Skalenlinie grün. Liegt er nahe am Grenzwert, ist die Linie gelb. Wird der Grenzwert überschritten, ist sie rot. 
    • Klicken Sie auf die Schaltfläche  , um zum PCB-Editor zu wechseln und die Kupferflächen dieses Netzes auf der Leiterplatte anzuzeigen. Verwenden Sie im PCB-Editor das Panel Power Analyzer by Keysight, um den Analyseprozess zu steuern.
    • Klicken Sie auf die Schaltfläche  , um einen detaillierten Bericht zu diesem Versorgungsnetz zu erstellen und zu öffnen. Verwenden Sie innerhalb des Berichts  Schaltfläche, um eine HTML-Kopie zu speichern.

Die Baumansicht der Versorgungsnetze

Wechseln Sie zur Baumansicht des konfigurierten Versorgungsnetzes (und aller über VRMs definierten Unternetze), indem Sie auf die zugehörige  Schaltfläche klicken. Die gesamte Struktur wird angezeigt, wobei das jeweilige Versorgungsnetz und die zugehörigen Komponenten entsprechend hervorgehoben werden.

In der Baumansicht können Sie schnell beurteilen, ob das gesamte Versorgungsnetzwerk wie erforderlich definiert wurde und für die Analyse bereit ist. Um zum Hauptfenster zurückzukehren, klicken Sie auf den Link Power Analyzer by Keysight oben links im Dokument .pdnaK.

Eine Analyse ausführen

Nach Abschluss der Konfiguration können Sie die Analyse für ein bestimmtes Netz starten, indem Sie auf die zugehörige  Schaltfläche klicken. Eine Zusammenfassung der Analyseergebnisse wird in der Versorgungsnetzdefinition angezeigt, wie unten dargestellt. Um die Ergebnisse auf der Leiterplatte zu sehen, klicken Sie auf die zugehörige  Schaltfläche.

Um alle konfigurierten Netze in einem Schritt zu analysieren, klicken Sie auf die  Schaltfläche (oben rechts im Analysedokument). Wenn Sie das Versorgungsnetz auf der obersten Ebene der Baumstruktur analysieren, werden auch alle Unternetze (die über VRM-Komponenten erstellt wurden) analysiert. Wenn alle Netze analysiert wurden, können Sie über das Dropdown-Menü Network/Net oben im Panel Power Analyzer by Keysight auswählen, welches Netz aktuell hervorgehoben wird. 

Ebenenverwaltung

Sie können die Ebenen der Simulation genauso wechseln wie bei der Arbeit an der Leiterplatte – über die Ebenenregisterkarten am unteren Rand des PCB-Editorfensters. Mit dem Tastenkürzel Shift+S können Sie außerdem die aktuelle Ebene in den Fokus rücken. Verwenden Sie dieses Tastenkürzel, um die Sichtbarkeitsoptionen des Einzelebenenmodus zu durchlaufen.

Mit den Ebenenregisterkarten der Leiterplatte können Sie die Anzeige der Analyseergebnisse schnell umschalten. Hier sind die Ergebnisse für die oberste Ebene dargestellt. Bewegen Sie den Mauszeiger über das Bild, um die Ergebnisse für die unterste Ebene anzuzeigen.Mit den Ebenenregisterkarten der Leiterplatte können Sie die Anzeige der Analyseergebnisse schnell umschalten. Hier sind die Ergebnisse für die oberste Ebene dargestellt. Bewegen Sie den Mauszeiger über das Bild, um die Ergebnisse für die unterste Ebene anzuzeigen.

Das Panel „Power Analyzer by Keysight“

Im PCB-Editor werden der Analyseprozess und die Ergebnisse über das Panel Power Analyzer by Keysight gesteuert. Beachten Sie, dass das Panel erst dann zur Liste der verfügbaren Panels (über die Schaltfläche Panels) hinzugefügt wird, nachdem eine Versorgungsnetzanalyse durchgeführt und auf die  Schaltfläche geklickt wurde.  

Netzwerk / Netz

  • Network / Net – dient zur Auswahl des Netzwerks () oder Netzes (), das im grafischen Arbeitsbereich als Heatmap angezeigt werden soll.
  • Only nets with violations – Wenn diese Option aktiviert ist (Standardeinstellung), stehen im Dropdown-Menü nur Netze zur Verfügung, die aktuell eine Verletzung aufweisen. Deaktivieren Sie diese Option, um alle Versorgungsnetze aufzulisten. 
  • Verwenden Sie die üblichen Methoden des PCB-Editors zum Verschieben und Zoomen der Ansicht im Arbeitsbereich, um die Simulationsergebnisse zu untersuchen.

Unterhalb der Auswahl Network / Net verfügt das Panel über zwei Registerkarten: General und Heatmap. Die Optionen auf diesen Registerkarten gelten für das Netz, das aktuell im Dropdown-Menü Network / Net ausgewählt ist.

Wählen Sie das anzuzeigende Netz aus und konfigurieren Sie anschließend die allgemeinen oder die Heatmap-Optionen für dieses Netz.Wählen Sie das anzuzeigende Netz aus und konfigurieren Sie anschließend die allgemeinen oder die Heatmap-Optionen für dieses Netz.

Heatmap

Auf der Registerkarte Heatmap im Panel Power Analyzer by Keysight legen Sie fest, welche Daten als Heatmap dargestellt werden – entweder die Stromdichte oder der Spannungsabfall – und wie die Stromdichte bzw. der Spannungsabfall farblich dargestellt wird.

Verwenden Sie die Registerkarte Heatmap  des Panels Power Analyzer by Keysight, um die auf der Leiterplatte dargestellten Simulationsergebnisse zu ändern. Hier werden die Ergebnisse für die Stromdichte angezeigt. Bewegen Sie den Mauszeiger über das Bild, um die Ergebnisse für den Spannungsabfall anzuzeigen.Verwenden Sie die Registerkarte Heatmap des Panels Power Analyzer by Keysight, um die auf der Leiterplatte dargestellten Simulationsergebnisse zu ändern. Hier werden die Ergebnisse für die Stromdichte angezeigt. Bewegen Sie den Mauszeiger über das Bild, um die Ergebnisse für den Spannungsabfall anzuzeigen.

Die Optionen für jeden dieser Modi werden im Folgenden beschrieben.

Heatmap für die Stromdichte
  • Das gesamte Netz wird so eingefärbt, dass die Stromdichte an jeder Stelle des Netzes erkennbar ist. Je höher die Stromdichte, desto wärmer (röter) ist die Farbe. 
  • Show Heatmap – Mit diesem Bedienelement können Sie die Heatmap schnell entfernen und die Standardansicht der Leiterplatte wiederherstellen. 
  • Show Arrows of Current Direction – Aktivieren Sie diese Option, um kleine Pfeile anzuzeigen, die die Stromflussrichtung im gesamten Netz angeben.
  • Use Noise Suppression – Wenn sich der berechnete Strom null nähert, vermitteln die Pfeile für die Stromrichtung den Eindruck, dass in diesem Bereich Strom fließt, obwohl praktisch keiner vorhanden ist. Aktivieren Sie diese Option, um diese niedrigen, möglicherweise irreführenden Stromwerte auszublenden.
  • Scope Controller – Wie das Netz zur Darstellung der Intensität bzw. Wärme eingefärbt wird, wird über Scope Controller. gesteuert. Der Wert Max entspricht standardmäßig der maximal berechneten Stromdichte in diesem Netz (Bild anzeigen), und Min ist standardmäßig auf 0 A/mm2 eingestellt. Diese Skala wird als Farbbalken unterhalb der Leiterplatte angezeigt und berücksichtigt die aktuellen Min- und Max-Einstellungen, eine durch den ausgewählten Skalentyp bestimmte Skalierung sowie die Einheiten. Die Werte Min und Max lassen sich durch Klicken und Ziehen am Schieberegler oder durch Eingabe eines neuen Werts in die Felder Min bzw. Max anpassen. Berechnete Werte unterhalb von Min werden blau und Werte oberhalb von Max rot dargestellt. 
  • Use Logarithmic Scale – Aktivieren Sie diese Option, um von einer linearen zu einer logarithmischen Skala zu wechseln. Eine logarithmische Skala bewirkt, dass sich höhere Werte zum Ende hot der Farbskala hin konzentrieren. Sie können beispielsweise die logarithmische Skala aktivieren, um schnell Leiterbahnabschnitte mit höheren Strömen zu finden, und anschließend zur linearen Skala wechseln, um die Verteilung der Stromdichten innerhalb dieses Leiterbahnabschnitts zu untersuchen.

Die logarithmische Stromdichte-Heatmap zeigt einen kritischen Bereich. Bewegen Sie den Mauszeiger über das Bild, um diesen Bereich mit linearer Skalierung anzuzeigen.Die logarithmische Stromdichte-Heatmap zeigt einen kritischen Bereich. Bewegen Sie den Mauszeiger über das Bild, um diesen Bereich mit linearer Skalierung anzuzeigen.

Heatmap für den Spannungsabfall
  • Das gesamte Netz wird eingefärbt, um den Spannungsabfall an jeder Stelle entlang des Netzes darzustellen. Je höher die Spannung, desto wärmer (röter) ist die Farbe. Bei dieser Darstellung gilt: Je kälter die Farbe, desto niedriger die Spannung (und desto größer der Spannungsabfall). 
  • Show Heatmap - Mit diesem Steuerelement können Sie die Heatmap schnell entfernen und die Standarddarstellung der Leiterplatte wiederherstellen. 
  • Show Arrows of Current Direction - Aktivieren Sie diese Option, um kleine Pfeile anzuzeigen, die die Stromflussrichtung im gesamten Netz angeben.
  • Use Noise Suppression - Wenn sich der berechnete Strom null nähert, erwecken die Stromrichtungspfeile den Eindruck, dass in diesem Bereich Strom fließt, obwohl praktisch keiner vorhanden ist. Aktivieren Sie diese Option, um diese niedrigen, potenziell irreführenden Stromwerte auszublenden.
  • Scope Controller - Wie das Netz zur Darstellung der Intensität bzw. Wärme eingefärbt wird, wird über Scope Controller. gesteuert. Der Wert für Max liegt standardmäßig knapp unter der angegebenen maximalen Spannung für dieses Netz, und der Wert für Min beträgt Max - calculated voltage drop (Bild anzeigen). Diese Skala wird als farbiger Balken unterhalb der Leiterplatte angezeigt und stellt Folgendes dar: den Spannungsabfall als Absolutwert oder Prozentsatz, die aktuellen Min.- und Max.-Einstellungen sowie die Einheiten. Die Werte für Min und Max können durch Klicken und Ziehen der Schiebereglergriffe oder durch Eingabe eines neuen Werts in die Felder Min oder Max angepasst werden. Berechnete Werte unterhalb von Min werden blau und Werte oberhalb von Max rot dargestellt. 
  • Scale Type - Die Skala für den Spannungsabfall kann entweder in Volt (klicken Sie auf die Schaltfläche  ) oder als Prozentsatz (klicken Sie auf die Schaltfläche  ) angegeben werden.
  • Enable Visual Slider for Voltage Contour - Wenn diese Option aktiviert ist, werden auf der Heatmap die Stellen angezeigt, an denen die Spannung den angegebenen Spannungskonturpunkten entspricht. So können Sie diese Stellen leicht identifizieren. Die Werte der Konturpunkte können durch Ziehen der Schieberegler oder durch Eingabe von Werten in die darunterliegenden Felder Voltage Contour Points angepasst werden. Durch Klicken auf das entsprechende Symbol können Sie weitere Punkte hinzufügen und vorhandene Punkte entfernen.

Konturpunkte lassen sich so konfigurieren, dass Sie schnell die Stellen auf der Leiterplatte finden, an denen die Spannung dem jeweiligen Wert entspricht.Konturpunkte lassen sich so konfigurieren, dass Sie schnell die Stellen auf der Leiterplatte finden, an denen die Spannung dem jeweiligen Wert entspricht.

Erkennung von Verstößen

Wenn die Simulation einen Verstoß des Typs Voltage Drop, Current Density oder Max Via Current erkennt, wird dieser im Bereich Violations des Panels Power Analyzer by Keysight aufgeführt. Klicken Sie auf einen Verstoß im Panel, um per Cross-Probing zur entsprechenden Stelle auf der Leiterplatte zu springen, an der dieser Fehler aufgetreten ist. Wenn Sie die Beschreibung des Verstoßes nicht vollständig lesen können, bewegen Sie den Mauszeiger über den Beschreibungsbereich des Verstoßes, um einen Tooltip mit allen Details anzuzeigen.

Verstöße werden automatisch im Bereich Violations des Panels Power Analyzer by Keysight detailliert aufgeführt. Bewegen Sie den Mauszeiger über das Bild, um einen Verstoß beim Via-Strom anzuzeigen.Verstöße werden automatisch im Bereich Violations des Panels Power Analyzer by Keysight detailliert aufgeführt. Bewegen Sie den Mauszeiger über das Bild, um einen Verstoß beim Via-Strom anzuzeigen.

Beachten Sie, dass der Heatmap-Modus (Stromdichte oder Spannungsabfall) automatisch anhand des Verstoßtyps ausgewählt wird, auf den Sie klicken. 

Messsonden

Im Bereich „Messsonden“ des Panels Power Analyzer by Keysight können Sie Messsonden direkt auf der Leiterplatte platzieren. Messsonden können entweder die Stromdichte oder den Spannungsabfall messen. Die Art der Messung wird durch den aktuellen Heatmap-Modus der Leiterplatte bestimmt.

Es gibt folgende Arten von Messsonden:

  1. Eine Einzelsonde zur Messung eines Absolutwerts an der Sondenposition oder
  2. eine Differenzsonde zur Messung der Differenz zwischen zwei Sondenpositionen. 

Beide Arten von Messsonden werden durch Klicken auf die Schaltfläche  im Bereich Probes des Panels platziert. Um eine Einzelsonde zu platzieren, klicken Sie auf die gewünschte Position und anschließend mit der rechten Maustaste (oder drücken Sie Esc). Um eine Differenzsonde zu platzieren, klicken Sie einmal, um die erste Sondenposition festzulegen, und dann ein zweites Mal, um die zweite Sondenposition festzulegen. Sobald eine Messsonde definiert wurde, werden die Messergebnisse im Panel angezeigt.

Beim Platzieren einer Messsonde gelten dieselben Fangfunktionen wie beim Platzieren anderer Designobjekte im PCB-Editor. Weitere Informationen zum einheitlichen Cursor-Fangsystem finden Sie auf der Seite Arbeiten mit dem Cursor-Fangsystem.

Klicken Sie auf die Schaltfläche  , um ein Bild der Leiterplatte an der zuletzt angeklickten Sondenposition zu erstellen. Das Bild wird im Bereich Image Captures des Panels angezeigt und ist mit einer Kennzeichnung Probe versehen. Bewegen Sie den Mauszeiger über den Screenshot, um die Details der Messsonde anzuzeigen (Bild anzeigen). 

Messsonden können Spannung oder Strom messen, entweder als Absolutwert oder als Differenz zwischen zwei Positionen. Bewegen Sie den Mauszeiger über das Bild, um eine Strommesssonde anzuzeigen.Messsonden können Spannung oder Strom messen, entweder als Absolutwert oder als Differenz zwischen zwei Positionen. Bewegen Sie den Mauszeiger über das Bild, um eine Strommesssonde anzuzeigen.

Wenn das Design in irgendeiner Weise geändert wird, müssen vorhandene Messsonden gelöscht () und neue Messsonden platziert werden.

Bildaufnahmen

Mit der Bildaufnahmefunktion im Panel Power Analyzer by Keysight können Sie einen designspezifischen Screenshot des ausgewählten Netzes erstellen, der anschließend in einen Bericht aufgenommen werden kann.

Um ein Bild eines bestimmten Bereichs der Leiterplatte aufzunehmen, richten Sie zunächst die Ansicht der Leiterplatte im Hauptdesignbereich so ein, dass die gewünschten Elemente sichtbar sind. Klicken Sie anschließend auf die Schaltfläche   im Bereich Image Captures des Panels, um den Screenshot aufzunehmen. Sie können die Ansicht der Leiterplatte weiter ändern und mit Add weitere Bilder aufnehmen. Um ein Bild zu löschen, bewegen Sie den Mauszeiger darüber, sodass die Schaltfläche  angezeigt wird, und klicken Sie dann einmal darauf.

Bildaufnahmen werden nicht mit dem Projekt gespeichert. Um Bilder zu speichern, erstellen Sie einen Analysebericht.

Analysebericht

Um einen vollständigen Analysebericht zu erstellen, klicken Sie auf die Schaltfläche  oben im Analysedokument. Der vollständige Bericht enthält einen Abschnitt für jedes Versorgungsnetz im Netzwerk, wie im folgenden Bild gezeigt. 

Klicken Sie im Bericht auf ein Versorgungsnetz, um einen detaillierten Bericht dazu anzuzeigen, der Folgendes enthält:

  • Globale Konfigurationseinstellungen
  • Lagenaufbau der Leiterplatte
  • Stromdichte-Heatmaps für jede Signallage
  • Spannungsabfall-Heatmaps für jede Signallage
  • Die Baumansicht des Versorgungsnetzwerks mit hervorgehobenem ausgewähltem Netz.
  • Analysedetails für das ausgewählte Netz, darunter: Leistungsaufnahme; Details zu Reserven und Bestanden/Nicht-bestanden-Ergebnissen; eine detaillierte Zusammenfassung des Verhaltens aller Vias in diesem Netz; alle benutzerdefinierten Bildschirmaufnahmen.

  • Klicken Sie auf die Schaltfläche  , um den Bericht im HTML-Format zu speichern. Im anschließend angezeigten Dialogfeld Save Report Settings können Sie festlegen, welche Netzwerke und spezifischen Daten in den Bericht aufgenommen werden sollen.
  • Der Bericht wird in einem Unterordner des Projektordners mit dem Namen \PowerAnalyzerByKeysight_Output\HTMLReport\<ProjectName> [PDNA]_<CurrentDate>_<CurrentTime> gespeichert.
  • Alle Bilder des Berichts werden im Unterordner \Images gespeichert.
  • Während der Analyse werden außerdem mehrere Protokolldateien erstellt. Diese werden ebenfalls in einem Unterordner des Projektordners mit dem Namen \PowerAnalyzerByKeysight_Output\<BoardName>\ gespeichert.

Voraussetzungen für die automatische Erkennung

Neben dem manuellen Hinzufügen von Versorgungsnetzen bietet Power Analyzer by Keysight die Möglichkeit, Versorgungsnetze einschließlich Quellen und Lasten automatisch zu erkennen und hinzuzufügen. Dadurch lässt sich eine Versorgungsstruktur schneller definieren.

Einstellungen für die automatische Definition

Bevor Sie die automatische Erkennung starten, müssen Sie zunächst die Parameter des Algorithmus an Ihr Projekt anpassen. Diese Parameter werden im Bereich Auto-Define Settings des Abschnitts Configuration im Dokumentfenster von Power Analyzer by Keysight konfiguriert.

Bauteile, die diese Kriterien für die automatische Definition nicht erfüllen, werden als normale Lasten behandelt. Sie können einzelnen Schaltplanbauteilen auch benannte Parameter hinzufügen, die den Typ und die Eigenschaften des jeweiligen Bauteils im Versorgungssystem definieren. Diese Parameter können beim Erstellen des Bauteils angegeben oder später im Schaltplan hinzugefügt werden.

Parameter für Bauteile

Für eine korrekte Erkennung sollten alle versorgungsrelevanten Bauteile die folgenden Kriterien erfüllen:

  • Damit ein Quellenbauteil automatisch erkannt wird, sollte es einen Parameter mit dem Namen Component Type und dem Wert Source besitzen.

  • Wird der Parameter nicht gefunden, erfolgt die Suche anhand von Default Connectors Designators, die im Bereich Auto-Define Settings des Abschnitts Configuration im Analysedokument (*.pdnaK) definiert sind. Beachten Sie, dass nur Steckverbinder mit Versorgungsanschlüssen definiert werden, sofern sie nicht als Teil eines erweiterten Netzes referenziert werden.
  • Spannungsreglermodule (VRMs):
    • Linearregler sollten einen Parameter mit dem Namen Component Type und dem Wert VRM besitzen.
    • Bei einem VRM-Regler vom Typ SMPS muss der Parameter Component Type den Wert SMPS haben.
    • Wenn das VRM eine Sense-Funktion umfasst, muss der Parameter Component Type den Wert Sense haben.

  • Ist der Parameter nicht definiert, erfolgt die Suche anhand der VRM Keywords, die im Bereich Auto-Define Settings des Abschnitts Configuration im Analysedokument definiert sind. Standardmäßig sind dies die folgenden Schlüsselwörter: PWR, REG, Regulator, Voltage, Switch.

  • Die Stromaufnahme des Bauteils (Last) sollte über einen Parameter mit dem Namen Current Consumption definiert werden. Achten Sie auf das im Wert verwendete Dezimaltrennzeichen: Je nach Systemeinstellung kann dies ein Punkt oder ein Komma sein.

Wenn ein Bauteil den Parameter „Current Consumption“ besitzt, wird der angegebene Wert auf alle Pins aufgeteilt, die mit demselben Stromkreis verbunden sind.

Parametersynchronisierung

Alle Parameter müssen zwischen PCB und Schaltplan synchronisiert sein. Dies können Sie überprüfen, indem Sie ein Bauteil auf der PCB auswählen und sicherstellen, dass die Parameter für die Versorgungsanalyse auf der Registerkarte Parameters des Panels Properties vorhanden sind.

Für das Design

  • Alle Versorgungsnetze sollten wie folgt definiert sein:
    • mithilfe eines Power Port -Objekts,
    • mit einer konfigurierten Eigenschaft „Power Net“, sodass das Netz Supply Net Parameter enthält (wie unten beschrieben),
    • oder mit einem Namen, der von Name Mask erkannt wird (definiert im Bereich Auto-Define Settings des Abschnitts Configuration im Analysedokument).
  • Um mithilfe von Name Mask einen Spannungswert zu ermitteln, sollte der Name des Versorgungsnetzes dem Format *V* oder *.*V entsprechen, wobei * ein numerischer Wert ist, wie in der Abbildung unten gezeigt.

  • Alternativ können Sie den Spannungswert für das Versorgungsnetz festlegen, indem Sie die Eigenschaft Power Net konfigurieren, die im Panel Properties für eine beliebige Leitung im Netz definiert ist. Um die Eigenschaft zu aktivieren, platzieren Sie zunächst eine Parameter-Set-Direktive (Place » Directives » Parameter Set) auf dem Netz (bewegen Sie den Mauszeiger über die Abbildung unten, um diesen Vorgang zu sehen). Größe, Farbe und Beschriftung sind frei wählbar; allein das Vorhandensein der Direktive aktiviert die Eigenschaft Power Net dieses Netzes. Nachdem Sie die Direktive hinzugefügt haben, wählen Sie eine Leitung in diesem Netz aus, aktivieren die Eigenschaft Power Net und konfigurieren Voltage des Netzes wie unten gezeigt. 

  • Serienbauteile sollten den definierten Referenzbezeichnern für Widerstände, Induktivitäten und benutzerdefinierte Serienbauteile entsprechen (wie im Bereich Auto-Define Settings des Abschnitts Configuration im Analysedokument definiert).

  • VRMs sollten mit mindestens zwei Versorgungsnetzen verbunden sein.

Power Analyzer-Befehle

Die folgenden Befehle stehen in den Hauptmenüs des Power Analyzer-Editors zur Verfügung.

Befehl

Zusammenfassung und Verwendung

Tools » Define Automatically

Versucht, die Topologie des Projekts anhand der aktuellen Einstellungen im Bereich Auto-Define Settings des Abschnitts Configuration im Analysedokument (*.pdnaK) automatisch zu erkennen. Sie können diesen Befehl auch durch Klicken auf die Schaltfläche Define Automatically oben links im Editor aufrufen.

File » Load from File

Lädt ein gespeichertes Power Analyzer by Keysight-Dokument (*.pdnaK) in den Power Analyzer-Editor.

Edit » Manage Nets

Öffnet den Dialog Manage Nets, in dem Sie die zu analysierenden Versorgungsnetze auswählen. Durch Aktivieren des Kontrollkästchens eines Netzes wird dieses dem Analysedokument (*.pdnaK) hinzugefügt. Durch Deaktivieren wird es zusammen mit allen untergeordneten Versorgungsnetzen aus dem Dokument entfernt. Sie können diesen Befehl auch durch Klicken auf die Schaltfläche Manage Nets oben links im Editor aufrufen. Erfahren Sie mehr über das Verwalten von Netzen.

File » Save

Speichert die aktuelle Power Analyzer-Konfiguration in einem Power Analyzer by Keysight-Dokument (*.pdnaK).

File » Save As

Speichert die aktuelle Power Analyzer-Konfiguration in einem Power Analyzer by Keysight-Dokument (*.pdnaK) unter einem neuen, benutzerdefinierten Namen.

Tools » Measurement Units » mil

Konfiguriert Power Analyzer für die Verwendung imperialer Maßeinheiten (mils).

Tools » Measurement Units » mm

Konfiguriert Power Analyzer für die Verwendung metrischer Maßeinheiten (mm).

Einschränkungen von Power Analyzer

Derzeit unterstützt Power Analyzer by Keysight Folgendes nicht:

  1. Negative Spannungen.
  2. Eingebettete Bauteile (Bauteile, die auf einer Innenlage platziert sind). Erfahren Sie mehr über das Entwerfen einer PCB mit eingebetteten Bauteilen.

 

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents