Draftsman-Platzierungs- und Bearbeitungstechniken

Auf einen Blick

Dieser Artikel erläutert die grundlegenden Techniken zum Platzieren und Bearbeiten von Objekten in einem Draftsman-Dokument in Altium Designer. Er zeigt den üblichen Platzierungsablauf, wie Sie vor dem Platzieren Standardeigenschaften für Objekte festlegen und auf welche Weise Sie Objekte nach dem Platzieren auf dem Blatt bearbeiten können. Außerdem stellt er praktische Werkzeuge und Funktionen vor: das Properties-Panel, die grafische Bearbeitung, Befehle zum Verschieben und Drehen, das Kopieren und Einfügen, die Bearbeitung mehrerer Objekte, den Format Painter und die Textsuche. So erhalten Sie einen klaren Überblick darüber, wie Sie Ihre Leiterplattenzeichnungen während der Arbeit verfeinern können. Wenn Sie Draftsman-Inhalte sicherer und effizienter anpassen und das Erscheinungsbild Ihrer Zeichnungen verbessern möchten, hilft Ihnen dieser Leitfaden dabei. Lesen Sie weiter.

- Lernen Sie den einheitlichen Arbeitsablauf zum Platzieren von Draftsman-Objekten kennen und erfahren Sie, wie Sie die Standardeinstellungen vor dem Platzieren festlegen.
- Entdecken Sie die wichtigsten Bearbeitungsmöglichkeiten nach dem Platzieren, darunter Änderungen über das Properties-Panel, die grafische Größenanpassung und Positionierung sowie Befehle zum Verschieben und Drehen.
- Erfahren Sie, wie Sie mit zusätzlichen Draftsman-Funktionen produktiver arbeiten, darunter Kopieren und Einfügen, die Bearbeitung mehrerer Objekte, der Format Painter und die Textsuche.
Mit KI tiefer einsteigen:

Zum Erstellen einer Leiterplattenzeichnung stehen verschiedene Objekte zur Verfügung. Der Designbereich des Draftsman-Editors kann eine große Anzahl von Designobjekten enthalten, aus denen sich die Zeichnung zusammensetzt. Während der Erstellung der Zeichnung müssen die Platzierung und die Eigenschaften dieser Objekte angepasst werden, um das gewünschte Erscheinungsbild zu erzielen.

Gemeinsamkeiten bei der Platzierung und Bearbeitung von Objekten

In Draftsman von Altium Designer ist der Ablauf beim Platzieren eines Objekts weitgehend gleich, unabhängig davon, welches Objekt platziert wird. Im einfachsten Fall gehen Sie wie folgt vor:

  1. Wählen Sie das zu platzierende Objekt an einer der folgenden Stellen aus:

    • Im Hauptmenü Place .

    • In der Active Bar am oberen Rand des Designbereichs.

    • Im Untermenü Place des Kontextmenüs des Designbereichs.

  2. Wenn ein Objekt zur Platzierung ausgewählt wird, werden gegebenenfalls Zeichnungsdaten aus der Quell-Leiterplattendatei abgerufen. Der Cursor wird zu einem Fadenkreuz und zeigt damit an, dass Sie sich im Bearbeitungsmodus befinden. Gegebenenfalls erscheint das Objekt „schwebend“ am Cursor. Positionieren Sie den Cursor und klicken Sie oder drücken Sie Enter, um das Objekt zu platzieren. Bei einigen Objekten, beispielsweise Bemaßungen, müssen Sie weitere Positionen durch Positionieren und Klicken festlegen, um alle relevanten Punkte des Objekts zu definieren.

  3. Nach dem Platzieren eines Objekts, das keine Ansicht ist, bleiben Sie im Platzierungsmodus (erkennbar am Fadenkreuz-Cursor), sodass Sie sofort ein weiteres Objekt desselben Typs platzieren können. Um den Platzierungsmodus zu beenden, klicken Sie mit der rechten Maustaste oder drücken Sie die Taste Esc . In einigen Fällen, etwa beim Platzieren eines Flächenobjekts, müssen Sie dies möglicherweise zweimal tun: einmal, um die Platzierung des Objekts abzuschließen, und einmal, um den Platzierungsmodus zu verlassen. Wenn Sie den Platzierungsmodus verlassen, nimmt der Cursor wieder seine Standardform an.

Bearbeitung vor der Platzierung

Die Standardeigenschaften eines Objekts können jederzeit auf der Seite Draftsman – Defaults des Dialogs Preferences  geändert werden. Die meisten Eigenschaften eines Objekts bzw. diejenigen, die sich sinnvoll vordefinieren lassen, stehen als bearbeitbare Standardeinstellungen zur Verfügung. Diese Eigenschaften werden beim Platzieren nachfolgender Objekte angewendet. Wählen Sie ein Objekt unter Primitive List aus, um dessen Optionen auf der rechten Seite anzuzeigen.

Über die Spalte Primitive List  können Sie auf die Eigenschaften von Objekten zugreifen und die Standardwerte nach Bedarf bearbeiten.
Über die Spalte Primitive List  können Sie auf die Eigenschaften von Objekten zugreifen und die Standardwerte nach Bedarf bearbeiten.

Bearbeitung nach der Platzierung

Nachdem ein Objekt platziert wurde, gibt es verschiedene Möglichkeiten, es zu bearbeiten. Diese werden im Folgenden beschrieben.

Das zugehörige Eigenschaften-Panel

Bei dieser Bearbeitungsmethode werden der zugehörige Modus des Panels Properties und der zugehörige Dialog verwendet, um die Eigenschaften eines platzierten Objekts zu ändern.

Das Panel passt seinen Inhalt automatisch an das ausgewählte Objekt an.
Das Panel passt seinen Inhalt automatisch an das ausgewählte Objekt an.

So öffnen Sie das Panel Properties und greifen auf die Eigenschaften eines platzierten Objekts zu:

  • Wählen Sie nach der Auswahl des Objekts das Panel Properties  über die Schaltfläche Zum Verschieben klicken und ziehen​ unten rechts im Designbereich aus, oder wählen Sie View » Panels » Properties in den Hauptmenüs.

  • Doppelklicken Sie auf das Objekt im Designbereich.

  • Klicken Sie mit der rechten Maustaste auf das Objekt und wählen Sie anschließend Item Properties im Kontextmenü.

Wenn das Panel Properties bereits aktiv ist, klicken Sie auf das Objekt, um auf dessen Eigenschaften im Panel zuzugreifen. Das Panel zeigt automatisch die Eigenschaftseinstellungen des aktuell im Designbereich ausgewählten Objekts an.

Grafische Bearbeitung

Bei dieser Bearbeitungsmethode können Sie ein platziertes Objekt direkt im Designbereich auswählen und seine Position sowie, sofern unterstützt, seine Größe und Form ändern. Das ausgewählte Objekt wird durch eines oder mehrere der folgenden Merkmale gekennzeichnet:

  • Ein oder mehrere Bearbeitungsgriffe an Ecken und/oder Endpunkten.

  • Ein blau gestrichelter Auswahlrahmen.

  • Das Objekt nimmt die blaue Auswahlfarbe an.

Nach der Auswahl können Sie folgende grafische Bearbeitungen vornehmen:

  • Objekt verschieben – Klicken Sie auf eine beliebige Stelle des Objekts und halten Sie die Maustaste gedrückt, um es an eine andere Position zu ziehen. Wenn das Objekt eine Drehung unterstützt, drücken Sie Spacebar , um es gegen den Uhrzeigersinn zu drehen, oder Shift+Spacebar für eine Drehung im Uhrzeigersinn, jeweils in Schritten von 90 Grad.

  • Objektgröße ändern – Sofern unterstützt, klicken Sie auf einen Bearbeitungsgriff/-knoten und ziehen Sie ihn, um die Größe des Objekts zu ändern. Zu den Objekten, deren Größe grafisch geändert werden kann, gehören Ansichtsobjekte, Anmerkungen und grafische Werkzeuge. Bei einer Lagenaufbaulegende und Tabellenobjekten ist eine grafische Größenänderung nicht möglich.

    Beispiel eines Bearbeitungsgriffs für eine ausgewählte Leiterplatten-Bestückungsansicht. Ziehen Sie den Griff, um den Maßstab der Ansicht zu ändern.
    Beispiel eines Bearbeitungsgriffs für eine ausgewählte Leiterplatten-Bestückungsansicht. Ziehen Sie den Griff, um den Maßstab der Ansicht zu ändern.

Ausgewählte Draftsman-Objekte können durch Drücken der Pfeiltasten um den aktuellen Rasterwert schrittweise verschoben werden. Wenn Sie dabei die Taste Shift gedrückt halten, werden die ausgewählten Objekte um den zehnfachen Rasterwert verschoben.

Weitere Informationen zu den grafischen Bearbeitungsmethoden für bestimmte Draftsman-Objekte finden Sie in der Dokumentation zu diesen Objekten.

Befehle zum Verschieben und Drehen

Objekte können auch mit den Befehlen des Pop-up-Menüs Move verschoben und gedreht werden, das Sie über die Tastenkombination M öffnen.

Wählen Sie die zu verschiebenden Objekte aus, öffnen Sie das Pop-up-Menü Move und wählen Sie anschließend den gewünschten Befehl.

Move Selection Klicken Sie nach dem Aufrufen des Befehls in den Designbereich. Bewegen Sie dann den Cursor mit der daran angehängten Auswahl und klicken Sie erneut, sobald sich die Objekte an der gewünschten Position befinden.
Move Selection By XY Nach dem Aufrufen des Befehls wird der Dialog Get X / Y Offsets geöffnet (). Geben Sie in den Feldern X Offset und Y Offset des Dialogs an, um welchen Abstand die Auswahl entlang der horizontalen Achse (X) bzw. der vertikalen Achse (Y) verschoben werden soll. Je nach gewünschter Bewegungsrichtung können positive oder negative Werte angegeben werden.
Rotate Selection Nach dem Aufrufen des Befehls wird der Dialog Rotation Angle (Degrees) geöffnet (). Geben Sie den gewünschten Angle  der Drehung zwischen 0,001° und 360,00° ein (Auflösung: 0,001°). Geben Sie einen positiven Wert für eine Drehung gegen den Uhrzeigersinn oder einen negativen Wert für eine Drehung im Uhrzeigersinn ein. Klicken Sie auf OK , um den Dialog zu schließen. Positionieren Sie anschließend den Cursor und klicken Sie, um den Bezugspunkt für die Drehung festzulegen. Die ausgewählten Objekte werden um den eingegebenen Winkel um diesen Bezugspunkt gedreht.

Kopieren und Einfügen

In Draftsman können Sie Objekte innerhalb eines Draftsman-Dokuments oder zwischen Draftsman-Dokumenten ausschneiden, kopieren und einfügen. Verwenden Sie dazu die Befehle des Hauptmenüs Edit oder die üblichen Tastenkombinationen.

Beachten Sie, dass Altium Designer für normale Kopiervorgänge in Draftsman-Dokumenten nicht die Windows-Zwischenablage verwendet. Stattdessen wird für diesen Dokumenttyp eine separate interne Zwischenablage verwaltet. Die interne Draftsman-Zwischenablage ist zudem vollständig unabhängig von den internen Zwischenablagen aller anderen Editoren in Altium Designer. Kopieren und Einfügen ist nur innerhalb von Draftsman-Dokumenten oder zwischen diesen möglich.

Mehrere Objekte bearbeiten

Das Properties-Panel unterstützt die Bearbeitung mehrerer Objekte. Beachten Sie, dass Sie über das Properties -Panel zwar keine Änderungen an different Objekttypen gleichzeitig vornehmen können, jedoch mehrere ausgewählte Objekte des same Typs gleichzeitig ändern können. Verwenden Sie die übliche Shift+Click für die Mehrfachauswahl – das Panel zeigt die Werte des zuletzt zur Auswahl hinzugefügten Objekts an.

Format übertragen

Mit der Funktion „Format übertragen“ können Sie einen vorhandenen Textstil einfach und schnell auf andere Draftsman-Textelemente übertragen.

Wählen Sie, wie im folgenden Video gezeigt, ein vorhandenes Textelement mit den gewünschten Stileigenschaften aus (wie im Properties-Panel definiert). Wählen Sie anschließend den Befehl Format Painter im Hauptmenü Edit oder im Kontextmenü des Designbereichs. Dadurch werden die Stileigenschaften des aktuell ausgewählten Textes übernommen.

Verwenden Sie den Cursor, der nun das Werkzeugsymbol für „Format übertragen“ () anzeigt, um weitere Textelemente zu suchen und auszuwählen, die diese Stileigenschaften übernehmen sollen. Zu den kompatiblen Textobjekten gehören bearbeitbare Textelemente wie Ansichtstitel, Text objekte und Notizelemente.

Textsuche

Mit dem Draftsman-Editor können Sie anhand festgelegter Suchoptionen schnell nach bestimmten Texten oder Textteilen suchen. Wählen Sie den Befehl Edit » Find Text in den Hauptmenüs oder verwenden Sie die Tastenkombination Ctrl+F, um den Dialog Find Text zu öffnen.

Der Dialog Find text
Der Dialog Find text

In diesem Dialog legen Sie den zu suchenden Text sowie den Suchbereich und weitere Optionen fest.

Zu suchender Text

Text To Find

Geben Sie in dieses Feld die Zeichenfolge ein, nach der Sie suchen möchten. Geben Sie entweder das vollständige Wort ein oder suchen Sie nach einer Teilzeichenfolge. Für Letzteres muss die Option Whole Words Only deaktiviert sein. Die Zeichenfolge kann die Platzhalterzeichen ? (ein einzelnes Zeichen) und * (eine beliebige Gruppe von Zeichen) enthalten.

Bei Platzhaltern wird die Groß-/Kleinschreibung grundsätzlich nicht berücksichtigt.

Jede gesuchte Zeichenfolge wird der Dropdown-Liste des Feldes hinzugefügt, damit sie schnell erneut aufgerufen werden kann.

Suchbereich

Sheet Scope

Mit diesem Feld legen Sie den Suchbereich hinsichtlich der einbezogenen Draftsman-Dokumente fest. Wählen Sie eine der folgenden Optionen:

  • Current Page – die aktuelle Seite durchsuchen.

  • Entire Document – das gesamte Draftsman-Dokument durchsuchen.

Selection

Mit diesem Feld können Sie den Suchbereich anhand des aktuellen Auswahlstatus der Objekte weiter einschränken. Wählen Sie eine der folgenden Optionen:

  • Selected Objects – die Suche auf die aktuell ausgewählten Objekte beschränken.

  • DeSelected Objects – die Suche auf die aktuell nicht ausgewählten Objekte beschränken.

  • All Objects – keine Einschränkung; alle Objekte unabhängig von ihrem Auswahlstatus durchsuchen.

Identifiers

Mit diesem Feld können Sie den Suchbereich anhand des Typs des textbasierten Objekts weiter einschränken. Wählen Sie eine der folgenden Optionen:

  • All Identifiers – keine Einschränkung; alle textbasierten Objekte durchsuchen (Textzeichenfolgen, Textrahmen, Pins, Netzkennungen und Bezeichner).

  • Texts – die Suche auf Text beschränken.

  • Designators Only – die Suche auf Bauteilbezeichner beschränken.

Optionen

Case sensistive Aktivieren Sie diese Option, um bei der Suche die Groß-/Kleinschreibung zu berücksichtigen. Die Groß-/Kleinschreibung des gesuchten Textes muss dann mit der des im Feld Text To Find eingegebenen Suchtextes übereinstimmen.
Whole Words Only Aktivieren Sie diese Option, um nur nach ganzen Wörtern zu suchen. Der Suchtext muss also vollständig und unverändert vorliegen und darf nicht Teil einer längeren Zeichenfolge sein. Wenn diese Option beispielsweise bei der Suche nach cat aktiviert ist, betrachtet die Software die ersten drei Buchstaben von category nicht als gültigen Suchtreffer. Deaktivieren Sie diese Option, um auch nach Teilzeichenfolgen suchen zu können.

Wenn eine Suche mehrere Treffer ergibt, wird der Dialog Find text - Jump geöffnet.

Der Dialog Find text - Jump
Der Dialog Find text - Jump

Mit den Schaltflächen  und  des Dialogs wechseln Sie zum vorherigen bzw. nächsten passenden Textelement. Während Sie zwischen den Fundstellen vor- und zurückwechseln, zeigt der obere Bereich des Dialogs den ursprünglichen Suchtext sowie den Objekttyp und den übereinstimmenden Text des aktuell im Designbereich angezeigten Elements an.

Sie können im Dokument auch zum nächsten Treffer der zuletzt im Dialog Find text festgelegten Textsuche wechseln, indem Sie den Befehl Edit » Find Next in den Hauptmenüs auswählen (Tastenkombination: F3).

DXF-Import

Draftsman bietet zusätzliche grafische Möglichkeiten durch den Import von Standard-DXF-Dateien, die über den Menübefehl File » Import from DXF in den Zeichenbereich geladen werden. Wählen Sie im Windows-Standarddialog Open eine DXF-Datei (*.dxf) aus und konfigurieren Sie anschließend die Importoptionen im sich öffnenden Dialog DXF Import Settings.

  • Wenn Sie in ein bestimmtes Blatt eines mehrseitigen Dokuments importieren möchten, stellen Sie sicher, dass dieses Blatt das aktuelle Blatt ist.

  • Die DXF-Quellgrafik wird mit den standardmäßigen grafischen Formobjekten von Draftsman interpretiert. Jedes Grundobjekt ist daher bearbeitbar. Folgende Objekttypen werden beim Import aus einer DXF-Datei unterstützt: Bogen, Kreis, Linie, Rechteck, Fläche, Text.

Die folgenden Funktionen befinden sich in der offenen Betaphase und sind verfügbar, wenn die Option Draftsman.TeighaNet im Dialog Erweiterte Einstellungen aktiviert ist.

Importing DXF File Versions R12 and Later

Sie können DXF-Dateien der Version R12 und neuer in Fertigungszeichnungsdokumente importieren (*.PCBDwf, *.HarDwf, *.MbDwf).

Importing DXF Files with Splines

DXF-Dateien, die Splines enthalten, können in ein Fertigungszeichnungsdokument importiert werden (*.PCBDwf, *.HarDwf, *.MbDwf).

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents