Managed Projects and Releasing a Design

Modified by Rob Evans on Sep 13, 2018

Parent page: More about Projects

In a nutshell, Project Management is focused on securely storing and tracking changes throughout the design process, and ultimately, channeling the resulting design through to the creation of a physical item – such as an assembled PCB to be used in the final product.  To meet these needs, Altium NEXUS provides a range of project management approaches that offer increasing levels of sophistication and capabilities, yet simplify the process from a designer's perspective.

The Altium NEXUS integration with Version Control systems (VCS) provides the primary mechanism for robust management of design data, while its tightly managed generation of Output files forms the basis for sophisticated design data release mechanisms. In their most advanced form, both the management of design data and generation of output data are centered on the capabilities of an Altium managed content server.

The VCS-based project and design document management options that are available can be summarized as follows, ordered by increasing capabilities:

  1. External VCS, managed outside Altium NEXUS
    An installed Version Control System (VCS) such as Subversion (SVN) or Git that is managed independently of Altium NEXUS by a client application such as the Tortoise interface. A designer must leave the editing environment to perform VCS operations with a separate, client application.
    See Version Control and Design Repositories for more information.
  2. Internal VCS, managed in Altium NEXUS
    The VCS applications that are built in to Altium NEXUS (Subversion and Git) are accessed through the Projects and Storage Manager panels. Altium NEXUS works directly with its internal VCS application, minimizing the need for user intervention and setup. SVN type repositories may be created from within Altium NEXUS.
    See Version Control and Design Repositories and Using Version Control for more information.
  3. An Altium managed content server hosting advanced Managed Projects
    A managed content server and its internal VCS service host Managed Projects, which offer simplified VCS operations, inherent design collaboration capabilities and Lifecycle management. Projects are managed through the server browser interface or Explorer panel, and can be accessed directly from Altium NEXUS, based on a user's server login credentials. A Managed Project is accessed from the Altium NEXUS Explorer, Projects or Storage Manager panels.
    See the Managed Projects overview, below.

Beyond the selected method used for project and document management, a board design will eventually be 'released' from the design domain to the manufacturing domains for fabrication, testing and assembly.

At its fundamental level, this involves generating a set of output files that correctly provide the information required to manufacture and populate the board design. At its most advanced level, a preconfigured and fully verified set of generated output files (including a snapshot of the design files) are Released to a managed content server as a packaged 'item' revision, which is itself under lifecycle-managed version control. See Releasing a Design, below.

Managed Projects

In conjunction with a managed content server, Altium NEXUS offers the ability to work with an advanced project construct in the form of a Managed Project. Stored in a repository within the server, a Managed Project harnesses the server's version control, lifecycle management and design collaboration capabilities to provide a refined approach to centralized design.

Thanks to the intelligence built in to the services provided by a managed content server, tasks such as VCS operations are simplified and automated, and additional design collaboration features such as user access control (sharing), commenting and notifications are integrated with Altium NEXUS. The end result is a robust and secure project storage format and location that can become the central point for collaborative project design.

The preliminary requirements for managing and working with Managed Projects are:

  1. Access to an Altium managed content server that offers suitable User accounts and appropriate access permissions.
    ► See Controlling Access to Server Content
  2. Altium NEXUS is signed in to the managed content server.
    ► See Accessing a Server from Altium NEXUS

A Managed Project can then be created through the server's browser interface or in Altium NEXUS, or an existing project may be converted to a Managed Project.

The VCS repositories hosted by a managed content server are automatically available as target repositories in Altium NEXUS, when the user has signed into that server. Connected repositories may be reviewed in the Altium NEXUS Data Management - Design Repositories page of the Preferences dialog.

Create a Managed Project

Prior to creating a new Managed Project, or converting an existing non-managed project, ensure that a Design Repository exists in which to store that project, and all future projects. Design Repositories are centrally managed as part of the Altium NEXUS Server, through its local Version Control service. A new installation of the Altium NEXUS Server provides a single Git-based design repository - Versioned Storage - for accommodating all of your managed design projects. If you have upgraded your Server from Altium NEXUS Server 1.0 (or Altium Vault 3.0), then use of SVN repositories will also be enabled, so that you can continue to use your previous (and established) design flow. In this case, you can continue to create repositories through the local Version Control service (SVN-only), or connect to external repositories (SVN or Git).

A new Managed Project is created in Altium NEXUS via the standard New Project dialog (File » New » Project), where the Managed option is selected as the Project Kind.

As with other new VCS projects, the files will be configured for version control and must then be Saved and Committed to the VCS repository – typically from the Projects panel right-click options. With a Git-based server repository, the locally committed files must be Pushed to the remote server repository. These two actions (Commit and Push) can be completed as a single step with the button in the Add to Version Control dialog.

Create a new Managed Project or convert an existing 'normal' project to one – see below.

See Creating a Managed Project through Altium design software

Via the Server's Browser Interface

Alternatively, a Managed Project can be created directly through the Projects page in the server's browser interface . Use the button to open the Add Project dialog, where the Managed Project's name, description, and target repository/folder is nominated. This automatically adds and commits the project structure in the server's VCS repository, which can be subsequently opened and added to in the Altium NEXUS design environment.

► See Creating a Managed project through the server browser interface

Convert to a Managed Project

A Managed Project can also be created by converting an existing Altium NEXUS project. To do so, right click on the project file in the Projects panel and select the Convert to Managed Project command. Note that you need to be signed in to a managed content server to access the command.

Set the Managed Project options (name, paths etc) in the Convert to managed project dialog, which is followed the Add to Version Control dialog where specific project files may be selected or deselected for addition. The  (SVN repository) or (Git repository) button will complete the final process. The local version of the project is retained as the working copy.

If an Altium NEXUS project has previously been under version control, the Convert to Managed Project process will attempt to remove/replace VCS data from the project files. This will ensure that a  new, clean (Git-based) Managed Project is created.

The newly created Managed Project can then be shared with other managed content server Team members (or user Role groups) to enable a collaborative design environment for that project.

► See Convert an existing non-managed project

Share a Managed Project

A Managed Project can be individually shared with specified Users or Group roles by setting its access permissions (including write restrictions) through the Altium NEXUS Explorer panel or via an Altium server browser interface.

In the Altium NEXUS Explorer panel, select the the desired project in the managed content server's Projects folder and then use the button to open the panel's Manage Permissions window, where server Users and Group roles can be added to grant access to the selected project.

Users and Roles are defined in the Team section of the server browser interface (Administrator rights required).

In the Server browser interface, share the desired project by selecting its Share button () in the Projects folder to open the Manage Permissions window, where Users and Group roles can be added to grant access. If the project is currently open in the browser interface (see below), use the button to access the permissions window.

Users and Roles are defined in the Team section of the server browser interface (Administrator rights required).

► See Sharing a Managed Project

Open a Managed Project

A Managed Project can be opened from the Altium NEXUS menu (File » Open Managed Project), from the Altium NEXUS Explorer panel, or from the Projects page of an Altium managed content server browser interface. In all cases the Managed Project files are checked out from the server repository to a local working folder and opened in Altium NEXUS. You must be signed in to the server, with appropriate permissions, to access its Managed Projects.

In Altium NEXUS, use the File » Open Managed Project menu command to open the Open Managed Project dialog, where a project can be selected and opened.

Above: Opening a Manged Project through the Altium NEXUS Open Managed Project command.

In the Altium NEXUS Explorer panel, select the Managed Project in the folder tree and use the button (top right) to open the project in Altium NEXUS.

Above: Opening a Manged Project through the Altium Designer Explorer panel.

In the server browser interface, open the project from the Projects list (by selecting the project's name or its  button) and then use the button to open the Managed Project in Altium NEXUS.

Above: Opening a Manged project through the server browser interface (opens in Altium Designer).

► See Opening a Managed Project

An Altium NEXUS user must be signed in to the Altium managed content server to access a Managed Project, and the project sharing permissions must set to allow access for that user – see Share a Managed Project above.

Releasing a Design

Also in conjunction with an Altium managed content server, Altium NEXUS provides an advanced approach to organizing, tracking and storing the design output files required for manufacturing a PCB design project. This employs an automated process that ‘releases’ a specific set of design output files to the server as read-only ‘Item’ revisions, which collectively corresponds to a physical entity that may be manufactured. The Item revisions created by this Project Release process are stored in the server’s version controlled repository, are lifecycle managed, and represent a manufacturable snapshot of the PCB design at the time the Release was created.

The Project Releases that follow, as the design progresses, are automatically committed as new revisions of each Item, allowing a sequence of released revisions to be created as the design changes and evolves. Previous revisions are read-only, and may be viewed or downloaded from the managed content server at any time.

A board design that is released or 'committed' to the server-based Item (as a set of lifecycle-managed Revisions) generally includes:

  • Source Data –  a time-stamped copy (snapshot) of the core project design files (Schematic, PCB and Project file, etc).
  • Fabrication Data – the data required by a Fabrication House to create the bare board (Gerber files, NC Drill files, etc)
  • Assembly Data – the data required by an Assembly House to fully populate the bare board according to a Bill of Materials, both with and without any design Variations (Pick and Place files, Assembly Drawings, BOMs, etc).
The Project Release can also be used in an offline mode, where the generated release files are created in a specified folder or ZIP archive file on the local machine. If the current project is not a Managed Project or you are not signed in to the Altium server, the Project Releaser will automatically offer the offline release mode. Read about the Project Releaser's Offline mode.

The prerequisites for releasing a PCB design to a managed content server are:

  • Altium NEXUS is signed in to the Altium server, which hosts the target repository for the release.
  • The Altium NEXUS PCB project includes suitable Output Jobs – design data output generators (for outputs such as print, file or PDF). If no OutJobs are available, the Project Releaser will offer to create suitable Fabrication and Assembly Outjobs to drive the process.
  • The project sourced by the Release process has all required elements in place – the source data is valid and up to date, the user has sufficient rights to release that project to the server, etc.

The essentials of these requirements are outlined below.

Output Jobs and Files

The fundamental method of generating design output from Altium NEXUS is through a range of available design Output Generators that produced the data files and artwork needed to create the real world version of the design – in other words, the Schematic and PCB Prints, Gerber and NC Drill fabrication files, Bill of Materials (BOM), Pick and Place Assembly files etc that are required to fabricate and assemble the PCB design.

The selected Output Generators and the specific Output files they will create for a design are collectively defined using the Output Job Editor, which saves the generator to output mapping configurations in an Output Job file (*.OutJob) – created via the File » New » Output Job File command.

An OutJob document contains output generator definitions (output jobs) that map project outputs to their host 'containers'.

Within the editor, the available Output types are arranged in functional sections (Documentation Outputs, Fabrication Outputs, etc) and are enabled by selecting a sub-type and the design document source. The selected Output is then linked to a target Output Container (such as a PDF, file, or a printer) – as shown above and below.


The Output Job Editor allows a wide range of design output generators to be targeted at output containers (files, printers, location paths etc), and the configuration saved as a OutJob project file.

As the core mechanism for collectively generating manufacturing and assembly files for a board design, Altium NEXUS Output Jobs offer the following additional capabilities:

  • Any number of OutJobs can be added to a given design, so that configurations will be available for specific tasks such as generating outputs for fabrication, assembly, archiving, procurement and documentation.
  • OutJob files are in fact portable and can be applied to any design project where a standardized set of design outputs are required. Choose 'PCB Document' as the document source option, rather than a specific design file, to create a generic (and therefore portable) Output Job.
  • OutJobs can include files for design Validation checks, such as electrical (ERC), Rule (DRC) and Footprint to source comparisons. As such, Validation output jobs are a specialized 'active' case where the design is checked and the actual output (such as a PDF document) represents the results of the validation process. 
  • OutJobs cater for variations in an assembled board design, where different sets of output files are required to manufacture alternative versions the design – such as standard or uprated versions of the product that uses additional components or different types. See Design Variants for more information on board design variations.
    Note that a Variant Choice nominated by an Output Job does not apply when the OutJob is used in the Project Release process. In that case, Variant choices are automatically detected and/or specifically nominated in the Releaser itself.


► See Preparing Multiple Outputs in an OutputJob for more information on Output Jobs.

When releasing a design to an Altium managed content server through the Project Release process (see below), the available OutJobs (such as those for Assembly and Fabrication) can be nominated for use by the Releaser. Additional Output Jobs that are included in the design project may also be added to the release setup through its Options dialog. The Release process uses the selected OutJobs to map specific sets of files and project production data to target Items (data containers) in the server's repository.

The Project Releaser

With a PCB project’s required Output Jobs created, the design is ready to be released by the Project Releaser as a manufacturable set of design data to a set of Items in the Altium managed content server. By using a sequence of checks and file generation processes, this will create a specific collection of board design data that represents a particular physical item (such as a fully assembled PCB) or set of physical items.

► See Working with the Project Releaser for more detailed information.

To access and setup the Project Releaser, open its Release view from the Altium NEXUS main menu (Project » Project Releaser) or right-click on the project name in the Projects panel and select Project Releaser.

The Project Releaser is an automated process that works through a sequence of checks and output file generation stages targeted at an Altium server, or a local folder/zip.

The Project Releaser's Release View offers an initial setup page that corresponds to the first stage of the release process sequence – Configure Vault Release. This includes a range of release data sections that represent the type of outputs that will be generated and released to the server, such as the Source data (a snapshot of the project files), Fabrication data and Assembly data.

The automated Releaser will:

  • attempt to apply suitable OutJob collections to the data assembly groups, based on the name prefix (ass, fab) of the available project OutJobs.
  • create suitable default Assembly and Fabrication OutJobs if there are no existing OutJobs in the project.
  • detect any Variants that have been defined in the active project and create suitable Assembly data sets for generating output files that relate to those variations.
  • detect the correct release mode – offline or online – based on the current conditions (server connection status, Managed or Local project type). In this instance, the Managed Peoject data will be released using online mode.

Additional 'custom' sections can be added (Add Section) to create a separate, nominated collection of output data. The initial configuration for the core data sections (or any added custom sections) can be edited, added to or reconfigured through the Project Release Options dialog, opened from the button.

The output jobs defined by a nominated OutJob document will be run (eg: Assembly), and their data collected in that target section (eg: Assembly Data).

The main Release Options include:

  • Release Target – select, or browse to and select, either an online Altium manged content server or local folder (offline mode) target for the release.
  • Output Jobs – within each listed section (Source Data, Fabrication Data etc), select which of the available OutJobs (and their constituent output generators) will be used in the release. Note that the release Sections are simply predefined data division names that can include the data generated by any selected OutJob..
  • Item Naming tab – set the name of the Items that will be created in the server, or browse to and choose (or create) an existing server Item that will be targeted by the release.
    • Settings – view or edit the base naming templates for the data Revisions that will be released to the server.

► See the Project Release Options dialog for more information.

A number of Project Release preference options (such the temporary file storage location) are available in the Data Management - Servers page of the Altium NEXUS Preferences .

Prepare the Release

When the project release has been set up as needed, instigate the Releaser's preparation process with the  button. This will trigger a series of pre-release checks such as whether the project files have been saved (and committed to VCS), and ensuring that the target locations will be accessible. During this part of the process, the Releaser will also create the release target Item Revisions in the Altium managed content server. The following processing stage will Validate the project (ERC, DRC etc) if a Validation report is included in the project OutJobs.

The final step of the preparation process will generate the data for all outputs defined by the nominated project OutJobs – this targets a local temporary location, prior to uploading that data to the server.

All data and files generated for the release can be reviewed prior to being released to the Altium server.

At this stage the generated data can be reviewed in the Release view. For the data collection of interest, select the Details link option to expand a full report of the files generated for that section, and use the Explore link to open the (temporary) folder that contains the generated files. Alternatively, use the View link to open the listed entry in its native editor/viewer.

Release to the Managed Content Server

Assuming all is well with the prepared release, the generated data can be uploaded to the managed content server release target that was initialized as part of the previous step. Use the  button to trigger that process, and confirm the action in the following Confirm Release dialog.

The completed release process will be followed by an Execution Report, which provides a release summary tree and navigation links (top) to the data collection revisions in the server.

Select a generation section link to open that released revision in the server.

View a Released Managed Project

Use the Release report's navigation links to access the released data revisions in the Altium NEXUS Explorer panel, or simply open the Explorer panel (View » Panels » Explorer) and navigate to the release target folder to access the overall release. Subsequent releases of the project will create a new set of revisions (where the revision numbering is incremented) of the those Items.

Note that the Explorer panel offers two view styles when a Managed Project has been released: the detailed Classic View or the tab-based Project View.

In the Explorer panel, navigate to the folder that was defined in the pre-release process to see the released data, in either View style

Under the Project View's Releases tab, every release of the project is presented, with the latest release at the top of the list. Each entry on the left shows a snapshot of the date/time of release, along with what packages are included in the release. Use the Search field to quickly find a specific release (very useful if you have released the project many times). With the revision selected, the following sub-tabs are presented:

  • Details - a graphical representation of how the generated data links together, all under the umbrella of the parent design project. Click a link to access that Item-Revision within the NEXUS Server, on the Explorer page of the browser interface. Also included is the date and time of the release, by whom it was released, and the VCS revision.
  • Parameters - a listing of parameters that have been defined at the project level, either within Altium NEXUS (through the Parameters tab of the Project Options dialog), or through the Server (not currently available). In addition, system-generated parameters specific to that release.
  • Preview - an interactive preview of the released design source - zoom, explore, and double-click entities in the main preview window to navigate around the released design source.
  • Part List - a simple listing of all managed components in the released design, in terms of the following information:
    • Name
    • Item ID
    • Description
    • Designator
    • Quantity
    • Revision Status

Note that the list shows all parts used in the released design, irrespective of variant assembly packages generated. In other words, the list is not filtered by variant.

When a Managed Project has been released to the server (the PROJECT), its subsequent Released data (SOURCES, FABRICATION etc) are shown as a graphic evolution in the Project View.

The above Project View and information is also available through a managed content server web browser interface – select a project entry under the Projects tab. For more information on accessing and managing project data released to a managed content server see:
Browsing Server Content
Browser-based Lifecycle Management
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.