Altium Designer Documentation

Managed Projects

Modified by Jason Howie on Oct 25, 2019
This documentation page references Altium Vault, which is no longer a supported product. Altium Vault and its component management features have migrated to Altium Concord Pro.

Parent page: Altium Concord Pro

Altium design software, in conjunction with Altium Concord Pro, brings support for Managed Projects. Managed Projects target the development stage of the project lifecycle, simplifying the creation and ongoing workflow for version controlled projects. Centralized storage under the control of Concord Pro also enables this feature to be a foundation for other collaborative services.

Some key benefits to using Managed Projects are:

  • Simplified storage. No need to make decisions about storage locations. Backup and other basic services are taken care of.
  • Foundation for collaborative features.
  • Enforced version control.
  • Beneficiary of a dedicated commenting system.
  • Notifications and status. Document status including local modifications is visible to entire design teams.
  • Concurrent PCB design works without any complex setup.

Technically a Managed Project is the combination of meta information stored on the server, along with tight integration with Altium Concord Pro's local Version Control service. The typical work flow is as follows:

  1. A user creates a new managed project (via the Create Project dialog in Altium design software such as Altium Designer, from Concord Pro's browser-based interface, or by converting an existing project in the design software). During creation, that user defines the project's name, description, and design repository.
  2. In Concord Pro's browser-based interface, or directly within the Altium design software, access to the project is defined and managed.
  3. All collaborators select the project for opening (either from within the design software, or from Concord Pro's browser interface) after which it is automatically checked out.
The advantage of Managed Projects is that they are version controlled by default, and can be collaboratively worked upon without having to worry about shared drives, servers, agreements etc.
Prior to creating a new Managed Project, or converting an existing non-managed project, ensure that a Design Repository exists in which to store that project, and all future projects. Design Repositories are centrally managed as part of the Altium Concord Pro server, through its local Version Control service. A new installation of Altium Concord Pro provides a single Git-based design repository - Versioned Storage - for accommodating all of your managed design projects. If you have upgraded your Server from Altium NEXUS Server 1.0 (or Altium Vault 3.0), then the use of SVN repositories will also be enabled, so that you can continue to use your previous (and established) design flow. In this case, you can continue to create repositories through the local Version Control service (SVN-only), or connect to external repositories (SVN or Git).

Creating a New Managed Project

There are three ways in which a Managed Project can be created:

  • Creation of a new project within Altium Designer.
  • Creation of a new project within Altium Concord Pro's browser-based interface.
  • Conversion of an existing, non-managed project from within Altium Designer.

The following sections take a closer look at these three avenues of creation.

Through Altium Designer

A new Managed Project can be created from within Altium Designer using the Create Project dialog (File » New » Project):

  1. Select the entry for your Concord Pro server from the LOCATIONS options (it will appear with the name you have specified for it, on the Admin - General page of Concord Pro's browser interface) – you must be signed in to Concord Pro to access this option.
  2. Enter a Project Name and optionally, a project Description.
The project name should start with, and can contain A-Z, a-z, or 0-9. Underscores, dashes, and spaces are allowed, but the latter can only be used within the middle of the name (leading and trailing spaces will be ignored). You can not use the following words: AUX, COM1-COM9, LPT1-LPT9, CON, NUL, and PRN. In addition, the name cannot contain the following characters: \ . / ? % * : | " < >.
  1. The Repository field will list all Design Repositories managed through Concord Pro's local Version Control service, and which have been shared with you to use. Choose the repository in which to store the new project and its files.
  2. Use the Folder field to specify where the folder for the project – within Concord Pro's folder structure – is to be created. The default path for new Concord Pro projects is specified on the Admin - Settings - Projects page of Concord Pro's browser interface.
  3. Use the Local Storage field to specify where the project will be stored on your hard drive, prior to its committal to the centralized Design Repository. The default location is defined in the System - Default Locations page of the Preferences dialog.
  4. Use the button to add parameter Name-Value pairs to the Parameters list. These Managed Project parameters are saved in the Concord Pro server with the new project, and can be edited within the server. By contrast, Project type parameters are saved in the project file (*.PrjPcb), and can be edited in Altium Designer. Both parameter types may be used as Special Strings in Altium Designer.

Setting up to create a new Managed Project from within Altium Concord Pro, courtesy of the New Project dialog. Note that only those central Design Repositories
that are shared with you will be available for selection from the Repository field.

After clicking , the new project will be created locally, in accordance with the defined Local Storage path. The project will be opened in the Projects panel, which will show the project as being Scheduled for addition, denoted by a blue cross icon ().

The project will appear in the Projects panel under an entry for the target server, reflecting the name of that server – in this case, Altium Concord Pro.

Right-click on the project in the Projects panel and choose the Commit Project command or the Version Control » Commit Whole Project command. You will be presented with the Commit to Version Control dialog. Select the files you wish to commit to the Design Repository and click Commit and Push (or Commit for a target SVN repository). Once added, the Projects panel will reflect the fully synchronized state that exists between the files in the repository and the local working copy.

Commit the newly created Managed Project to the target Design Repository.

In addition, an entry for the project will appear on the Projects page of Concord Pro's browser-based interface.

The newly-created Managed Project, evident on the Projects page.

The project will initially be shared for Read/Write access with the designer who created it, and all Administrators for the Concord Pro server. In addition, it will be shared for Read-only access publicly, meaning that all users of the Concord Pro server can view the project. For more information on configuring project access permissions, see Sharing a Managed Project.

Through Concord Pro's Browser Interface

A Managed Project can be created directly through Altium Concord Pro's browser interface:

  1. Sign in to the interface and access the Projects page. Any previously created projects will be listed here.
  2. Click the button at the top-right of the page. The Add Project pop-up window will appear.
  3. The window will initially present in simplified view. Enter the desired name for the project, a description (if required), and if available, choose from any Managed Project Templates that exist in the server.

The project name should start with, and can contain A-Z, a-z, or 0-9. Underscores, dashes, and spaces are allowed, but the latter can only be used within the middle of the name (leading and trailing spaces will be ignored). You can not use the following words: AUX, COM1-COM9, LPT1-LPT9, CON, NUL, and PRN. In addition, the name cannot contain the following characters: \ . / ? % * : | " < >.
  1. To access more controls by putting the window in advanced view, click on the Show additional fields control. The following fields will present:
    1. Server (Vault) Folder – use this field to specify where the folder for the project is to be created within Concord Pro's folder structure. By default, this will be Projects\<ProjectName>. The default folder path for new projects is specified on the Admin - Settings - Projects page of Concord Pro's browser interface.
    2. Project Type – use this field to specify the type of project from a list of all project types supported by Altium Concord Pro. If you have selected a managed project template to use, this field will not be presented.
    3. Repository – this field will list all Design Repositories managed through the server's local Version Control service, and which have been shared with you to use. Choose the repository in which to store the new project and its files. By default, the Versioned Storage (Git-based) repository will be selected.
    4. Repository Folder - use this field to specify the name of the folder within the repository in which to accommodate the project and its associated files. By default, this will take the project's name. If the Versioned Storage (Git-based) repository is chosen, this field will not be presented.

Defining a new Managed Project directly through the server's browser interface.

After defining the new project as required, click – the new project will be created. You will initially be taken to the detailed view for the project (more on this below). Click the Projects entry in the navigation tree to come back to the summary-level listing of managed projects, where you will now see an entry for your newly-created project has been added to the list.

An additional Managed Project has been created through the browser interface. Click the Projects entry in the nav tree to switch back from the detailed project view to the summary-level view.

The project will initially be shared for Read/Write access with the designer who created it, and all Administrators for the Altium Concord Pro server. In addition, it will be shared for Read-only access publicly, which means that all users of Altium Concord Pro can view the project. For more information on configuring project access permissions, see Sharing a Managed Project.

Conversion of an Existing Non-Managed Project

You can also create a Managed Project from an existing non-managed one, by converting the latter to the former. To do this, open the existing non-managed project as normal in Altium Designer, right-click on its entry in the Projects panel and then use the Convert to Managed Project command from the context menu.

If the project is currently under Version Control in a local Design Repository, it can not be converted directly. A message will alert you to this, with the option to essentially convert the project to a Regular project first – ignoring SVN revisions and changes log – and then converting that Regular project to a Managed one.

The Convert to Managed Project command opens the Convert to Managed Project dialog, which allows you to determine the project's name and its description. By default, the name will be that of the original (source) project.

Further setting are available by opening the Advanced options:

  • The target Design Repository, managed through the Altium Concord Pro server that you are currently signed into. Choose from all managed repositories shared with you, and that are defined through the server's Version Control service (on the VCS page (Admin - VCS) of the browser interface). By default, the Versioned Storage (Git-based) repository will be selected. Note that if you are converting a VCS-type project and that project already exists in an SVN design repository provided by the server, then that same repository will be used – you will not be able to choose a different one.
  • The repository path and directory are shown, where the latter is not editable when the Versioned Storage (Git-based) repository is chosen. By default a folder of the same name as the project will be created within the repository.
  • The path to the local working VCS copy of the project is also shown (Working Copy Path), as defined by the project's source location.
  • The Server Folder entry represents the target path for the new project entry within the server's folder structure. By default this will be Projects\<ProjectName> but may be edited to suit, where the Server Folder setting will also define the location in which data for the project will be released when using the Project Releaser in Altium Designer.

Convert an existing project to a Managed Project.

With the properties for the Managed Project defined as required in the Convert to Managed Project dialog, click OK. The project and files will be committed to the target Design Repository, with the Projects panel reflecting the fully synchronized state that exists between the files in the repository and the local working copy.

The newly-converted Managed Project will subsequently be available from the Projects page of Concord Pro's browser interface.

The converted project is added to the list of centrally-managed projects.

The project will initially be shared for Read/Write access with the designer who converted it, and all Concord Pro Administrators. In addition, it will be shared for Read-only access publicly, meaning that all users of the Concord Pro server can view the project. For more information on configuring project access permissions, see Sharing a Managed Project.

Browsing Managed Projects

As mentioned above, Managed Projects are available to browse from the Projects page of Concord Pro's browser interface.

The Projects page of Concord Pro's browser interface – command central for managing your managed projects.

Each project is listed in terms of the following information:

  • Name - the name of the project, along with its description (if defined).
  • Author - the user who created the project.
  • Last modified - the date on which the project was last modified.
The list of managed projects is automatically sorted by Last modified date, with the most recently modified project appearing first in the list. The list can be sorted by any of these data columns – click once within a column header to sort in ascending order, click again to sort in descending order.

For each project, the following controls are provided (and detailed in the linked sections that follow):

Open – open the project, via its detailed view.

Edit – edit the project, in terms of its Name and/or Description.

Share – access controls with which to configure project access permissions.

Remove – remove the project from the server.

Detailed Project View

Selecting the Open control () associated with a managed project or clicking on its name will give you access to a detailed view of the Project.

Accessing the detailed view for a managed project.

This view of a project can also be accessed within Altium Designer through the Explorer panel. It is the default view, available once the project has been released to Concord Pro. If you are viewing your project-related Items in the panel's Classic View, you can switch to this detailed view by clicking the button at the top-right of the panel and choosing Project View from the associated context menu.

The following tabs are available within the project detail view:

  • Parameters – a listing of parameters (as Name/Value pairs) associated with the Managed Project that are grouped under three parameter type headings:
    • Project file – parameters stored in the project file (*.PrjPCB) that can be added/modified through the Project Options dialog in Altium Designer.
    • Managed project – parameters stored in the server with the Managed Project that can be added in the Create Project dialog in Altium Designer, or added/modified by editing the project in the server's browser interface.
    • Analytics – parameter data automatically extracted by Concord Pro from the Managed Project.

The Project and Server -type parameters will be available to use as special strings in Altium Designer – access from the Properties panel with a placed Text String selected in the design workspace. Parameters defined for the project can also be viewed on the Parameters and Server Parameters tabs of the Project Options dialog (Project » Project Options).
  • Preview – an interactive graphical preview of the design source. Zoom, pan and double-click entities in the main preview window to navigate around the design.

  • Part List – a simple listing of all managed components in the design, as automatically extracted from the design source by Concord Pro. This includes the Item ID and revision status for each server component used in the design.

  • Working files – the source design files of the project, which can be downloaded in a single Zip file.

  • Releases – presents every release of the project, with the latest release at the top of the list. Each entry on the left shows a snapshot of the date/time of release, along with what packages are included in the release. Use the Search field to quickly find a specific release (very useful if you have released the project many times).

As you click on a release summary entry on the left, the following sub-tabs on the right populate with information that applies to that specific release:

A graphical representation of how the generated data links together, all under the umbrella of the parent design project for the selected release. Click a link to access that Item-Revision within the Concord Pro server, on the Explorer page of the browser interface. Also included is the date and time of the release, by whom it was released, and the VCS revision.

A listing of parameter data that apply to the selected release, including system-generated parameters and any Project or Server parameters that have been defined.

An interactive graphic preview of the released design source, where all design files are available for selection in the Navigator tree.

A simple listing of all managed components in the released design, including the server item identifier (ItemID) and revision status for each of the components hosted in the Concord Pro server.

Note that the list shows all parts used in the released design, irrespective of variant assembly packages generated in the release. In other words, the list is not filtered by variant. This is not intended to be a replacement for a BOM - use the ActiveBOM for that as you normally would.

The currently selected release can be downloaded by clicking the control, to the far right of the tab. The Download Configuration pop-up will appear, with which to specify what data you wish to include in the download (e.g. source, fabrication and any assembly packages).

Configure the packages to be included in a download of the currently selected release of the managed project.

Once you have configured the download as required using the available check boxes, click the button. A master zip file will be downloaded to your browser's default downloads folder (named according to the format: SRC-<ProjectName>-<ReleaseRevision>(<IncludedPackages>).zip, for example SRC-Bluetooth_Sentinel-A.2(fab,src,pcba).zip. This contains individual zip files of the packages selected for download.

  • Stream - sequential even data detailing recent activity for the project.

Project Functions

A number of additional controls are also available for the presented project:

  • VCS Location - the URL to the project inside its parent design repository. For a project stored in an SVN-based design repository, click this link to open that design repository, in which the project resides, in your external SVN client browser.
  • – click this button to open the project within Altium Designer (by opening the X2.exe file). If the design software is already running, the project will be opened in that instance.
  • menu – select this menu to expose the additional functions for a released project, which include:
    • Edit – select to access the Edit Project window. From here, you can change the project's Name, Description and any applied server Parameters. All other fields are non-editable, providing information only.
    • Share – select to access the Manage Permissions window, with all the controls necessary to share the project with other users. See Sharing a Managed Project for more information.
    • Clone – select to access the Clone Project window, providing the controls to make an identical copy of the project. See Cloning a Managed Project for more information.
    • Watch – select to follow the project. You will receive applicable notifications related to the project (e.g. updated, released, permission changes) on the project's Stream tab, as well as the main Home and Stream pages of the browser interface. The creator of the project will automatically be set to watch that project. Select the option again to stop following the project and receiving notifications.
    • Remove –select to remove the project from the repository, rendering it no longer managed. If you have checked out the project locally, you will still have this local working copy.

Project Data Update

When a project has been externally updated, say after being edited in Altium design software and the changes committed back to Concord Pro, the server will automatically re-process the project data to update detailed information such as Parameter Analytics and the extracted Parts List.

After a substantial project update has been committed to the server, the project's detailed view may include a progress warning as the data is updated. Once complete, the message will request a page refresh to display the new data – click the offered refresh link or press F5 to update the page.

Sharing a Managed Project

Once a project is managed, you'll want to determine which users can actually access that project. This is done by sharing the project, or rather, by configuring its access permissions. Remember that a managed project – newly created or converted – is shared, by default, with the following:

  • The designer who created (converted) the project: full (Read/Write) access permissions.
  • The Administrators role group: full (Read/Write) access permissions.
  • Publicly – denoted by the presence of the Public entity: with Read-only access permissions.

Configuration of access permissions can be performed through Concord Pro's browser interface, and also directly from within Altium Designer.

From within the Server's Browser Interface

To configure access for a project from Concord Pro's browser interface, from the Projects page of the interface click on the project's associated Share control ().

Also available by clicking the button, from the detailed Project view.

The Manage Permissions window will appear, with all the controls necessary to share the project with other users.

With projects centrally managed in a Concord Pro server, sharing with others is simply a case of managing each project's permissions.

Things to be aware of:

  • In terms of permissions, a User or Group has Read/Write access when the Can Write option is enabled. If this option is disabled, they have Read access only.
  • To remove an existing user/group from having shared access to a project, click the associated Remove control ().
  • All users of the Concord Pro server will by default be able to see the project. If you want to lock access down to a specific set of users and/or group roles, you must remove the Public entity.
  • If you remove the Public entity, it can be added back again using the Add Public control. Be aware that doing so will, by default, grant Read/Write access of the project to all Concord Pro users.

To share a project with another Concord Pro user:

  1. Click the Add User control in the Manage Permissions window.

  1. In the Add Users window that appears, start typing the full name, username, or email address of a Concord Pro user in the Select Users to be added field, to pop-up a list of matching users. Select the required user from this list. Multiple users can be chosen. To remove a user, click the delete cross, to the right of their name.

  1. Set the permission for the user(s) using the Permission field. Use the drop-down to choose between Read access, or Read/Write access.

  1. Click the button once ready, to effect addition of the user(s) and return to the Manage Permissions window.

  1. Click the button in the Manage Permissions window.
To edit the permissions for an existing user, use the Can Write checkbox option in the Manage Permissions window to toggle between Read/Write access (enabled) or Read-only access (disabled).

You also have the ability to share with role Groups defined for your Concord Pro server. To share a project with another group:

  1. Click the Add Group control in the Manage Permissions window.

  1. In the Add Groups window that appears, start typing the name of a group in the Select Groups to be added field, to pop-up a list of matching role groups. Select the required group from this list. Multiple groups can be chosen. To remove a group, click the delete cross, to the right of its name.

  1. Set the permission for the group(s) using the Permission field. Use the drop-down to choose between Read access, or Read/Write access.

  1. Click the button once ready, to effect addition of the group(s) and return to the Manage Permissions window.

  1. Click the button in the Manage Permissions window.
To edit the permissions for an existing role group, use the Can Write checkbox option in the Manage Permissions window to toggle between Read/Write access (enabled) or Read-only access (disabled).

From within Altium Designer

Access for a project can be configured directly from within Altium Designer by using the Project Permissions command. This command can be accessed for the active project, or a focused project:

  • Active project – with a source document for the project open as the active document, choose the Project » Project Permissions command from the main menus.
  • Focused project – access is made from the Projects panel by right-clicking on the entry for the required project and choosing the Project Permissions command from the context menu.

The Permissions For - <ProjectName> dialog will open in which you can configure sharing as required. User the dialog's Add menu to select the type of sharing you wish to apply (by User, Role etc) and then choose desired entity in the following Search for User/Role dialog.

Configure access to your Managed Project directly from within Altium Designer.

Opening a Managed Project

To work on a managed project, you effectively check it out as a local working copy. This can be performed in two ways:

  • Directly from within Altium Designer – use the File » Open Project command. The Open Project dialog will appear, from where you can choose which managed project to open from Altium Concord Pro. Only those Managed Projects that have been shared with you (you have permission to access) will be listed, and from across all managed Design Repositories shared with you.

Choose which managed project to open, from within Altium Designer, from those currently shared with you.

You have the option to open the project to the default checkout path, or use the  drop down menu to specify a custom path. The default checkout path is taken from the Document Path field on the System - Default Locations page of the Preferences dialog.
  • From the Projects page of Concord Pro's browser interface – click the Open control () associated with the project. From the detailed view for the project that is presented, click the button.
The browser's project open command, instigated by the button, will open the Altium design software by accessing its underlying executable – x2.exe. The selected project will open in the running instance of the software or launch its last used instance.

Access the control to open a managed project from its detailed view within Concord Pro's browser interface.

Editing a Managed Project

To edit the properties of a Managed Project at a later stage, click its associated Edit control ().

Also available by selecting the Edit option from the menu in the detailed Project view.

The Edit Project window will appear. From here, you can change the project's Name, Description and server Parameters. All other fields are non-editable, providing information only.

You can edit the Name, Description and Parameters for a Managed Project at any stage.

Cloning a Managed Project

To clone an existing managed project, access its detailed Project view and then select the Clone option from the menu. The Clone Project window will appear.

You can clone a managed project to create an identical copy of it, along with its working files.

Use the window to set the naming, description and storage paths for the cloned project. By default, the original project name will be used with the suffix ' - Copy'.

The cloned project will be made in the same design repository as the original – you cannot change this as part of the cloning process.

After setting the fields as required, click the button – the original project will be cloned, and the clone opened within the interface at the Parameters tab of its detailed Project view.

Removing a Managed Project

To remove a Managed Project, click its associated Remove control () in the Projects page listing.

Alternatively, in the detailed Project view of the project select the Remove option from the menu.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Concord Pro Free Trial

Please Complete the form below to get Free Trial of Altium Concord Pro